Cisco Nexus 1000V VXLAN Configuration Guide, Release 4.2(1)SV2(2.1a)
Configuring Advanced Features
Downloads: This chapterpdf (PDF - 1.26MB) The complete bookPDF (PDF - 2.75MB) | The complete bookePub (ePub - 316.0KB) | Feedback

Configuring Advanced Features

Configuring Advanced Features

This chapter contains the following sections:

VXLAN trunk is used to configure ports that can individually map a .1Q tag value to a VXLAN. Ports receive the packets with the .1Q tag and are used in mapping the packet into a VXLAN. You can use the VXLAN trunk feature to support network service VMs which need access to more VXLANs than the number of VNICs VMware supports on a VM.

Configuring VXLAN Trunks

You can trunk multiple VXLANs on a single vEthernet interface.

Procedure
     Command or ActionPurpose
    Step 1switch# configure terminal 

    Enters global configuration mode.

     
    Step 2 switch(config )# port-profile type vethernet name 

    Enters port profile configuration mode for the named port profile. If the port profile does not already exist, it is created using the following characteristics:

    • name—The port profile name can be up to 80 characters and must be unique for each port profile on the Cisco Nexus 1000V.
    • type—(Optional) The port profile type can be Ethernet or vEthernet.
     
    Step 3 switch(config -port-profile)# switchport access bridge-domain name-string 

    Assigns a VXLAN bridge domain to this profile for non-dot1q traffic.

     
    Step 4 switch(config -port-profile)# [no] service instance 1 to 4096 

    Defines a place holder for mappings. The range is from 1 to 4096.

     
    Step 5 switch(config -port-profile)# [no] encapsulation dot1q 1-4094 bridge-domain name  

    Creates mappings. The range is from 1 to 4094.

     

    This example shows how to configure a VXLAN trunk:

    switch# configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    switch(config)# port-profile type vethernet csr-access
    switch(config-port-prof)# switchport mode access 
    switch(config-port-prof)# switchport access bridge-domain bd-701
    switch(config-port-prof)# service instance 10
    switch(config-port-prof-srv)# encapsulation dot1q 600 bridge-domain bd-600
    switch(config-port-prof-srv)# encapsulation dot1q 601 bridge-domain bd-601
    switch(config-port-prof-srv)# encapsulation dot1q 602 bridge-domain bd-602
    switch(config-port-prof-srv)# no shutdown 
    cswitch(config-port-prof-srv)# state enabled 
    switch(config-port-prof)# end
    
    switch# show run port-profile csr-access
    port-profile type vethernet csr-access
      switchport mode access
      switchport access bridge-domain bd-701
      service instance 10
        encapsulation dot1q 600 bridge-domain bd-600
        encapsulation dot1q 601 bridge-domain bd-601
        encapsulation dot1q 602 bridge-domain bd-602
      state enabled
    

    This example shows how to display VXLAN trunk interface mappings:

    switch(config-bd)# show bridge-domain mappings 
    
    -------------------------------------------------------------------------------
    Interface      Service Instance ID      Module ID    Vlan ID      Segment ID   
    -------------------------------------------------------------------------------
    Vethernet2                 10            3            600            5000         
    Vethernet2                 10            3            601            5001        
    Vethernet2                 10            3            602            5002         
    
    switch(config-bd)#
    

    Note


    The value in the Interface column varies based on the VXLAN gateway or the VXLAN trunk feature. Vethernet<number> in the Interface column indicates mapping for the VXLAN trunk feature; port-channel<number> in the Interface column indicates mapping configured on the VXLAN gateway.


    Configuring Multi-MAC Capability

    You can mark a virtual Ethernet interface as capable of sourcing packets from multiple MAC addresses.

    Before You Begin

    Do not use the multi-MAC capability feature if MAC distribution (segment distribution MAC) is enabled.

    Procedure
       Command or ActionPurpose
      Step 1switch# configure terminal 

      Enters global configuration mode.

       
      Step 2 switch(config )# port-profile type vethernet name  

      Enters port profile configuration mode for the named port profile. If the port profile does not already exist, it is created using the following characteristics:

      • name—The port profile name can be up to 80 characters and must be unique for each port profile on the Cisco Nexus 1000V.
      • type—(Optional) The port profile type can be Ethernet or vEthernet.
       
      Step 3 Switch(config )# [no] capability multi- mac  

      Marks the vEthernet port as multi-MAC capable.

       

      This example shows how to configure the multi-MAC capability feature:

      switch# configure terminal 
      Enter configuration commands, one per line.  End with CNTL/Z.
      switch(config-port-prof)# port-profile type vethernet csr-multi-mac-access
      switch(config-port-prof)# switchport mode access 
      switch(config-port-prof)# switchport access bridge-domain bd-701
      switch(config-port-prof)# capability multi-mac 
      switch(config-port-prof)# state enabled 
      switch(config-port-prof)# no shutdown 
      switch(config-port-prof)# end 
      
      switch# show running-config port-profile csr-multi-mac-access
      port-profile type vethernet csr-multi-mac-access
        switchport mode access
        switchport access bridge-domain bd-701
        capability multi-mac
        no shutdown
        state enabled