Cisco Nexus 1000V System Management Configuration Guide, Release 4.2(1)SV1(4b)
Managing the Configuration
Downloads: This chapterpdf (PDF - 172.0KB) The complete bookPDF (PDF - 4.06MB) | Feedback

Table Of Contents

Managing the Configuration

Information About Configuration Management

Changing the Switch Name

Configuring a Message of the Day

Verifying the Configuration

Verifying the Software and Hardware Versions

Verifying the Running Configuration

Comparing the Startup and Running Configurations

Verifying the Interface Configuration

Verifying a Brief Version of an Interface Configuration

Verifying a Detailed Version of an Interface Configuration

Verifying a Brief Version of all Interfaces

Verifying the Running Configuration for all Interfaces

Saving a Configuration

Erasing a Configuration

Feature History for Configuration Management


Managing the Configuration


This chapter includes the following topics:

Information About Configuration Management

Changing the Switch Name

Configuring a Message of the Day

Verifying the Configuration

Saving a Configuration

Erasing a Configuration

Feature History for Configuration Management

Information About Configuration Management

The Cisco Nexus 1000V provides you with the capabiliyt to change the switch name, configure messages of the day, and display, save, and erase configuration files.

Changing the Switch Name

Use this procedure to change the switch name or prompt from the default (switch#) to another character string.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in configuration mode.

If the VSM is connected to vCenter Server then this procedure also changes the DVS the VSM is managing.In case of error in renaming the DVS, a syslog is generated and the DVS on vCenter Server will continue using the old DVS name.

DETAILED STEPS

 
Command
Purpose

Step 1 

switchname

Example: 

n1000v(config)# switchname metro

metro(config)# exit

metro#

Changes the switch prompt.

Configuring a Message of the Day

Use this procedure to configure a message of the day (MOTD) to display before the login prompt on the terminal when a user logs in.

BEFORE YOU BEGIN

Before beginning this procedure, you must know or do the following:

You are logged in to the CLI in configuration mode.

The banner message can be up to 40 lines with up to 80 characters per line.

Use the following guidelines when choosing your delimiting character:

Do not use the delimiting-character in the message string.

Do not use " and % as delimiters.

The following tokens can be used in the the message of the day:

$(hostname) displays the host name for the switch.

$(line) displays the vty or tty line or name.

DETAILED STEPS

 
Command
Purpose

Step 1 

banner motd [delimiting-character message delimiting-character]

Example: 
n1000v(config)# banner motd #April 16, 2008 
Welcome to the svs#
n1000v(config)# 

Configures a banner message of the day.

up to 40 lines

up to 80 characters per line

enclosed in delimiting character, such as #

can span multiple lines

can use tokens

Step 2 

show banner motd

Example: 
n1000v(config)# show banner motd
April 16, 2008 Welcome to the Switch

Displays the configured banner message.

Verifying the Configuration

Use this section to view the switch configuration. This section includes the following topics:

Verifying the Software and Hardware Versions

Verifying the Running Configuration

Comparing the Startup and Running Configurations

Verifying the Interface Configuration

Verifying the Software and Hardware Versions

Use this command to view the versions of software and hardware on your system, for example, to verify the version before and after an upgrade.

BEFORE YOU BEGIN

Before using this command, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

show version

 
      
Example:

n1000v# show version

Displays the versions of system software and hardware that are currently running on the switch,

Example:
n1000v# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2009, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
 
 
Software
  loader:    version 1.2(2)
  kickstart: version 4.0(4)SV1(1)
  system:    version 4.0(4)SV1(1)
  kickstart image file is:
  kickstart compile time:  4/2/2009 23:00:00
  system image file is:    bootflash:/svs.bin
  system compile time:     4/2/2009 23:00:00 [04/23/2009 09:55:29]
 
 
 
 
Hardware
  Cisco Nexus 1000V Chassis ("Virtual Supervisor Module")
  Intel(R) Xeon(R) CPU         with 1034780 kB of memory.
  Processor Board ID T5056893321
 
 
  Device name: n1000v
  bootflash:    3897832 kB
 
 
Kernel uptime is 0 day(s), 0 hour(s), 2 minute(s), 55 second(s)
 
 
 
 
plugin
  Core Plugin, Ethernet Plugin

Verifying the Running Configuration

Use this section to view the configuration currently running on the system.

BEFORE YOU BEGIN

Before using this command, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

show running-config

 
      
Example:
n1000v# show running-config 
Displays the versions of system software and hardware that are currently running on the switch,

Example:
n1000v# show running-config
version 4.0(4)SV1(1)
username admin password 5 $1$ouYE/pRM$/j4/2lg3RMd4PhE.1Z1S.0  role network-admin
telnet server enable
ip domain-lookup
ip host n1000v 172.23.232.141
kernel core target 0.0.0.0
kernel core limit 1
system default switchport
vem 3
  host vmware id 89130a67-e66b-3e57-ad25-547750bcfc7e
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0 priv 
0xb64ad6879970f0e57600c443287a79f0 localizedkey
snmp-server enable traps license
vrf context management
  ip route 0.0.0.0/0 172.23.232.1
switchname n1000v
vlan 1,260-269
vdc n1000v id 1
  limit-resource vlan minimum 16 maximum 513
  limit-resource monitor-session minimum 0 maximum 64
  limit-resource vrf minimum 16 maximum 8192
  limit-resource port-channel minimum 0 maximum 256
  limit-resource u4route-mem minimum 32 maximum 80
  limit-resource u6route-mem minimum 16 maximum 48
port-profile Unused_Or_Quarantine_Uplink
  description "Port-group created for Nexus1000V internal usage. Do not use."
  capability uplink
  vmware port-group
  shutdown
  state enabled
port-profile Unused_Or_Quarantine_Veth
  description "Port-group created for Nexus1000V internal usage. Do not use."
  vmware port-group
  shutdown
  state enabled
port-profile system-uplink
  capability uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 260-261
  no shutdown
  system vlan 260-261
  state enabled
port-profile vm-uplink
  capability uplink
  vmware port-group
  switchport mode access
  switchport access vlan 262
  no shutdown
  state enabled
port-profile data262
  vmware port-group
  switchport access vlan 262
  no shutdown
  state enabled
 
 
interface Ethernet3/2
  inherit port-profile system-uplink
 
 
interface Ethernet3/3
  inherit port-profile vm-uplink
 
 
interface mgmt0
  ip address 172.23.232.141/24
 
 
interface control0
line vty
  session-limit 32
boot kickstart bootflash:/kick.bin sup-1
boot system bootflash:/svs.bin sup-1
boot kickstart bootflash:/kick.bin sup-2
boot system bootflash:/svs.bin sup-2
svs-domain
  domain id 141
  control vlan 260
  packet vlan 261
  svs mode L2
svs connection vc
  protocol vmware-vim
  remote hostname 172.23.231.201
  vmware dvs uuid "2c 6f 3d 50 62 f3 7f 4d-dc 00 70 e2 52 77 ca 15" datacenter-name 
HamiltonDC
  connect
 
 
n1000v# 
 
 

Comparing the Startup and Running Configurations

Use this procedure to view the difference between the startup and running configurations.

BEFORE YOU BEGIN

Before using this command, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

show running-config diff

 
      
Example:
n1000v# show running-config diff

Displays the difference between the startup configuration and the running configuration currently on the switch.

Example 5-1 Command output, show running-config diff

n1000v# show running-config diff
*** Startup-config
--- Running-config
***************
*** 1,7 ****
  version 4.0(1)
- system mem-thresholds minor 0 severe 0 critical 0
  vrf context management
    ip route 0.0.0.0/0 10.78.1.1
  switchname DCOS-112-S10
  vlan 80,110-111,150,160,170
  vdc DCOS-112-S10 id 1
--- 1,6 ----
***************
*** 116,131 ****
    ip address 10.78.1.112/24
  interface Vethernet49
    inherit port-profile vlan160
- interface Vethernet65
-   inherit port-profile vlan170
  interface Vethernet50
    inherit port-profile vlan160
  interface Vethernet66
    inherit port-profile vlan170
  ip route 0.0.0.0/0 10.78.1.1
  vlan 80-80, 110-110, 111-111, 150-150, 160-160, 170-170
  
--- 115,130 ----
    ip address 10.78.1.112/24
  
  interface Vethernet49
    inherit port-profile vlan160
  
  interface Vethernet50
    inherit port-profile vlan160
  
+ interface Vethernet65
+   inherit port-profile vlan170
+ 
  interface Vethernet66
    inherit port-profile vlan170
  ip route 0.0.0.0/0 10.78.1.1
  vlan 80-80, 110-110, 111-111, 150-150, 160-160, 170-170
  
n1000v# 

Verifying the Interface Configuration

This section includes the following procedures:

Verifying a Brief Version of an Interface Configuration

Verifying a Detailed Version of an Interface Configuration

Verifying a Brief Version of all Interfaces

Verifying the Running Configuration for all Interfaces

For more information about displaying interfaces, see the document,
Cisco Nexus 1000V Interface Configuration Guide, Release 4.2(1)SV1(4a)

Verifying a Brief Version of an Interface Configuration

Use this procedure to view a brief version of an interface configuration.

BEFORE YOU BEGIN

Before using this procedure, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

show interface {type} {name} brief

Displays a brief version of information about the specified interface configuration,

Example:
n1000v# show interface mgmt 0 brief
 
 
--------------------------------------------------------------------------------
Port   VRF          Status IP Address                              Speed    MTU
--------------------------------------------------------------------------------
mgmt0  --           up     10.78.1.63                              1000     1500
n1000v# 
 
 

Verifying a Detailed Version of an Interface Configuration

Use this procedure to view a detailed version of an interface configuration.

BEFORE YOU BEGIN

Before using the commands in this section, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

show interface {type} {name}

Displays details about the specified interface configuration,

Example:
n1000v# show interface mgmt 0
mgmt0 is up
  Hardware: Ethernet, address: 0050.5689.3321 (bia 0050.5689.3321)
  Internet Address is 172.23.232.141/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  full-duplex, 1000 Mb/s
  Auto-Negotiation is turned on
    4961 packets input, 511995 bytes
    0 multicast frames, 0 compressed
    0 input errors, 0 frame, 0 overrun, 0 fifo
    245 packets output, 35853 bytes
    0 underrun, 0 output errors, 0 collisions
    0 fifo, 0 carrier errors
 
 
n1000v# 

Verifying a Brief Version of all Interfaces

Use this procedure to view a brief version of all interfaces configured on your system.

BEFORE YOU BEGIN

Before usingthis procedure, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

show interface brief

Displays a brief version of all interface configurations on your system,

Example:
n1000v# show interface brief
 
 
--------------------------------------------------------------------------------
Port     VRF          Status IP Address                     Speed    MTU
--------------------------------------------------------------------------------
mgmt0     --           up     172.23.232.141                 1000     1500
 
 
--------------------------------------------------------------------------------
Ethernet      VLAN   Type Mode   Status  Reason                   Speed     Port
Interface                                                                   Ch #
--------------------------------------------------------------------------------
Eth3/2        1      eth  trunk  up      none                       1000(D) --
Eth3/3        262    eth  access up      none                     1000(D) --
--------------------------------------------------------------------------------
Interface     VLAN   Type Mode   Status  Reason                   MTU
--------------------------------------------------------------------------------
Veth81        630    virt access up      none                     1500 
Veth82        630    virt access up      none                     1500 
Veth224       631    virt access up      none                     1500 
Veth225       1      virt access nonPcpt nonParticipating         1500 
n1000v# 
 
 

Verifying the Running Configuration for all Interfaces

Use this procedure to view the running configuration for all interfaces on your system.

BEFORE YOU BEGIN

Before using this procedure, you must know or do the following:

You are logged in to the CLI in any command mode.

The output for the command, show running-config interface differs from that of the command, show interface.

DETAILED STEPS

 
Command
Description

Step 1 

show running-config interface

Displays the running configuration for all interfaces on your system,

Example:
n1000v# show running-config interface
version 4.0(1)
 
 
interface Ethernet3/2
  switchport
  inherit port-profile sftrunk
 
 
interface Ethernet3/6
  switchport
  inherit port-profile vmuplink
 
 
interface Ethernet6/2
  switchport
  inherit port-profile alluplink
 
 
interface mgmt0
  ip address 10.78.1.63/24
 
 
interface Vethernet81
  inherit port-profile vm630
 
 
interface Vethernet82
  inherit port-profile vm630
 
 
interface Vethernet224
  inherit port-profile vm631
 
 
interface Vethernet225
 
 
n1000v# 
 
 

Saving a Configuration

Use this procedure to save the running configuration to the startup configuration so that your changes are retained in the configuration file the next time you start the system.

BEFORE YOU BEGIN

Before using this command, you must know or do the following:

You are logged in to the CLI in any command mode.

DETAILED STEPS

 
Command
Description

Step 1 

copy running-config startup-config

Saves the new configuration into nonvolatile storage, after which the running and the startup copies of the configuration are identical.

Example:
n1000v(config)# copy run start
[########################################] 100%
n1000v(config)# 

Erasing a Configuration

Use this procedure to erase a startup configuration.

BEFORE YOU BEGIN

Before using this command, you must know or do the following:


Caution The write erase command erases the entire startup configuration with the exception of loader functions, the license configuration, and the certificate extension configuration.

You are logged in to the CLI.

The following parameters are used with this command:

boot: Erases the boot variables and the mgmt0 IP configuration.

debug: Erases the debug configuration.

DETAILED STEPS

 
Command
Description

Step 1 

write erase [boot | debug]

The existing startup configuration is completely erased and all settings revert to their factory defaults.

The running configuration is not affected.

Feature History for Configuration Management

This section provides the configuration managementfeature release history.

Feature Name
Releases
Feature Information

Configuration Management

4.0(4)SV1(1)

This feature was introduced.