Cisco MDS 9000 Family Data Mobility Manager Configuration Guide
Getting Started
Downloads: This chapterpdf (PDF - 340.0KB) The complete bookPDF (PDF - 5.3MB) | Feedback

Getting Started

Table Of Contents

Getting Started

Installing Cisco MDS DMM Software

Using DMM Software Licenses

Deployment Guidelines

DMM Management Installation and Configuration Tools

DMM CLI

DMM GUI (Fabric Manager)

Installing Fabric Manager

Configuring SSH on the Switch

Configuring IP Connectivity

Configuring IP Connectivity for SSM and MSM-18/4 Modules

Configuring IP Connectivity for MDS 9222i Switches

Enabling the DMM Feature

Enabling DMM with the CLI

Enabling DMM with Fabric Manager

Configuring Migration Rate

Configuring Migration Rate Using the CLI

Configuring Migration Rate Using Fabric Manager


Getting Started


This chapter describes how to install and configure the Cisco MDS DMM software. The required tasks are described in the following sections:

Installing Cisco MDS DMM Software

Using DMM Software Licenses

Deployment Guidelines

DMM Management Installation and Configuration Tools

Configuring IP Connectivity

Enabling the DMM Feature

Configuring Migration Rate

Installing Cisco MDS DMM Software

The Cisco MDS DMM feature runs on the SSM, the MSM-18/4, or the MDS 9222i switch.

The DMM software package is included in the SSI image as a part of the SAN-OS or NX-OS.

For information on how to install the SSM, MSM-18/4 module, or MDS 9222i switch image, refer to Cisco MDS 9000 Family Storage Services Module Software Installation and Upgrade Guide.

Using DMM Software Licenses

Table 2-1 lists the Cisco DMM licenses that are available.

Table 2-1 Cisco DMM Licenses 

Part Number
Description
Applicable Product

M95DMM184K9

Cisco Data Mobility Manager (DMM) permanent license for MSM-18/4 module

MDS 9500 Series with MSM-18/4 module

M95DMM184TSK9

Cisco Data Mobility Manager (DMM) time-based license for MSM-18/4 module (for 180 days)

MDS 9500 Series with MSM-18/4 module

M92DMM184K9

Cisco Data Mobility Manager (DMM) permanent license for MSM-18/4 module

MDS 9200 Series with MSM-18/4 module

M92DMM184TSK9

Cisco Data Mobility Manager (DMM) time-based license for MSM-18/4 module (for 180 days)

MDS 9200 Series with MSM-18/4 module

M9222iDMMK9

Cisco Data Mobility Manager (DMM) permanent license for fixed slot

MDS 9222i switch only

M9222IDMMTSK9

Cisco Data Mobility Manager (DMM) time-based license (for 180 days) for fixed slot

MDS 9222i switch only

M95DMMS1K9

Cisco Data Mobility (DMM) permanent license for one SSM, MSM-18/4 module, or MDS 9222i switch

MDS 9500 Series with SSM, MSM-18/4 module, or MDS 9222i switch

M95DMMTS1K9

Cisco Data Mobility (DMM) time-based license for one SSM, MSM-18/4 module, or MDS 9222i switch (for 180 days)

MDS 9500 Series with SSM, MSM-18/4 module, or MDS 9222i switch

M92DMMS1K9

Cisco Data Mobility (DMM) permanent license for one SSM, MSM-18/4 module, or MDS 9222i switch

MDS 9200 Series with SSM, MSM-18/4 module, or MDS 9222i switch

M92DMMTS1K9

Cisco Data Mobility (DMM) time-based license for one SSM, MSM-18/4 module, or MDS 9222i switch (for 180 days)

MDS 9200 Series with SSM, MSM-18/4 module, or MDS 9222i switch



Note You can use the Cisco MDS 9000 Family DMM software without a license for a period of 120 days.


You may purchase a DMM license for an SSM, MSM-18/4 module, or MDS 9222i switch in a fabric that does not have a Fabric Manager license. In this configuration, you can open multiple fabrics in Fabric Manager and use the DMM functionality. Full Fabric Manager functionality is not available. For example, performance manager, desktop client remote login, and web client fabric reporting are not available without an Fabric Manager license.


Note If the DMM license for an SSM, MSM-18/4 module, or MDS 9222i switch expires, all scheduled and in-progress jobs will continue to execute. You cannot create new jobs with an expired license.


For more information about installing or upgrading software licenses, refer to Cisco MDS 9000 Family NX-OS Licensing Guide.

Deployment Guidelines

When planning and configuring data migration using Cisco MDS DMM, follow these deployment guidelines:

The SSM, MSM-18/4 module, or MDS 9222i switch should be installed in the same MDS switch as the existing storage and the new storage should be connected to the same switch. Data migration causes increased inter-switch link (ISL) traffic if the existing storage or new storage devices are connected to different switches than the SSM, MSM-18/4 module, or MDS 9222i switch.

MDS DMM supports 16 simultaneous jobs on each SSM, MSM-18/4 module, or MDS 9222i switch.

The same initiator and target port pair should not be added into more than one migration job simultaneously.

When using multipath ports, the server must not send simultaneous I/O write requests to the same LUN from both multipath ports. The first I/O request must be acknowledged as completed before initiating the second I/O request.

DMM is not compatible with LUN zoning.

DMM is not compatible with inter-VSAN routing (IVR). The server and storage ports must be included in the same VSAN.

DMM is not compatible with SAN device virtualization (SDV). The server and storage ports cannot be virtual devices, or physical devices associated with a virtual device.

For assistance on DMM and FC/IP write acceleration, contact Cisco support.

DMM does not support migration to a smaller destination LUN.

DMM Management Installation and Configuration Tools

Cisco MDS DMM supports a CLI tool and a GUI tool for configuring and managing data migrations. The tools are described in these sections:

DMM CLI

DMM GUI (Fabric Manager)

DMM CLI

The Cisco MDS DMM feature uses the CLI on the MDS switch and on the SSM, MSM-18/4 module, or MDS 9222i switch.

No DMM-specific tasks are required to install or configure the CLI.

DMM GUI (Fabric Manager)

The Cisco MDS 9000 Fabric Manager, a Java-based GUI, manages Cisco MDS 9000 Family switches using SNMP. The GUI for the Cisco MDS DMM is integrated into Fabric Manager.

To use the DMM GUI, complete the following tasks:

Installing Fabric Manager

Configuring SSH on the Switch

Installing Fabric Manager

The DMM GUI software is bundled into the Fabric Manager software package.

For information about installing Fabric Manager software, refer to the Cisco Fabric Manager Fundamentals Configuration Guide.

Configuring SSH on the Switch

The DMM GUI communicates with the SSM, MSM-18/4 module, or MDS 9222i switch using a secure shell protocol (SSH) connection. Before using DMM, you need to enable SSH on the switch that hosts the SSM, MSM-18/4 module, or MDS 9222i switch.

For information about configuring SSH, see the SSH chapter of the Cisco Fabric Manager Security Configuration Guide and the Cisco MDS 9000 Family NX-OS Security Configuration Guide.

Configuring IP Connectivity

This section covers the configuration of IP connectivity for the following modules

Configuring IP Connectivity for SSM and MSM-18/4 Modules

Configuring IP Connectivity for MDS 9222i Switches

Configuring IP Connectivity for SSM and MSM-18/4 Modules

The SSM and the MSM-18/4 modules and the supervisor module in an MDS switch communicate over VSAN 1 using IP. You need to configure an IP subnetwork for VSAN 1 on the MDS switch.

SSMs and MSM-18/4s communicate with their peer SSMs and MSM-18/4s using the management IP network (See Figure 2-1). Each DMM-enabled SSM or MSM-18/4 on the management IP network must have a unique subnetwork address configured for VSAN 1.

Configuring IP over Fibre Channel (IPFC) for an SSM or a MSM-18/4 consists of the following tasks:

Create the VSAN 1 interface and configure an IP address for this interface.

The IP subnet can use a private address space because these addresses will not be advertised. As noted, the subnet number needs to be unique for each SSM-enabled or MSM-18/4 enabled MDS switch that is connected to the same management IP subnetwork.

Create a CPP interface (with an IP address) on each SSM or MSM-18/4 on the switch.

CPP IP addresses needs to be in the same subnet as the VSAN 1 interface.

Configure zoning.

The CPP interfaces and the VSAN 1 interface need to be zoned together.

Enable IPv4 routing.

Configure the default gateway for each CPP interface.

Configure the default-gateway for the CPP interface to point to the VSAN 1 IP address, so that all IP traffic from the CPP interface is routed to the management interface.


Note Starting from Release 4.2(1) the default-gateway for the CPP interface can be configured on the Fabric Manager. For more information, refer to the Cisco Fabric Manager IP Services Configuration Guide.


Configure static routes as required to access the peer SSMs or MSM-18/4s.

Configure static routes in the switch to each SSM-enabled or MSM-18/4 enabled peer switch to enable routing of packets between peer SSMs or MSM-18/4s.

Figure 2-1 IP Configuration

The following example is based on the configuration and subnetwork numbers shown in Figure 2-1. The example shows the configuration for MDS switch 1:

Create VSAN 1 and configure it with an IP address:

switch# configure terminal
switch(config)# interface vsan 1
switch(config-if)# ip address 10.10.1.1 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit

Create the CPP IPFC interface, and configure an IP address:

switch(config)# interface cpp 8/1/1
switch(config-if)# ip address 10.10.1.6 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit

Configure a new zone to include the pWWN of the CPP interface on the SSM or MSM-18/4 and the VSAN 1 interface on the supervisor:

switch(config)# zone name DMM_IP_MGMT vsan 1 
switch(config-zone)# member pwwn 22:00:00:20:37:39:15:09
switch(config-zone)# member pwwn 21:00:00:e0:8b:05:76:28
switch(config-zone)# exit

The zone created for the IPFC interfaces must be added to the existing zone set in VSAN 1 and the zone set must be re-activated to include the new zone. If a zone set does not exist in VSAN 1, create a zone set. Add the zone to the zone set and activate the zone set.

For additional information about creating and activating zone set, refer to the Cisco Fabric Manager Security Configuration Guide and the Cisco MDS 9000 Family NX-OS Security Configuration Guide.

Enable IPv4 routing:

switch(config)# ip routing

Configure the default gateway for the SSMs or MSM-18/4s:

switch(config)# ip default-gateway 10.10.1.1 interface cpp 8/1/1

Configure static route to access the peer SSMs or MSM-18/4s:

switch(config)# ip route 10.10.2.0 255.255.255.0 172.22.43.95

You can also create a host specific route to point to the IPFC interface on the peer:

ip route 10.10.2.1 255.255.255.255 172.22.43.95

The following example shows the configuration for MDS switch 2 (see Figure 2-1):

switch# configure terminal
switch(config)# interface vsan 1
switch(config-if)# ip address 10.10.2.1 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit

switch(config)# interface cpp 4/1/1
switch(config-if)# ip address 10.10.2.7 255.255.255.0
switch(config-if)# no shutdown
switch(config-if)# exit

switch(config)# zone name DMM_IP_MGMT vsan 1 
switch(config-zone)# member pwwn 22:00:00:20:25:19:25:11
switch(config-zone)# member pwwn 21:00:00:c0:7d:76:04:15
switch(config-zone)# exit

switch(config)# ip routing

switch(config)# ip default-gateway 10.10.2.1 interface cpp 4/1/1

switch(config)# ip route 10.10.1.1 255.255.255.0 172.22.43.94

For additional information about configuring IPFC, refer to the Cisco Fabric Manager IP Services Configuration Guide and the Cisco MDS 9000 Family NX-OS IP Services Configuration Guide.

Configuring IP Connectivity for MDS 9222i Switches

Configuring IP over Fibre Channel (IPFC) for an MDS 9222i switch (without an SSM or MSM-18/4 module in slot 2) includes the following tasks:

Create the VSAN 1 interface and configure an IP address for this interface.

switch# configure terminal
switch(config)# interface vsan 1
switch(config-if)# no shutdown
switch(config-if)# ip address 10.1.1.1 255.255.255.0
switch(config-if)# exit

A CPP IPFC interface does not need to be created for this module.

Use the show interface command to verify if the VSAN 1 interface is online.

switch# show interface vsan 1
vsan1 is up, line protocol is up
WWPN is 10:00:00:0d:ec:39:08:01, FCID is 0x33000d
Internet address is 10.1.1.1/24

A VSAN is online only if there is atleast one other device logged into the VSAN.

If VSAN 1 does not have any other devices except the VSAN 1 interface, VSAN 1 will be offline and following outputs are displayed for the show and ping commands.

switch# show interface vsan 1
vsan1 is up, line protocol is down (port down)
WWPN is 10:00:00:0d:ec:4a:ba:01, FCID not assigned
Internet address is 10.1.3.1/24
MTU 1500 bytes, BW 1000000 Kbit
0 packets input, 0 bytes, 0 errors, 0 multicast
0 packets output, 0 bytes, 0 errors, 0 dropped 
switch# show fcns database vsan 1 
There are no entries in the database

switch# show flogi database vsan 1
No flogi sessions found.
switch# ping 10.1.3.1
interface is down

To bring VSAN 1 to the online status, configure another device to log into VSAN 1.

switch# configure terminal
switch(config)# vsan database
switch(config-vsan-db)# interface fc1/4
switch(config-if)# terminal monitor
switch(config-if)# no shutdown

Use the show interface and ping commands to view the status and the information of VSAN 1.

switch# show interface vsan 1
vsan1 is up, line protocol is up
WWPN is 10:00:00:0d:ec:4a:ba:01, FCID is 0x1e0003
Internet address is 10.1.3.1/24
MTU 1500 bytes, BW 1000000 Kbit
0 packets input, 0 bytes, 0 errors, 0 multicast
6 packets output, 384 bytes, 0 errors, 0 dropped 

switch# ping 10.1.3.1
PING 10.1.3.1 (10.1.3.1) 56(84) bytes of data.
64 bytes from 10.1.3.1: icmp_seq=1 ttl=64 time=0.075 ms
64 bytes from 10.1.3.1: icmp_seq=2 ttl=64 time=0.073 ms

Enabling the DMM Feature

You can use the CLI or the Fabric Manager GUI to enable the DMM feature. The two methods are described in the following sections:

Enabling DMM with the CLI

Enabling DMM with Fabric Manager

Enabling DMM with the CLI

To enable DMM on an SSM, MSM-18/4 module, or MDS 9222i switch and to provision ports to use the DMM feature, follow these steps:

 
Command
Purpose

Step 1 

switch# configure terminal

Enters configuration mode.

Step 2 

switch(config)# ssm enable feature dmm module slot

Enables DMM on the SSM, MSM-18/4 module, or MDS 9222i switch in the specified slot.

switch(config)# no ssm enable feature dmm module slot

Disables DMM on the SSM, MSM-18/4 module, or MDS 9222i switch in the specified slot.

Step 3 

switch(config)# ssm enable feature dmm interface slot/port - port

Enables DMM for the interface in the specified slot and port range.

Enabling DMM with Fabric Manager

To enable DMM for SSM, MSM-18/4 module, or MDS 9222i switch using Fabric Manager, and to provision ports to use the DMM service, follow these steps:


Step 1 Expand End Devices and then double-click the Intelligent Features folder in the Physical Attributes pane.

Choose an SSM or MSM to provision DMM.

a. For SSM, click the SSM tab.

You see the set of configured services in the Information pane as shown in Figure 2-2.

Figure 2-2 SSM Tab

b. For MSM, click the MSM tab.

You see the set of configured services in the Information pane as shown in Figure 2-3.

Figure 2-3 MSM Tab

Step 2 Click the Create Row icon (third button in the tool bar, directly above the SSM or the MSM tab).

You see the Create SSM dialog box shown in Figure 2-4.

Figure 2-4 Create SSM Dialog Box

Step 3 Select the switch and SSM module where you want to enable DMM.

Step 4 The Use All Ports on Module check box is checked by default. DMM does not support provisioning a subset of the ports on the card to use this service.

Step 5 From the feature drop-down list, select dmm.

Step 6 Click Create to enable the DMM service.

Configuring Migration Rate

When a migration job is created, you can configure the migration rate as fast, medium, or slow. Use the CLI or the Fabric Manager GUI to configure the values for these rates, as described in the following sections:

Configuring Migration Rate Using the CLI

Configuring Migration Rate Using Fabric Manager

Configuring Migration Rate Using the CLI

To configure the values associated with the fast, medium, and slow migration rates, follow this step:

 
Command
Purpose

Step 1 

switch# config t

Enters the configuration mode.

Step 2 

switch(config)# dmm module module-id rate_of_migration fast rate medium rate slow rate


Sets the migration rate for the specified SSM, MSM-18/4 module, or MDS 9222i switch. The migration rate has a range of 1 to 200 and the units are megabytes per second (MB/s).

The default values for migration rate are as follows:

Slow: 10 MB/s

Medium: 25 MB/s

Fast: 60 MB/s

The following example sets the fast migration rate to 100 MB/s for the SSM in slot 4:

switch(config)# dmm module 4 rate_of_migration fast 100 medium 25 slow 10

Configuring Migration Rate Using Fabric Manager

To configure the values to associate with the fast, medium, and slow migration rates, follow these steps:


Step 1 Expand End Devices and then double-click the Intelligent Features folder in the Physical Attributes pane.

You see the SSM or MSM services in the Information pane.

Step 2 Click the DMM Rate tab.

You see the set of configured services in the Information pane as shown in Figure 2-5.

Figure 2-5 Configuring Migration Rate

Step 3 Click in the table cell that you are configuring (Fast, Medium, or Slow).

Step 4 Enter the new value for the migration rate. The units are MB/s.

Step 5 Click the Save button to save the configuration values.



Note While configuring DMM with two hosts accessing the same storage port on a per-job basis, the rate limit that gets applied will be the lower configured rate because the configured rate is the total bandwidth per existing storage port and not per job. Hosts with active sessions will have this bandwidth shared between them.