Guest

Cisco 1000 Series Connected Grid Routers

Cisco Connected Grid Cellular 3G Module for CGR1000 Series Installation and Configuration Guide

  • Viewing Options

  • PDF (1.7 MB)
  • Feedback
Cisco Connected Grid 3G Module Installation and Configuration Guide

Table Of Contents

Cisco Connected Grid 3G Module Installation and Configuration Guide

Tell Us What You Think

Kit Contents

Features

Hardware Overview

Front Panel

Ports and LEDs

Supported Cisco Antennas

Supported Cisco Cables

Interfaces

Radio Frequency Interface

Environmental Specifications

Power Specifications

Modem

GSM

CDMA

GSM Module SIM Interface

Voltage Monitoring State Machine

Temperature Monitoring State Machine

Data Rates

Memory Specifications

Module Power States

Installing and Removing the SIM Card (GSM Module)

Preventing Electrostatic Discharge Damage

Installing the SIM Card (GSM Module)

Removing the SIM Card (GSM Module)

Installing and Removing the 3G Module

Before You Begin Installation

Installation Warning Statements

Installing the 3G Module

Removing the Module

Regulatory and Compliance Information

3G Overview

Configuring the Module

Prerequisites

Configuration Restrictions

Configuring the GSM Module

Step 1: Creating a GSM Profile

Step 2: Configuring a Chat Script

Step 3: Configuring Dialer Parameters

Step 4: Configuring Cellular Parameters

Step 5: Saving Configuration

Disabling GSM Configuration

Configuring the CDMA Module

Configuration of the CDMA Hostname and Password

Step 1: Configuring a Chat Script

Step 2: Configuring Dialer Parameters

Step 3: Configuring PPP Encapsulation

Step 4: Configuring Cellular Parameters

Step 5: Saving Configuration

show Commands

show cellular 3/1 all (GSM Module)

show cellular 3/1 all (CDMA Module)

Data Account Provisioning

Verifying Signal Strength and Service Availability

Activating the Module Using OTASP (CDMA Module)

GSM Cellular Interface Configuration

Disabling GSM Dialer Persistent

CDMA Cellular Interface Configuration

Configuring WAN Backhaul Redundancy

Configuration Example

Upgrading to a New Software Release and Firmware

Additional References

Hardware Overview and Installation Documents

Supported Cisco Antennas and Accessories Documents

Cisco System Software Commands Documents

Regulatory, Compliance, and Safety Information

Troubleshooting and Diagnostics

Debug Commands

Checking Signal Strength

Verifying Service Availability (GSM Module)

Verifying Service Availability (CDMA Module)

Successful Call Setup (GSM Module)

Successful Call Setup (CDMA Module)

Debug Output (GSM Module)

Debug Output (CDMA Module)

Retrieving the Electronic Serial Number

GSM Module Sample Output

CDMA Module Sample Output

Converting Hexadecimal ESN to Decimal Notation

Technical Assistance


Cisco Connected Grid 3G Module Installation and Configuration Guide


Last Updated: April 2013
Part Number: OL-25991-03

Tell Us What You Think

 

Send your feedback about this document directly to the Connected Energy Documentation Team.

Connected Energy Documentation Feedback Form


This document provides an overview of hardware and configuration information for the following single-wide grid router WAN interface card modules:

Cisco Connected Grid Module—3G EVDO Rev A/0/1xRTT (CDMA version)

Cisco Connected Grid Module—3G HSPA+/UMTS/GSM/GPRS/EDGE (GSM version)

These 3rd Generation (3G) technology modules are supported on Cisco 1240 Connected Grid Router. This document contains the following topics:

Kit Contents

Features

Hardware Overview

Installing and Removing the SIM Card (GSM Module)

Installing and Removing the 3G Module

Regulatory and Compliance Information

3G Overview

Configuring the Module

Configuration Example

Additional References

Troubleshooting and Diagnostics

Technical Assistance


Warning Only trained and qualified personnel should be allowed to install, replace, or service this equipment. Statement 1030

Note The Cisco Connected Grid 3G Module is a field-replaceable unit.


Figure 1 Cisco Connected Grid 2G/3G Wireless Connected Grid Module

1

CGM-3G-HSPA-A and CGM-3G-HSPA-G

2

CGM-3G-HSPA-AB-G (all band)


Kit Contents

Your 3G module kit contains the GSM or CDMA module. Refer to the information shown in Table 1 when ordering parts.

Table 1 Kit Contents for the 3G Module

Cisco Part Number
Mode
Description
Region
Frequency Band

CGM-3G-HSPA-AB-G (all band)

GSM/HSPA+

All bands (MC8705), Connected Grid Module - 3G (All band) HSPA+/UMTS/ GSM/EDGE

Canada, Europe, Australia, South America, other

GSM/GPRS/EDGE: 850/900/1800/1900 MHz

UMTS(WCDMA)/HSPA+:
850/900/1900/2100 MHz


For system requirements, important notes, limitations, open and resolved bugs, and last-minute documentation updates, see the Release Notes on Cisco.com. For translations of the warnings that appear in this document, see the Regulatory Compliance and Safety Information document for your router on Cisco.com.

When using the online publications, see the documents that match the Cisco system software version running on the 2G/3G wireless module.

Features

Cisco Connected Grid 3G Modules offer the following features:

Table 2 Feature Information for 3G modules

3G GSM Module
3G CDMA Module

MC8705 PCI Express Mini Card wireless data modem:

GSM data connectivity

GSM SIM-card interface

Supports 850 MHz, 1800 MHz, and 1900 MHz frequencies

PCI Express chip-set interface

Input/output hub component for embedded applications

MC5728V PCI Express Mini Card wireless data modem:

CDMA data connectivity

1xEVDO data connectivity (full-mini and half-mini)

Supports 800 MHz, 850 MHz, 900 MHz, 1900 MHz, and 2100 MHz frequencies

PCI Express chip-set interface

Input/output hub component for embedded applications

Support for the following technologies:

High Speed Packet Access (HSPA and HSPA+)

High-speed Downlink Packet Access (HSDPA)

High-speed Uplink Packet Access (HSUPA)

Universal Mobile Telecommunication System (UMTS)

Enhanced Data-Rates for GSM Evolution (EDGE)

General Packet Radio Service (GPRS)

Support for the following technologies:

EVDO Rev. A

EVDO Rel. 0

1xRTT


The Cisco Connected Grid 3G GSM and CDMA modules share the following key features:

Supported by Cisco CG-OS system software

Supported on the Cisco 1240 Connected Grid Router and the Cisco 1120 Connected Grid Router

Supports Cisco system software

Provides the primary cellular WAN connection for critical data applications in supporting the Connected Grid Router

WAN connectivity as a backup data link for critical data applications

SIM plug-in SIM card—ISO 7816 compliant, (U)SAT commands, USIM, 3G phone book, flash memory 8/6/128-1024 MB

The 3G module provides the following functionality:

Broadband WAN connectivity using high-speed cellular data technology

Automatic best-network selection

Always-on capability

Multiple antenna and cable options:

Diversity antenna

Indoor and outdoor external antennas

Radio Frequency Low loss coaxial cable

Dynamic IP addressing

Cellular modem upgrade over wireless link—Enables you to upgrade the firmware on the modem by using Cisco commands

Modem management—Enables you to access modem software and hardware information, radio and network status, and data profile information by using Cisco commands

Auto-detect—3G WAN for fixed and modular routers automatically detects and uses the best available service

Profile Configuration—Enables you to configure the Access-Point Name (APN) profile.

3G wireless WAN for fixed and modular routers support on Cisco Connected Grid Router 1000 Series platforms

Hardware Overview

The 3G modules are wireless modules with a mini-card cellular modem (PCI-e mini-card form factor). The 3G module comes in two types of technologies: GSM and CDMA. This document describes both types.

The module connects to the host router board of the CGR 1120 or CGR1240.

This section covers the following topics:

Front Panel

Ports and LEDs

Supported Cisco Antennas

Supported Cisco Cables

Interfaces

Radio Frequency Interface

Environmental Specifications

Power Specifications

Modem

GSM Module SIM Interface

Voltage Monitoring State Machine

Temperature Monitoring State Machine

Data Rates

Memory Specifications

Module Power States

Front Panel

The front panel of the 3G module has the following components:

Auxiliary port—QMA connector for the antenna for RX diversity antenna. (The connector is not used for GPS because the GPS of the host router is used.)

QMA connector for antenna—transmits and receives RF.

Mini-USB port—Can be used as a diagnostic port.

LEDs:

Wireless WAN (WWAN)

Received Signal Strength Indication (RSSI)

Service (SVC1 and SVC2)

SIM0 and SIM1

Figure 2 shows the front panel components of the 3G module.

Figure 2 Front Panel of the 3G module

1

Captive screws (2)

2

Auxiliary port—QMA connector for antenna for RX diversity antenna. (Connector is not used for GPS since the GPS of host router is used).

3

Main port—QMA connector for antenna—transmits and receives RF.

4

SIM card slots—Only SIM card slot x is currently supported by software.

5

RSVD—Mini-USB port (can be diagnostic port).

6

LEDs—WWAN, RSSI, SVC1, SVC2, SIM0, and SIM1.


Ports and LEDs

Figure 3 shows the LEDs of the Cisco Connected Grid 3G Module.

Figure 3 2G/3G Connected Grid Module LEDs

1

WWAN LED

2

RSSI LED

3

SVC LED

4

GPS LED (not used)

5

SIM0 LED

6

SIM1 LED


Table 3 lists the ports and the LED indicators and describes their behavior. The LEDs provide a visual indication of the available services.

Table 3 LED Definitions

Port or LED Name
Color
Description

WWAN

Green

Indicates the modem status. Driven by the modem, not under software control except for diagnostic purposes. Functionality may be changed by configuring modem.

Off: Module not powered

On: Module is powered on and connected but not transmitting or receiving

Slow blink: Module is powered on and searching for connection

Fast blink: Module is transmitting or receiving.

For information on modem settings, see Modem.

RSSI

Bi-color, green/amber

Indicates the level of signal strength received by the software:

Off: RSSI < = -110

Solid amber: -110 < RSSI <= -90

Fast green blink: -90 < RSSI <= -75

Slow green blink: -75 < RSSI <= -60

Solid green: RSSI > -60

SVC

Bi-color, green/amber

Service LED indicates the following:


Supported Cisco Antennas

The antenna is connected to the QMA, panel-mount, 50-ohm connector located on the faceplate of the module. The modem mini-card antenna connector is a U.FL, 50-ohm, with a short 50-ohm coaxial cable to the QMA connector.


Note The antennas have either N or TNC connectors (not QMA connectors). This means that either an adapter (ANT-4G-SR-OUT-TNC) or lightning arrestor (omni or panel) is required.


For more information about antennas, including installation procedures, see Connected Grid Antennas Installation Guide.

Table 4 lists the Cisco antennas that are supported for use with the 3G module and the Cisco 1120 Connected Grid Router.

Table 4 CGR 1120—Supported Antennas and Cables for Use With the 3G module

Cisco 1120 Connected Grid Router
Case Description
Indoor Cable
Lightning Arrestor
Outdoor Cable
Antenna

Case 1: 2G/3G Connected Grid Module, 10', 15' or 20' cable through conduit or building entry panel passthrough, Stick Omni or Directional Flat Panel antenna, 2 QMA(f) on faceplate

RA-QMA(m) to N(m), LMR-240-DB, 10', qty 2

CAB-L240-10-QMA-N

None

Same cable as indoor cable, that is, a single cable runs from inside to outside, through conduit.

4G omni stick, N(f), qty 2

ANT-4G-OMNI-OUT-N

RA-QMA(m) to N(m), LMR-240-DB, 15', qty 2

CAB-L240-15-QMA-N

3G, 806-960 MHz, 1710-2170 MHz, flat panel antenna, 10/11 dBi, qty 1

ANT-4G-PNL-OUT-N

RA-QMA(m) to N(m), LMR-240-DB, 20', qty 2

CAB-L240-20-QMA-N

Case 2: 2G/3G Connected Grid Module, Indoor Cable, Lightning Arrestor, Outdoor Cable, Stick Omni or Directional Flat Panel antenna, 2 QMA(f) on faceplate

RA-QMA(m) to N(m), LMR-240-DB, 10', qty 2

CAB-L240-10-QMA-N

Lightning Arrestor, N(f)-N(f), qty 2

CGR-LA-N-N

RA-N(m) to N(m), LMR-400-DB, 20', qty 2

CAB-L400-20-N-N

4G omni stick, N(f), qty 2

ANT-4G-OMNI-OUT-N

RA-N(m)-N(m), LMR-600-DB, 30'

CAB-L600-30-N-N

3G, 806-960 MHz, 1710-2170 MHz, flat panel antenna, 10/11 dBi, qty 2

ANT-4G-PNL-OUT-N

Case 3. 2G/3G Connected Grid Module, Low Profile Antenna with Integrated 15" coax cable, Mounted to top of Utility Cabinet Roof, 2 QMA(f) on faceplate

None

Connector Adaptor, QMA(m)-TNC(f), qty 2

ANT-ADPTR-Q-TNC

None

4G Low Profile, Integrated, 15' LMR-195 cable with TNC(m), qty 2

ANT-4G-SR-OUT-TNC


(f) denotes female connector
(m) denotes male connector

Table 5 lists the Cisco antennas that are supported for use with the 3G module and the Cisco 1240 Connected Grid Router.

Table 5 CGR 1240—Supported Antennas and Cables for Use With the 3G Module


Supported Cisco Cables

Table 6 lists insertion loss information and operating frequency levels for the Ultra-Low-Loss (ULL) LMR cables, and LMR 400 cables available from Cisco for use with the 2G/3G Connected Grid module.

You can use the RG-174/U type cables to adapt the modem external antenna connection to any of the modules cables and antennas.

Table 6 Cisco Extension Cable Assemblies for 3G Module

Cisco Product Number
Cable Length
Maximum Insertion Loss
Frequency (MHz)

CAB-L240-10-Q-N

10 ft (3.1 m)

1.3 dB max. at 2000 MHz

700 to 2700 MHz

CAB-L240-15-Q-N

15 ft (4.6 m)

1.9 dB max. at 2000 MHz

700 to 2700 MHz

CAB-L240-20-Q-N

20 ft (6.1 m)

2.5 dB max. at 2000 MHz

700 to 2700 MHz

CAB-L400-20-Q-N

20 ft (6.1 m)

1.4 dB max. at 2000 MHz

700 to 2700 MHz

CAB-L400-30-Q-N

30 ft (9.1 m)

1.4 dB max. at 2000 MHz

700 to 2700 MHz


Interfaces

The module includes the following physical interfaces to the host:

Power—Supplied to the module by the host

Wireless disable—As described in the PCI-Express Mini Card specification

LED output—As described in the PCI-Express Mini Card specification

Antenna—QMA (f) RF connector for the Rx/Tx path.

USIM—Supported through the interface connector. The USIM cavity/connector needs to be placed on the host device for this feature

USB—Only communication interface to the host for data, control, and status information

Radio Frequency Interface

The Radio Frequency (RF) interface consists of two QMA connectors on the faceplate labeled MAIN and AUX. The main antenna is mandatory; it both transmits and receives RF. The second AUX QMA connector is for the RX Diversity.

Environmental Specifications

Table 7 lists the environmental specifications for the 3G module.

Table 7 Module Environmental Specifications

Environmental—Operational
Specifications

Operating temperature

-13°F to 140°F (-25°C to 60°C)

Altitude

Up to 1500 meters

Humidity

RH95% non condensed

Vibration

1.0 g from 1.0 to 150 Hz

Shock

30 G half sine 6 ms and 11 ms

Seismic

GR63-Core, Zone 4


Power Specifications

There are two switching DC-DC power supplies on the Cisco Connected Grid 2G/3G Wireless Connected Grid Module. The module 12V-to-3.3V DC-DC switcher and modem 12V-to-3.3V DC-DC switcher can both be power margined through CLI commands.


Note Power cables are self-shielded; no additional shielding is required.


The 2G/3G Connected Grid module has a 12V power rail and 3.3V stand-by power provided by the host system. It has two 3.3V DC-DC converters on the 12V power rail: one for the module and the other for the modem.

Table 8 Power Specifications  

Power Source
Description

12V power rail

Max 1A (based on current draw from 2 DC-DC converters below)

3.3V modem

Peak current 3.75A, average power: 3W (based on average current of ~0.8A)

3.3V module

Peak current 500mA typical: 200mA (for LEDs and integrated circuitry)

3.3V standby

Peak current 500mA (for quack2/temp sensor)


Modem

GSM

The MC8705 PCI Express mini-card modem provides EDGE, GPRS, GSM, WCDMA, HSDPA, HSUPA, and HSPA+ wireless radio connectivity technologies over the following frequency bands:

Table 9


MC8705 includes an RF connector jack for use with host antennas (it does not have integrated antennas) which is used for the main Rx/Tx path.

The MC8705 modem supports the following GSM features:

Cellular packet data profile

Traditional modem COM port support for CSD and AT commands (concurrent with NDIS)

Suspend/resume

SIM application tool kit with proactive SIM commands

Static and Dynamic IP address. The network may assign a fixed IP address or dynamically assign one using DHCP (Dynamic Host Configuration Protocol).

CDMA

The MC5728V PCI Express Mini Card modem provides voice, features, and CDMA and 1xEVDO wireless radio connectivity technologies with dual-band diversity radio supporting the following frequency bands:

800 MHz cellular

1900 MHz PCS

MC5728V includes two RF connector jacks for use with host antennas. (It does not have integrated antennas.) One connector is used for the main Rx/Tx path.

MC5728V supports the following RF features:

Dual-band for 800 MHz cellular and 1.9 GHz PCS bands

Diversity support for the 800 MHz cellular and 1.9 GHz PCS bands

CDMA authentication as specified in CDMA 1X

IS-95A/B and CDMA 1X Release 0/A

IS-856 1xEVDO Revision A

The MC5728V Mini Card supports communication with the host through the USB. The USB interface can be dynamically configured to operate in one of two modes:

Non-MUX mode

MUX mode

The MC5728V Mini Card supports three logical interfaces:

Data channel—Supports AT command and Point-to-Point (PPP) packet exchange during data calls

Control channel—Supports modem control and status, call processing, and event notification

Diagnostic channel—Supports the QUALCOMM Diagnostic Monitoring protocol used by support tools

GSM Module SIM Interface

The GSM module has two GSM (Global System for Mobile Communications) SIM card sockets for storing critical subscriber authentication information. The SIM card can be installed in either of the two available sockets accessible on the front panel of the 3G module. Only one slot is active at any given time—if both slots SIM0 and SIM1 are occupied by a card, then the system activates SIM0. This behavior cannot be reconfigured.

The SIM card stores critical GSM subscriber authentication information.

The two SIM cards are powered by the modem and operate at 5 MHz.

The SIM card is a 3.3 V device, and it has 2.8 V power applied to its power pin.

Through the software you can control which SIM is connected to the modem. Only one SIM can be connected to the modem at any time. The SIM switching circuit also provides the option of disconnecting both SIMs from the modem. The 3G Debug and SIM Control register controls the SIM connections.

By setting the SIM Socket Enable and the SIM Socket Select bit, you can control the signal and power connections from the modem to the SIM card.

Table 10 shows the options used to connect to SIM0 and SIM1 cards:

Table 10 Options to Connect to the SIM Sockets

SIM Socket Enable
SIM Socket Select
State

0

No SIM connected

1

0

SIM0 connected

1

1

SIM1 connected


For information on installing and removing the SIM card, see Installing and Removing the SIM Card (GSM Module).

Voltage Monitoring State Machine

A state machine in the 3G module monitors the VCC supply and the voltage conditions that trigger state changes.

Temperature Monitoring State Machine

The state machine in the Cisco Connected Grid 2G/3G Wireless Connected Grid Module monitors the embedded module temperature.

Data Rates

The actual throughput rates depend on many different factors, but the theoretical rates for the technologies follows:

Table 11 GSM and CDMA Data Rates

GSM
CDMA

 

 


Memory Specifications

The memory specifications of the module are listed in Table 12.

Table 12 Memory Specifications for the 3G Module

Memory Type
Minimum
Maximum

DDR2 SDRAM

1Gb (128 Mb)

NA (1Gb is sufficient for the Linux SDK design and modem firmware upgrade)

DDR2 SDRAM for fixed platforms

512 Mb (384 Mb for IOS and 128 Mb for the Linux)


Module Power States

The module has the following power states:

Normal mode (default mode)—Module is active. Receive and Transmit modes are possible. In this state:

The module is fully powered

The module is capable of placing/receiving calls or establishing data connections on the wireless network

The USB interface is fully active


Note The module unit defaults to the Normal state when VCC is first applied.


Low power mode (airplane mode)—The module is active, but RF is disabled. In this state, RF (both Rx and Tx) is disabled on the module, but the USB interface is still active. This state is controlled though the host interface by the following software commands:

+CFUN=0 command (AT Command Set for User Equipment (UE) (Release 6))

CDMA module: CNS_RADIO_POWER [0x1075] (CDMA CnS Reference (Document 2130754))

GSM module: CNS_RADIO_POWER [0x1075] (MC87XX Modem CnS Reference (Document 2130602))

Disable Modem command (MC87XX Modem CnS Reference (Document 2130602))


Note The module goes from normal mode into low-power mode to suspend RF activity. This occurs when the module's supply voltage exceeds either the high or low limits. The module returns to normal mode to resume RF activity. It occurs when the module's supply voltage returns from critical to normal limits.


Disconnected mode—No power to the module. The host power source is disconnected from the module and all voltages associated with the module are at 0 V.

CGR 1120 and CGR 1240 control the power to the module, therefore the host can stay powered on and cut the power in order to put the module into the disconnected state.

The module begins a shutdown sequence and powers off if it has been in a powered-on state for more than 10.5 seconds and the host device drives the W_Disable# signal low for:

MC8775/MC8775V: >/= 50 ms

Other devices: >/= 500 ms

Installing and Removing the SIM Card (GSM Module)

For more information on the SIM interface, see GSM Module SIM Interface.


Note You must reload the system after installing or changing the SIM card.


Preventing Electrostatic Discharge Damage

Electrostatic Discharge (ESD) damage can occur when electronic cards or components are handled improperly, which can result in complete or intermittent failures.

To prevent ESD damage:

Always use an ESD wrist or ankle strap and ensure that it makes good skin contact.

Connect the equipment end of the strap to an unfinished chassis surface.

Place a removed compact SIM card on an antistatic surface or in a static shielding bag. If the card will be returned to the factory, immediately place it in a static shielding bag.

Avoid contact between the card and clothing. The wrist strap protects the card from ESD voltages on the body only; ESD voltages on clothing can still cause damage.

Do not remove the wrist strap until the installation is complete.


Warning Only trained and qualified personnel should be allowed to install, replace, or service this equipment.
Statement 1030

Caution For safety, periodically check the resistance value of the antistatic strap. The measurement should be between 1 and 10 megohms (Mohms).

Installing the SIM Card (GSM Module)

To install the SIM card:


Step 1 Using a Phillips-head screwdriver, loosen the screw that secures the SIM slot cover in place. Rotate the cover downward so it exposes the SIM slot.

Step 2 Insert the SIM card with the key (notch) positioned on the right-hand side. The SIM card will come in contact with the metal contacts in the socket.

Figure 4 Installing the SIM Card

Step 3 Firmly insert the card until it clicks into place.

Step 4 Rotate the cover back in place and secure it by tightening the screw.


Removing the SIM Card (GSM Module)

To remove the SIM card, open the cover and press the card to eject it. Remove the card and replace the cover.

Installing and Removing the 3G Module

Some Cisco Connected Grid 2G/3G Wireless Connected Grid Modules are installed into the host router at the factory.

Before You Begin Installation

Before installing the module, verify that the following guidelines have been met:

Clearance to the I/O-side view is such that the LEDs can be easily read.

Cabling is away from sources of electrical noise, such as radios, power lines, and fluorescent lighting fixtures. Make sure that the cabling is away from other devices that might damage the cables.

Airflow around the switch module and through the vents is unrestricted.

Temperature around the unit does not exceed 140°F (60° C). If the switch module is installed in a closed or multi-rack assembly, the temperature around it might be higher than normal room temperature.

Relative humidity around the switch module does not exceed 95 percent (non-condensing).

Altitude at the installation site is not higher than 4921 feet (1500 meters).

For 10/100 and 10/100/1000 fixed ports, cable lengths from the switch module to connected devices are not longer than 328 feet (100 meters).

Installation Warning Statements

This section includes the basic installation warning statements. Translations of these warning statements appear in the Regulatory Compliance and Safety Information for Cisco Connected Grid Router 1000 Series Routers document.


Warning This unit is intended for installation in restricted access areas. A restricted access area can be accessed only through the use of a special tool, lock and key, or other means of security. Statement 1017

Warning Only trained and qualified personnel should be allowed to install, replace, or service this equipment. Statement 1030

Warning To prevent the system from overheating, do not operate it in an area that exceeds the maximum recommended ambient temperature of:
140°F (60°C) Statement 1047

Warning This equipment is intended to be grounded to comply with emission and immunity requirements. Ensure that the switch functional ground lug is connected to earth ground during normal use. Statement 1064

Warning To prevent airflow restriction, allow clearance around the ventilation openings to be at least: 1.75 in. (4.4 cm) Statement 1076

Installing the 3G Module

The 3G module can be installed into any slot of the CGR 1120 and CGR 1240.

To install the module into the router:


Caution The module can not be hot swapped—to install the module, you must first power down the host router.


Step 1 Before you install the Cisco Connected Grid 3G Module into the host router, read the instructions about installing and removing modules in the Hardware Installation Guide of your router.

Step 2 Insert the module into the slot. (CGR 1120 and CGR 1240 shown.)

Step 3 Using a screwdriver, secure the two captive screws into place. Tighten to 5 to 8 pound-force inches (lbf-in.).


Removing the Module

To remove the module from a router:


Caution The module can not be hot swapped—to remove the module, you must first power down the host router.


Step 1 Before you remove the Cisco Connected Grid 3G Module from the host router, power down the router as described in the Hardware Installation Guide of your router.

Step 2 Using a screwdriver, loosen the two captive screws on the Cisco Connected Grid 3G Module.

Step 3 Gently pull the module out of the slot.


Regulatory and Compliance Information

For regulatory compliance and safety information for the module, refer to Regulatory Compliance and Safety Information for the Cisco 1000 Series Connected Grid Routers.

3G Overview

3G is defined by the ITU (International Telecommunications Union-2000 (IMT-2000)) as mobile radio systems capable of supporting peak data rates of:

144 Kb/s or more in a large cell (where the users may be miles from the Base Stations) with high speed vehicular users

384 Kb/s or more for urban small cells (where the user may be only a few city blocks from a Base Station) with pedestrian users

2 Mb/s or more for indoor (or very small cells, where the user may be only a few hundred feet from a Base Station) with primarily stationary users


Note On the Cisco Connected Grid Module—3G HSPA+/UMTS/GSM/GPRS/EDGE module (CGM-3G-HSPA-A), the ping packet size limit is 1472 bytes.


Configuring the Module

The module is configured using the system software. This section covers the following topics:

Prerequisites

Configuration Restrictions

Configuring the GSM Module

Configuring the CDMA Module

show Commands

Data Account Provisioning

GSM Cellular Interface Configuration

CDMA Cellular Interface Configuration

Configuring WAN Backhaul Redundancy


Note The 3G module can be plugged into slots 3 to 6 of Cisco 1240 Connected Grid Router. Therefore, the interface names used to configure the module can be 3/1, 4/1, 5/1, or 6/1. Interface 3/1 is used in the configuration examples in this section.



Note The 3G module can be plugged into slots 3 or 4 of Cisco 1120 Connected Grid Router. Therefore, the interface names used to configure the module can be 3/1 or 4/1. Interface 3/1 is used in the configuration examples in this section.


Prerequisites

To configure the 3G module, you must meet the following requirements:

Have 2G/3G network coverage where your router will be physically located. For a complete list of supported carriers, see the product data sheet.

Subscribe to a service plan with a wireless service provider and obtain a SIM card.

Install the SIM card before configuring the 3G module. For instructions on how to install the SIM card, see the section, Installing the SIM Card (GSM Module).

When installing within a Verizon network, be sure that you register the 3G Verizon modem as CGR 1240.

Configuration Restrictions

The following restrictions apply to configuring the Cisco Connected Grid 3G Module:

Data connection can be originated only by the module.

Throughput: Due to the shared nature of wireless communications, the experienced throughput varies depending on the number of active users or congestion in a given network.

Cellular networks have higher latency compared to wired networks. Latency rates depend on the technology and carrier. Latency may be higher because of network congestion.

Any restrictions that are a part of the terms of service from your carrier.

Configuring the GSM Module

Before beginning the steps below, contact your ISP and get your access point name.


Note In the following examples, the interface name, including the slot number, is used as an example. Your configuration will vary depending on the slot in which you have installed your 3G module.


Step 1: Creating a GSM Profile

Use the cellular 3/1 gsm profile command to configure a GSM profile:

Router# cellular 3/1 gsm profile create 1 access_point_name [authentication_type username 
password ]
 
   

Use authentication_type if username and password are configured.

Use username if required by your carrier.

Use password if required by your carrier.

See also GSM Cellular Interface Configuration.

Step 2: Configuring a Chat Script

Use the chat-script command to configure a GSM chat script:

Router(config)# chat-script chat-script_name PROFILE1 

Step 3: Configuring Dialer Parameters

Use the dialer commands to configure dialer parameters:

Router(config)# interface dialer 1
Router(config-if)# dialer pool 1
Router(config-if)# dialer string chat-script_name
Router(config-if)# dialer persistent
Router(config-if)# no shutdown

Note To disable dialer persistent, you must delete the profile by using the command, cellular 3/1 gsm profile delete 1.


Step 4: Configuring Cellular Parameters

Use the dialer pool-member command to configure cellular parameters:

Router(config)# interface cellular 3/1
Router(config-if)# dialer pool-member 1 

Step 5: Saving Configuration

Use the no shutdown commands to activate the interface:

Router(config)# interface cellular 3/1
Router(config-if)# no shutdown
 
   

Disabling GSM Configuration

All configuration commands can be disabled by using the no option. The dialer persistent profile must be deleted with the command cellular 3/1 gsm profile delete 1.

See also Step 3: Configuring Dialer Parameters.

Configuring the CDMA Module

Configuration of the CDMA Hostname and Password

The CDMA module supports PPP Challenge Handshake Authentication Protocol (CHAP) type 6 and type 7 password support for Simple IP (SIP) to provide strength-check configuration on passwords. The SIP CLI command enables you to configure your hostname and password on a cellular interface to be used for PPP negotiation.

Currently, the password is not subject to password strength-check configuration because the CGR acts as the PPP client rather than a server. Typically, the hostname and password are managed and set by the cellular network-side server with strength-check functionality.

Use the ppp chap hostname command in interface configuration mode. To disable this function, use the no form of this command.

Router(config-if)# ppp chap hostname xyz

 
   

Use the ppp chap password command in interface configuration mode. To disable the PPP CHAP password, use the no form of this command.

Router(config-if)# ppp chap password ?
   6 Type-6 encrypted 
   7 Type-7 encrypted
   WORD PPP CHAP clear text password (Max Size 63)
 
   

Step 1: Configuring a Chat Script

Use the chat-script command to configure a GSM chat script:

Router(config)# chat-script chat-script_name ATDT#777 
 
   

Step 2: Configuring Dialer Parameters

Use the dialer commands to configure dialer parameters:

Router(config)# interface dialer 1
Router(config-if)# dialer pool 1
Router(config-if)# dialer string chat-script_name
Router(config-if)# dialer persistent
Router(config-if)# no shutdown
 
   

Step 3: Configuring PPP Encapsulation

Use the feature ppp command to configure PPP encapsulation:

Router(config)# feature ppp

Step 4: Configuring Cellular Parameters

Use the dialer pool and encapsulation ppp commands to configure cellular parameters:

Router(config)# interface cellular 3/1
Router(config-if)# dialer pool-member 1 
Router(config-if)# encapsulation ppp

Step 5: Saving Configuration

Use the no shutdown command to activate the interface:

Router(config)# interface cellular 3/1
Router(config-if)# no shutdown
 
   

show Commands

To view your configurations, use the following show commands:

show ip interface brief

show interface cellular 3/1

show cellular 3/1 ?

all—Display cellular information

connection—Display cellular connection status

hardware—Display cellular hardware information

leds—Display LED information

network—Display cellular network information

profile—Display cellular interface profile

radio—Display cellular radio information

band—Display radio band information

show cellular 3/1 all (GSM Module)

The following example shows consolidated information about the modem, profiles created, radio signal strength, network security, and so on.


Note The RSSI should be better than -90 dBm for steady and reliable connection.


Router# show cellular 3/1 all
 
   
Hardware Information
====================
 
   
Modem Firmware Version = T1_0_3_2AP R361 CNSZXD00000061 2011/04/15 17:40:48
Modem Firmware Built = 04/15/11
Modem Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 0123456063
International Mobile Equipment Identity (IMEI) = 353567040032469 <-- Unique identifier for module
Factory Serial Number (FSN) = CC3291006141001
Modem status = Online
Current Modem Temperature = 33 deg C
Current Temperature State = Normal
 
   
 
   
Profile Information
===================
 
   
--- Profile 1 details ---
Status = Activated
Default: Yes
PDP Type: IPv4
Profile IP: 192.0.2.0 <-- Profile details stored on the modem
Profile APN: isp.cingular
Authentication: CHAP
Profile UserName: 
Profile Password:
 
   
 
   
Data Connection Information
===========================
 
   
Data Transmitted = 208880986 bytes
Data Received = 208880986 bytes
Profile 1, Packet Session Status = ACTIVATED <-- State of the connection
 
   
 
   
Network Information
===================
 
   
Modem status = Online
Service status = Normal
Service type = Combined
Country Initials = 1
Network name = 
MCC = 1, MNC = 1 <-- Mobile country code, mobile network code
Location Area Code (LAC) = 128
Routing Area Code (RAC) = 0
Cell ID = 1
Primary Scrambling Code = 100
PLMN Selection = Automatic
 
   
 
   
Radio Information
=================
 
   
Current band = WCDMA_I_IMT2000 <-- Current band/channel/RSSI
Radio power mode = On
Channel number = 10563
Band selected = Auto
Current RSSI = -56 dBm
 
   
 
   
Band Information
================
 
   
Number of bands:   5 <-- Bands supported by the modem are listed below
  Band 1: GSM EGSM DCS
  Band 2: Unknown Band Group
  Band 3: GSM ALL
  Band 4: Unknown Band Group
  Band 5: AUTO BAND
 
   

show cellular 3/1 all (CDMA Module)

The following example shows consolidated information about the modem, profiles created, radio signal strength, network security, and so on.


Note The RSSI should be better than -90 dBm for steady and reliable connection.


Router# show cellular 3/1 all
 
   
Hardware Information
====================
 
   
Modem Firmware Version = p2813301
Modem Firmware Built = 06-24-10
Modem Hardware Version = MC5728V Rev 1.0
International Mobile Subscriber Identity (IMSI) = 5555550032
Electronic Serial Number (ESN) = 60D22706 <-- Unique identifier for module
Modem status = Online
Current Modem Temperature = 31 deg C
Current Temperature State = Normal
 
   
 
   
Profile Information
===================
 
   
Electronic Serial Number (ESN) = 60D22706 <-- Unique identifier for module
Activation Status = active
Activation Date = 20110925
Phone Number (MDN) = 5555550213
Number of data profiles configured: 1
Current Active Data Profile: 1
NAI (Network Access Identifier) = 5555550213@vzw3g.com
MN-HA SS = enabled
MN-HA SPI = 300
MN-AAA SS = enabled
MN-AAA SPI = 2
Reverse Tunneling Preference = enabled
Home Address = 0.0.0.0
Primary Home Agent Address = 255.255.255.255
Secondary Home Agent Address = 255.255.255.255
 
   
 
   
Data Connection Information
===========================
 
   
Phone Number of outgoing call = 5555550213
Data Transmitted = 14041 bytes
Data Received = 14041 bytes
 
   
 
   
Network Information
===================
 
   
Current Roaming Status = Not Roaming
Current Idle Digital Mode = No Service
Current System Identifier (SID) = 40
Current System Identifier (NID) = 0
Serving Base Station Longitude = 0 deg 0 min 0 sec
Serving Base Station Latitude = 0 deg 0 min 0 sec
 
   
 
   
Radio Information
=================
 
   
Current band = CDMA_CLASS1,CDMA_CLASS1 <-- Current band/channel/RSSI
Radio power mode = On
Channel number = 548
Current RSSI = -82 dBm
 
   

Data Account Provisioning


Note For the Cisco Connected Grid 3G Module, the interface number is 3/1 for all commands.



Note To provision the GSM or CDMA modem, you must have an active wireless account with a service provider. The GSM module requires a SIM card installed.


To provision your data account, see the following topics:

Verifying Signal Strength and Service Availability

Activating the Module Using OTASP (CDMA Module)

Verifying Signal Strength and Service Availability

An RSSI rating of less than -100 dBm will not allow the modem to connect to the base station.

To verify the signal strength and service availability on your modem, use the following commands in privileged EXEC mode. See also show Commands.

show cellular 3/1 network

show cellular 3/1 radio

show cellular 3/1 profile

show cellular 3/1 led

show cellular 3/1 all

DETAILED STEPS

Step
Command
Purpose

Step 1 

show cellular 3/1 network

Displays information about the carrier network, cell site, and available service.

Step 2 

show cellular 3/1 radio

Shows the radio signal strength.

Note The RSSI should be better than -90 dBm for steady and reliable connection.

Step 3 

show cellular 3/1 profile

Shows information about the modem data profiles created.

Step 4 

show cellular 3/1 led

Shows WWAN link state, RSSI strength, SIM card, and service status.

Step 5 

show cellular 3/1 all

Shows consolidated information about the modem, profiles created, radio signal strength, network security, and so on.


Activating the Module Using OTASP (CDMA Module)

To activate the module using Over-The-Air Service Provisioning (OTASP), use the cellular 3/1 cdma activate otasp *22899 command.


Note Do not press Enter until provisioning is complete—you will see "Over the air provisioning complete; Result = Success." See below.


Router# cellular 3/1 cdma activate otasp *22899
Beginning OTASP activation
OTASP number is *22899
Router# <-- Do not press Enter key-- provisioning is in process. 
OTA State = SPL unlock, Result = Successprovising
OTA State = Profile downloaded, Result = Success
OTA State = MDN downloaded, Result = Success
OTA State = Parameters committed to NVRAM, Result = Success
Over the air provisioning complete; Result = Success <-- Activation successful. Press Enter to return to prompt.
 
   

To verify that the account has been provisioned and the modem has been activated, use the show cellular 3/1 profile command in EXEC mode:

Router# show cellular 3/1 profile
Electronic Serial Number (ESN) = 60D22720
Activation Status = actived <-- Activation verified. 
Activation Date = 20111129
Phone Number (MDN) = 4086875313
Number of data profiles configured: 1
Current Active Data Profile: 1
NAI (Network Access Identifier) = 4086875313@vzw3g.com
MN-HA SS = enabled
MN-HA SPI = 300
MN-AAA SS = enabled
MN-AAA SPI = 2
Reverse Tunneling Preference = enabled
Home Address = 0.0.0.0
Primary Home Agent Address = 255.255.255.255
Secondary Home Agent Address = 255.255.255.255
 
   

GSM Cellular Interface Configuration

To configure the GSM cellular interface:


Step 1 Create a profile on interface 3/1 using the cellular command:

Router# cellular 3/1 gsm profile create 1 access_point_name [username password]
 
   

Step 2 Configure terminal:

Router# configure terminal
 
   

Step 3 Create a chat script using the chat-script command and assign it to your profile:

Router(config)# chat-script chat-script_name PROFILE1 #
 
   

Step 4 Configure dialer parameters on the interface by using the interface command to enter interface configuration mode, and the dialer command to configure persistent dialer mode.

Router(config)# interface dialer 1
Router(config-if)# dialer pool 1
Router(config-if)# dialer string chat-script_name #
Router(config-if)# dialer persistent
Router(config-if)# no shutdown
 
   

Step 5 Configure cellular parameters on the interface by using the interface and dialer commands:

Router(config)# interface cellular 3/1
Router(config-if)# dialer pool-member 1 
 
   

Step 6 Shut down and then enable the interface using the shutdown and no shutdown commands:

Router(config)# interface cellular 3/1
Router(config-if)# shutdown
Router(config-if)# no shutdown
 
   

Disabling GSM Dialer Persistent

The interface configuration command, dialer persistent, allows a dial-on-demand routing (DDR) dialer profile connection to be brought up without being triggered by interesting traffic. When configured, the dialer persistent command starts a timer when the dialer interface starts up and starts the connection when the timer expires. If interesting traffic arrives before the timer expires, the connection is still brought up and set as persistent. The command provides a default timer interval, or you can set a custom timer interval.

The connection is brought down when the shutdown interface command is entered on the dialer interface. If the persistent connection is torn down for some other reason, such as the ISDN line goes down, the system immediately tries to bring the connection back up, and will use any other settings configured for dialing on the dialer interface. The Dialer Persistent feature allows the connection settings in the dialer profile to be configured as persistent, that is, the connection is not torn down until the shutdown interface command is entered on the dialer interface.

The dialer persistent feature can be disabled with the no dialer persistent command.

CDMA Cellular Interface Configuration

The following example shows how to configure the cellular interface:


Step 1 Configure a chat script using the chat-script command:

Router(config)# chat-script chat-script_name ATDT#777 <-- ATDT777# is the chat-script name.
 
   

Step 2 Configure dialer parameters by using the dialer command:

Router(config)# interface dialer 1
Router(config-if)# dialer pool 1
Router(config-if)# dialer string ATDT777#
Router(config-if)# dialer persistent
Router(config-if)# no shutdown
 
   

Step 3 Configure PPP encapsulation by using the feature command:

Router(config)# feature ppp
 
   

Step 4 Configure the cellular parameters by using the encapsulation command:

Router(config)# interface cellular 3/1
Router(config-if)# dialer pool-member 1 
Router(config-if)# encapsulation ppp
 
   

Step 5 Save changes by issuing shutdown and no shutdown on the interface:

Router(config)# interface cellular 3/1
Router(config-if)# no shutdown 


Configuring WAN Backhaul Redundancy

For information on configuring WAN backhaul redundancy, see Cisco 1000 Series Connected Grid Routers Unicast Routing Software Configuration Guide.

Configuration Example

The following example shows a configuration that includes information on TACACS+ security, OSPF (Open Shortest Path First), OSPF v3, DHCP (Dynamic Host Configuration Protocol), DHCP v6, a tunnel, virtual tunnel, QoS, Internet Protocol Security (IPSec), a static IP address when a tunnel interface (3/1) is configured, the interfaces (Ethernet, serial, cellular, WPAN, and WiFi), dialer, and chat script. The cellular-related configurations are highlighted.

Router# show running-configuration 
 
   
!Command: show running-config
!Time: Sun Aug 14 00:36:25 2011
 
   
version 5.2(1)
hostname Router
vdc Router id 1
  limit-resource vlan minimum 16 maximum 4094
  limit-resource vrf minimum 2 maximum 4096
  limit-resource port-channel minimum 0 maximum 768
  limit-resource u4route-mem minimum 9 maximum 9
  limit-resource u6route-mem minimum 24 maximum 24
  limit-resource m4route-mem minimum 58 maximum 58
  limit-resource m6route-mem minimum 8 maximum 8
 
   
feature privilege
feature tacacs+
feature crypto ike
crypto ike domain ipsec
  policy 10
    group 1
    lifetime seconds 660
  identity hostname
feature ospf
feature ospfv3
feature dhcp
feature tunnel
feature crypto ipsec virtual-tunnel
feature dhcpv6
feature ppp
 
   
username adminbackup password 5 !  role network-operator
username admin password 5 $1$fMmnWu6t$Aawk/sH5wmErCjCwnxeyb.  role network-admin
enable secret 5 $1$454cdd6$a08d10dc3fdb2f6f
no password strength-check
ip domain-lookup
tacacs-server host 4.4.4.5 key 7 "fewhg" 
aaa group server tacacs+ tactical 
    server 4.4.4.5 
crypto key param rsa label IPSEC_IDENTITY_BLUE modulus 2048 exportable
crypto ca trustpoint IPSEC_IDENTITY_BLUE 
     rsakeypair IPSEC_IDENTITY_BLUE  2048
     revocation-check  none 
class-map type qos match-all ignore
  match precedence 0
class-map type qos match-all packet
  match packet length 1500
class-map type qos match-all critical
  match dscp 46
class-map type qos match-all matchall
  match precedence 1
  match dscp 10
class-map type qos match-any matchany
  match dscp 10,26
class-map type qos match-all priority
  match precedence 3
policy-map type qos ignore
  class ignore
    set dscp 1
policy-map type qos packet
  class packet
    set precedence 5
policy-map type qos critical
  class critical
    set dscp 10
policy-map type qos matchall
  class matchall
    set precedence 5
policy-map type qos matchany
  class matchany
    set dscp 46
policy-map type qos priority
  class priority
    set dscp 46
priority level 3
copp profile strict
snmp-server user admin auth md5 0x5f66c5f7cde8de86eecb2008de9126f8 priv 0x5f66c5
f7cde8de86eecb2008de9126f8 localizedkey engineID 128:0:0:9:3:0:34:189:224:46:129
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO
 
   
vrf context test
vrf context management
crypto ipsec profile MyProfile
  set transform-set MyTransformSet
  set pfs group1
  set security-association lifetime seconds 120
  set security-association lifetime kilobytes 2560
crypto ipsec transform-set MyTransformSet esp-gcm 256
vlan 1
 
   
no ip dhcp relay
 
   
interface Tunnel0
  ip address 4.0.0.1/24
  tunnel mode ipsec ipv4
  tunnel source cellular3/1
  tunnel destination 192.168.168.2
  tunnel protection ipsec profile MyProfile
  no shutdown
 
   
interface Tunnel1
  ipv6 address 2001:b:b:bc::1/64
  ipv6 mld join-group ff38:40:2011:dead:beef:cafe:0:1
  ipv6 router ospfv3 1 area 0.0.0.0
  tunnel source Tunnel0
  tunnel destination 4.0.0.2
  no shutdown
  ipv6 dhcp relay destination 2001:a:b:c::100
 
   
interface Tunnel5
  no shutdown
 
   
interface Ethernet2/1
  mac-address 0022.bde0.3201
  ip address 2.12.54.10/16
  no shutdown
 
   
interface Ethernet2/2
  mtu 1496
  mac-address 0022.bde0.3202
  ip address 172.27.161.54/25
  ipv6 address 2001:dead:beef:cafe::2/64
  no shutdown
 
   
interface Ethernet2/3
  mtu 1496
  mac-address 0022.bde0.3203
 
   
interface Ethernet2/4
  mtu 1496
  mac-address 0022.bde0.3204
 
   
interface Ethernet2/5
  mtu 1496
  mac-address 0022.bde0.3205
 
   
interface Ethernet2/6
  mtu 1496
  mac-address 0022.bde0.3206
 
   
interface Ethernet2/7
  mtu 1496
  mac-address 0022.bde0.3207
 
   
interface Ethernet2/8
  mtu 1496
  mac-address 0022.bde0.3208
  no shutdown
 
   
interface serial1/1
  physical-layer async
 
   
interface serial1/2
  physical-layer async
 
   
interface cellular3/1
  no shutdown
  encapsulation ppp
  dialer pool-member 1
 
   
interface wimax5/1
  shutdown
  no description
  pkm version none
  pkm crypto algorithm none
 
   
interface wpan4/1
  no shutdown
  ipv6 address 2011:dead:beef:cafe::0/64
  rpl prefix 2011:dead:beef:cafe::0/64
  ipv6 dhcp relay client-interface
 
   
interface wifi2/1
clock timezone PST -8 0
line console
line vty
boot kickstart bootflash:/cgr1000-uk9-kickstart.5.2.0.CG1.0.194.SSA.gbin sup-1
boot system bootflash:/cgr1000-uk9.5.2.0.CG1.0.194.SSA.gbin sup-1
router ospfv3 1
  address-family ipv6 unicast
ip route 0.0.0.0/0 cellular3/1
ip route 223.255.0.0/16 2.12.0.1
ipv6 route 2001:420:7bf:5f::/64 Tunnel1
ipv6 route 2001:a:b:c::/64 Tunnel1
line tty 1
  device-role dce
line tty 2
  device-role dce
 
   
interface Dialer1
  dialer persistent
  dialer pool 1
  dialer string gsm
  
  chat-script gsm PROFILE1
 
   
cgdm
  registration start trustpoint ://2001:420:7bf:5f::800:9121
no logging console

Upgrading to a New Software Release and Firmware

You can upgrade the NX-OS software on the Cisco router by using the install all command in one of the two possible approaches:

Download the images (kickstart, system image, or firmware) from a remote server into the volatile memory of the Cisco CG-OS router by employing the install all command to specify the path to the remote server and the protocol. After the download, the software installation begins automatically.

Download the images (kickstart, system image, or firmware) from a local server directly into the bootflash of the Cisco CG-OS router, and then manually enter the install all command to initiate the software upgrade.

The following table provides detailed command syntax for the install all command.

install all [kickstart {bootflash: | ftp:[//server][/path] | scp:[//[username@]server][/path] | sftp:[//[username@]server][/path] | tftp:[//server[:port]][/path] | volatile:} kickstart-filename]
[
system {bootflash: | ftp:[//server][/path] | scp:[//[username@]server][/path] | sftp:[//[username@]server][/path] | tftp:[//server[:port]][/path] | volatile:} system-filename]
[non-interactive]

The install all command specifies the software images being downloaded (kickstart, system, or firmware images), the method used to download the images such as FTP, SCP, TFTP (remote server downloads only), and the destination of the images (bootflash or volatile) on the
Cisco CG-OS router.

Define bootflash: as the destination in the install all command when the download is from a local server.

Define volatile: as the destination in the install all command when you are downloading the software from a remote server (such as Cisco.com or a remote server in your own network).

kickstart bootflash: kickstart-file-name-Identifies the file as a kickstart image and the file name of that image. Format of the kickstart filename is as follows: cg-os_kick.bin. File name is case sensitive.

system bootflash: system-filename-Specifies internal flash memory as the destination of the software images. Format of the bootflash filename is as follows: cg-os_sys.bin. File name is case sensitive.

ftp: Specifies File Transfer Protocol (FTP) as the transfer method for the software images (kickstart and system).

scp:-Specifies Secure Copy Protocol (SCP) as the transfer method for the software images (kickstart and system).

sftp:-Specifies Secure Shell FTP (SFTP) as the transfer method for the software images (kickstart and system).

tftp:-Specifies Trivial FTP (TFTP) as the transfer method for the software images (kickstart and system).

username@-Specifies the username on the server. Username is case-sensitive.

//path-Defines the path to the server on which the software images reside.

//server-Defines the IPv4 address or name of the server on which the software images reside.

[non-interactive]-Eliminates the need for interaction or responses from an administrator during the process. Process proceeds to completion without requesting approval by the user.

EXAMPLES

This example shows how to download the software images from a remote FTP server onto the
Cisco CG-OS router bootflash. After download, the software installation starts automatically on the
Cisco CG-OS router.

cgr1000# install all kickstart ftp://10.10.1.1/cg-os_kick.bin  
system ftp://10.10.1.1/cg-os_sys.bin
 
   

This example shows how to download the software images from a remote SCP server onto the
Cisco CG-OS router bootflash. After download, the software installation starts automatically on the
Cisco CG-OS router.

cgr1000# install all kickstart scp://adminuser@10.10.1.1/cg-os_kick.bin  
system scp://adminuser@10.10.1.1/cg-os_sys.bin
 
   

This example shows how to copy the image from a remote SCP server onto the Cisco CG-OS router bootflash and then manually upgrade the software by using the install all command.

 
   
cgr1000# copy scp://adminuser@10.10.1.1/cg-os_kick.bin bootflash:
cgr1000# install all kickstart bootflash:cg-os_kick.bin system bootflash:cg-os_sys.bin
 
   

This example shows how to copy the image from a remote SCP server onto the Cisco CG-OS router bootflash without requiring any action or entry by the administrator. All actions proceed automatically.

cgr1000# copy scp://adminuser@10.10.1.1/cg-os_kick.bin bootflash:
cgr1000# install all kickstart bootflash:cg-os_kick.bin system bootflash:cg-os_sys.bin 
non-interactive
 
   

Note An output similar to the one below displays during the install. The same output displays for local and remote installations.


 
   
Verifying image bootflash:///cgr1000-uk9-kickstart.5.2.1.CG1.0.277.SPA.bin for boot 
variable "kickstart".
[####################] 100% -- SUCCESS
 
   
Verifying image bootflash:///cgr1000-uk9.5.2.1.CG1.0.277.SPA.bin for boot variable 
"system".
[####################] 100% -- SUCCESS
 
   
Verifying image type.
[####################] 100% -- SUCCESS
 
   
Extracting "system" version from image bootflash:///cgr1000-uk9.5.2.1.CG1.0.277.SPA.bin.
[####################] 100% -- SUCCESS
 
   
Extracting "kickstart" version from image 
bootflash:///cgr1000-uk9-kickstart.5.2.1.CG1.0.277.SPA.bin.
[####################] 100% -- SUCCESS
 
   
Extracting "bios" version from image bootflash:///cgr1000-uk9.5.2.1.CG1.0.277.SPA.bin.
[####################] 100% -- SUCCESS
 
   
Extracting "loader" version from image 
bootflash:///cgr1000-uk9-kickstart.5.2.1.CG1.0.277.SPA.bin.
[####################] 100% -- SUCCESS
 
   
Performing module support checks.
2012 Jan 3 00:12:23 Router %$ VDC-1 %$
[####################] 100% -- SUCCESS
 
   
Notifying services about system upgrade.
[####################] 100% -- SUCCESS
 
   
Compatibility check is done:
Module  bootable          Impact  Install-type  Reason
------  --------  --------------  ------------  ------
    1       yes  non-disruptive          none  
Images will be upgraded according to following table:
Module   Image       Running-Version(pri:alt)   New-Version    Upg-Required
------   ----------  ----------------------------------------  --------------------
  1     system              5.2(1)               5.2(1)            no
  1     kickstart           5.2(1)               5.2(1)            no
  1     bios                 :                                     no
  1     loader              1.2(2)               1.2(2)            no
  1     fpga                2_0_0                2_4_0             yes
 
   
 
   
Do you want to continue with the installation (y/n)?  [n] y
 
   
Install is in progress, please wait.
 
   
Performing runtime checks.
[####################] 100% -- SUCCESS
Setting boot variables.
[####################] 100% -- SUCCESS
 
   
Performing configuration copy.
[####################] 100% -- SUCCESS
 
   
Module 1: Refreshing compact flash and upgrading bios/loader/bootrom/fpga/modem firmware.
Warning: please do not remove or power off the module at this time.
[####################] 100% -- SUCCESS
 
   
Install has been successful.
 
   
cgr1000# 
 
   

Note The Cisco CG-OS router reboots after a successful installation.


Additional References

Consult the following resources for related information about the 3G module or for technical assistance.

Hardware Overview and Installation Documents

Cisco Connected Grid Modules

Cisco CGR 1240 Hardware Installation Guide

Cisco CGR 1120 Hardware Installation Guide

Supported Cisco Antennas and Accessories Documents

Cisco Connected Grid Antennas Installation Guide

Cisco System Software Commands Documents

Cisco Connected Grid Device Manager Installation and User Guide

Cisco System Software

Configuring Cisco EHWIC and 880G for 3G (EV-DO Rev A)

Cisco 1000 Series Connected Grid Routers Unicast Routing Software Configuration Guide

Regulatory, Compliance, and Safety Information

Cisco Network Modules, Server Modules, and Interface Cards Regulatory Compliance and Safety Information

Troubleshooting and Diagnostics

This section provides the necessary background information and resources available for troubleshooting the 2G/3G Connected Grid module.

For LED descriptions, see Ports and LEDs.

Debug Commands

The following are the debug commands and keywords:

Checking Signal Strength

Verifying Service Availability (GSM Module)

Verifying Service Availability (CDMA Module)

Successful Call Setup (GSM Module)

Successful Call Setup (CDMA Module)

Debug Output (GSM Module)

Debug Output (CDMA Module)

Retrieving the Electronic Serial Number

Converting Hexadecimal ESN to Decimal Notation

Debug Commands

The following are the debug commands and keywords:

Command Syntax
Description

 

debug cellular

<0-10>—Debug level

debug cellpm

all—All debugging

error—Error cellpm debug

trace—Trace cellpm debug

debug chat

error—Error chat debug

trace—Trace chat debug

debug dialer

all—All debugging

error—Error chat debug

trace—Trace chat debug


Checking Signal Strength

If the Received Signal Strength Indication (RSSI) level is very low (for example, if it is less than -110 dBm), follow these steps:


Step 1 Check the antenna connection. Make sure the QMA connector is correctly threaded and tightened.

Step 2 If you are using a remote antenna, move the antenna cradle and check if the RSSI has improved.

Step 3 Contact your wireless service provider to verify that there is service availability in your area.


Verifying Service Availability (GSM Module)

The following are the GSM module service availability issues and their corresponding troubleshooting tasks:

Issues
Troubleshooting

No profile configured

Verify profile. See Step 1: Creating a GSM Profile.

Not connected to the network

Antenna not present

Antenna bad

Out of network

Check antenna hardware for faulty connections.

Verify RSSI. See Verifying Signal Strength and Service Availability.

SIM card not installed. Use show cellular 3/1 led command to verify presence of SIM card in a slot and indicated as "green." See Verifying Signal Strength and Service Availability.

Contact your base station for more information.


The following is sample show cellular 3/1 all command output for a scenario where the antenna is disconnected and a modem data profile has not been created.

The error in this case has been highlighted below:

Router# show cellular 3/1 all
Hardware Information
====================
 
   
Modem Firmware Version = T1_0_3_2AP R361 CNSZXD00000061 2011/04/15 17:40:48
Modem Firmware Built = 04/15/11
Modem Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 345678901
International Mobile Equipment Identity (IMEI) = 357115040054053
Factory Serial Number (FSN) = CC3200115221007
Modem status = Online
Current Modem Temperature = 0 deg C
Current Temperature State = Normal
 
   
 
   
Profile Information
====================
 * - Default profile <-- Indicates that no profile is present.
 
   
 
   
Data Connection Information
===========================
 
   
Data Transmitted = 5616 bytes
Data Received = 9424 bytes
Profile 1, Packet Session Status = ACTIVATED
IP Address = 192.0.2.0
 
   
 
   
Network Information
===================
Current Service Status = No service, Service Error = None <-- Indicates not connected to network.
 
   
Current Service = Combined
Packet Service = None
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = USA, Network = Cinglr
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 380
Location Area Code (LAC) = 6042
Routing Area Code (RAC) = 255
Cell ID = 0
Primary Scrambling Code = 0
PLMN Selection = Automatic
 
   
 
   
Radio Information
=================
 
   
Current Band = None, Channel Number = 0
Current RSSI = -110 dBm <-- Indicates either no antenna or bad antenna, or out of network.
 
   
 
   
Band Information
================
 
   
  Number of bands:   5 
  Band 1: GSM EGSM DCS
  Band 2: Unknown Band Group
  Band 3: GSM ALL
  Band 4: Unknown Band Group
  Band 5: AUTO BAND

Verifying Service Availability (CDMA Module)

The following are the CDMA module service availability issues and their corresponding troubleshooting tasks:

Issue
Troubleshooting

No profile configured

Verify profile:

Contact your wireless carrier to ensure your account is activated.

See Data Account Provisioning.

Not connected to the network

Antenna not present

Antenna bad

Out of network

Check antenna hardware for faulty connections.

Verify RSSI. See Verifying Signal Strength and Service Availability.

Check that OTASP is active. See Activating the Module Using OTASP (CDMA Module).

Contact your base station for more information.


The following is sample show cellular 3/1 all command output for a scenario where the antenna is disconnected and a modem data profile has not been created.

Hardware Information
====================
 
   
Modem Firmware Version = p2813301
Modem Firmware Built = 06-24-10
Modem Hardware Version = MC5728V Rev 1.0
International Mobile Subscriber Identity (IMSI) = 0000008126
Electronic Serial Number (ESN) = 60E62F4E
Modem status = Online
Current Modem Temperature = 33 deg C
Current Temperature State = Normal
 
   
 
   
Profile Information
===================
Electronic Serial Number (ESN) = 60E62F4E
Activation Status = not actived <- account is not provisioned yet
Activation Date =
Phone Number (MDN) = 0000008126
Number of data profiles configured: 1
Current Active Data Profile: 0 <- no active data profile, account is not provisioned yet
NAI (Network Access Identifier) = 0000008126@vzw3g.com
MN-HA SS = enabled
MN-HA SPI = 300
MN-AAA SS = enabled
MN-AAA SPI = 2
Reverse Tunneling Preference = enabled
Home Address = 0.0.0.0
Primary Home Agent Address = 255.255.255.255
Secondary Home Agent Address = 255.255.255.255
 
   
 
   
Data Connection Information
===========================
Phone Number of outgoing call = 0000008126
Data Transmitted = 0 bytes
Data Received = 0 bytes
 
   
 
   
 
   
Network Information
===================
Current Roaming Status = Not Roaming
Current Idle Digital Mode = No Service <- Indicates no service - not connected to network
Current System Identifier (SID) = 0
Current System Identifier (NID) = 0
Serving Base Station Longitude = 0 deg 0 min 0 sec
Serving Base Station Latitude = 0 deg 0 min 0 sec
 
   
 
   
Radio Information
=================
 
   
Current band = CDMA_CLASS1,CDMA_CLASS0
Radio power mode = On
Channel number = 375
Current RSSI = -150 dBm <- Indicates either no antenna or bad antenna, or out of network
 
   

Successful Call Setup (GSM Module)

The following are the single-line debug output for key steps while establishing a successful connection.

Modem is Enabled

The debug cellular trace command output provides the following output:

...
2009 Jan  1 07:53:37.232260 cellpm: Receive modem enabled notification
...
 
   

Chat Script Invoked

The debug chat trace command output provides the following output:

...
2009 Jan  1 07:53:37.265470 dialer: CHAT SCRIPT gsm1_x profile 1 
...
 
   

Dialer Dial Out Successfully

The debug dialer trace command output provides the following output:

...
2009 Jan 1 07:53:38.724766 dialer: Dialer1 dial out cellular3/1 successfully
... 
 
   

Packet Session Activated Successfully

The debug cellular trace command output provides the following output:

...
2009 Jan  1 07:53:39.724489 cellpm: Send MTS - PKT SESS ACTIVATED to dialer 
...
 
   

Stop Dialer Since Connection is Established

The debug dialer trace command output provides the following output:

...
2009 Jan 1 07:53:39.557800 dialer: Session activated. Dialer1 stop dialing
..
2009 Jan 1 07:53:39.267768 cellpm: interface cellular 3/1 IP address 166.129.59.20
... 

Successful Call Setup (CDMA Module)

The following are the single-line debug output for key steps while establishing a successful connection.

Modem is Enabled

The debug cellular trace command output provides the following output:

...
2008 Mar 12 03:10:46.519698 cellpm: Receive modem enabled notification
...
 
   

Chat Script Invoked

The debug chat trace command output provides the following output:

...
2008 Mar 12 03:10:46.520486 dialer: CHAT SCRIPT cdma ATDT string ATDT#777
...
 
   

Dialer Dial Out Successfully

The debug cellular trace command output provides the following output:

...
2008 Mar 12 03:10:52.600975 dialer: Dialer1 dial out cellular3/1 successfully
...
 
   

Call Connect Successfully

The debug cellular trace command output provides the following output:

...
2008 Mar 12 03:10:52.610970 cellpm: Call Connecting rec'd
2008 Mar 12 03:10:53.519849 cellpm: Call Connected rec'd
...
 
   

Stop Dialer Since Connection is Established

The debug dialer trace command output provides the following output:

...
2008 Mar 12 03:10:53.522327 dialer: Session activated. Dialer1 stop dialing
...
 
   

Start PPP Session

The debug cellpm trace command output provides the following output:

...
2008 Mar 12 03:10:56.533277 cellpm: Send PPP Start MTS for if_index 29100000
...
 
   

PPP Connection Established Successfully

The debug cellpm trace command output provides the following output:

...
2008 Mar 12 03:10:59.620989 cellpm: PPP notify IP address 107.38.152.162
2008 Mar 12 03:10:59.621037 cellpm: interface name ppp0
 
   

Cellular Driver Started

The debug cellular trace command output provides the following output:

...
2008 Mar 12 03:11:00.305943 cellpm: Cellular start driver: ifindex 29100000
... 

Debug Output (GSM Module)

The following is a sample output for a call that is set up using a CHAT script. It shows a received IP address from the network and indicates that the call setup is successful and the data path is open:

Debugs enabled:
deb chat error
deb chat trace
deb dialer error
deb dialer trace
deb cellular error
deb cellular trace
 
   
2012 Mar 9 13:59:12.952936 cellpm: Modem Disabled Status: Enabled
2012 Mar 9 13:59:12.953231 cellpm: Receive modem enabled notification
2012 Mar 9 13:59:12.955038 dialer: Modem Enable on interface 29100000
2012 Mar 9 13:59:12.955160 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 13:59:12.955205 dialer: current modem state is DISABLE
2012 Mar 9 13:59:12.955250 dialer: modem changes from DISABLE to ENABLE
2012 Mar 9 13:59:12.955300 dialer: CHAT SCRIPT gsm profile 1
2012 Mar 9 13:59:12.955346 dialer: Dialer1 is in READY state
2012 Mar 9 13:59:12.955395 dialer: Dial out interface service is not ready yet
2012 Mar 9 13:59:12.960748 cellpm: Plmn Ready: 0
2012 Mar 9 13:59:12.960860 cellpm: SIM Status: SIM Okay
2012 Mar 9 13:59:12.960945 cellpm: Rec'd Modem Radio Power Enable
2012 Mar 9 13:59:12.961311 cellpm: Receive modem enabled notification
2012 Mar 9 13:59:12.964637 dialer: Modem Enable on interface 29100000
2012 Mar 9 13:59:12.964752 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 13:59:12.964802 dialer: current modem state is ENABLE
sg-salta-12(config-if)# 2012 Mar 9 13:59:14.304917 cellpm: Network Service Status: 
Emergency
2012 Mar 9 13:59:14.305279 cellpm: Service Type: 0
2012 Mar 9 13:59:14.305633 cellpm: Registration Indication:
2012 Mar 9 13:59:14.305678 cellpm:
2012 Mar 9 13:59:58.156348 cellpm: Network Service Status: Emergency
2012 Mar 9 13:59:58.156840 cellpm: Service Type: 0
2012 Mar 9 13:59:58.157253 cellpm: Network Service Status: Normal
2012 Mar 9 13:59:58.157295 cellpm: Modem Status Normal notify dialer
2012 Mar 9 13:59:58.157502 cellpm: Send MTS opcode 183299 to sap 776 if_index 29100000
2012 Mar 9 13:59:58.157692 dialer: Modem Enable on interface 29100000
2012 Mar 9 13:59:58.157769 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 13:59:58.157802 dialer: current modem state is ENABLE
2012 Mar 9 13:59:58.160722 cellpm: Send MTS opcode 183317 to sap 776 if_index 29100000
2012 Mar 9 13:59:58.160915 dialer: Modem service is ready for interface 29100000
2012 Mar 9 13:59:58.160965 dialer: timer start #1 if_index 29100000
2012 Mar 9 13:59:58.161004 dialer: Create time for msg 0
2012 Mar 9 13:59:58.161035 dialer: dialer_timer_start start timer
2012 Mar 9 13:59:58.163338 cellpm: Service Type: 6
2012 Mar 9 13:59:58.163777 cellpm: Registration Indication:
2012 Mar 9 13:59:58.163819 cellpm: Network Name; Limited Service
2012 Mar 9 13:59:58.163852 cellpm: Network Name; Ltd Srv
2012 Mar 9 13:59:58.163883 cellpm:
2012 Mar 9 13:59:58.164301 cellpm: Network Service Status: Normal
2012 Mar 9 13:59:58.164343 cellpm: Modem Status Normal notify dialer
2012 Mar 9 13:59:58.164536 cellpm: Send MTS opcode 183299 to sap 776 if_index 29100000
2012 Mar 9 13:59:58.164716 dialer: Modem Enable on interface 29100000
2012 Mar 9 13:59:58.164788 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 13:59:58.164822 dialer: current modem state is ENABLE
2012 Mar 9 13:59:58.167941 cellpm: Send MTS opcode 183317 to sap 776 if_index 2
9100000
2012 Mar 9 13:59:58.168192 dialer: Modem service is ready for interface 29100000
2012 Mar 9 13:59:58.168250 dialer: Dial out timer started already
2012 Mar 9 13:59:58.171015 cellpm: Service Type: 6
2012 Mar 9 13:59:59.329671 cellpm: Network Service Status: Normal
2012 Mar 9 13:59:59.329741 cellpm: Modem Status Normal notify dialer
2012 Mar 9 13:59:59.330002 cellpm: Send MTS opcode 183299 to sap 776 if_index 29100000
2012 Mar 9 13:59:59.330234 dialer: Modem Enable on interface 29100000
2012 Mar 9 13:59:59.330337 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 13:59:59.330388 dialer: current modem state is ENABLE
2012 Mar 9 13:59:59.333237 cellpm: Send MTS opcode 183317 to sap 776 if_index 29100000
2012 Mar 9 13:59:59.333496 dialer: Modem service is ready for interface 29100000
2012 Mar 9 13:59:59.333554 dialer: Dial out timer started already
2012 Mar 9 13:59:59.336185 cellpm: Service Type: 6
2012 Mar 9 13:59:59.336339 cellpm: Registration Indication:
2012 Mar 9 13:59:59.336389 cellpm: Network Name; AT&T
2012 Mar 9 13:59:59.336436 cellpm:
2012 Mar 9 13:59:59.825867 cellpm: Network Service Status: Normal
2012 Mar 9 13:59:59.825922 cellpm: Modem Status Normal notify dialer
2012 Mar 9 13:59:59.826132 cellpm: Send MTS opcode 183299 to sap 776 if_index 29100000
2012 Mar 9 13:59:59.826323 dialer: Modem Enable on interface 29100000
2012 Mar 9 13:59:59.826422 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 13:59:59.826467 dialer: current modem state is ENABLE
2012 Mar 9 13:59:59.829155 cellpm: Send MTS opcode 183317 to sap 776 if_index 29100000
2012 Mar 9 13:59:59.829361 dialer: Modem service is ready for interface 29100000
2012 Mar 9 13:59:59.829405 dialer: Dial out timer started already
2012 Mar 9 13:59:59.831511 cellpm: Service Type: 6
2012 Mar 9 13:59:59.831613 cellpm: Registration Indication:
2012 Mar 9 13:59:59.831648 cellpm: Network Name; AT&T
2012 Mar 9 13:59:59.831681 cellpm:
2012 Mar 9 14:00:03.168981 dialer: timer expired if_index 29100000
2012 Mar 9 14:00:03.169048 dialer: CHAT SCRIPT gsm profile 1
2012 Mar 9 14:00:03.169087 dialer: Dialer1 is in READY state
2012 Mar 9 14:00:03.204955 dialer: timer start #2 if_index 29100000
2012 Mar 9 14:00:03.205014 dialer: Create time for msg 0
2012 Mar 9 14:00:03.205050 dialer: dialer_timer_start start timer
2012 Mar 9 14:00:03.205086 dialer: Dialer1 dial out cellular3/1 successfully
2012 Mar 9 14:00:03.215063 cellpm: Plmn Ready: 0
2012 Mar 9 14:00:04.985692 cellpm: Network Service Status: Normal
2012 Mar 9 14:00:04.985747 cellpm: Modem Status Normal notify dialer
2012 Mar 9 14:00:04.985952 cellpm: Send MTS opcode 183299 to sap 776 if_index 29100000
2012 Mar 9 14:00:04.986139 dialer: Modem Enable on interface 29100000
2012 Mar 9 14:00:04.986212 dialer: Rec'd cellular3/1 modem ENABLE notification
2012 Mar 9 14:00:04.986245 dialer: current modem state is ENABLE
2012 Mar 9 14:00:04.989199 cellpm: Send MTS opcode 183317 to sap 776 if_index 29100000
2012 Mar 9 14:00:04.989399 dialer: Modem service is ready for interface 29100000
2012 Mar 9 14:00:04.989442 dialer: Dial out timer started already
2012 Mar 9 14:00:04.991674 cellpm: Service Type: 7
2012 Mar 9 14:00:05.557275 cellpm: GSM profile 1 is activated
2012 Mar 9 14:00:05.557559 cellpm: Send MTS - PKT SESS ACTIVATED to dialer
2012 Mar 9 14:00:05.557800 dialer: Session activated. Dialer1 stop dialing
2012 Mar 9 14:00:05.558321 cellpm: Rec'd session active notification
2012 Mar 9 14:00:06.267768 cellpm: interface cellular 3/1 IP address 166.129.59.20
2012 Mar 9 14:00:06.268517 cellpm: Cellpm:Going to send port bringup message to qosmgr for 
ifindex 29100000

Debug Output (CDMA Module)

The following is debug output for key steps while establishing a successful connection.

2008 Mar 12 03:10:46.519360 cellpm: Rec'd Modem Radio Power Enable 
2008 Mar 12 03:10:46.519698 cellpm: Receive modem enabled notification 
2008 Mar 12 03:10:46.519370 cellpm: Cellpm:Going to send port bringup message to qosmgr 
2008 Mar 12 03:10:46.520230 dialer: Modem Enable on interface 29100000 
2008 Mar 12 03:10:46.520335 dialer: Rec'd cellular3/1 modem ENABLE notification  
2008 Mar 12 03:10:46.520388 dialer: current modem state is DISABLE 
2008 Mar 12 03:10:46.520435 dialer: modem changes from DISABLE to ENABLE 
2008 Mar 12 03:10:46.520486 dialer: CHAT SCRIPT cdma ATDT string ATDT#777 
2008 Mar 12 03:10:46.520533 dialer: Dialer1 is in READY state 
2008 Mar 12 03:10:46.520570 cellpm: Report modem available
2008 Mar 12 03:10:46.644498 cellpm: RSSI hdr_srv_state: No Service 
2008 Mar 12 03:10:46.775658 cellpm: Channel State: 5 
2008 Mar 12 03:10:46.775716 cellpm: Scan 
2008 Mar 12 03:10:47.467059 cellpm: Channel State: 1 
2008 Mar 12 03:10:47.467117 cellpm: Aquired 
2008 Mar 12 03:10:47.528183 dialer: No EVDO Service 
2008 Mar 12 03:10:47.538327 dialer: CDMA Digital Service 
2008 Mar 12 03:10:47.538374 dialer: num_service_check 0 
2008 Mar 12 03:10:47.538408 dialer: EVDO is not ready, CDMA is  ready 
2008 Mar 12 03:10:47.538468 dialer: timer start #1 if_index 29100000 
2008 Mar 12 03:10:47.538508 dialer: Create time for msg 0 
2008 Mar 12 03:10:47.538542 dialer: dialer_timer_start start timer 
2008 Mar 12 03:10:47.538578 dialer: Dial out interface service is not ready yet 
2008 Mar 12 03:10:47.538860 dialer: air service available - if_index 29100000 
2008 Mar 12 03:10:47.538904 dialer: CHAT SCRIPT cdma ATDT string ATDT#777 
2008 Mar 12 03:10:47.538939 dialer: Dialer1 is in PENDING state 
2008 Mar 12 03:10:48.325223 cellpm: Service Indication State: 2 
2008 Mar 12 03:10:48.325469 cellpm: Send MTS opcode 183317 to sap 776 if_index 29100000 
2008 Mar 12 03:10:48.327789 cellpm: Digital Service 
2008 Mar 12 03:10:48.327909 cellpm: EVDO/HDR Service State: 0 
2008 Mar 12 03:10:48.327960 cellpm: Hdr_srv: No Service 
2008 Mar 12 03:10:48.328043 cellpm: Protocol Revision: 6 
2008 Mar 12 03:10:48.328095 cellpm: CDMA 2000 Rev 0
2008 Mar 12 03:10:48.328176 cellpm: Radio Band: 1 
2008 Mar 12 03:10:48.328228 cellpm: PCS 
2008 Mar 12 03:10:48.328461 dialer: Modem service is ready for interface 29100000 
2008 Mar 12 03:10:48.328522 dialer: Dial out timer started already 
2008 Mar 12 03:10:49.318960 cellpm: Protocol Revision: 6 
2008 Mar 12 03:10:49.319020 cellpm: CDMA 2000 Rev 0 
2008 Mar 12 03:10:49.319399 cellpm: Radio Band: 1 
2008 Mar 12 03:10:49.319445 cellpm: PCS 
2008 Mar 12 03:10:49.570086 cellpm: EVDO/HDR Service State: 4 
2008 Mar 12 03:10:49.570333 cellpm: Send MTS opcode 183317 to sap 776 if_index 29100000 
2008 Mar 12 03:10:49.572369 cellpm: EVDO RevA Service 
2008 Mar 12 03:10:49.572461 cellpm: Protocol Revision: 6 
2008 Mar 12 03:10:49.572517 cellpm: CDMA 2000 Rev 0 
2008 Mar 12 03:10:49.572596 cellpm: Radio Band: 1 
2008 Mar 12 03:10:49.572642 cellpm: PCS 
2008 Mar 12 03:10:49.572855 dialer: Modem service is ready for interface 29100000 
2008 Mar 12 03:10:49.572905 dialer: Dial out timer started already 
2008 Mar 12 03:10:50.322934 cellpm: Protocol Revision: 6 
2008 Mar 12 03:10:50.322994 cellpm: CDMA 2000 Rev 0 
2008 Mar 12 03:10:50.323334 cellpm: Radio Band: 1 
2008 Mar 12 03:10:50.323380 cellpm: PCS
2008 Mar 12 03:10:52.539100 dialer: timer expired if_index 29100000 
2008 Mar 12 03:10:52.539166 dialer: CHAT SCRIPT cdma ATDT string ATDT#777 
2008 Mar 12 03:10:52.539202 dialer: Dialer1 is in READY state 
2008 Mar 12 03:10:52.560359 dialer: EVDO RevA Service 
2008 Mar 12 03:10:52.580554 dialer: CDMA Digital Service 
2008 Mar 12 03:10:52.580601 dialer: num_service_check 1 
2008 Mar 12 03:10:52.580637 dialer: Both EVDO and CDMA are ready 
2008 Mar 12 03:10:52.580667 dialer: Dial out interface service is ready 
2008 Mar 12 03:10:52.600846 dialer: timer start #2 if_index 29100000 
2008 Mar 12 03:10:52.600903 dialer: Create time for msg 0 
2008 Mar 12 03:10:52.600939 dialer: dialer_timer_start start timer 
2008 Mar 12 03:10:52.600975 dialer: Dialer1 dial out cellular3/1 successfully 
2008 Mar 12 03:10:52.610970 cellpm: Call Connecting rec'd  
2008 Mar 12 03:10:53.519849 cellpm: Call Connected rec'd  
2008 Mar 12 03:10:53.520138 cellpm: Send MTS opcode 183297 to sap 776 if_index 29100000 
2008 Mar 12 03:10:53.522327 dialer: Session activated. Dialer1 stop dialing 
2008 Mar 12 03:10:56.533277 cellpm: Send PPP Start MTS for if_index 29100000 
2008 Mar 12 03:10:59.579924 cellpm: Channel State: 5 
2008 Mar 12 03:10:59.579991 cellpm: Scan 
2008 Mar 12 03:10:59.580050 cellpm: Channel State: 1 
2008 Mar 12 03:10:59.580086 cellpm: Aquired 
2008 Mar 12 03:10:59.587827 cellpm: Protocol Revision: 6 
2008 Mar 12 03:10:59.587880 cellpm: CDMA 2000 Rev 0
2008 Mar 12 03:10:59.587940 cellpm: Radio Band: 1 
2008 Mar 12 03:10:59.587976 cellpm: PCS 
2008 Mar 12 03:10:59.620989 cellpm: PPP notify IP address 107.38.152.162 
2008 Mar 12 03:10:59.621037 cellpm: interface name ppp0 
2008 Mar 12 03:10:59.621436 cellpm: ifindex 29100000 
2008 Mar 12 03:11:00.300889 cellpm: interface cellular 3/1 IP address 107.38.152.162 
2008 Mar 12 03:11:00.301243 cellpm: Cellpm:Going to send port bringup message to qosmgr 
for ifindex 29100000 
2008 Mar 12 03:11:00.305705 cellpm: Error setting status LED to OK (22 - Invalid argument) 
2008 Mar 12 03:11:00.305943 cellpm: Cellular start driver: ifindex 29100000
 
   

Retrieving the Electronic Serial Number

If your network provider requests the 11-digit decimal equivalent of your Electronic Serial Number (ESN), you must retrieve your ESN, then convert it to decimal notation. See also, Converting Hexadecimal ESN to Decimal Notation.

The ESN number is located directly on the modem label in hexadecimal notation. It can also be retrieved using the Cisco IOS CLI using the show cellular 3/1 all command.

GSM Module Sample Output

The sample output below shows the IMEI number:

Router# show cellular 3/1 all
 
   
Hardware Information
====================
Modem Firmware Version = T1_0_3_2AP R361 CNSZXD00000061 2011/04/15 17:40:48
Modem Firmware Built = 04/15/11
Modem Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 0123456063
International Mobile Equipment Identity (IMEI) = 353567040032469 <-- Unique identifier for module
Factory Serial Number (FSN) = CC3291006141001
Modem status = Online
Current Modem Temperature = 33 deg C
Current Temperature State = Normal
 
   

CDMA Module Sample Output

The sample output below shows the ESN number:

 
   
Router# show cellular 3/1 all
 
   
Hardware Information
====================
Modem Firmware Version = p2813301
Modem Firmware Built = 06-24-10
Modem Hardware Version = MC5728V Rev 1.0
International Mobile Subscriber Identity (IMSI) = 4082280032
Electronic Serial Number (ESN) = 60D22706 <-- Unique identifier for module
Modem status = Online
Current Modem Temperature = 31 deg C
Current Temperature State = Normal

Converting Hexadecimal ESN to Decimal Notation

If your network provider requests the 11-digit decimal equivalent of your Electronic Serial Number (ESN), you must retrieve your ESN, then convert it to decimal notation. See also, Retrieving the Electronic Serial Number.

To convert the ESN number from hexadecimal notation to decimal notation:


Step 1 Start with the 8-digit HEX ESN # obtained from the label or using the CLI, for example 0x603C9854. This number consists of two parts:

0x60—Serial number

3C9854—Manufacturer's code

Step 2 Convert the manufacturer's code to decimal as shown:

Hexadecimal 0x60 equals decimal 96.

If the decimal value is two digits only, prepend it with a zero to expand it to three digits.

Manufacturer's code is thus 096.

Step 3 Convert the serial number to decimal, as shown in the example below:

Hexadecimal 0x3C9854 equals decimal 3971156.

If the decimal value is less than 8 digits, add enough zeros to make it into an 8 digit number.

Serial number is thus 03971156.

Step 4 To obtain the complete 11-digit decimal ESN, combine the manufacturer code and serial number:

Manufacturer code: 096

Serial #: 03971156

Decimal ESN: 09603971156


Technical Assistance

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html