Cisco ASR 9000 Series Aggregation Services Router Routing Command Reference, Release 5.1.x
RIP Commands
Downloads: This chapterpdf (PDF - 1.67MB) The complete bookPDF (PDF - 13.22MB) | Feedback

RIP Commands

This module describes the commands used to configure and monitor the Routing Information Protocol (RIP).

For detailed information about RIP concepts, configuration tasks, and examples, see the Implementing RIP on Cisco ASR 9000 Series Router module in the Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide.

authentication keychain mode (RIP)

To enable an authentication keychain mechanism on RIP interfaces, use the authentication keychain mode command in interface configuration mode or VRF-interface configuration mode. To disable authentication keychain configuration on RIP interfaces, use the no form of this command.

authentication keychain keychain_name mode { md5 | text }

no authentication keychain keychain_name mode { md5 | text }

Syntax Description

keychain-name
Specifies the name of the keychain configured using the keychain command.
Note   

All keychains need to be configured in Cisco IOS XR keychain database using the keychain configuration commands described in Implementing Keychain Management module of Cisco ASR 9000 Series Aggregation Services Router System Security Configuration Guide

md5

Specifies that the authentication keychain mode is keyed message digest (md5).

text

Specifies that the authentication keychain mode is clear text.

Command Default

Keychain authentication is disabled.

Command Modes

Interface configuration

VRF-interface configuration

Command History

Release Modification

Release 4.0.0

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

All keychains need to be configured in Cisco IOS XR keychain database using the keychain configuration commands described in Implementing Keychain Management module of Cisco ASR 9000 Series Aggregation Services Router System Security Configuration Guide

Task ID

Task ID Operation

rip

read, write

Examples

This example shows how to configure an authentication keychain in md5 mode on a RIP VRF interface:
RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router rip
RP/0/RSP0/CPU0:router(config-rip)#vrf vrf_rip_auth
RP/0/RSP0/CPU0:router(config-rip-vrf)#interface POS 0/6/0/0
RP/0/RSP0/CPU0:router(config-rip-vrf-if)#authentication keychain key1 mode md5

This example shows how to configure an authentication keychain in clear text mode on a RIP interface:
RP/0/RSP0/CPU0:router#configure
RP/0/RSP0/CPU0:router(config)#router rip
RP/0/RSP0/CPU0:router(config-rip)#interface POS 0/6/0/1
RP/0/RSP0/CPU0:router(config-rip-if)#authentication keychain key2 mode text

Related Commands

Command Description

router rip

Configures a routing process and enters router configuration mode for a Routing Information Protocol (RIP) process.

vrf (RIP)

Defines a VPN routing and forwarding (VRF) instance and enters VRF configuration mode.

Refer Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference for complete command reference information.

key chain (key chain)

Creates or modifies a keychain.

Refer Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference for complete command reference information.

key (key chain)

Creates or modifies a keychain key.

Refer Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference for complete command reference information.

key-string (keychain)

Specifies text string for the key.

Refer Cisco ASR 9000 Series Aggregation Services Router System Security Command Reference for complete command reference information.

auto-summary (RIP)

To enable the automatic summarization of subnet routes into network-level routes, use the auto-summary command in the appropriate configuration mode. To disable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no arguments or keywords.

Command Default

Disabled

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the auto-summary command to turn on route summarization. Route summarization reduces the amount of routing information in the routing tables.

Disable automatic summarization if you must perform routing between disconnected subnets. When automatic summarization is off, subnets are advertised. Automatic summarization is disabled by default.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to turn on RIP auto-summarization:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# auto-summary
  
         

Related Commands

Command

Description

vrf (RIP)

Defines a VRF instance and enters VRF configuration mode.

broadcast-for-v2

To send Routing Information Protocol (RIP) Version 2 output packets to a broadcast address, use the broadcast-for-v2 command in the appropriate configuration mode. To disable this feature, use the no form of this command.

broadcast-for-v2

no broadcast-for-v2

Syntax Description

This command has no arguments or keywords.

Command Default

RIPv2 output packets are not broadcasted.

Command Modes

Router configuration

VRF configuration

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the broadcast-for-v2 command to broadcast RIP Version 2 broadcast updates to hosts that do not listen to multicasts. Version 2 updates (requests and responses) will be sent to the IP broadcast address 255.255.255.255 instead of the IP multicast address 244.0.0.9.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to send RIP v2 output messages to a broadcast address for all RIP interfaces:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# broadcast-for-v2
  
         

clear rip

To clear VRF and interface-related information for Routing Information Protocol (RIP) such as database entries and statistics, use the clear rip command in EXEC configuration mode.

clear rip [ vrf { vrf | all } ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

Command Default

No default behavior or values

Command Modes

EXEC configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

RIP VRFs and interfaces that are forcibly deactivated by the software because of a severe memory state are not activated again until the out-of-memory state is cleared by using the clear rip , clear rip interface , or clear rip out-of-memory command.

Task ID

Task ID

Operations

rip

read

Examples

The following example shows how to clear all database, interface, and VRF entries in RIP:

RP/0/RSP0/CPU0:routerr# clear rip vrf all
         

Related Commands

Command

Description

clear rip interface

Clears interface-related information for RIP such as database entries and statistics.

clear rip out-of-memory

Clears the out-of-memory state for RIP.

clear rip database

To clear only database entries from the Routing Information Protocol (RIP) topology table, use the clear rip database command in EXEC configuration mode.

clear rip [ vrf { vrf | all } ] database [ interface type interface-path-id ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

interface

(Optional) Specifies the interface to clear topology entries.

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

No default behavior or values

Command Modes

EXEC configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to clear only database entries from the topology table for the GigabitEthernet 0/1/0/0 interface:

RP/0/RSP0/CPU0:router# clear rip database interface GigabitEthernet 0/1/0/0
         

Related Commands

Command

Description

show rip statistics

Displays database and interface entry information for the RIP process.

clear rip interface

To clear interface-related information for Routing Information Protocol (RIP) such as database entries and statistics, use the clear rip interface command in EXEC configuration mode.

clear rip [ vrf { vrf | all } ] interface type interface-path-id

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

interface

Specifies the interface to clear topology entries.

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

No default behavior or values

Command Modes

EXEC configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

RIP VRFs and interfaces that are forcibly deactivated by the software because of a severe memory state are not activated again until after out-of-memory state is cleared by using the clear rip , clear rip interface or c lear rip out-of-memory command.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to clear all interface-related data such as routes and statistics from the GigabitEthernet 0/1/0/0 interface:

RP/0/RSP0/CPU0:router# clear rip vrf vpn-1 interface GigabitEthernet 0/1/0/0
         

Related Commands

Command

Description

clear rip

Clears VRF and interface-related information for RIP such as database entries and statistics.

clear rip out-of-memory

Clears the out-of-memory state for RIP.

clear rip out-of-memory

To clear the out-of-memory state for Routing Information Protocol (RIP), use the clear rip out-of-memory command in EXEC configuration mode.

clear rip [ vrf { vrf | all } ] out-of-memory [ interface type interface-path-id ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

interface

(Optional) Specifies the interface to clear topology entries.

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

No default behavior or values

Command Modes

EXEC configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the clear rip out-of-memory command, to clear the out-of-memory state completely and allow the RIP process to force the VRF or interface to shut down.

When the router begins to run out of memory, the RIP process can transition through different memory states defined as Normal, Minor, Severe, and Critical:

  • In Normal state, RIP VRFs and interfaces function normally.
  • In Minor state, RIP VRFs and interfaces that are currently active are allowed to remain active. VRFs and interfaces that are not currently active are not allowed to become active until the RIP process transitions to Normal state.
  • In Severe state, a few VRFs and interfaces are forcibly brought down periodically until the RIP process transitions to another state.
  • In Critical state, the RIP process is forcibly shut down.

VRFs and interfaces that are forcibly shut down in Severe state are not automatically activated when the RIP process transitions to Minor or Normal state. When a VRF or interface is forcibly brought down while in Severe state, the clear rip , clear rip interface or clear rip out-of-memory command clears the Forced Down state and reactivates the VRF or interface.

The show rip and show rip interface commands allow you to view the current out-of-memory state.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to clear the out-of-memory state for a RIP process:

RP/0/RSP0/CPU0:router# clear rip out-of-memory
         

Related Commands

clear rip

Clears VRF and interface-related information for RIP such as database entries and statistics.

clear rip interface

Clears interface-related information for RIP such as database entries and statistics.

show rip

Displays configuration and status of RIP.

show rip interface

Displays interface entry information from the RIP topology table.

clear rip statistics

To clear the Routing Information Protocol (RIP) statistics, use the clear rip statistics command in EXEC configuration mode.

clear rip [ vrf { vrf | all } ] statistics [ interface type interface-path-id ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

interface

(Optional) Specifies the interface from which to clear topology entries.

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

No default behavior or values

Command Modes

EXEC configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to clear all RIP statistics:

RP/0/RSP0/CPU0:router# clear rip statistics
         

Related Commands

Command

Description

show rip statistics

Displays database and interface entry information for the RIP process.

default-information originate (RIP)

To generate a default route into Routing Information Protocol (RIP), use the default-information originate command in the appropriate configuration mode. To disable a default route into RIP, use the no form of this command.

default-information originate [ route-policy name ]

no default-information originate

Syntax Description

route-policy name

Route policy name that indicates riteria for the default route.

Command Default

This command is disabled by default.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to originate a default route in RIP updates based on the result of running the route policy on the routing table:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# default-information originate route-policy policy1
  
         

Related Commands

Command

Description

route-policy (RIP)

Applies a routing policy to updates advertised to or received from a RIP neighbor.

default-metric (RIP)

To set default metric values for routes redistributed from other protocols into Routing Information Protocol (RIP), use the default-metric command in the appropriate configuration mode. To return to the default state, use the no form of this command.

default-metric number-value

no default-metric

Syntax Description

number-value

Default metric value. Range is 1 to 15.

Command Default

Default metrics are not set.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the default-metric command with the redistribute command to cause RIP to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics by providing a reasonable substitute and enables redistribution to proceed. If you want to set different metrics for other redistributed protocols, use the route-policy option in the redistribute command.

The RIP metric used for redistributed routes is determined by the route policy. If a route policy is not configured or the route policy does not set the RIP metric, the metric is determined based on the redistributed protocol. For VPNv4 routes redistributed by BGP, the RIP metric set at the remote PE router is used, if valid.

In all other cases (BGP, IS-IS, OSPF, EIGRP, connected, static), the metric set by the default-metric command is used. If a valid metric cannot be determined, then redistribution does not happen.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how a router in autonomous system 109 uses both the RIP and the Open Shortest Path First (OSPF) routing protocols. The example advertises OSPF-derived routes using RIP and assigns the OSPF-derived routes a RIP metric of 10:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# default-metric 10
  RP/0/RSP0/CPU0:router(config-rip-vrf)# redistribute ospf 109
  
         

Related Commands

Command

Description

redistribute (RIP)

Redistributes routes from one routing domain into RIP.

distance (RIP)

To define the administrative distance assigned to routes discovered by the Routing Information Protocol (RIP), use the distance admin-distance command in the appropriate configuration mode. To remove the distance definition from the configuration file and restore the system to its default condition, use the no form of this command.

distance admin-distance [ prefix prefix-length | prefix mask ]

no distance admin-distance

Syntax Description

admin-distance

Administrative distance to be assigned to RIP routes. Range is 0 to 255.

prefix

(Optional) Network IP address about which routing information should be displayed.

prefix-length

(Optional) The prefix-length argument specifies the length of the IP prefix. A decimal value that indicates how many of the high-order contiguous bits of the address compose the prefix (the network portion of the address). A slash must precede the decimal value. Range is 0 to 32 for IPv4 addresses.

mask

(Optional) Network mask specified in either of two ways:

  • Network mask can be a four-part, dotted decimal address. For example, 255.0.0.0 indicates that each bit equal to 1 means the corresponding address bit is a network address.
  • Network mask can be indicated as a slash (/) and number. For example, /8 shows that the first 8 bits of the mask are ones, and the corresponding bits of the address are the network address.

Command Default

admin-distance : 120

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the distance command to change the preference of RIP routes over other protocol routes. When administrative distance and redistribution features are used to together, routing behavior may be affected for routes accepted from and advertised to RIP neighbors.

Numerically, an administrative distance is an integer from 0 to 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means that the routing information source cannot be trusted at all and should be ignored.

The order in which you enter distance commands can affect the assigned administrative distances in unexpected ways.

This table lists default administrative distances.

Table 1 Default Administrative Distances of Routing Protocols

Routing Protocol

Administrative Distance Value

Connected interface

0

Static route out an interface

0

Static route to next-hop

1

EIGRP Summary Route

5

External BGP

20

Internal EIGRP

90

OSPF

110

IS-IS

115

RIP Versions 1 and 2

120

External EIGRP

170

Internal BGP

200

Unknown

255

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to set the administrative distance for a particular prefix:

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# distance 85 192.168.10.0/24

Related Commands

Command

Description

redistribute (RIP)

Redistributes routes from one routing domain into RIP.

interface (RIP)

To define the interfaces on which the Routing Information Protocol (RIP) runs and enter interface configuration mode, use the interface command in router configuration mode. To disable RIP routing for interfaces, use the no form of this command.

interface type interface-path-id

no interface type interface-path-id

Syntax Description

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or a virtual :interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

When you do not specify this command in configuration mode, RIP routing for interfaces is not enabled.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the interface command to associate a specific interface with a RIP process. The interface remains associated with the process even when the IPv4 address of the interface changes.

This command places the router in interface configuration mode, from which you can configure interface-specific settings. Commands configured under this mode (such as the broadcast-for-v2 command) are automatically bound to that interface.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to enter interface configuration mode for a RIP process, and send RIP Version 2 messages to the broadcast address on the GigabitEthernet interface 0/1/0/0:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# ?
  
    broadcast-for-v2    Specify broadcast address for RIP v2 output packet
    commit              Commit the configuration changes to running
    describe            Describe a command without taking real actions
    do                  Run an exec command
    exit                Exit from this submode
    metric-zero-accept  Accept rip update with metric 0 to compensate a common bug
    no                  Negate a command or set its defaults
    passive-interface   Suppress routing updates on this interface
    poison-reverse      Enable poison reverse
    receive             Advertisement reception
    route-policy        Apply route policy to routing updates
    send                Advertisement transmission
    show                Show contents of configuration
    site-of-origin      SOO community for prefixes learned over this interface
    split-horizon       Disable split horizon
  RP/0/RSP0/CPU0:router(config-rip-if)# broadcast-for-v2
  
         

Related Commands

Command

Description

broadcast-for-v2

Sends RIP Version 2 output packets to a broadcast address.

maximum-paths (RIP)

To configure the maximum number of equal cost parallel routes that the Routing Information Protocol (RIP) will install into the routing table, use the maximum-paths command in the appropriate configuration mode. To remove the maximum-paths command from the configuration file and restore the system to its default condition with respect to RIP, use the no form of this command.

maximum-paths maximum

no maximum-paths

Syntax Description

maximum

Maximum number of parallel routes that RIP can install in a routing table. Range is 1 to 32..

Command Default

4 paths

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to allow a maximum of 16 equal cost paths to a destination:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# maximum-paths 16
  
         

metric-zero-accept

To allow RIP to accept routing entries from RIP updates with a metric set to zero (0), use the metric-zero-accept command in interface configuration mode. To remove the metric-zero-accept command from the configuration file and restore the system to its default condition with respect to RIP, use the no form of this command.

metric-zero-accept

no metric-zero-accept

Syntax Description

This command has no arguments or keywords.

Command Default

RIP routes received with a metric of zero (0) are ignored.

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

After the metric-zero-accept command is configured on routing entries from RIP updates, RIP accepts these routes and then sets the metric to one (1).

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to set the RIP interface to accept metric zero on routing entries:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# metro-zero-accept
  
         

neighbor (RIP)

To define a neighboring router with which to exchange Routing Information Protocol (RIP) information, use the neighbor command in the appropriate configuration mode. To remove an entry, use the no form of this command.

neighbor ip-address

no neighbor ip-address

Syntax Description

ip-address

IP address of a peer router with which routing information is exchanged.

Command Default

No neighboring routers are defined.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the neighbor command to permit the point-to-point (nonbroadcast) exchange of routing information. When the neighbor command is used in combination with the passive-interface command in router configuration mode, routing information can be exchanged between a subset of routers and access servers on a LAN.

Multiple neighbor commands can be used to specify additional neighbors or peers.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to permit the sending of RIP updates to specific neighbors. One copy of the update is generated per neighbor:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# neighbor 172.16.1.2
  
         

Related Commands

Command

Description

passive-interface (RIP)

Suppresses the sending of RIP updates on an interface.

nsf (RIP)

To configure nonstop forwarding (NSF) on Routing Information Protocol (RIP) routes after a RIP process shutdown or restart, use the nsf command in the appropriate configuration mode. To remove this command from the configuration file and restore the system to its default condition, use the no form of this command.

nsf

no nsf

Syntax Description

This command has no arguments or keywords.

Command Default

NSF is disabled.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

When you use the nsf command, NSF lifetime is automatically set to two times the update time (with a minimum value of 60 seconds). The RIP process must reconverge within this time. If the convergence exceeds the NSF lifetime, routes are purged from the Routing Information Base (RIB) and NSF may fail.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to configure RIP NSF:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# nsf
  
         

output-delay

To change the interpacket delay for Routing Information Protocol (RIP) updates sent, use the output-delay command in the appropriate configuration mode. To remove the delay, use the no form of this command.

output-delay delay

no output-delay delay

Syntax Description

delay

Delay (in milliseconds) between consecutive packets in a multiple-packet RIP update. The range is from 8 to 50.

Command Default

The default is no delay.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the output-delay command if you are sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command helps prevent the routing table from losing information.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to set the interpacket delay to 10 milliseconds:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
  RP/0/RSP0/CPU0:router(config-rip-vrf)# output-delay 10
  
         

passive-interface (RIP)

To suppress the sending of Routing Information Protocol (RIP) updates on an interface, use the passive-interface command in interface configuration mode. To unsuppress updates, use the no form of this command.

passive-interface

no passive-interface

Syntax Description

This command has no arguments or keywords.

Command Default

RIP updates are sent on the interface.

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

While RIP stops sending routing updates to the multicast (or broadcast) address on a passive interface, RIP continues to receive and process routing updates from its neighbors on that interface.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows that GigabitEthernet interface 0/1/0/0 stops multicasting (or broadcasting) RIP updates while continuing to receive RIP updates normally. GigabitEthernet interface 0/1/0/3 sends and receives updates normally. Also RIP updates are unicast to neighbor 172.168.1.2 over the appropriate interface:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# neighbor 172.16.1.2
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# passive-interface
  RP/0/RSP0/CPU0:router(config-rip-if)# exit
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/3
  RP/0/RSP0/CPU0:router(config-rip-if)# exit
  
         

Related Commands

Command

Description

neighbor (RIP)

Defines a neighboring router with which to exchange RIP protocol information.

poison-reverse

To enable poison reverse processing of Routing Information Protocol (RIP) router updates, use the poison-reverse command in interface configuration mode. To disable poison reverse processing of RIP updates, use the no form of this command.

poison-reverse

no poison-reverse

Syntax Description

This command has no arguments or keywords.

Command Default

Poison reverse processing is disabled.

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Route poisoning prevents routing loops by communicating to other routers that a route is no longer reachable, effectively removing these routes from other router's routing tables. The system default, split horizon , provides that routes learned through RIP are not advertised from the interface over which they were learned.

The poison-reverse command enables poison reverse processing of RIP router updates. A router that receives route poisoning information sends the poisoning information back to the sending router, a process called poison reverse. This process ensures that all routers on the same interface have received the poisoned route information.

If both poison- reverse and split horizon are configured, then simple split horizon behavior (suppression of routes from the interface over which they were learned) is replaced by poison reverse behavior. If split horizon is disabled, the poison reverse configuration is ignored.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to enable poison reverse processing for an interface running RIP:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# poison-reverse
  
         

Related Commands

Command

Description

split-horizon disable (RIP)

Disables the split horizon mechanism.

receive version

To configure the Routing Information Protocol (RIP) interface to accept version-specific packets, use the receive version command in interface configuration mode. To revert to the default setting, use the no form of this command.

receive version { 1 | 2 | 1 2 }

no receive version { 1 | 2 | 1 2 }

Syntax Description

1

Version 1 packets.

2

Version 2 packets.

1 2

Both versions 1 and 2 packets.

Command Default

Version 2

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the receive version command to override the default behavior of RIP. This command applies only to the interface being configured.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to configure an interface to accept both RIP Version 1 and 2 packets:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# receive version 1 2
  
         

Related Commands

Command

Description

send version

Configures the RIP interface to send version specific packets.

redistribute (RIP)

To redistribute routes from another routing domain into Routing Information Protocol (RIP), use the redistribute command in the appropriate configuration mode. To remove the redistribute command from the configuration file and restore the system to its default condition in which the software does not redistribute routes, use the no form of this command.

Border Gateway Protocol (BGP)

redistribute bgp process-id [ route-policy name ] [ external | internal | local ]

no redistribute bgp process-id

Connected Interface Routes

redistribute connected [ route-policy name ]

no redistribute connected

Enhanced Interior Gateway Routing Protocol (EIGRP)

redistribute eigrp process-id [ route-policy name ]

no redistribute eigrp process-id

Intermediate System-to-Intermediate System (ISIS)

redistribute isis process-id [ route-policy name ] [ level-1 | level-1-2 | level-2 ]

no redistribute isis process-id

Open Shortest Path First (OSPF)

redistribute ospf process-id [ route-policy name ] [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ] } ]

no redistribute ospf process-id

IP Static Routes

redistribute static [ route-policy name ]

no redistribute static

Syntax Description

bgp

Distributes routes from the BGP protocol.

process-id

  • For the bgp keyword:
    • Range for 2-byte Autonomous system numbers (ASNs) is 1 to 65535.
    • Range for 4-byte Autonomous system numbers (ASNs) in asplain format is 1 to 4294967295.
    • Range for 4-byte Autonomous system numbers (ASNs) is asdot format is 1.0 to 65535.65535.
  • For the eigrp keyword, an EIGRP instance name from which routes are to be redistributed. The value takes the form of a string. A decimal number can be entered, but it is stored internally as a string.
  • For the isis keyword, an IS-IS instance name from which routes are to be redistributed. The value takes the form of a string. A decimal number can be entered, but it is stored internally as a string.
  • For the ospf keyword, an OSPF instance name from which routes are to be redistributed. The value takes the form of a string. A decimal number can be entered, but it is stored internally as a string.

external

(Optional) Specifies BGP external routes only.

internal

(Optional) Specifies BGP internal routes only.

local

(Optional) Specifies BGP local routes only.

route-policy name

(Optional) Specifies the identifier of a configured policy. A policy is used to filter the importation of routes from this source routing protocol to RIP.

level-1

(Optional) Redistributes Level 1 IS-IS routes into other routing protocols independently.

level-1-2

(Optional) Distributes both Level 1 and Level 2 IS-IS routes into other routing protocols.

level-2

(Optional) Distributes Level 2 IS-IS routes into other routing protocols independently.

[ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]]} [ route-policy name ]

(Optional) Specifies the criteria by which OSPF routes are redistributed into other routing domains. It can be one or more of the following:

  • internal —Routes that are internal to a specific autonomous system (intra- and inter-area OSPF routes).
  • external [ 1 | 2 ]—Routes that are external to the autonomous system, but are imported into OSPF as Type 1 or Type 2 external routes.
  • nssa-external [ 1 | 2 ]—Routes that are external to the autonomous system, but are imported into OSPF as Type 1 or Type 2 not-so-stubby area (NSSA) external routes.

For the external and nssa-external options, if a type is not specified, then both Type 1 and Type 2 are assumed.

If no match is specified, the default is no filtering.

static

Redistributes IP static routes.

Command Default

Route redistribution is disabled.

Command Modes

Router configuration

VRF configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Release 3.9.0

Asplain format for 4-byte Autonomous system numbers notation was supported.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.


Note


When you are redistributing routes (into RIP) using both command keywords for setting or matching of attributes and a route policy, the routes are run through the route policy first, followed by the keyword matching and setting.


Redistributed routing information may be filtered by the route-policy name keyword and argument. This filtering ensures that only those routes intended by the administrator are redistributed by RIP.

The RIP metric used for redistributed routes is determined by the route policy. If a route policy is not configured or the route policy does not set the RIP metric, the metric is determined based on the redistributed protocol. For VPNv4 routes redistributed by BGP, the RIP metric set at the remote PE router is used, if valid.

In all other cases (BGP, IS-IS, OSPF, EIGRP, connected, static), the metric set by the default-metric command is used. If a valid metric cannot be determined, then redistribution does not happen.

For information about routing policies, see the Routing Policy Commands on Cisco ASR 9000 Series Router module of the Cisco ASR 9000 Series Aggregation Services Router Routing Command Reference.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to cause BGP routes to be redistributed into a RIP process:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# redistribute bgp 100
  
         

Related Commands

Command

Description

default-metric (RIP)

Sets default metric values for routes redistributed from other protocols into RIP.

router rip

To configure a routing process and enter router configuration mode for a Routing Information Protocol (RIP) process, use the router rip command in global configuration mode. To turn off the RIP routing process, use the no form of this command.

router rip

no router rip

Syntax Description

This command has no arguments or keywords.

Command Default

No router process is defined.

Command Modes

Global configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to configure a router process for RIP:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# 
  
  

The following example shows how to enter router configuration mode for RIP and identify commands that can be issued from that mode.

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# ?
  
    auto-summary            Enable automatic network number summarization
    broadcast-for-v2        Send RIP v2 output packets to broadcast address
    commit                  Commit the configuration changes to running
    default-information     Control distribution of default information
    default-metric          Set metric of redistributed routes
    describe                Describe a command without taking real actions
    distance                Define an administrative distance
    do                      Run an exec command
    exit                    Exit from this submode
    interface               Enter the RIP interface configuration submode
    maximum-paths           Maximum number of paths allowed per route
    neighbor                Specify a neighbor router
    no                      Negate a command or set its defaults
    nsf                     Enable Cisco Non Stop Forwarding
    output-delay            Interpacket delay for RIP updates
    redistribute            Redistribute information from another routing protocol
    route-policy            Apply route policy to routing updates
    show                    Show contents of configuration
    timers                  Adjust routing timers
    validate-update-source  Validate source address of routing updates
    vrf                     Enter the RIP vrf configuration submode
  RP/0/RSP0/CPU0:router(config-rip)#
  

route-policy (RIP)

To apply a routing policy to updates advertised to or received from a Routing Information Protocol (RIP) neighbor, use the route-policy command in the appropriate configuration mode. To disable applying routing policy to updates, use the no form of this command.

route-policy name { in | out }

no route-policy name { in | out }

Syntax Description

name

Name of route policy.

in

Applies policy to inbound routes.

out

Applies policy to outbound routes.

Command Default

No policy is applied.

Command Modes

Router configuration

VRF configuration

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the route-policy command to specify a routing policy for an inbound or outbound route. The policy can be used to filter routes or modify route attributes.


Note


If a route policy is configured both on the interface and on the VRF, the interface route policy is applied.


Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to filter routing updates received on an interface:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# route-policy updpol-1 in
  
         

send version

To configure the Routing Information Protocol (RIP) interface to send version specific packets, use the send version command in interface configuration mode. To revert to the default setting, use the no form of this command.

send version { 1 | 2 | 1 2 }

no send version { 1 | 2 | 1 2 }

Syntax Description

1

Version 1 packets.

2

Version 2 packets.

1 2

Both Version 1 and Version 2 packets.

Command Default

Version 2

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the send version command to override the default behavior of RIP. This command applies only to the interface being configured.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to configure an interface to send only RIP Version 2 packets:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# send version 2
  
  
         

Related Commands

Command

Description

receive version

Configures the RIP interface to accept version-specific packets.

show protocols (RIP)

To display information about the Routing Information Protocol (RIP) process configuration, use the show protocols command in EXEC mode.

show protocols [ ipv4 | afi-all ] [ all | protocol ] [ default-context | vrf vrf-name ] [private]

Syntax Description

ipv4

(Optional) Specifies an IPv4 address family.

afi-all

(Optional) Specifies all address families.

all

(Optional) Specifies all protocols for a given address family.

protocol

(Optional) Specifies a routing protocol.

  • For the IPv4 address family, the options are eigrp , bgp , isis , ospf , and rip .

default-context

(Optional) Displays default context information. This keyword is available when the eigrp or rip protocol is specified.

vrf vrf-name

(Optional) Displays VPN routing and forwarding (VRF) information for the specified process. This keyword is available when the eigrp or rip protocol is specified.

private

(Optional) Displays private EIGRP data. This keyword is available when the eigrp protocol is specified.

Command Modes

EXEC

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the show protocols command to get information about the protocols running on the router and to quickly determine which protocols are active. The command summarizes the important characteristics of the running protocol, and command output varies depending on the specific protocol selected.

For RIP, the command output lists the instance number, default AS context, router ID, default networks, distance, maximum paths, and so on.

Task ID

Task ID

Operations

RIP

read

Examples

The following is sample output from the show protocols rip command:

  RP/0/RSP0/CPU0:router# show protocols rip
  Routing Protocol RIP
    2 VRFs (including default) configured, 2 active
    25 routes, 16 paths have been allocated
    Current OOM state is "Normal"
    UDP socket descriptor is 37
      VRF              Active   If-config If-active Routes     Paths      Updates
      default          Active   3         3         11         7              30s
  
  

This table describes the significant fields shown in the display.



Table 2 show protocols Field Descriptions

Field

Description

VRFs configured

Number of VRFs configured.

VRFs active

Number of active VRFs.

Routes

Number of allocated routes.

Paths

Number of allocated paths.

OOM state

Current out-of-memory state of RIP process.

UDP socket

Current UDP socket descriptor value.

show rip

To display configuration and status of Routing Information Protocol (RIP), use the show rip command in EXEC mode.

show rip [ vrf { vrf | all } ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

Command Default

No default behavior or values

Command Modes

EXEC

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read

Examples

The following example shows sample output from the show rip command:

  RP/0/RSP0/CPU0:router# show rip
  
  RIP config:
  Active?:                    Yes
  Added to socket?:           Yes
  Out-of-memory state:        Normal
  Version:                    2
  Default metric:             Not set
  Maximum paths:              4
  Auto summarize?:            No
  Broadcast for V2?:          No
  Packet source validation?:  Yes
  NSF:                        Disabled
  Timers: Update:             30 seconds (25 seconds until next update)
          Invalid:            180 seconds
          Holddown:           180 seconds
          Flush:              240 seconds

This table describes the significant fields shown in the display.



Table 3 show rip Field Descriptions

Field

Description

Active?

Active state setting.

Added to socket?

Multicast group setting on RIP configured interfaces. If yes, updates are received on these interfaces.

Out-of-memory state

Out-of-memory state for RIP can be one of the following: Normal, Minor, Severe, or Critical.

Version

Version number is 2.

Default metric

Default metric value, if configured. Otherwise Not set.

Maximum paths

Number of maximum paths allowed per RIP route.

Auto summarize?

Auto-summarize state setting.

Broadcast for V2?

RIP Version 2 broadcast setting.

Packet source validation?

Validation setting for the source IP address of incoming routing updates to RIP.

Timers

RIP network timer settings.

show rip database

To display database entry information from the Routing Information Protocol (RIP) topology table, use the show rip database command in EXEC mode.

show rip [ vrf { vrf | all } ] database [ prefix prefix-length | prefix mask ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

prefix

(Optional) Network IP address about which routing information should be displayed.

prefix-length

(Optional) The prefix-length argument specifies the length of the IP prefix. A decimal value that indicates how many of the high-order contiguous bits of the address compose the prefix (the network portion of the address). A slash between must precede the decimal value. Range is 0 to 32 for IPv4 addresses.

prefix-mask

(Optional) Network mask specified in either of two ways:

  • Network mask can be a four-part, dotted decimal address. For example, 255.0.0.0 indicates that each bit equal to 1 means the corresponding address bit is a network address.
  • Network mask can be indicated as a slash (/) and number. For example, /8 shows that the first 8 bits of the mask are ones, and the corresponding bits of the address are the network address.

Command Default

No default behavior or values

Command Modes

EXEC

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Summary address entries appear in the database only if relevant child routes are summarized. When the last child route for a summary address becomes invalid, the summary address is also removed from the routing table.

Task ID

Task ID

Operations

rip

read

Examples

The following is sample output from the show rip database command:

  RP/0/RSP0/CPU0:router# show rip database
  
  Routes held in RIP's topology database:
      10.0.0.0/24
          [0]    directly connected, GigabitEthernet0/6/0/0
      10.0.0.0/8    auto-summary
      12.0.0.0/24
          [5] distance: 20    redistributed
      12.0.0.0/8    auto-summary
      50.50.0.0/24
          [1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0
      50.50.1.0/24 (inactive)
          [1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0
      50.0.0.0/8    auto-summary
      90.90.0.0/24
          [5] distance: 20    redistributed
      90.90.1.0/24
          [5] distance: 20    redistributed
  
  

This table describes the significant fields shown in the display.



Table 4 show rip database Field Descriptions

Field

Description

10.0.0.0/24

[0] directly connected, GigabitEthernet0/6/0/0

Prefix and prefix length for a RIP connected route.

10.0.0.0/24 is directly connected to GigabitEthernet 0/6/0/0. The [0] represents the metric.

10.0.0.0/8 auto-summary

10.0.0.0/8 is a summary route entry.

12.0.0.0/24

[5] distance: 20 redistributed

12.0.0.0/24 is a redistributed route. The metric is 5, and the distance is 20.

50.50.0.0/24

[1] via 10.0.0.20, next-hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0

The destination route 50.50.0.0/24 is learned through RIP, and the source 10.0.0.20 advertised it from GigabitEthernet 0/6/0/0. The route was last updated one second ago.

50.50.1.0/24 (inactive)

[1] via 10.0.0.20, next hop 10.0.0.20, Uptime: 1s, GigabitEthernet0/6/0/0

The destination route 50.50.1.0/24 is not active in the routing table.

show rip interface

To display interface entry information from the Routing Information Protocol (RIP) topology table, use the show rip interfacecommand in EXEC mode.

show rip [ vrf { vrf | all } ] interface [ type interface-path-id ]

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

interface

(Optional) Specifies the interface from which to clear topology entries.

type

Interface type. For more information, use the question mark ( ? ) online help function.

interface-path-id

Physical interface or virtual interface.

Note   

Use the show interfaces command to see a list of all interfaces currently configured on the router.

For more information about the syntax for the router, use the question mark ( ? ) online help function.

Command Default

No default behavior or values

Command Modes

EXEC

Command History

Release

Modification

Release 4.0.0

The command output was modified to include authentication keychain configuration information.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read

Examples

This example is sample output from the show rip interface command:

  RP/0/RSP0/CPU0:router# show rip interface
  
  GigabitEthernet0_6_0_0 
  Rip enabled?:               Yes
  Out-of-memory state:        Normal
  Broadcast for V2:           No
  Accept Metric 0?:           No
  Send versions:              2
  Receive versions:           2
  Interface state:            Up
  IP address:                 10.0.0.12/24
  Metric Cost:                0
  Split horizon:              Enabled
  Poison Reverse:             Disabled
  Joined multicast group?:    Yes
  
  GigabitEthernet0_6_0_2 
  Out-of-memory state:        Normal
  Rip enabled?:               Yes
  Broadcast for V2:           No
  Accept Metric 0?:           No
  Send versions:              2
  Receive versions:           2
  Interface state:            Up
  IP address:                 12.0.0.12/24
  Metric Cost:                0
  Split horizon:              Enabled
  Poison Reverse:             Disabled
  Joined multicast group?:    Yes 
  
  RIP peers attached to this interface:
      12.0.0.13
          uptime: 3    version: 2
          packets discarded: 0    routes discarded: 402
  
  

This table describes the significant fields shown in the display.



Table 5 show rip interface Field Descriptions

Field

Description

Rip enabled?

Specifies whether the RIP routing protocol is enabled on the interface.

Out-of-memory state

Specifies the current out-of-memory state on the interface.

Broadcast for V2

Specifies whether RIP Version 2 output packets are sent to a broadcast address on the interface.

Accept Metric 0?

Specifies whether this interface accepts routing entries from RIP updates with a metric set to zero (0).

Send versions:

Specifies which version RIP uses to send out packets on this interface.

Receive versions:

Specifies which version packets RIP accepts on this interface.

Interface state:

Specifies whether the interface is in an up or a down state.

IP address:

IP address of the interface.

Metric Cost:

Specifies metric cost value.

Split horizon:

Specifies whether split horizon is enabled on this interface.

Poison Reverse:

Specifies whether poison reverse is enabled on this interface.

Joined multicast group?:

Specifies whether the interface has joined the RIP multicast group 224.0.0.9.

RIP peers attached to this interface

12.0.0.13

List of RIP neighbors on this interface.

uptime: 3

Specifies how long this neighbor is up.

version: 2

Specifies which version packets are received from this neighbor.

packets discarded: 0

Specifies the number of packets discarded from this neighbor.

routes discarded: 402

Specifies the number of routes discarded from this neighbor.

Authentication Keychain Configuration for RIP Interface on Default VRF

These examples are output of the show rip interface interface-path-id command to display authentication keychain configuration for RIP interface on default VRF.

When an existing keychain with MD5 cryptographic algorithm was configured on the RIP interface:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No
 Authentication mode: MD5  Key chain: <key-chain-name>  
 Current active send  key id: <send key id>
 Current active receive key id: <recv key id>
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>

When the keychain configured on the RIP interface does not exists or does not have any active keys:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No
  
 Authentication mode: MD5  Key chain: <key-chain-name>     
 No active key found  in keychain database.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
When an active key exists in the keychain configured on the RIP interface, but not configured with MD5 cryptographic algorithm:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No
 
 Authentication mode: MD5  Key chain: <key-chain-name>     
 Key(s) not configured with MD5 cryptographic algorithm.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>

When no authentication keychain was configured on the RIP interface:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
 LPTS filter set?:           No
 
Authentication mode is not set.
 Packets received: <num-rx-packets>

Authentication keychain Configuration for RIP Interface on Non-default VRF

These examples are output of the show rip vrf vrf-name interface interface-path-id command to display authentication keychain configuration for RIP interface on a non- default VRF.

When an existing keychain with MD5 cryptographic algorithm has been configured on the RIP interface:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:                2
Receive versions:           2
Interface state:             Unknown State
IP address:                   0.0.0.0/0
Metric Cost:                0
Split horizon:                Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode: MD5  Key chain: <key-chain-name>     
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
When the keychain configured on the RIP interface does not exist or does not have any active keys:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode: MD5  Key chain: <key-chain-name>     
 No active key found  in keychain database.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
When an active key exists in the keychain configured on the RIP interface, but not configured with MD5 cryptographic algorithm:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode: MD5  Key chain: <key-chain-name>     
 Key(s) not configured with MD5 cryptographic algorithm.
 Packets received: <num-rx-packets>
 Authenticated packets received: <num-auth-rx-packets>
 Packets dropped due to wrong keychain config: <num-rx-wrong-auth-cfg-pkts>
 Packets received without authentication data: <num-rx-auth-missing-pkt>
 Packets received with invalid authentication: <num-rx-invalid-auth-pkt>
When no authentication keychain has been configured on the RIP interface:

GigabitEthernet0/3/0/3 (Forward Reference)
Rip enabled?:               No
Out-of-memory state:        Normal
Broadcast for V2:           No
Accept Metric 0?:           No
Send versions:              2
Receive versions:           2
Interface state:            Unknown State
IP address:                 0.0.0.0/0
Metric Cost:                0
Split horizon:              Enabled
Poison Reverse:             Disabled
Socket set options:
Joined multicast group?:    No
LPTS filter set?:           No

 Authentication mode is not set.
 Packets received: <num-rx-packets>
This table describes the significant fields shown in the display.

Table 6 show rip [vrf <vrf-name>] interface Field Descriptions

Authentication mode: MD5 Key chain

MD5 authentication mode is enabled.

Current active send key id

Active send key ID.

Current active receive key id

Active receive key ID.

Packets received

Number of packets received on the interface.

Authenticated packets received

Number packets received with valid authentication.

Packets dropped due to wrong keychain config

Number of packets dropped due to wrong keychain configuration.

Packets received without authentication data

Number packets received without authentication data .

Packets received with invalid authentication

Number of packets received with invalid authentication.

No active key found in keychain database

No active keys are available in IOS XR keychain database.

Key(s) not configured with MD5 cryptographic algorithm

Keys are not configured with MD5 cryptographic algorithm.

Authentication mode is not set

Authentication mode is not set.

show rip statistics

To display statistical entry information from the Routing Information Protocol (RIP) topology table, use the show rip statistics command in EXEC mode.

show rip [ vrf { vrf | all } ] statistics

Syntax Description

vrf { vrf | all }

(Optional) Specifies a particular VPN routing and forwarding (VRF) instance or all VRF instances.

Command Default

No default behavior or values

Command Modes

EXEC

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Task ID

Task ID

Operations

rip

read

Examples

The following example is sample output from the show rip statistics command:

  RP/0/RSP0/CPU0:router# show rip statistics
  
  RIP statistics:
      Total messages sent:        5597
      Message send failures:      0
      Regular updates sent:       5566
      Queries responsed to:       0
      RIB updates:                6
      Total packets received:     5743
      Discarded packets:          0
      Discarded routes:           0
      Number of routes allocated: 18
      Number of paths allocated:  14
  
      Route malloc failures:      0
      Path malloc failures:       0 
  
  

This table describes the significant fields shown in the display.



Table 7 show rip statistics Field Descriptions

Field

Description

Total messages sent

Number of RIP packets sent.

Message send failures

Number of times that the packet send operation failed.

Queries responsed to

Number of times RIP updates are sent in response to a RIP query.

RIB updates

Number of route addition and deletion messages sent to RIB.

Total packets received

Number of RIP packets received.

Discarded packets

Number of received RIP packets that are discarded.

Discarded routes

Number of routes (in received RIP update packets) that are discarded.

Number of routes allocated

Number of routes allocated for the RIP internal topology database.

Number of paths allocated

Number of paths allocated for the RIP internal topology database.

Route malloc failures

Number of failures during route allocation.

Path malloc failures

Number of failures during route allocation.


Note


The number of routes found in the allocated field might ot be the same number of routes present in the RIP database.


site-of-origin (RIP)

To configure the Site of Origin (SoO) filtering on a Routing Information Protocol (RIP) interface, use the site-of-origin command in interface configuration mode. To disable SoO filtering on an interface, use the no form of this command.

site-of-origin { as-number : number | ip-address : number }

no site-of-origin { as-number : number | ip-address : number }

Syntax Description

as-number :

Autonomous system number.

  • Range for 2-byte Autonomous system numbers (ASNs) is 1 to 65535.
  • Range for 4-byte Autonomous system numbers (ASNs) in asplain format is 1 to 4294967295.
  • Range for 4-byte Autonomous system numbers (ASNs) is asdot format is 1.0 to 65535.65535.

A colon is used to separate the autonomous system number and network number.

number

Network number. Range is from 0 to 4294967295 when a 2-byte AS number is used. Range is from 0 to 65535 when a 4-byte AS number is used.

ip-address

The IP address argument specifies the IP address in four-part, dotted-decimal notation.

A colon is used to separate the IP address and network number.

Command Default

No default behavior or values

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Release 3.9.0

Asplain format for 4-byte Autonomous system numbers notation was supported.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

A RIP process must be capable of retrieving the SoO attribute on routes redistributed from the Border Gateway Protocol (BGP) when required to support complex topologies that include MPLS VPN links between sites with backdoor links.

Use the site-of-origin command to set an SoO BGP extended community attribute that is used to identify routes that have originated from a site so that the readvertisement of that prefix back to the source site can be prevented. The SoO extended community uniquely identifies the site from which a provider edge (PE) router has learned a route.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to configure SoO filtering on a RIP interface:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip) interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# site-of-origin 10.0.0.1:20
  
         

split-horizon disable (RIP)

To disable split horizon for a Routing Information Protocol (RIP) process, use the split-horizon disable command in interface configuration mode. To enable split horizon, use the no form of this command.

split-horizon disable

no split-horizon disable

Syntax Description

This command has no arguments or keywords.

Command Default

Split horizon is enabled for a RIP process.

Command Modes

Interface configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

You can explicitly specify the split-horizon disable command in your configuration.

If split horizon is disabled, the poison reverse configuration is ignored.


Note


In general, we recommend that you do not change the default state of split horizon unless you are certain that your application requires the change to properly advertise routes.


Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to disable split horizon on a Packet-over-SONET/SDH link:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip)# interface GigabitEthernet 0/1/0/0
  RP/0/RSP0/CPU0:router(config-rip-if)# split-horizon disable
  
  
         

Related Commands

Command

Description

poison-reverse

Enables poison reverse processing of RIP router updates.

timers basic

To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the timers default values, use the no form of this command.

timers basic update invalid holddown flush

no timers basic

Syntax Description

update

Rate, in seconds, at which updates are sent. This is the fundamental timing parameter of the routing protocol. Range is 5 to 50000.

invalid

Interval, in seconds, after which a route is declared invalid; it should be at least three times the value of the update argument. A route becomes invalid when there is an absence of updates that refresh the route. The route then enters into a holddown state. The route is marked inaccessible and is advertised as unreachable. Range is 15 to 200000.

holddown

Interval, in seconds, during which routing information regarding better paths is suppressed. It should be at least three times the value of the update argument. A route enters into a holddown state when an update packet is received that indicates that the route is unreachable. The route is marked inaccessible and is advertised as unreachable. When holddown expires, routes advertised by other sources are accepted, and the route is no longer inaccessible. Range is 15 to 200000.

flush

Amount of time, in seconds, that must pass before the route is removed from the routing table; the interval specified should be greater than the value of the invalid argument. If it is less than the invalid timer value, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. Range is 16 to 250000.

Command Default

update : 30

invalid : 180

holddown : 180

flush : 240

Command Modes

Router configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

The basic timing parameters for RIP are adjustable. Because RIP is running a distributed, asynchronous routing algorithm, these timers must be the same for all routers in the network.


Note


Use the show rip command to display the current and default timer values.


Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to set updates to be broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the flush period, the route is flushed from the routing table.

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip) timers basic 5 15 15 30
  
         

Related Commands

Command

Description

show rip

Displays configuration and status of RIP.

validate-update-source disable

To stop the Cisco IOS XR software from validating the source IP address of incoming routing updates for Routing Information Protocol (RIP), use the validate-update-source disable command in router configuration mode. To reenable this function, use the no form of this command.

validate-update-source disable

no validate-update-source disable

Syntax Description

This command has no arguments or keywords.

Command Default

The source IP address of incoming updates for RIP is always validated.

Command Modes

Router configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

When the validate-update-source disable command is used, validation is not performed.

By default, the software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.

For unnumbered IP interfaces (interfaces configured as IP unnumbered), no checking is performed.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to disable source validation:

  RP/0/RSP0/CPU0:router(config)# router rip
  RP/0/RSP0/CPU0:router(config-rip) validate-update-source disable
  
         

vrf (RIP)

To define a VPN routing and forwarding (VRF) instance and to enter VRF configuration mode, use the vrf command in router configuration mode. To remove a VRF instance use the no form of this command.

vrf vrf-name

no vrf vrf-name

Syntax Description

vrf-name

Specifies a particular VPN routing and forwarding instance.

Command Default

No VRFs are defined.

Command Modes

Router configuration

Command History

Release

Modification

Release 3.7.2

This command was introduced.

Usage Guidelines

To use this command, you must be in a user group associated with a task group that includes appropriate task IDs. If the user group assignment is preventing you from using a command, contact your AAA administrator for assistance.

Use the vrf command to configure a VRF instance. A VRF instance is a collection of VPN routing and forwarding tables maintained at the provider edge (PE) router.

From VRF configuration mode, you can issue all commands available in router configuration mode such as the auto-summary command.

Task ID

Task ID

Operations

rip

read, write

Examples

The following example shows how to enter VRF configuration mode and identify RIP commands that can be issued from that mode:

RP/0/RSP0/CPU0:router(config)# router rip
RP/0/RSP0/CPU0:router(config-rip)# vrf vpn-1
RP/0/RSP0/CPU0:router(config-rip-vrf)# ?
  
   auto-summary            Enable automatic network number summarization
   broadcast-for-v2        Send RIP v2 output packets to broadcast address
   commit                  Commit the configuration changes to running
   default-information     Control distribution of default information
   default-metric          Set metric of redistributed routes
   describe                Describe a command without taking real actions
   distance                Define an administrative distance
   do                      Run an exec command
   exit                    Exit from this submode
   interface               Enter the RIP interface configuration submode
   maximum-paths           Maximum number of paths allowed per route
   neighbor                Specify a neighbor router
   no                      Negate a command or set its defaults
   nsf                     Enable Cisco Non Stop Forwarding
   output-delay            Interpacket delay for RIP updates
   redistribute            Redistribute information from another routing protocol
   route-policy            Apply route policy to routing updates
   show                    Show contents of configuration
   timers                  Adjust routing timers
   validate-update-source  Validate source address of routing updates
RP/0/RSP0/CPU0:router(config-rip-vrf)#