Cisco 2800 Series Software Configuration Guide
Configuration Example: IP Communication Solution for Group Applications
Downloads: This chapterpdf (PDF - 1.51MB) The complete bookPDF (PDF - 5.74MB) | Feedback

IP Communication Solution for Group Applications Configuration Example

Table Of Contents

IP Communication Solution for Group Applications Configuration Example

Introduction

Prerequisites

Requirements

Components Used

Related Products

Conventions

Configure

Network Diagram

Configurations

Cisco 3845 Router

Verify

Verification Screens: Examples

Cisco CallManager Screen Examples

Cisco CME Screen Examples

Cisco Unity Express Screen Examples

Troubleshoot

Troubleshooting Reference Documents and Commands

Related Information


IP Communication Solution for Group Applications Configuration Example


Contents

Introduction

Prerequisites

Configure

Verify

Troubleshoot

Related Information

Introduction

This document provides a configuration example in which:

A small branch office uses both analog and IP phones. The small branch office implementation addressed in this document requires IP Telephony services and may also use other full-service branch (FSB) features of Cisco access routers. These features include Cisco Content Engines (CEs), Voice over IP (VoIP) services and integration with back-end VoIP call control devices. The small branch office requires a robust and integrated voice-mail solution. The integrated services routers also support various options for WAN uplink and integrated LAN switching modules.

Land Mobile Radio (LMR) is used by an enterprise for several reasons which include loss prevention (premise safety and security) and Push-to-Talk (PTT) communication for mobile workers within range of the radio system. LMR base stations can be connected to an E&M port for integration with an IP network and can be accessed via VoIP. The LMR feature also allows connecting walkie-talkies to the radios using multicast.

Multicast is dial-plan enabled so that IP phones and public switched telephone network (PSTN) phones can dial in to the LMR by using E.164 numbers. Traditionally, the E&M ports were used to connect to PSTN or Hoot-and-Holler networks. The E&M ports connected to the LMR can be multicast-to-VoIP enabled. This configuration permits desktop clients and IP-Phone clients on the LAN that are using XML services to directly connect to the radio via the multicast features on Cisco IOS. The LMR can be integrated with the E&M port on the gateway; the commands on the gateway support this router-to-radio adaptation.

This document provides a workaround method that bridges the multicast VoIP to unicast VoIP using a physical T1 loopback. This is not an essential configuration. It is documented to demonstrate how you can integrate multicast VoIP audio into standards-based VoIP call-control schemes such as Skinny, H.323, or SIP. IP-to-IP gateway is the preferred and recommended option to use for bridging between standards-based VoIP protocols. The VoIP-to-multicast bridge using a physical loopback can also be used for local multi-party conferencing via Cisco CallManager Express (Cisco CME) phones or PSTN phones.

Onboard DSPs are used for the voice modules on the WAN interface car (WIC) slots

Cisco CallManager seamlessly connects to Cisco CME over an H.323 trunk defined on the Cisco CallManager [Release 3.3 (3) or later].

Cisco CME (Release 3.2) manages the local phone network. Cisco CME and Cisco Unity Express enable users to use a gateway as though it were a PBX coupled to a voice-mail system.

Cisco Unity Express (with Cisco Service Engine 1.1) on the NM-CUE provides voice-mail and auto-attendant services.

Cisco CME seamlessly integrates with the Cisco CallManager at the headquarters site and supports all supplementary services.

Content Engine (CE) modules support web caching, video-on-demand and live-splitting applications.

Cisco Access Control Network Server (ACNS) on CE (ce2636-sw-5.1.3) saves WAN bandwidth by web-caching and splitting streaming video over unicast and multicast.

Prerequisites

Prerequisites included in this section:

Requirements

Components Used

Related Products

Conventions

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the following software and Cisco 3845 router hardware and software:

16 FastEthernet interfaces (NM-ESW-16)

1 serial interface

3 terminal lines

2 channelized T1/PRI ports

4 voice FXS interfaces (VIC-4FXS-DID)

2 voice E&M interfaces (VIC2-2E&M)

1 Cisco service engine (NM-CUE)

1 Cisco Content Engine (NM-CE-BP)

A VIC2-4FS in slot 0

A VIC2-2FXS in slot 1

An HWICD-9ESW with inline power card in slots 2-3 (double-wide)

Cisco CallManager Release 3.3(3)

Cisco IOS Release 12.3(11)T or later

Enterprise Services feature set

The information in this document reflects use of devices in a specific lab environment. All devices used in this configuration example started with a cleared (default) configuration. If you are working with a live network, ensure that you understand the potential effects of any command before you use it. The configuration example presented in this document depicts a combination of features on a single branch office router. Users of this document should review the documents listed under the"Related Information" section.

Related Products

This configuration can also be used with any Cisco 2800 and Cisco 3800 series routers.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.


Note To find additional information on the commands used in this document, use the Cisco IOS Command Lookup tool. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Configuration Tips

The gigabit port on the router does not provide inline power.

Routing should be enabled and assumed to be configured.

The external flash card on the integrated services routers holds the router image, VLAN database, graphical user interface (GUI) files for Cisco CME and Cisco Unity Express. It should not be removed during the normal operation of the router.

The LMR integration to the router might require radio frequency (RF)/radio skills (typically a non-IP and proprietary implementation). The radio-to-router physical cable might not be available off-the-shelf.

Network Diagram

This document uses the network setup shown in the following diagram.

1

Stream encoder, original source

7

LMR (LMR integration to the router)

2

TDM

8

T1 Loopback (unicast to multicast bridge); a workaround to integrate a multicast audio-to-standards based VoIP

3

NM-CE multicasting and live splitting on ACNS

9

PSTN

4

Cisco CME/Cisco Unity Express

10

Headquarters

5

Local multicast on LAN from gateway

11

Cisco CallManager

6

PC client, multicast RTP client, Media Player (streaming)

   

Configurations

This example presents configuration for the Cisco 3845 router.

Cisco 3845 Router

3845-gw#show running-config
 Building configuration...
 
 Current configuration : 17622 bytes
 !
 !---Last configuration change at 23:07:46 PDT Wed Jul 7 2004 by cisco
 !
 version 12.3
 service timestamps debug datetime msec localtime show-timezone
 service timestamps log datetime msec localtime show-timezone
 service password-encryption
 service internal
 !
 hostname 3845-gw
 !
 boot-start-marker
 boot-end-marker
 !
 logging buffered 4096 informational
 enable secret 5 $1$3do1$SDp9TOK4YaZ7XguJYD2MD1
!
!---Local Database of username and passwords for Web server and local
!---authentication
 !
 username cisco password 7 1511021F0725
! 
 clock timezone PST -8
 clock summer-time PDT recurring
 no network-clock-participate slot 1 
 no network-clock-participate slot 2 
 no network-clock-participate slot 3 
 no network-clock-participate slot 4 
 no network-clock-participate wic 0 
 no network-clock-participate wic 1 
 network-clock-participate wic 2 
 no network-clock-participate wic 3 
 no network-clock-participate aim 0 
 no network-clock-participate aim 1 
 
 aaa new-model
 !
 !
 aaa group server tacacs+ admin
  server 192.x or 10.x
  server 192.x or 10.x
 !
 aaa group server radius vpn
  server 192.x or 10.x auth-port 1645 acct-port 1646
 !
!---AAA configuration used for local authentication
!
 aaa authentication login admin group tacacs+ enable
 aaa authentication login remote group vpn
 aaa authentication login NOTACACS line
 aaa authentication login LOCAL local
 aaa authentication login WEB none
 aaa authentication ppp LOCAL local
 aaa authentication dot1x default group vpn
 aaa authorization console
 aaa authorization exec default local 
 aaa authorization network groupauthor local 
 aaa session-id common
 ip subnet-zero
 no ip source-route
 !
 
 ip cef
 !
 !
!---Configure a DHCP address pool for each IP phone:
 ip dhcp excluded-address 192.168.10.1 192.168.10.99
 !
 ip dhcp pool NONAT
    network 10.1.153.0 255.255.255.248
    default-router 10.1.153.1 
    dns-server 10.1.162.183 10.1.156.120 
    option 150 ip 10.1.152.9 
    domain-name cisco.com
 !
ip dhcp pool NAT
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 10.1.162.183 1010.1.156.120 
    option 150 ip 10.1.152.9 
    domain-name cisco.com

 !
 ip domain name cisco.com
 ip name-server 10.1.162.183
 ip name-server 10.1.156.120
 ip multicast-routing 
 ip sap cache-timeout 30
 ip ssh time-out 30
 ip ssh version 1
 ip ids po max-events 100
 no ip rcmd domain-lookup
 ip rcmd rcp-enable
 ip rcmd rsh-enable
 !
 voice-card 0
 
  no dspfarm
 !
 !
 !
!---Configuration to enable "H.323 to H.323" and "H.323 to SIP" calls between Cisco 
!---CallManager-Cisco CME-Cisco Unity Express. The "allow connections h323 to h323" & 
!---"allow-connections h323 to sip" enable an easy configuration on gateway without the 
!---need for loopback-dn for incoming calls from Cisco CallManager or for call flow from 
!---Cisco CallManager to SIP for Voice Mail. 
!
 voice service voip 
  allow-connections h323 to h323
  allow-connections h323 to sip
  no supplementary-service h450.2
  no supplementary-service h450.3
  supplementary-service h450.12 advertise-only
  h323
 !
 !
 !
!---Configuration to support LMR(Land Mobile Radio) integration through E&M port on the 
!---router (similar to Hoot and Holler configuration)
 !
 voice class permanent 1
  signal timing oos restart 50000
  signal timing oos timeout disabled
  signal keepalive disabled
  signal sequence oos no-action
 !
 !
!---Two T1 ports connected back-to-back to bridge VoIP to multicast audio bridging. This
!---is required to enable dialing into multicast. Connecting the TDM T1 port back-to-back 
!---offers the possibility of using E.164 number as a conference ID, or for using the 
!---multicast stream for application such as Hoot and Holler. 
!---
!---Cisco CME offers 3-party conference calling and is the recommended method for a 
!---small branch office, the following T1 loopback cable is not required for configuring 
!---the conferencing features.
!---
!---Cisco IOS supports audio mixing of loudest three streams. The TDM back to 
!---back connection enables the bridging of 23 channels of VoIP to one or 
!---more multicast connections (one side with multicast configuration and the 
!---other side with VoIP configuration)

!---This method provides a way to connect the standards-based VoIP call control to
!---the multicast audio streams that do not have any associated call control. 
!
 controller T1 0/2/0
  framing esf
  linecode b8zs
  ds0-group 1 timeslots 1 type e&m-immediate-start
  ds0-group 2 timeslots 2 type e&m-immediate-start
  ds0-group 3 timeslots 3 type e&m-immediate-start
  ds0-group 4 timeslots 4 type e&m-immediate-start
  ds0-group 5 timeslots 5 type e&m-immediate-start
  ds0-group 6 timeslots 6 type e&m-immediate-start
 !
 controller T1 0/2/1
 framing esf
 clock source internal
 linecode b8zs
  ds0-group 1 timeslots 1 type e&m-immediate-start
  ds0-group 2 timeslots 2 type e&m-immediate-start
  ds0-group 3 timeslots 3 type e&m-immediate-start
  ds0-group 4 timeslots 4 type e&m-immediate-start
  ds0-group 5 timeslots 5 type e&m-immediate-start
  ds0-group 6 timeslots 6 type e&m-immediate-start
 ! 
 no crypto isakmp enable
 !
 !
!---Loopback0 used to bind H323 to the Loopback0 interface. RTP Packets 
!---originate/terminate on the router using this IP address.
 !
 interface Loopback0
  ip address 10.1.152.9 255.255.255.255
  h323-gateway voip interface
  h323-gateway voip bind srcaddr 10.1.152.9
 !
 interface Loopback2
  ip address 10.1.152.241 255.255.255.252
  ip ospf network point-to-point
 !
 interface Loopback3
  ip address 10.1.152.249 255.255.255.252
  ip virtual-reassembly
  ip ospf network point-to-point
 !
!---Configuration to enable Hoot and Holler using multicast on router. The multicast 
!---streaming of packets from the local router uses the VIF interface to derive the local 
!---ip address and the port of the packets. This can be verified by the show command "show 
!---voip rtp connection" 
!
 interface Vif1
  ip address 10.1.153.41 255.255.255.252
  ip pim sparse-dense-mode
 
 !
!
!---WAN uplink
!
 interface Serial0/0/0
  ip address 10.1.152.30 255.255.255.252
  ip pim sparse-dense-mode
  ip nat outside
  ip virtual-reassembly
  no fair-queue
 !
!--- Content Engine connected as a Network Module. 
!
interface Content-Engine1/0
 ip unnumbered Loopback3
 ip pim sparse-dense-mode
 service-module ip address 10.1.152.250 255.255.255.252
 service-module ip default-gateway 10.1.152.249
!
!
 interface FastEthernet3/0
  switchport access vlan 110
  switchport trunk native vlan 100
  switchport mode trunk
  switchport voice vlan 110
  no ip address
 !
 interface FastEthernet3/1
  switchport access vlan 100
  switchport trunk native vlan 100
  switchport mode trunk
  switchport voice vlan 110
  no ip address
 !
 interface FastEthernet3/2
  switchport access vlan 100
  switchport trunk native vlan 100
  switchport mode trunk
  switchport voice vlan 110
  no ip address
 !
 interface FastEthernet3/3
  switchport access vlan 100
  switchport trunk native vlan 100
  switchport mode trunk
  switchport voice vlan 110
  no ip address
 !
 !
!---Cisco Unity Express used for local voice-mail storage
!
 interface Service-Engine4/0
  ip unnumbered Loopback2
  service-module ip address 10.1.152.242 255.255.255.252
  service-module ip default-gateway 10.1.152.241
 !
!--- Data VLAN, used for the desktops at the branch
!
 interface Vlan100
  ip address 192.168.10.1 255.255.255.0
  ip pim sparse-dense-mode
  ip nat inside
  ip virtual-reassembly
 !
 interface Vlan110
  ip address 10.1.153.1 255.255.255.248
  ip pim sparse-dense-mode
  ip virtual-reassembly
 !
!---OSPF used as the routing protocol for scenario
!
 router ospf 1
  router-id 10.1.152.9
  log-adjacency-changes
  network 10.1.152.9 0.0.0.0 area 0
  network 10.1.152.10 0.0.0.0 area 0
 
  network 10.1.152.28 0.0.0.3 area 0
  network 10.1.152.140 0.0.0.3 area 0
  network 10.1.152.240 0.0.0.3 area 0
  network 10.1.152.248 0.0.0.3 area 0
  network 10.1.153.0 0.0.0.3 area 0
 !
!---Static routes defined for routing to Service-Engine and Content-Engine network Module
 ip classless
 ip route 10.1.152.242 255.255.255.255 Service-Engine4/0
 ip route 10.1.152.250 255.255.255.255 Content-Engine1/0
!
 ip http server
 ip http authentication aaa login-authentication LOCAL
 no ip http secure-server
 ip http path flash:
!
!---PAT (Port address translation used for the Data VLAN. 
 ip nat inside source list 11 interface Serial0/0/0 overload
 !
 !
 access-list 11 permit 192.168.11.0 0.0.0.255
 access-list 11 permit 192.168.20.0 0.0.0.255
 access-list 11 permit 192.168.10.0 0.0.0.255
 !
!
!---Router serves as TFTP server for Signed Image for 7960 phone on Local LAN.
!
 tftp-server flash:P00306000300.bin
 tftp-server flash:P00306000300.loads
 tftp-server flash:P00306000300.sb2
 !
 control-plane
 !
 !
!---VoIP side of the Back-to-Back T1 used for bridging VoIP to multicast streams defined 
!---by the dial-peer with " session protocol multicast"
 !
 voice-port 0/2/0:1
  auto-cut-through
 !
 voice-port 0/2/0:2
  auto-cut-through
 !
 voice-port 0/2/0:3 
  auto-cut-through
 !
 voice-port 0/2/0:4
  auto-cut-through
 !
voice-port 0/2/0:3
auto-cut-through
!
voice-port 0/2/0:4
auto-cut-through
!
voice-port 0/2/0:5
auto-cut-through
!
voice-port 0/2/0:6
auto-cut-through
!
!---E&M ports connected to the LMR (Land Mobile Radio). Each radio may have a different 
!---radio frequency (such as VHF or UHF)
!
 voice-port 0/1/0
  auto-cut-through
  voice-class permanent 1
  operation 4-wire
  signal lmr
  lmr e-lead voice
  timeouts call-disconnect 3
  connection trunk 20480
 !
 
 voice-port 0/1/1
  auto-cut-through
  voice-class permanent 1
  operation 4-wire
  signal lmr
  lmr m-lead audio-gate-in
  lmr e-lead voice
  timeouts call-disconnect 3
  connection trunk 20481
 !
!---Multicast side of the back-to-back T1 used for bridging VoIP to multicast connection 
!---trunk points to the dial-peer that is used for streaming into multicast
!
 voice-port 0/2/1:1
  auto-cut-through
  timeouts call-disconnect 3
  connection trunk 20480
 !
 voice-port 0/2/1:2
  auto-cut-through
  timeouts call-disconnect 3
  connection trunk 20481
 !
!---Multicast side of the back-to-back T1 used for bridging VoIP to multicast connection 
!---trunk points to the dial-peer that is used for streaming into multicast for local 
!---conferencing. 2111 dialed from the network side is looped back to the other side of 
!---the T1 that is connected to the multicast dial-peer to convert it into a multicast 
!---stream. The 3-party mixing algorithm takes care of conferencing between the dialed 
!---parties
!
voice-port 0/2/1:3
 auto-cut-through
 timeouts call-disconnect 3
 connection trunk 21111
!
voice-port 0/2/1:4
 auto-cut-through
 timeouts call-disconnect 3
 connection trunk 21111
!
voice-port 0/2/1:5
 auto-cut-through
 timeouts call-disconnect 3
 connection trunk 21111
!
voice-port 0/2/1:6
 auto-cut-through
 timeouts call-disconnect 3
 connection trunk 21111
 voice-port 0/3/0
 !
 voice-port 0/3/1
 !
 voice-port 0/3/2
 !
!---FXS ports tied to multicast Hoot and Holler
!
 voice-port 0/3/3
 !
!---Dial peers pointing toward the NM-CUE for auto attendant and voice mail
!
 dial-peer voice 27749 voip
  description Towards CUE-Auto-Attendant
  destination-pattern 27749
  session protocol sipv2
  session target ipv4:10.1.152.242
  dtmf-relay sip-notify
  codec g711ulaw
  no vad
 !
 dial-peer voice 27748 voip
  description Towards CUE-Voice-Mail
  destination-pattern 27748
  session protocol sipv2
  session target ipv4:10.1.152.242
  dtmf-relay sip-notify
  codec g711ulaw
  no vad
 !
!---Dial peers for dialing out; pointing to Cisco CallManager Release 3.3(3)
!
 dial-peer voice 101 voip
  description CCM-IT-Cisco
  destination-pattern .T
  session target ipv4:10.1.148.178
  dtmf-relay h245-alphanumeric
  codec g711ulaw
 !
 dial-peer voice 9 voip
 
  preference 1
  destination-pattern 91..........
  session target ipv4:10.1.148.178
 !
 dial-peer voice 2 voip
  destination-pattern 2....
  session target ipv4:10.1.148.178
 !
!---Dial Peers for multicast streaming from TDM port
!
 dial-peer voice 20480 voip
description VoIP to multicast bridging for LMR integration
  destination-pattern 20480
  voice-class permanent 1
  session protocol multicast
  session target ipv4:239.192.17.191:20480
  codec g711ulaw
  vad aggressive
 !
 dial-peer voice 20481 voip
description VoIP to multicast bridging for LMR integration
  destination-pattern 20481
  voice-class permanent 1
  session protocol multicast
  session target ipv4:239.192.17.192:20480
  codec g711ulaw
  vad aggressive
 !
dial-peer voice 21111 voip
description VoIP to multicast bridging for Local Conferencing
  destination-pattern 21111
  voice-class permanent 1
  session protocol multicast
  session target ipv4:239.192.17.195:20480
  dtmf-relay cisco-rtp
  codec g711ulaw
  vad aggressive
!---Dial Peers for the T1 physical loopback used for bridging multicast to VoIP 
!---(VoIP Side)
!
 dial-peer voice 1 pots
description VoIP to multicast bridging for LMR
  destination-pattern 27737
  port 0/2/0:1
 !
 dial-peer voice 3 pots
description VoIP to multicast bridging for LMR
  destination-pattern 4089027737
  port 0/2/0:1
 !
 dial-peer voice 4 pots
description VoIP to multicast bridging for LMR
  destination-pattern 27738
  port 0/2/0:2
 !
 dial-peer voice 5 pots
description VoIP to multicast bridging for LMR
  destination-pattern 4089027738
  port 0/2/0:2
 !
dial-peer voice 6 pots
 description VoIP to local multicast conference bridge
  destination-pattern 2111
  port 0/2/0:3
 !
 dial-peer voice 7 pots
description VoIP to local multicast conference bridge
  destination-pattern 2111
  port 0/2/0:4
 !
 dial-peer voice 8 pots
description VoIP to local multicast conference bridge
  destination-pattern 2111
  port 0/2/0:5
 !
 dial-peer voice 9 pots
description VoIP to local multicast conference bridge
  destination-pattern 2111
  port 0/2/0:6
 !
 !
!---Dial Cisco CME Configuration with services configuration
 !
 !
 telephony-service
  fxo hook-flash
  load 7910 P00403020214
  load 7960-7940 P00306000300
  max-ephones 27
  max-dn 40
  ip source-address 10.1.152.9 port 2000
  auto assign 1 to 27
  timeouts interdigit 5
  system message Next GEN Branch Documentation 
  url services http://phone-xml.berbee.com/menu.xml
  create cnf-files version-stamp 7960 Jun 24 2004 14:00:45
  dialplan-pattern 1 408902.... extension-length 5
 
  voicemail 27749
  mwi relay
  mwi expires 99999
  max-conferences 8
  call-forward pattern .....
  web admin customer name cisco password admin
  dn-webedit 
  time-webedit 
  transfer-system full-consult
  transfer-pattern .....
  secondary-dialtone 9
 !
 !
 ephone-dn  1  dual-line
  number 27725
  description Ross
  name Ross
  call-forward busy 27749
  call-forward noan 27749 timeout 10
 !
 !
 ephone-dn  2  dual-line
  number 27726
  description Rachel
  name Rachel
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  3  dual-line
  number 27727
  description Chandler
  name Chandler
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  4  dual-line
  number 27728
  description Monica
  name Monica
  call-forward busy 27749
  call-forward noan 27749 timeout 10
 !
 !
 ephone-dn  5  dual-line
  number 27729
  description Jen-Shue Shih 
  name Jen-Shue Shih 
  call-forward busy 27749
  call-forward noan 27749 timeout 10
 !
 !
 ephone-dn  6  dual-line
  number 27730
  description Mike
  name Mike
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  7  dual-line
  number 27731
 
  description Phoebe
  name Phoebe
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  8  dual-line
  number 27732
  description Cosmo
  name Cosmo
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  9  dual-line
  number 27733
  description Jerry
  name Jerry
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  10  dual-line
  number 27734
  description George
  name George
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  11  dual-line
  number 27735
  description Frank
  name Frank
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  12  dual-line
  number 27736
  description Estelle
  name Estelle
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  13  dual-line
 !
 !
 ephone-dn  14  dual-line
 !
 !
 ephone-dn  15  dual-line
  number 27739
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  16  dual-line
  number 27740
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 
 ephone-dn  17  dual-line
  number 27741
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  18  dual-line
  number 27742
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  19  dual-line
  number 27743
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  20  dual-line
  number 27744
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  21  dual-line
  number 27745
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  25
 !
 !
 ephone-dn  27
  number 27749
  call-forward busy 27749
  call-forward noan 27749 timeout 18
 !
 !
 ephone-dn  39
  number 8000.....
  mwi off
 !
 !
 ephone-dn  40
  number 8001.....
  mwi on
 !
 !
 ephone  1
  mac-address 0003.4713.5554
  type CIPC
  button  1:1
 !
 !
 !
 ephone  2
  mac-address 0002.8A3E.6606
  type CIPC
  button  1:2
 !
 !
 !
 ephone  3
 
  mac-address 0001.022C.88A1
  type CIPC
  button  1:3
 !
 !
 !
 ephone  4
  mac-address 0009.6B10.494D
  type CIPC
  button  1:4
 !
 !
 !
 ephone  5
  mac-address 0002.8A4B.000B
  type CIPC
  button  1:5
 !
 !
 !
 ephone  6
  mac-address 0009.6B53.44C6
  type CIPC
  button  1:6
 !
 !
 !
 ephone  7
  mac-address 0009.6B30.E399
  type CIPC
  button  1:7
 !
 !
 !
 ephone  8
  mac-address 000B.BE37.1AB1
  type 7960
  button  1:8
 !
 !
 !
 ephone  9
  mac-address 0006.D74B.15B3
  type 7960
  button  1:9
 !
 !
 !
 ephone  10
  mac-address 000B.5F92.5784
  type 7960
  button  1:10
 !
 !
 !
 ephone  11
  mac-address 000C.CE3A.87FA
  type 7960
  button  1:11
 !
 !
 !
 ephone  12
  mac-address 000C.CE35.1B23
 
  type 7960
  button  1:12
 !
 !
 !
 ephone  13
  mac-address 0002.8A9B.0CE5
  type CIPC
  button  1:13
 !
 !
 !
 ephone  14
  mac-address 0003.47D8.C236
  type CIPC
  button  1:14
 !
 !
 !
 ephone  15
  mac-address 000C.CE35.1935
  type 7960
  button  1:15
 !
 !
 !
 ephone  16
  mac-address 0030.94C3.BE45
  type 7960
  button  1:16
 !
 !
 !
 ephone  17
 !
 !
 !
 ephone  18
 !
 !
 !
 ephone  19
 !
 !
 !
 ephone  20
 !
 !
 !
 ephone  21
 !
 !
 !
 line con 0
  authorization exec LOCAL
  stopbits 1
 line aux 0
  stopbits 1
 line 66
  no activation-character
  no exec
  transport preferred none
  transport input all
  transport output all
 
 line 130
  no activation-character
  no exec
  transport preferred none
  transport input all
  transport output all
 line 258
  no activation-character
  no exec
  transport preferred none
  transport input all
  transport output all
 line vty 0 4
  exec-timeout 0 0
  password 7 04490E020D205E4107
 line vty 5 8
  exec-timeout 0 0
  password 7 03165E0F040E334340
 !
 scheduler allocate 20000 1000
 ntp clock-period 1079741
 ntp master
 ntp update-calendar
 ntp server 10.68.10.80
 ntp server 10.68.10.150
 end
 

Verify

This section provides information you can use to confirm that your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only), which allows you to view an analysis of show command output. In summary, use these commands:

show telephony-service—Shows the IP telephony services available for Cisco CallManager server

show ephone registered—Verifies IP phone registration occurring and lists information associated with each registered IP phone

show commands for the voice gateway

show voice port summary—Displays a summary of all voice ports

show voip rtp connections—Displays VoIP RTP active connections

show voip dsp—Displays DSP information

show voice trace—Displays voice-channel configuration information for all DSP channels

show voice call summary—Displays the call status for all voice ports

show running-config—Displays the contents of the currently running configuration file

show commands for CE

show version—Displays information about the currently loaded CE software version along with hardware and device information

show running-config—Displays the contents of the currently running configuration file

show processes cpu—Displays detailed CPU utilization statistics (CPU use per process)

show statistics wmt streamstat—Displays statistics for Windows Media Technologies (WMT) streaming connections

show statistics wmt all—Display all WMT statistics

show and service commands on Cisco CME for Cisco Unity Express

show interface service-engine—Displays the status of the service-engine interface

service-module service-engine 4/0 status—Displays status of Cisco Unity Express

service-module service-engine 4/0 session—Opens session with Cisco Unity Express

show commands for Cisco Unity Express

show running-config—Displays the contents of the currently running configuration file

show voicemail mailboxes—Displays summary of mailbox owners and status

show voicemail usage—Displays snapshot of voicemail system use

show voicemail limits—Displays system limits for voicemail system

show ccn application—Displays details about each configured application

show ccn trigger—Displays the parameter values for all configured triggers

Representative output for each of these commands is presented in the verification summaries that follow.


Note Relevant display output is highlighted as appropriate.


The following is an example of output for the show telephony-service command on the Cisco CME:

CCME-CUE-SJC# show telephony-service 

CONFIG (Version=3.2)
=====================
 
Version 3.2
Cisco CallManager Express
For on-line documentation please see:
www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/ip_ks/index.htm

ip source-address 10.1.152.9 port 2000
load 7910 P00403020214
load 7960-7940 P00303020214
max-ephones 27
max-dn 40
max-conferences 8
dspfarm units 0
dspfarm transcode sessions 0
max-redirect 5
dialplan-pattern 1 408902.... extension-length 5
voicemail 27749
mwi relay
mwi expires 99999
time-format 12
date-format mm-dd-yy
timezone 0 Greenwich Standard Time
secondary-dialtone 9
url services http://phone-xml.berbee.com/menu.xml
call-forward pattern .....
transfer-pattern .....
keepalive 30
timeout interdigit 5
timeout busy 10
timeout ringing 180
caller-id name-only: enable
system message CCME2 Cisco (MCEBU) Bldg 22
web admin system name cisco  password 3800
web admin customer name cisco1  password 38001
edit DN through Web:  enabled.
edit TIME through web:  enabled.
Log (table parameters):
     max-size: 150
     retain-timer: 15
create cnf-files version-stamp 7960 Apr 12 2004 12:16:53
transfer-system full-consult 
auto assign 1 to 27
fxo hook-flash
local directory service: enabled.

The following example illustrates output using the show ephone registered command:

CCME-CUE-SJC# show ephone registered


ephone-1 Mac:0003.4713.5554 TCP socket:[6] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:172.19.150.31 1649 CIPC   keepalive 10410 max_line 8
button 1: dn 1  number 27725 CH1   IDLE         CH2   IDLE         


ephone-9 Mac:0006.D74B.15B3 TCP socket:[1] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:192.168.20.4 50475 Telecaster 7960  keepalive 39556 max_line 6
button 1: dn 9  number 27733 CH1   IDLE         CH2   IDLE         


ephone-15 Mac:000C.CE35.1935 TCP socket:[3] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:192.168.20.2 51961 Telecaster 7960  keepalive 39556 max_line 6
 
button 1: dn 15 number 27739 CH1   IDLE         CH2   IDLE         

The following is an example of output for the show voice port summary command on the branch office router:


3845-gw# show voice port summary

                                     IN       OUT
PORT      CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
========= == ============ ===== ==== ======== ======== ==
0/2/0:1   01  e&m-imd     up    dorm idle     idle     y
0/2/0:2   02  e&m-imd     up    dorm idle     idle     y
0/2/0:3   03  e&m-imd     up    dorm idle     idle     y
0/2/0:4   04  e&m-imd     up    dorm idle     idle     y
0/2/0:5   05  e&m-imd     up    dorm idle     idle     y
0/2/0:6   06  e&m-imd     up    dorm idle     idle     y
0/1/0     --  e&m-lmr     up    up   trunked  trunked  y
0/1/1     --  e&m-lmr     up    up   trunked  trunked  y
0/2/1:1   01  e&m-imd     up    up   trunked  trunked  y
0/2/1:2   02  e&m-imd     up    up   trunked  trunked  y
0/2/1:3   03  e&m-imd     up    up   trunked  trunked  y
0/2/1:4   04  e&m-imd     up    up   trunked  trunked  y
0/2/1:5   05  e&m-imd     up    up   trunked  trunked  y
0/2/1:6   06  e&m-imd     up    up   trunked  trunked  y
0/3/0     --  fxs-ls      up    dorm on-hook  idle     y
0/3/1     --  fxs-ls      up    dorm on-hook  idle     y
0/3/2     --  fxs-ls      up    dorm on-hook  idle     y
0/3/3     --  fxs-ls      up    dorm on-hook  idle     y
50/0/1    1      efxs     up    up   on-hook  idle     y
50/0/1    2      efxs     up    up   on-hook  idle     y
50/0/2    1      efxs     up    up   on-hook  idle     y
50/0/2    2      efxs     up    up   on-hook  idle     y
50/0/3    1      efxs     up    up   on-hook  idle     y
.
50/0/40   1      efxs     up    dorm on-hook  idle     y

The following is an example of output for the show voice rtp connections command on the branch office router:

3845-gw# show voip rtp connections

VoIP RTP active connections :
No. CallId  dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP
1   2       1          32414    20480  10.1.153.42    239.192.17.191
2   4       3          28764    20480  10.1.153.42    239.192.17.192
3   6       5          16416    20480  10.1.153.42    239.192.17.191
4   8       7          27572    20480  10.1.153.42    239.192.17.192
5   1754    1753       16446    20480  10.1.153.42    239.192.17.195
6   1756    1755       31552    20480  10.1.153.42    239.192.17.195
7   1758    1757       16454    20480  10.1.153.42    239.192.17.195
8   1761    1760       16496    20480  10.1.153.42    239.192.17.195
Found 8 active RTP connections

The following is an example of output for the show voip dsp command on the branch office router:

3845-gw# show voip dsp

----------------------------FLEX VOICE CARD 0 ------------------------------
                           *DSP VOICE CHANNELS*
DSP   DSP             DSPWARE CURR  BOOT                         PAK   TX/RX
TYPE  NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ======== ======= ===== ======= === == ========= == ==== ============
C5510 013 01 g711ulaw   4.4.1 busy  idle      0  0 0/1/0     00    0     1/419970
C5510 013 02 g711ulaw   4.4.1 busy  idle      0  0 0/2/1:2   02    0    15/420330
C5510 013 03 g711ulaw   4.4.1 busy  idle      0  0 0/2/1:1   01    0    16/420130
C5510 013 04 g711ulaw   4.4.1 busy  idle      0  0 0/1/1     01    0     0/419879
C5510 013 05 None       4.4.1 busy  idle      0  0 0/2/0:3   03    0         0/14
C5510 013 06 g711ulaw   4.4.1 busy  idle      0  0 0/2/1:3   03    0    1873/1655
C5510 014 01 None       4.4.1 busy  idle      0  0 0/2/0:4   04    0         0/14
C5510 014 02 g711ulaw   4.4.1 busy  idle      0  0 0/2/1:6   06    0    1833/5379
C5510 014 03 None       4.4.1 busy  idle      0  0 0/2/0:5   05    0         0/14
C5510 014 04 None       4.4.1 busy  idle      0  0 0/2/0:6   06    0         0/14
C5510 014 05 g711ulaw   4.4.1 busy  idle      0  0 0/2/1:5   05    0    1424/5334
C5510 014 06 g711ulaw   4.4.1 busy  idle      0  0 0/2/1:4   04    0    1402/5057
                           *DSP SIGNALING CHANNELS*
DSP   DSP             DSPWARE CURR  BOOT                         PAK   TX/RX
TYPE  NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ======== ======= ===== ======= === == ========= == ==== ============
C5510 013 01 {flex}     4.4.1 alloc idle      0  0 0/1/0     02    0         34/0
C5510 013 02 {flex}     4.4.1 alloc idle      0  0 0/1/1     02    0         35/0
C5510 013 03 {flex}     4.4.1 alloc idle      0  0 0/3/1     06    0         14/0
C5510 013 04 {flex}     4.4.1 alloc idle      0  0 0/3/0     06    0         14/0
C5510 013 05 {flex}     4.4.1 alloc idle      0  0 0/3/3     02    0         14/0
C5510 013 06 {flex}     4.4.1 alloc idle      0  0 0/3/2     02    0         14/0
C5510 013 07 {flex}     4.4.1 alloc idle      0  0 0/2/0:1   01    0         4/18
C5510 013 08 {flex}     4.4.1 alloc idle      0  0 0/2/0:2   02    0         4/18
C5510 013 09 {flex}     4.4.1 alloc idle      0  0 0/2/1:1   01    0        27/23
C5510 013 10 {flex}     4.4.1 alloc idle      0  0 0/2/1:2   02    0        27/23
C5510 013 11 {flex}     4.4.1 alloc idle      0  0 0/2/0:3   03    0      454/335
C5510 013 12 {flex}     4.4.1 alloc idle      0  0 0/2/0:4   04    0      465/341
C5510 013 13 {flex}     4.4.1 alloc idle      0  0 0/2/0:5   05    0      433/315
C5510 013 14 {flex}     4.4.1 alloc idle      0  0 0/2/0:6   06    0      421/307
C5510 013 15 {flex}     4.4.1 alloc idle      0  0 0/2/1:3   03    0    3969/3831
C5510 013 16 {flex}     4.4.1 alloc idle      0  0 0/2/1:4   04    0    4050/3933
C5510 014 01 {flex}     4.4.1 alloc idle      0  0 0/2/1:5   05    0    3819/3657
C5510 014 02 {flex}     4.4.1 alloc idle      0  0 0/2/1:6   06    0    3724/3553
------------------------END OF FLEX VOICE CARD 0 ----------------------------

The following is an example of output for the show voice trace command on the branch office router:

3845-gw# show voice trace 0/2/1:1

0/2/1:1 1  State Transitions: timestamp (state, event) -> (state, event) ...
42.808 (S_SETUP_INDICATED, E_CC_PROCEEDING) ->
42.808 (S_PROCEEDING, E_CC_CONNECT) ->

State Transitions: timestamp (state, event) -> (state, event) ...
42.808 (S_TRUNK_PEND, E_HTSP_EVENT_TIMER) ->
42.808 (S_TRUNK_PROC, E_HTSP_SETUP_ACK) ->
42.808 (S_TRUNK_PROC, E_HTSP_PROCEEDING) ->
42.808 (S_TRUNK_PROC, E_HTSP_VOICE_CUT_THROUGH) ->
42.808 (S_TRUNK_W_CONNECT, E_HTSP_CONNECT) ->

The following is an example of output for the show voice call summary command on the branch office router:

3845-gw# show voice call summary

PORT           CODEC    VAD VTSP STATE            VPM STATE
============== ======== === ==================== ======================
0/2/0:1.1       -         -  -                     EM_ONHOOK
0/2/0:2.2       -         -  -                     EM_ONHOOK
0/2/0:3.3       -         -  -                     EM_ONHOOK
0/2/0:4.4       -         -  -                     EM_ONHOOK
0/2/0:5.5       -         -  -                     EM_ONHOOK
0/2/0:6.6       -         -  -                     EM_ONHOOK
0/1/0           g711ulaw  y  S_CONNECT             S_TRUNKED
0/1/1           g711ulaw  y  S_CONNECT             S_TRUNKED
0/2/1:1.1       g711ulaw  y  S_CONNECT             S_TRUNKED
0/2/1:2.2       g711ulaw  y  S_CONNECT             S_TRUNKED
0/2/1:3.3       g711ulaw  y  S_CONNECT             S_TRUNKED
0/2/1:4.4       g711ulaw  y  S_CONNECT             S_TRUNKED
0/2/1:5.5       g711ulaw  y  S_CONNECT             S_TRUNKED
0/2/1:6.6       g711ulaw  y  S_CONNECT             S_TRUNKED
0/3/0           -         -  -                     FXSLS_ONHOOK
0/3/1           -         -  -                     FXSLS_ONHOOK
0/3/2           -         -  -                     FXSLS_ONHOOK
0/3/3           -         -  -                     FXSLS_ONHOOK
50/0/1  .1      -         -  -                     EFXS_ONHOOK
50/0/9  .1      -         -  -                     EFXS_ONHOOK
50/0/9  .2      -         -  -                     EFXS_ONHOOK

The following is an example of output for the show version command on the CE:

sjc22-13a-rb-CE3# show version

Application and Content Networking System Software (ACNS)
Copyright (c) 1999-2003 by Cisco Systems, Inc.
Application and Content Networking System Software Release 5.1.3 (build b15 Feb
13 2004)
Version: ce2636-sw-5.1.3

Compiled 17:52:07 Feb 13 2004 by test
Compile Time Options: PP SS

System was restarted on Tue Jan  1 00:01:12 1980.
The system has been up for 16 hours, 8 seconds.

The following is an example of output for the show running-config command on the CE:

sjc22-13a-rb-CE3# show running-config

hostname sjc22-13a-rb-CE3
!
http dns-cache serial-lookup
!
!
ip domain-name cisco.com
!
!
gui-server secure port 8002
!
!
interface FastEthernet external
 shutdown
 exit
interface FastEthernet internal
 exit
!
!
primary-interface FastEthernet 0/1
!
wmt license-key 92W5SNNNSULWCXN78
wmt accept-license-agreement
wmt max-concurrent-sessions 9
wmt mms allow extension asf none nsc wma wmv mp3
wmt broadcast alias-name lanka source mms://24.6.215.172/AAA

wmt enable
!
!
multicast accept-license-agreement
!
!
 ip name-server 10.68.162.183
 ip name-server 10.72.156.120
!
!
wccp router-list 1 10.1.152.249
wccp web-cache router-list-num 1
wccp version 2
!
!
!
!
!
!

!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
!
authentication login local enable primary
authentication configuration local enable primary
!
!
cdm ip 10.86.46.81
cms enable
!
!
! 
End of ACNS configuration

The following is an example of output for the show processes cpu command on the CE:

sjc22-13a-rb-CE3# show processes cpu

CPU usage:
         Current      Peak
   cpu:     96 %     100 %
CPU average usage since last reboot:
   cpu: 0.03% User,  7.28% System,  1.80% User(nice),  90.90% Idle
  cpu0: 0.03% User,  7.28% System,  1.80% User(nice),  90.90% Idle
--------------------------------------------------------------------
 PID  STATE PRI User T  SYS T        COMMAND
----- ----- --- ------ ------ --------------------
    1    S   0    744   4839 (init)
 
    2    R   0      0      0 (keventd)
    3    S  19      0      0 (ksoftirqd_CPU0)
    4    S   0      0      0 (kswapd)
    5    S   0      0      0 (bdflush)
    6    S   0      0      0 (kupdated)
  157    S   0      0      0 (streamd)
  197    S  10  30143   3926 (nodemgr)
  201    S  10      0      0 (syslogd)
  202    R  10    396    150 (dataserver)
  298    S   0      0      0 (kjournald)
  902    S  10    108     23 (ruby_disk)
 1494    S  10      2      1 (parser_server)
 1544    S  10      3      1   (su)

The following is an example of output for the show statistics xmt streamstat command on the CE:

sjc22-13a-rb-CE3# show statistics wmt streamstat

Detailed Stream Statistics
==========================

Incoming Streams:
=================
Bandwidth in Kbps, Duration in seconds

Type Transport  Source   Pkts_Recd Bytes_Recd Duration  BW        Server-IP
  Filename                  Stream-Id
LIVE MMS(TCP)   RMT_MMS  807995    1165556557 44531     216       24.6.215.172
  AAA                       5878

Outgoing Streams:
=================
Client-IP       Type Transport Source   State    Pkts_sent Bytes_sent  Duration BW    
Server-IP      Filename                  Stream-Id
10.21.96.174    LIVE HTTP      RMT_MMS  Play     216441    312540804   11946    216  
24.6.215.172    lanka                     13830
10.21.81.206    LIVE MMS(UDP)  RMT_MMS  Play     59505     85925220    3283     216  
24.6.215.172    lanka                     15639
10.21.88.96     LIVE HTTP      RMT_MMS  Play     165227    238587788   9129     216  
24.6.215.172    lanka                     14402
10.21.113.252   LIVE MMS(UDP)  RMT_MMS  Play     596188    860895472   32961    216  
24.6.215.172    lanka                     8644
10.21.116.124   LIVE HTTP      RMT_MMS  Play     53848     77756512    3033     216  
24.6.215.172    lanka                     15682
10.21.115.95    LIVE MMS(UDP)  RMT_MMS  Play     481970    695964680   26584    216  
24.6.215.172    lanka                     10694
10.21.65.223    LIVE MMS(UDP)  RMT_MMS  Play     15883     22935052    878      216  
24.6.215.172    lanka                     16161
sjc22-13a-rb-CE3#

The following is an example of output for the show statistics xmt all command on the CE:

sjc22-13a-rb-CE3# show statistics wmt all

Unicast Requests Statistics
===========================
Total unicast requests received: 79
-------------------------------------

                                Total            % of Total
                                              Unicast Requests
                              --------------------------------------------

Streaming Requests served:         75               94.94%
   Mcast nsc file Request:          0                0.00%
           Requests error:          0                0.00%
 

                       Total        % of Total Streaming Requests
                             ---------------------------------------------

By Type of Content
------------------
             Live content:         75              100.00%
        On-Demand Content:          0                0.00%

By Transport Protocol
---------------------
                     MMSU:         32               42.67%
                     MMST:          1                1.33%
                     HTTP:         42               56.00%

By Source of Content
--------------------
                    Local:          0                0.00%
               Remote MMS:         75              100.00%
              Remote HTTP:          0                0.00%
                Multicast:          0                0.00%


CDN-Related WMT Requests
--------------------
         CDN Content Hits:          0                0.00%
       CDN Content Misses:          0                0.00%
         CDN Content Live:          0                0.00%
       CDN Content Errors:          0                0.00%
Unicast Bytes Statistics
========================
Total unicast incoming bytes: 1178064843
---------------------------------
                                         Total     % of Total Unicast
                                                    Incoming Bytes
                              --------------------------------------------

By Type of Content
------------------
             Live content:           1178064843         100.00%
        On-Demand Content:                    0           0.00%

By Transport Protocol
---------------------
                     MMSU:                    0           0.00%
                     MMST:           1178064843         100.00%
                     HTTP:                    0           0.00%

Unicast Bytes Statistics
========================
Total unicast outgoing bytes: 4698135144
---------------------------------
                                         Total     % of Total Unicast
                                                    Outgoing Bytes
                              --------------------------------------------

By Type of Content
------------------
             Live content:           4698135144         100.00%
        On-Demand Content:                    0           0.00%

By Transport Protocol
---------------------
                     MMSU:           3148201513          67.01%
 
                     MMST:                    0           0.00%
                     HTTP:           1549933631          32.99%

Unicast Savings Statistics
==========================
Total bytes saved: 3520070301
--------------------------
                                         Total       % of Total Bytes
                                                            Saved
                              --------------------------------------------
By Pre-positioned content:                    0           0.00%
        By Live-splitting:           3520070301         100.00%
             By Cache-hit:                    0           0.00%

                                         Total         % of Total
                                                  Live Outgoing Bytes
                              --------------------------------------------
Live Splitting
--------------
           Incoming bytes:           1178064843          25.08%
           Outgoing bytes:           4698135144         100.00%
              Bytes saved:           3520070301          74.92%

                                         Total       % of Bytes Cache
                                                           Total
                              --------------------------------------------
Caching
-------
         Bytes cache-miss:                    0           0.00%
          Bytes cache-hit:                    0           0.00%
        Bytes cache-total:                    0           0.00%

     Bytes cache-bypassed:                    0

                                         Total         % of Req Cache
                                                           Total
                              --------------------------------------------

Cacheable requests
------------------
           Req cache-miss:                    0           0.00%
            Req cache-hit:                    0           0.00%
    Req cache-partial-hit:                    0           0.00%
          Req cache-total:                    0           0.00%

       Req cache-bypassed:                   81

Objects not cached
------------------
           Cache bypassed:                   81
          Exceed max-size:                    0



Usage Summary
=============
Concurrent Unicast Client Sessions
----------------------------------
        Current:         8
            Max:         8

Concurrent Active Multicast Sessions
------------------------------------
        Current:         0
            Max:         0

Concurrent Remote Server Sessions
---------------------------------
        Current:         1
            Max:         1

Concurrent Unicast Bandwidth (Kbps)
-----------------------------------
        Current:  1734.120
            Max:  1734.120

Concurrent Multicast Out Bandwidth (Kbps)
-----------------------------------------
        Current:     0.000
            Max:     0.000

Concurrent Bandwidth to Remote Servers (Kbps)
---------------------------------------------
        Current:   216.765
 
            Max:   216.765

Error Statistics
================
                    Total request errors:         0

  Errors generated by this box
                   Reach MAX connections:         0
            Reach MAX incoming bandwidth:         0
            Reach MAX outgoing bandwidth:         0
             Reach MAX incoming bit rate:         0
             Reach MAX outgoing bit rate:         0
                         MMSU under wccp:         0
                        MMSU not allowed:         0
                        MMST not allowed:         0
                      MMSU/T not allowed:         0
                        HTTP not allowed:         0
   1st tcp pkt error, possible port scan:         0
                             Illegal url:         0
                               No socket:         0
                          Cannot connect:         0
                     Authentication fail:         0
                     Remote server error:         0
                            Client error:         0
                          Internal error:         0
                Local vod file not found:         0
         Local vod file header corrupted:         0
           Local vod file data corrupted:         0
                           Unknown error:         0

  Errors generated by remote servers
                   Reach MAX connections:         0
                     Reach MAX bandwidth:         0
                      Reach MAX bit rate:         0
                             Illegal url:         0
                         Invalid request:         0
                               No socket:         0
                          Cannot connect:         0
                       Conection refused:         0
                             Access deny:         0
                     Invalid stream type:         0
                     Remote server error:         0
                          Remote timeout:         0
                      Remote proxy error:         0
                          File not found:         0
                   File header corrupted:         0
                     File data corrupted:         0
                    Remote unknown error:         0

  Authentication Retries from Clients:            0

WMT Rule Template Statistics
================
                             URL Rewrite:         0
                        Connection Reset:         0
                               URL Block:         0
                                 No-Auth:         0
                                No-Cache:         0
                         Selective Cache:         0
                                   Allow:         0

WMT URL Filter Statistics
================
                             URL Allowed:         0
 
                            URL Filtered:         0

The following is an example of output for the show interface service-engine 4/0 command on the Cisco CME for Cisco Unity Express:


3845-gw# show interface service-engine 4/0 

Service-Engine4/0 is up, line protocol is up 
  Hardware is I82559FE, address is 000e.8335.7c30 (bia 000e.8335.7c30)
  Interface is unnumbered. Using address of Loopback2 (10.1.152.241)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:14, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     138507 packets input, 21920546 bytes, 0 no buffer
     Received 2237 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     421216 packets output, 53661814 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

The following is an example of output for the service-module service-engine 4/0 status command on the Cisco CME for Cisco Unity Express:

3845-gw# service-module service-Engine 4/0 status

Service Module is Cisco Service-Engine4/0
Service Module supports session via TTY line 258
Service Module is in Steady state
Getting status from the Service Module, please wait..
cisco service engine 1.1

The following is an example of output for the service-module service-engine 4/0 status session command on the Cisco CME for Cisco Unity Express:

3845-gw# service-module service-engine 4/0 session

Trying 10.1.152.241, 2258 ... Open


User Access Verification

Username: cisco
Password: 
se-10-32-152-242# 
se-10-32-152-242# 

The following is an example of output for the show running-config command on Cisco Unity Express:

se-10-32-152-242# show running-config

Generating configuration:

clock timezone America/Los_Angeles

hostname se-10-32-152-242

ip domain-name cisco.com
ip name-server 10.64.2.113 10.64.11.48

ntp server 10.1.152.241

groupname Administrators create

username Ross create
username Rachel create
username Chandler create
username Monica create
username Jeshih create
username Mike create
username Phoebe create
username Cosmo create
username Jerry create
username George create
username Frank create
username Estelle create
username Ross phonenumber "27725"
username Rachel phonenumber "27726"
username chandler phonenumber "27727"
username Monica phonenumber "27728"
username Jeshih phonenumber "27729"
username Mike phonenumber "27730"
username Phoebe phonenumber "27731"
username Cosmo phonenumber "27732"
username Jerry phonenumber "27733"
username George phonenumber "27734"
username Frank phonenumber "27735"
username Estelle phonenumber "27736"

groupname Administrators member cisco
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts

backup server url "ftp://127.0.0.1/ftp" credentials hidden "EWlTygcMhYmjazXhE/VN
XHCkplVV4KjescbDaLa4fl4WLSPFvv1rWUnfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35jwAAAAA="

ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "MaxRetry" "3"
 parameter "operExtn" "0"
 parameter "welcomePrompt" "AAWelcome.wav"
 end application

ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8000"
 parameter "strMWI_ON_DN" "8001"
 parameter "CallControlGroupID" "0"
 end application

ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application

ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application

ccn engine
 end engine

ccn subsystem jtapi
 ccm-manager address 
 end subsystem

ccn subsystem sip
 gateway address "10.1.152.241"
 end subsystem

ccn trigger sip phonenumber 27748
 application "autoattendant"
 enabled
 locale "en_US"
 maxsessions 8
 end trigger

ccn trigger sip phonenumber 27749
 application "voicemail"
 enabled
 locale "en_US"
 maxsessions 8
 end trigger

ccn trigger sip phonenumber 27751
 application "promptmgmt"
 enabled
 locale "en_US"
 maxsessions 1
 end trigger

voicemail default expiration time 30
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail recording time 900
voicemail default messagesize 60
voicemail operator telephone 0
voicemail capacity time 6000
voicemail mailbox owner "Ross" size 3000
 description "Ross mailbox"
 end mailbox

voicemail mailbox owner "Rachel" size 3000
 description "Rachel mailbox"
 end mailbox

voicemail mailbox owner "Chandler" size 3000
 description "Chandler mailbox"
 end mailbox

voicemail mailbox owner "Monica" size 3000
 description "Monica mailbox"
 end mailbox
 
 voicemail mailbox owner "Jeshih" size 3000
  description "Jeshih mailbox"
  end mailbox

voicemail mailbox owner "Mike" size 3000
 description "Mike mailbox"
 end mailbox

voicemail mailbox owner "Phoebe" size 3000
 description "Phoebe mailbox"
 end mailbox

voicemail mailbox owner "Cosmo" size 3000
 description "Cosmo mailbox"
 end mailbox

voicemail mailbox owner "Jerry" size 3000
 description "Jerry mailbox"
 end mailbox

voicemail mailbox owner "George" size 3000
 description "George mailbox"
 end mailbox

voicemail mailbox owner "Frank" size 3000
 description "Frank mailbox"
 end mailbox
 
 voicemail mailbox owner "Estelle" size 3000
  description "Estelle mailbox"
 end mailbox

end

The following is an example of output for the show voicemail mailboxes command on Cisco Unity Express:

se-10-32-152-242# show voicemail mailboxes

OWNER                              MSGS NEW  SAVED  MSGTIME MBXSIZE   USED
"Ross"                             0    0    0      0       3000      0 %
"Rachel"                           0    0    0      0       3000      0 %
"Chandler"                         0    0    0      0       3000      0 %
"Monica"                           3    3    0      142     3000      5 %
"Jeshih"                           0    0    0      0       3000      0 %
"Mike"                             0    0    0      0       3000      0 %
"Phoebe"                           0    0    0      0       3000      0 %
"Cosmo"                            0    0    0      0       3000      0 %
"Jerry"                            0    0    0      0       3000      0 %
"George"                           0    0    0      0       3000      0 %
"Frank"                            0    0    0      0       3000      0 %
"Estelle"                          0    0    0      0       3000      0 %

The following is an example of output for the show voicemail usage command on Cisco Unity Express:

se-10-32-152-242# show voicemail usage

personal mailboxes:                     12
general delivery mailboxes:             0
orphaned mailboxes:                     0
capacity of voicemail (minutes):        6000
allocated capacity (minutes):           600.0
message time used (seconds):            141
message count:                          3
average message length (seconds):       47.0
greeting time used (seconds):           0
greeting count:                         0
average greeting length (seconds):      0.0
total time used (seconds):              141
total time used (minutes):              2.3499999046325684
percentage used time (%):               1

The following is an example of output for the show voicemail limits command on Cisco Unity Express:

se-10-32-152-242# show voicemail limits

Default Mailbox Size (seconds):         3000
Default Caller Message Size (seconds):  60
Maximum Recording Size (seconds):       900
Default Message Age (days):             30
System Capacity (minutes):              6000
Default Prompt Language:                en_US
Operator Telephone:                     0

The following is an example of output for the show ccn application command on Cisco Unity Express:

se-10-32-152-242# show ccn application

Name:                                   ciscomwiapplication
Description:                            ciscomwiapplication
Script:                                 setmwi.aef
ID number:                              0
Enabled:                                yes
Maximum number of sessions:             8
strMWI_OFF_DN:                          8000
strMWI_ON_DN:                           8001
CallControlGroupID:                     0

Name:                                   voicemail
Description:                            voicemail
Script:                                 voicebrowser.aef
ID number:                              1
Enabled:                                yes
Maximum number of sessions:             8
logoutUri:                              http://localhost/voicemail/vxmlscripts/m
bxLogout.jsp
uri:                                    http://localhost/voicemail/vxmlscripts/l
ogin.vxml

Name:                                   autoattendant
Description:                            autoattendant
Script:                                 aa.aef
ID number:                              2
Enabled:                                yes
Maximum number of sessions:             8
MaxRetry:                               3
operExtn:                               0
welcomePrompt:                          AAWelcome.wav
Name:                                   promptmgmt
Description:                            promptmgmt
Script:                                 promptmgmt.aef
ID number:                              3
Enabled:                                yes
Maximum number of sessions:             1

The following is an example of output for the show ccn trigger command on Cisco Unity Express:

se-10-32-152-242# show ccn trigger

Name:                         27749
Type:                         SIP
Application:                  voicemail
Locale:                       en_US
Idle Timeout:                 10000
Enabled:                      yes
Maximum number of sessions:   8

Name:                         27751
Type:                         SIP
Application:                  promptmgmt
Locale:                       en_US
Idle Timeout:                 10000
Enabled:                      yes
Maximum number of sessions:   1

Name:                         27748
Type:                         SIP
Application:                  autoattendant
Locale:                       en_US
Idle Timeout:                 10000
Enabled:                      yes
Maximum number of sessions:   8
se-10-32-152-242#

Verification Screens: Examples

The following display screen examples depict the graphical user interface for Cisco CallManager, Cisco CallManager Express (Cisco CME) and Cisco Unity Express for verification purposes. These screen examples are shown for your reference are presented in the following sections:

Cisco CallManager Screen Examples

Cisco CME Screen Examples

Cisco Unity Express Screen Examples

Cisco CallManager Screen Examples

The screen display example below shows Cisco CallManager Release 3.3(3) trunk configuration for a Cisco CME.

The screen display example below depicts media termination point (MTP) software configuration.

Cisco CME Screen Examples

The screen display example below identifies Cisco CallManager extensions.

The screen display example below provides details about Cisco CME phones.

Cisco Unity Express Screen Examples

The screen display example below lists voice mailboxes on Cisco Unity Express user configuration.

The screen display example below provides details about voice mailboxes on Cisco Unity Express.

The screen display example below depicts the Group Profile-Administrator display.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

See the following tech notes:

IP Security Troubleshooting - Understanding and Using debug Commands

Troubleshooting Reference Documents and Commands

The following references and command recommendations offer guidance for troubleshooting Cisco CME-based Cisco Unity Express implementations.


Note Before issuing debug commands, see Important Information on Debug Commands.


For troubleshooting and debugging VoIP call basics, see the following document:

http://www.cisco.com/warp/public/788/voip/voip_debugcalls.html

The following specific commands related to troubleshooting VoIP calls:

show dialplan number—This command is used to show which dial peer is reached when a particular telephone number is dialed.

debug vtsp session—This command displays information to help you trace how the router interacts with the DSP based on the signalling indications from the signalling stack and requests from the application.

debug vtsp dsp—This command displays the digits as they are received by the voice port.

debug vtsp all—This command enables the following debug voice telephony service provider (VTSP) commands: debug vtsp session, debug vtsp error, and debug vtsp dsp.

debug vpm signal—This command collects debug information only for signaling events. This command can also be useful in resolving problems with signaling to a PBX.

debug voip ccapi—This command traces the execution path through the call control application programming interface (API),, which serves as the interface between the call session application and the underlying network-specific software. You can use the output from this command to understand how calls are being handled by the router.

debug vpm port—This command is to limit the debug output to a particular port. The debug output can be quite voluminous for a single port. A six-port chassis might create problems. Use this debug command with any or all of the other debug modes

Related Information

For additional information about Cisco CallManager Express, go to:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/index.html

For additional information about Cisco Unity Express, go to:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/index.html