Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
Configuring Dial Backup and Remote Management
Downloads: This chapterpdf (PDF - 292.0KB) The complete bookPDF (PDF - 2.29MB) | Feedback

Table of Contents

Configuring Dial Backup and Remote Management

Dial Backup Feature Activation Methods

Backup Interfaces

Configuring Backup Interfaces

Floating Static Routes

Configuring Floating Static Routes

Dialer Watch

Configuring Dialer Watch

Dial Backup Feature Limitations

Configuration Example

Configuring Dial Backup and Remote Management Through the ISDN S/T Port

Configure ISDN Settings

Configure the Aggregator and ISDN Peer Router

Configuring Dial Backup and Remote Management Through a V.92 Modem

Asynchronous Interface Configuration

Line Configuration

Configuring Dial Backup and Remote Management

The Cisco 1800 integrated services fixed-configuration routers support dial-in (for remote management) and dial-out (for dial backup) capabilities. By allowing you to configure a backup modem line connection, the Cisco 1800 integrated services fixed-configuration routers provide protection against WAN downtime. Dial backup is inactive by default, and must be configured to be active.

Dial backup and remote management functions are configured through the ISDN S/T port of the Cisco 1812, Cisco 1801, Cisco 1802, and Cisco 1803 routers. These functions are configured through the V.92 modem port of the Cisco 1811 router.

This chapter contains the following topics:

Dial Backup Feature Activation Methods

Three methods are available to activate the dial backup feature:

Backup Interfaces

When the router receives an indication that the primary line is down, a backup interface is brought up. You can configure the backup interface to go down once the primary connection has been restored for a specified period.

This is accomplished using dial-on-demand routing (DDR). When this is configured, a backup call is triggered by specified traffic.


Note Even if the backup interface comes out of standby mode (is brought up), the router does not trigger the backup call unless it receives the specified traffic for that backup interface.


Configuring Backup Interfaces

Perform these steps to configure your router with a backup interface, beginning in global configuration mode:

 

Command
Purpose

Step 1

interface type number

Example:

Router(config)# interface atm 0
Router(config-if)#
 

Enters interface configuration mode for the interface for which you want to configure backup.

This can be a serial interface, ISDN interface, or asynchronous interface.

The example shows the configuration of a backup interface for an ATM WAN connection.

Step 2

backup interface interface-type interface-number

Example:

Router(config-if)# backup interface bri 0
Router(config-if)#
 

Assigns an interface as the secondary, or backup interface.

This can be a serial interface or asynchronous interface. For example, a serial 1 interface could be configured to back up a serial 0 interface.

The example shows a Basic Rate Interface configured as the backup interface for the ATM 0 interface.

Step 3

exit

Example:

Router(config-if)# exit
Router(config)#
 

Enters global configuration mode.

Floating Static Routes

Floating static routes provide alternative routes for traffic. Floating static routes are not activated unless a DDR backup call has been triggered by specified traffic for a backup interface.

Floating static routes are independent of line protocol status. This is an important consideration for Frame Relay circuits because the line protocol may not go down if the data-link connection identifier (DLCI) is inactive. Floating static routes are also encapsulation independent.


Note When static routes are configured, the primary interface protocol must go down in order to activate the floating static route.


Configuring Floating Static Routes

Static and dynamic routes are the two components of floating static routes. Perform these steps to configure the static and dynamic routes on your router, beginning in global configuration mode:

 

Command
Purpose

Step 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

Assigns the primary static route.

Step 2

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
Router(config)#
 

Assigns the lower routing administrative distance value for the backup interface route. 192.168.2.2 is the peer IP address of the backup interface.

Step 3

router rip

Example:

Router(config)# router ri p
Router(config)#
 

Enables RIP routing.

Step 4

network ip-address

Example:

Router(config)# network 22.0.0.0
Router(config)#
 

Defines the primary interface network. 22.0.0.0 is the network value of the primary interface.

Step 5

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
Router(config)#
 

Assigns the lower routing administrative distance value for the backup interface route. 192.168.2.2 is the peer IP address of the backup interface.


Note When dynamic routing is activated, the floating static route depends upon routing protocol convergence times.


Dialer Watch

The dialer watch method only supports the Extended Interior Gateway Routing Protocol (EIGRP) link-state dynamic routing protocols.

Configuring Dialer Watch

Perform these steps to configure a dialer watch on your router, beginning in global configuration mode:

 

Command
Purpose

Step 1

interface type number

Example:

Router(config)# interface dialer 2
Router(config-if)#
 

Enters configuration mode for the dial backup interface.

Step 2

dialerwatch-group group-number

Example:

Router(config-if)# dialer watch-group 2
Router(config-if)#
 

Specifies the group number for the watch list.

Step 3

exit

Example:

Router(config-if)# exit
Router(config)#
 

Enters global configuration mode.

Step 4

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

Assigns the primary route. 22.0.0.2 is the peer IP address of the primary interface.

Step 5

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
Router(config)#
 

Assigns the lower routing administrative distance value for the backup interface route. 192.168.2.2 is the peer IP address of the backup interface.

Step 6

dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

Example:

Router(config)# dialer watch-list 2 ip 22.0.0.2 255.255.255.255
Router(config)#
 

Assigns an IP address to the watch list.

If the connection on the primary interface is lost and the IP address is unavailable on the router, the dial-out feature on the backup interface is triggered. 22.0.0.2 is the peer IP address of the primary interface.

Dial Backup Feature Limitations

The following limitation exists for the dial backup feature: bridging is not supported over console or auxiliary port backup interfaces.

Table 13-1 summarizes dial backup support and limitations for the Cisco 1800 series integrated services fixed-configuration routers.

 

Table 13-1 Dial Backup Feature Support and Limitations Summary

WAN Encapsulation Type
Dial Backup Possible?
Dial Backup Method
Limitations
Cisco 1811 or Cisco 1812

PPPoE

Yes

Dialer watch

Bridging is not supported across a slow interface, for example, an auxiliary port. The peer IP address of the ISP is needed to configure the dialerwatch command and the IP static route.

Normal IP in cable modem scenario

No

Dialer watch

The IP addresses of the peers are needed for dialer watch to work properly. If a lease time obtained by DHCP is not set short enough (1 or 2 minutes), dial backup is not supported.

Cisco 1801, Cisco 1802, or Cisco 1803

PPP over ATM

PPP over Ethernet

Yes

Backup interfaces

Floating static routes

Dialer watch

Floating static route and dialer watch need a routing protocol to run in the router. The dialer watch method brings up the backup interface as soon as the primary link goes down. The backup interface is brought down as soon as the dialer timeout is reached and the primary interface is up. The router checks the primary interface only when the dialer timeout expires. The backup interface remains up until the dialer timeout is reached, even though the primary interface is up.

For the dialer watch method, a routing protocol does not need to be running in the router, if the IP address of the peer is known.

RFC 1483 (AAL5, SNAP, and MUX)

Yes

Backup interfaces

Floating static routes

Dialer watch

If bridging is done through the WAN interface, it is not supported across the auxiliary port.

Configuration Example

The following three examples show sample configurations for the three dial backup methods.

Example 13-1 Configuring Dial Backup Using Backup Interfaces

!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
!Specifies the ISDN switch type
isdn switch-type basic-net3
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
!ISDN interface to be used as a backup interface
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
backup interface BRI0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. Dialer pool 1 associates it with BRI0’s dialer pool member 1
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer-group 1
!
! Primary interface associated with physical ATM0’s interface, dialer pool 2 associates it with ATM0’s dial-pool-number2
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
!
ip classless
!Primary and backup interface given route metric
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
!Specifies interesting traffic to trigger backup ISDN traffic
dialer-list 1 protocol ip permit
 

Example 13-2 Configuring Dial Backup Using Floating Static Routes

!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
!Specifies the ISDN switch type
isdn switch-type basic-net3
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
!ISDN interface to be used as a backup interface
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. Dialer pool 1 associates it with BRI0’s dialer pool member 1
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer-group 1
!
! Primary interface associated with physical ATM0’s interface, dialer pool 2 associates it with ATM0’s dial-pool-number2
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
!
ip classless
no cdp enable
!Primary and backup interface given route metric (This example using static routes, thus atm0 line protocol must be brought down for backup interface to function.)
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
ip http server
!
!Specifies interesting traffic to trigger backup ISDN traffic
dialer-list 1 protocol ip permit
 

Example 13-3 Configuring Dial Backup Using Dialer Watch

!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
!Specifies the ISDN switch type
isdn switch-type basic-net3
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
!ISDN interface to be used as a backup interface
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. Dialer pool 1 associates it with BRI0’s dialer pool member 1. Note “dialer watch-group 1” associates a watch list with corresponding “dialer watch-list” command
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer watch-group 1
dialer-group 1
!
! Primary interface associated with physical ATM0 interface, dialer pool 2 associates it with ATM0’s dial-pool-number2
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
!
ip classless
 
!Primary and backup interface given route metric
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
!Watch for interesting traffic
dialer watch-list 1 ip 22.0.0.2 255.255.255.255
 
!Specifies interesting traffic to trigger backup ISDN traffic
dialer-list 1 protocol ip permit
!

Configuring Dial Backup and Remote Management Through the ISDN S/T Port

The Cisco 1812, Cisco 1801, Cisco 1802, and Cisco 1803 routers use the ISDN S/T port for dial backup and remote management. Perform the following tasks to configure dial backup and remote management through the ISDN S/T port of your router:

Configure ISDN Settings

Configure ISDN Settings


Note Traffic of interest must be present to activate the backup ISDN line by means of the backup interface and floating static routes methods. Traffic of interest is not needed for the dialer watch to activate the backup ISDN line.


Perform these steps to configure your router ISDN interface for use as a backup interface, beginning in global configuration mode:

 

Command
Purpose

Step 1

isdn switch-type switch-type

Example:

Router(config)# isdn switch-type basic-net3
Router(config)#
 

Specifies the ISDN switch type.

The example specifies a switch type used in Australia, Europe, and the United Kingdom. For details on other switch types supported, see the Cisco IOS Dial Technologies Command Reference .

Step 2

interface type number

Example:

Router(config)# interface bri 0
Router(config-if)#
 

Enters configuration mode for the ISDN Basic Rate Interface (BRI).

Step 3

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

Sets the BRI0 interface encapsulation type.

Step 4

dialer pool-member number

Example:

Router(config-if)# dialer pool-member 1
Router(config-if)#
 

Specifies the dialer pool membership.

Step 5

isdn switch-type switch-type

Example:

Router(config-if)# isdn switch-type basic-net3
Router(config-if)#
 

Specifies the ISDN switch type.

Step 6

exit

Example:

Router(config-if)# exit
Router(config)#
 

Enters global configuration mode.

Step 7

interface dialer dialer-rotary-group-number

Example:

Router(config)# interface dialer 0
Router(config-if)#
 

Creates a dialer interface (numbered 0–255) and enters into interface configuration mode.

Step 8

ip address negotiated

Example:

Router(config-if)# ip address negotiated
Router(config-if)#
 

Specifies that the IP address for the interface is obtained through PPP/IPCP (IP Control Protocol) address negotiation. The IP address is obtained from the peer.

Step 9

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

Sets the encapsulation type to PPP for the interface.

Step 10

dialer pool number

Example:

Router(config-if)# dialer pool 1
Router(config-if)#
 

Specifies the dialer pool to be used.

In the example, the dialer pool 1 setting associates the dialer 0 interface with the BRI0 interface because the BRI0 dialer pool-member value is 1.

Step 11

dialer string dial-string [ : isdn-subaddress ]

Example:

Router(config-if)# dialer string 384040
Router(config-if)#
 

Specifies the telephone number to be dialed.

Step 12

dialer-group group-number

Example:

Router(config-if)# dialer group 1
Router(config-if)#
 

Assigns the dialer interface to a dialer group (1–10).

Step 13

exit

Example:

Router(config-if)# exit
Router(config)#
 

Exits the dialer 0 interface configuration mode, and enters global configuration mode.

Step 14

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

Example:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

Creates a dialer list for packets of interest to be forwarded through the specified interface dialer group.

In the example, dialer-list 1 corresponds to dialer-group 1.

For details about this command and additional parameters that can be set, see the Cisco IOS Dial Technologies Command Reference .

Configure the Aggregator and ISDN Peer Router

The aggregator is typically a concentrator router where your Cisco router ATM PVC terminates. In the configuration example shown below, the aggregator is configured as a PPPoE server to correspond with the Cisco 876 router configuration example that is given in this chapter.

The ISDN peer router is any router that has an ISDN interface and can communicate through a public ISDN network to reach your Cisco router ISDN interface. The ISDN peer router provides Internet access for your Cisco router during the ATM network downtime.

!This portion of the example configures the aggregator
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
interface Ethernet3
description “4700ref-1”
ip address 40.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Ethernet4
ip address 30.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Virtual-Template1
ip address 22.0.0.2 255.255.255.0
ip mtu 1492
peer default ip address pool adsl
!
interface ATM0
no ip address
pvc 1/40
encapsulation aal5snap
protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
 
!This portion of the example configures the ISDN peer
isdn switch-type basic-net3
!
interface Ethernet0
ip address 30.1.1.2 255.0.0.0
!
interface BRI0
description “to 836-dialbackup”
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer0
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 384020
dialer-group 1
peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
!
dialer-list 1 protocol ip permit
!

 

Configuring Dial Backup and Remote Management Through a V.92 Modem

Perform the following tasks to configure dial backup and remote management through the V.92 modem on your Cisco 1811 router:

Asynchronous Interface Configuration

Asynchronous Interface Configuration

Perform these steps to configure the V.92 modem for use as a backup interface, beginning in global configuration mode:

 
Command
Purpose

Step 1

interface type number

Example:

Router(config)# interface async 1
Router(config-if)#
 

Enters interface configuration mode for the asynchronous serial interface. Enter the number of the interface you want to configure.

Step 2

ip unnumbered type number

Example:

Router(config-if)# ip unnumbered FastEthernet 2
Router(config-if)#
 

Conserves IP addresses by configuring the asynchronous interface as unnumbered, and assigns the IP address of the interface type that you want to leverage.

Step 3

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

Sets the encapsulation type to PPP for the interface.

Step 4

dialer in-band

Example:

Router(config-if)# dialer in-band
Router(config-if)#
 

Specifies support for dial-on-demand routing (DDR) and chat scripts on this asynchronous interface.

Step 5

dialer string dial-string

Example:

Router(config-if)# dialer string T14085551234
Router(config-if)#
 

Specifies the telephone number to be dialed.

Step 6

dialer-group group-number

Example:

Router(config-if)# dialer group 1
Router(config-if)#
 

Assigns the dialer interface to a dialer group (1–10), controlling access. The number to which the dialer access group belongs is defined with the dialer-list command.

Step 7

async mode interactive

Example:

Router(config-if)# async mode interactive Router(config-if)#
 

Returns a line that has been placed into dedicated asynchronous network mode to interactive mode, thereby enabling the Serial Line Internet Protocol (SLIP) and PPP EXEC commands.

Step 8

peer default ip address { ip-address | pool [ pool-name ]}

Example:

Router(config-if)# peer default ip address pool pool123
Router(config-if)#
 

Assigns IP addresses to remote clients, using an address pool. To create an IP address pool, use the ip local pool global configuration command.

Step 9

exit

Example:

Router(config-if)# exit
Router(config)#
 

Exits asynchronous interface configuration, and enters global configuration mode.

Line Configuration

Perform these steps to configure the line on the V.92 modem, beginning in global configuration mode:

 
Command
Purpose

Step 1

line line-number

Example:

Router(config)# line 1
Router(config-line)
 

Identifies a specific line for configuration and enters line configuration collection mode.

Note The number entered here must be the same as the number entered for the asynchronous serial interface.

Step 2

modem inout

Example:

Router(config-line)# modem inout
Router(config-line)#
 

Configures the line for both incoming and outgoing calls.

Step 3

autoselect { arap | ppp | slip | during-login | timeout seconds }

Example:

Router(config-line)# autoselect ppp
Router(config-line)#
 

Configures the line to automatically start an AppleTalk Remote Access (ARA), PPP, or SLIP session.

for use with the dial backup feature.

Step 4

transport input { all | lat | mop | nasi | none | pad | rlogin | telnet | v120 }

Example:

Router(config-line)# transport input all
Router(config-line)#
 

Defines which protocols can be used to connect to the line.

for use with the dial backup feature.

Step 5

exit

Example:

Router(config-line)# exit
Router(config)#
 

Exits line configuration mode, and enters global configuration mode.