Cisco 1800 Series Integrated Service Routers (Fixed) Hardware Installation Guide
Power Up and Initial Configuration Procedures
Downloads: This chapterpdf (PDF - 431.0KB) The complete bookPDF (PDF - 2.93MB) | Feedback

Power-Up and Initial Configuration Procedures

Table Of Contents

Power-Up and Initial Configuration Procedures

Powering Up Cisco 1800 Series Fixed-Configuration Routers

Checklist for Power Up

Power-Up Procedure

Verifying the Front Panel LED Indications

Verifying the Hardware Configuration

Configuring the Router

Initial Configuration Using Cisco Router and Security Device Manager

Initial Configuration Using the Setup Command Facility

Initial Configuration Using the Cisco CLI—Manual Configuration

Verifying the Initial Configuration

Completing the Configuration


Power-Up and Initial Configuration Procedures


This chapter describes how to power up your Cisco 1800 series fixed-configuration router and perform an initial configuration for network access. This chapter includes the following sections:

Powering Up Cisco 1800 Series Fixed-Configuration Routers

Configuring the Router

Powering Up Cisco 1800 Series Fixed-Configuration Routers

This section includes the following topics:

Checklist for Power Up

Power-Up Procedure

Verifying the Front Panel LED Indications

Verifying the Hardware Configuration

Checklist for Power Up

After you ensure that the following conditions have been met, you can power up the Cisco 1800 series fixed-configuration router:

The chassis is securely mounted and grounded.

The power and interface cables are connected.

The external CompactFlash memory card is properly seated into its slot. For installation instructions, see the "Removing and Installing CompactFlash Cards" section on page 7-7.

A PC with terminal emulation program (HyperTerminal or equivalent) is connected to the console port and powered up.

Your PC terminal emulation program is configured for 9600 baud, 8 data bits, 1 stop bit, and no parity, and flow control is set to "none."

A suitable PC COM port is selected in the terminal emulation program.

You have selected passwords for access control.

You have determined the IP addresses for the Ethernet and serial interfaces.

Power-Up Procedure

To power up your Cisco router and verify that it completes initialization and self-test, follow the procedure below. After you complete this procedure, you can configure the router.

If you encounter problems when you power on the router, see the "Troubleshooting" chapter.


Note To view the boot sequence, you must have a console connection to the router before it powers up.



Step 1 Make sure that your PC is powered up and connected as described in the "Checklist for Power Up" section.

Step 2 Move the power switch to the ON position.

The following indications appear:

The SYS OK LED on the front of the chassis blinks green.

The fans operate.

If you encounter problems when you power up the router, see the "Troubleshooting" chapter.

Startup messages appear in your terminal emulation program window. When the startup messages end, the SYS OK LED comes on solid green.


Caution Do not press any keys on the keyboard until the messages stop and the SYS OK LED is solid green. Any keys pressed during this time are interpreted as the first command entered when the messages stop, which might cause the router to power off and start over. The messages will stop after a few minutes.

You may see various startup messages:

If you see the following messages, the router has booted with a configuration file and is ready for initial configuration using Cisco Router and Security Device Manager (SDM).

yourname con0 is now available

Press RETURN to get started.

If these messages do not appear, then the Cisco SDM software and the Cisco Router and Security Device Manager (SDM) Quick Start Guide were not shipped with your router. If SDM is installed on your router, we recommend using SDM to perform the initial configuration. To configure your router using SDM, or to obtain SDM and install it on your router, see the "Initial Configuration Using Cisco Router and Security Device Manager" section.

If you see the following messages, the router has booted and is ready for initial configuration using the setup command facility or the command-line interface (CLI).

--- System Configuration Dialog ---

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Would you like to enter the initial configuration dialog? [yes/no]:

To use the setup command facility to configure the router, see the "Initial Configuration Using the Setup Command Facility" section.

To use the CLI to configure the router, see the "Initial Configuration Using the Cisco CLI—Manual Configuration" section.


Note If the rommon 1> prompt appears, your system has booted in ROM monitor mode.



Verifying the Front Panel LED Indications

The front-panel indicator LEDs described in Table 5-1 provide power, activity, and status information useful during power up. For more detailed information about the LEDs, see the "LED Indicators" section on page 1-4.

Table 5-1 LED Indicators for the Cisco 1800 Series Fixed-Configuration Router 

LED Label
LED Color or State
Meaning

SYS OK

Solid green

System is operating normally

Blinking green

System is booting or is in ROM monitor mode

Off

Power is off, or there is a power fault

POE1

Green

Inline power supply is installed and operating normally

Amber

Inline power supply fault

Off

Inline power supply is not installed

CF

Blinking green or solid green

CompactFlash memory is being accessed; do not eject

Off

CompactFlash memory is not being accessed; OK to eject

1 Inline power is a field-upgradable option on Cisco 1800 series fixed-configuration routers; inline power is not installed by default.


Verifying the Hardware Configuration

To display and verify the hardware features, enter the following commands:

show version—Displays the system hardware version; the installed software version; the names and sources of configuration files; the boot images; and the amount of installed DRAM, NVRAM, and flash memory.

show diag—Lists and displays diagnostic information about the controllers and interface processors.

Configuring the Router

This section includes the following topics:

Initial Configuration Using Cisco Router and Security Device Manager

Initial Configuration Using the Setup Command Facility

Initial Configuration Using the Cisco CLI—Manual Configuration

Verifying the Initial Configuration

Completing the Configuration

You can configure your router by using one of the following tools:

Cisco Router and Security Device Manager—See the "Initial Configuration Using Cisco Router and Security Device Manager" section.

Setup command facility—See the "Initial Configuration Using the Setup Command Facility" section.

Command-line interface (CLI)—See the "Initial Configuration Using the Cisco CLI—Manual Configuration" section.


Note For a description of the interface and port numbering, see the "Interface Numbering" section on page 1-11.


Initial Configuration Using Cisco Router and Security Device Manager

The following messages appear at the end of the startup sequence:

yourname con0 is now available

Press RETURN to get started.

For instructions on configuring your router by using Cisco Router and Security Device Manager (SDM), see the Cisco Router and Security Device Manager (SDM) Quick Start Guide that shipped with your router. If the above messages do not appear, then the Cisco SDM software and the Cisco Router and Security Device Manager (SDM) Quick Start Guide were not shipped with your router. If you want to use SDM, you can download the latest version of SDM and instructions for installing it from the following location:

http://www.cisco.com/pcgi-bin/tablebuild.pl/sdm

To obtain the SDM quick start guide, SDM release notes, and other SDM documentation, go to www.cisco.com/go/sdm and click the Technical Documentation link.

For a description of the interface and port numbering, see the "Interface Numbering" section on page 1-11.

Initial Configuration Using the Setup Command Facility

This section shows how to use the setup command facility to configure a hostname for the router, set passwords, and configure an interface for communication with the management network. If you see the following messages at the end of the startup sequence, the setup command facility has been invoked automatically:

--- System Configuration Dialog ---

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Would you like to enter the initial configuration dialog? [yes/no]:

The setup command facility prompts you for basic information about your router and network, and it creates an initial configuration file. After the configuration file has been created, you can use the CLI or SDM to perform additional configuration.

The prompts in the setup command facility vary, depending on your router model, the installed interface modules, and the software image. The following example and the user entries (in bold) are shown as examples only.

For a description of the interface numbering, see the "Interface Numbering" section on page 1-11.


Note If you make a mistake while using the setup command facility, you can exit and run the setup facility again. Press Ctrl-C, and enter setup at the privileged EXEC mode prompt (Router#).



Step 1 To proceed using the setup command facility, enter yes when the power-up messages have ended.

Would you like to enter the initial configuration dialog? [yes/no]: yes

Step 2 When the following messages appear, press Return to enter basic management setup:

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes

Step 3 Enter a hostname for the router (this example uses Router):

Configuring global parameters:

Enter host name [Router]: Router

Step 4 Enter an enable secret password. This password is encrypted (more secure) and cannot be seen when you view the configuration:

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: xxxxxx

Step 5 Enter an enable password that is different from the enable secret password. This password is not encrypted (less secure) and can be seen when you view the configuration:

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: xxxxxx

Step 6 Enter the virtual terminal password, which prevents unauthenticated access to the router through ports other than the console port:

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: xxxxxx

Step 7 Respond to the following prompts as appropriate for your network:

Configure SNMP Network Management? [yes]:
    Community string [public]:

A summary of the available interfaces appears.

Current interface summary

Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
Async1                     unassigned      YES unset  down                  down
FastEthernet0              unassigned      NO  unset  up up
FastEthernet1              unassigned      NO  unset  up down
FastEthernet2              unassigned      NO  unset  initializing down
FastEthernet3              unassigned      NO  unset  initializing down
FastEthernet4              unassigned      NO  unset  initializing down
FastEthernet5              unassigned      NO  unset  initializing down
FastEthernet6              unassigned      NO  unset  initializing down
FastEthernet7              unassigned      NO  unset  initializing down
FastEthernet8              unassigned      NO  unset  initializing down
FastEthernet9              unassigned      NO  unset  initializing down
Vlan1                      unassigned      YES unset  up                    down

Step 8 Choose one of the available interfaces for connecting the router to the management network:

Enter interface name used to connect to the
management network from the above interface summary: fastethernet0

Step 9 Respond to the following prompts as appropriate for your network:

Configuring interface FastEthernet0:
Use the 100 Base-TX (RJ-45) connector? [yes]: yes
Operate in full-duplex mode? [no]: no
Configure IP on this interface? [yes]: yes
    IP address for this interface: 172.16.2.3
    Subnet mask for this interface [255.255.0.0] : 255.255.0.0
    Class B network is 172.16.0.0, 16 subnet bits; mask is /16

Step 10 The configuration is displayed:

The following configuration command script was created:

hostname Router
enable secret 5 $1$AaVU$9tl.HLXo/M1oYglcLDVIN1
enable password 654321
line vty 0 4
password 123456
snmp-server community public
!
no ip routing

!
interface FastEthernet0
no shutdown
media-type 100BaseX
full-duplex
ip address 172.16.2.3 255.255.0.0
!
interface FastEthernet1
shutdown
no ip address
!
interface FastEthernet2
shutdown
no ip address
!
interface FastEthernet3
shutdown
no ip address
!
interface FastEthernet4
shutdown
no ip address
!
interface FastEthernet5
shutdown
no ip address
!
interface FastEthernet6
shutdown
no ip address
!
interface FastEthernet7
shutdown
no ip address
!
interface FastEthernet8
shutdown
no ip address
!
interface FastEthernet9
shutdown
no ip address
!
interface Vlan1
shutdown
no ip address
!
end

Step 11 Respond to the following prompts. Enter 2 to save the initial configuration:

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2
Building configuration...
Use the enabled mode 'configure' command to modify this configuration.


Press RETURN to get started!

The user prompt appears.

Router>

Step 12 Verify the initial configuration. See the "Verifying the Initial Configuration" section for verification procedures.


Initial Configuration Using the Cisco CLI—Manual Configuration

This section describes how to display a command-line interface (CLI) prompt for configuration using the CLI, and it directs you to documentation for the CLI configuration. You can use the CLI if you see the following messages at the end of the startup sequence:

--- System Configuration Dialog ---

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Would you like to enter the initial configuration dialog? [yes/no]:

If these messages do not appear, then the Cisco SDM software and a default configuration file were installed on the router at the factory. To use SDM to configure your router, see the "Initial Configuration Using Cisco Router and Security Device Manager" section.

For a description of interface and port numbering, see the "Interface Numbering" section on page 1-11.


Step 1 To proceed with manual configuration using the CLI, enter no when the power-up messages end:

Would you like to enter the initial configuration dialog? [yes/no]: no

Step 2 To terminate autoinstall and continue with manual configuration, press Return:

Would you like to terminate autoinstall? [yes] Return

Several messages are displayed, ending with lines similar to the following:

...
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled <date> <time> by <person>

Step 3 To bring up the Router> prompt, press Return:

...
flashfs[4]: Initialization complete.
Router>

Step 4 Enter privileged EXEC mode:

Router> enable 
Router#

Step 5 For configuration procedures, see the online document Cisco 1800 Series Integrated Services Router (Fixed) Software Configuration Guide.


Note To avoid losing the work that you have completed, be sure to save your configuration occasionally as you proceed. Use the copy running-config startup-config command to save the configuration to NVRAM.


Step 6 After you finish the initial configuration, you need to verify the initial configuration. See the "Verifying the Initial Configuration" section for verification procedures.


Verifying the Initial Configuration

To verify that the new interfaces are operating correctly, enter commands as follows:

To verify that the interfaces are operating correctly and that the interfaces and line protocol are in the correct state—up or down—enter show interfaces.

To display a summary status of the interfaces configured for IP, enter show ip interface brief.

To verify that you configured the correct hostname and password, enter show configuration.

After you complete and verify the initial configuration, you can configure your Cisco 1800 series fixed-configuration router for specific functions. See the "Completing the Configuration" section for information about locating documentation for advanced configuration procedures.

Completing the Configuration

After you complete and verify the initial configuration, you can configure your Cisco 1800 series fixed-configuration router for specific functions. For advanced configuration procedures, use either SDM or the CLI.

For configuration procedures using SDM, see the Cisco Router and Security Device Manager (SDM) Quick Start Guide that shipped with your router.

For configuration procedures using the CLI, see the online document Cisco 1800 Series Integrated Services Router (Fixed) Software Configuration Guide. The software configuration guide includes the following topics:

Basic software configuration

Feature documentation

Configuration examples

Troubleshooting and maintenance