Guest

Cisco 7300 Series Routers

Cisco 7304 Fast Etherchannel and Gigabit Etherchannel Notes

  • Viewing Options

  • PDF (58.9 KB)
  • Feedback
Cisco 7304 Fast EtherChannel and Gigabit EtherChannel Notes

Table Of Contents

Cisco 7304 Fast EtherChannel and Gigabit EtherChannel Notes

Overview

EtherChannel Configuration

EtherChannel Example Configurations

EtherChannel Restrictions for Cisco 7304 Routers

Features Supported within Fast EtherChannel and Gigabit EtherChannel Bundles


Cisco 7304 Fast EtherChannel and Gigabit EtherChannel Notes

The purpose of this document is to explain some Cisco 7304 router-specific information regarding Fast EtherChannel and Gigabit EtherChannel support.

This document contains the following sections:

Overview

EtherChannel Configuration

EtherChannel Example Configurations

EtherChannel Restrictions for Cisco 7304 Routers

Features Supported within Fast EtherChannel and Gigabit EtherChannel Bundles

Overview

In Cisco IOS Release 12.2(31)SB2, Fast EtherChannel and Gigabit EtherChannel support was introduced for the Cisco 7304 router. This support was introduced for Cisco 7304 routers using the NSE-100, the NSE-150, or the NPE-G100.

Additionally, PXF-acceleration of EtherChannels was introduced in Cisco IOS Release 12.2(31)SB2 as part of this feature. Because this portion of the feature is PXF-related, it only applies to the NSE-100 and the NSE-150.

EtherChannel Configuration

EtherChannel configuration on the Cisco 7304 router is consistent with EtherChannel configuration on other platforms. As with other platforms, the interface port-channel command is used to create and configure an EtherChannel, and the channel-group command, in interface configuration mode while configuring a Fast Ethernet or Gigabit Ethernet interface, is used to assign an interface to an EtherChannel.

For more detailed information on configuring EtherChannels, see the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/finter_c/icflanin.htm#1056303

EtherChannel Example Configurations

In the following example, three Gigabit Ethernet interfaces are added to the Gigabit EtherChannel group created as port-channel 1.

Router(config)# interface port-channel 1 
Router(config-if)# ip address 1.1.1.10 255.255.255.0 
Router(config)# interface g1/0/0 
Router(config-if)# channel-group 1 
Router(config)# interface g4/0/0 
Router(config-if)# channel-group 1 
Router(config)# interface g5/0/0 
Router(config-if)# channel-group 1

In the following example, a Gigabit EtherChannel with four Gigabit Ethernet interfaces is created. In this example, dot1q is enabled on the Gigabit Etherchannel and an IP address is assigned to the sub interface.

Router# configure terminal 
Router(config)# interface port-channel 1 
Router(config-if)# no shutdown 
Router(config-if)# exit 
Router(config)# interface port-channel 1.1 
Router(config-if)# ip address 1.1.1.10 255.255.255.0 
Router(config-if)# encapsulation dot1q 100 
Router(config-if)# exit 
Router(config)# interface g0/0/0 
Router(config-if)# no ip address 
Router(config-if)# channel-group 1 
!Gig Ethernet 0/0 added as member-1 to port-channel1. 
Router(config-if)# exit 
Router(config)# interface g0/1/0 
Router(config-if)# no ip address 
Router(config-if)# channel-group 1 
!Gig Ethernet 0/1 added as member-2 to port-channel1. 
Router(config-if)# exit 
Router(config)# interface g1/0/0 
Router(config-if)# no ip address 
Router(config-if)# channel-group 1 
!Gig Ethernet 1/0 added as member-3 to port-channel1. 
Router(config-if)# exit 
Router(config)# interface g1/1/0 
Router(config-if)# no ip address 
Router(config-if)# channel-group 1 
!Gig Ethernet 1/1 added as member-4 to port-channel1. 
Router(config-if)# exit 
Router(config)# exit

EtherChannel Restrictions for Cisco 7304 Routers

This section contains the Cisco 7304 router-specific EtherChannel restrictions:

Fast EtherChannel bundles are supported for up to 4 Fast Ethernet links and up to 16 channels per router.

Gigabit EtherChannel bundles are supported for up to 4 Gigabit Ethernet links and up to 16 channels per router.

Any Gigabit Ethernet interface on a Cisco 7304 router, such as a native Gigabit Ethernet port, a SPA Gigabit Ethernet port, or a Port Adapter Gigabit Ethernet port, can be used as a link in a Gigabit EtherChannel bundle.

The native Fast Ethernet interface on a Cisco 7304 router cannot be used as a link in a Fast EtherChannel bundle. Any other Fast Ethernet interface on a Cisco 7304 router, such as a SPA Fast Ethernet port or a Fast Ethernet Port Adapter port, can be used as part of a Fast EtherChannel bundle.

A few notes about QoS on EtherChannels:

The set and police commands can be configured directly on the EtherChannel bundle and will be applied to all traffic traversing the bundle.

If the bandwidth or shape command is configured in a policy map that is attached to an EtherChannel bundle, the requested bandwidth or shape parameter is distributed evenly to each link in the bundle. For example, if bandwidth percent 10 is configured on a Fast EtherChannel with three links (300 Mbps aggregate bandwidth), the total bandwidth needed would be 30 Mbps and each link in the bundle would therefore reserve 10 Mbps of bandwidth to accommodate the configuration.

The queue-limit size when configured on a bundle is applied individually to each link in the bundle. For instance, if you had a bundle with three links and set the queue-limit size to 1024, all three of the links in the bundle would be configured to have a queue size of 1024.

Features Supported within Fast EtherChannel and Gigabit EtherChannel Bundles

The following table outlines support for features that are supported within a Fast EtherChannel or Gigabit EtherChannel bundle:

Table 1  Features Supported within Fast EtherChannel and Gigabit EtherChannel Bundles

Feature
Bundle Interface
Subinterface of a Bundle Interface

IP Switching

Supported

Supported

MPLS VPN

Supported

Supported

IP DSCP and Precedence Marking

Supported

Supported

MPLS Experimental Bit Marking

Supported

Supported

Class of Service Marking

Supported

Supported

Layer 2 VPN (AToM/L2TPv3)

Not Supported

Not Supported

Multicast

Supported

Supported

Multicast VPN

Supported

Supported

Class-Based Weighted Fair Queueing

Supported

Not Supported

Low Latency Queueing

Supported

Not Supported

Input and Output Access Control Lists

Supported

Supported

Input and Output Traffic Policing

Supported

Supported

QoS Group Marking

Supported

Supported

Ingress Aggregated Netflow

Supported

Supported

Interface Statistics

Supported

Supported