Cisco ONS 15454 and Cisco ONS 15454 SDH Ethernet Card Software Feature and Configuration Guide, Release 8.0
Chapter 5, Configuring POS
Downloads: This chapterpdf (PDF - 305.0KB) The complete bookPDF (PDF - 7.97MB) | Feedback

Configuring POS

Table Of Contents

Configuring POS

POS on the ML-Series Card

ML-Series SONET and SDH Circuit Sizes

VCAT

SW-LCAS

Framing Mode, Encapsulation, and CRC Support

Configuring POS Interface Framing Mode

Configuring POS Interface Encapsulation Type

Configuring POS Interface CRC Size in HDLC Framing

Setting the MTU Size

Configuring Keep Alive Messages

SONET/SDH Alarms

Configuring SONET/SDH Alarms

Configuring SONET/SDH Delay Triggers

C2 Byte and Scrambling

Third-Party POS Interfaces C2 Byte and Scrambling Values

Configuring SPE Scrambling

Monitoring and Verifying POS

POS Configuration Examples

ML-Series Card to ML-Series Card

ML-Series Card to Cisco 12000 GSR-Series Router

ML-Series Card to G-Series Card

ML-Series Card to ONS 15310 ML-100T-8 Card

Configuring SONET/SDH Alarms


Configuring POS


This chapter describes advanced packet-over-SONET/SDH (POS) interface configuration for the ML-Series card. Basic POS interface configuration is included in Chapter 4 "Configuring Interfaces." For more information about the Cisco IOS commands used in this chapter, refer to the Cisco IOS Command Reference publication. POS operation on ONS Ethernet cards, including the ML-Series card, is described in Chapter 20 "POS on ONS Ethernet Cards."

This chapter contains the following major sections:

POS on the ML-Series Card

Monitoring and Verifying POS

POS Configuration Examples

POS on the ML-Series Card

Ethernet and IP data packets need to be framed and encapsulated into SONET/SDH frames for transport across the SONET/SDH network. This framing and encapsulation process is known as POS and is done in the ML-Series card. Chapter 20 "POS on ONS Ethernet Cards," explains POS in greater detail.

The ML-Series card takes the standard Ethernet ports on the front of the card and the virtual POS ports and includes them all as switch ports. Under Cisco IOS, the POS port is an interface similar to the other Ethernet interfaces on the ML-Series card. It is usually used as a trunk port. Many standard Cisco IOS features, such as IEEE 802.1 Q VLAN configuration, are configured on the POS interface in the same manner as on a standard Ethernet interface. Other features and configurations are done strictly on the POS interface. The configuration of features limited to POS ports is shown in this chapter.

ML-Series SONET and SDH Circuit Sizes

SONET is an American National Standards Institute (ANSI) standard (T1.1051988) for optical digital transmission at hierarchical rates from 51.840 Mbps (STS-1) to 2.488 Gbps (STS-48) and greater. SDH is the international standard for optical digital transmission at hierarchical rates from 155.520 Mbps (STM-1) to 2.488 Gbps (STM-16) and greater.

Both SONET and SDH are based on a structure that has a basic frame and speed. The frame format used by SONET is the synchronous transport signal (STS), with STS-1 being the base level signal at 51.84 Mbps. A STS-1 frame can be carried in an OC-1 signal. The frame format used by SDH is the synchronous transport module (STM), with STM-1 being the base level signal at 155.52 Mbps. A STM-1 frame can be carried in an OC-3 signal.

Both SONET and SDH have a hierarchy of signaling speeds. Multiple lower level signals can be multiplexed together to form higher level signals. For example, three STS-1 signals can be multiplexed together to form a STS-3 signal, and four STM-1 signals can be multiplexed together to form a STM-4 signal.

SONET circuit sizes are defined as STS-n, where n is a multiple of 51.84 Mbps and n is equal to or greater than 1. SDH circuit sizes are defined as STM-n, where n is a multiple of 155.52 Mbps and n is equal to or greater than 0. Table 5-1 shows STS and STM line rate equivalents.

Table 5-1 SONET STS Circuit Capacity in Line Rate Mbps

SONET Circuit Size

SDH Circuit Size

Line Rate in Mbps

STS-1 (OC-1)

VC-31

52 Mbps

STS-3c (OC-3)

STM-1 (VC4)

156 Mbps

STS-6c (OC-6)

STM-2 (VC4-2c)

311 Mbps

STS-9c (OC-9)

STM-3 (VC4-3c)

466 Mbps

STS-12c (OC-12)

STM-4 (VC4-4c)

622 Mbps

STS-24c (OC-24)

STM-8 (VC4-8c)

1244 Mbps (1.24 Gbps)

1 VC-3 circuit support requires an XC-VXx or XC-VCX-10G card to be installed.


For step-by-step instructions on configuring an ML-Series card SONET STS circuit, refer to the "Create Circuits and VT Tunnels" chapter of the Cisco ONS 15454 Procedure Guide. For step-by-step instructions on configuring an ML-Series card SDH STM circuit, refer to the "Create Circuits and Tunnels" chapter of the Cisco ONS 15454 SDH Procedure Guide.

VCAT

VCAT significantly improves the efficiency of data transport over SONET/SDH by grouping the synchronous payload envelopes (SPEs) of SONET/SDH frames in a nonconsecutive manner into VCAT groups. VCAT group circuit bandwidth is divided into smaller circuits called VCAT members. The individual members act as independent circuits.

Intermediate nodes treat the VCAT members as normal circuits that are independently routed and protected by the SONET/SDH network. At the terminating nodes, these member circuits are multiplexed into a contiguous stream of data. VCAT avoids the SONET/SDH bandwidth fragmentation problem and allows finer granularity for provisioning of bandwidth services.

The ONS 15454 SONET and ONS 15454 SDH ML-Series card VCAT circuits must also be routed over common fiber and be both bidirectional and symmetric. Only high order (HO) VCAT circuits are supported. The ML-Series card supports a maximum of two VCAT groups, with each group corresponding to one of the POS ports. Each VCAT group can contain two circuit members. A VCAT circuit originating from an ML-Series card must terminate on another ML-Series card or a CE-Series card. Table 5-2 shows supported VCAT circuit sizes for the ML-Series.

Table 5-2 VCAT Circuit Sizes Supported by ML100T-12, ML100X-8, and ML1000-2 Cards 

SONET VCAT Circuit Size
SDH VCAT Circuit Size

STS-1-2v

VC-3-2v

STS-3c-2v

VC-4-2v

STS-12c-2v

VC-4-4c-2v


For step-by-step instructions on configuring an ML-Series card SONET VCAT circuit, refer to the "Create Circuits and VT Tunnels" chapter of the Cisco ONS 15454 Procedure Guide. For step-by-step instructions on configuring an ML-Series card SDH VCAT circuit, refer to the "Create Circuits and Tunnels" chapter of the Cisco ONS 15454 SDH Procedure Guide. For more general information on VCAT circuits, refer to the "Circuits and Tunnels" chapter of the Cisco ONS 15454 Reference Manual or the Cisco ONS 15454 SDH Reference Manual.


Note ML-Series card POS interfaces normally send an alarm for signal label mismatch failure in the ONS 15454 STS path overhead (PDI-P) to the far end when the POS link goes down or when RPR wraps. ML-Series card POS interfaces do not send PDI-P to the far-end when PDI-P is detected, when a remote defection indication alarm (RDI-P) is being sent to the far end, or when the only defects detected are generic framing procedure (GFP)-loss of frame delineation (LFD), GFP client signal fail (CSF), virtual concatenation (VCAT)-loss of multiframe (LOM), or VCAT-loss of sequence (SQM).



Note For nodes not connected by DCC (open ended nodes), VCAT must be configured through TL-1.


SW-LCAS

A link capacity adjustment scheme (LCAS) increases VCAT flexibility by allowing the dynamic reconfiguration of VCAT groups without interrupting the operation of noninvolved members. Software link capacity adjustment scheme (SW-LCAS) is the software implementation of a LCAS-type feature. SW-LCAS differs from LCAS because it is not errorless and uses a different handshaking mechanism.

SW-LCAS on the ONS 15454 SONET/SDH ML-Series cards allows the automatic addition or removal of a VCAT group member in the event of a failure or recovery on a two-fiber bidirectional line switched ring (BLSR). The protection mechanism software operates based on ML-Series card link events. SW-LCAS allows service providers to configure VCAT member circuits on the ML-Series as protection channel access (PCA) circuits. This PCA traffic is dropped in the event of a protection switch, but is suitable for excess or noncommited traffic and can double the total available bandwidth on the circuit.

For step-by-step instructions on configuring SW-LCAS, refer to the "Create Circuits and VT Tunnels" chapter of the Cisco ONS 15454 Procedure Guide or the "Create Circuits and Tunnels" chapter of the Cisco ONS 15454 SDH Procedure Guide. For more general information on SW-LCAS, refer to the "Circuits and Tunnels" chapter of the Cisco ONS 15454 Reference Manual or the Cisco ONS 15454 SDH Reference Manual.

Framing Mode, Encapsulation, and CRC Support

The ML-Series cards on the ONS 15454 and ONS 15454 SDH support two modes of the POS framing mechanism, GFP-F framing and HDLC framing (default). The framing mode, encapsulation, and CRC size on source and destination POS ports must match for a POS circuit to function properly. Chapter 20 "POS on ONS Ethernet Cards," explains the framing mechanisms, encapsulations, and cyclic redundancy check (CRC) bit sizes in detail.

Supported encapsulation and CRC sizes for the framing types are detailed in Table 5-3.

Table 5-3 Supported Encapsulation, Framing, and CRC Sizes for ML-Series Cards on the ONS 15454 and ONS 15454 SDH

 
Encapsulations for HDLC Framing
CRC Sizes for HDLC Framing
Encapsulations for GFP-F Framing
CRC Sizes for GFP-F Framing
ML-Series

LEX (default)

Cisco HDLC

PPP/BCP

16-bit

32-bit (default)

LEX (default)

Cisco HDLC

PPP/BCP

32-bit (default)



Note ML-Series card POS interfaces normally send PDI-P to the far-end when the POS link goes down or RPR wraps. ML-Series card POS interfaces do not send PDI-P to the far-end when PDI-P is detected, when RDI-P is being sent to the far-end or when the only defects detected are GFP LFD, GFP CSF, VCAT LOM or VCAT SQM.


Configuring POS Interface Framing Mode

You configure framing mode on an ML-Series card only through CTC. For more information on configuring framing mode in CTC, see Chapter 2 "CTC Operations."

Configuring POS Interface Encapsulation Type

The default Cisco EoS LEX is the primary encapsulation of ONS Ethernet cards. This encapsulation is used under HDLC framing with the protocol field set to the values specified in Internet Engineering Task Force (IETF) Request For Comments (RFC) 1841. Under GFP-F framing, the Cisco IOS CLI also uses the keyword lex. With GFP-F framing, the lex keyword is used to represent standard mapped Ethernet over GFP-F according to ITU-T G.7041.

To configure the encapsulation type for a ML-Series card, perform the following steps beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos number

Activates interface configuration mode to configure the POS interface.

Step 2 

Router(config-if)# shutdown

Manually shuts down the interface. Encapsulation changes on POS ports are allowed only when the interface is shut down (ADMIN_DOWN).

Step 3 

Router(config-if)# encapsulation type

Sets the encapsulation type. Valid values are:

hdlc—Cisco HDLC

lex—(default) LAN extension, special encapsulation for use with Cisco ONS Ethernet line cards. When the lex keyword is used with GFP-F framing it is standard Mapped Ethernet over GFP-F according to ITU-T G.7041.

ppp—Point-to-Point Protocol

Step 4 

Router(config-if)# no shutdown

Restarts the shutdown interface.

Step 5 

Router(config)# end

Returns to privileged EXEC mode.

Step 6 

Router# copy running-config startup-config

(Optional) Saves configuration changes to NVRAM.

Configuring POS Interface CRC Size in HDLC Framing

To configure additional properties to match those of the interface at the far end, perform the following steps, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos number

Activates interface configuration mode to configure the POS interface.

Step 2 

Router(config-if)# crc {16 | 32}

Sets the CRC value for HDLC framing. If the device to which the POS module is connected does not support the default CRC value of 32, set both devices to use a value of 16.

Note The CRC value is fixed at a value of 32 under GFP-F framing.

Step 3 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 4 

Router# copy running-config startup-config

(Optional) Saves configuration changes to NVRAM.

Setting the MTU Size

To set the maximum transmission unit (MTU) size, perform the following steps, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos number

Activates interface configuration mode to configure the POS interface.

Step 2 

Router(config-if)# mtu bytes

Configures the MTU size up to a maximum of 9000 bytes. See Table 5-4 for default MTU sizes.

Step 3 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 4 

Router# copy running-config startup-config

(Optional) Saves configuration changes to NVRAM.

Table 5-4 shows the default MTU sizes.

Table 5-4 Default MTU Size 

Encapsulation Type
Default Size

LEX (default)

1500

HDLC

4470

PPP

4470


Configuring Keep Alive Messages

To configure keep alive messages for the ML-Series card, perform the following steps beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos 
number

Enters interface configuration mode and specifies the POS interface to configure.

Step 2 

Router(config-if)# [no] keepalive

Configures keep alive messages.

Keep alive messages are on by default and are recommended, but not required.

The no form of this command turns off keep alive messages.

Step 3 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 4 

Router# copy running-config 
startup-config

(Optional) Saves configuration changes to NVRAM.

SONET/SDH Alarms

The ML-Series cards report SONET/SDH alarms under both Cisco IOS and CTC/TL1. A number of path alarms are reported in the Cisco IOS console. Configuring Cisco IOS console alarm reporting has no effect on CTC alarm reporting. The "Configuring SONET/SDH Alarms" section specifies the alarms reported to the Cisco IOS console.

CTC/TL1 has sophisticated SONET/SDH alarm reporting capabilities. As a card in the ONS node, the ML-Series card reports alarms to CTC/TL-1 like any other ONS card. On the ONS 15454 SONET, the ML-Series card reports Telcordia GR-253 SONET alarms in the Alarms panel of CTC. For more information on alarms and alarm definitions, refer to the "Alarm Troubleshooting" chapter of the Cisco ONS 15454 Troubleshooting Guide or the Cisco ONS 15454 SDH Troubleshooting Guide.

Configuring SONET/SDH Alarms

All SONET/SDH alarms appear by default But to provision the reporting of SONET/SDH alarms on the Cisco IOS CLI, perform the following steps beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos 
number

Enters interface configuration mode and specifies the POS interface to configure.

Step 2 

Router(config-if)# pos report 
{all | encap | pais | plop | ppdi 
| pplm | prdi | ptim | puneq | 
sd-ber-b3 | sf-ber-b3}

Permits console logging of selected SONET/SDH alarms. Use the no form of the command to disable reporting of a specific alarm.

The alarms are as follows:

allAll alarms/signals

encap—Path encapsulation mismatch

pais—Path alarm indication signal

plop—Path loss of pointer

ppdi—Path payload defect indication

pplm—Payload label, C2 mismatch

prdi—Path remote defect indication

ptim—Path trace identifier mismatch

puneq—Path label equivalent to zero

sd-ber-b3—PBIP BER in excess of SD threshold

sf-ber-b3—PBIP BER in excess of SF threshold

Step 3 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 4 

Router# copy running-config 
startup-config

(Optional) Saves configuration changes to NVRAM.

To determine which alarms are reported on the POS interface and to display the bit error rate (BER) thresholds, use the show controllers pos command, as described in the "Monitoring and Verifying POS" section.


Note Cisco IOS alarm reporting commands apply only to the Cisco IOS CLI. SONET/SDH alarms reported to the TCC2/TCC2P are not affected.


Configuring SONET/SDH Delay Triggers

You can set path alarms listed as triggers to bring down the line protocol of the POS interface. When you configure the path alarms as triggers, you can also specify a delay for the triggers using the pos trigger delay command. You can set the delay from 200 to 2000 ms. If you do not specify a time interval, the default delay is set to 200 ms.

To configure path alarms as triggers and specify a delay, perform the following steps beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos 
number

Enters interface configuration mode and specifies the POS interface to configure.

Step 2 

Router(config-if)# pos trigger 
defect {all | ber_sf_b3 | encap 
| pais | plop | ppdi | pplm | 
prdi | ptim | puneq}

Configures certain path defects as triggers to bring down the POS interface. The configurable triggers are as follows:

all—All link down alarm failures

ber_sd_b3—PBIP BER in excess of SD threshold failure

ber_sf_b3—PBIP BER in excess of SD threshold failure (default)

encap—Path Signal Label Encapsulation Mismatch failure (default)

pais—Path Alarm Indication Signal failure (default)

plop—Path Loss of Pointer failure (default)

ppdi—Path Payload Defect Indication failure (default)

pplm—Payload label mismatch path (default)

prdi—Path Remote Defect Indication failure (default)

ptim—Path Trace Indicator Mismatch failure (default)

puneq—Path Label Equivalent to Zero failure (default)

Step 3 

Router(config-if)# pos trigger 
delay millisecond

Sets waiting period before the line protocol of the interface goes down. Delay can be set from 200 to 2000 ms. If no time intervals are specified, the default delay is set to 200 ms.

Step 4 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 5 

Router# copy running-config 
startup-config

(Optional) Saves configuration changes to NVRAM.

C2 Byte and Scrambling

One of the overhead bytes in the SONET/SDH frame is the C2 byte. The SONET/SDH standard defines the C2 byte as the path signal label. The purpose of this byte is to communicate the payload type being encapsulated by the SONET framing overhead (FOH). The C2 byte functions similarly to EtherType and Logical Link Control (LLC)/Subnetwork Access Protocol (SNAP) header fields on an Ethernet network; it allows a single interface to transport multiple payload types simultaneously. The C2 byte is not configurable. Table 5-5 provides C2 byte hex values.

Table 5-5 C2 Byte and Scrambling Default Values 

Signal Label
SONET/SDH Payload Contents

0x01

LEX Encapsulation with 32-bit CRC with or without scrambling

0x05

LEX Encapsulation with 16-bit CRC with or without scrambling

0xCF

Cisco HDLC or PPP/BCP without scrambling

0x16

Cisco HDLC or PPP/BCP with scrambling

0x1B

GFP-F


Third-Party POS Interfaces C2 Byte and Scrambling Values

If a Cisco POS interface fails to come up when connected to a third-party device, confirm the scrambling and cyclic redundancy check (CRC) settings as well as the advertised value in the C2 byte. On routers from Juniper Networks, configuring RFC 2615 mode sets the following three parameters:

Scrambling enabled

C2 value of 0x16

CRC-32

Previously, when scrambling was enabled, these third-party devices continued to use a C2 value of 0xCF, which did not properly reflect the scrambled payload.

Configuring SPE Scrambling

SPE scrambling is on by default. To configure POS SONET/SDH Payload (SPE) scrambling, perform the following steps, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos 
number

Enters interface configuration mode and specifies the POS interface to configure.

Step 2 

Router(config-if)# no pos 
scramble-spe 

Disables payload scrambling on the interface. Payload scrambling is on by default.

Step 3 

Router(config-if)# no shutdown

Enables the interface with the previous configuration.

Step 4 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 5 

Router# copy running-config 
startup-config

(Optional) Saves configuration changes to NVRAM.

Monitoring and Verifying POS

The show controller pos [0 | 1] command (Example 5-1) outputs the receive and transmit values and the C2 value. Thus, changing the value on the local end does not change the value in the show controller command output.

Example 5-1 show controller pos [0 | 1] Command

ML_Series# sh controllers pos 0
Interface POS0
Hardware is Packet/Ethernet over Sonet 
Framing Mode: HDLC  
Concatenation: CCAT  
Alarms reportable to CLI: PAIS PLOP PUNEQ PTIM PPLM ENCAP PRDI PPDI BER_SF_B3 BER_SD_B3 
VCAT_OOU_TPT LOM SQM 
Link state change defects: PAIS PLOP PUNEQ PTIM PPLM ENCAP PRDI PPDI BER_SF_B3 
Link state change time   : 200 (msec)
***************  Path  ***************
Circuit state: IS  
	PAIS      = 0         PLOP      = 0         PRDI    = 0         PTIM = 0
	PPLM      = 0         PUNEQ     = 0         PPDI    = 0         PTIU = 0
	BER_SF_B3 = 0         BER_SD_B3 = 0         BIP(B3) = 0          REI = 0
	NEWPTR    = 0         PSE       = 0         NSE     = 0        ENCAP = 0
Active Alarms : PAIS 
Demoted Alarms: None
Active Defects: PAIS 
DOS FPGA channel number  : 0
Starting STS (0 based)   : 0
VT ID (if any) (0 based) : 255
Circuit size           : STS-3c
RDI Mode               : 1 bit
C2 (tx / rx)           : 0x01 / 0x01
Framing                : SONET
Path Trace
	Mode            : off          
	Transmit String : 
	Expected String : 
	Received String : 
	Buffer          : Stable
	Remote hostname :                         
	Remote interface:               
	Remote IP addr  :                 
B3 BER thresholds: 
SFBER = 1e-4,   SDBER = 1e-7
0 total input packets,  0 post-HDLC bytes
0 input short packets,  0 pre-HDLC bytes
0  input long packets , 0  input runt packets
0  input CRCerror packets , 0  input drop packets
0 input abort packets
0 input packets dropped by ucode
0  total output packets, 0  output pre-HDLC bytes
0 output post-HDLC bytes
Carrier delay is 200 msec
 
   

The show interface pos {0 | 1} command (Example 5-2) shows scrambling.

Example 5-2 show interface pos [0 | 1] Command

ML_Series# show interface pos 0
POS0 is administratively down, line protocol is down 
	Hardware is Packet/Ethernet over Sonet, address is 0011.2130.b340 (bia 0011.2130.b340)
	MTU 1500 bytes, BW 145152 Kbit, DLY 100 usec, 
	reliability 255/255, txload 1/255, rxload 1/255
	Encapsulation: Cisco-EoS-LEX, crc 32, loopback not set
	Keepalive set (10 sec)
	Scramble enabled 
	ARP type: ARPA, ARP Timeout 04:00:00
	Last input 01:21:02, output never, output hang never
	Last clearing of "show interface" counters 00:12:01
	Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
	Queueing strategy: fifo
	Output queue: 0/40 (size/max)
	5 minute input rate 0 bits/sec, 0 packets/sec
	5 minute output rate 0 bits/sec, 0 packets/sec
	0 packets input, 0 bytes
		Received 0 broadcasts (0 IP multicast)
	0 runts, 0 giants, 0 throttles
		0 parity
	0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
	0 input packets with dribble condition detected
	0 packets output, 0 bytes, 0 underruns
	0 output errors, 0 applique, 0 interface resets
	0 babbles, 0 late collision, 0 deferred
	0 lost carrier, 0 no carrier
	0 output buffer failures, 0 output buffers swapped out
	0 carrier transitions

POS Configuration Examples

The following sections show ML-Series card POS configuration examples for connecting to other ONS Ethernet cards and POS-capable routers. These examples are only some of the ML-Series card configurations available to connect to other ONS Ethernet cards and POS-capable routers. For more specifics about the POS characteristics of ONS Ethernet cards, see Chapter 20 "POS on ONS Ethernet Cards."

ML-Series Card to ML-Series Card

Figure 5-1 illustrates a POS configuration between two ONS 15454 or ONS 15454 SDH ML-Series cards.

Figure 5-1 ML-Series Card to ML-Series Card POS Configuration

Example 5-3 shows the commands associated with the configuration of ML-Series card A.

Example 5-3 ML-Series Card A Configuration

hostname ML_Series_A
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
!
interface POS0
 ip address 192.168.2.1 255.255.255.0
 crc 32
pos flag c2 1
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
 
   

Example 5-4 shows the commands associated with the configuration of ML Series B.

Example 5-4 ML-Series Card B Configuration

hostname ML_Series_B
!
interface FastEthernet0
 ip address 192.168.3.1 255.255.255.0
!
interface POS0
 ip address 192.168.2.2 255.255.255.0
 crc 32
pos flag c2 1
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
!

ML-Series Card to Cisco 12000 GSR-Series Router

Figure 5-2 illustrates a POS configuration between an ML-Series card and a Cisco 12000 GSR-Series router. PPP/BCP encapsulation or Cisco HDLC encapsulation may be used for interoperation.

Figure 5-2 ML-Series Card to Cisco 12000 Series Gigabit Switch Router (GSR) POS Configuration

Example 5-5 shows the commands associated with configuration of ML-Series card A.

Example 5-5 ML-Series Card A Configuration

hostname ML_Series_A
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
!
!
interface POS0
 ip address 192.168.2.1 255.255.255.0
 encapsulation ppp
 crc 32
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
 
   

Example 5-6 shows the commands associated with the configuration of the GSR-12000.

Example 5-6 GSR-12000 Configuration

hostname GSR
!
interface FastEthernet1/0
 ip address 192.168.3.1 255.255.255.0
!
interface POS2/0
 ip address 192.168.2.2 255.255.255.0
 crc 32
encapsulation PPP
pos scramble-atm
!
router ospf 1
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
!
 
   

The default encapsulation for the ML-Series card is LEX and the corresponding default MTU is 1500 bytes. When connecting to an external POS device, it is important to ensure that both the ML-Series switch and the external device uses the same configuration for the parameters listed in Table 5-6.

Table 5-6 ML-Series Parameter Configuration for Connection to a Cisco 12000 GSR-Series Router

Command
Parameter
Router(config-if)# encapsulation ppp
 
        

or

Router(config-if)# encapsulation hdlc

Encapsulation—Default encapsulation on the Cisco 12000 GSR Series is HDLC, which is supported by the ML-Series. PPP is also supported by both the ML-Series card and the Cisco 12000 GSR Series.

The Cisco 12000 GSR Series does not support LEX, which is the default encapsulation on the ML-Series card.

Router(config-if)# show controller 
pos

C2 Byte—Use the show controller pos command to verify that the transmit and receive C2 values are the same.

Router(config-if)# pos flag c2 value

Sets the C2 byte value. Valid choices are 0 to 255 (decimal). The default value is 0x01 (hex) for LEX.


ML-Series Card to G-Series Card

Figure 5-3 illustrates a POS configuration between an ML-Series card and a G-Series card.

Figure 5-3 ML-Series Card to G-Series Card POS Configuration

Example 5-7 shows the commands associated with the configuration of ML-Series card A.

Example 5-7 ML-Series Card A Configuration

hostname ML_Series_A
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
!
interface POS0
 ip address 192.168.2.1 255.255.255.0
 crc 32
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0

ML-Series Card to ONS 15310 ML-100T-8 Card

Figure 5-4 illustrates a POS configuration between an ML-Series card and an ONS 15310 ML-100T-8 card. For step-by-step circuit configuration procedures for the connected ML-100T-8 card, refer to the Cisco ONS 15310-CL and Cisco ONS 15310-MA Ethernet Card Software Feature and Configuration Guide.

Figure 5-4 ML-Series Card to ONS 15310 CE-100T-8 Card Configuration

Example 5-8 shows the commands associated with the configuration of ML-Series card A.

Example 5-8 ML-Series Card A Configuration

hostname ML_Series_A
!
interface FastEthernet0
 ip address 192.168.1.1 255.255.255.0
!
interface POS0
 ip address 192.168.2.1 255.255.255.0
 crc 32
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
 
   

CTC/TL1 has sophisticated SONET/SDH alarm reporting capabilities. As a card in the ONS node, the ML-Series card reports alarms to CTC/TL-1 like any other ONS card. On the ONS 15454 SONET, the ML-Series card reports Telcordia GR-253 SONET alarms in the Alarms panel of CTC. For more information on alarms and alarm definitions, refer to the "Alarm Troubleshooting" chapter of the Cisco ONS 15454 Troubleshooting Guide or the Cisco ONS 15454 SDH Troubleshooting Guide.

Configuring SONET/SDH Alarms

All SONET/SDH alarms are logged on the Cisco IOS CLI by default. But to provision or disable the reporting of SONET/SDH alarms on the Cisco IOS CLI, perform the following steps beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface pos 
number

Enters interface configuration mode and specifies the POS interface to configure.

Step 2 

Router(config-if)# pos report 
{all | encap | pais | plop | ppdi 
| pplm | prdi | ptim | puneq | 
sd-ber-b3 | sf-ber-b3}

Permits logging of selected SONET/SDH alarms. Use the no form of the command to disable reporting of a specific alarm.

The alarms are as follows:

all—All alarms/signals

encap—Path encapsulation mismatch

pais—Path alarm indication signal

plop—Path loss of pointer

ppdi—Path payload defect indication

pplm—Payload label, C2 mismatch

prdi—Path remote defect indication

ptim—Path trace identifier mismatch

puneq—Path label equivalent to zero

sd-ber-b3—PBIP BER in excess of SD threshold

sf-ber-b3—PBIP BER in excess of SF threshold

Step 3 

Router(config-if)# end

Returns to the privileged EXEC mode.

Step 4 

Router# copy running-config 
startup-config

(Optional) Saves configuration changes to NVRAM.

To determine which alarms are reported on the POS interface and to display the bit error rate (BER) thresholds, use the show controllers pos command, as described in the "Monitoring and Verifying POS" section.


Note Cisco IOS alarm reporting commands apply only to the Cisco IOS CLI. SONET/SDH alarms reported to the TCC2/TCC2P are not affected.