RADIUS Attributes Configuration Guide Cisco IOS XE Release 3S
RADIUS Attribute 82: Tunnel Assignment ID
Downloads: This chapterpdf (PDF - 136.0KB) | Feedback

RADIUS Attribute 82: Tunnel Assignment ID

Table Of Contents

RADIUS Attribute 82: Tunnel Assignment ID

Finding Feature Information

Contents

Restrictions for Radius Attribute 82: Tunnel Assignment ID

Information about RADIUS Attribute 82: Tunnel Assignment ID

Benefits

How to Configure RADIUS Attribute 82: Tunnel Assignment ID

Verifying RADIUS Attribute 82

Configuration Examples

LAC Configuration Example

LNS Configuration Example

RADIUS Configuration Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for RADIUS Attribute 82: Tunnel Assignment ID


RADIUS Attribute 82: Tunnel Assignment ID


Last Updated: July 31, 2009

Finding Feature Information

For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for RADIUS Attribute 82: Tunnel Assignment ID" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS XE software image support. To access Cisco Feature Navigator, go to http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp. An account on Cisco.com is not required.

Contents

How to Configure RADIUS Attribute 82: Tunnel Assignment ID

Information about RADIUS Attribute 82: Tunnel Assignment ID

How to Configure RADIUS Attribute 82: Tunnel Assignment ID

Configuration Examples

Additional References

Feature Information for RADIUS Attribute 82: Tunnel Assignment ID

Restrictions for Radius Attribute 82: Tunnel Assignment ID

This feature is designed only for VPDN dial-in applications. It does not support VPDN dial-out.

Information about RADIUS Attribute 82: Tunnel Assignment ID

The RADIUS Attribute 82: Tunnel Assignment ID feature allows the Layer 2 Transport Protocol access concentrator (LAC) to group users from different per-user or domain RADIUS profiles into the same active tunnel. The RADIUS Attribute 82: Tunnel Assignment ID feature defines a new avpair, Tunnel-Assignment-ID, which allows the LAC to group users from different RADIUS profiles into the same tunnel if the chosen endpoint, tunnel type, and Tunnel-Assignment-ID are identical. This feature introduces new software functionality. No new commands are introduced with this feature.

Benefits

The RADIUS Attribute 82: Tunnel Assignment ID feature improves LAC and L2TP network server (LNS) performance by reducing memory usage, because fewer tunnel data structures must be maintained. This feature allows the LAC and LNS to handle a higher volume of users without negatively impacting router performance.

How to Configure RADIUS Attribute 82: Tunnel Assignment ID

There are not any specific configuration tasks associated with support of this feature.

Verifying RADIUS Attribute 82

To verify that RADIUS attribute 82 is being used by the LAC during tunnel authorization, use the following privileged EXEC command:

Command
Purpose

Router# debug radius

Displays information associated with RADIUS. The output of this command shows whether attribute 82 is being sent in access requests.


Configuration Examples

This section provides the following configuration examples:

LAC Configuration Example

LNS Configuration Example

RADIUS Configuration Example

LAC Configuration Example

The following example shows a sample LAC configuration when the VPDN group is defined on the router:

aaa new-model 
aaa authentication ppp default local 
aaa authorization network default local 
! 

bba-group pppoe bba_group1 
virtual-template 1 
! 
interface Loopback1 
no ip address 

vpdn-group VPDN_LAC1 
request-dialin 
protocol l2tp 
local name tb162_LAC1 
domain isp1.com 
initiate-to ip 10.0.0.2 
source-ip 10.0.0.1 
l2tp tunnel receive-window 100 
l2tp tunnel nosession-timeout 30 
l2tp tunnel retransmit retries 5 
l2tp tunnel retransmit timeout min 2 
l2tp tunnel retransmit timeout max 8 
l2tp tunnel hello 60 
l2tp tunnel password tunnel1 
! 
! 
interface virtual-template 1 
no snmp trap link-status 
no keepalive 
ip unnumbered loopback1 
ppp mtu adaptive 
ppp authentication pap 
no logging event link-status 
! 

The following example shows a sample LAC configuration when the VPDN group is defined in RADIUS:

aaa authentication ppp default group radius 
aaa authorization network default radius 
!
bba-group pppoe bba_group1 
virtual-template 1 
! 
interface Loopback1 
no ip address 
interface virtual-template 1 
no snmp trap link-status 
no keepalive 
ip unnumbered loopback1 
ppp mtu adaptive 
ppp authentication pap 
no logging event link-status 

LNS Configuration Example

The following example configures VPDN on the LNS:

hostname lns
aaa new-model
aaa authentication ppp default group radius
aaa authorization network default group radius

vpdn enable

vpdn-group VPDN_LNS1
 accept-dialin
  protocol l2tp
  virtual-template 1
 terminate-from hostname tb162_LAC1
 local name LNS1
 l2tp tunnel hello 90
 l2tp tunnel password 0 hello1

interface Loopback0
 ip address 10.1.1.3 255.255.255.0

interface Virtual-Template1
 ip unnumbered Loopback0
 no keepalive
 peer default ip address pool mypool
 ppp authentication chap

ip local pool mypool 10.1.1.10 10.1.1.50

radius-server host lns-radiusd  auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco

RADIUS Configuration Example

The following examples configure the RADIUS server to group sessions in a tunnel:

Per-User Configuration

user@router.com Password = "cisco" Service-Type = Outbound,
       Tunnel-Type = :1:L2TP,
       Tunnel-Server-Endpoint = :1:"10.14.10.54",
       Tunnel-Assignment-Id = :1:"router"

client@router.com Password = "cisco" Service-Type = Outbound,
       Tunnel-Type = :1:L2TP,
       Tunnel-Server-Endpoint = :1:"10.14.10.54",
       Tunnel-Assignment-Id = :1:"router"

Domain Configuration

eng.router.com Password = "cisco" Service-Type = Outbound,
        Tunnel-Type = :1:L2TP,
        Tunnel-Server-Endpoint = :1:"10.14.10.54",
        Tunnel-Assignment-Id = :1:"router"

sales.router.com Password = "cisco" Service-Type = Outbound,
        Tunnel-Type = :1:L2TP,
        Tunnel-Server-Endpoint = :1:"10.14.10.54",
        Tunnel-Assignment-Id = :1:"router"

Additional References

The following sections provide references related to the Configuring RADIUS Attribute 82: Tunnel Assignment ID.

Related Documents

Related Topic
Document Title

Virtual template interfaces and dial features

Cisco IOS XE Dial Technologies Configuration Guide, Release 2

Virtual private dialup networks (VPDNs)

Cisco IOS XE VPDN Configuration Guide, Release 2

RADIUS

"Configuring RADIUS" in the Cisco IOS XE Security Configuration Guide: Configuring User Services, Release 2.

Security commands

Cisco IOS Security Command Reference


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS XE software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature Information for RADIUS Attribute 82: Tunnel Assignment ID

Table 78 lists the release history for this feature.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS XE software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp. An account on Cisco.com is not required.


Note Table 78 lists only the Cisco IOS XE software release that introduced support for a given feature in a given Cisco IOS XE software release train. Unless noted otherwise, subsequent releases of that Cisco IOS XE software release train also support that feature.


Table 78 Feature Information for RADIUS Attribute 82: Tunnel Assignment ID 

Feature Name
Releases
Feature Information

RADIUS Attribute 82: Tunnel Assignment Id

Cisco IOS XE Release 2.1

The RADIUS Attribute 82: Tunnel Assignment ID feature allows the Layer 2 Transport Protocol access concentrator (LAC) to group users from different per-user or domain RADIUS profiles into the same active tunnel.

In Cisco IOS XE Release 2.1, support was added for the Cisco ASR 1000 Series Aggregation Services Routers.



Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2007-2009 Cisco Systems, Inc. All rights reserved.