Bridging and IBM Networking Configuration Guide, Cisco IOS Release 15S
Configuring Token Ring Route Switch Module
Downloads: This chapterpdf (PDF - 343.0KB) The complete bookPDF (PDF - 6.1MB) | Feedback

Configuring Token Ring Route Switch Module

Table Of Contents

Configuring Token Ring Route Switch Module

Technology Overview

Usability of Switching

VLAN

Token Ring VLANs

Token Ring VLAN Support on the RSM

Related Documents

Prerequisites

TRRSM Configuration Task List

Configuring IP Routing

Configuring IPX Routing

Configuring Source-Route Bridging

Configuring Source-Route Transparent Bridging

Configuring Source-Route Translational Bridging

Configuring Automatic Spanning Tree

Verifying TRRSM

Monitoring Statistics

TRRSM Configuration Examples

IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

IP Routing Source-Routed Frames Between TrBRF VLANs Example

IP Routing Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN Example

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

IP Routing Non-Source-Routed Frames Between TrBRF VLANs Example

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN Example

SRB Between a TrBRF VLAN and VIP2 Token Ring Interface Example

SRB Between TrBRF VLANs Example

Transparent Bridging Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

SR/TLB Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

SR/TLB Between a TrBRF VLAN and Ethernet VLAN Example

DLSw+ Example


Configuring Token Ring Route Switch Module


This chapter describes how to configure Token Ring virtual LANs (VLANs) on the route switch module (RSM). For a complete description of the commands mentioned in this chapter, refer to the Cisco IOS Bridging and IBM Networking Command Reference (Volume 1 of 2). To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

The Token Ring RSM feature is supported on the RSM in the Catalyst 5000 platform. Support for the Token Ring RSM feature was first introduced in the Cisco IOS Release 11.3(5)T. The Token Ring RSM feature is supported on all RSM Cisco IOS Release 12.0 T images. A list of the supported Cisco IOS releases and software images are located in the Release Notes for Catalyst 5000 Family RSM/VIP2 Cisco IOS 12.0 T Software Releases publication. A complete description of the RSM can be found in the Catalyst 5000 Family Route Switch Module Installation and Configuration Note and the Route Switch Module Catalyst VIP2-15 and VIP2-40 Installation and Configuration Note.

The Token Ring VLAN support on the RSM adds the capability to do multiprotocol routing and bridging for Token Ring VLANs on the RSM. The RSM is a router module running Cisco IOS software that plugs into a switch that supports Token Ring. This section provides a brief overview of Token Ring switching.

Technology Overview

Related Documents

Prerequisites

TRRSM Configuration Task List

Verifying TRRSM

Monitoring Statistics

TRRSM Configuration Examples

To identify the hardware platform or software image information associated with a feature, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Platform Support for Cisco IOS Software Features" section on page li in the "Using Cisco IOS Software" chapter.

Technology Overview

The term switching was originally used to describe packet-switch technologies such as Link Access Procedure, Balanced (LAPB), Frame Relay, Switched Multimegabit Data Service (SMDS), and X.25. Today, LAN switching refers to a technology that is similar to a bridge in many ways.

Like bridges, switches connect LAN segments and use information contained in the frame to determine the segment to which a datagram needs to be sent. Switches, however, operate at much higher speeds than bridges, and can support new functionality, such as VLANs. See the "VLAN" section and the "Token Ring VLANs" section.

Token Ring switches first appeared in 1994. The first-generation Token Ring switches can be divided into two basic categories:

Processor-based switches—These switches use reduced instruction set computer (RISC) processors to switch Token Ring frames. Although they typically have a lot of function, they are slow and relatively expensive. These switches have been deployed mainly as backbone switches because of their high cost.

Application-specific integrated circuit (ASIC)-based switches with limited functionality—These switches are fast and relatively inexpensive, but have very limited function. Typically, they offer little to no filtering, limited management information, limited support for bridging modes, and limited VLANs. Today, although these switches are less expensive than processor-based switches, they are still too expensive and limited for widespread use of dedicated Token Ring to the desktop.

In 1997, a second generation of Token Ring switches was introduced. Cisco's second-generation Token Ring switches use ASIC-based switching, but they provide increased functionality resulting in a higher speed and lower cost. They also provide a wider variety of function than their predecessors, including support for multiple bridging modes, Dedicated Token Ring (DTR) on all ports, high-port density, high-speed links, filtering, Remote Monitoring (RMON) management, broadcast control, and flexible VLANs.

The family of second-generation Token Ring switches can be used for backbone switching, workgroup microsegmentation, and dedicated Token Ring to the desktop. Switches currently being offered that support Token Ring include:

The Catalyst 3900, which is a stackable workgroup Token Ring switch that provides support for all switching modes, filtering, RMON, DTR, and SNMP management, and support for Asynchronous Transmission Mode (ATM) and Inter-Switch Link (ISL).

The Catalyst 3920, which is a also a stackable workgroup Token Ring switch that provides support for all switching modes, filtering, RMON, DTR, and SNMP management.

The Catalyst 5000, which is a modular switch that supports Ethernet, Fast Ethernet, Fiber Distributed Data Interface (FDDI), ATM, and now Token Ring.

The Catalyst Token Ring switches support the following bridging modes: source-route bridging (SRB), source-route transparent bridging (SRT), and source-route switching.

Usability of Switching

The traditional method of connecting multiple Token Ring segments is to use a SRB. For example, bridges are often used to link workgroup rings to the backbone ring. However, the introduction of the bridge can significantly reduce performance at the user's workstation. Further problems might be introduced by aggregate traffic loading on the backbone ring.

To maintain performance and avoid overloading the backbone ring, you can locate servers on the same ring as the workgroup that needs to access the server. However, dispersing the servers throughout the network makes them more difficult to back up, administer, and secure than if they are located on the backbone ring. Dispersing the servers also limits the number of servers that particular stations can access.

Collapsed backbone routers might offer greater throughput than bridges, and can interconnect a larger number of rings without becoming overloaded. Routers provide both bridging and routing functions between rings and have sophisticated broadcast control mechanisms. These mechanisms become increasingly important as the number of devices on the network increases.

The main drawback of using routers as the campus backbone is the relatively high price per port and the fact that the throughput typically does not increase as ports are added. A Token Ring switch is designed to provide wire speed throughput regardless of the number of ports in the switch. In addition, the Catalyst 3900 Token Ring switch can be configured to provide very low latency between Token Ring ports by using cut-through switching.

As a local collapsed backbone device, a Token Ring switch offers a lower per-port cost and can incur lower interstation latency than a router. In addition, the switch can be used to directly attach large numbers of clients or servers, thereby replacing concentrators. Typically, a Token Ring switch is used in conjunction with a router, providing a high-capacity interconnection between Token Ring segments while retaining the broadcast control and wide-area connectivity provided by the router.

VLAN

A VLAN is a logical group of LAN segments, independent of physical location, with a common set of requirements. For example, several end stations might be grouped as a department, such as engineering or accounting. If the end stations are located close to one another, they can be grouped into a LAN segment. If any of the end stations are on a different LAN segment, such as different buildings or locations, they can be grouped into a VLAN that has the same attributes as a LAN even though the end stations are not all on the same physical segment. The information identifying a packet as part of a specific VLAN is preserved across a Catalyst switch connection to a router or another switch if they are connected via trunk ports, such as ISL or ATM.

Token Ring VLANs

Because a VLAN is essentially a broadcast domain, a Token Ring VLAN is slightly more complex than an Ethernet VLAN. In transparent bridging, there is only one type of broadcast frame and, therefore, only one level of broadcast domain and one level of VLAN. In source routing, however, there are two types of broadcast frames:

Those that are confined to a single ring

Those that traverse the bridged domain

Therefore, there are two levels of VLANs in a Token Ring switched network. These two categories of broadcast frames result in a broadcast domain that is hierarchical in nature, just as a local ring domain can exist only within a domain of all the inter-connected rings.

The first level is the Token Ring Concentrator Relay Function (TrCRF). In a Token Ring VLAN, logical ring domains are formed by defining groups of ports that have the same ring number. The IEEE calls such a port group a Concentrator Relay Function (CRF). On Catalyst switches, such a grouping of Token Ring ports is called a Token Ring CRF (TrCRF). At this level, the VLAN is a logical ring and, as such, is assigned a ring number. On a Token Ring switch, the logical ring (TrCRF) contains one or more physical ports. Source-route switching is used to forward frames within a TrCRF based on Media Access Control (MAC) address or Route Descriptor. On an RSM, a logical ring (TrCRF) can be defined that does not contain any physical ports, but rather is used only in processing source-routed traffic to terminate the RIF.

The second level of VLAN is the Token Ring Bridge Relay Function (TrBRF). This is the parent VLAN to which TrCRF VLANs are assigned. The domain of interconnected rings is formed using an internal multiport bridge function that the IEEE calls a Bridge Relay Function (BRF). On Catalyst switches, such a grouping of logical rings is called a Token Ring BRF (TrBRF). At this level, the VLAN is a logical bridge and, as such, is assigned a bridge number. The TrBRF is responsible for forwarding frames between groups of ports with the same ring number (TrCRFs) via either SRB or SRT.

Figure 1 depicts the relationship between TrCRF and TrBRF VLANS.

Figure 1 Token Ring VLAN Support on the RSM

Token Ring VLAN Support on the RSM

The Token Ring VLAN support on the RSM adds the capability to do multi-protocol routing and bridging for Token Ring VLANs on the RSM. The RSM can be used alone to do inter-VLAN routing, or it can be paired with a Catalyst second-generation Versatile Interface Processor (VIP2) to provide external network connections with the same port adapters used on Cisco 7500 series routers. The RSM/VIP2 combination provides routing between VLANs and Catalyst VIP2 port adapters.

The Token Ring VLAN support on the RSM adds the following functionality to the Catalyst 5000 switch:

IP routing for source-routed and non-source-routed frames between Token Ring (TrBRF) and/or Ethernet VLANs and VIP2 interfaces

IPX routing for source-routed and non-source-routed frames between Token Ring (TrBRF) and/or Ethernet VLANs and VIP2 interfaces

Source-route bridging SRB between Token Ring (TrBRF) VLANs and VIP2 interfaces

Source-route translational bridging (SR/TLB) between Token Ring (TrBRF) VLANs and Ethernet VLANs and VIP2 interfaces

Source-route transparent bridging (SRT) between Token Ring (TrBRF) VLANs and SRT-capable VLANs and VIP2 interfaces

Both APPN and DLSw+ are supported for Token Ring VLANs on the RSM. However, RSRB is not supported on the RSM.

For information on how Token Ring VLANs are implemented on switches, refer to the Catalyst Token Ring Switching Implementation Guide, the Catalyst 5000 Series Token Ring Configuration Notes, the Catalyst 3900 Token Ring Switching User Guide, and the Catalyst 3920 Token Ring Switching User Guide.

The RSM is a router module running Cisco IOS router software that directly interfaces (plugs into) the Catalyst switch backplane. From the Token Ring VLAN perspective, the interface to the RSM is at the Token Ring bridged network (TrBRF) level. With the RSM, it is possible to route or bridge between separate Token Ring and Ethernet domains.

When routing or bridging between TrBRF VLANs that are defined as SRB domains, it is necessary to create a logical ring on the RSM for proper RIF processing. This logical ring is defined as a TrCRF VLAN that does not contain any external Token Ring switch ports. Figure 2 illustrates the logical view of IP routing between two source-route bridged VLANs on the RSM. In this view, the RSM appears to have an interface to both ring 100 and ring 110.

Figure 2 Logical View of VLAN Support on the RSM

Related Documents

For related information on this feature, see the following documents:

Cisco IOS Bridging and IBM Networking Configuration Guide

Cisco IOS Bridging and IBM Networking Command Reference (Volume 1 of 2)

Catalyst 5000 Series RSM Installation and Configuration Note

Catalyst Token Ring Switching Implementation Guide

Catalyst 5000 Series Token Ring Configuration Notes

Catalyst 3900 Token Ring Switching User Guide

Catalyst 3920 Token Ring Switching User Guide.

Catalyst 5000 Family Route Switch Module Installation and Configuration Note

Route Switch Module Catalyst VIP2-15

Release Notes for Catalyst 5000 Family RSM/VIP2 Cisco IOS 12.0 T Software Releases

VIP2-40 Installation and Configuration Note

Prerequisites

Before you configure bridging or routing for Token Ring VLAN interfaces on the RSM, configure the VLANs on the Catalyst 5000 supervisor engine module.

To configure a VLAN on the supervisor engine module, use the following command in privileged EXEC mode:

Command
Purpose

Router# set vlan vlan_num [name name] [type {ethernet | fddi | fddinet | trcrf | trbrf}] [state {active | suspend}] [said said] [mtu mtu] [ring hex_ring_number] [decring decimal_ring_number] [bridge bridge_num] [parent vlan_num] [mode {srt | srb}] [stp {ieee | ibm | auto}] [translation vlan_num] [backupcrf {off | on}] [aremaxhop hopcount] [stemaxhop hopcount]

Configures a TrCRF or TrBRF on the supervisor engine module.


TRRSM Configuration Task List

To configure and monitor Token Ring VLAN support on the RSM, perform one or more of the following tasks:

Configuring IP Routing

Configuring IPX Routing

Configuring Source-Route Bridging

Configuring Source-Route Transparent Bridging

Configuring Source-Route Translational Bridging

Configuring Automatic Spanning Tree

See the "TRRSM Configuration Examples" section for examples.


Note For information on configuring DLSw+, refer to the "Configuring Data-Link Switching Plus" chapter in this publication and the "DLSw+ Commands" chapter in the Cisco IOS Bridging and IBM Networking Command Reference (Volume 1 of 2).


Configuring IP Routing

The IP routing for Token Ring VLANs feature extends IP routing capabilities to include support for routing IP frame types in Token Ring VLAN configurations. IP can be routed between:

TrBRFs

TrBRFs and the VIP2

TrBRFs and Ethernet VLANs

To configure IP routing on an RSM, use the following commands beginning in global configuration mode:

 

 
Command
Purpose

Step 1 

Router(config)# ip routing

Enables IP routing on the RSM.

Step 2 

Router(config)# interface vlan vlanid type [trbrf | ethernet]

Configures a Token Ring or Ethernet interface on the RSM.

Step 3 

Router(config-if)# ip address ip-address mask

Sets a primary IP address for an interface.

You can configure an RSM to route source-routed traffic by creating a "pseudoring" to terminate the RIF path on a ring and by enabling the collection and use of RIF information.

To route source-routed traffic, use the following additional commands in interface configuration mode:

 
Command
Purpose

Step 1 

Router(config-if)# multiring trcrf-vlan vlanid ring ring-number

Creates a pseudoring to terminate the RIF and assigns it to a VLAN.

Step 2 

Router(config-if)# multiring {protocol-keyword [all-routes | spanning | all | other]}

Enables collection and use of RIF information with routed protocols.

Configuring IPX Routing

The IPX routing support for Token Ring VLANs extends Novell NetWare routing capabilities to include support for routing IPX on Token Ring VLAN interfaces and on Ethernet VLAN interfaces. IPX can be routed between:

TrBRFs

TrBRFs and the VIP2

TrBRFs and Ethernet VLANs

Users with Novell NetWare environments can configure either SAP or SNAP encapsulations to be routed across VLAN boundaries.

To configure Cisco IOS software to route IPX on an RSM with connected Token Ring VLANs, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# ipx routing [node]

Enables IPX routing globally.

Step 2 

Router(config)# interface vlan vlanid type [trbrf | ethernet]

Configures a Token Ring or Ethernet interface on the RSM.

Step 3 

Router(config-if)# ipx encapsulation encapsulation-type

Specifies the IPX encapsulation.

Step 4 

Router(config-if)# ipx network network number

Specifies the IPX network.


Note The default IPX encapsulation format for Token Ring in the Cisco IOS software is SAP. Therefore, you only need to explicitly configure the IPX encapsulation type if your Token Ring network requires SNAP encapsulation instead of SAP.


When routing source-routed traffic for specific VLANs, use the following additional commands in interface configuration mode: 

 
Command
Purpose

Step 1 

Router(config-if)# multiring trcrf-vlan vlanid ring ring-number

Creates a pseudoring to terminate the RIF and assigns it to a VLAN.

Step 2 

Router(config-if)# multiring {protocol-keyword [all-routes | spanning | all | other]}

Enables collection and use of RIF information with routed protocols.


Configuring Source-Route Bridging

To configure SRB on the RSM, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# source-bridge ring-group vring-num

Configures a virtual ring for the RSM.

Step 2 

Router(config)# interface vlan vlanid type [trbrf | ethernet]

Configures a Token Ring or Ethernet interface on the RSM.

Step 3 

Router(config-if)# source-bridge trcrf-vlan vlanid ring-group ring-number

Attaches a TrCRF VLAN identifier to the RSM's virtual ring.

Configuring Source-Route Transparent Bridging

To configure SRT on the RSM, use the following command beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface vlan vlanid type [trbrf | ethernet]

Configures a Token Ring or Ethernet interface on the RSM.

Step 2 

Router(config-if)# bridge-group bridge-group number

Specifies the bridge group to which the interface belongs.

Configuring Source-Route Translational Bridging

To configure SR/TLB on the RSM, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# source-bridge ring-group vring-num

Configures a virtual ring for the RSM.

Step 2 

Router(config)# source-bridge transparent ring-group pseudoring bridge-number tb-group [oui]

Enables bridging between transparent bridging and source-route bridging.

Step 3 

Router(config)# interface vlan vlanid type [trbrf | ethernet]

Configures a Token Ring or Ethernet interface on the RSM.

Step 4 

Router(config-if)# source-bridge trcrf-vlan vlanid ring-group ring-number

Assigns a VLAN ID to the RSM's virtual ring.


Note For a complete description of SR/TLB, including configuring translation compatibility with IBM 8209 bridges and configuring Token Ring LLC2 to Ethernet Type II (0x80d5) and Token Ring LLC2 to Ethernet 802.3 LLC2 (standard) translations, refer to the "Configuring Source-Route Bridging" chapter in this publication and the "Source-Route Bridging Commands" chapter in the Cisco IOS Bridging and IBM Networking Command Reference (Volume 1 of 2).


Configuring Automatic Spanning Tree

The automatic spanning-tree function supports automatic resolution of spanning trees in SRB networks, which provides a single path for spanning explorer frames to traverse from a given node in the network to another. Spanning explorer frames have a single-route broadcast indicator set in the RIF. Port identifiers consist of ring numbers and bridge numbers associated with the ports. The spanning-tree algorithm for SRB does not support Topology Change Notification Bridge Protocol Data Unit (BPDU).

Although the automatic spanning-tree function can be configured with SR/TLB, the SRB domain and transparent bridging domain have separate spanning trees. Each Token Ring interface can belong to only one spanning tree. Only one bridge group can run the automatic spanning-tree function at a time.

To create a bridge group that runs an automatic spanning-tree function compatible with the IBM SRB spanning-tree implementation, use the following command in global configuration mode:

Command
Purpose

Router(config)# bridge bridge-group protocol ibm

Creates a bridge group that runs the automatic spanning-tree function.


To enable the automatic spanning-tree function for a specified group of bridged interfaces in SRB or SR/TLB, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# source-bridge spanning bridge-group

Enables the automatic spanning-tree function on a group of bridged interfaces.


Verifying TRRSM

To verify that Token Ring Route Switch Module (TRRSM) is configured, use the following command in privileged EXEC mode:

Command
Purpose

Router# show running configuration

Displays the running configuration of a device.


The following output indicates this is a Token Ring VLAN because of the trbrf interface:

milan# show run
version 12.0
!
hostname Sample
!
interface Vlan61 type trbrf
 no ip address
 no ip directed-broadcast
 no ip route-cache
 ethernet-transit-oui 90-compatible

To verify the status of the Token Ring VLAN, use one of the following commands in privileged EXEC mode, as needed:

Command
Purpose

Router# show ip interfaces brief

Lists a summary of an interface's IP information and status

Router# show interface

Displays statistics for all interfaces configured on the router or access server


The following output indicates that Vlan5 and Vlan61 interfaces are up:

RSM-A# show ip interface brief
Interface IP-Address OK? Method Status Protocol

Vlan5 	 	 	 	 unassigned 	YES unset 	 			 up 	 	 	 	 	 	 	 up      
Vlan61 	 	 	 unassigned 	YES NVRAM 	 	 up 	 	 	 		 	 	 	 up 

The following output shows the statistics for Vlan61:

RSM-A# show interface vlan61
Vlan61 is up, line protocol is up 
  Hardware is Cat5k Virtual Token Ring, address is 0009.d49e.0100 (bia
0009.d49e.0100)
  MTU 4464 bytes, BW 16000 Kb, DLY 630 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation SNAP, loopback not set
  ARP type:SNAP, ARP Timeout 04:00:00
  Ring speed:16 Mbps
  Duplex:half
  Mode:Classic token ring station

Monitoring Statistics

You can collect, display, and clear statistical information about the network. The Duplicate Ring Protocol (DRiP) runs on Cisco routers and switches that support switched VLAN networking and is used to identify active Token Ring VLANs (TrCRFs). DRiP maintains the status of TrCRFs and uses this information to determine whether there are multiple TrCRFs active in a TrBRF.

DRiP information is used for the following:

All-routes explorer filtering

DRiP information is used in conjunction with the local configuration to determine which of the TrCRFs configured within a TrBRF have active ports. This information is used on the base switch to correctly filter all-routes explorers and on the RSM to discard AREs that have already been on an attached ring.

Detecting the configuration of duplicate TrCRFs across routers and switches

DRiP information is used in conjunction with the local configuration information to determine which TrCRFs are already active on the switches. If a TrCRF is enabled on more than one switch or router, the ports associated with the TrCRF are disabled on all switches. The RSM will not disable the internal ring used for processing source-routed traffic. Instead, the RSM generates the following error message to indicate that two identical TrCRFs exist:

DRIP conflict with CRF <vlan-id>

To show or clear DRiP or VLAN statistics, use one of the following commands in privileged EXEC mode, as needed:

Command
Purpose

Router# clear drip counters

Clears DRiP counters.

Router# show drip

Displays DRiP information.



Note When DRiP counters are cleared, the counter is reset to 0. Incrementing of DRiP counters indicates that the router is receiving packets across the TrBRF.


TRRSM Configuration Examples

The following sections provide the following RSM and Catalyst 5000 switch configuration examples:

IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

IP Routing Source-Routed Frames Between TrBRF VLANs Example

IP Routing Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN Example

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

IP Routing Non-Source-Routed Frames Between TrBRF VLANs Example

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN Example

SRB Between a TrBRF VLAN and VIP2 Token Ring Interface Example

SRB Between TrBRF VLANs Example

Transparent Bridging Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

SR/TLB Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

SR/TLB Between a TrBRF VLAN and Ethernet VLAN Example

DLSw+ Example

IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

Following is the configuration for the RSM as shown in Figure 3:

interface TokenRing 3/1
 ip address 4.4.4.1 255.255.255.0
 multiring all
!
interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0
 multiring trcrf-vlan 200 ring 100
 multiring ip

Figure 3 IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with the TrCRF VLAN 201:

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 201 type trcrf parent 998 ring 0x65 mode srb
#add token port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

Following is the configuration for the RSM as shown in Figure 4:

interface Ethernet 2/2
 ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0
 multiring trcrf-vlan 200 ring 100
 multiring all

Figure 4 IP Routing Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 201 type trcrf parent 998 ring 0x65 mode srb
#add token ring port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Source-Routed Frames Between TrBRF VLANs Example

Following is the configuration for the RSM as shown in Figure 5:

interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0
 multiring trcrf-vlan 200 ring 100
 multiring all
interface vlan999 type trbrf
 ip address 6.6.6.1 255.255.255.0
 multiring trcrf-vlan 201 ring 101
 multiring all

Figure 5 IP Routing Source-Routed Frames Between TrBRF VLANs

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 300 and the Token Ring port 5/2 is assigned with TrCRF VLAN 301.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 300 type trcrf parent 998 ring 0x66 mode srb
set vlan 999 type trbrf bridge 0xe stp ibm
set vlan 201 type trcrf parent 999 ring 0x65 mode srb
set vlan 301 type trcrf parent 999 ring 0x67 mode srb
#add token port to trcrfs
set vlan 300 5/1
set vlan 301 5/2

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN Example

Following is the configuration for the RSM as shown in Figure 6:

interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0
 multiring trcrf-vlan 200 ring 100
 multiring all
interface vlan500 type ethernet
 ip address 6.6.6.1 255.255.255.0

Figure 6 IP Routing Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 3 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 300 and the Ethernet port 3/1 is assigned with VLAN 500.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 300 type trcrf parent 998 ring 0x66 mode srb
#add token port to trcrf 300
set vlan 300 5/1
#add ether port to 500
set vlan 500 3/1

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

Following is the configuration for the RSM as shown in Figure 7:

interface TokenRing 3/1
 ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0

Note The multiring command is not needed in this configuration because these are non-source-routed frames.


Figure 7 IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Token Ring Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with the TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 201 type trcrf parent 998 ring 0x65 mode srt
#add token port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

Following is the configuration for the RSM as shown in Figure 8:

interface Ethernet 2/2
 ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0

Note The multiring command is not needed in this configuration because these are non-source-routed frames.


Figure 8 IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and a VIP2 Ethernet Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 201 type trcrf parent 998 ring 0x65 mode srt
#add token ring port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames Between TrBRF VLANs Example

Following is the configuration for the RSM as shown in Figure 9:

interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0
interface vlan999 type trbrf
 ip address 6.6.6.1 255.255.255.0

Note The multiring command is not needed in this configuration because these are non-source-routed frames.


Figure 9 IP Routing Non-Source-Routed Frames Between TrBRF VLANs

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with VLAN 300 and the Token Ring port 5/2 is assigned with VLAN 301.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 300 type trcrf parent 998 ring 0x66 mode srt
set vlan 999 type trbrf bridge 0xd stp ieee
set vlan 301 type trcrf parent 999 ring 0x67 mode srt
#add token port to trcrfs
set vlan 300 5/1
set vlan 301 5/2

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN Example

Following is the configuration for the RSM as shown in Figure 10:

interface vlan998 type trbrf
 ip address 5.5.5.1 255.255.255.0
!
interface vlan500 type ethernet
 ip address 6.6.6.1 255.255.255.0

Note The multiring command is not needed in this configuration because these are not source-routed frames.


Figure 10 IP Routing Non-Source-Routed Frames Between a TrBRF VLAN and an Ethernet VLAN

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 3 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 300 and the Ethernet port 3/1 is assigned with VLAN 500.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 300 type trcrf parent 998 ring 0x66 mode srt
#add token port to trcrf 300
set vlan 300 5/1
#add ether port to 500
set vlan 500 3/1

Because the VLANs are defined on a per-port basis, end stations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

SRB Between a TrBRF VLAN and VIP2 Token Ring Interface Example

The following configuration refers to the RSM as shown in Figure 11:

interface TokenRing3/1
 source-bridge 10 1 100
 source-bridge spanning
!
source-bridge ring-group 100
interface vlan999 type trbrf
 source-bridge trcrf-vlan 40 ring-group 100
 source-bridge spanning

Figure 11 SRB Between a TrBRF VLAN and VIP2 Token Ring Interface

Following is the configuration for the Catalyst 5000 switch which performs simple SRB. In this configuration, the Token Ring switch module exists in slot 5 and is using port 1. The Token Ring port on 5/1 is assigned to TrCRF VLAN 50.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 name trbrf type trbrf bridge 0xe stp ibm
set vlan 40 name trcrf40 type trcrf parent 999 ring 0x64 mode srb 
set vlan 50 name trcrf50 type trcrf parent 999 ring 0x1 mode srb 
#add token port to trcrf 50
set vlan 50 5/1

In this configuration, the keyword name is optional and srb is the default mode. The ring number on the switch must be specified in decimal by substituting the decring keyword for ring.

SRB Between TrBRF VLANs Example

The following configuration refers to the RSM as shown in Figure 12:

source-bridge ring-group 100
!
interface vlan999 type trbrf
 source-bridge trcrf-vlan 40 ring-group 100
 source-bridge spanning
!
interface vlan998 type trbrf
 source-bridge trcrf-vlan 70 ring-group 100
 source-bridge spanning

Figure 12 SRB Between TrBRF VLANs

The following is the configuration for the Catalyst 5000 switch with the Token Ring switch module in slot 5. The Token Ring port on 5/1 is assigned to TrCRF VLAN 50 and the Token Ring port on 5/2 is assigned to TrCRF VLAN 80.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 name trbrf type trbrf bridge 0xe stp ibm
set vlan 40 name trcrf40 type trcrf parent 999 ring 0x64 mode srb
set vlan 50 name trcrf50 type trcrf parent 999 ring 0x1 mode srb
set vlan 998 name trbrf type trbrf bridge 0xd stp ibm 
set vlan 70 name trcrf70 type trcrf parent 998 ring 0x64 mode srb
set vlan 80 name trcrf80 type trcrf parent 998 ring 0x2 mode srb
#add token port to trcrf 50
set vlan 50 5/1
#add token port to trcrf 80
set vlan 80 5/2

In this configuration, the keyword name is optional and srb is the default mode.

Transparent Bridging Between a TrBRF VLAN and a VIP2 Token Ring Interface Example

The following is the configuration for the RSM as shown in Figure 13:

bridge 1 protocol ieee 
!
interface tokenring0
 bridge-group 1
interface vlan 50 type trbrf
 bridge-group 1

Figure 13 Transparent Bridging Between a TrBRF VLAN and a VIP2 Token Ring Interface

The following is the configuration for the Catalyst 5000 switch with a Token Ring switch module in slot 5:

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 50 name trbrf50 type trbrf bridge 0xb stp ieee
set vlan 100 name trcrf100 type trcrf ring 0x64 parent 50 mode srt
#add token port to trcrf 100
set vlan 100 5/14

SR/TLB Between a TrBRF VLAN and a VIP2 Ethernet Interface Example

The following is the configuration for the RSM as shown in Figure 14:

source-bridge ring-group 100
bridge 1 protocol ieee
source-bridge transparent 100 200 10 1
!
interface vlan999 type trbrf
  source-bridge trcrf-vlan 20 ring-group 100
  source-bridge spanning
!
interface ethernet1/0
  bridge-group 1

Figure 14 SR/TLB Between a TrBRF VLAN and a VIP2 Ethernet Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port on 2/1 is assigned to VLAN 21.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 type trbrf bridge 0xd stp ibm
set vlan 20 type trcrf parent 999 ring 0x64 mode srb
set vlan 21 type trcrf parent 999 ring 0x65 mode srb
#add token ring port to trcrf 21
set vlan 21 2/1

SR/TLB Between a TrBRF VLAN and Ethernet VLAN Example

The following is the configuration for the RSM as shown in Figure 15:

source-bridge ring-group 100
bridge 1 protocol ieee
source-bridge transparent 100 200 10 1
!
interface vlan999 type trbrf
 source-bridge trcrf-vlan 20 ring-group 100
 source-bridge spanning
!
interface vlan100 type ethernet
 bridge-group 1

Figure 15 SR/TLB Between a TrBRF VLAN and Ethernet VLAN

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 3 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port on 5/1 is assigned to TrCRF 21, and the Ethernet port on 3/1 is assigned to VLAN 100.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 type trbrf bridge 0xd stp ibm
set vlan 20 type trcrf parent 999 ring 0x64 mode srb
set vlan 21 type trcrf parent 999 ring 0x65 mode srb
#add token port to trcrf 21
set vlan 21 5/1
#add ethernet
set vlan 100 type ethernet
set vlan 100 3/1

DLSw+ Example

The following is the configuration for the RSM with a VIP2 serial interface as shown in Figure 16:

source-bridge ring-group 100
dlsw local-peer peer-id 10.18.20.8
dlsw remote-peer 0 tcp 10.18.20.6
!
interface Serial1/0
 ip address 10.18.20.8 255.255.255.0
 no keepalive
 clockrate 64000
!
interface Vlan89 type trbrf
 no ip address
 source-bridge trcrf-vlan 9 ring-group 100
 source-bridge spanning

Figure 16 Configuration for DLSw+

The following is the configuration for a Catalyst 5000 with a Token Ring module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with the TrCRF VLAN 10:

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 89 type trbrf bridge 0xd stp ibm
set vlan 10 type trcrf parent 89 ring 0xa mode srb
#add token ring port to TrCRF 10
set vlan 10 5/1
set vlan 9 type trcrf parent 89 ring 0x64 mode srb

The following is the configuration for the remote router:

source-bridge ring group 100 
dlsw local-peer peer-id 10.18.20.6
dlsw remote-peer 0 tcp 10.18.20.8
!
interface loopback 0
 ip address 10.18.20.6
!
interface serial1/0
 no ip address
 no keepalive
 clockrate 64000
!
interface tokenring 2/0
 no ip address
 ring-speed 16
 source-bridge 20 1 100
 source-bridge spanning