Guest

Networking Software (IOS & NX-OS)

Cisco IOS Broadband High Availability In Service Software Upgrade

  • Viewing Options

  • PDF (267.9 KB)
  • Feedback
Cisco IOS Broadband High Availability In Service Software Upgrade

Table Of Contents

Cisco IOS Broadband High Availability In Service Software Upgrade

Finding Feature Information

Contents

Prerequisites for Cisco IOS Broadband High Availability In Service Software Upgrade

Restrictions for Cisco IOS Broadband High Availability In Service Software Upgrade

Information About Cisco IOS Broadband High Availability In Service Software Upgrade

Feature Design of Cisco IOS Broadband High Availability In Service Software Upgrade

Supported Broadband Aggregation Protocols

ISSU PPPoA

ISSU PPPoE

ISSU RA-MLPS VPN

Benefits of Cisco IOS Broadband High Availability In Service Software Upgrade

How to Configure Cisco IOS Broadband High Availability In Service Software Upgrade

Configuring Subscriber Redundancy Policy for Cisco IOS Broadband High Availability In Service Software Upgrade

Prerequisites

Verifying and Troubleshooting Subscriber Redundancy Policy for Broadband HA ISSU

Configuration Examples for Cisco IOS Broadband High Availability In Service Software Upgrade

PPPoX Terminated into an RA-MPLS Network with ISSU: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for Cisco IOS Broadband High Availability In Service Software Upgrade


Cisco IOS Broadband High Availability In Service Software Upgrade


First Published: December 4, 2006
Last Updated: October 21, 2009

The Cisco IOS Broadband High Availability (HA) In Service Software Upgrade (ISSU) feature ensures continuous operations of broadband access protocols during software upgrades, downgrades, and service enhancements.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for Cisco IOS Broadband High Availability In Service Software Upgrade" section on page 42.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Cisco IOS Broadband High Availability In Service Software Upgrade

Restrictions for Cisco IOS Broadband High Availability In Service Software Upgrade

Information About Cisco IOS Broadband High Availability In Service Software Upgrade

How to Configure Cisco IOS Broadband High Availability In Service Software Upgrade

Configuration Examples for Cisco IOS Broadband High Availability In Service Software Upgrade

Additional References

Feature Information for Cisco IOS Broadband High Availability In Service Software Upgrade

Prerequisites for Cisco IOS Broadband High Availability In Service Software Upgrade

The Cisco IOS stateful switchover (SSO) and nonstop forwarding (NSF) features must be enabled. For more information on SSO, see the document Stateful Switchover. For more information on NSF, see the document Cisco Nonstop Forwarding.

Cisco 10000 Series Platform

The Cisco 10000 series router must be configured with redundant Performance Routing Engine (PRE) modules, that is, dual Route Processors.

Cisco IOS Release 12.2(31)SB or a later release must be running.

Cisco 7600 Series Platform

Cisco  IOS Release 12.2(33)SRC or a later release must be running.

Restrictions for Cisco IOS Broadband High Availability In Service Software Upgrade

You can perform an In Service Software Upgrade (ISSU) across a major Cisco IOS release.

You can perform an ISSU from a Cisco IOS software version that supports ISSU capability.

Information About Cisco IOS Broadband High Availability In Service Software Upgrade

To configure the Cisco IOS Broadband High Availability In Service Software Upgrade feature, you should understand the following concepts:

Feature Design of Cisco IOS Broadband High Availability In Service Software Upgrade

Benefits of Cisco IOS Broadband High Availability In Service Software Upgrade

Feature Design of Cisco IOS Broadband High Availability In Service Software Upgrade

Prior to the implementation of the Cisco IOS Broadband High Availability In Service Software Upgrade feature, software upgrades typically required planned outages that took the router or network out of service. The Cisco IOS Broadband High Availability In Service Software Upgrade feature enables the service provider to maximize network availability and eliminate planned outages by allowing the Cisco IOS image to be upgraded without taking the router or network out of service. ISSU is a procedure, based on Cisco high availability (HA) architecture, whereby the Cisco IOS infrastructure accomplishes an upgrade while packet forwarding continues and broadband sessions are maintained. Cisco HA architecture is based on redundant Route Processors and the NSF and SSO features, such that ports stay active and calls do not drop, eliminating network disruption during upgrades.

The ISSU feature allows deployment of new features, hardware, services, and maintenance fixes in a procedure that is seamless to end users. A critical component of ISSU and Cisco HA technology is the cluster control manager (CCM) that manages session re-creation and synchronization on the standby processor. The Cisco IOS Broadband High Availability In Service Software Upgrade feature allows the configuration of subscriber redundancy policies that tune the synchronization process. For more information see the "Configuring Subscriber Redundancy Policy for Cisco IOS Broadband High Availability In Service Software Upgrade" section.

The Cisco IOS Broadband High Availability In Service Software Upgrade feature handles upgrades and downgrades, and supports the following:

Upgrades from one software feature release to another, as long as both versions support the ISSU feature, for example, from Cisco IOS Release 12.2(28)SB to Cisco IOS Release 12.2(31)SB2.

Upgrades from one software maintenance release to another, for example from Cisco IOS Release 12.2(28)SB1 to Cisco IOS Release 12.2(28)SB2


Note Software upgrades and downgrades are supported only within the major Cisco IOS releases; crossing between S and T or Mainline Cisco IOS releases (for example, from Cisco IOS Release 12.4(11)T and Cisco IOS Release 12.2(31)SB) is not supported even if each release supports ISSU capability. For more information on Cisco IOS releases, see Cisco IOS Software.


The Cisco IOS Broadband High Availability In Service Software Upgrade feature works with other Cisco IOS HA features, NSF and SSO, to maintain broadband sessions.

For more information on performing an ISSU, see the document Cisco IOS In Service Software Upgrade Process.

Supported Broadband Aggregation Protocols

The Cisco IOS Broadband High Availability In Service Software Upgrade feature supports the following broadband aggregation protocols:

ISSU PPPoA

ISSU PPPoE

ISSU RA-MLPS VPN

ISSU PPPoA

The Cisco IOS Broadband High Availability In Service Software Upgrade feature delivers ISSU capability for PPP over ATM sessions during supported software upgrades, downgrades, and enhancements.

ISSU PPPoE

The Cisco IOS Broadband High Availability In Service Software Upgradefeature delivers ISSU capability for PPP over Ethernet (PPPoE) subscriber access sessions, including PPPoE, PPPoEVLAN, and PPPoE802.1q-in-q sessions, during supported software upgrades, downgrades, and enhancements.

ISSU RA-MLPS VPN

The Cisco IOS Broadband High Availability In Service Software Upgrade feature delivers ISSU capability for PPPoA and PPPoE (PPPoX) sessions terminated into remote access (RA)-Multiprotocol Label Switching (MPLS) Virtual Private Networks (VPN) or PPPoX into MPLS VPN during supported software upgrades, downgrades, and enhancements.

Figure 1 shows a typical broadband aggregation HA deployment with ISSU functionality.

Figure 1 Broadband Aggregation High Availability Deployment

Benefits of Cisco IOS Broadband High Availability In Service Software Upgrade

Eliminates network downtime for Cisco IOS software image upgrades.

Eliminates resource scheduling challenges associated with planned outages and late night maintenance windows.

Accelerates deployment of new services and applications and allows faster implementation of new features, hardware, and fixes.

Reduces operating costs due to outages while delivering higher service levels.

Provides additional options for adjusting maintenance windows.

Minimizes the impact of upgrades to service and allows for faster upgrades, resulting in higher availability.

How to Configure Cisco IOS Broadband High Availability In Service Software Upgrade

This section contains the following procedures:

Configuring Subscriber Redundancy Policy for Cisco IOS Broadband High Availability In Service Software Upgrade

Verifying and Troubleshooting Subscriber Redundancy Policy for Broadband HA ISSU

Configuring Subscriber Redundancy Policy for Cisco IOS Broadband High Availability In Service Software Upgrade

The Cisco IOS Broadband High Availability In Service Software Upgrade feature is enabled by default. This task configures subscriber redundancy policy for HA ISSU capability, allowing you to manage synchronization between HA active and standby processors.

Prerequisites

For more information on performing the ISSU process, see the document Cisco IOS In Service Software Upgrade Process.

SUMMARY STEPS

1. enable

2. configure terminal

3. subscriber redundancy [bulk limit cpu percentage delay seconds allow value] [dynamic limit cpu percentage delay seconds allow value] [delay time] [rate sessions time]

4. exit

DETAILED STEPS
 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

subscriber redundancy [bulk limit cpu percentage delay seconds allow value][dynamic limit cpu percentage delay seconds allow value][delay time][rate sessions time]

Example:

Router(config)# subscriber redundancy bulk limit cpu 75 delay 20 allow 30

(Optional) Configures subscriber redundancy policy.

bulk—Configures bulk synchronization redundancy policy.

limit cpu percentage—Specifies CPU busy threshold value as a percentage. Range is 0 to 100; default is 90.

delay seconds—Specifies delay in seconds before the CCM component synchronizes sessions after the CPU busy threshold is exceeded.

allow value—Specifies the minimum number of sessions to synchronize once the CPU busy threshold is exceeded and the specified delay is met. Range is 1 to 2147483637; default is 25.

dynamic—Configures a dynamic synchronization redundancy policy.

delay time—Specifies a minimum amount of time in seconds that a session must be ready before dynamic synchronization occurs. Range is 1 to 33550.

rate sessions time—Specifies number of sessions per time period for bulk and dynamic synchronization.

sessions—Range is 1 to 32000; default is 250.

time—Range in seconds is 1 to 33550; default is 1.

Step 4 

exit

Example:

Router(config)# exit

Exits the current configuration mode.

Verifying and Troubleshooting Subscriber Redundancy Policy for Broadband HA ISSU

To verify the subscriber redundancy policy configuration, use the show running-config command. Sample output is located in the "Configuration Examples for Cisco IOS Broadband High Availability In Service Software Upgrade" section.

Step 1 and Step 2 are useful for troubleshooting the CCM synchronization component. Steps 3, 4, and 5 are useful for reviewing PPPoX session statistics. Step 6 through Step 8 are typically used by Cisco engineers for internal debugging purposes; you may be asked to provide command output to a Technical Assistance Center (TAC) engineer for assistance in troubleshooting.

SUMMARY STEPS

1. show ccm clients

2. show ccm sessions

3. show ppp subscriber statistics

4. show pppatm statistics

5. show pppoe statistics

6. show ccm queues

7. debug pppatm redundancy

8. debug pppoe redundancy

DETAILED STEPS


Step 1 show ccm clients

This command shows information on the CCM, the HA component that manages the capability to synchronize session launch on the standby processor of a redundant processor, HA system. Use the show ccm clients command to display information on CCM clients. The following is sample output fromthe show ccm clients command from a Cisco 10000 series router active RP:

Router# show ccm clients

CCM bundles sent since peer up:
	Sync Session                0
	Update Session              0
	Active Bulk Sync            0
	Session Down                0
	ISSU client msgs            0
	Unknown msgs                0
Client events sent since peer up:
	PPP                         0
	PPPoE                       0
	PPPoA                       0
	AAA                         0
	PPP SIP                     0
	LTERM                       0
	AC                          0
	Virtual Template            0

The following is sample output from the show ccm clients command from a Cisco 10000 series router standby RP:


Router# show ccm clients

CCM bundles rcvd since last boot:
    Sync Session                8
    Update Session              0
    Active Bulk Sync            1
    Session Down                8
    ISSU client msgs            59
    Unknown msgs                0
Client events extracted since last boot:
    PPP                         72
    PPPoE                       50
    PPPoA                       0
    AAA                         32
    PPP SIP                     0
    LTERM                       8
    AC                          0

The following is sample output from the show ccm clients command on a Cisco 7600 series router active processor:

Router# show ccm clients

CCM bundles sent since peer up:
	Sync Session                28059
	Update Session              0
	Active Bulk Sync End        1
	Session Down                8057
	ISSU client msgs            160
	Dynamic Session Sync        0
	Unknown msgs                0
Client events sent since peer up:
	PPP                         252351
	PPPoE                       168236
	AAA                         112236
	PPP SIP                     0
	LTERM                       28059
	AC                          0
	SSS FM                      28040
	IP SIP                      60
	IP IF                       0
	DPM                         80
	COA                         0
	Auto SVC                    0

The following is sample output from the show ccm clients command on a Cisco 7600 series router standby processor:


CCM bundles rcvd since last boot:
    Sync Session                28059
    Update Session              0
    Active Bulk Sync End        1
    Session Down                8057
    ISSU client msgs            160
    Dynamic Session Sync        0
    Unknown msgs                0
Client events extracted since last boot:
    PPP                         252351
    PPPoE                       168236
    AAA                         112174
    PPP SIP                     0
    LTERM                       28045
    AC                          0
	SSS FM                      28040
    IP SIP                      18
    IP IF                       0
    DPM                         24
    COA                         0
    Auto Svc                    0

Step 2 show ccm sessions

This command shows information on sessions managed by the CCM. The following is sample output from the show ccm sessions command on the active RP:

Router# show ccm sessions

Global CCM state:                                CCM HA Active - Dynamic Sync
Global ISSU state:                               Compatible, Clients Cap 0x0
> Number of sessions in state Down:                0
> Number of sessions in state Not Ready:           0
> Number of sessions in state Ready:               0
> Number of sessions in state Dyn Sync:            0
> 
> Timeout: Timer Type   Delay    Remaining Starts    CPU Limit CPU Last
>          ------------ -------- --------- --------- --------- --------
>          Rate         00:00:01 -         2         -         -       
>          Dynamic CPU  00:00:10 -         0         90        0 

The following is sample output from the show ccm sessions command on the standby RP:

Router# show ccm sessions

Global CCM state:                        CCM HA Standby - Collecting
Global ISSU state:                       Compatible, Clients Cap 0xFFE

                                         Current     Bulk Sent   Bulk Rcvd
                                         ----------- ----------- -----------
Number of sessions in state Down:        0           0           0          
Number of sessions in state Not Ready:   0           0           0          
Number of sessions in state Ready:       0           0           0          
Number of sessions in state Dyn Sync:    0           0           0          

Timeout: Timer Type   Delay    Remaining Starts      CPU Limit CPU Last
         ------------ -------- --------- ----------- --------- --------
         Rate         00:00:01 -         0           -         -       
         Dynamic CPU  00:00:10 -         0           90        0       
         Bulk Time Li 00:08:00 -         0           -         -       
         RF Notif Ext 00:00:20 -         0           -         -       

Step 3 show ppp subscriber statistics

This command is useful for obtaining events and statistics for PPP subscribers. Use the show ppp subscriber statistics command to display a cumulative count of PPP subscriber events and statistics, and to display an incremental count since the clear ppp subscriber statistics command was last issued.

The following is sample output from the show ppp subscriber statistics command:

Router# show ppp subscriber statistics

PPP Subscriber Events          TOTAL         SINCE CLEARED
Encap                          32011         32011        
DeEncap                        16002         16002        
CstateUp                       173           173          
CstateDown                     36            36           
FastStart                      0             0            
LocalTerm                      7             7            
LocalTermVP                    0             0            
MoreKeys                       173           173          
Forwarding                     0             0            
Forwarded                      0             0            
SSSDisc                        0             0            
SSMDisc                        0             0            
PPPDisc                        167           167          
PPPBindResp                    173           173          
PPPReneg                       3             3            
RestartTimeout                 169           169          
> 
PPP Subscriber Statistics      TOTAL         SINCE CLEARED
IDB CSTATE UP                  16008         16008        
IDB CSTATE DOWN                40            40           
APS UP                         0             0            
APS UP IGNORE                  0             0            
APS DOWN                       0             0            
READY FOR SYNC                 10            10           

Step 4 show pppatm statistics

This command is useful for obtaining statistics for PPPoA sessions. Use the show pppatm statistics command to display a total count of PPPoA events since the clear pppatm statistics command was last issued.

The following is sample output from the show pppatm statistics command:

Router# show pppatm statistics

	4000 : Context Allocated events
	3999 : SSS Request events
	7998 : SSS Msg events
	3999 : PPP Msg events
	3998 : Up Pending events
	3998 : Up Dequeued events
	3998 : Processing Up events
	3999 : Vaccess Up events
	3999 : AAA unique id allocated events
	3999 : No AAA method list set events
	3999 : AAA gets nas port details events
	3999 : AAA gets retrived attrs events
	68202 : AAA gets dynamic attrs events
	3999 : Access IE allocated events

Step 5 show pppoe statistics

This command is useful for obtaining statistics and events for PPPoE sessions. Use the show pppoe statistics command to display a cumulative count of PPPoE events and statistics, and to display an incremental count since the last time the clear pppoe statistics command was issued.

The following is sample output from the show pppoe statistics command:

Router# show pppoe statistics

PPPoE Events                   TOTAL         SINCE CLEARED
------------------------------ ------------- -------------
INVALID                        0             0            
PRE-SERVICE FOUND              0             0            
PRE-SERVICE NONE               0             0            
SSS CONNECT LOCAL              16002         16002        
SSS FORWARDING                 0             0            
SSS FORWARDED                  0             0            
SSS MORE KEYS                  16002         16002        
SSS DISCONNECT                 0             0            
CONFIG UPDATE                  0             0            
STATIC BIND RESPONSE           16002         16002        
PPP FORWARDING                 0             0            
PPP FORWARDED                  0             0            
PPP DISCONNECT                 0             0            
PPP RENEGOTIATION              0             0            
SSM PROVISIONED                16002         16002        
SSM UPDATED                    16002         16002        
SSM DISCONNECT                 0             0            
> 
PPPoE Statistics               TOTAL         SINCE CLEARED
------------------------------ ------------- -------------
SSS Request                    16002         16002        
SSS Response Stale             0             0            
SSS Disconnect                 0             0            
PPPoE Handles Allocated        16002         16002        
PPPoE Handles Freed            0             0            
Dynamic Bind Request           16002         16002        
Static Bind Request            16002         16002 

Step 6 show ccm queues

Use the show ccm queues command to display queue statistics for CCM sessions on active and standby processors. This command is primarily used only by Cisco engineers for internal debugging of CCM processes.

The following is sample output from the show ccm queues command:

Router# show ccm queues

9 Event Queues
                 size   max      kicks     starts    false   suspends  ticks(ms)
 4 CCM              0     2         13         13        0          0        20

 Event Names
                          Events  Queued  MaxQueued  Suspends  usec/evt max/evt
 1  4 Sync Session              0        0        0        0         0         0
 2  4 Sync Client               0        0        0        0         0         0
 3  4 Update                    0        0        0        0         0         0
 4  4 Session Down              0        0        0        0         0         0
 5  4 Bulk Sync Begi            0        0        0        0         0         0
 6  4 Bulk Sync Cont            0        0        0        0         0         0
 7  4 Bulk Sync End             1        0        1        0        53        53
 8  4 Going Active              0        0        0        0         0         0
 9  4 Going Standby             1        0        1        0        10        10
10  4 Standby Presen            0        0        0        0         0         0
11  4 Standby Gone              0        0        0        0         0         0
13  4 CP Message               18        0        2        0       156       573
14  4 Recr Session              0        0        0        0         0         0
15  4 Recr Update               0        0        0        0         0         0
16  4 Recr Sess Down            0        0        0        0         0         0
17  4 ISSU Session N            1        0        1        0       283       283
18  4 ISSU Peer Comm            0        0        0        0         0         0

Step 7 debug pppatm redundancy

Use the debug pppatm redundancy command to display CCM events and messages for PPPoA sessions on HA systems. This command is generally used only by Cisco engineers for internal debugging of CCM processes. The following is sample output from the debug pppatm redundancy command from a Cisco 10000 series router standby RP:

Router# debug pppatm redundancy

*Dec  3 02:58:40.784: PPPATM HA: [14000001]: Received the first SHDB 
*Dec  3 02:58:40.784: PPPATM HA: [14000001]: Base hwidb not created > yet, queuing SHDB 
*Dec  3 02:58:40.784: PPPATM HA: [14000001]: 
Requesting base vaccess creation

Step 8 debug pppoe redundancy

Use the debug pppoe redundancy command to display CCM events and messages for PPPoE sessions on HA systems. This command is generally used only by Cisco engineers for internal debugging of CCM processes. The following is sample output from the debug pppoe redundancy command from a Cisco 10000 series router active RP:

Router# debug pppoe redundancy

Nov 22 17:21:11.327: PPPoE HA[0xBE000008] 9: Session ready to sync data 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PADR, length = 58 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SESSION ID, length = 2 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SWITCH HDL, length = 4 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SEGMENT HDL, length = 4 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PHY SWIDB DESC, length = 20 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = VACCESS DESC, length = 28 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: Sync collection for ready events 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PADR, length = 58 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SESSION ID, length = 2 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SWITCH HDL, length = 4 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SEGMENT HDL, length = 4 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PHY SWIDB DESC, length = 20 
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = VACCESS DESC, length = 28

The following is sample output from the debug pppoe redundancy command from a Cisco 10000 series router standby RP:

Router# debug pppoe redundancy

The following is sample output from the debug pppoe redundancy command from a Cisco 10000 series router standby RP:

Nov 22 17:21:11.448: PPPoE HA[0x82000008]: Recreating session: retrieving data 
Nov 22 17:21:11.464: PPPoE HA[0x82000008] 9: Session ready to sync data

The following is sample output from the debug pppoe redundancy command from a Cisco 7600 series router active processor.

Router# debug pppoe redundancy

Dec 17 15:14:37.060: PPPoE HA[0x131B01B1] 28039: Session ready to sync data
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = PADR, length = 48
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = SESSION ID, length = 2
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = SWITCH HDL, length = 4
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = SEGMENT HDL, length = 4
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = PHY SWIDB DESC, length = 20
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = VACCESS DESC, length = 28
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: Sync collection for ready events
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = PADR, length = 48
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = SESSION ID, length = 2
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = SWITCH HDL, length = 4
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = SEGMENT HDL, length = 4
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = PHY SWIDB DESC, length = 20
Dec 17 15:14:37.076: PPPoE HA[0x131B01B1] 28039: code = VACCESS DESC, length = 28

The following is sample output from the debug pppoe redundancy command from a Cisco 7600 series router standby processor:

Router# debug pppoe redundancy

Dec 17 15:14:37.180: STDBY: PPPoE HA[0xE41B019B]: Recreating session: retrieving data
Dec 17 15:14:37.204: STDBY: PPPoE HA[0xE41B019B] 28039: Session ready to sync data


Configuration Examples for Cisco IOS Broadband High Availability In Service Software Upgrade

This section provides the following configuration example:

PPPoX Terminated into an RA-MPLS Network with ISSU: Example

PPPoX Terminated into an RA-MPLS Network with ISSU: Example

The following example shows how to configure PPPoX session subscriber redundancy policy for the Cisco IOS Broadband High Availability In Service Software Upgrade feature in an RA-MPLS network:

Router# show running-config

hostname Router
!
boot-start-marker
boot system bootflash:c10k2-p11-mz.sur3_1003 boot-end-marker !
enable password cisco
!
aaa new-model
!
!
aaa authentication ppp default local
!
!
!
aaa session-id common
ppp hold-queue 80000
facility-alarm intake-temperature major 54 facility-alarm intake-temperature minor 45 
facility-alarm intake-temperature critical 72 facility-alarm core-temperature major 58 
facility-alarm core-temperature minor 50 facility-alarm core-temperature critical 85 !
!
card 1/0 4oc3atm-1
card 2/0 4oc3atm-1
card 3/0 4oc3atm-1
card 4/0 4oc3atm-1
card 5/0 8fastethernet-1
card 6/0 4oc3atm-1
card 7/0 4oc3atm-1
card 8/0 1gigethernet-hh-1
card 8/1 1gigethernet-hh-1
ip subnet-zero
no ip gratuitous-arps
no ip domain lookup
ip vrf vrf1
  rd 1:1
  route-target export 1:1
  route-target import 1:1
!
no ip dhcp use vrf connected
!
!
!
!
no subscriber policy recording rules

The following lines show subscriber redundancy policy configuration:

subscriber redundancy dynamic limit cpu 90 delay 10 subscriber redundancy bulk limit cpu 
90 delay 10 subscriber redundancy rate 4000 1 subscriber redundancy delay 10 no mpls 
traffic-eng auto-bw timers frequency 0 mpls ldp graceful-restart mpls ldp router-id 
Loopback100 no virtual-template snmp issu config-sync policy bulk prc issu config-sync 
policy bulk bem !
redundancy
  mode sso
username cisco password 0 cisco
!
buffers small permanent 15000
buffers middle permanent 12000
buffers large permanent 1000
bba-group pppoe grp1
  virtual-template 1
!
bba-group pppoe grp2
  virtual-template 2
!
bba-group pppoe grp3
  virtual-template 3
!
bba-group pppoe grp4
  virtual-template 4
!
bba-group pppoe grp5
  virtual-template 5
!
bba-group pppoe grp7
  virtual-template 7
!
bba-group pppoe grp8
  virtual-template 8
!
bba-group pppoe grp6
  virtual-template 6
!
!
interface Loopback0
  ip vrf forwarding vrf1
  ip address 172.16.1.1 255.255.255.255
!
interface Loopback100
  ip address 172.31.0.1 255.255.255.255
!
interface FastEthernet0/0/0
  ip address 192.168.2.26 255.255.255.0
  speed 100
  full-duplex
!
interface ATM1/0/0
  no ip address
  load-interval 30
!
interface ATM1/0/0.1 multipoint
  range pvc 1/32 1/4031
   encapsulation aal5snap
   protocol pppoe group grp1
  !
!
interface ATM1/0/0.2 multipoint
  range pvc 2/32 2/4031
   encapsulation aal5snap
   protocol pppoe group grp2
  !
!
interface ATM1/0/1
  no ip address
!
interface ATM1/0/1.1 multipoint
  range pvc 3/32 3/4031
   encapsulation aal5snap
   protocol pppoe group grp3
  !
!
interface ATM1/0/1.2 multipoint
  range pvc 4/32 4/4031
   encapsulation aal5snap
   protocol pppoe group grp4
  !
!
interface ATM1/0/2
  no ip address
!
interface ATM1/0/2.1 multipoint
  range pvc 5/32 5/4031
   encapsulation aal5snap
   protocol pppoe group grp5
  !
!
interface ATM1/0/2.2 multipoint
  range pvc 6/32 6/4031
   encapsulation aal5snap
   protocol pppoe group grp6
  !
!
interface ATM1/0/3
  no ip address
!
interface ATM1/0/3.1 multipoint
  range pvc 7/32 7/4031
   encapsulation aal5snap
   protocol pppoe group grp7
  !
!
interface ATM1/0/3.2 multipoint
  range pvc 8/32 8/4031
   encapsulation aal5snap
   protocol pppoe group grp8
  !
!
!
!
interface ATM7/0/3
  no ip address
!
interface GigabitEthernet8/0/0
  mac-address 0011.0022.0033
  ip vrf forwarding vrf1
  ip address 10.1.1.2 255.255.255.0
  negotiation auto
!
interface GigabitEthernet8/1/0
  ip address 10.1.1.1 255.255.255.0
  negotiation auto
  mpls ip
!
interface Virtual-Template1
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool1
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template2
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool2
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template3
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool3
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template4
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool4
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template5
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool5
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template6
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool6
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template7
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool7
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
interface Virtual-Template8
  ip vrf forwarding vrf1
  ip unnumbered Loopback0
  no logging event link-status
  peer default ip address pool pool8
  no snmp trap link-status
  keepalive 30
  ppp authentication pap
!
router ospf 1
  log-adjacency-changes
  nsf
  network 10.1.1.0 0.0.0.255 area 0
  network 10.0.0.0 0.0.0.255 area 0
!
router bgp 1
  no synchronization
  bgp log-neighbor-changes
  bgp graceful-restart restart-time 120
  bgp graceful-restart stalepath-time 360
  bgp graceful-restart
  neighbor 10.0.0.3 remote-as 1
  neighbor 10.0.0.3 update-source Loopback100
  no auto-summary
  !
  address-family vpnv4
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.3 send-community extended
  exit-address-family
  !
  address-family ipv4 vrf vrf1
  redistribute connected
  redistribute static
  no auto-summary
  no synchronization
  exit-address-family
!
ip local pool pool2 10.1.1.1 10.1.16.160
ip local pool pool3 10.1.1.1 10.1.16.160 
ip local pool pool4 10.1.1.1 10.1.16.160 
ip local pool pool5 10.1.1.1 10.1.16.160 
ip local pool pool6 10.1.1.1 10.1.16.160 
ip local pool pool7 10.1.1.1 10.1.16.160 
ip local pool pool8 10.1.1.1 10.1.16.160 
ip classless !
!
no ip http server
!
!
arp 10.1.1.1 0020.0001.0001 ARPA
arp vrf vrf1 10.1.1.1 0020.0001.0001 ARPA !
!
!
!
!
line con 0
line aux 0
line vty 0 4
  password cisco
!
exception crashinfo file bootflash:crash.log !
end

Additional References

The following sections provide references related to the Cisco IOS Broadband High Availability In Service Software Upgrade feature.

Related Documents

Related Topic
Document Title

Information about Cisco 10000 series routers and broadband aggregation

Cisco 10000 Series Router Broadband Aggregation, Leased-Line, and MPLS Configuration Guide

Performing an ISSU

Cisco IOS In Service Software Upgrade Process

Information about the broadband SSO feature

Cisco IOS Broadband High Availability Stateful Switchover

Information about SSO

Stateful Switchover

Information about NSF

Cisco Nonstop Forwarding

Information on Cisco IOS releases

Cisco IOS Software


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature Information for Cisco IOS Broadband High Availability In Service Software Upgrade

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for Cisco IOS Broadband High Availability In Service Software Upgrade

Feature Name
Releases
Feature Information

Cisco IOS Broadband High Availability In Service Software Upgrade

12.2(31)SB2
12.2(33)SRC

The Cisco IOS Broadband High Availability In Service Software Upgrade feature provides the capability for the dual Route Processor Cisco 10000 series platforms to support continuous operations during software upgrades, downgrades, and service enhancements.

Cisco IOS Broadband High Availability In Service Software Upgrade for PPPoE

12.2(1st)SRE

The Cisco IOS Broadband High Availability In Service Software Upgrade feature delivers In-Service Software Upgrade (ISSU) support for PPP over Ethernet (PPPoE) (including PPPoE, PPPoVLAN, PPPoEo802.1q-in-q) sessions during a planned software upgrade on a dual-RP HA platform utilizing Cisco's ISSU capability.

In Release 12.2(1st)SRE, this feature was supported. The following commands were introduced or modified:

clear ppp subscriber statistics, clear pppatm statistics, clear pppoe statistics, debug pppatm redundancy, debug pppoe redundancy, show ccm clients, show ccm queues, show ccm sessions, show ppp subscriber statistics, show pppatm statistics, show pppoe statistics, subscriber redundancy.



CCDE, CCENT, CCSI, Cisco Eos, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Lumin, Cisco Nexus, Cisco Nurse Connect, Cisco Pulse, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, and Flip Gift Card are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco  IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Fast Step, Follow Me Browsing, FormShare, GainMaker, GigaDrive, HomeLink, iLYNX, Internet Quotient, IOS, iPhone, iQuick Study, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MediaTone, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, Network Registrar, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, ScriptShare, SenderBase, SMARTnet, Spectrum Expert, StackWise, The Fastest Way to Increase Your Internet Quotient, TransPath, WebEx, and the WebEx logo are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.