Guest

Cisco IOS Software Releases 12.4 T

Configuring the Cisco Wireless Controller Network Module on a Cisco Router, Cisco IOS Release 12.4(15)T

  • Viewing Options

  • PDF (1.0 MB)
  • Feedback
Configuring the Cisco Wireless Controller Network Module on a Cisco Router, Cisco IOS Release 12.4(15)T

Table Of Contents

Configuring the Cisco Wireless Controller Network Module on a Cisco Router, Cisco IOS Release 12.4(15)T

Obtaining Documentation, Obtaining Support, and Security Guidelines

Contents

Prerequisites for Configuring the Cisco WLCM on a Cisco Router

Restrictions for Configuring the Cisco WLCM on a Cisco Router

Information About the Cisco WLCM on a Cisco Router

Power over Ethernet

Connecting Access Points

Operating System User Interfaces

How to Configure the Cisco WLCM

Accessing the CLI Through a Console Connection or Through Telnet

Understanding Interfaces on the Cisco WLCM

Using Interface Configuration Mode

Configuring the Cisco WLCM in the Router

Prerequisites

What to Do Next

Running the Configuration Wizard

Configuration Example for Running the Configuration Wizard

What to Do Next

Configuring and Verifying Management and AP Manager Interfaces

Configuration Examples for Verifying Management and AP Manager Interfaces

What to Do Next

Configuring Wide-Area LANs on the Cisco WLCM

Configuring the Interface

Assigning the WLANs to a DHCP server

Assigning the WLANs to a VLAN

Configuration Examples for Creating VLANs

What to Do Next

Configuring VLANs with APs Connected to an External Switch

Restrictions

Configuring the Switch Port

Assigning the WLANs on the Router to a DHCP Server

Creating Dynamic Interfaces on the WLCM

What to Do Next

Configuring APs Connected to an EtherSwitch Module on the Router

Configuring Integrated Routing and Bridging

What to Do Next

Configuring Wired VLANs on the EtherSwitch Module with Wireless VLANs on the WLCM

Configuring the Router

Configuring the EtherSwitch Network Module

What to Do Next

Upgrading the Cisco WLCM Software

Restrictions

Configuration Examples for Using the reset system Command

What to Do Next

Saving Configurations

What to Do Next

Erasing and Resetting the WLCM Configuration

Additional References

Related Documents

Technical Assistance

Commands at a Glance

interface integrated-service-engine

service-module integrated-service-engine

show controllers integrated-service-engine

show interfaces integrated-service-engine


Configuring the Cisco Wireless Controller Network Module on a Cisco Router, Cisco IOS Release 12.4(15)T


The Cisco wireless LAN (WLAN) controller network module (WLCM) is designed to provide small- and medium-sized businesses (SMBs) and enterprise branch office customers 802.11 wireless networking solutions for Cisco 2800 series and Cisco 3800 series Integrated Services Routers (ISRs) and Cisco 3700 series routers. The Cisco WLCM operating system enables Cisco ISRs and Cisco 3700 series routers to manage up to 8 or 12 WLAN access points (APs) and simplifies deploying and managing wireless LANs. The operating system manages all data client, communications, and system administration functions, performs radio resource management (RRM) functions, manages system-wide mobility policies using the operating system security (OSS), and coordinates all security functions using the OSS framework. The Cisco WLCM works in conjunction with Cisco Aironet lightweight access points, the Cisco Wireless Control System (WCS), and the Cisco Wireless Location Appliance (WLA) to support wireless data, voice, and video applications.

For information about the Cisco Wireless LAN controller module NM-AIR-WLC6 solution, see the Cisco Network Modules Hardware Installation Guide at the following URL:

http://www.cisco.com/en/US/products/hw/modules/ps2797/prod_installation_guides_list.html


Note The Cisco 2801 Integrated Services Router does not support the Cisco WLCM.



Note The Cisco WCS software version to use for this release is 4.1.x. The Cisco WLA software version to use for this release is 3.0.


For more information about the Cisco WLAN solution, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Obtaining Documentation, Obtaining Support, and Security Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, security guidelines, and also recommended aliases and general Cisco documents, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Contents

Prerequisites for Configuring the Cisco WLCM on a Cisco Router

Restrictions for Configuring the Cisco WLCM on a Cisco Router

Information About the Cisco WLCM on a Cisco Router

How to Configure the Cisco WLCM

Additional References

Commands at a Glance

Prerequisites for Configuring the Cisco WLCM on a Cisco Router

The Cisco WLCM operating system on the Cisco WLCM must be compatible with the Cisco IOS software release and feature set on the router.

Use the following commands to view the Cisco IOS version on the router and to view the operating system version on the WLCM.

To view the Cisco IOS software release and feature set, enter the show version command in privileged EXEC mode on the router.

To view the Cisco WLCM OS version, enter the show sysinfo: command at the WLCM prompt.

Restrictions for Configuring the Cisco WLCM on a Cisco Router

The WLCM does not manage the integrated access points (HWIC-AP modules) on Cisco ISRs.

Information About the Cisco WLCM on a Cisco Router

The Cisco WLCM is supported on the following router platforms:

Cisco 3725 and 3745 routers

For information about Cisco 3700 series routers wireless support, see the following URL:

http://www.cisco.com/en/US/products/hw/routers/ps282/tsd_products_support_series_home.html

Cisco 2811, 2821, and 2851 Integrated Services Routers

For information about Cisco 2800 Integrated Services Routers wireless support, see the following URL:

http://www.cisco.com/en/US/products/ps5854/tsd_products_support_series_home.html

Cisco 3825 and 3845 Integrated Services Routers

For information about Cisco 3800 Integrated Services Routers wireless support, see the following URL:

http://www.cisco.com/en/US/products/ps5855/tsd_products_support_series_home.html

Cisco WLCMs ship with a boot loader and a 512-MB CompactFlash memory card. The CompactFlash memory card contains the boot loader, Linux kernel, Cisco WLCM and access points executable file, emergency upgrade software, and Cisco WLCM configuration.

Figure 1 shows the faceplate of the Cisco WLCM.


Note The external Gigabit Ethernet port on the faceplate of the Cisco WLCM is not supported.


Figure 1 Cisco Wireless LAN Controller Network Module Faceplate


Note Only one Cisco WLCM can be installed in a single router chassis.



Note The wireless LAN controller network module is supported only in network module slots. It is not supported in the extension voice module (EVM) slots available in the Cisco 2821 and Cisco 2851 Integrated Services Routers.


Figure 2 shows how the Cisco WLCM can be simultaneously deployed across multiple floors and buildings in a wired branch office with secure data, voice, switching, and wireless functions.

Figure 2 Cisco WLCM Deployment for Converged Wireless with Secure Data, Voice, Switching, and Wireless Functions

The Cisco Wireless Control System (WCS) allows users to design, control, and monitor enterprise wireless networks from a centralized location. The Cisco WCS is an optional network component that works in conjunction with Cisco APs and Cisco WLCMs.

The Cisco 2700 series location appliance is another optional network component that enhances the high-accuracy, built-in, Cisco WCS location-tracking abilities by computing, collecting, and storing historical location data. This data can be displayed in the Cisco WCS. The location appliance acts as a server to one or more Cisco WCS servers; the location appliance collects, stores, and passes on data from its associated controllers. For complete information about managing the Cisco WLAN location appliance, see the following URL:

http://www.cisco.com/en/US/products/ps6386/tsd_products_support_series_home.html

Power over Ethernet

Power over Ethernet (PoE) is supported on Cisco ISR routers. When using PoE, the installer runs a single CAT-5 cable from each access point to PoE-equipped network elements, such as a PoE-compliant Cisco EtherSwitch service module on the integrated services router or a Cisco Catalyst 3750 switch with PoE. When the PoE equipment determines that the access point is PoE-enabled, it sends -48 VDC over the unused pairs in the Ethernet cable to power the access point.

Connecting Access Points

Access points can be connected to a separate switch or to a Cisco EtherSwitch service module on Cisco ISRs. The Cisco ISR family supports a range of integrated Cisco EtherSwitch service modules with 4 to 48 ports supporting PoE.


Note Only Cisco EtherSwitch service modules support PoE. Cisco Ethernet switch network modules (NM-16ESW and NMD-36ESW) do not support PoE.


Operating System User Interfaces

The Cisco WLCM and its associated Cisco access points can be concurrently managed by these operating system user interfaces:

Command line interface (CLI)—The CLI is a full-featured but simple text-based, tree-structured interface that allows up to five users with Telnet-capable terminal emulators to simultaneously manage all aspects of the Cisco WLCM and associated Cisco access points. You can locally or remotely configure, monitor, and control individual Cisco WLCMs.

For more information about the CLI and a complete list of features available on the Cisco WLCM, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Cisco WLCM web GUI—The web user interface is built into each Cisco wireless LAN controller. The web user interface allows up to five users to simultaneously browse the built-in Cisco wireless LAN controller http: or https: (http + SSL) web server, configure parameters, and monitor operational status for the Cisco wireless LAN controller and its associated access points.


Note We recommend that you enable the https: interfaces and disable the http: interfaces to ensure stronger security for your Cisco WLAN solution.


Because the web user interface works with one Cisco wireless LAN controller at a time, the web user interface is especially useful when you wish to configure or monitor a single Cisco wireless LAN controller and its associated access points that support Lightweight Access Point Protocol (LWAPP). The web GUI is supported on Internet Explorer, version 6.0 Standard and Enterprise Editions (SP1) or later.

For complete information about the GUI, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Cisco WCS—The Cisco WCS is the Cisco wireless LAN solution network management tool that adds to the capabilities of the web user interface and the CLI, moving from individual controllers to a network of controllers. The Cisco WCS runs on Windows 2000, Windows 2003, and Red Hat Enterprise Linux ES servers.

The Cisco WCS includes the same configuration, performance monitoring, security, fault management, and accounting options that are used at the Cisco wireless LAN controller level, but adds a graphical view of multiple controllers and managed access points.

For complete information about the Cisco WCS, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

The Cisco WLCM, together with Cisco ISRs, supports IPSec security for wireless clients that terminate on Cisco ISRs through the use of a VPN pass-through on the Cisco WLCM.

How to Configure the Cisco WLCM

This section contains the following procedures:

Accessing the CLI Through a Console Connection or Through Telnet

Understanding Interfaces on the Cisco WLCM

Using Interface Configuration Mode

Configuring the Cisco WLCM in the Router

Running the Configuration Wizard

Configuring and Verifying Management and AP Manager Interfaces

Configuring Wide-Area LANs on the Cisco WLCM

Configuring VLANs with APs Connected to an External Switch

Configuring APs Connected to an EtherSwitch Module on the Router

Configuring Wired VLANs on the EtherSwitch Module with Wireless VLANs on the WLCM

Upgrading the Cisco WLCM Software

Saving Configurations

Erasing and Resetting the WLCM Configuration


Note This section describes how to perform the initial configuration of a Cisco WLCM that is installed in the router. This section does not provide configuration information on Cisco access points and other components (from the Cisco WLCM). For this information, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Before installing, configuring, or upgrading a Cisco WLCM, see the Cisco Wireless LAN Solution Product Guide.



Note Configuration of the Cisco WLCM is possible only through the CLI wizard. Web Agent Configuration Wizard is not supported in this release.



Caution The internal serial port data rate for the WLCM is fixed at 9600 baud. The data rate should not be changed on the router or on the Cisco WLCM.

Accessing the CLI Through a Console Connection or Through Telnet

Before you can access the Cisco WLCM CLI, you must first use one of these methods to establish a connection from the host router:

Connect to the router console using Telnet or SSH, and open a session to the module using the service-module integrated-service-engine slot/unit session command in privileged EXEC mode on the router.


Note Before you can establish a connection between the router and the Cisco WLCM, you must configure an IP address on the integrated-service-engine interface on the Cisco WLCM.



Note When connecting to the router through the console using Telnet or SSH from a client station, you must have IP connectivity from the client station to the router.


Use any Telnet TCP/IP or encrypted SSH package from a remote management station. The router must have network connectivity with Telnet or SSH allowed from the clients, and must have an enable or enable secret password configured. After you connect through the CLI, through a Telnet session, or through a SSH session, the user EXEC prompt appears on the management station.

The Cisco WLCM supports one secure SSH session and up to 5 simultaneous Telnet sessions. Changes made by one Telnet user are reflected in all other Telnet sessions.

If your Cisco WLCM is already configured, you can directly open a session to the WLCM and configure it through its CLI.

Understanding Interfaces on the Cisco WLCM

The host router and the Cisco WLCM communicate through the integrated-service-engine interface connection between the router and the Cisco WLCM.


Note The Cisco WLCM (NME-AIR-WLC8-K9 and NME-AIR-WLC12-K9) support the integrated-service-engine command in interface configuration mode. The Cisco WLCM (NM-AIR-WLC6-K9) supports the wlan-controller command in interface configuration mode. The interface numbering format on the Cisco WLCM is slot/port.


For more detailed information about interface types on the controller network module, see the
Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Using Interface Configuration Mode


Note Although the configure interface port interface name port command is available, the software automatically sets the port value to port 1. Therefore, there is no need to manually configure the port.


The Gigabit Ethernet internal interface on the Cisco WLCM connects internally to the integrated-service-engine interface 1/0 on the router (if the WLCM is inserted in slot 1 of the router).

The port numbering scheme that you use in interface configuration mode is interface type/slot number/port number.

Type—The interface type interface integrated-service-engine.

Slot numberThe slot number on the router where the Cisco WLCM is plugged in.

Port number—Port number within the Cisco WLCM. For this release, the port number is always 0.

Configuring the Cisco WLCM in the Router

This section describes how to perform the initial configuration of the router with a Cisco WLCM installed. This section also describes the initial configuration of the Cisco WLCM itself.

For advanced information about configuring the Cisco WLCM, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Prerequisites

Before installing, configuring, or upgrading the Cisco WLCM, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html


Note For complete information about command syntax and attributes, see the Cisco Wireless LAN Controller Command Reference at the following URL:

http://www.cisco.com/en/US/products/ps6308/prod_command_reference_list.html


SUMMARY STEPS

1. enable

2. configure terminal

3. interface integrated-service-engine slot/port

4. ip address ip address/subnet mask

5. no shutdown

6. end

7. service-module integrated-service-engine slot/port session

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router# enable

Enters privileged EXEC mode.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface integrated-service-engine slot/port

Example:

Router(config)# interface integrated-service-engine 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 4 

ip address ip address/subnet mask

Example:

Router(config-if)# ip address 192.0.2.254 255.255.255.0

Configures an IP address and subnet mask on this controller interface.

Step 5 

no shutdown

Example:

Router(config-if)# no shutdown

Enables the module port.

Step 6 

end

Example:

Router(config-if)# end

Returns to privileged EXEC mode.

Step 7 

service-module integrated-service-engine slot/port session

Example:

Router# service-module integrated-service-engine 1/0 session

Opens a session to the WLCM.

If the Cisco WLCM has no prior configuration, the configuration wizard automatically starts. You cannot bypass the configuration wizard. Through the CLI, you must provide the required information at the prompts. For information about the configuration wizard, see the "Running the Configuration Wizard" section.

What to Do Next

Proceed to the "Running the Configuration Wizard" section.

Running the Configuration Wizard

When the controller boots at factory defaults, the bootup script runs the configuration wizard, which prompts the installer for initial configuration settings.


Note After the Cisco WLCM interface has been configured and you have booted the WLCM image, you can switch back and forth between the router and the module by pressing Control-Shift-6, followed by x.


SUMMARY STEPS

1. system name

2. username and password

3. IP address, netmask, default router, VLAN identifier, port number

4. DHCP server IP address

5. AP manager interface and AP manager DHCP server IP address

6. virtual gateway IP address

7. RF group name

8. service set identifier (SSID)

9. static IP addresses for clients

10. RADIUS server

11. country code

12. support for 802.11b, 802.11a, or 802.11g

13. radio resource management (RRM) (auto RF)

14. NTP server IP address and polling interval

15. username and password

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

system name

Example:
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup

WLCM:# anyname

Enter up to 32 printable ASCII characters.

Step 2 

username and password

Example:

Enter Administrative User Name (24 characters max): anyname

Enter Administrative Password (24 characters max): *****

Enter an administrator username and password, each up to 24 printable ASCII characters.

Step 3 

IP address, netmask, default router, VLAN identifier, port number

Example:

Management Interface IP Address: 192.0.2.24

Management Interface Netmask: 255.255.255.0

Management Interface Default Router: 192.0.2.254

Management Interface VLAN Identifier (0 = untagged): 0

Management Interface Port Num [1]: 1

Enter the management interface IP address, netmask, default router IP address, optional VLAN identifier (a valid VLAN identifier, or 0 for untagged), and port number.

Step 4 

DHCP server IP address

Example:

Management Interface DHCP Server IP Address: 192.0.2.24

Enter the IP address of the default DHCP server that will supply IP addresses to clients and to the management interface, if you use one.

Step 5 

AP manager interface and AP manager DHCP server IP address

Example:

AP Manager Interface IP Address: 192.0.2.25

AP-Manager is on Management subnet, using same values

AP Manager Interface DHCP Server (192.0.2.24): 192.0.2.24

Enter the IP addresses for the AP manager interface and the AP manager DHCP server.

Step 6 

virtual gateway IP address

Example:

Virtual Gateway IP Address: 1.1.1.1

Enter the virtual gateway IP address. This address can be any fictitious, unassigned IP address (such as 1.1.1.1) to be used by Layer 3 security and mobility managers.

Step 7 

RF group name

Example:

Mobility/RF Group Name: anyname-mg

Enter the Cisco WLAN solution mobility RF group name.

Step 8 

service set identifier (SSID)

Example:

Network Name (SSID): wlan-15

Enter the WLAN 1 service set identifier (SSID), or network name. This is the default SSID that access points use to associate to a controller.

Step 9 

static IP addresses for clients

Example:

Allow Static IP Addresses [YES][no]: no

Allow or disallow static IP addresses for clients. Enter yes to allow clients to supply their own IP addresses. Enter no to require clients to request an IP address from a DHCP server.

Step 10 

RADIUS server

Example:

Configure a RADIUS Server now? [YES][no]: no

Warning! The default WLAN security policy requires a RADIUS server.

Please see documentation for more details.

If you need to configure a RADIUS server, enter yes, and enter the RADIUS server IP address, the communication port, and the shared secret. If you do not need to configure a RADIUS server, or if you want to configure the server later, enter no.

Step 11 

country code

Example:

Enter Country Code (enter 'help' for a list of countries) [US]: US

Enter a country code for the unit. To see a list of the supported country codes, enter help or see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

Step 12 

support for 802.11b, 802.11a, or 802.11g

Example:

Enable 802.11b Network [YES][no]: yes

Enable 802.11a Network [YES][no]: yes

Enable 802.11g Network [YES][no]: yes

Enable or disable support for 802.11b, 802.11a, and 802.11g.

Step 13 

radio resource management (RRM) (auto RF)

Example:

Enable Auto-RF [YES][no]:


Enable or disable radio resource management (RRM) (auto RF).

Note The controller saves the configuration, reboots with your changes, and prompts you to log in or to enter recover-config to reset to the factory default configuration and return to the wizard.

When the configuration wizard has completed initial configuration, the Cisco WLCM automatically reboots with the new configuration and stops at the User prompt.

Step 14 

NTP server IP address and polling interval

Example:

Configure a NTP server now? [YES][no]: yes

Enter the NTP server's IP address: 192.0.2.254

Enter a polling interval between 3600 and 604800 secs: 7200

You are prompted to configure the Network Time Protocol (NTP) server if necessary.

If you answer yes to configuring the NTP server, you are prompted to provide the NTP server IP address.

If you answer yes to configuring the NTP server, you are also prompted to provide the polling interval.

Step 15 

username and password

Example:

User: anyname

Password: *****

(WLCM)

Supply the username and password.

Configuration Example for Running the Configuration Wizard

The following example shows the settings by using the wizard on the CLI:

Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
WLCM:# anyname

Enter Administrative User Name (24 characters max): anyname
Enter Administrative Password (24 characters max): *****

Management Interface IP Address: 192.0.2.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.0.2.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1

Management Interface DHCP Server IP Address: 192.0.2.24

AP Manager Interface IP Address: 192.0.2.25
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.0.2.24): 192.0.2.24

Virtual Gateway IP Address: 1.1.1.1

Mobility/RF Group Name: anyname-mg

Network Name (SSID): wlan-15

Allow Static IP Addresses [YES][no]: no

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter Country Code (enter 'help' for a list of countries) [US]: US

Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes

Enable Auto-RF [YES][no]: 

Configure an NTP server now? [YES][no]: yes 
Enter the NTP server's IP address: 192.0.2.24 
Enter a polling interval between 3600 and 604800 secs: 3600 

Configuration correct? If yes, system will save it and reset. [yes][no]: yes

Configuration saved!
Resetting system with new configuration...

User:

Configure a NTP server now? [YES][no]: yes 

Enter the NTP server's IP address: 192.0.2.254 

Enter a polling interval between 3600 and 604800 secs: 7200

User: anyname
Password: *****
(WLCM)

What to Do Next

Proceed to the "Configuring and Verifying Management and AP Manager Interfaces" section.

Configuring and Verifying Management and AP Manager Interfaces

You can create any number of static or dynamic logical interfaces on the Cisco WLCM, configured as VLAN tagged interfaces or untagged interfaces. By default, two static untagged interfaces are assigned (management interface and ap-manager interface) and used for management and communication with APs. Because these interfaces are untagged, they must be assigned to the same subnet that is used to configure the WLCM interface on the router.

SUMMARY STEPS

1. configure interface address management ip-address ip-netmask gateway

2. configure interface address ap-manager ip-address ip-netmask gateway

3. ping ip-address

4. ping ip-address

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure interface address management ip-address ip-netmask gateway

Example:

WLCM> configure interface address management 192.0.2.24 255.255.255.0 192.0.2.254

Assignes an IP address that can be reached from the workstation that is managing the address management interface.

Step 2 

configure interface address ap-manager ip-address ip-netmask gateway

Example:

WLCM> configure interface address ap-manager 192.0.2.25 255.255.255.0 192.0.2.254

Assignes an IP address that can be reached from the workstation that is managing the AP-manager interface.

Step 3 

ping ip-address

Example:

Router:# ping 192.0.2.24

Sends a ping from the router to the WLCM management interface and AP manager interface.

Step 4 

ping ip-address

Example:

Router:# ping 192.0.2.25

Sends a ping from the router to the WLCM management interface and AP manager interface.

Configuration Examples for Verifying Management and AP Manager Interfaces

The management interface must have an IP address that can be reached from the workstation that is managing the interface. The AP manager interface allows the WLCM to communicate with APs.

WLCM> configure interface address management 192.0.2.24 255.255.255.0 192.0.2.254
WLCM> configure interface address ap-manager 192.0.2.25 255.255.255.0 192.0.2.254

The last IP address (192.0.2.254) is the default-gateway IP address for those interfaces and the IP address of the WLCM interface on the router.

Send a ping from the router to the WLCM management interface and AP manager interface.

Router:# ping 192.0.2.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.0.2.24, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Router:# ping 192.0.2.25
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.0.2.25, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router#

For information about configuring VLANs on the Cisco WLCM, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html

What to Do Next

Proceed to the "Configuring Wide-Area LANs on the Cisco WLCM" section.

Configuring Wide-Area LANs on the Cisco WLCM

The Cisco WLCM can control up to 16 wireless LANs for access points. Each wireless LAN has a separate wireless LAN ID (1 through 16) and a separate wireless LAN SSID (wireless LAN name). Each wireless LAN can be assigned unique security policies.


Note The Cisco AIR-AP1000 series support 16 SSIDs; however, the Cisco AIR-AP1130 series and the Cisco AIR-AP1240 series can support only 8 SSIDs.



Note We recommend that you assign one set of VLANs for wireless LANs and a different set of VLANs for management interfaces to ensure that controllers properly route VLAN traffic. Configure VLANs on the integrated-service-engine interface using IEEE 802.1Q trunking encapsulation. The number of VLANs that are configured on the router integrated-service-engine interface should be equal to the number of VLAN tags used on the Cisco WLCM.

Native VLAN is not supported on the Cisco WLCM; therefore, the router should not have any functional native VLANs configured.

For additional information about configuring VLANs on the Cisco WLCM, see the Cisco Wireless LAN Solution Product Guide at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_installation_and_configuration_guides_list.html


To configure and activate WLANs, to assign the WLANs to a DHCP server, and to assign the WLANs a VLAN, follow the steps below.

Configuring the Interface

The interface must have an IP address and descriptors configured to the interface. To assign the IP address and descriptors to the interface, follow the steps below.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type slot/port

4. description string

5. ip address ip-address mask

6. load-interval seconds

7. duplex speed

8. speed speed

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router# enable

Enters privileged EXEC mode.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type slot/port

Example:

Router(config)# interface gigabitethernet 0/0

Configures an interface type, and enters interface configuration mode.

Step 4 

description string

Example:

Router(config-if)# description: connected to AP

Specifies a description of the digital signal processor (DSP) interface.

Step 5 

ip address ip-address mask

Example:

Router(config-if)# ip address 100.100.100.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 6 

load-interval seconds

Example:

Router(config-if)# load-interval 30

Specifies the length of time to be used for calculating the average load for an interface.

Step 7 

duplex speed

Example:

Router(config-if)# duplex auto

Detects the transmission type of the device.

Step 8 

speed speed

Example:

Router(config-if)# speed auto

Detects the speed settings of the device.

Assigning the WLANs to a DHCP server

The following shows how to configure a DHCP server to the router, and an IP address to the AP.

SUMMARY STEPS

1. ip dhcp excluded-address low-address high-address

2. ip dhcp pool name

3. network (dhcp) network-number mask

4. default-router address

5. option code ascii string hex string ip address

6. interface integrated-service-engine slot/port

7. ip address ip-address mask

8. interface integrated-service-engine slot/port

9. encapsulation dot1q vlan-id

10. ip address ip-address mask

11. interface integrated-service-engine slot/port

12. encapsulation dot1q vlan-id

13. ip address ip-address mask

14. ip dhcp pool name

15. network (dhcp) network-number mask

16. default-router address

17. ip dhcp pool name

18. network (dhcp) network-number mask

19. default-router address

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ip dhcp excluded-address low-address high-address

Example:

Router(config-if)# ip dhcp excluded-address 100.100.100.1 100.100.100.100

Specifies the IP addresses that a Dynamic Host Configuration Protocol (DHCP) server should not assign to DHCP clients.

Step 2 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool lwapp-ap

Configures a DHCP address pool on a DHCP server and enters DHCP pool configuration mode.

Step 3 

network (dhcp) network-number mask

Example:

Router(config-if)# network 100.100.100.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 4 

default-router address

Example:

Router(config-if)# default-router 100.100.100.1

Specifies the default router list for a DHCP client.

Step 5 

option code ascii string hex string ip address

Example:

Router(config-if)# option 43 ascii 192.0.2.24

Configures DHCP server options for the Cisco WLAN 1000 series AP.

Note To use the option command to configure DHCP server options on the Cisco WLAN 1100 series and Cisco 1200 series APs, use the option command and specifying the hex string. For complete information about configuring DHCP on Cisco WLCM products, see the Cisco 440X Series Wireless LAN Controllers Deployment Guide at the following URL:
http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html

Step 6 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 7 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.0.2.254 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 8 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.15

Enters interface configuration mode, and specifies an interface for configuration.

Step 9 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 15

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a virtual LAN (VLAN).

Step 10 

ip address ip-address mask

Example:

Router(config-if)# ip address 15.0.0.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 11 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.16

Enters interface configuration mode, and specifies an interface for configuration.

Step 12 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 16

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 13 

ip address ip-address mask

Example:

Router(config-if)# ip address 16.0.0.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 14 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool client-15

Configures a DHCP address pool on a DHCP server and enters DHCP pool configuration mode.

Step 15 

network (dhcp) network-number mask

Example:

Router(config)# network 15.0.0.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 16 

default-router address

Example:

Router(config)# default-router 15.0.0.1

Specifies the default router list for a DHCP client.

Step 17 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool lwapp-ap

Configures a DHCP address pool on a DHCP server and enters DHCP pool configuration mode.

Step 18 

network (dhcp) network-number mask

Example:

Router(config-if)# network 100.100.100.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 19 

default-router address

Example:

Router(config)# default-router 16.0.0.1

Specifies the default router list for a DHCP client.

Assigning the WLANs to a VLAN

The following shows how to configure a the WLAN to a VLAN.

SUMMARY STEPS

1. configure interface create interface_name profile-name vlan-id

2. configure interface address dynamic-interface ap-manager ip_address netmask gateway

3. configure interface dhcp management primary primary-server secondary secondary-server

4. configure interface address management ip-address netmask gateway

5. configure interface ap-manager ip-address netmask gateway

6. configure interface address dynamic-interface dynamic-interface-name ip-address netmask gateway

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure interface create interface_name profile-name vlan-id

Example:

WLCM> configure interface create profile-name Controller15 15

WLCM> configure interface create profile-name Controller16 16

Adds a new dynamic interface on the Cisco WLCM.

Step 2 

configure interface address dynamic-interface ap-manager ip_address netmask gateway

Example:

WLCM> configure interface address Controller15 15.0.0.254 255.255.255.0 15.0.0.1

WLCM> configure interface address Controller16 16.0.0.254 255.255.255.0 16.0.0.1

Configures the address information of an interface on the Cisco WLCM.

Step 3 

configure interface dhcp management primaary primary-server secondary secondary-server

Example:

WLCM> configure interface dhcp management primary 15.0.0.1

WLCM> configure interface dhcp management primary 16.0.0.1

Configures DHCP options on an interface on the Cisco WLCM.

Step 4 

configure interface address management ip-address netmask gateway

Example:

WLCM> configure interface address management 15.0.0.1 255.255.255.0

Configures the address management interface on the Cisco WLCM.

Step 5 

configure interface ap-manager ip-address netmask gateway

Example:

WLCM> configure interface ap-manager 15.0.0.1 255.255.255.0

Configures the AP manager interface on the Cisco WLCM.

Step 6 

configure interface address dynamic-interface dynamic-interface-name ip-address netmask gateway

Example:

WLCM> configure interface address dynamic-interface Controller 15.0.0.1 255.255.255.0

Configures the dynamic interface address on the Cisco WLCM.

Configuration Examples for Creating VLANs

The Cisco WLCM that is installed in the router can be logically considered to be equivalent to an external wireless LAN controller that is connected to the router through an Ethernet interface, as shown in Figure 3.

Figure 3 Creating VLANs for the Cisco WLCM

The following example assumes the network module is plugged into slot 1 of the router. The following are additional assumptions for the example:

The WLCM is connected to the router through the interface integrated-service-engine command 1/0 interface.

A Layer 2 switch is connected to router onboard Gigabit Ethernet interface g0/0. This switch can be an external standalone switch or one of the Cisco integrated EtherSwitch HWIC/NM/NME switches.

An LWAPP AP is connected to the Layer 2 switch.

Wireless client 1 and wireless client 2 are associated with the AP: one in WLAN 15 and the other in WLAN 16.

Configure a DHCP server on the router to assign an IP address to the AP. Use the dhcp option 43 command to inform the AP contact information of the controller IP address. The following example shows how to configure a DHCP server to the router, and an IP address to the AP:

Router(config-if)# interface GigabitEthernet0/0								
Description: Connected to AP							
Router(config-if)# ip address 100.100.100.1 255.255.255.0						
load-interval 30									
duplex auto									
speed auto
									
!										
Router(config-if)# ip dhcp excluded-address 100.100.100.1 100.100.100.100
!
Router(config-if)# ip dhcp pool lwapp-ap
Router(config-if)# network 100.100.100.0 255.255.255.0
Router(config-if)# default-router 100.100.100.1 
Router(config-if)# option 43 ascii "192.0.2.24"

The following example shows how WLAN 15 and WLAN 16 are created on the controller and mapped to the corresponding wired side VLAN 15 and VLAN 16. It also shows how routing between VLAN 15 and VLAN 16 is done by the router through dot1Q subinterfaces.

On the router, create one subinterface under integrated-service-engine interface (in interface configuration mode) for every VLAN, assign it to the corresponding VLAN, and configure an IP address from the respective subnets.

Router(config-if)# interface integrated-service-engine 1/0								
Router(config-if)# ip address 192.0.2.254 255.255.255.0							
!										
Router(config-if)# interface integrated-service-engine 1/0.15								
Router(config-if)# encapsulation Dot1q 15								
Router(config-if)# ip address 15.0.0.1 255.255.255.0							
!										
Router(config-if)# interface integrated-service-engine 1/0.16							
Router(config-if)# encapsulation Dot1q 16								
Router(config-if)# ip address 16.0.0.1 255.255.255.0

On the router, create two DHCP pools from subnet 15.0.0.0/24 and 16.0.0.0/24, and assign IP address information to the wireless clients in WLAN 15 and WLAN 16.


Note DHCP services for clients can also run on the controller, but we recommend running DHCP services on the router because the controller is not a full-fledged DHCP server and will not pass on such options as TFTP server required for applications such as Cisco Call Manager Express.


Router(config)# ip dhcp pool client-15
Router(config)# network 15.0.0.0 255.255.255.0
Router(config)# default-router 15.0.0.1 

Router(config)# ip dhcp pool client-16
Router(config)# network 16.0.0.0 255.255.255.0
Router(config)# default-router 16.0.0.1

For every VLAN on the controller, create one dynamic interface to the corresponding VLAN and assign an IP address, a subnet mask, and default gateways from the subnets.

Controller> configure
Controller configure> interface create controller15 15
Controller configure> interface create controller16 16

Controller configure> interface address dynamic-interface Controller15 15.0.0.254 
255.255.255.0 
15.0.0.1
Controller configure> interface address dynamic-interface Controller16 16.0.0.254 
255.255.255.0 16.0.0.1

Create WLAN 15 and WLAN 16 with SSID WLAN-15 and WLAN-16.

Controller configure> wlan create 15 anyname wlan-15
Controller configure> wlan create 16 anyname wlan-16

Map these WLANs to corresponding dynamic VLAN interfaces on the controller.

Controller configure> wlan interface 15 Controller15
Controller configure> wlan interface 16 Controller16

Configure DHCP server information on the controller interfaces (for wireless clients) that point to the subinterface IP addresses on the router.

Controller configure> interface dhcp dynamic-interface primary 15.0.0.1

The traffic from WLAN 15 client that is destined to the WLAN 16 client will be routed between the subinterfaces that have been created in the preceding steps.


Note The controller supports a maximum number of 16 VLANs.


What to Do Next

Proceed to the "Configuring VLANs with APs Connected to an External Switch" section.

Configuring VLANs with APs Connected to an External Switch

The WLCM in the router is considered equivalent to an external wireless LAN controller connected to the router through an Ethernet interface.

Restrictions

The WLCM is installed in slot 1 of the router.

A Layer 2 switch is connected to the router onboard Fast Ethernet interface f0/0.

An LWAPP AP is connected to the switch.

Wireless clients C1 and C2 are associated with the AP. Either wireless client can be associated with either WLAN 15 or WLAN 16.

Configuring the Switch Port

Configure a Fast Ethernet interface from the Catalyst 3750 switch to the LWAPP AP and configure a Gigabit Ethernet trunking interface from the Catalyst 3750 switch to the router. To assign these interfaces on the Catalyst 3750 switch, follow the steps below.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface-id

4. switchport access vlan vlan-id

5. switchport mode access

6. interface interface-id

7. switchport trunk encapsulation dot1q

8. switchport mode trunk

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Switch# enable

Enters privileged EXEC mode.

Step 2 

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode.

Step 3 

interface interface-id

Example:

Switch(config)# interface fastethernet 1/0/1

Configures an interface type, and enters interface configuration mode.

Step 4 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 100

Attaches the LWAPP AP into the Fast Ethernet interface in VLAN 100.

Step 5 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

Step 6 

interface interface-id

Example:

Switch(config-if)# interface gigabitethernet 1/0/1

Configures an interface type, and enters interface configuration mode.

Step 7 

switchport trunk encapsulation dot1q

Example:

Switch(config-if)# switchport trunk encapsulation dot1q

Causes a port that is configured as a switched interface to encapsulate in IEEE 802.1Q trunking format regardless of its default trunking format in trunking mode.

Step 8 

switchport mode trunk

Example:

Switch(config-if)# switchport mode trunk

Enables trunking to a device that does not support DTP.

Assigning the WLANs on the Router to a DHCP Server

To configure WLANs on the router when connected to a switch, and a DHCP server on the router with several with several pools defined, perform the steps which follow.


Note DHCP services for the clients can also be run on the WLCM, however, we recommend running DHCP services on the router because the WLCM is not a full-fledged DHCP server and can not pass on TFTP server options required for applications like Cisco Call Manager Express.


SUMMARY STEPS

1. ip dhcp excluded-address low-address high-address

2. ip dhcp pool name

3. network (dhcp) network-number mask

4. default-router address

5. option code ascii string hex string ip address

6. ip dhcp pool name

7. network (dhcp) network-number mask

8. default-router address

9. ip dhcp pool name

10. network (dhcp) network-number mask

11. default-router address

12. interface type slot/port

13. no ip address ip-address mask

14. load-interval seconds

15. duplex speed

16. speed speed

17. interface type slot/port

18. encapsulation dot1q vlan-id

19. ip address ip-address mask

20. interface integrated-service-engine slot/port

21. ip address ip-address mask

22. interface integrated-service-engine slot/port

23. encapsulation dot1q vlan-id

24. ip address ip-address mask

25. interface integrated-service-engine slot/port

26. encapsulation dot1q vlan-id

27. ip address ip-address mask

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ip dhcp excluded-address low-address high-address

Example:

Router(config-if)# ip dhcp excluded-address 192.168.100.1 192.168.100.100

Specifies the IP addresses that a Dynamic Host Configuration Protocol (DHCP) server should not assign to DHCP clients.

Step 2 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool lwapp-ap

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 3 

network (dhcp) network-number mask

Example:

Router(config-if)# network 192.168.100.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 4 

default-router address

Example:

Router(config-if)# default-router 192.168.100.1

Specifies the default router list for a DHCP client.

Step 5 

option code ascii string hex string ip address

Example:

Router(config-if)# option 43 ascii 192.168.99.24

Configures DHCP server options for the Cisco WLAN 1000 series AP.

Note To use the option command to configure DHCP server options on the Cisco WLAN 1100 series and Cisco 1200 series APs, use the option command and specify the hex string. For complete information about configuring DHCP on Cisco WLCM products, see the Cisco 440X Series Wireless LAN Controllers Deployment Guide at the following URL:
http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html

Step 6 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool client-15

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 7 

network (dhcp) network-number mask

Example:

Router(config)# network 192.168.15.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 8 

default-router address

Example:

Router(config)# default-router 192.168.15.1

Specifies the default router list for a DHCP client.

Step 9 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool client-16

Configures a DHCP address pool on a DHCP server and enters DHCP pool configuration mode.

Step 10 

network (dhcp) network-number mask

Example:

Router(config)# network 192.168.16.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 11 

default-router address

Example:

Router(config)# default-router 192.168.16.1

Specifies the default router list for a DHCP client.

Step 12 

interface type slot/port

Example:

Router(config-if)# interface gigabitethernet 0/0

Configures an interface type, and enters interface configuration mode.

Step 13 

no ip address ip-address mask

Example:

Router(config-if)# ip address 100.100.100.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 14 

load-interval seconds

Example:

Router(config-if)# load-interval 30

Specifies the length of time to be used for calculating the average load for an interface.

Step 15 

duplex speed

Example:

Router(config-if)# duplex auto

Detects the transmission type of the device.

Step 16 

speed speed

Example:

Router(config-if)# speed auto

Detects the speed settings of the device.

Step 17 

interface type slot/port

Example:

Router(config-if)# interface gigabitethernet 0/0.100

Enters interface configuration mode, and specifies an interface for configuration.

Step 18 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 100

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 19 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.100.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 20 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 21 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.99.254 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 22 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.15

Enters interface configuration mode, and specifies an interface for configuration.

Step 23 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 15

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 24 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.15.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 25 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.16

Enters interface configuration mode, and specifies an interface for configuration.

Step 26 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 16

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 27 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.16.1 255.255.255.0

Sets a primary or secondary IP address for an interface.

Creating Dynamic Interfaces on the WLCM

For every VLAN that has been created on the router, create one dynamic interface and corresponding VLAN on the WLCM.

SUMMARY STEPS

1. configure interface create interface_name vlan-id

2. configure interface address ap-manager ip_address netmask gateway

3. configure wlan create wlan_id wlan_name

4. configure wlan interface wlan_id interface-name

5. configure interface dhcp ap-manager server1 server2

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure interface create interface_name vlan-id

Example:

(WLCM)# configure interface create v|15 15

(WLCM)# configure interface create v|16 16

Adds a new dynamic interface on the Cisco WLCM.

Step 2 

configure interface address ap-manager ip_address netmask gateway

Example:

(WLCM)# configure interface address v|15 192.168.15.254 255.255.255.0 192.168.15.1

(WLCM)# configure interface address v|16 192.168.16.254 255.255.255.0 192.168.16.1

Configures the address information of an interface on the Cisco WLCM.

Step 3 

configure wlan create wlan_id wlan_name

Example:

(WLCM)# configure wlan create 15 w|15

(WLCM)# configure wlan create 16 w|16

Creates a WLAN on the Cisco WLCM.

Step 4 

configure wlan interface wlan_id interface-name

Example:

(WLCM)# configure wlan interface 15 v|15

(WLCM)# configure wlan interface 16 v|16

Associates a WLAN with an existing interface on the Cisco WLCM.

Step 5 

configure interface dhcp ap-manager server1 server2

Example:

(WLCM)# configure interface dhcp v|15 192.168.15.1

(WLCM)# configure interface dhcp v|16 192.168.16.1

Configures the DHCP options on the WLCM interface.

What to Do Next

Proceed to the "Configuring APs Connected to an EtherSwitch Module on the Router" section.

Configuring APs Connected to an EtherSwitch Module on the Router

The following configuration provides APs that are connected to an EtherSwitch module on the router and merges VLANs from wired and wireless LANs.

The Cisco EtherSwitch module is inserted into slot 0 of the integrated services router (ISR), and a WLCM is inserted into network module slot 1 of the ISR.

SUMMARY STEPS

1. ip dhcp excluded-address low-address high-address

2. ip dhcp pool name

3. network network-number mask

4. default-router address

5. option code ascii string hex string ip address

6. ip dhcp pool name

7. network network-number mask

8. default-router address

9. ip dhcp pool name

10. network network-number mask

11. default-router address

12. interface interface-id

13. switchport mode access

14. switchport access vlan vlan-id

15. interface interface-id

16. switchport mode access

17. switchport access vlan vlan-id

18. interface interface-id

19. switchport mode access

20. switchport access vlan vlan-id

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ip dhcp excluded-address low-address high-address

Example:

Router(config-if)# ip dhcp excluded-address 192.168.100.1 192.168.100.100

Router(config-if)# ip dhcp excluded-address 192.168.15.1 192.168.15.100

Router(config-if)# ip dhcp excluded-address 192.168.16.1 192.168.16.100

Specifies the IP addresses that a Dynamic Host Configuration Protocol (DHCP) server should not assign to DHCP clients.

Step 2 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool lwapp-ap

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 3 

network network-number mask

Example:

Router(config-if)# network 192.168.100.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 4 

default-router address

Example:

Router(config-if)# default-router 192.168.100.1

Specifies the default router list for a DHCP client.

Step 5 

option code ascii string hex string ip address

Example:

Router(config-if)# option 43 ascii 192.168.99.24

Configures DHCP server options for the Cisco WLAN 1000 series AP.

Note To use the option command to configure DHCP server options on the Cisco WLAN 1100 series and Cisco 1200 series APs, use the option command and specify the hex string. For complete information about configuring DHCP on Cisco WLCM products, see the Cisco 440X Series Wireless LAN Controllers Deployment Guide at the following URL: http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html

Step 6 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool vlan-15

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 7 

network network-number mask

Example:

Router(config)# network 192.168.15.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 8 

default-router address

Example:

Router(config)# default-router 192.168.15.1

Specifies the default router list for a DHCP client.

Step 9 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool vlan-16

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 10 

network network-number mask

Example:

Router(config)# network 192.168.16.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 11 

default-router address

Example:

Router(config)# default-router 192.168.16.1

Specifies the default router list for a DHCP client.

Step 12 

interface interface-id

Example:

Switch(config-if)# interface fastethernet 0/0/0

Configures an interface type, and enters interface configuration mode.

Step 13 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

Step 14 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 100

Attaches the Lightweight Access Point Protocol (LWAPP) AP to the Fast Ethernet interface in VLAN 100.

Step 15 

interface interface-id

Example:

Switch(config-if)# interface fastethernet 0/0/1

Configures an interface type, and enters interface configuration mode.

Step 16 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

Step 17 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 15

Attaches the LWAPP AP to the Fast Ethernet interface in VLAN 15.

Step 18 

interface interface-id

Example:

Switch(config-if)# interface fastethernet 0/0/2

Configures an interface type, and enters interface configuration mode.

Step 19 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

Step 20 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 16

Attaches the LWAPP AP to the Fast Ethernet interface in VLAN 16.

Configuring Integrated Routing and Bridging

For clients in two different bridge groups, you must enable integrated routing and bridging (IRB) on the router so that the clients can communicate with each other through the Bridge-Group Virtual Interface (BVI) in their respective bridge groups.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type slot/port

4. bridge-group bridge-group

5. interface type slot/port

6. bridge-group bridge-group

7. interface type slot/port

8. ip address ip-address mask

9. load-interval seconds

10. interface integrated-service-engine slot/port

11. ip address ip-address mask

12. interface integrated-service-engine slot/port

13. encapsulation dot1q vlan-id

14. bridge-group bridge-group

15. interface integrated-service-engine slot/port

16. encapsulation dot1q vlan-id

17. bridge-group bridge-group

18. bridge irb

19. bridge bridge-group route protocol

20. bridge bridge-group route protocol

21. interface bvi bridge-group

22. ip address ip-address mask

23. interface bvi bridge-group

24. ip address ip-address mask

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Switch# enable

Enters privileged EXEC mode.

Step 2 

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode.

Step 3 

interface type slot/port

Example:

Router(config)# interface gigabitethernet 0/0

Configures an interface type, and enters interface configuration mode.

Step 4 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 15

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 5 

interface type slot/port

Example:

Router(config-if)# interface vlan 16

Configures an interface type, and enters interface configuration mode.

Step 6 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 16

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 7 

interface type slot/port

Example:

Router(config-if)# interface vlan 100

Configures an interface type, and enters interface configuration mode.

Step 8 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.100.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 9 

load-interval seconds

Example:

Router(config-if)# load-interval 30

Specifies the length of time to be used for calculating the average load for an interface.

Step 10 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 11 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.99.254 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 12 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.15

Enters interface configuration mode, and specifies an interface for configuration.

Step 13 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 15

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 14 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 15

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 15 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.16

Enters interface configuration mode, and specifies an interface for configuration.

Step 16 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 16

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 17 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 16

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 18 

bridge irb

Example:

Router(config-if)# bridge irb

Enables Cisco IOS software to route a given protocol between routed interfaces and bridge groups or to route a given protocol between bridge groups.

Step 19 

bridge bridge-group route protocol

Example:

Router(config-if)# bridge 15 route ip

Enables the routing of a specified protocol in a specified bridge group.

Step 20 

bridge bridge-group route protocol

Example:

Router(config-if)# bridge 16 route ip

Enables the routing of a specified protocol in a specified bridge group.

Step 21 

interface bvi bridge-group

Example:

Router(config-if)# interface bvi 15

Creates the bridge-group virtual interface (BVI) that represents the specified bridge group to the routed world and links the corresponding bridge group to the other routed interfaces.

Step 22 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.15.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 23 

interface bvi bridge-group

Example:

Router(config-if)# interface bvi 16

Creates the bridge-group virtual interface (BVI) that represents the specified bridge group to the routed world and links the corresponding bridge group to the other routed interfaces.

Step 24 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.16.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

What to Do Next

Proceed to the "Configuring Wired VLANs on the EtherSwitch Module with Wireless VLANs on the WLCM" section.

Configuring Wired VLANs on the EtherSwitch Module with Wireless VLANs on the WLCM

The Cisco EtherSwitch module is inserted into slot 2 of the integrated services router (ISR) and a WLCM is inserted into network module slot 1 of the ISR. The Cisco EtherSwitch module is considered equivalent to an external switch connected to the ISR through a Gigabit Ethernet link.

Configuring the Router

The ISR is configured as a DHCP server with several pools to serve IP addresses to the AP and AP clients.

SUMMARY STEPS

1. ip dhcp excluded-address low-address high-address

2. ip dhcp pool name

3. network network-number mask

4. default-router address

5. option code ascii string hex string ip address

6. ip dhcp pool name

7. network network-number mask

8. default-router address

9. ip dhcp pool name

10. network network-number mask

11. default-router address

12. interface interface-id

13. ip address ip-address mask

14. load-interval seconds

15. interface type slot/port

16. encapsulation dot1q vlan-id

17. ip address ip-address mask

18. interface type slot/port

19. encapsulation dot1q vlan-id

20. bridge-group bridge-group

21. interface type slot/port

22. encapsulation dot1q vlan-id

23. bridge-group bridge-group

24. interface integrated-service-engine slot/port

25. ip address ip-address mask

26. interface integrated-service-engine slot/port

27. encapsulation dot1q vlan-id

28. bridge-group bridge-group

29. interface integrated-service-engine slot/port

30. encapsulation dot1q vlan-id

31. bridge-group bridge-group

32. bridge irb

33. bridge bridge-group route protocol

34. bridge bridge-group route protocol

35. interface bvi bridge-group

36. ip address ip-address mask

37. interface bvi bridge-group

38. ip address ip-address mask

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ip dhcp excluded-address low-address high-address

Example:

Router(config-if)# ip dhcp excluded-address 192.168.100.1 192.168.100.100

Router(config-if)# ip dhcp excluded-address 192.168.15.1 192.168.15.100

Router(config-if)# ip dhcp excluded-address 192.168.16.1 192.168.16.100

Specifies the IP addresses that a Dynamic Host Configuration Protocol (DHCP) server should not assign to DHCP clients.

Step 2 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool lwapp-ap

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 3 

network network-number mask

Example:

Router(config-if)# network 192.168.100.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 4 

default-router address

Example:

Router(config-if)# default-router 192.168.100.1

Specifies the default router list for a DHCP client.

Step 5 

option code ascii string hex string ip address

Example:

Router(config-if)# option 43 ascii 192.168.99.24

Configures DHCP server options for the Cisco WLAN 1000 series AP.

Note To use the option command to configure DHCP server options on the Cisco WLAN 1100 series and Cisco 1200 series APs, use the option command and specifying the hex string. For complete information about configuring DHCP on Cisco WLCM products, see the Cisco 440X Series Wireless LAN Controllers Deployment Guide at the following URL: http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html

Step 6 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool vlan-15

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 7 

network network-number mask

Example:

Router(config-if)# network 192.168.15.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 8 

default-router address

Example:

Router(config-if)# default-router 192.168.15.1

Specifies the default router list for a DHCP client.

Step 9 

ip dhcp pool name

Example:

Router(config-if)# ip dhcp pool vlan-16

Configures a DHCP address pool on a DHCP server, and enters DHCP pool configuration mode.

Step 10 

network network-number mask

Example:

Router(config-if)# network 192.168.16.0 255.255.255.0

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.

Step 11 

default-router address

Example:

Router(config-if)# default-router 192.168.16.1

Specifies the default router list for a DHCP client.

Step 12 

interface interface-id

Example:

Switch(config-if)# interface gigabitethernet 2/0

Configures an interface type, and enters interface configuration mode.

Step 13 

ip address ip-address mask

Example:

Router(config-if)# ip address 20.0.0.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 14 

load-interval seconds

Example:

Router(config-if)# load-interval 30

Specifies the length of time to be used for calculating the average load for an interface.

Step 15 

interface interface-id

Example:

Switch(config-if)# interface gigabitethernet 2/0.100

Configures an interface type, and enters interface configuration mode.

Step 16 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 100

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 17 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.100.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 18 

interface interface-id

Example:

Switch(config-if)# interface gigabitethernet 2/0.15

Configures an interface type, and enters interface configuration mode.

Step 19 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 15

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 20 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 15

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 21 

interface interface-id

Example:

Switch(config-if)# interface gigabitethernet 2/0.16

Configures an interface type, and enters interface configuration mode.

Step 22 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 16

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 23 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 16

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 24 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0

Enters interface configuration mode, and specifies an interface for configuration.

Step 25 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.99.254 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 26 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.15

Enters interface configuration mode, and specifies an interface for configuration.

Step 27 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 15

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 28 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 15

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 29 

interface integrated-service-engine slot/port

Example:

Router(config-if)# interface integrated-service-engine 1/0.16

Enters interface configuration mode, and specifies an interface for configuration.

Step 30 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 16

Enables IEEE 802.1q encapsulation of traffic on a specified subinterface in a VLAN.

Step 31 

bridge-group bridge-group

Example:

Router(config-if)# bridge-group 16

Assigns an interface to a bridge group. The bridge group must be an integer between 1 and 63.

Step 32 

bridge irb

Example:

Router(config-if)# bridge irb

Enables Cisco IOS software to route a given protocol between routed interfaces and bridge groups or to route a given protocol between bridge groups.

Step 33 

bridge bridge-group route protocol

Example:

Router(config-if)# bridge 15 route ip

Enables the routing of a specified protocol in a specified bridge group.

Step 34 

bridge bridge-group route protocol

Example:

Router(config-if)# bridge 16 route ip

Enables the routing of a specified protocol in a specified bridge group.

Step 35 

interface bvi bridge-group

Example:

Router(config-if)# interface bvi 15

Creates the bridge-group virtual interface (BVI) that represents the specified bridge group to the routed world and links the corresponding bridge group to the other routed interfaces.

Step 36 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.15.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Step 37 

interface bvi bridge-group

Example:

Router(config-if)# interface bvi 16

Creates the BVI that represents the specified bridge group to the routed world and links the corresponding bridge group to the other routed interfaces.

Step 38 

ip address ip-address mask

Example:

Router(config-if)# ip address 192.168.16.1 255.255.255.0

Does not set a primary or secondary IP address for an interface.

Configuring the EtherSwitch Network Module

Open a session from the ISR to the EtherSwitch network module using the service-module session command. When a session from the ISR to the EtherSwitch network module is open, perform the following steps.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface-id

4. switchport trunk encapsulation dot1q

5. switchport mode trunk

6. interface interface-id

7. switchport access vlan vlan-id

8. switchport mode access

9. switchport access vlan vlan-id

10. switchport mode access

11. switchport access vlan vlan-id

12. switchport mode access

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Switch# enable

Enters privileged EXEC mode.

Step 2 

configure terminal

Example:

Switch# configure terminal

Enters global configuration mode.

Step 3 

interface interface-id

Example:

Switch(config-if)# interface gigabitethernet 1/0/2

Configures an interface type, and enters interface configuration mode.

Step 4 

switchport trunk encapsulation dot1q

Example:

Switch(config-if)# switchport trunk encapsulation dot1q

Causes a port configured as a switched interface to encapsulate in IEEE 802.1Q trunking format regardless of its default trunking format in trunking mode.

Step 5 

switchport mode trunk

Example:

Switch(config-if)# switchport mode trunk

Enables trunking to a device that does not support Dynamic Trunking Protocol (DTP).

Step 6 

interface interface-id

Example:

Switch(config-if)# interface fastethernet 1/0/1

Configures an interface type, and enters interface configuration mode.

Step 7 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 15

Attaches the Lightweight Access Point Protocol (LWAPP) AP to the Fast Ethernet interface in VLAN 100.

Step 8 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

Step 9 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 16

Attaches the LWAPP AP to the Fast Ethernet interface in VLAN 100.

Step 10 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

Step 11 

switchport access vlan vlan-id

Example:

Switch(config-if)# switchport access vlan 100

Attaches the LWAPP AP to the Fast Ethernet interface in VLAN 100.

Step 12 

switchport mode access

Example:

Switch(config-if)# switchport mode access

Configures the links to disallow trunking.

What to Do Next

Proceed to the "Upgrading the Cisco WLCM Software" section.

Upgrading the Cisco WLCM Software

To upgrade the controller software, use the CLI to complete these steps.

Restrictions

Make sure that you have a TFTP server available for the operating system software download.

You must first download the desired operating system software update file from the Cisco.com website to the default directory on your TFTP server.

SUMMARY STEPS

1. ping server-ip-address

2. transfer download start

3. transfer download mode tftp

4. transfer download datatype code

5. transfer download serverip tftp-server-ip-address

6. transfer download filename filename

7. transfer download path relative-tftp-server-path-to-file

8. transfer download start

9. reset system


Note The argument slot indicates the number of the router chassis slot for the module. The argument port indicates the number of the daughter card on the module. For a Cisco WLCM, always use 0. For more information about interfaces, see the "Understanding Interfaces on the Cisco WLCM" section.

For information about module slot locations and numbering on Cisco routers, see the Cisco Network Modules Hardware Installation Guide at the following URL:

http://www.cisco.com/en/US/products/hw/modules/ps2797/prod_installation_guides_list.html


After the WLCM software has been successfully upgraded, enter the reset system command to reboot the Cisco WLCM and run the new code.

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ping server-ip-address

Example:

WLCM> ping 192.0.2.24

Verifies that the controller can contact the TFTP server.

Step 2 

transfer download start

Example:

WLCM> transfer download start

Begins the file transfer process.

Note Answer n to the prompt to view the current download settings.

Step 3 

transfer download mode tftp

Example:

WLCM> transfer download mode tftp

Sets the mode to TFTP.

Step 4 

transfer download datatype code

Example:

WLCM> transfer download datatype code

Sets the data type code.

Step 5 

transfer download serverip tftp-server-ip-address

Example:

WLCM> transfer download serverip 192.168.88.5

Sets the IP address of the TFTP server.

Step 6 

transfer download filename filename

Example:

WLCM> transfer download filename anyname

Sets the filename to download.

Step 7 

transfer download path relative-tftp-server-path-to-file

Example:

WLCM> transfer download path C:/

Sets the relative TFTP path.

Note All TFTP servers require the full pathname. For example, in Windows, the path is C:\TFTP-Root. (In UNIX, forward slashes (/) are required.)

Step 8 

transfer download start

Example:

WLCM> transfer download start

Allows you to view the updated settings.

Note Answer y to the prompt to confirm the current download settings and to start the operating system code download.

Step 9 

reset system

Example:

WLCM> reset system

Saves the code update to NVRAM and reboots the Cisco WLCM.

Configuration Examples for Using the reset system Command

Sample Output for the reset system Command

This example shows what appears when you enter the reset system command:

WLCM> reset system
The system has unsaved changes. 
Would you like to save them now? (y/n) y

What to Do Next

Proceed to the "Saving Configurations" section.

Saving Configurations

Controllers contain two kinds of memory: volatile RAM and nonvolatile RAM (NVRAM). At any time, you can save the configuration changes from active volatile RAM to NVRAM.

SUMMARY STEPS

1. clear configuration

2. reset system

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

clear configuration

Example:

WLCM> clear configuration

Resets the configuration data to the factory defaults.

Step 2 

reset system

Example:

WLCM> reset system

Prompts you to confirm that you want to save the configuration changes before the controller reboots.

Note Because you are resetting the configuration data to the factory defaults, do not save the configuration when prompted.

What to Do Next

Proceed to the "Erasing and Resetting the WLCM Configuration" section.

Erasing and Resetting the WLCM Configuration

To reboot the Cisco WLCM and restore it to the factory defaults, perform the following steps.


Note For complete information about password recovery procedures, see the Password Recovery Procedure for the Wireless LAN Controller Module (WLCM) and Wireless Services Module (WiSM) document at the following URL:

http://www.cisco.com/en/US/products/ps6308/products_password_recovery09186a008071faa7.shtml


SUMMARY STEPS

1. reset system

2. recover configuration

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

reset system

Example:

WLCM> reset system

Prompts you to confirm that you want to save the configuration changes before the controller reboots.

Step 2 

recover configuration

Example:

WLCM> recover configuration

Prompts you to enter a username. After you enter the username, the factory default configuration is restored. The Cisco WLCM reboots, and the configuration wizard starts automatically.

Additional References

Related Documents

Related Topic
Document Title

Hardware installation instructions for the Cisco Wireless LAN controller module NM-AIR-WLC6 solution

Connecting Cisco Wireless LAN Controller Modules

Hardware installation instructions for modules

Cisco Network Modules Hardware Installation Guide

General information about voice configuration and command reference

Cisco IOS Voice Command Reference

Software configuration information for the Cisco WLCM

Cisco Wireless LAN Solution Product Guide

CLI command information for the Cisco WLCM

Cisco Wireless LAN Controller Command Reference


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Commands at a Glance

This section documents new and modified commands only.

New Commands

interface integrated-service-engine

service-module integrated-service-engine

show controllers integrated-service-engine

show interfaces integrated-service-engine

interface integrated-service-engine

To configure the Cisco wireless LAN controller network module (WLCM) interface with dot1q encapsulation on the router, use the interface integrated-service-engine command.

interface integrated-service-engine slot/unit

Syntax Description

slot/unit

Specifies the router slot and unit numbers for the WLCM.


Defaults

None

Command Modes

Global configuration

Command History

Release
Modification

12.4(15)T

This command was introduced.


Examples

The following example shows how to create dot1Q virtual LAN (VLAN) subinterfaces under the interface integrated-service-engine command:

Router(config)# interface integrated-service-engine 1/0
Router(config-if)# exit
Router(config)# interface integrated-service-engine 1/0.10
Router(config-subif)# encapsulation dot1q 10
 
If the interface doesn't support baby giant frames
maximum mtu of the interface has to be reduced by 4
bytes on both sides of the connection to properly
transmit or receive large packets. Please refer to
documentation on configuring IEEE 802.1Q vLANs.
 
Router(config-subif)# end

Related Commands

show interfaces integrated-service-engine

service-module integrated-service-engine

To configure the Cisco wireless LAN controller network module (WLCM) network module from the router, use the service-module integrated-service-engine command in global configuration mode.

service-module integrated-service-engine slot/port {default-boot | reload | reset | session | shutdown | statistics | status}

Syntax Description

slot/port

Specifies the router slot and port numbers.

default-boot

Sets or clears the default boot loader image for the next reboot.

reload

Reloads the WLCM.

reset

Resets the WLCM.

session

Opens a session to the WLCM.

shutdown

Shuts down the WLCM.

statistics

Shows statistics.

status

Displays information about the WLCM.


Defaults

None

Command Modes

Global configuration

Command History

Release
Modification

12.4(15)T

This command was introduced.


Usage Guidelines

If the Cisco WLCM has no prior configuration, the configuration wizard is automatically invoked. You cannot bypass the configuration wizard. Through the CLI, you must provide the information at the prompts provided.

Examples

The following example shows how to clear the existing session on the WLCM:

Router# service-module integrated-service-engine 1/0 
Router# Trying 192.0.2.254, 2066 ... Open

User:

show controllers integrated-service-engine

To show the Cisco wireless LAN controller network module (WLCM) on the router, use the show controllers integrated-service-engine command in privileged EXEC mode.

show controllers integrated-service-engine slot/unit

Syntax Description

slot/unit

Specifies the router slot and unit numbers for the WLCM.


Defaults

None

Command Modes

Privileged EXEC

Command History

Release
Modification

12.4(15)T

This command was introduced.


Examples

The following example shows how to display interface information for the WLCM:

Router# show controllers integrated-service-engines 1/0

Interface integrated-service-engine 1/0
Hardware is Intel 82559 FastEthernet
IDB: 67796B08, FASTSEND: 60E073CC, MCI_INDEX: 0
 
INSTANCE=0x67797BE8
  Rx Ring entries = 64
  Rx Shadow = 0x67797ED0
  Rx Ring = 0x2DCC1840
  Rx Ring Head = 5
  Rx Ring Last = 4
  Rx Buffer Descr = 0x2DCC3040
  Rx Buffer Descr Head = 5
  Rx Buffer Descr Last = 4
  
(cont...)

Receive All Multicasts = enabled
Receive Promiscuous = disabled
Loopback Mode = disabled
 
          
Module Reset Statistics:
  CLI reset count = 0
  CLI reload count = 0
  Registration request timeout reset count = 0
  Error recovery timeout reset count = 0
  Module registration count = 1

show interfaces integrated-service-engine

To show the Cisco wireless LAN controller network module (WLCM) interfaces on the router, use the show interfaces integrated-service-engine command in privileged EXEC mode.

show interfaces integrated-service-engine slot/unit {aaa | accounting | counters | crb | dampening | description | etherchannel | irb | mac-accounting | mpls-exp | precedence | pruning | rate-limit | stats | status | summary | switching | switchport | trunk}

Syntax Description

slot/unit

Specifies the router slot and unit numbers.

aaa

Shows the dot11 aaa information.

accounting

Shows the interface accounting information.

counters

Shows the interface counters.

crb

Shows the interface routing and bridging information.

dampening

Shows the interface dampening information.

description

Shows the interface description.

etherchannel

Shows the interface Ethernet channel information.

irb

Shows the interface routing and bridging information.

mac-accounting

Shows the interface MAC accounting information.

mpls-exp

Shows the interface MPLS experimental accounting information.

precedence

Shows the interface precedence accounting information.

pruning

Shows the interface trunk VTP pruning information.

rate-limit

Shows the interface rate-limit information.

stats

Shows the interface in and out packets and octets by switching path.

status

Shows the interface line status.

summary

Shows the interface summary.

switching

Shows the interface switching.

switchport

Shows the interface switchport information.

trunk

Shows the interface trunk information.


Defaults

None

Command Modes

Privileged EXEC

Command History

Release
Modification

12.4(15)T

This command was introduced.


Examples

The following example shows how to read the interface information about the WLCM in the router:

Router# show interfaces integrated-service-engine 1/0

integrated-service-engine 1/0 is up, line protocol is up 
  Hardware is I82559FE, address is 0005.9a3d.7450 (bia 0005.9a3d.7450)
  Internet address is 30.0.0.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:05, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     2400779 packets input, 143127299 bytes
     Received 2349587 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     468232 packets output, 106333102 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 1 no carrier
     0 output buffer failures, 0 output buffers swapped out

Related Commands

interface integrated-service-engine