Guest

Cisco IOS Software Releases 12.2 S

TCP MSS Adjustment

  • Viewing Options

  • PDF (201.4 KB)
  • Feedback
TCP MSS Adjustment

Table Of Contents

TCP MSS Adjustment

Contents

How to Configure the TCP MSS Adjustment

Setting the MTU on the Local Hosts

Verifying TCP MSS Adjustments

Configuration Examples for TCP MSS Adjustment

TCP MSS Adjustment Configuration: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

ip tcp adjust-mss


TCP MSS Adjustment


The TCP MSS Adjustment feature enables the configuration of the maximum segment size (MSS) for transient packets that traverse a router, specifically TCP segments in the SYN bit set, when Point to Point Protocol over Ethernet (PPPoE) is being used in the network. PPPoE truncates the Ethernet maximum transmission unit (MTU) 1492, and if the effective MTU on the hosts (PCs) is not changed, the router in between the host and the server can terminate the TCP sessions. The ip tcp adjust-mss command specifies the MSS value on the intermediate router of the SYN packets to avoid truncation.

History for the TCP MSS Adjustment Feature

Release
Modification

12.2(4)T

This feature was introduced.

12.2(8)T

The command that was introduced by this feature was changed from ip adjust-mss to ip tcp adjust-mss.

12.2(27)SBA

This feature was integrated into Cisco IOS Release 12.2(27)SBA.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

How to Configure the TCP MSS Adjustment

Configuration Examples for TCP MSS Adjustment

Additional References

How to Configure the TCP MSS Adjustment

This section contains the following procedure:

Setting the MTU on the Local Hosts (required)

Verifying TCP MSS Adjustments (optional)

Setting the MTU on the Local Hosts

Perform this task to set the MTU on the local hosts. NAT does not have to be configured to specify the MTU.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip tcp adjust-mss max-segment-size

5. ip mtu bytes

6. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet0/1

Configures an interface type and enters interface configuration mode.

Step 4 

ip tcp adjust-mss max-segment-size

Example:

Router(config-if)# ip tcp adjust-mss 1452

Adjusts the MSS value of TCP SYN packets going through a router. The max-segment-size argument is the maximum segment size, in bytes. The range is from 500 to 1460.

Step 5 

ip mtu bytes

Example:

Router(config-if) ip mtu 1491

Sets the MTU size of IP packets, in bytes, sent on an interface.

Step 6 

end

Example:

Router(config-if) end

Exits to global configuration mode.

Verifying TCP MSS Adjustments

In the following examples, there are outputs that assist in verifying the TCP MSS adjustments.

Command Configured on Single Interface


Step 1 Configure the interface adjustment value.

interface ethernet1/1
 ip tcp adjust 500

Step 2 Telnet from router A to router C, with B having the MSS adjustment configured.

telnet
00:09:15:%SYS-5-CONFIG_I: Configured from console by consolenet 1.0.1.3
Trying 1.0.1.3... Open

Step 3 Observe the debug output from router C.

*Mar 10 14:49:45.045: tcp0: I LISTEN 4.0.0.1:11001 1.0.1.3:23 seq 2012812244
        OPTS 4 SYN WIN 4128
*Mar 10 14:49:45.045: TCP0: state was LISTEN -> SYNRCVD [23 -> 4.0.0.1(11001)]
*Mar 10 14:49:45.045: TCP0: Connection to 4.0.0.1:11001, received MSS 500, 
MSS is 500
*Mar 10 14:49:45.045: TCP: sending SYN, seq 1091096877, ack 2012812245

The MSS gets adjusted to 500 as configured.


Command Configured on Two Interfaces


Step 1 Configure the command on both the interfaces using different values.

interface Ethernet1/1
 ip address 4.0.0.2 255.0.0.0
 ip tcp adjust-mss 505
 duplex half

interface Ethernet1/3
 ip address 1.0.1.1 255.255.255.0
 ip tcp adjust-mss 500
 duplex half

Step 2 Telnet from router A to router C,

telnet 10.0.1.3
     Trying 10.0.1.3... Open

Step 3 Observe the debug output from router A.

06:06:49: TCP: sending SYN, seq 979045471, ack 0
     06:06:49: TCP0: Connection to 1.0.1.3:23, advertising MSS 536

Step 4 Observe the debug output from router C.

I LISTEN 4.0.0.1:11003 1.0.1.3:23 seq 979045471
       OPTS 4 SYN WIN 4128
       TCP0: state was LISTEN -> SYNRCVD [23 -> 4.0.0.1(11003)]
       TCP0: Connection to 4.0.0.1:11003, received MSS 500, MSS is 500

The TCP MSS is successfully adjusted to 500.


Command Used with Process Switching


Step 1 Verify the configuration of the TCP MSS adjustment.

Router# show running-config interface ethernet1/1

Building configuration...

Current configuration: 95 bytes
!
interface ethernet1/1
 ip address 10.0.0.2 255.0.0.0
 ip tcp adjust-mss 505
 duplex half

Step 2 Telnet from router A to router C.

telnet 10.0.1.3
 Trying 10.0.1.3... 
    TCP: sending SYN, seq 886170752, ack 0
    TCP0: Connection to 1.0.1.3:23, advertising MSS 536
tcp0: O CLOSED 1.0.1.3:23 4.0.0.1:11008 seq 886170752
          OPTS 4 SYN WIN 4128

Step 3 Observe the debug output on router C.

tcp0: I LISTEN 4.0.0.1:11008 1.0.1.3:23 seq 886170752
           OPTS 4 SYN WIN 4128
    TCP0: state was LISTEN -> SYNRCVD [23 -> 4.0.0.1(11008)]
    TCP0: Connection to 4.0.0.1:11008, received MSS 505, MSS is 505

The TCP MSS value gets adjusted to the configured value of 505.


Configuration Examples for TCP MSS Adjustment

This section provides the following examples:

TCP MSS Adjustment Configuration: Example

TCP MSS Adjustment Configuration: Example

The following example shows how to configure one interface with CEF switching turned on:

interface ethernet1/1
 ip tcp adjust 500

The following example shows how to configure two interfaces:

interface Ethernet1/1
 ip address 10.0.0.2 255.0.0.0
 ip tcp adjust-mss 505
 duplex half

interface Ethernet1/3
 ip address 10.0.1.1 255.255.255.0
 ip tcp adjust-mss 500
 duplex half

Additional References

The following sections provide references related to TCP MSS Adjustment feature.

Related Documents

Related Topic
Document Title

WAN commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

Cisco IOS Wide-Area Networking Command Reference, Release 12.3


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

This section documents one new command.

ip tcp adjust-mss

ip tcp adjust-mss

To adjust the maximum segment size (MSS) value of TCP SYN packets going through a router, use the ip tcp adjust-mss command in interface configuration mode. To return the MSS value to the default setting, use the no form of this command.

ip tcp adjust-mss max-segment-size

no ip tcp adjust-mss max-segment-size

Syntax Description

max-segment-size

Maximum segment size, in bytes. The range is from 500 to 1460.


Defaults

If the ip tcp adjust-mss command is not configured, the MSS is determined by the originating host.

Command Modes

Interface configuration

Command History

Release
Modification

12.2(4)T

This command was introduced.

12.2(8)T

This command was changed from ip adjust-mss to ip tcp adjust-mss.

12.2(27)SBA

This command was integrated into Cisco IOS Release 12.2(27)SBA.


Usage Guidelines

When a host (usually a PC) initiates a TCP session with a server, it negotiates the IP segment size by using the MSS option field in the TCP SYN packet. The value of the MSS field is determined by the maximum transmission unit (MTU) configuration on the host. The default MSS value for a PC is 1500 bytes.

The PPP over Ethernet (PPPoE) standard supports a MTU of only 1492 bytes. The disparity between the host and PPPoE MTU size can cause the router in between the host and the server to drop 1500-byte packets and terminate TCP sessions over the PPPoE network. Even if the path MTU (which detects the correct MTU across the path) is enabled on the host, sessions may be dropped because system administrators sometimes disable the ICMP error messages that must be relayed from the host in order for path MTU to work.

The ip tcp adjust-mss command helps prevent TCP sessions from being dropped by adjusting the MSS value of the TCP SYN packets.

The ip tcp adjust-mss command is effective only for TCP connections passing through the router.

In most cases, the optimum value for the max-segment-size argument is 1452 bytes. This value plus the 20-byte IP header, the 20-byte TCP header, and the 8-byte PPPoE header add up to a 1500-byte packet that matches the MTU size for the Ethernet link.

If you are configuring the ip mtu command on the same interface as the ip tcp adjust-mss command, it is recommended that you use the following commands and values:

ip tcp adjust-mss 1452

ip mtu 1492

The ip tcp adjust-mss command does not work on subinterfaces or GRE tunnels.

Examples

The following example shows the configuration of a PPPoE client with the MSS value set to 1452:

vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface Ethernet0
 ip address 192.168.100.1.255.255.255.0
 ip tcp adjust-mss 1452
 ip nat inside
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
 pppoe client dial-pool-number 1
!
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex B
dsl linerate AUTO
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username sohodyn password 7 141B1309000528
!
ip nat inside source list 101 Dialer1 overload
ip route 0.0.0.0.0.0.0.0 Dialer1
access-list permit ip 192.168.100.0.0.0.0.255 any

Related Commands

Command
Description

ip mtu

Sets the MTU size of IP packets sent on an interface.