ISDN Voice Configuration Guide, Cisco IOS Release 15M&T
NFAS with D-Channel Backup
Downloads: This chapterpdf (PDF - 1.33MB) The complete bookPDF (PDF - 4.43MB) | The complete bookePub (ePub - 1.38MB) | Feedback

NFAS with D-Channel Backup

NFAS with D-Channel Backup

This chapter describes how to implement the Non-Facility Associated Signaling (NFAS) with D-Channel Backup feature with two new switch types: DMS100 and NI2. ISDN NFAS allows a single D channel to control multiple ISDN PRI interfaces. You can configure a backup D channel for use when the primary NFAS D channel fails.

After you configure channelized T1 controllers for ISDN PRI, you only need to configure the NFAS primary D channel; its configuration is distributed to all the members of the associated NFAS group.


Note


A controller configured with backup D channel loses one B channel.


Use of a single D channel to control up to 10 PRI interfaces can free one B channel on each interface to carry other traffic.

Any hard failure causes a switchover to the backup D channel and currently connected calls remain connected. The backup D channel cannot be used for data transfer.


Note


On the Nortel dms100 switch, when a single D channel is shared, multiple PRI interfaces may be configured in a single trunk group. The additional use of alternate route indexing, which is a feature of the dms100 switch, provides a rotary from one trunk group to another. This enables the capability of building large trunk groups in a public switched network.


Feature History for NFAS with D-Channel Backup

Release

Modification

12.1(5)XM

This feature was introduced.

12.2(11)T

This feature was implemented on the Cisco AS5850 platform.

12.4(24)T

NFAS network-side support was added.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Configuring NFAS with D-Channel Backup

  • Perform the prerequisites that are listed in the "Prerequisites for Configuring an ISDN Voice Interface" section.
  • Configure your router’s channelized T1 controllers for ISDN, as described in the "Configuring ISDN PRI" section of the "Configuring Channelized E1 and Channelized T1" chapter in the Dial Solutions Quick Configuration Guide.

Restrictions for Configuring NFAS with D-Channel Backup

Restrictions are described in "Restrictions for Configuring ISDN Voice Interfaces". In addition, the following apply:

  • NFAS is supported with only a channelized T1 controller and, as a result, is ISDN PRI capable.
  • NFAS is supported across multiple T1 controllers installed on different slots only if the DSPs of those slots are of the same type. For example, if T1 controllers on slot 1 and slot 2 are combined to form an NFAS group with the T1 in slot 1 being primary, both slots must have the same type of DSP. If these two slots have different DSP types, only those calls using T1 on slot 1 will connect --all calls through T1 on slot 2 will fail with a disconnect cause of "Resource Unavailable/Unspecified (47)."
  • The router must connect to either a 4ess, dms250, dms100, or National ISDN switch type. The table below shows applicable ISDN switch types and supported NFAS types.
Table 1 ISDN Switch Types and Supported NFAS Types

ISDN Switch Type

NFAS Type

Lucent 4ESS

Custom NFAS

Nortel DMS250

Custom NFAS

Nortel DMS100

Custom NFAS

Lucent 5ESS

Custom; does not support NFAS

Lucent 5ESS

NI-2 NFAS

AGCS GTD5

NI-2 NFAS

Other switch types

NI-2 NFAS

Network-side

Network-side emulation

Information about NFAS

Non-Facility Associated Signaling is a classification of signalling protocols that provide the signalling channel in a separate physical line from the bearer channels.


Note


General information about ISDN voice interfaces is presented in the "Information About ISDN Voice Interfaces" section.


How to Configure NFAS with D-Channel Backup

Configuring NFAS on PRI Groups

To configure NFAS on PRI groups, perform the following steps.


Note


When a backup NFAS D channel is configured and the primary NFAS D channel fails, rollover to the backup D channel is automatic and all connected calls stay connected. If the primary NFAS D channel recovers, the backup NFAS D channel remains active and does not switch over again unless the backup NFAS D channel fails.


SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    controller {t1 | e1} controller-number

    4.    pri-group timeslots range nfas_d primary nfas_interface number nfas_group number

    5.    pri-group timeslots range nfas_d backup nfas_interface number nfas_group number

    6.    pri-group timeslots range nfas_d none nfas_int number nfas_group number

    7.    exit


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enters privileged EXEC mode. Enter your password when prompted.

     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters configuration mode.

     
    Step 3 controller {t1 | e1} controller-number


    Example:
    Router(config)# controller t1 3
     

    Enters controller configuration mode for the specified controller number.

     
    Step 4 pri-group timeslots range nfas_d primary nfas_interface number nfas_group number


    Example:
    Router(config-controller)# pri-group timeslots 1-24 nfas_d primary nfas_interface 1 nfas_group 1
     

    Configures, on one channelized T1 controller, the NFAS primary D channel. Keywords are as follows:

    • nfas_interface number --Value assigned by the service provider to ensure unique identification of a PRI interface.
    • nfas_group number --Group identifier unique on the router. Multiple NFAS groups can exist on the router.

    The interface number is the number of the interface assigned to an interface that is part of an nfas group. All interfaces that are part of an nfas group have the same group number and each is identified uniquely within the group by the interface number.

     
    Step 5 pri-group timeslots range nfas_d backup nfas_interface number nfas_group number


    Example:
    Router(config-controller)# pri-group timeslots 1-24 nfas_d backup nfas_interface 2 nfas_group 1
     

    Configures, on a different channelized T1 controller, the NFAS backup D channel to be used if the primary D channel fails. Keywords are as above.

    Repeat this step on other channelized T1 controllers, as appropriate.

     
    Step 6 pri-group timeslots range nfas_d none nfas_int number nfas_group number


    Example:
    Router(config-controller)# pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1
     

    (Optional) Configures, on other channelized T1 controllers, a 24 B channel interface, if desired.

     
    Step 7 exit


    Example:
    Router(config-controller)# exit
     

    Exits the current mode.

     

    Configuring a VoIP Dial Peer for NFAS Voice

    To configure a VoIP dial peer for NFAS voice, perform the following steps.


    Note


    Dial peers are used by the Cisco IOS voice stack for handling calls going from the PSTN to the VoIP side or vice versa. The dial-peer configuration for each NFAS controller should contain the primary of the NFAS group.


    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    dial-peer voice tag voip

      4.    port controller :D

      5.    exit


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enters privileged EXEC mode. Enter your password when prompted.

       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters configuration mode.

       
      Step 3 dial-peer voice tag voip


      Example:
      Router(config)# dial-peer voice 99 voip
       

      Enters dial-peer configuration mode for the specified VoIP dial peer.

       
      Step 4 port controller :D


      Example:
      Router(config-dial-peer)# port 4:D
       

      Associates the dial peer with a specific voice port--in this case, the D channel associated with ISDN PRI for the NFAS primary.

       
      Step 5 exit


      Example:
      Router(config-dial-peer)# exit
       

      Exits the current mode.

       

      Disabling a Channel or Interface

      To disable a channel or interface, perform the following steps.


      Note


      You can disable a specified channel or an entire PRI, thus taking it out of service or put it into one of the other states that is passed in to the switch.


      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    interface serial controller-number : timeslot

        4.    isdn service [dsl number | nfas_int number] b_channel number state{0 | 1 | 2}

        5.    isdn service [dsl number | nfas_int number] b_channel number state {0 | 1 | 2}

        6.    exit


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enters privileged EXEC mode. Enter your password when prompted.

         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters configuration mode.

         
        Step 3 interface serial controller-number : timeslot


        Example:
        Router(config)# interface serial 4/1:23
         

        Enters interface configuration mode and specifies a serial interface for ISDN PRI, channel-associated signaling, or robbed-bit signaling.

         
        Step 4 isdn service [dsl number | nfas_int number] b_channel number state{0 | 1 | 2}


        Example:
        Router(config-if)# isdn service nfas_int 3 b_channel 1 state 1
         

        Takes an individual B channel out of service or sets it to a different state. State values are as follows:

        • 0 --In service
        • 1 --Maintenance
        • 2 --Out of service
         
        Step 5 isdn service [dsl number | nfas_int number] b_channel number state {0 | 1 | 2}


        Example:
        Router(config-if)# isdn service nfas_int 3 b_channel 0 state 1
         

        As above. Setting the b-channel number to 0 sets the entire PRI interface to a specified state value.

         
        Step 6 exit


        Example:
        Router(config-if)# exit
         

        Exits the current mode.

         

        Verifying NFAS Configuration

        To verify NFAS configuration, perform the following steps (listed alphabetically).

        SUMMARY STEPS

          1.    show dial-peer voice

          2.    show isdn nfas group

          3.    show isdn service

          4.    show isdn status

          5.    show running-config


        DETAILED STEPS
          Step 1   show dial-peer voice

          Use this command to display the configuration information for dial peers.



          Example:
          Router# show dial-peer voice
          VoiceOverIpPeer1
                  information type = voice,
                  tag = 1, destination-pattern = `',
                  answer-address = `', preference=0,
                  numbering Type = `unknown'
                  group = 1, Admin state is up, Operation state is down,
                  incoming called-number = `', connections/maximum = 0/unlimited,
                  DTMF Relay = disabled,
                  modem passthrough = system,
                  huntstop = disabled,
                  in bound application associated: DEFAULT
                  out bound application associated:
                  permission :both
                  incoming COR list:maximum capability
                  outgoing COR list:minimum requirement
                  type = voip, session-target = `',
                  technology prefix:
                  settle-call = disabled
                  ip precedence = 0, UDP checksum = disabled,
                  session-protocol = cisco, session-transport = udp, req-qos = best-effor
                  acc-qos = best-effort,
                  fax rate = voice,   payload size =  20 bytes
                  fax protocol = system
                  fax NSF = 0xAD0051 (default)
                  codec = g729r8,   payload size =  20 bytes,
                  Expect factor = 0, Icpif = 20,
                  Playout: Mode adaptive,
                  Expect factor = 0,
                  Max Redirects = 1, Icpif = 20,signaling-type = cas,
                  CLID Restrict = disabled
                  VAD = enabled, Poor QOV Trap = disabled,
                  voice class perm tag = `'
                  Connect Time = 0, Charged Units = 0,
                  Successful Calls = 0, Failed Calls = 0,
                  Accepted Calls = 0, Refused Calls = 0,
                  Last Disconnect Cause is "",
                  Last Disconnect Text is "",
                  Last Setup Time = 0.
          
          Step 2   show isdn nfas group

          Use this command to display information about members of an NFAS group.



          Example:
          Router# show isdn nfas group 1
          ISDN NFAS GROUP 1 ENTRIES:
          The primary D is Serial1/0:23.
          The backup D is Serial1/1:23.
          The NFAS member is Serial2/0:23.
          There are 3 total nfas members.
          There are 93 total available B channels.
          The primary D-channel is DSL 0 in state INITIALIZED.
          The backup D-channel is DSL 1 in state INITIALIZED.
          The current active layer 2 DSL is 1.
          
          Step 3   show isdn service

          Use this command to display information about ISDN channels and the service states.

          Step 4   show isdn status

          Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

          Step 5   show running-config

          Use this command to display the basic router configuration.


          Examples

          This section provides the following output examples:

          Sample Output for the show isdn nfas group Command

          The following three examples show D channel state changes when rollover occurs from the primary NFAS D channel to the backup D channel. The first example shows the output with the primary D channel in service and the backup D channel in standby.

          Router# show isdn nfas group 0
          ISDN NFAS GROUP 0 ENTRIES:
          The primary D is Serial1/0:23.
          The backup D is Serial1/1:23.
          The NFAS member is Serial2/0:23.
          There are 3 total nfas members.
          There are 70 total available B channels.
          The primary D-channel is DSL 0 in state IN SERVICE.
          The backup D-channel is DSL 1 in state STANDBY.
          The current active layer 2 DSL is 0.
          

          The following example shows output during rollover. The configured primary D channel is in maintenance busy state and the backup D channel is waiting.

          Router# show isdn nfas group 0
          ISDN NFAS GROUP 0 ENTRIES:
          The primary D is Serial1/0:23.
          The backup D is Serial1/1:23.
          The NFAS member is Serial2/0:23.
          There are 3 total nfas members.
          There are 70 total available B channels.
          The primary D-channel is DSL 0 in state MAINTENANCE BUSY.
          The backup D-channel is DSL 1 in state WAIT.
          The current active layer 2 DSL is 1.
          

          The following example shows output when rollover is complete. The configured primary D channel is now in standby and the backup D channel is in service.

          Router# show isdn nfas group 0
          ISDN NFAS GROUP 0 ENTRIES:
          The primary D is Serial1/0:23.
          The backup D is Serial1/1:23.
          The NFAS member is Serial2/0:23.
          There are 3 total nfas members.
          There are 70 total available B channels.
          The primary D-channel is DSL 0 in state STANDBY.
          The backup D-channel is DSL 1 in state IN SERVICE.
          The current active layer 2 DSL is 1.

          Configuration Examples for NFAS with D-Channel Backup

          NFAS Primary and Backup D Channels Example

          The following example configures ISDN PRI and NFAS on multiple T1 controllers of a Cisco 7500 series router. The D-channel of T1 1/0/0 is configured as primary D-channel and T1 1/0/1 is configured as backup D-channel. Once you configure the NFAS primary D channel, that channel is the only interface you see and have to configure.

          version 12.x
          service timestamps debug datetime msec localtime show-timezone
          service timestamps log datetime msec localtime show-timezone
          service password-encryption
          !
          hostname travis-nas-01
          !
          aaa new-model
          aaa authentication login default local
          aaa authentication login NO_AUTHENT none
          aaa authorization exec default local if-authenticated
          aaa authorization exec NO_AUTHOR none
          aaa authorization commands 15 default local if-authenticated
          aaa authorization commands 15 NO_AUTHOR none
          aaa accounting exec default start-stop group tacacs+
          aaa accounting exec NO_ACCOUNT none
          aaa accounting commands 15 default stop-only group tacacs+
          aaa accounting commands 15 NO_ACCOUNT none
          enable secret 5 $1$LsoW$K/qBH9Ih2WstUxvazDgmY/
          !
          username admin privilege 15 password 7 06455E365E471D1C17
          username gmcmilla password 7 071824404D06140044
          username krist privilege 15 password 7 0832454D01181118
          !
          call rsvp-sync
          shelf-id 0 router-shelf
          shelf-id 1 dial-shelf
          !
          resource-pool disable
          !
          modem-pool Default
           pool-range 1/2/0-1/2/143,1/3/0-1/3/143
          !
          clock timezone CST -6
          clock summer-time CST recurring
          !
          ip subnet-zero
          ip domain-name cisco.com
          ip name-server 172.22.53.210
          ip name-server 171.69.2.133
          ip name-server 171.69.2.132
          ip name-server 171.69.11.48
          !
          isdn switch-type primary-5ess
          isdn voice-call-failure 0
          !
          controller T1 1/0/0
           framing esf
           linecode b8zs
           pri-group timeslots 1-24 nfas_d primary nfas_interface 1 nfas_group 1
           description PacBell 3241933
          !
          controller T1 1/0/1
           framing esf
           linecode b8zs
           pri-group timeslots 1-24 nfas_d backup nfas_interface 2 nfas_group 1
           description PacBell 3241933
          !
          interface Loopback0
           ip address 172.21.10.1 255.255.255.255
          !
          interface FastEthernet0/0/0
           ip address 172.21.101.20 255.255.255.0
           half-duplex
          !
          interface Serial1/0/0:23
           no ip address
           ip mroute-cache
           isdn switch-type primary-5ess
           isdn incoming-voice modem
           no cdp enable
          !
          interface Group-Async0
           no ip address
           group-range 1/2/00 1/3/143
          !
          router eigrp 1
           network 172.21.0.0
           no eigrp log-neighbor-changes
          !
          ip classless
          ip route 0.0.0.0 0.0.0.0 172.21.101.1

          ip http server

          ip http authentication aaa
          !
          snmp-server engineID local 0000000902000030F2F51400
          snmp-server community 5urf5h0p RO
          snmp-server community 5crapmeta1 RW
          snmp-server community SNMPv1 view v1default RO

          POTS Dial-Peer Configuration Example

          The following example shows configuration of a POTS dial peer with the primary controller of an NFAS group:

          dial-peer voice 35 pots
          		incoming called-number 45...
          destination-pattern 35...
          direct-inward-dial
          port 1/0/0:D
          prefix 35

          PRI Service State Example

          The following example reenables the entire PRI after it was disabled:

          isdn service dsl 0 b-channel 0 state 0

          Additional References

          General ISDN References

          • "Overview of ISDN Voice Interfaces" --Describes relevant underlying technology; lists related documents, standards, MIBs, and RFCs; and describes how to obtain technical assistance
          • "Additional References" section --Lists additional ISDN references