ISDN Voice Configuration Guide, Cisco IOS Release 15M&T
ISDN GTD for Setup Message
Downloads: This chapterpdf (PDF - 1.41MB) The complete bookPDF (PDF - 4.43MB) | The complete bookePub (ePub - 1.38MB) | Feedback

ISDN GTD for Setup Message

Contents

ISDN GTD for Setup Message

This chapter describes how to implement the ISDN Generic Transparency Descriptor (GTD) for Setup Message feature. The feature provides support for mapping ISDN information elements (IEs) to corresponding GTD parameters. The following IEs and parameters are supported:

  • Originating line information (OLI)
  • Bearer capability (USI and TMR) called-party number (CPN)
  • Calling-party number (CGN)
  • Redirecting number (RGN, OCN and RNI)

This feature allows VoIP service providers to develop custom call treatments and enhanced service offerings based on call origination and to correctly identify the source of a call, bill appropriately, and settle accurately with other network providers.

Feature History for ISDN GTD for Setup Message

Release

Modification

12.2(15)T

This feature was introduced.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Configuring ISDN GTD for Setup Message

  • Perform the prerequisites that are listed in the "Prerequisites for Configuring an ISDN Voice Interface" section.
  • Configure your VoIP network and Cisco IOS gateways to allow sending and processing of ISDN Q.931 setup messages.

Restrictions for Configuring ISDN GTD for Setup Message

Restrictions are described in the Restrictions for Configuring ISDN Voice Interfaces section. In addition, the following applies:

  • This feature does not support ISDN BRI calls.

Information About ISDN GTD for Setup Message


Note


General information about ISDN voice interfaces is presented in the "Information About ISDN Voice Interfaces" section.


Feature Design of ISDN GTD for Setup Messages

The ISDN GTD for Setup Messages feature allows the delivery of information elements present in ISDN setup messages to Tool Command Language (Tcl) scripts, RADIUS accounting servers, and routing servers in VoIP networks. This allows Tcl scripts and routing servers to access ISDN signaling information to provide enhanced features and routing services. In particular, the OLI IE present in AT&T (TR-41459 ISDN PRI UNI Specification) and MCI setup messages can be passed to the originating-line-info VSA in RADIUS start-accounting messages to identify the originating caller.

FCC regulations mandate that pay-telephone operators be compensated by network operators for 1-800 calls made from their pay telephones. Before implementation of this feature, network operators had no way to identify calls made from their pay telephones. As a result, network operators had to compensate pay-telephone operators directly from their own revenues. In addition, network operators had no billing records to validate pay-telephone operators’ settlement requests to prevent fraud. This feature provides Cisco network operators with the ability to correctly identify the source of a call. It allows networks to do the following:

  • Extract originating-line information (OLI) to identify pay telephone calls and pass on applicable charges
  • Generate billing records that can be used to validate pay telephone operator settlement requests.

Note


For information on accounting records and RADIUS billing, see the RADIUS VSA Voice Implementation Guide.


This feature provides the flexibility to identify other types of originated calls (from prisons, hotels, and so forth) and allows you to use the Tcl interface to define custom services for these types of calls.


Note


For more information on Tcl application programming, see the Tcl IVR API Version 2.0 Programmer's Guide.


In addition to passing OLI, this feature supports GTD mapping for Bearer Capability, Called Party Number, Calling Party Number, and Redirecting Number IEs.

Cisco implements this feature on Cisco IOS gateways by providing a mechanism to allow creating and passing the Q931 setup message and its parameters in a GTD format. The setup message, received by the gateway to initiate call establishment, is mapped to the GTD initial address message (IAM). Generic transparency descriptors represent parameters within signaling messages and enable transport of signaling data in a standard format across network components and applications. The GTD mechanism allows them to share signaling data and achieve interworking between different signaling types. This feature supports only ISDN PRI and non-facility associated signaling (NFAS) calls.

Mapping of ISDN Information Elements to GTD Parameters

ISDN messages, used to signal call control, are composed of information elements and follow the format specified in ITU-T Q.931. This feature supports only the mapping of Q931 setup messages to GTD IAM messages. This section defines the mapping of ISDN information elements to GTD parameters. Parameters are referred to by both parameter name and three-character GTD code.

The table below defines the mapping of ISDN IEs to GTD parameters. The GTD mechanism also passes the following parameters for which there are no corresponding ISDN IEs:

  • Calling-party category (CPC)
  • Forward-call indicators (FCI)
  • Protocol name (PRN)
Table 1 ISDN IEs Mapped to GTD Parameters

ISDN Information Element

GTD Parameter

Bearer Capability

USI (user-service information), TMR (transmission-medium requirements)

Called Party Number

CPN (called party number)

Calling Party Number

CGN (calling-party number)

Originating Line Info

OLI (originating-line information)

Redirecting Number

RGN (redirecting number), OCN (original called number), RNI (redirection information)

GTD mapping allows up to two redirecting number (original called number) IEs per call as follows:

  • If only one IE is present in the incoming setup message, then both RGN and OCN parameters are built by the ISDN stack and the RGN and OCN parameters contain the same values. Both the redirection reason (rr) field and original redirection reason (orr) field in the GTD RNI parameter contain the redirection reason indicated in the IE.
  • If two IEs are present, then OCN contains information specified in the first IE and RGN contains information for the second IE. RNI contains redirection reasons. The GTD orr field indicates the redirection reason of the first IE and the GTD rr field indicates that of the second IE.

Mapping for CPN CGN and RGN

This section defines mapping for fields and values common to the called party number (CPN), calling party number (CGN), and redirecting information (RGN) GTD parameters carried in the GTD IAM message.

The table below defines mapping for ISDN type of number fields to GTD nature of address (noa) fields.

Table 2 Type of Number to Nature of Address Mapping

ISDN Type of Number

GTD Nature of Address (noa)

0--Unknown

00--Unknown (number present)

1-- International number

06--Unique international number

2--National number

04--Unique national (significant) number

3--Network specific number

08--Network specific number

4--Subscriber number

02--Unique subscriber number

6--Abbreviated number

34--Abbreviated number

The table below defines mapping for ISDN numbering plan identification fields to GTD numbering plan indicator (npi) fields.

Table 3 Numbering Plan Identification to Numbering Plan Indicator Mapping

ISDN Numbering Plan Identification

GTD Numbering Plan Indicator (npi)

0--Unknown

u--Unknown

1--ISDN telephony numbering plan

1--ISDN numbering plan

2--Telephony numbering plan

1--ISDN numbering plan (best fit)

3--Data numbering plan

2--Data numbering plan

4--Telex numbering plan

3--Telex numbering plan

8--National standard numbering plan

5--National numbering plan

9--Private numbering plan

4--Private numbering plan

The table below defines mapping for ISDN and GTD presentation indicator (pi) fields.

Table 4 Presentation Indicator Mapping

ISDN Presentation Indicator

GTD Presentation Indicator (pi)

--

u--Unknown

0-- Presentation allowed

y--Presentation allowed

1--Presentation restricted

n--Presentation not allowed

2--Number not available due to interworking

0--Address not available

Mapping for Calling Party Number (CGN)

The table below defines mapping for ISDN and GTD screening indicator (si) fields.

Table 5 Screening Indicator Mapping

ISDN Screening Indicator

GTD Screening Indicator (si)

--

u--Unknown

0-- User-provided, not screened

1--User-provided, not screened

1--User-provided, verified and passed

2--User-provided screening passed

2--User-provided, verified and failed

3--User-provided screening failed

Mapping for Redirection Information (RNI)

The table below defines mapping for the ISDN reason for redirection fields to GTD original redirection reason (orr) and redirection reason (rr) fields in the GTD RNI parameter.

Table 6 Reason for Redirection to Original Redirection Reason and Redirection Reason Mapping

ISDN Reason for Redirection

GTD Original Redirection Reason (orr) and Redirection Reason (rr)

0--Unknown

u--Unknown

1--Call forwarding busy or called DTE busy

1--User busy

2--Call forwarding no reply

2--No reply

4--Call deflection

4--Deflection during alerting

5--Call deflection immediate response

5--Call deflection immediate response

9--Called DTE out of order

2--No reply (best fit)

10--Call forwarding by the called DTE

5--Call deflection immediate response (best fit)

13--Call transfer

5--Call deflection immediate response (best fit)

14--Call pickup

5--Call deflection immediate response (best fit)

15--Call forwarding unconditional

3--Unconditional

Mapping for Originating Line Information (OLI)

The table below defines mapping for OLI fields.

Table 7 Originating Line Information Mapping

ISDN Originating-Line Information

GTD Originating-Line Information (oli)

0-- POTS

0--POTS

1--Multiparty line

1--Multiparty line

2--ANI failure

2--ANI failure

6--Station-level rating

6--Station-level rating

7--Special operator handling required

7--Special operator handling required

8--Inter-LATA restricted

8-- Inter-LATA restricted

10--Test call

10--Test call

20--AIOD-listed DN sent

20--AIOD-listed DN sent

23--Coin or noncoin on calls using database access

23--Coin or noncoin on calls using database access

24--800 service call

24--800 service call

25-- 800 service call from a pay station

25--800 service call from a pay station

27--Payphone using coin control signaling

27--Payphone using coin control signaling

29-- Prison or inmate service

29--Prison or inmate service

30-- Intercept (blank)

30--Intercept (blank)

31--Intercept (trouble)

31--Intercept (trouble)

32--Intercept (regular)

32--Intercept (regular)

34--Telco operator-handled call

34--Telco operator-handled call

36--CPE

36--CPE

52--OUTWATS

52--OUTWATS

60--TRS call from unrestricted line

60--TRS call from unrestricted line

61--Wireless or cellular PCS (type 1)

61--Wireless or cellular PCS (type 1)

62--Wireless or cellular PCS (type 2)

62--Wireless or cellular PCS (type 2)

63-- Wireless or cellular PCS (roaming)

63--Wireless or cellular PCS (roaming)

66--TRS call from hotel

66--TRS call from hotel

67--TRS call from restricted line

67--TRS call from restricted line

68-- Inter-LATA restricted hotel

68--Inter-LATA restricted hotel

78--Inter-LATA restricted coinless

78--Inter-LATA restricted coinless

70--Private paystations

70--Private paystations

93--Private virtual network

93--Private virtual network

Mapping for Bearer Capability (USI and TMR) Parameters

The ISDN Bearer Capability IE is mapped to the GTD User Service Information (USI) and Transmission Medium Requirements (TMR) parameters. The table below defines mapping for coding standard fields and values.

Table 8 ISDN to GTD Coding Standard Mapping

ISDN Coding Standard

GTD Coding Standard (cs)

0--CCITT standardized coding

c--CCITT/ITU standardized coding

1--Reserved for other international standard

i--ISO/IEC standard

2--National standard

n--National standard

3--Standard defined for the network

p--Standard defined for the network

The table below defines ISDN to GTD mapping for information transfer capability fields and values.

Table 9 Information Transfer Capability Mapping

ISDN Information Transfer Capability

GTD Information Transfer Capability (cap)

0--Speech

s--Speech

8--Unrestricted digital information

d--Unrestricted digital information

9--Restricted digital information

r--Restricted digital information

16--3.1-kHz audio

3--3.1-kbps audio

17--7-kHz audio

7--7-kbps audio

24--Video

v-- Video

The table below defines mapping for transfer mode fields and values.

Table 10 Transfer Mode Mapping

ISDN Transfer Mode

GTD Transfer Mode (mode)

0--Circuit mode

c--Circuit mode

2--Packet mode

p--Packet mode

The table below defines mapping for information transfer rate fields and values.

Table 11 Information Transfer Rate Mapping

ISDN Information Transfer Rate

GTD Information Transfer Rate (rate)

0--Packet mode

0--Not applicable (used for packet call)

16--64 kbps

1--64 kbps

17--2x64 kbps

7--2x64 kbps

19--384 kbps

2--384 kbps

21--1536 kbps

4--1536 kbps

23--1920 kbps

5--1920 kbps

The table below defines mapping for transmission medium requirements.

Table 12 Transmission Medium Requirements Mapping

ISDN Information Transfer Capability

ISDN Information Transfer Rate

GTD Transmission Medium Requirements

0--Speech

--

00

8--Unrestricted digital information

16--64 kbps

01

8--Unrestricted digital information

17--2x64 kbps

04

8--Unrestricted digital information

19--384 kbps

05

8--Unrestricted digital information

21--1536 kbps

06

8--Unrestricted digital information

23--1920 kbps

07

16--3.1-kHz audio

--

02

17--7-kHz audio

--

08

24--Video

--

08

The table below defines mapping for structure fields and values.

Table 13 Structure Mappings

Structure

Structure (str)

0--Default

0--Default or unknown

1--8-kHz integrity

1--8-kHz integrity

4--Service data unit integrity

2--Service data unit integrity

7--Unstructured

3--Unstructured

The table below defines mapping for configuration fields and values.

Table 14 Configuration Field Mapping

ISDN Configuration

GTD Configuration (conf)

0--Point to point

0--Point to point

The table below defines mapping for establishment fields and values.

Table 15 Establishment Field Mapping

ISDN Establishment

GTD Establishment (estab)

0--Demand

d--Demand

The table below defines mapping for symmetry fields and values.

Table 16 Symmetry Field Mapping

ISDN Symmetry

GTD Symmetry (sym)

0--Bidirectional symmetric

sb--Symmetric bidirectional

The table below defines mapping for Layer 1 protocol fields and values.

Table 17 Layer 1 Protocol Mapping

ISDN Information Layer 1 Protocol

GTD Layer 1 Protocol (lay1)

1--CCITT standardized V110

v110--CCITT standardized V.110/X.30

2--G.711mu-law

ulaw--G711 mu-law

3--G.711A-law

alaw--G711 A-law

4--G.721 32 kbps

g721--G721 32 kbps

5--G.722 and G.725

g722--G.722 and G.725/G.724 7-kHz audio

6--G.7xx 384 video

g735--G.735 for 384 kbps video

7--Non-CCITT standardized

nonc--Non-CCITT rate adaptation

8--CCITT standardized V.120

v120--CCITT standardized V.120

9--CCITT standardized X.31

hdlc--CCITT standardized X.31

The table below defines mapping for synchronization fields and values.

Table 18 Synchronization Mapping

ISDN Synchronous/Asynchronous

GTD Synchronization (sync)

0--Synchronous

y--Synchronous

1--Asynchronous

n--Asynchronous

The table below defines mapping for negotiation fields and values.

Table 19 Negotiation Mapping

ISDN Negotiation

GTD Negotiation (neg)

0--In-band negotiation not possible

0--In-band negotiation not possible

1--In-band negotiation possible

1--In-band negotiation possible

The table below defines mapping for user rate fields and values.

Table 20 User-Rate Mapping

ISDN User Rate

ISDN User Rate (subrate)

0--rate is indicated by E-bits

0--rate is indicated by E-bits

1--0.6 kbps

1--0.6 kbps

2--1.2 kbps

2--1.2 kbps

3--2.4 kbps

3--2.4 kbps

4--3.6 kbps

4--3.6 kbps

5--4.8 kbps

5--4.8 kbps

6--7.2 kbps

6--7.2 kbps

7--8.0 kbps

7--8.0 kbps

8--9.6 kbps

8--9.6 kbps

9--14.4 kbps

9--14.4 kbps

10--16.0 kbps

10--16.0 kbps

11--19.2 kbps

11--19.2 kbps

12--32.0 kbps

12--32.0 kbps

14--48.0 kbps

13--48.0 kbps

15--56.0 kbps

14--56.0 kbps

16--64.0 kbps

14--56.0 kbps (best fit)

21--0.1345 kbps

15--0.1345 kbps

22--0.100 kbps

16--0.1000 kbps

23--0.075/1.2 kbps

17--0.075/1.2 kbps

24--1.2/0.075 kbps

18--1.2/0.075 kbps

25--0.050 kbps

19--0.050 kbps

26--0.075 kbps

20--0.075 kbps

27--0.110 kbps

21--0.110 kbps

28--0.150 kbps

22--0.150 kbps

29--0.200 kbps

23--0.200 kbps

30-- 0.300 kbps

24--0.300 kbps

31--12 kbps

25--12 kbps

The table below defines mapping for intermediate rate fields and values.

Table 21 Intermediate Rate Mapping

ISDN Intermediate Rate

GTD Intermediate Rate (int)

1--8 kbps

08--8 kbps

2--16 kbps

16--16 kbps

3--32 kbps

32--32 kbps

The table below defines mapping for network independent clock on transmission fields and values.

Table 22 Mapping for Network Independent Clock on Transmission

ISDN Network Independent Clock on TX

ISDN Network Independent Clock on TX (txnic)

0--Not required to send data

n--Not required to send data

1--Required to send data

y--Required to send data

The table below defines mapping for network independent clock on reception fields and values.

Table 23 Mapping for Network Independent Clock on Reception

ISDN Network Independent Clock on RX

GTD Network Independent Clock on RX (rxnic)

0--Cannot accept data

n--Cannot accept data

1--Can accept data

y--Can accept data

The table below defines mapping for flow control on transmission fields and values.

Table 24 Mapping for Flow Control on Transmission

ISDN Flow Control on TX

GTD Flow Control on TX (txfl)

0--Not required to send data

n--Not required to send data

1--Required to send data

y--Required to send data

The table below defines mapping for flow control on reception fields and values.

Table 25 Mapping for Flow Control on Reception

ISDN Flow Control on RX

GTD Flow Control on RX (rxfl)

0--Cannot accept data

n--Cannot accept data

1--Can accept data

y--Can accept data

The table below defines mapping for rate adaptation header fields and values.

Table 26 Mapping for Rate Adaptation Header

ISDN Rate Adaptation Header/No Header

GTD Rate Adaptation Header (hdr)

0--Rate adaptation header not included

n--Rate adaptation header not included

1--Rate adaptation header included

y--Rate adaptation header included

The table below defines mapping for multiframe establishment support for data link fields and values.

Table 27 Mapping for Multiframe Establishment (MFE) Support

ISDN MFE Support in Data Link

GTD MFE Support in Data Link (mf)

0--MFE not supported

n--MFE not supported

1--MFE supported

y--MFE supported

The table below defines mapping for mode of operation fields and values.

Table 28 Mode of Operation Mapping

ISDN Mode of Operation

GTD Mode of Operation (mode)

0--Bit-transparent mode of operation

0--Bit-transparent mode of operation

1--Protocol-sensitive mode of operation

1--Protocol-sensitive mode of operation

The table below defines mapping for logical link identifier negotiation fields and values.

Table 29 Logical Link Identifier (LLI) Mapping

ISDN LLI Negotiation

GTD LLI Negotiation (lli)

0--Default

0--Default

1--Full protocol negotiation

1--Full-protocol negotiation

The table below defines mapping for assignor and assignee fields and values.

Table 30 Mapping for Assignor and Assignee

ISDN Assignor and Assignee

GTD Assignor and Assignee (asgn)

0--Message originator is default assignee

0--Message originator is default assignee

1--Message originator is assignor only

1--Message originator is assignor only

The table below defines mapping for in-band and out-of-band negotiation fields and values.

Table 31 Mapping for Inband and Out-of-Band Negotiation

ISDN In-band and Out-of-Band Negotiation

GTD In-band and Out-of-Band Negotiation (inbnd)

0--Negotiation done with USER INFO

0-- Not applicable to this protocol

1--Negotiation done in-band

1-- Negotiation done in-band

The table below defines mapping for fields and values for number of stop bits.

Table 32 Mapping for Number of Stop Bits

ISDN Number of Stop Bits

GTD Number of Stop Bits (stp)

1--1 bit

1--1 bit

2--1.5 bit

3--1.5 bit

3--2 bits

2--2 bits

The table below defines mapping for fields and values for number of data bits.

Table 33 Mapping for Number of Data Bits

ISDN Number of Data Bits

GTD Number of Data Bits (dat)

1--5 bits

5--5 bits

2--7 bits

7--7 bits

3--8 bits

8--8 bits

The table below defines mapping for parity information fields and values.

Table 34 Parity Mapping

ISDN Parity Information

GTD Parity (par)

0--Odd

o--Odd

2--Even

e--Even

3--None

n--None

4--Forced to 0

0--Forced to 0

5--Forced to 1

1-- Forced to 1

The table below defines mapping for duplex mode fields and values.

Table 35 Duplex Mode Mapping

ISDN Duplex Mode

GTD Duplex (dup1)

0--Half duplex

h--Half duplex

1--Full duplex

f--Full duplex

The table below defines mapping for modem type fields and values.

Table 36 Modem Type Mapping

Modem Type

Modem Type (modm)

1--V.21

11--V.21

2--V.22

00--V.22

3--V.22 bis

01--V.22 bis

4--V.23

02--V.23

5--V.26

03--V.26

6--V.26 bis

04--V.26 bis

7--V.26 ter

05--V.26 ter

8 --V.27

06--V.27

9--V.27 bis

07--V.27 bis

10--V.27 ter

08--V.27 ter

11--V.29

09--V.29

12--V.32

10--V.32

13--V.35

12--V.34 (best fit)

The table below defines mapping for Layer 2 protocol fields and values.

Table 37 Layer 2 Protocol Mapping

ISDN User Information Layer 2 Protocol

GTD Layer 2 Protocol (lay2)

2--Q.921

2--Q.921

6--X.25

1--X.25

The table below defines mapping for Layer 3 protocol fields and values.

Table 38 Layer 3 Protocol Mapping

ISDN User Information Layer 3 Protocol

GTD Layer 3 Protocol (lay3)

2--Q.931

2--Q.931

6--X.25

1--X.25

How to Configure ISDN GTD for Setup Message

Configuring ISDN GTD for Setup Messages

This feature is enabled by default; no configuration tasks are required to enable this feature. To reenable the feature if it was disabled by use of the no isdn gtd command, perform the following steps.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface

    4.    isdn gtd

    5.    exit


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode. Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface


    Example:
    Router(config)# interface
     

    Enters interface configuration mode.

     
    Step 4 isdn gtd


    Example:
    Router(config-if)# isdn gtd
     

    Enables GTD parameter mapping for ISDN IEs.

     
    Step 5 exit


    Example:
    Router(config-if)# exit
     

    Exits the current mode.

     

    Configuring the OLI IE to Interface with MCI Switches

    To configure OLI IE to interface with MCI switches, perform the following steps.


    Note


    You must configure the Cisco IOS gateway to support the switch variant from which the gateway receives ISDN signaling. For a gateway that interfaces to an MCI switch or PBX, the OLI IE identifier for the MCI ISDN variant, as defined in CPE Requirements for MCI ISDN Primary Rate Interface, (014-0018-04.3D-ER, revision 4.3D), is configurable. Select the IE value that indicates OLI information to configure gateway support for the MCI ISDN variant.


    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface

      4.    isdn ie oli value

      5.    exit


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode. Enter your password if prompted.

       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface


      Example:
      Router(config)# interface
       

      Enters interface configuration mode.

       
      Step 4 isdn ie oli value


      Example:
      Router(config-if)# isdn ie oli 7F
       

      Configures the OLI IE identifier to allow the gateway to interface with an MCI switch.

      OLI IE identifier values are in hexadecimal format. Values range from 00 to 7F.

       
      Step 5 exit


      Example:
      Router(config-if)# exit
       

      Exits the current mode.

       

      Verifying ISDN GTD

      To verify the interface, perform the following steps (listed alphabetically).

      SUMMARY STEPS

        1.    show isdn status

        2.    show running-config


      DETAILED STEPS
        Step 1   show isdn status

        Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

        Step 2   show running-config

        Use this command to display the configuration for the ISDN GTD for Setup Messages feature. If GTD mapping is enabled (default), command output does not display the isdn gtd command.


        Troubleshooting Tips

        • Use the debug gtd detailscommand to display GTD details.
        • Use the debug gtd error command to display GTD errors.
        • Use the debug gtd eventscommand to display GTD events.

        Examples

        This section provides the following output example:

        Sample Output for the debug gtd events Command
        Router# debug gtd events
        00:05:19:%SYS-5-CONFIG_I:Configured from console by console
        *Aug  8 06:32:20.915:ISDN Se3:23 Q931:RX <- SETUP pd = 8  callref = 0x0002
                Bearer Capability i = 0x8890
                        Standard = CCITT
                        Transer Capability = Unrestricted Digital
                        Transfer Mode = Circuit
                        Transfer Rate = 64 kbit/s
                Channel ID i = 0xA98397
                        Exclusive, Channel 23
                Called Party Number i = 0x81, '9999'
                        Plan:ISDN, Type:Unknown
        *Aug  8 06:32:20.919:ISDN Se3:23:Built a GTD of size 86 octets for ISDN message type 0x5
        *Aug  8 06:32:20.919:tsp_ccrawmsg_encap:calling cdapi_find_tsm
        *Aug  8 06:32:20.919:cdapi_find_tsm:Found Tunnelled Signaling Msg with GTD:PROT_PTYPE_GTD
        *Aug  8 06:32:20.919:cdapi_find_tsm:Found a gtd msg of length 86:
        *Aug  8 06:32:20.919:gtd msg = "IAM,
        PRN,isdn*,,,
        USI,rate,c,d,c,1
        TMR,01
        CPN,00,,1,9999
        CPC,09
        FCI,,,,,,,y,"
        *Aug  8 06:32:20.923:ccGTDExtractParm:Starting
        *Aug  8 06:32:20.923: tunnelledPtype = 2
        *Aug  8 06:32:20.923: gtdInstance = 0
        *Aug  8 06:32:20.923: gtdBitMap = 0xFFFFFFFF
        *Aug  8 06:32:20.923:ccGTDExtractParm:TunnelledContent has GTD message
        *Aug  8 06:32:20.923:gtd msg = "IAM,
        PRN,isdn*,,,
        USI,rate,c,d,c,1
        TMR,01
        CPN,00,,1,9999
        CPC,09
        FCI,,,,,,,y,"
        *Aug  8 06:32:20.927:ccGTDExtractParm:GTD Parm CPC obtained
        *Aug  8 06:32:20.927:ccGTDExtractParm:GTD Parm TMR obtained
        *Aug  8 06:32:20.927:ccGTDExtractParm:GTD Parm PRN obtained
        *Aug  8 06:32:21.547:ccMapGCItoGUID:GTD Parm GCI not present
        *Aug  8 06:32:21.547:ccMapGUIDtoGCI:Modified GTD string to include GCI
        *Aug  8 06:32:21.547:ccMapGUIDtoGCI:Calling update_gtd_in_raw_msg_buffer
        *Aug  8 06:32:21.547:update_gtd_in_raw_msg_buffer:Inserting 124 byte GTD string into rawmsg buffer.
        The new gtd string is:
        *Aug  8 06:32:21.547:gtd msg = "IAM,
        PRN,isdn*,,,
        USI,rate,c,d,c,1
        TMR,01
        CPN,00,,1,9999
        CPC,09
        FCI,,,,,,,y,
        GCI,7ba32c886c2c11d48005b0f6ff40a2c1"
        *Aug  8 06:32:21.547:update_gtd_in_raw_msg_buffer:Original rawmsg buf length is 115
        the original gtd length was 86
        the new gtd length is = 124
        *Aug  8 06:32:21.547:update_gtd_in_raw_msg_buffer:New data and IE inserted in rawmsg buff,
        rawmsg buf length is now 153
        *Aug  8 06:32:21.551:Have gtd msg, length=124:
        *Aug  8 06:32:21.551:gtd msg = "IAM,
        PRN,isdn*,,,
        USI,rate,c,d,c,1
        TMR,01
        CPN,00,,1,9999
        CPC,09
        FCI,,,,,,,y,
        GCI,7ba32c886c2c11d48005b0f6ff40a2c1"
        *Aug  8 06:32:21.555:Have gtd msg, length=124:
        *Aug  8 06:32:21.555:gtd msg = "IAM,
        PRN,isdn*,,,
        USI,rate,c,d,c,1
        TMR,01
        CPN,00,,1,9999
        CPC,09
        FCI,,,,,,,y,
        GCI,7ba32c886c2c11d48005b0f6ff40a2c1"
        *Aug  8 06:32:21.559:ccMapGUIDtoGCI:GTD Parm GCI is present:7ba32c886c2c11d48005b0f6ff40a2c1, just returning
        *Aug  8 06:32:21.559:ccGTDExtractParm:Starting
        *Aug  8 06:32:21.559: tunnelledPtype = 2
        *Aug  8 06:32:21.559: gtdInstance = 0
        *Aug  8 06:32:21.559: gtdBitMap = 0xFFFBFFFF
        *Aug  8 06:32:21.559:ccGTDExtractParm:TunnelledContent has GTD message
        *Aug  8 06:32:21.559:gtd msg = "IAM,
        PRN,isdn*,,,
        USI,rate,c,d,c,1
        TMR,01
        CPN,00,,1,9999
        CPC,09
        FCI,,,,,,,y,
        GCI,7ba32c886c2c11d48005b0f6ff40a2c1"
        *Aug  8 06:32:21.559:ccGTDExtractParm:GTD Parm CPC obtained
        *Aug  8 06:32:21.559:ccGTDExtractParm:GTD Parm TMR obtained
        *Aug  8 06:32:21.563:ccGTDExtractParm:GTD Parm PRN obtained
        *Aug  8 06:32:21.563:ISDN Se3:23 Q931:TX -> CALL_PROC pd = 8  callref = 0x8002
                Channel ID i = 0xA98397
                        Exclusive, Channel 23

        Configuration Examples for ISDN Generic Transparency Descriptor (GTD) for Setup Message

        GTD Mapping Example

        The following example shows that GTD mapping is enabled:

        enable
        configure terminal
        interface
        isdn gtd

        Note


        The GTD feature is different from the isdn mapcommand.


        OLI IE Example

        The following example shows that the OLI IE identifier for interfacing to an MCI switch is set to 7F:

        enable
        configure terminal
        interface
        isdn ie oli 7F

        OLI IE and GTD Example

        The following example shows that the isdn gtd command is disabled and that the OLI IE identifier is set to 1F in the D channel of the T1 line in slot 3 (serial3:23):

        Router# show running-config
        Building configuration...
        Current configuration :4112 bytes
        !
        version 12.2
        no parser cache
        service timestamps debug datetime msec
        service timestamps log uptime
        no service password-encryption
        !
        hostname Router
        !
        boot system flash:c5300-i-mz.122-4.2
        no logging buffered
        enable secret
        enable password
        !
        username guam password
        username user1 password
        username user2 password
        spe 2/0 2/7
         firmware location system:/ucode/mica_port_firmware
        !
        resource-pool disable
        !
        ip subnet-zero
        no ip domain lookup
        ip domain name cisco.com
        ip host nlab-boot 172.21.200.2
        ip host dirt 172.69.1.129
        ip host dsbu-web.cisco.com 172.19.192.254 172.71.162.82
        ip host lab 172.19.192.254
        !
        isdn switch-type primary-ni
        isdn gateway-max-interworking
        !
        trunk group  1
         carrier-id cd1
         max-retry 2
         hunt-scheme random
        !
        trunk group  2
         max-retry 2
         hunt-scheme random
        !
        voice service voip
        !
        no voice hpi capture buffer
        no voice hpi capture destination
        !
        fax interface-type modem
        mta receive maximum-recipients 0
        !
        controller T1 0
         framing esf
         clock source line primary
         linecode b8zs
         pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 0
         no yellow generation
         no yellow detection
        !
        controller T1 1
         framing esf
         clock source line secondary 1
         linecode b8zs
         pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 0
         no yellow generation
         no yellow detection
        !
        controller T1 2
         framing esf
         linecode b8zs
         pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 0
         no yellow generation
         no yellow detection
        !
        controller T1 3
         framing esf
         linecode b8zs
         pri-group timeslots 1-24
         no yellow generation
         no yellow detection
        !
        interface Ethernet0
         ip address 10.0.44.29 255.255.255.0
         no ip route-cache
         no ip mroute-cache
         no cdp enable
        !
        interface Serial0:23
         ip address 10.1.1.2 255.255.255.0
         dialer map ip 10.1.1.1 name host 1111
         dialer-group 1
         isdn switch-type primary-ni
         isdn protocol-emulate network
         isdn T310 30000
         isdn negotiate-bchan
         isdn bchan-number-order descending
         no cdp enable
        !
        interface Serial3:23
         ip address 10.9.9.9 255.255.255.0
         dialer map ip 10.8.8.8 name host 8888
         dialer map ip 10.8.8.8 255.255.255.0
         dialer-group 1
         isdn switch-type primary-net5
         isdn protocol-emulate network
         isdn incoming-voice modem
         isdn disconnect-cause 126
         no isdn outgoing display-ie
         isdn ie oli 1F
         no isdn gtd
         no cdp enable
        !
        interface FastEthernet0
         no ip address
         no ip route-cache
         no ip mroute-cache
         shutdown
         duplex auto
         speed auto
         no cdp enable
        !
        interface Group-Async1
         no ip address
         encapsulation ppp
         dialer in-band
         dialer-group 1
         no keepalive
         group-range 1 96
        !
        interface Dialer1
         ip address 10.2.2.2 255.255.255.0
         encapsulation ppp
         no ip route-cache
         no ip mroute-cache
         dialer remote-name host
         dialer-group 1
         no fair-queue
        !
        interface Dialer2
         no ip address
         no cdp enable
        !
        interface Dialer5
         ip address 10.1.1.1 255.0.0.0
         encapsulation ppp
         no ip route-cache
         no ip mroute-cache
         dialer in-band
         dialer map ip 10.1.1.2 name host 1234567
         dialer-group 1
         ppp authentication chap
        !
        ip default-gateway 10.0.44.1
        ip classless
        ip route 0.0.0.0 0.0.0.0 10.0.44.1
        ip route 0.0.0.0 0.0.0.0 Ethernet0
        no ip http server
        !
        access-list 101 permit ip any any
        dialer-list 1 protocol ip permit
        no cdp run
        !
        snmp-server enable traps tty
        snmp-server enable traps isdn layer2
        snmp-server host 10.1.1.1 public
        !
        call rsvp-sync
        !
        voice-port 0:D
        !
        voice-port 3:D
        !
        mgcp profile default
        !
        dial-peer cor custom
        !
        dial-peer voice 2 voip
         destination-pattern 111
         session target ipv4:10.0.45.87
        !
        dial-peer voice 10 pots
         destination-pattern 9999
         direct-inward-dial
         port 3:D
         prefix 9999
        !
        dial-peer voice 20 voip
         destination-pattern 000000002.
         session target ipv4:10.0.44.28
        !
        dial-peer voice 50 pots
         destination-pattern 2222
         direct-inward-dial
         port 0:D
         prefix 2222
        !
        alias exec c conf t
        !
        line con 0
         exec-timeout 0 0
         logging synchronous
        line 1 96
         no flush-at-activation
         modem InOut
         transport input all
         transport output lat pad telnet rlogin udptn v120 lapb-ta
        line aux 0
        line vty 0 4
         password
         login
        !
        end

        Additional References

        General ISDN References

        • "Overview of ISDN Voice Interfaces" --Describes relevant underlying technology; lists related documents, standards, MIBs, and RFCs; and describes how to obtain technical assistance
        • "Additional References" section --Lists additional ISDN references