RADIUS Configuration Guide Cisco IOS XE Release 3S
RADIUS Logical Line ID
Downloads: This chapterpdf (PDF - 1.29MB) The complete bookPDF (PDF - 3.43MB) | The complete bookePub (ePub - 458.0KB) | Feedback

RADIUS Logical Line ID

The RADIUS Logical Line ID feature, also known as the Logical Line Identification (LLID) Blocking feature enables administrators to track their customers on the basis of the physical lines on which customer calls originate. Administrators use a virtual port that does not change as customers move from one physical line to another. This virtual port facilitates the maintenance of the administrator’s customer profile database and allows the administrator to do additional security checks on customers.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for RADIUS Logical Line ID

Although this feature can be used with any RADIUS server, some RADIUS servers may require modifications to their dictionary files to allow the Calling-Station-ID attribute to be returned in Access-Accept messages. For example, the Merit RADIUS server does not support LLID downloading unless you modify its dictionary as follows: “ATTRIBUTE Calling-Station-Id 31 string (*, *)”

Restrictions for RADIUS Logical Line ID

The RADIUS Logical Line ID feature supports RADIUS only. TACACS+ is not supported.

This feature can be applied only toward PPP over Ethernet over ATM (PPPoEoATM) and PPP over Ethernet over VLAN (PPPoEoVLAN) (Dot1Q) calls; no other calls, such as ISDN, can be used.

Information About RADIUS Logical Line ID

Preauthorization

LLID is an alphanumeric string (which must be a minimum of one character and a maximum of 253 characters) that is a logical identification of a subscriber line. LLID is maintained in a customer profile database on a RADIUS server. When the customer profile database receives a preauthorization request from the access router, the RADIUS server sends the LLID to the router as the Calling-Station-ID attribute (attribute 31).

The Layer 2 Tunneling Protocol (L2TP) access concentrator (LAC) sends a preauthorization request to the customer profile database when the LAC is configured for preauthorization. Configure the LAC for preauthorization using the subscriber access command.


Note


Downloading the LLID is referred to as “preauthorization” because it occurs before either service (domain) authorization or user authentication and authorization occur.


The customer profile database on the RADIUS server consists of user profiles for each physical network access server (NAS) port that is connected to the router. Each user profile contains a profile matched to a username (attribute 1) representing the physical port on the router. When the router is configured for preauthorization, it queries the customer profile database using a username representative of the physical NAS port making the connection to the router. When a match is found in the customer profile database, the customer profile database returns an Access-Accept message containing the LLID in the user profile. The LLID is defined in the Access-Accept record as the Calling-Station-ID attribute.

The preauthorization process can also provide the real username being used for authentication to the RADIUS server. Because the physical NAS port information is being used as the username (attribute 1), RADIUS attribute 77 (Connect-Info) can be configured to contain the authentication username. This configuration allows the RADIUS server to provide additional validation on the authorization request if it chooses, such as analyzing the username for privacy rules, before returning an LLID back to the router.

How to Configure RADIUS Logical Line ID

Configuring Preauthorization

To download the LLID and configure the LAC for preauthorization, perform the following steps.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip radius source-interface interface-name

    4.    subscriber access {pppoe | pppoa} pre-authorize nas-port-id [default | list-name] [send username]


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip radius source-interface interface-name


    Example:
                
    
              


    Example:
    Router (config)# ip radius source-interface Loopback1
     

    Specifies the IP address portion of the username for the preauthorization request.

     
    Step 4 subscriber access {pppoe | pppoa} pre-authorize nas-port-id [default | list-name] [send username]


    Example:
                
    
              


    Example:
    Router (config)# subscriber access pppoe pre-authorize nas-port-id mlist_llid send username
     

    Enables the LLID to be downloaded so the router can be configured for preauthorization.

    The send username option specifies that you include the authentication username of the session inside the Connect-Info (attribute 77) in the Access-Request message.

     

    Configuring the LLID in a RADIUS User Profile

    To configure the user profile for preauthorization, add a NAS port user to the customer profile database and add RADIUS Internet Engineering Task Force (IETF) attribute 31 (Calling-Station-ID) to the user profile.

    SUMMARY STEPS

      1.    UserName=nas_port: ip-address:slot/module/port/vpi.vci

      2.    User-Name=nas-port: ip-address:slot/module/port/vlan-id

      3.    Calling-Station-Id = “string (*,*)”


    DETAILED STEPS
        Command or Action Purpose
      Step 1 UserName=nas_port: ip-address:slot/module/port/vpi.vci 

      (Optional) Adds a PPPoE over ATM NAS port user.

       
      Step 2 User-Name=nas-port: ip-address:slot/module/port/vlan-id 

      (Optional) Adds a PPPoE over VLAN NAS port user.

       
      Step 3 Calling-Station-Id = “string (*,*)” 

      Adds attribute 31 to the user profile.

      • String--One or more octets, containing the phone number from which the user placed the call.
       

      Verifying Logical Line ID

      To verify feature functionality, perform the following steps.

      SUMMARY STEPS

        1.    enable

        2.    debug radius


      DETAILED STEPS
          Command or Action Purpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 debug radius


        Example:
        Router# debug radius
         

        Checks to see that RADIUS attribute 31 is the LLID in the Accounting-Request on LAC and in the Access-Request and Accounting-Request on the LNS.

         

        Configuration Examples for RADIUS Logical Line ID

        LAC for Preauthorization Configuration Example

        The following example shows how to configure your LAC for preauthorization by downloading the LLID:

        aaa new-model
        aaa group server radius sg_llid
         server 172.31.164.106 auth-port 1645 acct-port 1646
        aaa group server radius sg_water
         server 172.31.164.106 auth-port 1645 acct-port 1646
        aaa authentication ppp default group radius 
        aaa authorization confg-commands
        aaa authorization network default group sg_water
        aaa authorization network mlist_llid group sg_llid
        aaa session-id common
        !
        username s7200_2 password 0 lab
        username s5300 password 0 lab
        username sg_water password 0 lab
        vpdn enable
        !
        vpdn-group 2 
         request-dialin 
         protocol l2tp 
         domain example.com 
         domain example.com#184 
         initiate-to ip 10.1.1.1 
         local name s7200_2 
         l2tp attribute clid mask-method right * 255 match #184
        !
        vpdn-group 3
         accept dialin
          protocol pppoe
          virtual-template 1
        !
        ! 
        Enable the LLID to be downloaded.
        subscriber access pppoe pre-authorize nas-port-id mlist_llid send username
        !
        interface Loopback0
         ip address 10.1.1.2 255.255.255.0
        !
        interface Loopback1
         ip address 10.1.1.1 255.255.255.0
        !
        interface FastEthernet1/0/0
         ip address 10.1.1.8 255.255.255.0 secondary
         ip address 10.0.58.111 255.255.255.0 
         no cdp enable
        !
        interface ATM4/0/0
         no ip address
         no atm ilmi-keepalive
        !
        interface ATM4/0/0.1 point-to-point
         pvc 1/100
          encapsulation aa15snap
          protocol pppoe
        !
        interface virtual-template1
         no ip unnumbered Loopback0
         no peer default ip address
         ppp authentication chap
        !
        radius-server host 172.31.164.120 auth-port 1645 acct-port 1646 key rad123
        radius-server host 172.31.164.106 auth-port 1645 acct-port 1646 key rad123
        ip radius source-interface Loopback1

        RADIUS User Profile for LLID Example

        The following example shows how to configure the user profile for LLID querying for PPPoEoVLAN and PPPoEoATM and how to add attribute 31:

        pppoeovlan
        ----------
        nas-port:10.1.0.3:6/0/0/0    Password = "password1",
            Service-Type = Outbound,
            Calling-Station-ID = "cat-example"
        pppoeoa
        --------
        nas-port:10.1.0.3:6/0/0/1.100    Password = "password1",
            Service-Type = Outbound,
            Calling-Station-ID = "cat-example"

        Additional References

        The following sections provide references related to RADIUS EAP Support feature.

        Related Documents

        Related Topic

        Document Title

        Configuring PPP Authentication Using AAA

        “ Configuring Authentication ” module.

        Configuring RADIUS

        “ Configuring RADIUS ” module.

        PPP Configuration

        “ Configuring Asynchronous SLIP and PPP ” module.

        Dial Technologies commands

        Cisco IOS Dial Technologies Command Reference

        Security Commands

        Cisco IOS Security Command Reference

        Standards

        Standard

        Title

        None

        --

        MIBs

        MIB

        MIBs Link

        None

        To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

        http:/​/​www.cisco.com/​go/​mibs

        RFCs

        RFC

        Title

        RFC 2284

        PPP Extensible Authentication Protocol (EAP)

        RFC 1938

        A One-Time Password System

        RFC 2869

        RADIUS Extensions

        Technical Assistance

        Description

        Link

        The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

        To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

        Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​techsupport

        Feature Information for RADIUS Logical Line ID

        The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

        Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

        Table 1 Feature Information for RADIUS Logical Line ID

        Feature Name

        Releases

        Feature Information

        RADIUS Logical Line ID

        Cisco IOS XE Release 2.1

        The RADIUS Logical Line ID feature, also known as the Logical Line Identification (LLID) Blocking feature enables administrators to track their customers on the basis of the physical lines on which customer calls originate.

        In Cisco IOS XE Release 2.1, this feature was introduced on Cisco ASR 1000 Series Aggregation Services Routers.

        The following command was introduced or modified by this feature: subscriber access.

        Calling Station ID Attribute 31

        Cisco IOS XE Release 2.1

        This feature was introduced on Cisco ASR 1000 Series Routers.

        LLID Blocking

        Cisco IOS XE Release 2.1

        This feature was introduced on Cisco ASR 1000 Series Routers.

        Glossary

        attribute --A RADIUS Internet Engineering Task Force (IETF) attribute is one of the original set of 255 standard attributes that are used to communicate authentication, authorization, and accounting (AAA) information between a client and a server. Because IETF attributes are standard, the attribute data is predefined and well known; thus all clients and servers that exchange AAA information through IETF attributes must agree on attribute data such as the exact meaning of the attributes and the general bounds of the values for each attribute.

        CHAP --Challenge Handshake Authentication Protocol. Security feature that is supported on lines using PPP encapsulation and prevents unauthorized access. CHAP does not itself prevent unauthorized access; it merely identifies the remote end. The router or access server then determines whether that user is allowed access.

        EAP --Extensible Authentication Protocol. A PPP authentication protocol that supports multiple authentication mechanisms that are negotiated during the authentication phase (instead of the Link Control Protocol [LCP] phase). EAP allows a third-party authentication server to interact with the PPP implementation through a generic interface.

        LCP --link control protocol. Protocol that establishes, configures, and tests data-link connections for use by PPP.

        MD5 (HMAC variant) --Message Digest 5. A hash algorithm used to authenticate packet data. HMAC is a key hashing for message authentication.

        NAS --network access server. A device providing local network access to users across a remote access network such as the public switched telephone network (PSTN).

        PAP --Password Authentication Protocol. Authentication protocol that allows PPP peers to authenticate one another. The remote router attempting to connect to the local router is required to send an authentication request. Unlike CHAP, PAP passes the password and host name or username in the clear (unencrypted). PAP does not itself prevent unauthorized access; it merely identifies the remote end. The router or access server then determines if that user is allowed access. PAP is supported only on PPP lines.

        PPP --Point-to-Point Protocol. A protocol that encapsulates network layer protocol information over point-to-point links. PPP is defined in RFC 1661.

        RADIUS --Remote Authentication Dial-In User Service. Database for authenticating modem and ISDN connections and for tracking connection time.

        Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental. © 2001-2009 Cisco Systems, Inc. All rights reserved.