Multitopology Routing Configuration Guide, Cisco IOS Release 15S
MTR in VRF
Downloads: This chapterpdf (PDF - 1.29MB) The complete bookPDF (PDF - 3.02MB) | The complete bookePub (ePub - 439.0KB) | Feedback

MTR in VRF

MTR in VRF

The MTR in VRF feature extends to IPv4 VRF contexts the Cisco IOS software's capability that allows users to configure one or more non-congruent multicast topologies in global IPv4 routing context. These contexts can be used to forward unicast and multicast traffic over different links in the network, or in the case of non-base topologies to provide a Live-Live multicast service using multiple non-congruent multicast topologies mapped to different (S,G) groups.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About MTR in VRF

MTR in VRF Overview

The MTR in VRF feature extends to IPv4 VRF contexts, Cisco IOS software's capability that allows users to configure one or more non-congruent multicast topologies in global IPv4 routing context. These contexts can be used to forward unicast and multicast traffic over different links in the network, or in the case of non-base topologies to provide a Live-Live multicast service using multiple non-congruent multicast topologies mapped to different (S,G) groups.

The Cisco IOS Software allows a set of attributes, primarily used by BGP/MPLS L3VPNs, to be configured on a per-address family basis within a VRF. The MTR in VRF feature allows these attributes to be independently configured for the multicast sub-address families within a VRF address family.

How to Configure VRF in MTR

Configuring MTR in VRF

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    vrf definition vrf-name

    4.    rd route-distinguisher

    5.    ipv4 multicast multitoplogy

    6.    address-family ipv4

    7.    exit-address-family

    8.    address-family ipv4 multicast

    9.    topology topology-instance-name

    10.    all-interfaces

    11.    exit

    12.    exit-address-family

    13.    exit

    14.    interface type number

    15.    interface type number

    16.    vrf forwarding vrf-name

    17.    ip address ip-address mask

    18.    ip pim sparse-dense-modeip

    19.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 vrf definition vrf-name


    Example:
    Device(config)# vrf definition vd1 
     

    Configures a VRF routing table and enters VRF configuration mode.

     
    Step 4 rd route-distinguisher


    Example:
    Device(config-vrf)# rd 10:1 
     

    Creates routing and forwarding tables for a VRF.

     
    Step 5 ipv4 multicast multitoplogy


    Example:
    Device(config-vrf)# ipv4 multicast multitoplogy 
     

    Enables IPv4 multicast support for multi-topology routing (MTR) in a VRF instance.

     
    Step 6 address-family ipv4


    Example:
    Device(config-vrf)# address-family ipv4
     

    Specifies the IPv4 address family type and enters address family configuration mode.

     
    Step 7 exit-address-family


    Example:
    Device(config-vrf-af)# exit-address-family
     

    Exits address family configuration mode and removes the IPv4 address family.

     
    Step 8 address-family ipv4 multicast


    Example:
    Device(config-vrf)# address-family ipv4 multicast
     

    Specifies the IPv4 address family multicast type and enters VRF address family configuration mode.

     
    Step 9 topology topology-instance-name


    Example:
    Device(config-vrf-af)# topology red
     

    Specifies a topology instance and a name to it and enters VRF address family topology configuration mode.

     
    Step 10 all-interfaces


    Example:
    Device(config-vrf-af-topology)# all-interfaces
     

    Configure the topology instance to use all interfaces on the device.

     
    Step 11 exit


    Example:
    Device(config-vrf-af-topology)# exit
     

    Exits VRF address-family topology configuration mode and enters VRF address-family configuration mode.

     
    Step 12 exit-address-family


    Example:
    Device(config-vrf-af)# exit-address-family
     

    Exits address family configuration mode and removes the IPv4 address family.

     
    Step 13 exit


    Example:
    Device(config-vrf)# exit
     

    Exits VRF configuration mode and enters global configuration mode.

     
    Step 14 interface type number


    Example:
    Device(config)# interface ethernet 0/1
     

    Selects the Ethernet interface and enters the interface configuration mode.

     
    Step 15 interface type number


    Example:
    Device(config)# interface ethernet 0/1
     

    Selects the Ethernet interface and enters the interface configuration mode.

     
    Step 16 vrf forwarding vrf-name


    Example:
    Device(config-if)# vrf forwwarding vrf1
     

    Associates a VRF instance with the interface.

     
    Step 17 ip address ip-address mask


    Example:
    Device(config-if)# ip address 10.1.10.1 255.255.255.0
     

    Sets a primary or secondary IP address for an interface.

     
    Step 18 ip pim sparse-dense-modeip


    Example:
    Device(config-if)# ip pim sparse-dense-mode
     

    Enables Protocol Independent Multicast (PIM) on an interface.

     
    Step 19 end


    Example:
    Device(config-if)# end
     

    Exits the interface configuration mode and enters privileged EXEC mode.

     

    Configuring Examples for MTR in VRF

    Example for MTR in VRF

    Device> enable
    Device# configuration terminal
    Device(config)# vrf definition vd1
    Device(config-vrf)# rd 10:1
    Device(config-vrf)# ipv4 multicast multitoplogy
    Device(config-vrf)# address-family ipv4
    Device(config-vrf)# exit-address-family
    Device(config-vrf)# address-family ipv4 multicast
    Device(config-vrf-af)# topology red
    Device(config-vrf-af-topology)# all-interfaces
    Device(config-vrf-af-topology)# exit
    Device(config-vrf-af)# exit-address-family
    Device(config-vrf)# exit
    Device(config)# vrf forwarding vrf1
    Device(config)# ip address 10.1.10.1 255.255.255.0
    Device(config)# ip pim sparse-dense-mode
    Device(config)# end
    

    Additional References for MTR in VRF

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    Multitopology Routing (MTR) commands

    Cisco IOS Multitopology Routing Command Reference

    IP multicast commands

    Cisco IOS Multicast Command Reference

    IP multicast concepts and tasks

    IP Multicast Configuration Guide Library

    Technical Assistance

    Description Link

    The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

    To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

    Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​support

    Feature Information for MTR in VRF

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for MTR in VRF

    Feature Name

    Releases

    Feature Information

    MTR in VRF

    Cisco IOS Release 15.4(1)S

    The MTR in VRF feature extends to IPv4 VRF contexts the Cisco IOS software's capability that allows users to configure one or more non-congruent multicast topologies in global IPv4 routing context. These contexts can be used to forward unicast and multicast traffic over different links in the network, or in the case of non-base topologies to provide a Live-Live multicast service using multiple non-congruent multicast topologies mapped to different (S,G) groups.