MPLS Layer 2 VPNs Configuration Guide, Cisco IOS XE Release 3S
Loop-Free Alternate Fast Reroute with L2VPN
Downloads: This chapterpdf (PDF - 1.32MB) The complete bookPDF (PDF - 8.27MB) | The complete bookePub (ePub - 2.03MB) | Feedback

Loop-Free Alternate Fast Reroute with L2VPN

Loop-Free Alternate Fast Reroute with L2VPN

The Loop-Free Alternate (LFA) Fast Reroute (FRR) with Layer 2 Virtual Private Network (L2VPN) feature minimizes packet loss due to link or node failure.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for Loop-Free Alternate Fast Reroute with L2VPN

  • Load balancing is not supported
  • Time-division multiplexing (TDM) pseudowire is not supported
  • Virtual Private LAN Services (VPLS) is not supported
  • The Virtual Private Wire Services (VPWS) scale number might change

Information About Loop-Free Alternate Fast Reroute with L2VPN

L2VPN Over Loop-Free Alternate Fast Reroute

The Loop-Free Alternate (LFA) Fast Reroute (FRR) feature offers an alternative to the MPLS Traffic Engineering Fast Reroute feature to minimize packet loss due to link or node failure. It introduces LFA FRR support for L2VPNs and Virtual Private Wire Services (VPWS), providing the following benefits:

  • Same level of protection from traffic loss
  • Simplified configuration
  • Link and node protection
  • Link and path protection
  • LFA (loop-free alternate) paths
  • Support for both IP and Label Distribution Protocol (LDP) core

LFA FRR enables a backup route to avoid traffic loss if a network fails. The backup routes (repair paths) are precomputed and installed in the router as the backup for the primary paths. After the router detects a link or adjacent node failure, it switches to the backup path to avoid traffic loss.

How to Configure Loop-Free Alternate Fast Reroute with L2VPN

To enable loop-free alternate fast reroute support for L2VPNs and VPWS, you must configure LFA FRR for the routing protocol. No additional configuration tasks are necessary. See one of the following documents, depending on the routing protocol:

Verifying Loop-Free Alternate Fast Reroute with L2VPN

Use one or more of the following commands to verify the LFA FRR configuration:

SUMMARY STEPS

    1.    show ip cef network-prefix internal

    2.    show mpls infrastructure lfd pseudowire internal

    3.    show platform hardware pp active feature cef database ipv4 network-prefix


DETAILED STEPS
    Step 1   show ip cef network-prefix internal


    Example:
    show ip cef 16.16.16.16 internal

    Displays entries in the Cisco Express Forwarding (CEF) Forwarding Information Base (FIB).

    Step 2   show mpls infrastructure lfd pseudowire internal


    Example:
    show mpls infrastructure lfd pseudowire internal

    Displays information about the Label Forwarding Database (LFD) and pseudowires.

    Step 3   show platform hardware pp active feature cef database ipv4 network-prefix


    Example:
    show platform hardware pp active feature cef database ipv4 16.16.16.16/32

    Displays information about the CEF database.


    Configuration Examples for Loop-Free Alternate Fast Reroute with L2VPN

    Example: Verifying LFA FRR with L2VPN

    show ip cef internal

    The following example shows the configuration of LFA FRR for OSPF:

    router ospf 1
     router-id 17.17.17.17
     fast-reroute per-prefix enable prefix-priority low
     network 3.3.3.0 0.0.0.255 area 1
     network 6.6.6.0 0.0.0.255 area 1
     network 7.7.7.0 0.0.0.255 area 1
     network 17.17.17.17 0.0.0.0 area 1
    

    show ip cef internal

    The following is sample output from the show ip cef internal command:

    Device# show ip cef 16.16.16.16 internal 
    16.16.16.16/32, epoch 2, RIB[I], refcount 7, per-destination sharing
      sources: RIB, RR, LTE 
      feature space:
       IPRM: 0x00028000
       Broker: linked, distributed at 1st priority
       LFD: 16.16.16.16/32 1 local label
       local label info: global/17
            contains path extension list
            disposition chain 0x3A3C1DF0
            label switch chain 0x3A3C1DF0
      subblocks:
       1 RR source [no flags]
        non-eos chain [16|44]
      ifnums:
       GigabitEthernet0/0/2(9): 7.7.7.2
       GigabitEthernet0/0/7(14): 7.7.17.9
      path 35D61070, path list 3A388FA8, share 1/1, type attached nexthop, for IPv4, flags has-repair
        MPLS short path extensions: MOI flags = 0x20 label 16
      nexthop 7.7.7.2 GigabitEthernet0/0/2 label [16|44], adjacency IP adj out of GigabitEthernet0/0/2, addr 7.7.7.2 35E88520
        repair: attached-nexthop 7.7.17.9 GigabitEthernet0/0/7 (35D610E0)
      path 35D610E0, path list 3A388FA8, share 1/1, type attached nexthop, for IPv4, flags repair, repair-only
      nexthop 7.7.17.9 GigabitEthernet0/0/7, repair, adjacency IP adj out of GigabitEthernet0/0/7, addr 7.7.17.9 3A48A4E0
      output chain: label [16|44]
      FRR Primary (0x35D10F60)
      <primary:  TAG adj out of GigabitEthernet0/0/2, addr 7.7.7.2 35E88380>
      <repair:  TAG adj out of GigabitEthernet0/0/7, addr 7.7.17.9 3A48A340>
    Rudy17#show mpls infrastructure lfd pseudowire internal
    PW ID: 1VC ID: 4, Nexthop address: 16.16.16.16
    SSM Class: SSS HW
    Segment Count: 1
    VCCV Types Supported:  cw ra ttl
    Imposition details:
     Label stack {22 16}, Output interface: Gi0/0/2
     Preferred path: not configured
     Control Word: enabled, Sequencing: disabled
     FIB Non IP entry: 0x35D6CEEC
     Output chain:  AToM Imp (locks 4) label 22 label [16|44]
      FRR Primary (0x35D10F60)
      <primary:  TAG adj out of GigabitEthernet0/0/2, addr 7.7.7.2 35E88380>
    Disposition details:
     Local label: 16
     Control Word: enabled, Sequencing: disabled
     SSS Switch: 3976200193
     Output chain:  mpls_eos( connid router-alert AToM Disp (locks 5)/ drop)
    

    show mpls infrastructure lfd pseudowire internal

    The following is sample output from the show mpls infrastructure lfd pseudowire internal command:

    Device# show mpls infrastructure lfd pseudowire internal
    PW ID: 1VC ID: 4, Nexthop address: 16.16.16.16
    SSM Class: SSS HW
    Segment Count: 1
    VCCV Types Supported:  cw ra ttl
    Imposition details:
     Label stack {22 16}, Output interface: Gi0/0/2
     Preferred path: not configured
     Control Word: enabled, Sequencing: disabled
     FIB Non IP entry: 0x35D6CEEC
     Output chain:  AToM Imp (locks 4) label 22 label [16|44]
      FRR Primary (0x35D10F60)
      <primary:  TAG adj out of GigabitEthernet0/0/2, addr 7.7.7.2 35E88380>
    Disposition details:
     Local label: 16
     Control Word: enabled, Sequencing: disabled
     SSS Switch: 3976200193
     Output chain:  mpls_eos( connid router-alert AToM Disp (locks 5)/ drop)
    

    show platform hardware pp active feature cef database

    The following is sample output from the show platform hardware pp active feature cef database command:

    Device# show platform hardware pp active feature cef database ipv4 16.16.16.16/32
    === CEF Prefix ===
    16.16.16.16/32 -- next hop: UEA Label OCE (PI:0x104abee0, PD:0x10e6b9c8)
                    Route Flags: (0) 
                    Handles (PI:0x104ab6e0) (PD:0x10e68140)
     
      HW Info:
        TCAM handle: 0x0000023f    TCAM index: 0x0000000d
        FID index  : 0x0000f804    EAID      : 0x0000808a
        MET        : 0x0000400c    FID Count : 0x00000000
    
    === Label OCE ===
      Label flags: 4
      Num Labels: 1
      Num Bk Labels: 1
      Out Labels: 16
      Out Backup Labels: 44
      Next OCE Type: Fast ReRoute OCE; Next OCE handle: 0x10e6f428
    
    === FRR OCE ===
      FRR type         : IP FRR
      FRR state        : Primary
      Primary IF's gid : 3
      Primary FID      : 0x0000f801
      FIFC entries     : 32
      PPO handle       : 0x00000000
      Next OCE         : Adjacency (0x10e63b38)
      Bkup OCE         : Adjacency (0x10e6e590)
    
    === Adjacency OCE ===
      Adj State: COMPLETE(0)   Address: 7.7.7.2 
      Interface: GigabitEthernet0/0/2   Protocol: TAG 
      mtu:1500, flags:0x0, fixups:0x0, encap_len:14 
      Handles (adj_id:0x00000039) (PI:0x1041d410) (PD:0x10e63b38) 
      Rewrite Str: d0:c2:82:17:8a:82:d0:c2:82:17:f2:02:88:47
     
      HW Info:
        FID index: 0x0000f486    EL3 index: 0x00001003    EL2 index: 0x00000000
        El2RW    : 0x00000107    MET index: 0x0000400c    EAID     : 0x00008060
        HW ADJ FLAGS: 0x40
        Hardware MAC Rewrite Str: d0:c2:82:17:8a:82:08:00:40:00:0d:02
    
    === Adjacency OCE ===
      Adj State: COMPLETE(0)   Address: 7.7.17.9 
      Interface: GigabitEthernet0/0/7   Protocol: TAG 
      mtu:1500, flags:0x0, fixups:0x0, encap_len:14 
      Handles (adj_id:0x00000012) (PI:0x104acbd0) (PD:0x10e6e590) 
      Rewrite Str: d0:c2:82:17:c9:83:d0:c2:82:17:f2:07:88:47
     
      HW Info:
        FID index: 0x0000f49d    EL3 index: 0x00001008    EL2 index: 0x00000000
        El2RW    : 0x00000111    MET index: 0x00004017    EAID     : 0x0000807d
        HW ADJ FLAGS: 0x40
        Hardware MAC Rewrite Str: d0:c2:82:17:c9:83:08:00:40:00:0d:07
    
    

    Example: Configuring Remote LFA FRR with VPLS

    Example: Configuration of Remote LFA FRR with Interior Gateway Protocol (IGP)

    router isis hp
     net 49.0101.0000.0000.0802.00
     is-type level-2-only
     ispf level-2
     metric-style wide
     fast-flood
     set-overload-bit on-startup 180
     max-lsp-lifetime 65535
     lsp-refresh-interval 65000
     spf-interval 5 50 200
     prc-interval 5 50 200
     lsp-gen-interval 5 5 200
     no hello padding
     log-adjacency-changes
     nsf cisco
     fast-reroute per-prefix level-1 all
     fast-reroute per-prefix level-2 all
     fast-reroute remote-lfa level-1 mpls-ldp
     fast-reroute remote-lfa level-2 mpls-ldp
     passive-interface Loopback0
     mpls ldp sync
     mpls traffic-eng router-id Loopback0
     mpls traffic-eng level-2
     

    Example: Configuration of Remote LFA FRR with VPLS at the interface level.

    !
    interface GigabitEthernet0/3/3
     ip address 198.51.100.1 255.255.255.0
     ip router isis hp
     logging event link-status
     load-interval 30
     negotiation auto
     mpls ip
     mpls traffic-eng tunnels
     isis network point-to-point 
    end
    !

    Example: Configuration of remote LFA FRR with VPLS at the global level.

    !
    l2 vfi Test-2000 manual 
     vpn id 2010
     bridge-domain 2010
     neighbor 192.0.2.1 encapsulation mpls
    !

    Example: Configuration of remote LFA FRR with VPLS at Access side.

    !
    interface TenGigabitEthernet0/2/0
     no ip address
     service instance trunk 1 ethernet
      encapsulation dot1q 12-2012
      rewrite ingress tag pop 1 symmetric
      bridge-domain from-encapsulation
     !

    Example: Verifying Remote LFA FRR with VPLS

    show ip cef internal

    The following is sample output from the show ip cef internal command:

    Router# show ip cef 198.51.100.2/32 internal
    
    198.51.100.2/32, epoch 2, RIB[I], refcount 7, per-destination sharing
      sources: RIB, RR, LTE 
      feature space:
       IPRM: 0x00028000
       Broker: linked, distributed at 1st priority
       LFD: 198.51.100.2/32 1 local label
       local label info: global/2033
            contains path extension list
            disposition chain 0x46764E68
            label switch chain 0x46764E68
      subblocks:
       1 RR source [heavily shared]
        non-eos chain [explicit-null|70]
      ifnums:
       TenGigabitEthernet0/1/0(15): 192.0.2.10
       MPLS-Remote-Lfa2(46)
      path 44CE1290, path list 433CF8C0, share 1/1, type attached nexthop, for IPv4, flags has-repair
        MPLS short path extensions: MOI flags = 0x21 label explicit-null
      nexthop 192.0.2.10 TenGigabitEthernet0/1/0 label [explicit-null|70], adjacency IP adj out of TenGigabitEthernet0/1/0, addr 192.0.2.10 404B3960
        repair: attached-nexthop 192.0.2.1 MPLS-Remote-Lfa2 (44CE1300)
      path 44CE1300, path list 433CF8C0, share 1/1, type attached nexthop, for IPv4, flags repair, repair-only
      nexthop 192.0.2.1 MPLS-Remote-Lfa2, repair, adjacency IP midchain out of MPLS-Remote-Lfa2 404B3B00
      output chain: label [explicit-null|70]
      FRR Primary (0x3E25CA00)
      <primary:  TAG adj out of TenGigabitEthernet0/1/0, addr 192.168.101.22 404B3CA0>
      <repair:  TAG midchain out of MPLS-Remote-Lfa2 404B37C0 label 37 TAG adj out of GigabitEthernet0/3/3, addr 192.0.2.14 461B2F20>
    

    show ip cef detail

    The following is sample output from the show ip cef detail command:

    Router# show ip cef 198.51.100.2/32 detail
    
    198.51.100.2/32, epoch 2
      local label info: global/2033
      1 RR source [heavily shared]
      nexthop 192.0.2.14 TenGigabitEthernet0/1/0 label [explicit-null|70]
        repair: attached-nexthop 192.0.2.1 MPLS-Remote-Lfa2
      nexthop 192.0.2.1 MPLS-Remote-Lfa2, repair
    !
    

    show platform hardware pp active feature cef databas

    The following is sample output from the show platform hardware pp active feature cef database command:

    Router# show platform hardware pp active feature cef database ipv4 198.51.100.2/32
    
    === CEF Prefix ===
    198.51.100.2/32 -- next hop: UEA Label OCE (PI:0x10936770, PD:0x12dd1cd8)
                    Route Flags: (0) 
                    Handles (PI:0x109099c8) (PD:0x12945968)
     
      HW Info:
        TCAM handle: 0x00000266    TCAM index: 0x00000015
        FID index  : 0x00008e7f    EAID      : 0x0001d7c4
        MET        : 0x0000401c    FID Count : 0x00000000
    === Label OCE ===
      Label flags: 4
      Num Labels: 1
      Num Bk Labels: 1
      Out Labels: 0
      Out Backup Labels: 70
    === FRR OCE ===
      FRR type         : IP FRR
      FRR state        : Primary
      Primary IF's gid : 52
      Primary FID      : 0x00008cb6
      FIFC entries     : 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0
      PPO handle       : 0x00000000
      Next OCE         : Adjacency (0x130e0df0)
      Bkup OCE         : Adjacency (0x130de608)
    
    === Adjacency OCE ===
      Adj State: COMPLETE(0)   Address: 192.168.101.22 
      Interface: TenGigabitEthernet0/1/0   Protocol: TAG 
      mtu:1500, flags:0x0, fixups:0x0, encap_len:14 
      Handles (adj_id:0x000016ac) (PI:0x1090cc10) (PD:0x130e0df0) 
      Rewrite Str: 18:33:9d:3d:83:10:c8:f9:f9:8d:04:10:88:47
    HW Info:
        FID index: 0x00008e7e    EL3 index: 0x00001034    EL2 index: 0x00000000
        El2RW    : 0x0000010d    MET index: 0x00004012    EAID     : 0x0001d7c1
        HW ADJ FLAGS: 0x40
        Hardware MAC Rewrite Str: 18:33:9d:3d:83:10:08:00:40:00:0d:10
    === Adjacency OCE ===
      Adj State: COMPLETE(0)   Address: 0 
      Interface: MPLS-Remote-Lfa2   Protocol: TAG 
      mtu:17940, flags:0x40, fixups:0x0, encap_len:0 
      Handles (adj_id:0xf80002e8) (PI:0x10da2150) (PD:0x130de608) 
      Rewrite Str: 
     
      HW Info:
        FID index: 0x00008ca8    EL3 index: 0x0000101c    EL2 index: 0x00000000
        El2RW    : 0x00000003    MET index: 0x00004024    EAID     : 0x0001d7cb
        HW ADJ FLAGS: 0x40
        Hardware MAC Rewrite Str: 00:00:00:00:00:00:00:00:00:00:00:00
    
    === Label OCE ===
      Label flags: 4
      Num Labels: 1
    Num Bk Labels: 1
      Out Labels: 37
      Out Backup Labels: 37
      Next OCE Type: Adjacency; Next OCE handle: 0x12943a00
    === Adjacency OCE ===
      Adj State: COMPLETE(0)   Address: 30.1.1.1 
      Interface: GigabitEthernet0/3/3   Protocol: TAG 
      mtu:1500, flags:0x0, fixups:0x0, encap_len:14 
      Handles (adj_id:0x0000378e) (PI:0x10909738) (PD:0x12943a00) 
      Rewrite Str: c8:f9:f9:8d:01:b3:c8:f9:f9:8d:04:33:88:47
     
      HW Info:
        FID index: 0x00008c78    EL3 index: 0x0000101c    EL2 index: 0x00000000
        El2RW    : 0x00000109    MET index: 0x0000400e    EAID     : 0x0001cf4b
        HW ADJ FLAGS: 0x40
        Hardware MAC Rewrite Str: c8:f9:f9:8d:01:b3:08:00:40:00:0d:33
    
    

    show mpls l2transport detail

    The following is sample output from the show mpls l2transport detail command:

    Router# show mpls l2transport vc 2000 detail
    
    Local interface: VFI Test-1990 vfi up
      Interworking type is Ethernet
      Destination address: 192.0.2.1, VC ID: 2000, VC status: up
        Output interface: Te0/1/0, imposed label stack {0 2217}
        Preferred path: not configured  
        Default path: active
        Next hop: 192.51.100.22
      Create time: 1d08h, last status change time: 1d08h
        Last label FSM state change time: 1d08h
      Signaling protocol: LDP, peer 192.0.51.1:0 up
        Targeted Hello: 192.51.100.2(LDP Id) -> 192.51.100.200, LDP is UP
        Graceful restart: configured and enabled
        Non stop routing: not configured and not enabled
        Status TLV support (local/remote)   : enabled/supported
          LDP route watch                   : enabled
          Label/status state machine        : established, LruRru
          Last local dataplane   status rcvd: No fault
          Last BFD dataplane     status rcvd: Not sent
          Last BFD peer monitor  status rcvd: No fault
          Last local AC  circuit status rcvd: No fault
          Last local AC  circuit status sent: No fault
          Last local PW i/f circ status rcvd: No fault
          Last local LDP TLV     status sent: No fault
          Last remote LDP TLV    status rcvd: No fault
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Command List, All Releases

    MPLS commands

    Multiprotocol Label Switching Command Reference

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for Loop-Free Alternate Fast Reroute with L2VPN

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for Loop-Free Alternate Fast Reroute with L2VPN

    Feature Name

    Releases

    Feature Information

    Loop-Free Alternate Fast Reroute with L2VPN

    15.3(2)S

    Cisco IOS XE Release 3.9S

    Cisco IOS XE Release 3.10 S

    This feature introduces loop-free alternate (LFA) fast reroute (FRR) support for Layer 2 VPN (L2VPN) and Virtual Private Wire Services (VPWS) to minimize packet loss due to link or node failure.

    No commands were introduced or modified.

    In Cisco IOS XE Release 3.9S, support was added for the Cisco ASR 903 Router.

    In Cisco IOS XE Release 3.10S, Remote LFA FRR is supported on ATM (IMA) and TDM pseudowires for the Cisco ASR 903 Router.

    In Cisco IOS XE Release 3.10S, Remote LFA FRR is supported over VPLS for Cisco ASR 903 Router.