Guest

Support

BFD for RIPv2 Support

Hierarchical Navigation

  • Viewing Options

  • PDF (109.1 KB)
  • Feedback
BFD for RIPv2 Support

BFD for RIPv2 Support

Last Updated: November 27, 2012

The BFD for RIPv2 Support feature is used to facilitate an alternate path selection when a neighboring router is inactive.

Routing Information Protocol (RIP) uses the timeout of prefixes of a particular neighbor to identify if a neighbor is inactive. By default, the timeout is 180 seconds; that is, although the next-hop router is inactive, the RIP router will still broadcast prefixes for up to 180 seconds.

Bidirectional Forward Detection (BFD) is a protocol that provides subsecond failure detection using a single, common standardized mechanism that is independent of media and routing protocols.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for BFD for RIPv2 Support

BFD is independent of RIPv2 and must be enabled and functional on the router.

How to Configure BFD for RIPv2 Support Feature

Configuring BFD on RIPv2 Neighbors

Perform this task toconfigure BFD on RIPv2 neighbors:

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router rip

4.    bfd all-interfaces

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
router rip


Example:

Router(config)# router rip

 

Configures the RIP routing process and enters router configuration mode.

 
Step 4
bfd all-interfaces


Example:

Router(config-router)# bfd all-interfaces

 

Enables BFD on all interfaces associated with the routing process.

  • RIPv2 registers with BFD and creates sessions for the neighbor when RIP updates are received. New neighbors are automatically enabled for BFD when the update packets are received.
Note    Alternatively, you can use the neighbor ip-address bfdcommand to enable BFD for a specific RIP neighbor.
 
Step 5
end


Example:

Router(config-router)# end

 

Exits router configuration mode and returns to global configuration mode.

 

Configuration Example for BFD for RIPv2 Support Feature

Example Configuring BFD for a RIPv2 Neighbor

The following example shows how to configure BFD for all interfaces associated with a RIPv2 neighbor:

!
interface GigabitEthernet 0/0/0
 ip address 10.10.10.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 5
end
!
interface GigabitEthernet 0/0/1
 ip address 10.10.20.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 5
end
!
router rip
 version 2
 redistribute connected
 network 10.0.0.0
 neighbor 10.10.20.2 bfd
 bfd all-interfaces
 no auto-summary
!

Additional References

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Cisco IOS IP Routing: Protocol-Independent Commands

Cisco IOS IP Routing: Protocol-Independent Command Reference

Standards

Standard

Title

None

--

MIBs

MIB

MIBs Link

None

--

RFCs

RFC

Title

None

--

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for BFD for RIPv2 Support

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for BFD for RIPv2 Support

Feature Name

Releases

Feature Information

BFD for RIPv2 Support

15.1(2)S

The BFD for RIPv2 Support feature is used to facilitate alternate path selection when a neighboring router is inactive.

The following commands were introduced or modified: bfd all-interfaces, debug ip rip bfd events, neighbor (RIP),and show ip rip neighbor.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.