IP Routing: ISIS Configuration Guide, Cisco IOS Release 15SY
Reducing Alternate-Path Calculation Times in IS-IS Networks
Downloads: This chapterpdf (PDF - 325.0KB) The complete bookPDF (PDF - 1.49MB) | Feedback

IS-IS Support for Route Tags

Contents

IS-IS Support for Route Tags

Last Updated: October 15, 2012

The IS-IS Support for Route Tags feature enables you to tag Intermediate System-to-Intermediate System (IS-IS) route prefixes and use those tags in a route map to control IS-IS route redistribution or route leaking. The results are network scalability and faster convergence for device updates.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for IS-IS Support for Route Tags

Because the Intermediate System-to-Intermediate System (IS-IS) route tag will be used in a route map, you must understand how to configure a route map.

To use the route tag, you must configure the metric-style wide command. (The metric-style narrow command is configured by default.) The tag value is set into sub-TLV 1 for type, length, values (TLV) Type 135.

You must understand the task for which you are using the route tag, such as route redistribution, route summarization, or route leaking.

You should be familiar with the concepts described in the "Overview of IS-IS Fast Convergence" module.

Before you tag any IS-IS routes, you need to make the following decisions:

  • Your goal to set values for routes or redistribute routes (or both).
  • Where in your network you want to tag routes.
  • Where in your network you want to reference the tags.
  • Which tagging method you will use. This method determines which task to perform.

Information About IS-IS Support for Route Tags

Route Redistribution

Devices are allowed to redistribute external prefixes, or routes, that are learned from any other routing protocol, static configuration, or connected interfaces. The redistributed routes are allowed in either a Level 1 device or a Level 2 device. Level 2 routes injected as Level 1 routes is called route leaking.

IS-IS Caching of Redistributed Routes

Intermediate System-to-Intermediate System (IS-IS) caches routes that are redistributed from other routing protocols or from another IS-IS level into a local redistribution cache that is maintained by IS-IS. Caching occurs automatically and requires no configuration. The caching of redistributed routes improves IS-IS convergence time when routes are being redistributed into IS-IS. IS-IS caching of redistributed routes increases the performance of link-state packet (LSP) protocol data unit (PDU) generation, significantly improving network scalability.

Prioritize the Update of IP Prefixes in the RIB to Reduce Alternate-Path Calculation Time

The time needed for the IS-IS Routing Information Base (RIB) or routing table to update depends on the number of changed Intermediate System-to-Intermediate System (IS-IS) prefixes or routes that must be updated. You can tag important IS-IS IP prefixes and configure the device to give priority to the tagged prefixes so that high-priority prefixes are updated first in the RIB. For example, the loopback addresses for the devices in a Multiprotocol Label Switching (MPLS) VPN environment are considered high-priority prefixes.

IS-IS Priority-Driven IP Prefix RIB Installation

In a network where devices run the Intermediate System-to-Intermediate System (IS-IS) protocol, convergence is achieved when a consistent view of the topology is distributed to all devices in the network. When a network event causes a topology change, a number of steps must occur in order for convergence to occur. The device that initially detects the topology change (for example, an interface state change) must inform other devices of the topology change by flooding updated routing information (in the form of link-state protocol data units [PDUs]) to other devices. All devices, including the device that detected the topology change, must utilize the updated topology information to recompute shortest paths (run a shortest path first [SPF]), providing the updated output of the SPF calculation to the device's routing information base (RIB), which eventually causes the updated routing information to be used to forward packets. Until all devices have performed these basic steps, some destinations might be temporarily unreachable. Faster convergence benefits the network performance by minimizing the period of time during which stale topology information--the previous routing information that will be obsoleted by the updated routing information--is used to forward packets.

After performing an SPF, IS-IS must install updated routes in the RIB. If the number of prefixes advertised by IS-IS is large, the time between the installation of the first prefix and the last prefix is significant. Priority-driven IP prefix RIB installation allows a subset of the prefixes advertised by IS-IS to be designated as having a higher priority. Updates to the paths to these prefixes are installed before updates to prefixes that do not have this designation. Priority-driven IP prefixes reduce the convergence time for the important IS-IS IP prefixes and results in faster updating for routes that are dependent on these prefixes. Faster updates shortens the time during which stale information is used for forwarding packets to these destinations.

Prefixes are characterized as having one of three levels of importance:

  1. High-priority prefixes--prefixes that are tagged with a tag designated for fast convergence.
  2. Medium-priority prefixes--any /32 prefixes that are not designated as high-priority prefixes.
  3. Low-priority prefixes--all other prefixes.

When IS-IS updates the RIB, prefixes are updated in the order based on the associated level of importance.

When you assign a high-priority tag to some IS-IS IP prefixes, those prefixes with the higher priority are updated in the routing tables before prefixes with lower priority. In some networks, the high-priority prefixes are the provider edge (PE) loopback addresses. The convergence time is reduced for the important IS-IS IP prefixes and results in reduced convergence time for the update processes that occur in the global RIB and Cisco Express Forwarding.

IS-IS Routes Tagged to Control Their Redistribution

You can control the redistribution of Intermediate System-to-Intermediate System (IS-IS) routes by tagging them. The term "route leaking" refers to controlling distribution through tagging of routes.

How Route Summarization Can Enhance Scalability in IS-IS Networks

Summarization is a key factor that enhances the scalability of a routing protocol. Summarization reduces the number of routing updates that are flooded across areas or routing domains. For example, in multiarea Intermediate System-to-Intermediate System (IS-IS) networks, a good addressing scheme can optimize summarization by not allowing an overly large Level 2 database to be unnecessarily populated with updates that have come from Level 1 areas.

A device can summarize prefixes on redistribution whether the prefixes have come from internal prefixes, local redistribution, or Level 1 device redistribution. Routes that have been leaked from Level 2 to Level 1 and routes that are advertised into Level 2 from Level 1 can also be summarized.

Benefits of IS-IS Route Tags

The IS-IS Support for Route Tags feature allows you to tag IP addresses of an interface and use the tag to apply administrative policy with a route map.

You can tag Intermediate System-to-Intermediate System (IS-IS) routes to control their redistribution. You can configure a route map to set a tag for an IS-IS IP prefix (route) or match on the tag (perhaps on a different device) to redistribute IS-IS routes. Although the match tag and set tag commands existed for other protocols before the IS-IS Support for Route Tags feature, they were not implemented for IS-IS, so they did nothing when specified in an IS-IS network.

You can tag a summary route and then use a route map to match the tag and set one or more attributes for the route.

IS-IS Route Tag Characteristics

An Intermediate System-to-Intermediate System (IS-IS) route tag number can be up to 4 bytes long. The tag value is set into a sub-TLV 1 for type, length, values (TLV) Type 135.

Only one tag can be set to an IS-IS IP route (prefix). The tag is sent in link-state packet (LSP) protocol data units (PDUs) advertising the route. Setting a tag to a route alone does nothing for your network. You can use the route tag at area or Level 1/Level 2 boundaries by matching on the tag and then applying administrative policies such as redistribution, route summarization, or route leaking.

Configuring a tag for an interface (with the isis tag command) triggers the generation of new LSPs from the device because the tag is new information for the PDUs.

IS-IS Route Leaking Based on a Route Tag

You can tag Intermediate System-to-Intermediate System (IS-IS) routes to configure route leaking (redistribution). Because only the appropriate routes are redistributed--or leaked--the results is network scalability and faster convergence for the device update. If you configure route leaking and you want to match on a tag, use a route map (not a distribute list).

There are two general steps to using IS-IS route tags: tagging routes and referencing the tag to set values for the routes or redistribute routes.

There are three ways to tag IS-IS routes: tag routes for networks directly connected to an interface, set a tag in a route map, or tag a summary route. The tagging method is independent of how you use the tag.

After you tag the routes, you can use the tag to set values (such as metric, next hop, and so on) or redistribute routes. You might tag routes on one device, but reference the tag on other devices, depending on what you want to achieve. For example, you could tag the interface on Device A with a tag, match the tag on Device B to set values, and redistribute routes on Device C based on values using a route map.

Limit the Number of Routes That Are Redistributed into IS-IS

If you mistakenly inject a large number of IP routes into an Intermediate System-to-Intermediate System (IS-IS), perhaps by redistributing Border Gateway Protocol (BGP) into IS-IS, the network can be severely flooded. You can limit the number of redistributed routes prevents this potential problem. You can either configure IS-IS to stop allowing routes to be redistributed once your maximum configured value is reached or configure the software to generate a system warning once the number of redistributed prefixes reaches the maximum value.

In some cases when a limit is not placed on the number of redistributed routes, the link-state packet (LSP) might become full and routes might be dropped. You can specify which routes should be suppressed in that event so that the consequence of an LSP full state is handled in a graceful and predictable manner.

Redistribution is usually the cause of the LSP full state. By default, external routes redistributed into IS-IS are suppressed if the LSP full state occurs. IS-IS can have 255 fragments for an LSP in a level. When no space is left in any of the fragments, an LSPFULL error message is generated.

Once the problem that caused the LSP full state is resolved, you can clear the LSPFULL state.


Note


You cannot both limit redistributed prefixes and also choose to be warned only.

Streamline the Routing Table Update Process by Excluding Connected IP Prefixes from LSP Advertisements

To speed up Intermediate System-to-Intermediate System (IS-IS) convergence time, limit the number of IP prefixes carried in link-state packets (LSPs). Configuring interfaces as unnumbered will limit the prefixes. However, for network management reasons, you might want to have numbered interfaces and also want to prevent advertising interface addresses into IS-IS. Two alternative methods avoid the overpopulation of routing tables and thereby reduce IS-IS convergence time. To choose the method that works best for your network type, you should become familiar with the concepts described in the following sections:

Small-Scale Method to Reduce IS-IS Convergence Time

You can explicitly configure an Intermediate System-to-Intermediate System (IS-IS) interface not to advertise its IP network to the neighbors (by using the no isis advertise-prefix command). This method is feasible for a small network; it does not scale well. If you have dozens or hundreds of devices in your network, with possibly ten times as many physical interfaces involved, adding this command to each device's configuration is not practical.

Large-Scale Method to Reduce IS-IS Convergence Time

A way to reduce Intermediate System-to-Intermediate System (IS-IS) convergence is to configure the IS-IS instance on a device to advertise only passive interfaces (by using the advertise-passive-only command). This command relies on the fact that a user enabling IS-IS on a loopback interface usually configures the loopback as passive (to prevent sending unnecessary hello PDUs through it because there is no chance of finding a neighbor behind it). Thus, if you want to advertise only the loopback and if it has already been configured as passive, configuring the advertise-passive-only command per IS-IS instance would prevent the overpopulation of the routing tables.

Benefit of Excluding IP Prefixes of Connected Networks in LSP Advertisements

Whether you choose to prevent the advertising of Intermediate System-to-Intermediate System (IS-IS) interface subnetworks or to advertise only the IS-IS prefixes that belong to passive (loopback) interfaces, you will reduce IS-IS convergence time. The IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements feature is recommended in any case where fast convergence is required.

How to Configure IS-IS Support for Route Tags

Configuring IS-IS Incremental SPF

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router isis [area-tag]

4.    ispf [level-1 | level-2 | level-1-2] [seconds]

5.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
router isis [area-tag]


Example:

Device(config)# router isis

 

Enables Intermediate System-to-Intermediate System (IS-IS) as an IP routing protocol and assigns a tag to a process, if required.

  • Enters router configuration mode.
 
Step 4
ispf [level-1 | level-2 | level-1-2] [seconds]


Example:

Device(config-router)# ispf level-1-2 60

 

Enables IS-IS incremental SPF.

  • The seconds argument represents the number of seconds after configuring this command that incremental SPF is activated. The range is 1 to 600. The default value is 120 seconds. The seconds argument applies only when you have enabled IS-IS.
 
Step 5
end


Example:

Device(config-router)# end

 

Returns to privileged EXEC mode.

 

Assigning a High Priority Tag to an IS-IS IP Prefix

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    ip router isis [area-tag]

5.    isis tag tag-value

6.    exit

7.    router isis [area-tag]

8.    ip route priority high tag tag-value

9.    end

10.    show isis rib [ip-address | ip-address-mask]


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface Ethernet 0

 

Configures an interface type and enters interface configuration mode.

 
Step 4
ip router isis [area-tag]


Example:

Router(config-if)# ip router isis tag13

 

Enables IS-IS as an IP routing protocol, and assigns a tag to a process, if required.

Note    If the area-tag argument is not specified, a null tag is assumed and the process is referenced with a null tag. This name must be unique among all IP or Connectionless Network Service (CLNS) router processes for a given router.
 
Step 5
isis tag tag-value


Example:

Router(config-if)# isis tag 17

 

Sets a tag on the IP address configured for an interface when this IP prefix is put into an IS-IS LSP.

  • The tag-value argument requires an interger in a range from 1 to 4294967295 and serves as a tag on an IS-IS route.
 
Step 6
exit


Example:

Router(config-if)# exit

 

Returns to global configuration mode.

 
Step 7
router isis [area-tag]


Example:

Router(config)# router isis marketing

 

Enables the IS-IS routing protocol and specifies an IS-IS process. Enters router configuration mode.

Note    If the area-tag argument is not specified, a null tag is assumed and the process is referenced with a null tag. This name must be unique among all IP or CLNS router processes for a given router.
 
Step 8
ip route priority high tag tag-value


Example:

Router(config-router)# ip route priority high tag 17

 

Assigns a high priority to prefixes associated with the specified tag value.

  • Assigns a high priority to IS-IS IP prefixes with a specific route tag in a range from 1 to 4294967295 that you specify for the tag-value argument.
 
Step 9
end


Example:

Router(config-router)# end

 

(Optional) Saves configuration commands to the running configuration file and returns to privileged EXEC mode.

 
Step 10
show isis rib [ip-address | ip-address-mask]


Example:

Router# show isis rib 255.255.255.0

 

Displays paths for a specific route in the IP Version 4 IS-IS local RIB.

  • IS-IS maintains a local database for all IS-IS routing information. This local database is referred to as the IS-IS local RIB. It contains additional attributes that are not maintained in the global IP routing table. Access to the contents of the local RIB is used to support the show isis rib command, which is used here to verify routing information related to the Priority-Driven IP Prefix RIB Installation feature.
 

Troubleshooting Tips

You can enter the debug isis rib local command to verify whether the IP prefixes that are advertised by Intermediate System-to-Intermediate System (IS-IS) link-state packet (LSP) protocol data units (PDUs) are being updated correctly in the IS-IS local Routing Information Base (RIB).

Tagging Routes for Networks Directly Connected to an Interface

Before You Begin
  • Because the IS-IS route tag will be used in a route map, you must understand how to configure a route map.
  • In order to use the route tag, you must configure the metric-style wide command. (The metric-style narrowcommand is configured by default). The tag value is set into sub-TLV 1 for TLV (Type Length Value) Type 135.
  • You must understand the task for which you are using the route tag, such as route redistribution, route summarization, or route leaking.

Before you tag any IS-IS routes, you need to decide on the following:

  1. Your goal to set values for routes or redistribute routes (or both).
  2. Where in your network you want to tag routes.
  3. Where in your network you want to reference the tags.
  4. Which tagging method you will use, which determines which task in this section to perform.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    ip address ip-address mask

5.    ip address ip-address mask secondary

6.    isis tag tag-value

7.    end

8.    show isis database verbose

9.    show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | list [access-list-number | access-list-name]]


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface ethernet 0

 

Configures an interface.

 
Step 4
ip address ip-address mask


Example:

Router(config-if)# ip address 10.1.1.1 255.255.255.0

 

Sets a primary IP address for an interface.

  • In this example, the network 10.1.1.0 will be tagged.
 
Step 5
ip address ip-address mask secondary


Example:

Router(config-if)# ip address 10.2.2.1 255.255.255.0 secondary

 

(Optional) Sets a secondary IP address for an interface.

  • In this example, the network 10.2.2.0 will be tagged.
 
Step 6
isis tag tag-value


Example:

Router(config-if)# isis tag 120

 

Sets a tag on the IP addresses configured under this interface when those IP prefixes are put into an IS-IS LSP.

  • The tag must be an integer.
 
Step 7
end


Example:

Router(config-if)# end

 

(Optional) Exits configuration mode and returns to privileged EXEC mode.

 
Step 8
show isis database verbose


Example:

Router# show isis database verbose

 

(Optional) Displays details about the IS-IS link-state database, including the route tag.

  • Perform this step if you want to verify the tag.
 
Step 9
show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | list [access-list-number | access-list-name]]


Example:

Router# show ip route 10.1.1.1 255.255.255.0

 

(Optional) Displays the current state of the routing table.

  • Perform this step if you want to verify the tag.
 

What to Do Next

Applying the tag does nothing of value for your network until you use the tag by referencing it in a route map, either to set values, to redistribute routes, or to do both. Proceed to the section "Using the Tag to Set Values or Redistribute Routes."

Tagging Routes Using a Route Map

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    route-map map-tag [permit | deny] [sequence-number]

4.    match tag tag-value [...tag-value]

5.    Use an additional match command for each match criterion that you want.

6.    set tag tag-value

7.    Set another value, depending on what else you want to do with the tagged routes.

8.    Repeat Step 7 for each value that you want to set.

9.    Repeat Steps 3 through 8 for each route-map statement that you want.

10.    end

11.    show isis database verbose

12.    show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | [list access-list-number | [access-list-name]]


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
route-map map-tag [permit | deny] [sequence-number]


Example:

Router(config)# route-map static-color permit 15

 

Defines the conditions for redistributing routes from one routing protocol into another or from one IS-IS level to another.

  • This command causes the router to enter route-map configuration mode.
 
Step 4
match tag tag-value [...tag-value]


Example:

Router(config-route-map)# match tag 15

 

(Optional) Matches routes tagged with the specified tag numbers.

  • If you are setting a tag for the first time, you cannot match on tag; this step is an option if you are changing tags.
 
Step 5
Use an additional match command for each match criterion that you want.  

(Optional) See the appropriate match commands in the Cisco IOS IP Routing: Protocol-Independent Command Reference

  • Repeat this step for each match criterion you that want.
 
Step 6
set tag tag-value


Example:

Router(config-route-map)# set tag 10

 

Specifies the tag number to set.

 
Step 7
Set another value, depending on what else you want to do with the tagged routes.  

(Optional) See the following set commands in the Cisco IOS IP Routing: Protocol-Independent Command Reference

  • set level
  • set metric
  • set metric-type
 
Step 8
Repeat Step 7 for each value that you want to set.  

(Optional)

 
Step 9
Repeat Steps 3 through 8 for each route-map statement that you want.  

(Optional)

 
Step 10
end


Example:

Router(config-route-map)# end

 

(Optional) Exits configuration mode and returns to privileged EXEC mode.

 
Step 11
show isis database verbose


Example:

Router# show isis database verbose

 

(Optional) Displays details about the IS-IS link-state database, including the route tag.

  • Perform this step if you want to verify the tag.
 
Step 12
show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | [list access-list-number | [access-list-name]]


Example:

Router# show ip route 10.1.1.1 255.255.255.0

 

(Optional) Displays the current state of the routing table.

  • Perform this step if you want to verify the tag.
 

What to Do Next

Applying the tag does nothing of value for your network until you use the tag by referencing it in a route map, either to set values, to redistribute routes, or to do both. Proceed to the section "Using the Tag to Set Values and or Redistribute Routes."

Tagging a Summary Address

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router isis [ area-tag ]

4.    metric-style wide

5.    summary-address address mask {level-1 | level-1-2 | level-2} [tag tag-value] [metric metric-value]

6.    end

7.    show isis database verbose

8.    show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | [list access-list-number | [access-list-name]]


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
router isis [ area-tag ]


Example:

Router(config)# router isis

 

Enables IS-IS as an IP routing protocol and assigns a tag to a process, if required.

  • Enters router configuration mode.
 
Step 4
metric-style wide


Example:

Router(config-router)# metric-style wide

 

Configures a router running IS-IS so that it generates and accepts type, length, and value object (TLV) 135 for IP addresses.

 
Step 5
summary-address address mask {level-1 | level-1-2 | level-2} [tag tag-value] [metric metric-value]


Example:

Router(config-router)# summary-address 192.168.0.0 255.255.0.0 tag 12345 metric 321

 

Creates aggregate addresses for IS-IS.

Note    If a tagged route is summarized and the tag is not explicitly configured in the summary-address command, then the tag is lost.
 
Step 6
end


Example:

Router(config-router)# end

 

(Optional) Exits configuration mode and returns to privileged EXEC mode.

 
Step 7
show isis database verbose


Example:

Router# show isis database verbose

 

(Optional) Displays details about the IS-IS link-state database, including the route tag.

  • Perform this step if you want to verify the tag.
 
Step 8
show ip route [ip-address [mask] [longer-prefixes] | protocol [process-id] | [list access-list-number | [access-list-name]]


Example:

Router# show ip route 10.1.1.1 255.255.255.0

 

(Optional) Displays the current state of the routing table.

  • Perform this step if you want to verify the tag.
 

What to Do Next

Applying the tag does nothing of value for your network until you use the tag by referencing it in a route map to set values. It is unlikely that you will redistribute summary routes. Proceed to the "Using the Tag to Set Values or Redistribute Routes" section.

Using the Tag to Set Values and or Redistribute Routes

Before You Begin

You must have already applied a tag on the interface, in a route map, or on a summary route. See the IS-IS Routes Tagged to Control Their Redistribution.


SUMMARY STEPS

1.    enable

2.    configure terminal

3.    route-map map-tag [permit | deny] [sequence-number]

4.    match tag tag-value

5.    Specify a match command for each match criterion that you want.

6.    Set a value, depending on what you want to do with the tagged routes.

7.    Repeat Step 6 for each value that you want to set.

8.    Repeat Steps 3 through 7 for each route-map statement that you want.

9.    exit

10.    router isis

11.    metric-style wide

12.    redistribute protocol [process-id] [level-1| level-1-2 | level-2] [metric metric-value] [metric-type type-value] [route-map map-tag]


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
route-map map-tag [permit | deny] [sequence-number]


Example:

Router(config)# route-map static-color permit 15

 

Defines the conditions for redistributing routes from one routing protocol into another or from one IS-IS level to another.

  • This command causes you to enter route-map configuration mode.
 
Step 4
match tag tag-value


Example:

Router(config-route-map)# match tag 120

 

(Optional) Applies the subsequent set commands to routes that match routes tagged with this tag number.

 
Step 5
Specify a match command for each match criterion that you want.  

(Optional) Reference the appropriate match commands in the Cisco IOS IP Routing: Protocol-Independent Command Reference.

 
Step 6
Set a value, depending on what you want to do with the tagged routes.  

(Optional) See the following set commands in the Cisco IOS IP Routing: Protocol-Independent Command Reference.

  • set level
  • set metric
  • set metric-type
 
Step 7
Repeat Step 6 for each value that you want to set.  

(Optional)

 
Step 8
Repeat Steps 3 through 7 for each route-map statement that you want.  

(Optional)

 
Step 9
exit


Example:

Router(config-route-map)# exit

 

(Optional) Returns to global configuration mode.

 
Step 10
router isis


Example:

Router(config)# router isis

 

(Optional) Enables the IS-IS routing protocol and specifies an IS-IS process.

 
Step 11
metric-style wide


Example:

Router(config-router)# metric-style wide

 

Configures a router running IS-IS so that it generates and accepts type, length, and value object (TLV) 135 for IP addresses.

 
Step 12
redistribute protocol [process-id] [level-1| level-1-2 | level-2] [metric metric-value] [metric-type type-value] [route-map map-tag]


Example:

Router(config-router)# redistribute static ip metric 2 route-map static-color

 

(Optional) Redistributes routes from one routing domain into another routing domain.

 

Limiting the Number of IS-IS Redistributed Routes

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router isis [area-tag]

4.    redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag]

5.    redistribute maximum-prefix maximum [percentage] [warning-only | withdraw]

6.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
router isis [area-tag]


Example:

Device(config)# router isis

 

Enables Intermediate System-to-Intermediate System (IS-IS) as an IP routing protocol and assigns a tag to a process, if required.

  • Enters router configuration mode.
 
Step 4
redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag]


Example:

Device(config-router)# redistribute eigrp 10 level-1

 

Redistributes routes from one routing domain into another routing domain.

 
Step 5
redistribute maximum-prefix maximum [percentage] [warning-only | withdraw]


Example:

Device(config-router)# redistribute maximum-prefix 1000 80

 

Sets a maximum number of IP prefixes that are allowed to be redistributed into IS-IS.

  • There is no default value for the maximum argument.
  • The percentage value defaults to 75 percent.
  • If the withdraw keyword is specified and the maximum number of prefixes is exceeded, IS-IS rebuilds the link-state protocol data unit (PDU) fragments without the external IP prefixes. That is, the redistributed prefixes are removed from the PDUs.
Note    If the warning-only keyword had been configured in this command, no limit would be enforced; a warning message would be logged.
 
Step 6
end


Example:

Device(config-router)# end

 

Exits router configuration mode.

 

Requesting a Warning About the Number of Prefixes Redistributed into IS-IS

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router isis [area-tag]

4.    redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag]

5.    redistribute maximum-prefix maximum [percentage] [warning-only | withdraw]

6.    lsp-full suppress {[external] [interlevel] | none}

7.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
router isis [area-tag]


Example:

Device(config)# router isis

 

Enables Intermediate System-to-Intermediate System (IS-IS) as an IP routing protocol and assigns a tag to a process, if required.

  • Enters router configuration mode.
 
Step 4
redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag]


Example:

Device(config-router)# redistribute eigrp 10 level-1

 

Redistributes routes from one routing domain into another routing domain.

 
Step 5
redistribute maximum-prefix maximum [percentage] [warning-only | withdraw]


Example:

Device(config-router)# redistribute maximum-prefix 1000 80 warning-only

 

Causes a warning message to be logged when the maximum number of IP prefixes are redistributed into IS-IS.

  • Because the warning-only keyword is included, no limit is imposed on the number of redistributed prefixes into IS-IS.
  • There is no default value for the maximum argument.
  • The percentage value defaults to 75 percent.
  • In this example configuration, two warnings are generated: one at 80 percent of 1000 (800 prefixes redistributed) and another at 1000 prefixes redistributed.
 
Step 6
lsp-full suppress {[external] [interlevel] | none}


Example:

Device(config-router)# lsp-full suppress external interlevel

 

(Optional) Controls which routes are suppressed when the link-state packet (LSP) protocol data unit (PDU) becomes full.

  • The default is external (redistributed routes are suppressed).
  • The interlevel keyword causes routes from another level to be suppressed.
  • The external and interval keywords can be specified together or separately.
 
Step 7
end


Example:

Device(config-router)# end

 

Exits router configuration mode.

 

Excluding Connected IP Prefixes on a Small Scale

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    ip address ip-address netmask

5.    no ip directed-broadcast

6.    ip router isis [area- tag ]

7.    no isis advertise-prefix

8.    exit

9.    Repeat Steps 3 through 8 for each interface on which you do not want to advertise IP prefixes.

10.    router isis [area- tag ]

11.    net network-entity-title

12.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface Ethernet 0

 

Configures an interface type and enters interface configuration mode.

 
Step 4
ip address ip-address netmask


Example:

Router(config-if)# ip address 192.168.20.1 255.255.255.0

 

Sets a primary IP address for an interface.

  • The network mask can be indicated as a 4-part dotted decimal address or as a prefix. This example uses a 4-part dotted decimal number.
 
Step 5
no ip directed-broadcast


Example:

Router(config-if)# no ip directed-broadcast

 

(Optional) Disables the translation of a directed broadcast to physical broadcasts.

 
Step 6
ip router isis [area- tag ]


Example:

Router(config-if)# ip router isis

 

Configures an IS-IS routing process for IP on an interface and attaches an area designator to the routing process.

 
Step 7
no isis advertise-prefix


Example:

Router(config-if)# no isis advertise-prefix

 

Prevents the advertising of IP prefixes of connected networks in LSP advertisements per IS-IS interface.

 
Step 8
exit


Example:

Router(config-if)# exit

 

Returns to global configuration mode.

 
Step 9
Repeat Steps 3 through 8 for each interface on which you do not want to advertise IP prefixes. 

(Optional)

 
Step 10
router isis [area- tag ]


Example:

Router(config)# router isis

 

Enables IS-IS as an IP routing protocol and assigns a tag to a process, if required.

  • Enters router configuration mode.
 
Step 11
net network-entity-title


Example:

Router(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

 

Configures an IS-IS network entity title (NET) for the routing process.

 
Step 12
end


Example:

Router(config-router)# end

 

(Optional) Saves configuration commands to the running configuration file, exits configuration mode, and returns to privileged EXEC mode.

 

Excluding Connected IP Prefixes on a Large Scale

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface loopback number

4.    ip address ip-address netmask

5.    no ip directed-broadcast

6.    exit

7.    interface type number

8.    ip address ip-address netmask

9.    no ip directed-broadcast

10.    ip router isis [area- tag ]

11.    exit

12.    router isis [area- tag ]

13.    passive-interface [default] type number

14.    net network-entity-title

15.    advertise-passive-only

16.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface loopback number


Example:

Router(config)# interface loopback 0

 

Configures a loopback interface and enters interface configuration mode.

 
Step 4
ip address ip-address netmask


Example:

Router(config-if)# ip address 192.168.10.1 255.255.255.255

 

Sets a primary IP address for an interface.

  • The network mask can be indicated as a 4-part dotted decimal address or as a prefix. This example uses a 4-part dotted decimal number.
 
Step 5
no ip directed-broadcast


Example:

Router(config-if)# no ip directed-broadcast

 

(Optional) Disables the translation of a directed broadcast to physical broadcasts.

 
Step 6
exit


Example:

Router(config-if)# exit

 

Returns to global configuration mode.

 
Step 7
interface type number


Example:

Router(config)# interface Ethernet 0

 

Configures an interface type and enters interface configuration mode.

 
Step 8
ip address ip-address netmask


Example:

Router(config-if)# ip address 192.168.20.1 255.255.255.0

 

Sets a primary IP address for an interface.

  • The network mask can be indicated as a 4-part dotted decimal address or as a prefix. This example uses a 4-part dotted decimal number.
 
Step 9
no ip directed-broadcast


Example:

Router(config-if)# no ip directed-broadcast

 

(Optional) Disables the translation of a directed broadcast to physical broadcasts.

 
Step 10
ip router isis [area- tag ]


Example:

Router(config-if)# ip router isis

 

Configures an IS-IS routing process for IP on an interface and attaches an area designator to the routing process.

 
Step 11
exit


Example:

Router(config-if)# exit

 

Returns to global configuration mode.

 
Step 12
router isis [area- tag ]


Example:

Router(config)# router isis

 

Enables IS-IS as an IP routing protocol and assigns a tag to a process, if required.

  • Enters router configuration mode.
 
Step 13
passive-interface [default] type number


Example:

Router(config-router)# passive-interface loopback 0

 

Disables sending routing updates on an interface.

 
Step 14
net network-entity-title


Example:

Router(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

 

Configures an IS-IS NET for the routing process.

 
Step 15
advertise-passive-only


Example:

Router(config-router)# advertise-passive-only

 

Configures IS-IS to advertise only prefixes that belong to passive interfaces.

 
Step 16
end


Example:

Router(config-router)# end

 

(Optional) Saves configuration commands to the running configuration file, exits configuration mode, and returns to privileged EXEC mode.

 

Monitoring IS-IS Network Convergence Time

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    isis display delimiter [return count | character count]

4.    exit

5.    show isis database [level-1] [level-2] [l1] [l2] [detail] [lspid]

6.    show isis [area-tag] routes

7.    show isis [area-tag] [ipv6 | *] spf-log

8.    show isis [process-tag] topology


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
isis display delimiter [return count | character count]


Example:

Device(config)# isis display delimiter return 2

 

Makes output from multiarea displays easier to read by specifying the delimiter to use to separate displays of information.

 
Step 4
exit


Example:

Device(config)# exit

 

Returns to privileged EXEC mode.

 
Step 5
show isis database [level-1] [level-2] [l1] [l2] [detail] [lspid]


Example:

Device# show isis database detail

 

Displays the Intermediate System-to-Intermediate System (IS-IS) link-state database.

 
Step 6
show isis [area-tag] routes


Example:

Device# show isis financetag routes

 

Displays the IS-IS Level 1 forwarding table for IS-IS learned routes.

 
Step 7
show isis [area-tag] [ipv6 | *] spf-log


Example:

Device# show isis spf-log

 

Displays how often and why the device has run a full shortest path first (SPF) calculation.

 
Step 8
show isis [process-tag] topology


Example:

Device# show isis financetag topology

 

Displays a list of all connected devices in all areas.

  • If a process tag is specified, output is limited to the specified routing process. When "null" is specified for the process tag, the output is displayed only for the device process that has no tag specified. If a process tag is not specified, the output is displayed for all processes.
 

Examples

The following sample output from the show isis spf-log command displays this information:

  • When the SPFs were executed
  • Total elapsed time for the SPF computation
  • Number of nodes that make up the topology in the SPF calculation
  • Number of triggers that caused the SPF calculation
  • Information regarding what triggered the SPF calculation
Device# show isis spf-log
   Level 1 SPF log
When      Duration  Nodes  Count     Last trigger LSP Triggers
00:15:46    3124     40      1          milles.00-00  TLVCODE
00:15:24    3216     41      5          milles.00-00  TLVCODE NEWLSP
00:15:19    3096     41      1          deurze.00-00  TLVCODE
00:14:54    3004     41      2          milles.00-00  ATTACHFLAG LSPHEADER
00:14:49    3384     41      1          milles.00-01  TLVCODE
00:14:23    2932     41      3          milles.00-00  TLVCODE
00:05:18    3140     41      1                        PERIODIC
00:03:54    3144     41      1          milles.01-00  TLVCODE
00:03:49    2908     41      1          milles.01-00  TLVCODE
00:03:28    3148     41      3           bakel.00-00  TLVCODE TLVCONTENT
00:03:15    3054     41      1          milles.00-00  TLVCODE
00:02:53    2958     41      1          mortel.00-00  TLVCODE

Configuration Examples for IS-IS Support for Route Tags

Example Assigning a High Priority Tag Value to an IS-IS IP Prefix

The following example uses the ip route priority high command to assign a tag value of 200 to the IS-IS IP prefix:

interface Ethernet 0
 ip router isis
 isis tag 200
!
router isis
 ip route priority high tag 200

Example Tagging Routes for Networks Directly Connected to an Interface and Redistributing Them

In this example, two interfaces are tagged with different tag values. By default, these two IP addresses would have been put into the IS-IS Level 1 and Level 2 database. However, by using the redistribute command with a route map to match tag 110, only IP address 172.16.10.5 255.255.255.0 is put into the Level 2 database.

interface ethernet 1/0
 ip address 192.168.129.1 255.255.255.0
 ip router isis
 isis tag 120
interface ethernet 1/1
 ip address 172.16.10.5 255.255.255.0
 ip router isis
 isis tag 110
router isis
 net 49.0001.0001.0001.0001.00
 redistribute isis ip level-1 into level-2 route-map match-tag
route-map match-tag permit 10
 match tag 110

Example: Redistributing IS-IS Routes Using a Route Map

In a scenario using route tags, you might configure some commands on one device and other commands on another device. For example, you might have a route map that matches on a tag and sets a different tag on a device at the edge of a network, and on different devices you might configure the redistribution of routes based on a tag in a different route map.

The figure below illustrates a flat Level 2 Intermediate System-to-Intermediate System (IS-IS) area. On the left edge are static routes from Device A to reach some IP prefixes. Device A redistributes the static routes into IS-IS. Device B runs the Border Gateway Protocol (BGP) and redistributes IS-IS routes into BGP and then uses the tag to apply different administrative policy based on different tag values.

Figure 1 Example of Redistributing IS-IS Routes Using a Route Map


Device A

router isis
 net 49.0000.0000.0001.00
 metric-style wide
 redistribute static ip route-map set-tag
!
route-map set-tag permit 5
 set tag 10

Device B

router bgp 100
 redistribute isis level-2 route-map tag-policy
route-map tag-policy permit 20
 match tag 10
 set metric 1000

Example: Tagging a Summary Address and Applying a Route Map

The figure below illustrates two Level 1 areas and one Level 2 area between them. Device A and Device B are Level 1/Level 2 edge devices in the Level 2 area. On edge Device A, a summary address is configured to reduce the number of IP addresses put into the Level 2 Intermediate System-to-Intermediate System (IS-IS) database. Also, a tag value of 100 is set to the summary address.

On Device B, the summary address is leaked into the Level 1 area, and administrative policy is applied based on the tag value.

Figure 2 Tag on a Summary Address


Device A

router isis
 net 49.0001.0001.0001.00
 metric-style wide
 summary-address 10.0.0.0 255.0.0.0 tag 100

Device B

router isis
 net 49.0002.0002.0002.0002.0
 metric-style wide
 redistribute isis ip level-2 into level-1 route-map match-tag
route-map match-tag permit 10
 match tag 100

Example Filtering and Redistributing IS-IS Routes Using an Access List and a Route Map

In this example, the first redistribute isis ip command controls the redistribution of Level 1 routes into Level 2. Only the routes with the tag of 90 and whose IP prefix is not 192.168.130.5/24 will be redistributed from Level 1 into Level 2.

The second redistribute isis ip command controls the route leaking from Level 2 into the Level 1 domain. Only the routes tagged with 60 or 50 will be redistributed from Level 2 into Level 1.

interface ethernet 1
 ip address 192.168.130.5 255.255.255.0
 ip router isis
 isis tag 60
!
interface ethernet 2
 ip address 192.168.130.15 255.255.255.0
 ip router isis
 isis tag 90
!
interface ethernet 3
 ip address 192.168.130.25 5 255.255.255.0
 ip router isis
 isis tag 50
!
router isis
 net 49.0001.0001.0001.0001.00
 metric-style wide
 redistribute isis ip level-1 into level-2 route-map redist1-2
 redistribute isis ip level-2 into level-1 route-map leak2-1
!
access-list 102 deny ip host 192.168.130.5 host 255.255.255.255
access-list 102 permit ip any any
!
route-map leak2-1 permit 10
 match tag 60
!
route-map leak2-1 permit 20
 match tag 50
!
route-map redist1-2 permit 10
 match ip address 102
 match tag 90

Example: IS-IS Limit on the Number of Redistributed Routes

This example shows how to set a maximum of 1200 prefixes that can be redistributed into an Intermediate System-to-Intermediate System (IS-IS). When the number of prefixes redistributed reaches 80 percent of 1200 (960 prefixes), a warning message is logged. When 1200 prefixes are redistributed, IS-IS rebuilds the link-state packet (LSP) fragments without external prefixes and no redistribution occurs.

router isis 1
 redistribute maximum-prefix 1200 80 withdraw

Example: Requesting a Warning About the Number of Redistributed Routes

This example shows how to allow two warning messages to be logged. The first message is generated if the number of prefixes redistributed reaches 85 percent of 600 (510 prefixes), and the second message is generated if the number of redistributed prefixes reaches 600. However, the number of redistributed prefixes is not limited. If the LSPFULL state occurs, external prefixes are suppressed.

router isis 1
 redistribute maximum-prefix 600 85 warning-only
 lsp-full suppress external

Example Excluding Connected IP Prefixes on a Small Scale

The following example uses the no isis advertise-prefix command on Ethernet interface 0. Only the IP address of loopback interface 0 is advertised.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet 0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 no isis advertise-prefix
.
.
.
router isis 
 passive-interface loopback 0
 net 47.0004.004d.0001.0001.0c11.1111.00
 log-adjacency-changes
!

Example Excluding Connected IP Prefixes on a Large Scale

The following example uses the advertise-passive-only command, which applies to the entire IS-IS instance, thereby preventing IS-IS from advertising the IP network of Ethernet interface 0. Only the IP address of loopback interface 0 is advertised.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
.
.
.
router isis 
 passive-interface Loopback0
 net 47.0004.004d.0001.0001.0c11.1111.00
 advertise-passive-only
 log-adjacency-changes
!

Where to Go Next

To configure features to improve Intermediate System-to-Intermediate System (IS-IS) network convergence times, complete the optional tasks in one or more of the following modules in the IP Routing: IS-IS Configuration Guide:

  • "Overview of IS-IS Fast Convergence"
  • "Reducing Failure Detection Times in IS-IS Networks"
  • "Reducing Link Failure and Topology Change Notification Times in IS-IS Networks"

Additional References

Related Documents

Related Topic

Document Title

Description of IS-IS type length value (TLV) and its use.

Intermediate System-to-Intermediate Systems (IS-IS) TLVs

IS-IS commands: complete command syntax, command mode, defaults, command history, usage guidelines, and examples

Cisco IOS IP Routing: ISIS Command Reference

IS-IS route leaking

IS-IS Route Leaking

Overview of Cisco IS-IS conceptual information with links to all the individual IS-IS modules

"Integrated IS-IS Routing Protocol Overview" module

RFCs

RFC

Title

No new or modified RFCs are supported, and support for existing RFCs has not been modified.

--

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for Reducing Alternate-Path Calculation Times in IS-IS Networks

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for Reducing Alternate-Path Calculation Times in IS-IS Networks

Feature Name

Releases

Feature Information

IS-IS Caching of Redistributed Routes

12.0(27)S 12.2(25)S 12.3(7)T Cisco IOS XE 3.1.0 SG

The IS-IS Caching of Redistributed Routes feature improves Intermediate System-to-Intermediate System (IS-IS) convergence time when routes are being redistributed into IS-IS. This document introduces new commands for monitoring and maintaining IS-IS redistributed routes.

IS-IS Incremental SPF

12.0(24)S 12.2(18)S 12.3(2)T Cisco IOS XE 3.1.0 SG

Integrated IS-IS can be configured to use an incremental SPF algorithm for calculating the shortest path first routes. Incremental SPF is more efficient than the full SPF algorithm, thereby allowing IS-IS to converge faster on a new routing topology in reaction to a network event.

IS-IS Limit on Number of Redistributed Routes

12.0(25)S 12.2(18)S 12.3(4)T Cisco IOS XE 3.1.0 SG

The IS-IS Limit on Number of Redistributed Routes feature provides for a user-defined maximum number of prefixes that are allowed to be redistributed into IS-IS from other protocols or other IS-IS processes. Such a limit can help prevent the router from being flooded by too many redistributed routes.

IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

12.0(22)S 12.2(18)S 12.3(2)T Cisco IOS XE 3.1.0 SG

This document describes two Integrated Intermediate System-to-Intermediate System (IS-IS) mechanisms to exclude IP prefixes of connected networks from link-state PDU (LSP) advertisements, thereby reducing IS-IS convergence time.

IS-IS Support for Priority-Driven IP Prefix RIB Installation

12.0(26)S 12.2(18)SXE 12.2(25)S 12.3(4)T Cisco IOS XE 3.1.0 SG

The IS-IS Support for Priority-Driven Prefix RIB Installation feature allows customers to designate a subset of IP prefixes advertised by IS-IS for faster processing and installation in the global routing table as one way to achieve faster convergence. For example, Voice over IP (VoIP) gateway addresses may need to be processed first to help VoIP traffic get updated faster than other types of packets.

IS-IS Support for Route Tags

12.2(18)S 12.2(27)SBC 12.3(2)T Cisco IOS XE 3.1.0 SG

The IS-IS Support for Route Tags feature provides the capability to tag IS-IS route prefixes and use those tags in a route map to control IS-IS route redistribution or route leaking.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.