IP Routing: EIGRP Configuration Guide, Cisco IOS Release 15M&T
BFD Support for EIGRP IPv6
Downloads: This chapterpdf (PDF - 1.32MB) The complete bookPDF (PDF - 4.06MB) | The complete bookePub (ePub - 698.0KB) | Feedback

BFD Support for EIGRP IPv6

BFD Support for EIGRP IPv6

The BFD Support for EIGRP IPv6 feature provides Bidirectional Forwarding Detection (BFD) support for Enhanced Interior Gateway Routing Protocol (EIGRP) IPv6 sessions, thereby facilitating rapid fault detection and alternate-path selection in EIGRP IPv6 topologies. BFD is a detection protocol that provides a consistent failure-detection method for network administrators, and network administrators use BFD to detect forwarding path failures at a uniform rate and not at variable rates for different routing protocol ‘Hello’ mechanisms. This failure-detection methodology ensures easy network profiling and planning and consistent and predictable reconvergence time. This document provides information about BFD support for EIGRP IPv6 networks and explains how to configure BFD support in EIGRP IPv6 networks.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for BFD Support for EIGRP IPv6

EIGRP IPv6 sessions have a shutdown option in router, address family, and address-family interface configuration modes. To enable BFD support on EIGRP IPv6 sessions, the routing process should be in no shut mode in the abovementioned modes.

Restrictions for BFD Support for EIGRP IPv6

  • The BFD Support for EIGRP IPv6 feature is supported only in EIGRP named mode.
  • EIGRP supports only single-hop Bidirectional Forwarding Detection (BFD).
  • The BFD Support for EIGRP IPv6 feature is not supported on passive interfaces.

Information About BFD Support for EIGRP IPv6

BFD for EIGRP IPv6

Bidirectional Forwarding Detection (BFD) is a detection protocol that provides fast-forwarding, path-failure detection for all media types, encapsulations, topologies, and routing protocols. The BFD Support for EIGRP IPv6 feature enables BFD to interact with the Enhanced Interior Gateway Routing Protocol (EIGRP) to create BFDv6 sessions between EIGRP neighbors. In a BFD-enabled EIGRP IPv6 session, BFD constantly monitors the forwarding path (from a local device to a neighboring device) and provides consistent failure detection at a uniform rate. Because failure detection happens at a uniform rate and not at variable rates, network profiling and planning is easier, and the reconvergence time remains consistent and predictable.

BFD is implemented in EIGRP at multiple levels; it can be implemented per interface or on all interfaces. When BFD is enabled on a specific interface, all peer relationships formed through the EIGRP “Hello” mechanism on that interface are registered with the BFD process. Subsequently, BFD establishes a session with each of the peers in the EIGRP topology and notifies EIGRP through a callback mechanism of any change in the state of any peer. When a peer is lost, BFD sends a “peer down” notification to EIGRP, and EIGRP unregisters a peer from BFD. BFD does not send a “peer up” notification to EIGRP when the peer is up because BFD now has no knowledge of the state of the peer. This behavior prevents rapid neighbor bouncing and repetitive route computations. The EIGRP “Hello” mechanism will later allow peer rediscovery and reregistration with the BFD process.

How to Configure BFD Support for EIGRP IPv6

Configuring BFD Support on All Interfaces

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ipv6 unicast-routing

    4.    interface type number

    5.    ipv6 address ipv6-address/prefix-length

    6.    bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

    7.    exit

    8.    router eigrp virtual-name

    9.    address-family ipv6 autonomous-system as-number

    10.    eigrp router-id ip-address

    11.    af-interface default

    12.    bfd

    13.    end

    14.    show eigrp address-family ipv6 neighbors


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ipv6 unicast-routing


    Example:
    Device(config)# ipv6 unicast-routing
     

    Enables the forwarding of IPv6 unicast datagrams.

     
    Step 4interface type number


    Example:
    Device(config)# interface gigabitethernet0/0/1
     

    Specifies the interface type and number, and enters the interface configuration mode.

     
    Step 5 ipv6 address ipv6-address/prefix-length


    Example:
    Device(config-if)# ipv6 address 2001:DB8:A:B::1/64
     

    Configures an IPv6 address.

     
    Step 6 bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier


    Example:
    Device(config-if)# bfd interval 50 min_rx 50 multiplier 3	
     

    Sets the baseline BFD session parameters on an interface.

     
    Step 7 exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and returns to global configuration mode.

     
    Step 8 router eigrp virtual-name


    Example:
    Device(config)# router eigrp name
     

    Specifies an EIGRP routing process and enters router configuration mode.

     
    Step 9 address-family ipv6 autonomous-system as-number


    Example:
    Device(config-router)# address-family ipv6 autonomous-system 3
     

    Enters address family configuration mode for IPv6 and configures an EIGRP routing instance.

     
    Step 10eigrp router-id ip-address


    Example:
    Device(config-router-af)# eigrp router-id 172.16.1.3
     

    Sets the device ID used by EIGRP for this address family when EIGRP peers communicate with their neighbors.

     
    Step 11 af-interface default


    Example:
    Device(config-router-af)# af-interface default 
     

    Configures interface-specific commands on all interfaces that belong to an address family in EIGRP named mode configurations, and enters address-family interface configuration mode.

     
    Step 12bfd


    Example:
    Device(config-router-af-interface)# bfd
     

    Enables BFD on all interfaces.

     
    Step 13 end


    Example:
    Device(config-router-af-interface)# end
     

    Exits address-family interface configuration mode and returns to privileged EXEC mode.

     
    Step 14 show eigrp address-family ipv6 neighbors


    Example:
    Device# show eigrp address-family ipv6 neighbors
     

    (Optional) Displays neighbors for which BFD has been enabled.

     

    Configuring BFD Support on an Interface

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    ipv6 unicast-routing

      4.    interface type number

      5.    ipv6 address ipv6-address /prefix-length

      6.    bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

      7.    exit

      8.    router eigrp virtual-name

      9.    address-family ipv6 autonomous-system as-number

      10.    eigrp router-id ip-address

      11.    af-interface interface-type interface-number

      12.    bfd

      13.    end

      14.    show eigrp address-family ipv6 neighbors


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 ipv6 unicast-routing


      Example:
      Device(config)# ipv6 unicast-routing
       

      Enables the forwarding of IPv6 unicast datagrams.

       
      Step 4interface type number


      Example:
      Device(config)# interface gigabitethernet0/0/1
       

      Specifies the interface type and number, and enters the interface configuration mode.

       
      Step 5 ipv6 address ipv6-address /prefix-length


      Example:
      Device(config-if)# ipv6 address 2001:DB8:A:B::1/64
       

      Configures an IPv6 address.

       
      Step 6 bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier


      Example:
      Device(config-if)# bfd interval 50 min_rx 50 multiplier 3	
       

      Sets the baseline BFD session parameters on an interface.

       
      Step 7 exit


      Example:
      Device(config-if)# exit
       

      Exits interface configuration mode and returns to global configuration mode.

       
      Step 8 router eigrp virtual-name


      Example:
      Device(config)# router eigrp name
       

      Specifies an EIGRP routing process and enters router configuration mode.

       
      Step 9 address-family ipv6 autonomous-system as-number


      Example:
      Device(config-router)# address-family ipv6 autonomous-system 3
       

      Enters address family configuration mode for IPv6 and configures an EIGRP routing instance.

       
      Step 10eigrp router-id ip-address


      Example:
      Device(config-router-af)# eigrp router-id 172.16.1.3
       

      Sets the device ID used by EIGRP for this address family when EIGRP peers communicate with their neighbors.

       
      Step 11 af-interface interface-type interface-number


      Example:
      Device(config-router-af)# af-interface gigabitethernet0/0/1 
       

      Configures interface-specific commands on an interface that belongs to an address family in an EIGRP named mode configuration, and enters address-family interface configuration mode.

       
      Step 12bfd


      Example:
      Device(config-router-af-interface)# bfd
       

      Enables BFD on the specified interface.

       
      Step 13 end


      Example:
      Device(config-router-af-interface)# end
       

      Exits address-family interface configuration mode and returns to privileged EXEC mode.

       
      Step 14 show eigrp address-family ipv6 neighbors


      Example:
      Device# show eigrp address-family ipv6 neighbors
       

      (Optional) Displays neighbors for which BFD has been enabled.

       

      Configuration Examples for BFD Support for EIGRP IPv6

      Example: Configuring BFD Support on All Interfaces

      Device(config)# ipv6 unicast-routing
      Device(config)# interface GigabitEthernet0/0/1
      Device(config-if)# ipv6 address 2001:0DB8:1::12/64
      Device(config-if)# bfd interval 50 min_rx 50 multiplier 3
      Device(config-if)# exit 
      Device(config)# router eigrp name
      Device(config-router)# address-family ipv6 unicast autonomous-system 1 
      Device(config-router-af)# eigrp router-id 172.16.0.1
      Device(config-router-af)# af-interface default
      Device(config-router-af-interface)# bfd
      Device(config-router-af-interface)# end
      

      Example: Configuring BFD Support on an Interface

      Device(config)# ipv6 unicast-routing
      Device(config)# GigabitEthernet0/0/1
      Device(config-if)# ipv6 address 2001:DB8:A:B::1/64
      Device(config-if)# bfd interval 50 min_rx 50 multiplier 3
      Device(config-if)# exit
      Device(config)# router eigrp name
      Device(config-router)# address-family ipv6 autonomous-system 3
      Device(config-router-af)# af-interface GigabitEthernet0/0/1
      Device(config-router-af-interface)# bfd
      Device(config-router-af-interface)# end
      
      

      Additional References

      Related Documents

      Related Topic

      Document Title

      Cisco IOS commands

      Master Commands List, All Releases

      BFD commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples.

      IP Routing: Protocol-Independent Command Reference

      EIGRP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples.

      IP Routing: EIGRP Command Reference

      Configuring EIGRP

      “Configuring EIGRP” chapter in IP Routing: EIGRP Configuration Guide

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for BFD Support for EIGRP IPv6

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for BFD Support for EIGRP IPv6

      Feature Name

      Releases

      Feature Information

      BFD Support for EIGRP IPv6

      15.2(1)E

      Bidirectional Forwarding Detection (BFD) is a detection protocol that provides fast-forwarding, path-failure detection for all media types, encapsulations, topologies, and routing protocols. BFD helps network administrators to ensure easier network profiling and planning and consistent and predictable reconvergence time. BFD interacts with Enhanced Interior Gateway Routing Protocol (EIGRP) to create sessions (IPv4 type sessions) between EIGRP neighbors for fast-forwarding, path-failure detections. Each session tests the forwarding path for a single route from a local router to a neighboring router. For any change in state (forwarding path goes down or forwarding path comes up) for any of the sessions, BFD notifies EIGRP of the new state for that route. Support has been added for EIGRP IPv6 neighbors to use BFD as a fall-over mechanism.

      The following commands were introduced or modified: bfd, show eigrp address-family neighbors, show eigrp address-family interfaces.