IP Multicast: MVPN Configuration Guide, Cisco IOS Release 15MT
MVPNv6
Downloads: This chapterpdf (PDF - 1.27MB) The complete bookPDF (PDF - 4.03MB) | The complete bookePub (ePub - 1.18MB) | Feedback

MVPNv6

This module describes how to configure IPv6 Multicast Virtual Private Network (MVPNv6) to enable service providers to use their existing IPv4 backbone to provide multicast-enabled private IPv6 networks to their customers.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for MVPNv6

  • BGP must be configured and operational on all devices sending or receiving multicast traffic.
  • BGP extended communities must be enabled to support the use of Multicast Distribution Trees (MDTs) in the network. Use the neighbor send-community both or neighbor send-community extended command to enable BGP extended communities.
  • VPN routing and forwarding (MVRF) instances to be used for MVPNv6 must be configured on the PE devices.

Restrictions for MVPNv6

Point-to-point GRE tunnel as an output interface in a VRF for MVPNv6 is not supported.

Information About MVPNv6

MVPNv6

To provide Layer 3 multicast services to customers with multiple distributed sites, service providers need a secure and scalable mechanism to transmit multicast traffic across the service-provider network. IPv4 Multicast VPN (MVPN) provides such services for IPv4 multicast traffic over a shared service provider backbone.

IPv6 Multicast Virtual Private Network (MVPNv6) provides the same services for IPv6 traffic, enabling service providers to provide multicast-enabled private IPv6 networks to their customers using their existing IPv4 back bone. The IPv4 and IPv6 VPN traffic is carried over the same tunnels simultaneously.

How to Configure MVPNv6

Configuring Multicast Routing

Perform this task to enable IPv4 and IPv6 multicast routing for the multicast VPN routing and forwarding (MVRF) instance to be used for MVPNv6.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip routing

    4.    ip routing vrf vrf-name

    5.    ipv6 routing

    6.    ipv6 routing vrf vrf-name

    7.    exit


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     
    Enables privileged EXEC mode.
    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip routing


    Example:
    Device(config)# ip routing
     

    Enables IPv4 multicast routing.

     
    Step 4 ip routing vrf vrf-name


    Example:
    Device(config)# ip routing vrf blue
     

    Enables IPv4 multicast routing for the specified MVRF instance.

     
    Step 5 ipv6 routing


    Example:
    Device(config)# ipv6 routing
     

    Enables IPv6 multicast routing.

     
    Step 6 ipv6 routing vrf vrf-name


    Example:
    Device(config)# ipv6 routing vrf blue
     

    Enables IPv6 multicast routing for the specified MVRF instance.

     
    Step 7 exit


    Example:
    Device(config)# exit
     

    Exits global configuration mode.

     

    Configuring MVRF on PE Devices

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    vrf forwarding vrf-name

      5.    ip address ip-address mask

      6.    ip pim sparse-mode

      7.    delay tens-of-seconds

      8.    ipv6 address ipv6-address link-local

      9.    ipv6 address ipv6-address-prefix

      10.    ipv6 pim

      11.    exit

      12.    ip pim rp-address ip-address

      13.    ip pim vrf vrf-name rp-address address

      14.    ipv6 pim vrf vrf-name rp-address ipv6-address

      15.    exit


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Device> enable
       
      Enables privileged EXEC mode.
      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Device(config)# interface GigabitEthernet 3/0/3
       

      Enters interface configuration mode.

       
      Step 4 vrf forwarding vrf-name


      Example:
      Device(config-if)# vrf forwarding blue
       

      Associates a VRF with the interface.

       
      Step 5 ip address ip-address mask


      Example:
      Device(config-if)# ip address 10.1.0.1 255.255.0.0
       

      Configures an IPv4 address on the interface.

       
      Step 6 ip pim sparse-mode


      Example:
      Device(config-if)# ip pim sparse-mode
       

      Enables Protocol Independent Multicast (PIM) on the interface.

       
      Step 7 delay tens-of-seconds


      Example:
      Device(config-if)# delay 1000
       

      Configures delay value on the interface.

       
      Step 8 ipv6 address ipv6-address link-local


      Example:
      Device(config-if)# ipv6 address FE80::20:1:1 link-local 
       
      Specifies a link-local IPv6 address.
      • This address is used instead of the link-local address that was automatically configured when IPv6 was enabled on the interface.
       
      Step 9 ipv6 address ipv6-address-prefix


      Example:
      Device(config-if)# ipv6 address FC00::/7 
       

      Configures an IPv6 address on the interface.

       
      Step 10 ipv6 pim


      Example:
      Device(config-if)# ipv6 pim
       

      Enables Protocol Independent Multicast (PIM) for IPv6.

       
      Step 11 exit


      Example:
      Device(config-if)# exit
       

      Exits interface configuration mode.

       
      Step 12 ip pim rp-address ip-address


      Example:
      Device(config)# ip pim rp-address 10.10.10.10 
       

      Configure the address of a PIM rendezvous point (RP) for multicast groups.

       
      Step 13 ip pim vrf vrf-name rp-address address


      Example:
      Device(config)# ip pim vrf blue rp-address 10.10.0.10
       

      Configures the IPv4 address of a PIM RP and associates the RP with the specified MVRF instance.

       
      Step 14 ipv6 pim vrf vrf-name rp-address ipv6-address


      Example:
      Device(config)# ipv6 pim vrf blue rp-address FC00::1:1:1
       

      Configures the IPv6 address of a PIM RP and associates the RP with the specified MVRF instance.

       
      Step 15 exit


      Example:
      Device(config)# exit
       

      Exits global configuration mode.

       

      Configuring Routing Protocols Between the PE and CE Devices

      Before You Begin

      The PE and CE devices must be configured with the same routing protocol.

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    router bgp as-number

        4.    address-family ipv6 vrf vrf-name

        5.    redistribute connected

        6.    redistribute eigrp as-number

        7.    redistribute static

        8.    end


      DETAILED STEPS
          Command or Action Purpose
        Step 1 enable


        Example:
        Device> enable
         
        Enables privileged EXEC mode.
        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Device# configure terminal
         

        Enters global configuration mode.

         
        Step 3 router bgp as-number


        Example:
        Device(config)# router bgp 55
         

        Specifies the number of an autonomous system that identifies the device to other BGP devices.

         
        Step 4 address-family ipv6 vrf vrf-name


        Example:
        Device(config-router)# address-family ipv6 vrf blue
         

        Specifies the name of the VRF to associate with subsequent address family configuration mode commands.

         
        Step 5 redistribute connected


        Example:
        Device(config-router-af)# redistibute connected
         

        Redistributes the directly connected networks to BGP.

         
        Step 6 redistribute eigrp as-number


        Example:
        Device(config-router-af)# redistribute eigrp 11
         

        Redistributes the EIGRP routes into BGP.

         
        Step 7 redistribute static


        Example:
        Device(config-router-af)# redistribute static
         

        Redistribute the static routes into BGP.

         
        Step 8 end


        Example:
        Device(config-router-af)# end
         

        Returns to privileged EXEC mode.

         

        Configuration Examples for MVPNv6

        Example: MVPNv6

        mls ipv6 vrf
        !
        vrf definition blue
         rd 55:1111
         route-target export 55:1111
         route-target import 55:1111
         !
         address-family ipv4
          mdt default 232.1.1.1
         exit-address-family
         !
         address-family ipv6
          mdt default 232.1.1.1
         exit-address-family
        !
        
        ip multicast-routing
        ip multicast-routing vrf blue
        !
        !
        ipv6 unicast-routing
        ipv6 multicast-routing
        ipv6 multicast-routing vrf blue
        !
        
        interface GigabitEthernet3/0/3
         vrf forwarding blue
         ip address 10.1.0.1 255.255.255.0
         no ip redirects
         no ip proxy-arp
         ip pim sparse-dense-mode
         delay 100
         ipv6 address FE80::20:1:1 link-local
         ipv6 address FC00::/7
         no mls qos trust
        !
        router bgp 55
        address-family ipv6 vrf blue
          redistribute connected
          redistribute eigrp 11
          redistribute static
         exit-address-family
        !
        
        ip pim vrf blue rp-address 10.10.0.10
        !
        ipv6 pim vrf blue rp-address FC00::1:1:1
        !
        !
              

        Additional References for Nextgen MVPN BGP C-Route Signaling

        Related Documents

        Related Topic

        Document Title

        Cisco IOS commands

        Cisco IOS Master Commands List, All Releases

        IP multicast commands

        Cisco IOS IP Multicast Command Reference

        Technical Assistance

        Description

        Link

        The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        Feature Information for MVPNv6

        The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

        Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

        Table 1 Feature Information for MVPNv6

        Feature Name

        Releases

        Feature Information

        MVPNv6

        15.2(4)S

        15.3(1)T

        Cisco IOS XE Release 3.8S

        This feature enables service providers to use their existing IPv4 back bone to provide multicast-enabled private IPv6 networks to their customers.

        No commands were introduced or modified.