Configuration Fundamentals Configuration Guide, Cisco IOS Release 15SY
Using Setup Mode to Configure a Cisco Networking Device
Downloads: This chapterpdf (PDF - 118.0KB) The complete bookPDF (PDF - 0.98MB) | The complete bookePub (ePub - 0.98MB) | Feedback

Using Setup Mode to Configure a Cisco Networking Device

Using Setup Mode to Configure a Cisco Networking Device

Last Updated: December 6, 2012

Setup mode provides an interactive menu to help you to create an initial configuration file for a new networking device, or a device that you have erased the startup-config file from NVRAM. The nteractive menu guides you through initial configuration and is useful when you are unfamiliar with Cisco products or the command line interface (CLI) and when configuration changes do not require the level of detail the CLI provides. Setup mode can also be used to modify an existing configuration.

This section describes how to use the System Configuration Dialog to prepare a Cisco networking device for full configuration and how you can make configuration changes after an initial configuration is complete. To improve readability, filenames are enclosed in quotation marks. Also, the terms device and networking device mean a router, switch, or other device running Cisco IOS software. The terms initial configuration and startup configuration are used interchangeably.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for Using Cisco IOS Setup Mode to Configure a Cisco Networking Device

  • You have read the "Basic Configuration of a Cisco Networking Device Overview" module.
  • An ASCII terminal is connected to the console port of the device being configured.
  • You know the interfaces you want to configure.
  • You know the routing protocols you want to enable.

For information about routing protocols, see the Cisco IOS IP Routing Protocols Configuration Guide , Release 12.4.

  • You know whether the device you are configuring will perform bridging.
  • You know whether the device you are configuring has protocol translation installed.
  • You have network addresses for the protocols being configured.

For information about network addresses, see the Cisco IOS IP Addressing Services Configuration Guide, Release 12.4.

  • You have a password strategy for your network environment.

For information about passwords and device security, see "Configuring Security with Passwords, Privilege Levels, and Login User names for CLI Sessions on Networking Devices" module in the Cisco IOS Security Configuration Guide, Release 12.4.

  • You have or have access to documentation for the product you want to configure.

Restrictions for Using Cisco IOS Setup Mode to Configure a Cisco Networking Device

  • Setup mode is hardware dependent. You must follow instructions for the specific product you want to configure, as described in documentation for that product.
  • Some configuration parameters apply only when a networking device has the protocol translation option. If a device does not have protocol translation, Setup does not prompt for these parameters.

Information About Using Cisco IOS Setup Mode to Configure a Cisco Networking Device

Cisco IOS Setup Mode

Cisco IOS Setup mode enables you to build an initial configuration file using the Cisco IOS CLI or System Configuration Dialog. The dialog guides you through initial configuration and is useful when you are unfamiliar with Cisco products or the CLI and when configuration changes do not require the level of detail the CLI provides.

Setup starts automatically when a device has no configuration file in NVRAM and is not preconfigured from the factory to use Cisco Router and Security Device Manager (SDM). When setup completes, it presents the System Configuration Dialog. This dialog guides you through an initial configuration with prompts for basic information about your device and network and then creates an initial configuration file. After the file is created, you can use the CLI to perform additional configuration.

Cisco Router and Security Device Manager

Cisco SDM is a web-based device management tool for configuring Cisco IOS network connections and security features on networking devices. SDM provides a default configuration and various wizards to guide you step by step through configuring a Cisco networking device, additional LAN or WAN connections, and VPN connections; creating firewalls; and performing security audits.

In addition to building an initial configuration, SDM provides an Advanced Mode through which you can configure advanced features such as Firewall Policy and Network Address Translation (NAT).

Some Cisco products ship from the factory with SDM installed. If SDM is preinstalled on your device and you want to use Setup to configure an initial configuration, you first must disable the SDM default configuration.

System Configuration Dialog

The System Configuration Dialog is an interactive CLI mode that prompts you for information needed to build an initial configuration for a Cisco networking device. Like the CLI, the System Configuration Dialog provides help text at each prompt. To access this help text, you enter a question mark (?) at the prompt.

The prompts in the System Configuration Dialog vary depending on hardware, installed interface modules, and software image. To use the dialog for an initial configuration, you need to refer to product-specific documentation.

The values shown in square brackets next to prompts reflect the current settings. These may be default settings from the factory or the latest settings configured on the device. To accept these settings, you press Enter on the keyboard.

You can exit (Ctrl-C) the System Configuration Dialog and return to privileged EXEC mode without making changes and without going through the entire dialog. If you exit the dialog but want to continue with setup, you can issue the setup command in privileged EXEC mode.

When you complete all the steps in the dialog, the device displays the modified configuration file and asks if you want to use that file. You must answer yes or no; there is no default for this prompt. If you answer yes, the file is saved to NVRAM as the startup configuration. If you answer no, the file is not saved and you must start at the beginning of the dialog if you want to build another initial configuration.

In addition to being a quick and easy way to perform an initial configuration, the System Configuration Dialog also is useful for performing basic configuration changes after an initial configuration has been performed.

Benefits of Using Cisco IOS Setup Mode

The System Configuration Dialog in Cisco IOS Setup mode can be a valuable tool for users who are unfamiliar with Cisco products or the CLI. The dialog guides users through the configuration process with prompts for basic information to get the device operational. When general configuration changes are needed, the dialog also is an alternative method to the detail-level CLI.

How to Use Cisco IOS Setup Mode to Configure a Cisco Networking Device and Make Configuration Changes

This section describes how to use the System Configuration Dialog to build an initial configuration file and to make configuration changes after a startup configuration has been loaded.

Disabling the SDM Default Configuration File

Perform this task if SDM was preinstalled on your device and you want to use Setup to build an initial configuration file. SDM remains on the device.

Perform this task if SDM was pre installed on your device and you want to use AutoInstall to configure the device instead. SDM remains on the device.

SUMMARY STEPS

1.    Connect the console cable, shipped with your device, from the console port on the device to a serial port on your PC. Refer to the hardware installation guide for the device for instructions.

2.    Connect the power supply to the device, plug the power supply into a power outlet, and turn on the device. Refer to the quick start guide for the device for instructions.

3.    Use Hyperterminal or a similar terminal emulation program on your PC, with the following terminal emulation settings, to connect to the device:

4.    enable

5.    erase startup-config

6.    reload


DETAILED STEPS
Step 1   Connect the console cable, shipped with your device, from the console port on the device to a serial port on your PC. Refer to the hardware installation guide for the device for instructions.
Step 2   Connect the power supply to the device, plug the power supply into a power outlet, and turn on the device. Refer to the quick start guide for the device for instructions.
Step 3   Use Hyperterminal or a similar terminal emulation program on your PC, with the following terminal emulation settings, to connect to the device:
  • 9600 baud
  • 8 data bits, no parity, 1 stop bit
  • No flow control
Step 4   enable

Enter privileged EXEC mode.

enable



Example:
Router> enable
Router#
Step 5   erase startup-config

Erases the existing configuration in NVRAM.



Example:
Router# erase startup-config
Step 6   reload

Initiates the reload process. The router will initiate the AutoInstall process after it finishes the reload process.



Example:
Router# reload

Using the System Configuration Dialog to Create an Initial Configuration File

Perform this task to create an initial configuration for a Cisco networking device.

Before You Begin

If SDM is installed, you must disable its default configuration file before using Setup.


Note


The System Configuration Dialog does not allow you to randomly select or enter parameters for configuration. You must move through the dialog step by step until the screen shows the information you want to change.



SUMMARY STEPS

1.    Power on the device.

2.    Enter yes at the prompt to enter the initial configuration dialogue.

3.    If you are prompted to continue with the configuration dialogue, enter yes attheprompttocontinuethedialog(thisstepmightnotappear).

4.    The basic management screen is displayed:

5.    Enter a hostname for the device. This example uses Router.

6.    Enter an enable secret password. This password is encrypted and cannot be seen when viewing the configuration.

7.    Enter an enable password that is different from the enable secret password. An enable password is not encrypted and can be seen when viewing the configuration:

8.    Enter a virtual terminal password. This password allows access to the device through only the console port.

9.    Respond to the following prompts as appropriate for your network. In this example, the current setting [no] is accepted by pressing Enter.

10.    Select an interface to connect the router to the management network:

11.    Respond to the prompts as appropriate for your network. In this example, IP is configured: an IP address is entered and the current subnet mask is accepted. The screen displays the command script created.

12.    Enter 2orpressEnterto save the configuration file to NVRAM and exit.


DETAILED STEPS
Step 1   Power on the device.
Step 2   Enter yes at the prompt to enter the initial configuration dialogue.

If the following messages appear at the end of the startup sequence, the System Configuration Dialog was invoked automatically:



Example:
--- System Configuration Dialog ---
Would you like to enter the initial configuration dialog? [yes/no]: yes

The screen displays the following:



Example:
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: 
Step 3   If you are prompted to continue with the configuration dialogue, enter yes attheprompttocontinuethedialog(thisstepmightnotappear).


Example:
Continue with configuration dialog? [yes/no]: yes
Step 4   The basic management screen is displayed:

Example:
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: 

Enter yes to enter basic management setup:



Example:
Would you like to enter basic management setup? [yes/no]: yes
The screen displays the following:
Configuring global parameters:
Enter host name [R1]: 
Step 5   Enter a hostname for the device. This example uses Router.

Example:
Configuring global parameters:
Enter host name [R1]: Router
The screen displays the following:
The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: 
Step 6   Enter an enable secret password. This password is encrypted and cannot be seen when viewing the configuration.

Example:
Enter enable secret: 1g2j3mm

The screen displays the following:



Example:
The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: 
Step 7   Enter an enable password that is different from the enable secret password. An enable password is not encrypted and can be seen when viewing the configuration:

Example:
  Enter enable password: cts54tnl

The screen displays the following:



Example:
The virtual terminal password is used to protect
  access to the router over a network interface.
  Enter virtual terminal password: 
Step 8   Enter a virtual terminal password. This password allows access to the device through only the console port.

Example:
  Enter virtual terminal password: tls6gato

The screen displays the following:



Example:
Configure SNMP Network Management? [no]: 
Step 9   Respond to the following prompts as appropriate for your network. In this example, the current setting [no] is accepted by pressing Enter.

Example:
Configure SNMP Network Management? [no]: 

A summary of the available interfaces displays. The interface numbering that appears depends on the type of platform and on the installed interface modules and cards.



Example:
Current interface summary
Interface                  IP-Address      OK? Method Status                Prol
Ethernet0/0                unassigned      YES NVRAM  administratively down dow 
Ethernet1/0                unassigned      YES NVRAM  administratively down dow 
Serial2/0                  unassigned      YES NVRAM  administratively down dow 
Serial3/0                  unassigned      YES NVRAM  administratively down dow 
Loopback0                  1.1.1.1         YES NVRAM  up                    up  
Enter interface name used to connect to the
management network from the above interface summary:
Step 10   Select an interface to connect the router to the management network:

Example:
Enter interface name used to connect to the
management network from the above interface summary: Ethernet0/0
Step 11   Respond to the prompts as appropriate for your network. In this example, IP is configured: an IP address is entered and the current subnet mask is accepted. The screen displays the command script created.

Example:
Configuring interface Ethernet0/0:
  Configure IP on this interface? [no]: yes
    IP address for this interface: 172.17.1.1
    Subnet mask for this interface [255.255.0.0] : 
    Class B network is 172.17.0.0, 16 subnet bits; mask is /16 
The following configuration command script was created:
hostname Router
enable secret 5 $1$1Gg9$GuxXfUUBBfVqGvlW4psIm1
enable password cts54tnl
line vty 0 4
password tls6gato
no snmp-server
!
no ip routing
!
interface Ethernet0/0
no shutdown
ip address 172.17.1.1 255.255.0.0
!
interface Ethernet1/0
shutdown
no ip address
!
interface Serial2/0
shutdown
no ip address
!
interface Serial3/0
shutdown
no ip address
!
end
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]: 
Step 12   Enter 2orpressEnterto save the configuration file to NVRAM and exit.

Example:
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]: 2

The screen displays the following:



Example:
Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.
Router#
00:01:32: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
00:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed p

What to Do Next

Proceed to the "Verifying the Configuration" section.

Using the System Configuration Dialog to Make Configuration Changes

The System Configuration Dialog is an alternative to the CLI when configuration changes do not require the level of detail the CLI provides. For example, you can use the System Configuration Dialog to add a protocol suite, make addressing scheme changes, or configure a newly installed interface. Although you can use configuration modes available through the CLI to make these changes, the System Configuration Dialog provides you a high-level view of the configuration and guides you through the configuration process.

Before You Begin

When you add or modify hardware and need to update a configuration, refer to documentation for your platform for details about physical and logical port assignments.


Note


The System Configuration Dialog does not allow you to randomly select or enter parameters for configuration. You must move through the dialog step by step until the screen shows the information you want to change.



SUMMARY STEPS

1.    enable

2.    setup

3.    Follow Steps 3 through 12 in the Detailed Steps in the preceding "Using the System Configuration Dialog to Create an Initial Configuration File" section on page 5 .

4.    Verify the configuration is modified correctly. Refer to the "Verifying the Configuration" section.


DETAILED STEPS
Step 1   enable

The enable command enters privileged EXEC mode.



Example:
Router> enable
Router#
Step 2   setup

The setup command puts the router in setup mode.



Example:
Router# setup

The screen displays the following:



Example:
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: 

Enter yes attheprompttocontinuethedialog.



Example:
Continue with configuration dialog? [yes/no]: yes
 
The screen displays the following:
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: 
Step 3   Follow Steps 3 through 12 in the Detailed Steps in the preceding "Using the System Configuration Dialog to Create an Initial Configuration File" section on page 5 .
Step 4   Verify the configuration is modified correctly. Refer to the "Verifying the Configuration" section.

Verifying the Configuration

Perform this task to verify that the configuration you created using the System Configuration Dialog is operating correctly.

SUMMARY STEPS

1.    show interfaces

2.    show ip interface brief

3.    show configuration


DETAILED STEPS
Step 1   show interfaces

This command verifies that the interfaces are operating correctly and that they and the line protocol are in the correct state: up or down.

Step 2   show ip interface brief

This command displays a summary status of the interfaces configured for IP.

Step 3   show configuration

This command verifies that the correct hostname and password were configured.


Example

This example is the verification of the configuration file created in the "Using the System Configuration Dialog to Create an Initial Configuration File" section.

Router# show interfaces
Ethernet0/0 is up, line protocol is up
  Hardware is AmdP2, address is aabb.cc03.6c00 (bia aabb.cc03.6c00)
  Internet address is 172.17.1.1/16
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:06, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     11 packets output, 1648 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Ethernet1/0 is administratively down, line protocol is down
  Hardware is AmdP2, address is aabb.cc03.6c01 (bia aabb.cc03.6c01)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial2/0 is administratively down, line protocol is down
  Hardware is M4T
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=down  RTS=down  CTS=up
Serial3/0 is administratively down, line protocol is down
  Hardware is M4T
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=down  DSR=down  DTR=up  RTS=up  CTS=down
Loopback0 is up, line protocol is up
  Hardware is Loopback
  Internet address is 1.1.1.1/32
  MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation LOOPBACK, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
Router# show ip interface brief
Interface                  IP-Address      OK? Method Status                Prol
Ethernet0/0                172.17.1.1      YES manual up                    up
Ethernet1/0                unassigned      YES manual administratively down dow
Serial2/0                  unassigned      YES manual administratively down dow
Serial3/0                  unassigned      YES manual administratively down dow
Loopback0                  1.1.1.1         YES NVRAM  up                    up
Router# show configuration
Using 1029 out of 8192 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$1Gg9$GuxXfUUBBfVqGvlW4psIm1
enable password cts54tnl
!
no aaa new-model
!
resource manager
!
clock timezone PST -8
ip subnet-zero
no ip routing
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 no ip route-cache
!
interface Ethernet0/0
 ip address 172.17.1.1 255.255.0.0
 no ip route-cache
!
interface Ethernet1/0
 no ip address
 no ip route-cache
 shutdown
!
interface Serial2/0
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 no ip route-cache
 shutdown
 serial restart-delay 0
!
!
ip classless
no ip http server
!
!
!
!
control-plane
!
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 password tls6gato
 login
 transport preferred all
 transport input all
 transport output all
!
end

Configuration Examples for Using Cisco IOS Setup Mode to Configure a Cisco Networking Device

Example Configuring Ethernet Interface 0 Using the System Configuration Dialog

In the following example, the System Configuration Dialog is used to configure Ethernet interface 0 with an IP address.


Note


Prompts and the order in which they appear on the screen vary depending on the platform and the interfaces installed in the device.
R1# setup
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: yes
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:
  Enter host name [R1]: Router
  The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: 1g2j3mmc
  The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: cts54tnl
  The virtual terminal password is used to protect
  access to the router over a network interface.
  Enter virtual terminal password: tls6gato
  Configure SNMP Network Management? [no]:
Current interface summary
Interface                  IP-Address      OK? Method Status                Prol
Ethernet0/0                172.17.1.1      YES manual up                    up
Ethernet1/0                unassigned      YES manual administratively down dow
Serial2/0                  unassigned      YES manual administratively down dow
Serial3/0                  unassigned      YES manual administratively down dow
Loopback0                  1.1.1.1         YES NVRAM  up                    up
Enter interface name used to connect to the
management network from the above interface summary: Ethernet0/0
Configuring interface Ethernet0/0:
  Configure IP on this interface? [no]: yes
    IP address for this interface: 172.17.1.1
    Subnet mask for this interface [255.255.0.0] :
    Class B network is 172.17.0.0, 16 subnet bits; mask is /16
The following configuration command script was created:
hostname Router
enable secret 5 $1$1Gg9$GuxXfUUBBfVqGvlW4psIm1
enable password cts54tnl
line vty 0 4
password tls6gato
no snmp-server
!
no ip routing
!
interface Ethernet0/0
no shutdown
ip address 172.17.1.1 255.255.0.0
!
interface Ethernet1/0
shutdown
no ip address
!
interface Serial2/0
shutdown
no ip address
!
interface Serial3/0
shutdown
no ip address
!
end
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]:
Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.
Router#
00:01:32: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
00:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed p

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.