Asynchronous Transfer Mode Configuration Guide, Cisco IOS Release 15M&T
ATM Multilink PPP Support on Multiple VCs
Downloads: This chapterpdf (PDF - 157.0KB) The complete bookPDF (PDF - 8.16MB) | The complete bookePub (ePub - 2.19MB) | Feedback

ATM Multilink PPP Support on Multiple VCs

ATM Multilink PPP Support on Multiple VCs

Last Updated: December 4, 2012

The ATM Multilink PPP Support on Multiple VCs feature facilitates traffic load balancing on high-speed virtual circuits (VCs) using multilink PPP (MLP) over Frame Relay and ATM. It also facilitates traffic load balancing by using MLP to combine packet datagrams on high-speed VCs as a means of transporting both the voice and data traffic more efficiently.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Restrictions for ATM Multilink PPP Support

The ATM Multilink PPP Support on Multiple VCs feature does not support the following commands and functionality. The configuration accepts these commands, but the commands have no effect:

  • ppp interleave
  • ppp multilink fragment-delay

The ATM Multilink PPP Support on Multiple VCs feature does not support the link fragmentation and interleaving (LFI) functionality.

Information About ATM Multilink PPP Support

ATM Multilink PPP Support Overview

Load balancing operates at Layer 2 or Layer 3 (the network layer) of the Open System Interconnection (OSI) reference model. Layer 3 load balancing is independent of any link-layer technologies. The ATM Multilink Point-to-Point Protocol (PPP) Support on Multiple VCs feature implements load balancing at Layer 2 and depends on having MLP enabled at the link layer.

The ATM MLP functionality keeps track of packet sequencing, and this functionality buffers any packets that arrive early. With this ability, ATM MLP preserves packet order across the entire bundle.

In addition to MLP, low latency queueing (LLQ) and class-based weighted fair queueing (CBWFQ) are used to prioritize and differentiate the voice and data packets. LLQ and CBWFQ help to ensure that the voice and data traffic receive the proper quality of service (QoS) treatment (such as the correct priority queue assignment) when the voice and data traffic are transmitted.

For more information about LLQ and CBWFQ, see the Cisco IOS Quality of Service Solutions Configuration Guide.

Benefits of ATM Multilink PPP Support

Facilitates More Efficient Traffic Load Balancing

The ATM Multilink PPP Support on Multiple VCs feature supports the transport of real-time (voice) and other (data) traffic on Frame Relay and ATM VCs.

How to Configure ATM Multilink PPP Support

Defining the Service Policy Using the MQC

Perform this task to define the service policy using the MQC. The MQC allows you to create class maps and define service policies. Service policies are used to create classes and set match criteria for classifying traffic.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    class-map class-map-name [match-all| match-any]

4.    match ip precedence ip-precedence-value [ip-precedence-value ip-precedence-value ip-precedence-value]

5.    exit

6.    policy-map policy-name

7.    class-map class-map-name [match-all| match-any

8.    bandwidth {bandwidth-kbps | percent percent}

9.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
class-map class-map-name [match-all| match-any]


Example:

Router(config)# class-map class1

 

Specifies the name of the class map to be created and enters class-map configuration mode. If match-all or match-any value is not specified, traffic must match all the match criteria to be classified as part of the class map.

 
Step 4
match ip precedence ip-precedence-value [ip-precedence-value ip-precedence-value ip-precedence-value]


Example:

Router(config-cmap)# match ip precedence 3 2 4

 

Identifies IP precedence values as match criteria.

 
Step 5
exit


Example:

Router(config-cmap)# exit

 

Exits class-map configuration mode.

 
Step 6
policy-map policy-name


Example:

Router(config)# policy-map policy1

 

Specifies the name of the policy map to be created and enters policy-map configuration mode.

 
Step 7
class-map class-map-name [match-all| match-any


Example:

Router(config-pmp)# class class2

 

Classifies traffic based on the class map specified and enters policy-map class configuration mode.

 
Step 8
bandwidth {bandwidth-kbps | percent percent}


Example:

Router (config-pmap-c)# bandwidth 45

 

Specifies a minimum bandwidth guarantee to a traffic class in periods of congestion.

  • A minimum bandwidth guarantee can be specified in kbps or by a percentage of the overall available bandwidth.
 
Step 9
end


Example:

Router(config-pmp)# end

 

Exits class-map configuration mode.

 

Defining a Multilink MLP Bundle Interface

Perform this task to define a multilink MLP bundle interface. The purpose of a multilink bundle interface is to combine more than one permanent virtual circuit (PVC). All configurations for PPP over ATM links are placed into virtual templates, and the bundle parameters are placed into the multilink bundle.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    ip address ip-address mask [secondary]

5.    load-interval seconds

6.    no cdp enable

7.    service-policy output policy-name

8.    ppp multilink

9.    ppp multilink fragment disable

10.    ppp multilink group group-number

11.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface multilink 34

 

Configures an interface type and enters interface configuration mode.

 
Step 4
ip address ip-address mask [secondary]


Example:

Router(config-if)# ip address 209.165.201.1 255.255.255.0

 

Sets a primary or secondary IP address for an interface.

 
Step 5
load-interval seconds


Example:

Router(config-if)# load-interval 60

 

Changes the length of time for which data is used to compute load statistics.

 
Step 6
no cdp enable


Example:

Router(config-if)# no cdp enable

 

Disables Cisco Discovery Protocol (CDP) on an interface.

 
Step 7
service-policy output policy-name


Example:

Router(config-if)# service-policy output policy1

 

Attaches the specified policy map to the output interface.

 
Step 8
ppp multilink


Example:

Router(config-if)# ppp multilink

 

Enables MLP on an interface.

 
Step 9
ppp multilink fragment disable


Example:

Router(config-if)# ppp multilink fragment disable

 

Disables packet fragmentation.

 
Step 10
ppp multilink group group-number


Example:

Router(config-if)# ppp multilink group 54

 

Restricts a physical link to joining only a designated multilink-group interface.

 
Step 11
end


Example:

Router(config-if)# end

 

Exits interface configuration mode.

 

Defining the Virtual Templates for Member Links

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    no ip address

5.    load-interval seconds

6.    ppp multilink

7.    ppp multilink group group-number

8.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface multilink 34

 

Configures an interface type and enters interface configuration mode.

 
Step 4
no ip address


Example:

Router(config-if)# no ip address

 

Removes existing IP addresses or disables IP processing.

 
Step 5
load-interval seconds


Example:

Router(config-if)# load-interval 30

 

Changes the length of time for which data is used to compute load statistics.

 
Step 6
ppp multilink


Example:

Router(config-if)# ppp multilink

 

Enables MLP on the interface.

 
Step 7
ppp multilink group group-number


Example:

Router(config-if)# ppp multilink-group 44

 

Restricts a physical link to joining only a designated multilink-group interface.

 
Step 8
end


Example:

Router(config-if)# end

 

Exits interface configuration mode.

 

Defining the PVCs and Bundling Member Links

SUMMARY STEPS

1.    enable

2.    configure terminal

3.   Do one of the following:

  • interface atm slot /0
  • interface atm slot / port

4.    no ip address

5.    load interval seconds

6.    atm ilmi-keepalive [seconds [retry[seconds]]]

7.    pvc [name ] vpi/vci

8.    vbr-nrt output-pcr output-scr [output-mbs ]

9.    tx-ring-limit ring-limit

10.    protocol ppp virtual-template number

11.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
Do one of the following:
  • interface atm slot /0
  • interface atm slot / port


Example:

Router(config)# interface atm 2/0



Example:

or



Example:

Router(config)# interface atm 2/1

 

Specifies the ATM interface type and enters interface configuration mode.

 
Step 4
no ip address


Example:

Router(config-if)# no ip address

 

Removes an IP address or disables IP processing.

 
Step 5
load interval seconds


Example:

Router(config-if)# load interval 30

 

Changes the length of time for which data is used to compute load statistics.

 
Step 6
atm ilmi-keepalive [seconds [retry[seconds]]]


Example:

Router(config-if)# atm ilmi-keepalive

 

Enables Interim Local Management Interface (ILMI) keepalives.

 
Step 7
pvc [name ] vpi/vci


Example:

Router(config-if)# pvc pvc1 0/56

 

Creates an ATM PVC. Enters interface-ATM-VC configuration mode.

 
Step 8
vbr-nrt output-pcr output-scr [output-mbs ]


Example:

Router(config-if-atm-vc)# vbr-nrt 45 4 45

 

Configures the variable bit rate (VBR)-non real time (NRT) QoS and specifies output peak cell rate, output sustainable cell rate, and output maximum burst cell size.

 
Step 9
tx-ring-limit ring-limit


Example:

Router(config-if-atm-vc)# tx-ring-limit 3

 

Limits the number of particles or packets that can be used on a transmission ring on an interface.

  • Use this command to tune the transmission ring to assign most of the packets to the Layer 3 queues.
 
Step 10
protocol ppp virtual-template number


Example:

Router(config-if-atm-vc)# protocol ppp virtual-template 34

 

Specifies that PPP is established over the ATM PVC using the configuration from the specified virtual template and enters interface configuration mode.

 
Step 11
end


Example:

Router(config-if)# end

 

Exits interface configuration mode.

 

Verifying ATM Multilink PPP Support

Perform this task to display information about ATM Multilink PPP Support on Multiple VCs:

SUMMARY STEPS

1.    enable

2.    show atm pvc

3.    show frame-relay pvc [[interface interface] [dlci] [64-bit] | summary [all]]

4.    show interfaces

5.    show policy-map

6.    show ppp multilink

7.    show queueing


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
show atm pvc


Example:

Router# show atm pvc

 

Displays all ATM PVCs and traffic information.

 
Step 3
show frame-relay pvc [[interface interface] [dlci] [64-bit] | summary [all]]


Example:

Router# show frame-relay pvc 16

 

Displays statistics about PVCs for Frame Relay interfaces.

 
Step 4
show interfaces


Example:

Router# show interfaces

 

Displays interleaving statistics.

  • Interleaving data is displayed only if interleaving occurs.
 
Step 5
show policy-map


Example:

Router# show policy-map

 

Displays the configuration of all classes for a specified service policy map or all classes for all existing policy maps.

 
Step 6
show ppp multilink


Example:

Router# show ppp multilink

 

Displays bundle information for the MLP bundles and their PPP links in the router.

 
Step 7
show queueing


Example:

Router# show queueing

 

Lists all or selected configured queueing strategies.

 

Monitoring ATM Multilink PPP Support

SUMMARY STEPS

1.    enable

2.    debug atm errors

3.    debug atm events

4.    debug ppp error

5.    debug ppp multilink events

6.    debug voice rtp


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
debug atm errors


Example:

Router# debug atm errors

 

Displays ATM errors.

 
Step 3
debug atm events


Example:

Router# debug atm events

 

Displays ATM events.

 
Step 4
debug ppp error


Example:

Router# debug ppp error

 

Displays information on traffic and exchanges in an internetwork implementing the PPP.

 
Step 5
debug ppp multilink events


Example:

Router# debug ppp multilink events

 

Displays information about events affecting multilink groups.

 
Step 6
debug voice rtp


Example:

Router# debug voice RTP

 

Displays information about the interleaving of voice and data packets.

  • The debug voice RTP command has memory overhead and should not be used when memory is scarce or when traffic is very high.
 

Configuration Examples for ATM Multilink PPP Support

Defining the Service Policy Using MQC Example

The following example shows how to configure a service policy using the MQC:

Router> enable
Router# configure terminal
Router(config)# class-map match-all DATA
Router(config-cmap)# match ip precedence 0
Router(config-cmap)# class-map match-all VOICE
Router(config-cmap)# match access-group 100
Router(config-cmap)# policy-map CISCO
Router(config-pmap)# class VOICE
Router(config-pmap-c)# priority percent 70
Router(config-pmap-c)# class DATA
Router(config-pmap-c)# bandwidth percent 5
Router(config-pmap-c)# access-list 100 permit udp any any precedence critical

Defining a Multilink MLP Bundle Interface Example

The following example shows how to define a multilink bundle for the mulitilink interface:

Router> enable
Router# configure terminal
Router(config)# interface Multilink1
Router(config-if)# ip address 10.2.1.1 255.0.0.0
Router(config-if)# load-interval 30
Router(config-if)# no cdp enable
Router(config-if)# service-policy output CISCO
Router(config-if)# ppp multilink fragment disable
Router(config-if)# ppp multilink group 1

Defining Virtual Templates for Member Links Example

The following example shows how to define virtual templates for member links:

Router> enable
Router# configure terminal
Router(config)# interface Virtual-Template1
Router(config-if)# no ip address
Router(config-if)# load-interval 30
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink group 1
Router(config-if)# interface Virtual-Template2
Router(config-if)# no ip address
Router(config-if)# load-interval 30
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink group 1

Defining PVCs and Bundling Member Links Example

The following example shows how to define and configure PVCs as bundle members:

Router> enable
Router# configure terminal
Router(config)# interface atm 6/0
Router(config-if)# no ip address
Router(config-if)# load-interval 30
Router(config-if)# atm ilmi-keepalive
Router(config-if)# pvc 0/34
 
Router(config-if-atm-vc)# vbr-nrt 1536 1536
Router(config-if-atm-vc)# tx-ring-limit 5
Router(config-if-atm-vc)# protocol ppp Virtual-Template1
Router(config-if-atm-vc)# pvc 0/35
 
Router(config-if-atm-vc)# vbr-nrt 800 800
Router(config-if-atm-vc)# tx-ring-limit 3
Router(config-if-atm-vc)# protocol ppp Virtual-Template2
Router(config-if-atm-vc)# pvc 0/36 
Router(config-if-atm-vc)# vbr-nrt 800 400 94
Router(config-if-atm-vc)# tx-ring-limit 5
Router(config-if-atm-vc)# protocol ppp Virtual-Template1
Router(config-if-atm-vc)# pvc 0/37
Router(config-if-atm-vc)# vbr-nrt 800 800
Router(config-if-atm-vc)# tx-ring-limit 3
Router(config-if-atm-vc)# protocol ppp Virtual-Template2
Router(config-if-atm-vc)# end

Additional References

The following sections provide references related to the ATM Multilink PPP Support on Multiple VCs feature.

Related Documents

Related Topic

Document Title

QoS configuration tasks

Cisco IOS Quality of Service Solutions Configuration Guide

QoS commands: complete command syntax, defaults, command mode, command history, usage guidelines, and examples

Cisco IOS Quality of Service Solutions Command Reference

WAN configuration tasks

Cisco IOS Wide-Area Networking Configuration Guide

WAN commands: complete command syntax, defaults, command mode, command history, usage guidelines, and examples

Cisco IOS Wide-Area Networking Command Reference

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Standards

Standard

Title

None

--

MIBs

MIB

MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

RFC 1990

The PPP Multilink Protocol (MP)

Technical Assistance

Description

Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for ATM Multilink PPP Support

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for ATM Multilink PPP Support on Multiple VCs

Feature Name

Releases

Feature Information

ATM Multilink PPP Support on Multiple VCs

12.2(28)SB 12.2(13)T 12.2(33)SRE

The ATM Multilink PPP Support on Multiple VCs feature facilitates traffic load balancing on high-speed virtual circuits, using MLP over Frame Relay and ATM. It facilitates traffic load balancing by using MLP to combine packet datagrams on high-speed VCs, as a means for transporting both the voice and data traffic more efficiently.

Glossary

LFI --link fragmentation and interleaving. Method of fragmenting large packets and then queueing the fragments between small packets.

MLP --multilink PPP.

QoS --quality of service.

VC --virtual circuit.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.