Installation and Configuration Guide for Cisco Services Ready Engine Virtualization 1.0
Configuring the Cisco SRE Service Module Interfaces
Downloads: This chapterpdf (PDF - 869.0KB) The complete bookPDF (PDF - 4.28MB) | Feedback

Configuring the Cisco SRE Service Module Interfaces

Table Of Contents

Configuring the Cisco SRE Service Module Interfaces

Basic Workflow for Configuring the Cisco SRE Service Module Interfaces

Cisco SRE Service Module Interfaces Overview

Configuring the Cisco SRE Service Module Interfaces

Prerequisites for Configuring the Cisco SRE Service Module Interfaces

Configuring the Cisco SRE Service Module Interfaces on the Router

MGF Layer 2 Switched Configuration—Recommended

Cisco IOS Layer 3 Routed Configuration

External Interface Configuration

Configuring VLANs

Configuring VLANs with MGF Layer 2 Switched Configuration

Configuring VLANS with Cisco IOS Layer 3 Routed Configuration

Configuring VLANs with External Interface Configuration

Reload, Reset, and Shut Down Commands


Configuring the Cisco SRE Service Module Interfaces


This chapter provides information about how to configure the Cisco SRE Service Module interfaces to run the Cisco SRE-V System software.

Before you begin, make sure that the ISR G2 in which the Cisco SRE Service Module is installed is running the supported Cisco IOS software version. See the "Verifying the Router, Cisco SRE Service Module, and Cisco IOS Software Version Compatibility" section on page 2-2.

This chapter contains the following sections:

Basic Workflow for Configuring the Cisco SRE Service Module Interfaces

Cisco SRE Service Module Interfaces Overview

Configuring the Cisco SRE Service Module Interfaces

Configuring VLANs

Reload, Reset, and Shut Down Commands

Basic Workflow for Configuring the Cisco SRE Service Module Interfaces

1. Configure the Cisco SRE service-module interface, sm1/0.

2. Configure the Cisco SRE service-module interface, sm1/1.

3. Configure VLAN 1.

4. (Optional) Configure additional VLANs.

See the "Configuring the Cisco SRE Service Module Interfaces on the Router" section and the "Configuring VLANs" section.

Cisco SRE Service Module Interfaces Overview

The host router and the Cisco SRE Service Module use several interfaces for internal and external communication. Use the Cisco IOS CLI commands to configure each of the interfaces on the router.

Before configuring the interfaces, make sure that you have the following information for entering the Cisco SRE Service Module command environment:

IP address of the Cisco router that contains the Cisco SRE Service Module.

Username and password for logging into the router.

Slot and unit number of the Cisco SRE Service Module.

The Cisco SRE Service Module communicates with the host router through the following three interfaces:

Console Manager Interface—Console Manager interface allows you to access the service module console to perform SRE-V configuration. Accessible from within the host router, this interface provides an internal Layer 3 Gigabit Ethernet link between the router and the Cisco SRE Service Module. All configuration and management of the Console Manager interface is performed using the Cisco IOS CLI.

MGF Interface—MGF interface enables the Cisco SRE Service Module to communicate over a high-speed backplane switch. Accessible from within the host router, this interface provides an internal Layer 2 Gigabit Ethernet link between the router and the Cisco SRE Service Module. Configuration of the MGF interface is performed using the Cisco IOS CLI. For more information about configuring MGF, see the "Multi-Gigabit Fabric on the Router" chapter in the Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software Configuration Guide on Cisco.com.

External Service Module Interface—VMware vSphere HypervisorTM or virtual machines can use the external service module interface as a primary interface or as a backup interface. Unlike the internal interfaces, the external interface is primarily controlled and managed by the VMware vSphere HypervisorTM. The traffic does not go into the router unless the VMware vSphere HypervisorTM is configured to forward the traffic into the router through the MGF interface.

Related Topics

Configuring the Cisco SRE Service Module Interfaces

Configuring the Cisco SRE Service Module Interfaces

This section describes how to configure basic network parameters for the Cisco SRE Service Module using the Cisco IOS CLI. It contains the following sections:

Prerequisites for Configuring the Cisco SRE Service Module Interfaces

Configuring the Cisco SRE Service Module Interfaces on the Router

Configuring VLANs

Prerequisites for Configuring the Cisco SRE Service Module Interfaces

This section provides the prerequisites for the router, Cisco SRE Service Module, and FTP/SFTP/HTTP server.

Cisco Router Prerequisites

Make sure that your Cisco router is running the appropriate Cisco IOS software version and recognizes the Cisco SRE Service Module. See the "Verifying the Router, Cisco SRE Service Module, and Cisco IOS Software Version Compatibility" section on page 2-2 and the "Verifying Cisco SRE Service Module Installation" section on page 2-3.

Cisco SRE Service Module Prerequisites


Note In most cases, the routers are shipped with the Cisco SRE Service Module already installed in them.


Identify the Cisco SRE Service Module slot and port location in the host router:

slot—ID of the host router chassis slot in which the Cisco SRE Service Module resides. After you install the service module, you can obtain this information by using the Cisco IOS software CLI show running-config command.

port—ID of the Network Interface Card (NIC) on the Cisco SRE Service Module.
The value is 0 for the Console Manager interface; and 1 for the MGF interface.

Related Topics

Configuring the Cisco SRE Service Module Interfaces on the Router

Configuring the Cisco SRE Service Module Interfaces on the Router

Configure the internal interfaces between the Cisco SRE Service Module and the host router. This initial configuration allows you to access the service module to install and configure the Cisco SRE-V application.

Cisco SRE-V provides the following three configuration options:

MGF Layer 2 Switched Configuration—This configuration option provides faster performance and has no impact on the router CPU because the traffic goes through the EtherSwitch rather than the router. It supports all Layer 2 functions, such as broadcasting. You must purchase a EtherSwitch EHWIC or EtherSwitch Service Module to use this configuration option.

Cisco IOS Layer 3 Routed Configuration—This configuration option does not require additional equipment; however, it has an impact on the router CPU. This option is complex, and some of the Layer 2 functions, such as broadcasting, are not supported.

External Interface Configuration—This configuration option is simple to configure, low in cost, and has no impact on the router CPU. However, it requires extra cabling and an extra Gigabit Ethernet switchport on the external switch. In addition, you cannot use Cisco IOS features on the VMware vSphere HypervisorTM networks (for example, you cannot put a virtual machine into a DMZ), and you cannot take advantage of the hardware TCP/IP/UDP/iSCSI off load features that are available on the internal interfaces.

See the following sections for more information:

MGF Layer 2 Switched Configuration—Recommended

Cisco IOS Layer 3 Routed Configuration

External Interface Configuration

MGF Layer 2 Switched Configuration—Recommended

Figure 3-1 shows the traffic flow in the MGF Layer 2 switched configuration. The MGF backplane switch connects the virtual network across multiple hypervisors and allows direct access to the LAN through Cisco EtherSwitch EHWICs or EtherSwitch Service Modules, without sending the traffic through the router CPU. For supported Cisco EtherSwitch EHWICs and EtherSwitch Service Modules, see Table 1-2.

Figure 3-1 Traffic Flow in the MGF Layer 2 Switched Configuration

Figure 3-2 shows the location of the IP addresses that you configure on the Cisco SRE service module interfaces.

The Console Manager needs two IP addresses: One IP address is for the router side of the router-to-console manager link; and the other IP address is for the Console Manager side of the link.

The VMware vSphere HypervisorTM also needs two IP addresses: One IP address is for the router side of the link that connects the router to the VMware vSphere HypervisorTM; and the other IP address is for the VMware vSphere HypervisorTM.

Figure 3-2 IP Address Location

PREREQUISITES

See the "Prerequisites for Configuring the Cisco SRE Service Module Interfaces" section.

SUMMARY STEPS

From the Host-Router CLI, enter:

1. enable

2. configure terminal

Configure slot/0 of the Console Manager

1. interface sm slot/0

2. ip address console-manager-router-side-ip-address subnet-mask
or
ip unnumbered type number

3. service-module ip address console-manager-ip-address subnet-mask

4. service-module ip default-gateway console-manager-gateway-ip-address

5. service-module mgf ip address hypervisor-ip-address subnet-mask

6. no shut

7. exit

8. [ip route console-manager-ip-address subnet-mask sm slot/0]

Configure slot/1 of the Console Manager

1. interface sm slot/1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers]

4. exit

Configure VLAN 1

1. interface vlan 1

2. ip address hypervisor-router-side-ip-address subnet-mask

3. no shut

4. end

5. copy running-config startup-config

6. show running-config

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

<password>

Example:

Router> enable

Router> <password>

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

 
Configure slot/0 of the Console Manager

Step 1 

interface sm slot/0

Example:

Router(config)# interface sm 1/0

Enters interface configuration mode for the slot and port where the Cisco SRE Service Module resides.

Step 2 

ip address console-manager-router-side-ip-address subnet-mask


or

ip unnumbered type number

Example:

Router(config-if)# ip address 10.0.0.100 255.255.255.0


 or

Router(config-if)# ip unnumbered gigabitethernet 1/0

Specifies the IP address for the router side of the link that connects the router to the Console Manager.

The Console Manager needs two IP addresses: One IP address is for the router side of the router-to-console manager link; and the other IP address is for the Console Manager side of the link. In this step, you configure the IP address for the router side of the link. See Figure 3-2.

console-manager-router-side-ip-address subnet-mask—IP address for the router side of the link that connects the router to the Console Manager. Subnet mask to append to the IP address.

or

The ip unnumbered command enables IP processing on an interface without assigning an explicit IP address to that interface.

type—Type of interface on which the router has an assigned IP address.

number—Number of the interface on which the router has an assigned IP address.

Note The unnumbered interface must be unique. It cannot be another unnumbered interface.


Caution The ip unnumbered command creates a point-to-point interface between devices. Broadcasting is not supported.

Note If you use the ip unnumbered command, you must use the ip route console-manager-ip-address subnet-mask sm slot/0 command to create a static route. See Step 8.

Step 3 

service-module ip address console-manager-ip-address subnet-mask

Example:

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

Specifies the IP address for the Console Manager.

console-manager-ip-address—IP address for the Console Manager. See Figure 3-2.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Note If you change the Console Manager IP address, you must reload the service module.

Step 4 

service-module ip default-gateway console-manager-gateway-ip-address

Example:

Router(config-if)# service-module ip default-gateway 10.0.0.100

Specifies the IP address of the default gateway for the Console Manager.

console-manager-gateway-ip-address—IP address for the default gateway router.

Step 5 

service-module mgf ip address hypervisor-ip-address subnet-mask

Example:

Router(config-if)# service-module mgf ip address 20.0.0.1 255.255.255.0

Specifies the IP address of the VMware vSphere HypervisorTM.

hypervisor-ip-address—IP address of the VMware vSphere HypervisorTM. See Figure 3-2.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Step 6 

no shut

Example:

Router(config-if)# no shut

Causes the interface to be administratively up.

Step 7 

exit

Example:

Router(config)# exit

Returns to global configuration mode on the host router.

Step 8 

[ip route console-manager-ip-address subnet-mask sm slot/0]

Example:

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

Creates a static route.

If you used the ip unnumbered command in Step 2, you must use the ip route console-manager-ip-address subnet-mask sm slot/0 command to create a static route.

console-manager-ip-address subnet-mask—IP address and subnet mask of the Console Manager.

slot/0—slot and port where the Cisco SRE Service Module resides.

 
Configure slot/1 of the Console Manager

Step 1 

interface sm slot/1

Example:

Router(config)# interface sm 1/1

Enters interface configuration mode for the slot and port where the Cisco SRE Service Module resides.

Step 2 

switchport mode trunk

Example:

Router(config-if)# switchport mode trunk

Puts the port into permanent trunking mode.

The default configuration is access mode. Access mode works with native VLAN, which is VLAN 1 for the
Cisco SRE Service Modules.

Step 3 

[switchport trunk allowed vlan vlan_numbers]

Example:

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 40, 60

(Optional) Allows trunking on the specified VLANs.

vlan_numbers—VLAN numbers on which you want to allow trunking.

Step 4 

exit

Example:

Router(config)# exit

Returns to global configuration mode on the host router.

 
Configure VLAN 1

Step 1 

interface vlan 1

Example:

Router(config)# interface vlan 1

Enters VLAN configuration mode for VLAN 1.

Step 2 

ip address hypervisor-router-side-ip-address subnet-mask

Example:

Router(config-if)# ip address 20.0.0.100 255.255.255.0

Specifies the IP address for the router side of the router-to-VMware vSphere HypervisorTM link. See Figure 3-2.

hypervisor-router-side-ip-address—IP address for the router side of the link that connects the router to the VMware vSphere HypervisorTM; must be in the same subnet as the IP address of the VMware vSphere HypervisorTM that you configured in Step 5.

subnet-mask—Subnet mask to append to the IP address.

Step 3 

no shut

Example:

Router(config-if)# no shut

Causes the interface to be administratively up.

Step 4 

end

Example:

Router(config)# end

Returns to global configuration mode on the host router.

Step 5 

copy running-config startup-config

Example:

Router# copy running-config startup-config

Saves the new running configuration of the router as the startup configuration.

Step 6 

show running-config

Example:

Router# show running-config

Displays the running configuration of the router so that you can verify the address configurations.

Example

Figure 3-3 shows an example of the MGF Layer 2 switched configuration.

The left pane shows an example of the Cisco IOS commands that you configure in the
sm 1/0, sm 1/1, and vlan 1 interfaces.

The right pane shows that the configuration is applied to the Console Manager and to the VMware vSphere HypervisorTM in Cisco SRE-V. The bottom area in the right pane shows the configuration for the Microsoft Windows Server that is configured using the standard Microsoft Windows network configuration setup process. This Microsoft Windows Server runs as a virtual machine.


Note The IP addresses in the configuration example are for reference only and might not be valid.


Figure 3-3 Configuration Example of the MGF Layer 2 Switched Configuration

Related Topics

Configuring VLANs with MGF Layer 2 Switched Configuration

Downloading the Cisco SRE-V Software, page 4-1

Cisco IOS Layer 3 Routed Configuration

Figure 3-4 shows the traffic flow in the Cisco IOS Layer 3 routed configuration. The MGF backplane switch forwards the traffic to the router CPU.

Figure 3-4 Traffic Flow in the Cisco IOS Layer 3 Routed Configuration

SUMMARY STEPS

From the Host-Router CLI, enter:

1. enable

2. configure terminal

Configure slot/0 of the Console Manager

1. interface sm slot/0

2. ip address console-manager-router-side-ip-address subnet-mask
or
ip unnumbered type number

3. service-module ip address console-manager-ip-address subnet-mask

4. service-module ip default-gateway console-manager-gateway-ip-address

5. service-module mgf ip address hypervisor-ip-address subnet-mask

6. no shut

7. exit

8. [ip route console-manager-ip-address subnet-mask sm slot/0]

Configure slot/1 of the Console Manager

1. interface sm slot/1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers]

4. exit

Configure VLAN 1

1. interface vlan 1

2. ip unnumbered gigabitethernet slot/port interface

Configure GE slot/port

1. interface gigabitethernet slot/port interface

2. ip address branch-LAN-ip-address subnet-mask

3. exit

4. ip route hypervisor-ip-address subnet-mask vlan 1

5. ip route virtual-machine-ip-address subnet-mask vlan 1

6. no shut

7. end

8. copy running-config startup-config

9. show running-config

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

<password>

Example:

Router> enable

Router> <password>

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

 
Configure slot/0 of the Console Manager

Step 1 

interface sm slot/0

Example:

Router(config)# interface sm 1/0

Enters interface configuration mode for the slot and port where the Cisco SRE Service Module resides.

Step 2 

ip address console-manager-router-side-ip-address subnet-mask


or

ip unnumbered type number

Example:

Router(config-if)# ip address 10.0.0.100 255.255.255.0


 or

Router(config-if)# ip unnumbered gigabitethernet 1/0

Specifies the IP address for the router side of the link that connects the router to the Console Manager.

The Console Manager needs two IP addresses: One IP address is for the router side of the router-to-console manager link; and the other IP address is for the Console Manager side of the link. In this step, you configure the IP address for the router side of the link. See Figure 3-2.

console-manager-router-side-ip-address subnet-mask—IP address for the router side of the link that connects the router to the Console Manager. Subnet mask to append to the IP address.

or

The ip unnumbered command enables IP processing on an interface without assigning an explicit IP address to that interface.

type—Type of interface on which the router has an assigned IP address.

number—Number of the interface on which the router has an assigned IP address.

Note The unnumbered interface must be unique. It cannot be another unnumbered interface.


Caution The ip unnumbered command creates a point-to-point interface between devices. Broadcasting is not supported.

Note If you use the ip unnumbered command, you must use the ip route console-manager-ip-address subnet-mask sm slot/0 command to create a static route. See Step 8.

Step 3 

service-module ip address console-manager-ip-address subnet-mask

Example:

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

Specifies the IP address for the Console Manager.

console-manager-ip-address—IP address for the Console Manager. See Figure 3-2.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Note If you change the Console Manager IP address, you must reload the service module.

Step 4 

service-module ip default-gateway console-manager-gateway-ip-address

Example:

Router(config-if)# service-module ip default-gateway 10.0.0.100

Specifies the IP address of the default gateway for the Console Manager.

console-manager-gateway-ip-address—IP address for the default gateway router.

Step 5 

service-module mgf ip address hypervisor-ip-address subnet-mask

Example:

Router(config-if)# service-module mgf ip address 20.0.0.1 255.255.255.0

Specifies the IP address of the VMware vSphere HypervisorTM.

hypervisor-ip-address—IP address of the VMware vSphere HypervisorTM. See Figure 3-2.

subnet-mask—Subnet mask to append to the IP address; must be in the same subnet as the host router.

Step 6 

no shut

Example:

Router(config-if)# no shut

Causes the interface to be administratively up.

Step 7 

exit

Example:

Router(config)# exit

Returns to global configuration mode on the host router.

Step 8 

[ip route console-manager-ip-address subnet-mask sm slot/0]

Example:

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

Creates a static route.

If you used the ip unnumbered command in Step 2, you must use the ip route console-manager-ip-address subnet-mask sm slot/0 command to create a static route.

console-manager-ip-address subnet-mask—IP address and subnet mask of the Console Manager.

slot/0—slot and port where the Cisco SRE Service Module resides.

 
Configure slot/1 of the Console Manager

Step 1 

interface sm slot/1

Example:

Router(config)# interface sm 1/1

Enters interface configuration mode for the slot and port where the Cisco SRE Service Module resides.

Step 2 

switchport mode trunk

Example:

Router(config-if)# switchport mode trunk

Puts the port into permanent trunking mode.

The default configuration is access mode. Access mode works with native VLAN, which is VLAN 1 for the
Cisco SRE Service Modules.

Step 3 

[switchport trunk allowed vlan vlan_numbers]

Example:

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 30, 40

(Optional) Allows trunking on the specified VLANs.

vlan_numbers—VLAN numbers on which you want to allow trunking.

Step 4 

exit

Example:

Router(config)# exit

Returns to global configuration mode on the host router.

 
Configure VLAN 1

Step 1 

interface vlan 1

Example:

Router(config)# interface vlan 1

Enters VLAN configuration mode for VLAN 1.

Step 2 

ip unnumbered gigabitethernet slot/port interface

Example:

Router(config-if)# ip unnumbered gigabitethernet 0/0

Enables IP processing on an interface without assigning an explicit IP address to that interface. The traffic is forwarded to and from a Gigabit Ethernet interface.

slot/port—Position of the Gigabit Ethernet interface in the router chassis.

interface—Number of the Gigabit Ethernet interface on which the router has an assigned IP address.

Note The unnumbered interface must be unique. It cannot be another unnumbered interface.


Caution The ip unnumbered command creates a point-to-point interface between devices. Broadcasting is not supported.
 
Configure Gigabit Ethernet slot/port

Step 1 

interface gigabitethernet slot/port interface

Example:

Router(config)# interface gigabitethernet 0/0

Enters Gigabit Ethernet configuration mode for the specified sub interface.

slot/port—Position of the Gigabit Ethernet interface in the router chassis.

interface—Number of the Gigabit Ethernet interface on which the router has an assigned IP address.

Step 2 

ip address branch-LAN-ip-address subnet-mask

Example:

Router(config-if)# ip address 20.0.0.100 255.255.255.0

Configures the IP address for the branch local area network.

branch-LAN-ip-address subnet-mask—IP address for the branch local area network. Subnet mask to append to the IP address.

Step 3 

exit

Exits interface mode.

Step 4 

ip route hypervisor-ip-address subnet-mask vlan 1

Example:

Router(config)# ip route 20.0.0.1 255.255.255.0

Creates a static route entry for the VMware vSphere HypervisorTM.

hypervisor-ip-address subnet-mask—IP address and subnet mask for the VMware vSphere HypervisorTM. See Figure 3-2.

Step 5 

ip route virtual-machine-ip-address subnet-mask vlan 1

Example:

Router(config)# ip route 20.0.0.2 255.255.255.0

Creates a static route entry for the virtual machine.

virtual-machine-ip-address subnet-mask—IP address and subnet mask for the virtual machine.

Step 6 

no shut

Example:

Router(config-if)# no shut

Causes the interface to be administratively up.

Step 7 

end

Example:

Router(config)# end

Returns to global configuration mode on the host router.

Step 8 

copy running-config startup-config

Example:

Router# copy running-config startup-config

Saves the new running configuration of the router as the startup configuration.

Step 9 

show running-config

Example:

Router# show running-config

Displays the running configuration of the router so that you can verify the address configurations.

Example

Figure 3-5 shows an example of the Cisco IOS Layer 3 routed configuration.

The left pane shows an example of the Cisco IOS commands that you configure in the
sm 1/0, sm 1/1, vlan 1, and Gigabit Ethernet interfaces.

The right pane shows that the configuration is applied to the Console Manager and to the VMware vSphere HypervisorTM in Cisco SRE-V.

The bottom area in the right pane shows the configuration for the Microsoft Windows Server that is configured using the standard Microsoft Windows network configuration setup process. This Microsoft Windows Server runs as a virtual machine.


Note The IP addresses in the configuration example are for reference only and might not be valid.


Figure 3-5 Configuration Example of the Cisco IOS Layer 3 Routed Configuration

Related Topics

Configuring VLANS with Cisco IOS Layer 3 Routed Configuration

Downloading the Cisco SRE-V Software, page 4-1

External Interface Configuration

The Cisco IOS configuration commands for the external interface configuration are the same as the commands for the"MGF Layer 2 Switched Configuration—Recommended" section or the "Cisco IOS Layer 3 Routed Configuration" section, except for the following:

The IP address of the virtual machine is on a network that is connected to the external interface.

The virtual machine default gateway points to the external interface.

The static route entry for the virtual machine, which is configured in the Cisco IOS Layer 3 Routed Configuration, is not required.

Figure 3-6 shows the traffic flow in the external interface configuration. The service module sends the traffic through the external interface.

Figure 3-6 Traffic Flow in the External Interface Configuration

To configure the external interface, complete the following steps:


Step 1 To configure access to the console manager and the VMware vSphere HypervisorTM, use the configuration commands provided in one of the following sections:

"MGF Layer 2 Switched Configuration—Recommended" section

or

"Cisco IOS Layer 3 Routed Configuration" section

Step 2 Use the vSphere Client GUI to configure access to the virtual machine through the external interface. For instructions, see the vSphere Client online help.


Related Topics

Configuring VLANs with External Interface Configuration

Downloading the Cisco SRE-V Software, page 4-1

Configuring VLANs

To dedicate VLANs to different segments, you must create VLANs. See the following sections as appropriate:

Configuring VLANs with MGF Layer 2 Switched Configuration

Configuring VLANS with Cisco IOS Layer 3 Routed Configuration

Configuring VLANs with External Interface Configuration

Configuring VLANs with MGF Layer 2 Switched Configuration

If you have configured the Cisco SRE Service Module using the MGF Layer 2 switched configuration, and you want to dedicate VLANs to different segments, use the commands provided in this section.

PREREQUISITES

Make sure that the switchport is in trunk mode, see Configure slot/1 of the Console Manager.

SUMMARY STEPS

From the Host-Router CLI

1. enable

2. vlan database

3. vlan vlan_number

4. exit

5. configure terminal

6. interface vlan vlan_number

7. ip address vlan-ip-address subnet mask

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

<password>

Example:

Router> enable

Router> <password>

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

vlan database

Example:

Router# vlan database

Enters VLAN database mode.

Step 3 

vlan vlan_number

Example:

Router(vlan)# vlan 40

VLAN 40 added:

Name: VLAN0040

Adds the specified VLAN to the database.

Step 4 

exit

Example:

Router(vlan)# exit

Exits VLAN database mode.

Step 5 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

Step 6 

interface vlan vlan_number

Example:

Router(config)# interface vlan 40

Enters VLAN configuration mode for the specified VLAN number.

Step 7 

ip address vlan-ip-address subnet-mask

Example:

Router(config-if)# ip address 40.0.0.100 255.255.255.0

Specifies the IP address for the VLAN.

vlan-ip-address—IP address for the VLAN.

subnet-mask—Subnet mask to append to the IP address.

Example

Figure 3-7 shows an example of the entire MGF Layer 2 switched configuration along with two new vlans: vlan 40 and vlan 60.


Note The IP addresses in the configuration example are for reference only and might not be valid.


Figure 3-7 MGF Layer 2 Switched Configuration Example with New VLANs

Related Topics

MGF Layer 2 Switched Configuration—Recommended

Downloading the Cisco SRE-V Software, page 4-1

Configuring VLANS with Cisco IOS Layer 3 Routed Configuration

If you have configured the Cisco SRE Service Module using the Cisco IOS Layer 3 configuration, and you want to dedicate VLANs to different segments, use the commands provided in this section.

PREREQUISITES

Make sure that the switchport is in trunk mode, see Configure slot/1 of the Console Manager.

SUMMARY STEPS

From the Host-Router CLI

1. enable

2. vlan database

3. vlan vlan_number

4. exit

5. configure terminal

6. interface vlan number

7. ip unnumbered gigabitethernet slot/port sub-interface

8. exit

Configure GE slot/port

1. interface gigabitethernet slot/port sub-interface

2. ip address branch-VLAN-ip-address subnet-mask

3. encapsulation dot1q vlan-id

4. exit

5. ip route virtual-machine-ip-address subnet-mask vlan_number

DETAILED STEPS

 
Command or Action
Purpose
 
From the Host-Router CLI

Step 1 

enable

<password>

Example:

Router> enable

Router> <password>

Router#

Enters privileged EXEC mode on the host router. Enter your password if prompted.

Step 2 

vlan database

Example:

Router# vlan database

Enters VLAN database mode.

Step 3 

vlan vlan_number

Example:

Router(vlan)# vlan 40

VLAN 40 added:

Name: VLAN0040

Adds the specified VLAN to the database.

Step 4 

exit

Example:

Router(vlan)# exit

Exits VLAN database mode.

Step 5 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode on the host router.

Step 6 

interface vlan vlan_number

Example:

Router(config)# interface vlan 40

Enters VLAN configuration mode for the specified VLAN number.

Step 7 

ip unnumbered gigabitethernet slot/port sub-interface

Example:

Router(config-if)# ip unnumbered gigabitethernet 0/0.40

Enables IP processing on an interface without assigning an explicit IP address to that interface. The traffic is forwarded to and from a Gigabit Ethernet sub-interface.

slot/port—Position of the Gigabit Ethernet interface in the router chassis.

sub-interface—Number of the Gigabit Ethernet sub interface on which the router has an assigned IP address.

Note The unnumbered interface must be unique. It cannot be another unnumbered interface.


Caution The ip unnumbered command creates a point-to-point interface between devices. Broadcasting is not supported.

Step 8 

exit

Exits interface mode.

 
Configure Gigabit Ethernet slot/port

Step 1 

interface gigabitethernet slot/port sub-interface

Example:

Router(config)# interface gigabitethernet 0/0.40

Enters Gigabit Ethernet configuration mode for the specified sub interface.

slot/port—Position of the Gigabit Ethernet interface in the router chassis.

sub-interface—Number of the Gigabit Ethernet interface on which the router has an assigned IP address.

Step 2 

ip address branch-VLAN-ip-address subnet-mask

Example:

Router(config-if)# ip address 40.0.0.100 255.255.255.0

Configures the IP address for the specific branch VLAN.

branch-VLAN-ip-address subnet-mask—IP address for the specific branch VLAN. This IP address can be used as the default gateway for virtual machines in the VLAN defined in Step 5.

Step 3 

encapsulation dot1q vlan-id

Example:

Router(config-if)# encapsulation dot1q 40

Enables IEEE 802.1Q encapsulation of traffic on the specified subinterface in VLANs.

vlan-id—Virtual LAN identifier. The allowed range is from 1 to 1000.

Step 4 

exit

Exits interface mode.

Step 5 

ip route virtual-machine-ip-address subnet-mask vlan_number

Example:

Router(config)# ip route 40.0.0.2 255.255.255.0

Creates a static route entry for the virtual machine.

virtual-machine-ip-address subnet-mask—IP address and subnet mask for the virtual machine.

Example

Figure 3-8 shows an example of the entire Cisco IOS Layer 3 routed configuration along with two new vlans: vlan 40 and vlan 60.


Note The IP addresses in the configuration example are for reference only and might not be valid.


Figure 3-8 Cisco IOS Layer 3 Routed Configuration Example with New VLANs

Related Topics

Cisco IOS Layer 3 Routed Configuration

Downloading the Cisco SRE-V Software, page 4-1

Configuring VLANs with External Interface Configuration

In the external interface configuration, you use the external vSwitch to configure VLANs.


Note Cisco IOS CLI is not required for creating VLANs.


Example

Figure 3-9 shows an example of the entire external interface configuration along with two new vlans: vlan 40 and vlan 60.


Note The IP addresses in the configuration example are for reference only and might not be valid.


Figure 3-9 External Interface Configuration Example with New VLANs

Related Topics

External Interface Configuration

Downloading the Cisco SRE-V Software, page 4-1

Reload, Reset, and Shut Down Commands

To reload, reset, or shut down the Cisco SRE Service Module, choose the common router commands listed in Table 3-1. You might choose to shut down the Cisco SRE Service Module for service reasons or to save energy when it is not being used.


NoteSome shutdown commands can potentially disrupt service. If the command output for such a command displays a confirmation prompt, confirm by pressing Enter or cancel by typing n and pressing Enter. You can prevent the prompt from being displayed by using the no-confirm keyword.

Some commands shut down the module or application, and then immediately restart it.


Table 3-1 Common Shutdown and Startup Commands 

Configuration Mode
Command
Purpose
Router#

service-module sm slot/0 reload

Shuts down the Cisco SRE Service Module operating system gracefully.

Router#

service-module sm slot/0 reset

Resets the hardware on the Cisco SRE Service Module. Use this command only to recover from a shutdown or failed state.


Caution Using this command does not provide an orderly software shutdown and may impact file operations that are in progress.
Router#

service-module sm slot/0 shutdown

Shuts down the Cisco SRE Service Module system gracefully. Use this command when removing or replacing a hot-swappable module during online insertion and removal (OIR). See the "Online Insertion and Removal of the Cisco SRE Service Module" section on page 2-3.

If the virtual machines on the VMware vSphere HypervisorTM have VMware tools installed on them, and you issue this command, the virtual machines shut down first, and then the Cisco SRE Service Module shuts down.

If the virtual machines do not have VMware tools installed on them, and you issue this command, the virtual machines get powered off first, and then the shutdown signal is sent to the service module. After about two minutes, the Cisco SRE Service Module shuts down.