Getting Started Guide, Cisco ACE Application Control Engine Module
Configuring Health Monitoring Using Health Probes
Downloads: This chapterpdf (PDF - 106.0KB) The complete bookPDF (PDF - 3.17MB) | Feedback

Configuring Health Monitoring Using Health Probes

Table Of Contents

Configuring Health Monitoring Using Health Probes

Information About Configuring Health Monitoring

Prerequisites for Configuring Health Monitoring

Configuring an HTTP Health Probe

Configuration Example for an HTTP Health Probe

Where to Go Next


Configuring Health Monitoring Using Health Probes


This chapter describes how to configure a health probe on the Cisco Application Control Engine (ACE) module.

This chapter contains the following sections:

Information About Configuring Health Monitoring

Prerequisites for Configuring Health Monitoring

Configuring an HTTP Health Probe

Configuration Example for an HTTP Health Probe

Where to Go Next

Information About Configuring Health Monitoring

After reading this chapter, you should have a basic understanding of how the ACE supports server health monitoring using health probes (sometimes referred to as "keepalives"), and how to configure an HTTP health probe.

To detect failures and make reliable load-balancing decisions, you can configure the ACE to track the health of servers and server farms by periodically sending out health probes. By default, the ACE implicitly checks for server failures.

You can configure probes on the ACE to make active connections and explicitly send traffic to servers. The ACE evaluates the server's response to determine the health of that server.

When the ACE determines the health of a server, the result is one of the following:

Passed—The server returned a valid response.

Failed—The server failed to provide a valid response to the ACE within a specified number of retries.

When a server fails in response to the probe, the ACE can check for network problems that prevent a client from accessing that server. The ACE can place the server out of service.

A probe can be any of several types, including HTTP, HTTPS, ICMP, TCP, Telnet, and UDP. You can also configure scripted probes using the TCL scripting language.

This chapter describes how to configure an HTTP probe. For information on how to configure other types of probes, see the Server Load-Balancing Guide, Cisco ACE Application Control Engine.

Prerequisites for Configuring Health Monitoring

Before you can configure health monitoring, you must configure one or more servers or a server farm. For details, see Chapter 6, Configuring Server Load Balancing.

Configuring an HTTP Health Probe

Procedure

 
Command
Purpose

Step 1 

changeto context
 
        

Example:

host1/Admin# changeto VC_WEB
host1/VC_WEB#

Changes to the correct context if necessary. Check the CLI prompt to verify that you are operating in the desired context.

Step 2 

config
 
        

Example:

host1/VC_WEB# config
host1/VC_WEB(config)# 

Enters configuration mode.

Step 3 

probe http name

Example:

host1/VC_WEB(config)# probe http 
HTTP_PROBE1
host1/VC_WEB(config-probe-http)#

Define an HTTP probe named HTPP_probe1 to access its configuration mode.

Step 4 

expect status min_number max_number 
 
        

Example:

host1/VC_WEB(config-probe-http)# expect 
status 200 200 

Configures a single status code or a range of status code responses that the ACE expects from the probe destination. This parameter is required. Without it, all HTTP or HTTPS probes will fail.

Step 5 

exit

Example:

host1/VC_WEB(config-probe-http)# exit
host1/VC_WEB(config)#

Exits probe configuration mode.

Step 6 

serverfarm name
 
        

Example:

host1/VC_WEB(config)# serverfarm SF_WEB
host1/VC_WEB(config-sfarm-host)#

Enter server farm host configuration mode for the SF_WEB server farm.

Step 7 

probe name
 
        

Example:

host1/VC_WEB(config-sfarm-host)# probe 
HTTP_PROBE1

Associate the probe HTTP_PROBE1 with the server farm SF_WEB.

Step 8 

exit

Example:

host1/VC_WEB(config-sfarm-host)# exit
host1/VC_WEB(config)# exit
host1/VC_WEB#

Exits server farm host configuration mode. Exits configuration mode.

Step 9 

show running-config probe

Example:

host1/VC_WEB# show running-config probe

Displays the running configuration to verify that the information that you just added is configured properly.

Step 10 

copy running-config startup-config

Example:

host1/VC_WEB# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuration Example for an HTTP Health Probe

The following example shows how to configure an HTTP health probe. The commands that you have configured in this chapter appear in bold text.

switch/VC_WEB(config)# do show running config
Generating configuration....
 
   
access-list INBOUND line 8 extended permit ip any any
 
   
probe http HTTP_PROBE1
  expect status 200 200
 
   
rserver host RS_WEB1
  description content server web-one
  ip address 10.10.50.10
  inservice
rserver host RS_WEB2
  description content server web-two
  ip address 10.10.50.11
  inservice
rserver host RS_WEB3
  description content server web-three
  ip address 10.10.50.12
  inservice
rserver host RS_WEB4
  description content server web-four
  ip address 10.10.50.13
  inservice
 
   
serverfarm host SF_WEB
  predictor hash header Accept
  probe HTTP_PROBE1
  rserver RS_WEB1 80
    inservice
  rserver RS_WEB2 80
    inservice
  rserver RS_WEB3 80
    inservice
  rserver RS_WEB4 80
    inservice
 
   
sticky http-cookie Cookie1 StickyGroup1
  timeout 3600
  serverfarm SF_WEB
 
   
ssl-proxy service SSL_PSERVICE_SERVER
  key cisco-sample-key
  cert cisco-sample-cert
 
   
class-map match-all CM_SSL
  2 match virtual-address 10.10.40.11 tcp eq https
class-map type management match-any REMOTE_ACCESS
  description Remote access traffic match
  2 match protocol ssh any
  3 match protocol telnet any
  4 match protocol icmp any
class-map match-all VS_WEB
  2 match virtual-address 10.10.40.10 tcp eq www
 
   
policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
  class REMOTE_ACCESS
    permit
 
   
policy-map type loadbalance first-match PM_LB
  class class-default
    serverfarm SF_WEB
 
   
policy-map multi-match PM_MULTI_MATCH
  class VS_WEB
    loadbalance vip inservice
    loadbalance policy PM_LB
policy-map multi-match PM_SSL
  class CM_SSL
    ssl-proxy server SSL_PSERVICE_SERVER
 
   
service-policy input REMOTE_MGMT_ALLOW_POLICY
 
   
interface vlan 400
  description Client connectivity on VLAN 400
  ip address 10.10.40.1 255.255.255.0
  access-group input INBOUND
  service-policy input PM_MULTI_MATCH
  service-policy input PM_SSL
  no shutdown
interface vlan 500
  description Server connectivity on VLAN 500
  ip address 10.10.50.1 255.255.255.0
  no shutdown
 
   
domain DOMAIN1
add-object all
 
   
ip route 0.0.0.0 0.0.0.0 172.25.91.1
username USER1 password 5 $1$vAN9gQDI$MmbmjQgJPj45lxbtzXPpB1  role SLB-Admin domain 
DOMAIN1

Where to Go Next

In this chapter, you have configured an HTTP health probe. In the next chapter, you will configure route health injection (RHI).