Guest

Cisco 500 Series Wireless Express Mobility Controllers

7921 Phones in SBCS Environment Configuration Guide

Cisco - A Guide to Configuring Cisco 7921 Phones in SBCS Environment

Document ID: 100757

Updated: Apr 08, 2008

   Print

Introduction

This document is a guide for how to configure the SBCS elements to support Cisco 7921® Wi-Fi phones. At the time of this writing, the Cisco 7920 and Cisco 7921 Wi-Fi phones are supported to work in the SBCS solution. Since SBCS is a solution for small businesses, not all the capabilities of the 7921 WiFi phones are supported to work in this solution. This document covers topics on configuration, troubleshooting, and design considerations for the introduction of Cisco Wi-Fi phones in an SBCS environment. The target audiences of this document are Cisco System Engineers (SE), Cisco Customer Support Engineers (CSE), and Cisco Technical Assistance Center (TAC) Support Engineers and SMB Select certified VARs. It is assumed that the audience has basic knowledge of the Cisco Voice and Wi-Fi technologies.

What is Cisco 7921?

The Cisco Unified Wireless IP Phone 7921G is an IEEE 802.11a/b/g wireless IP phone that provides voice communications in conjunction with the Cisco UC520 router, Wireless Express 521 Access Point, and Wireless Express 526 Mobility Controller over the 802.11b/g band.

What is SBCS?

The Cisco Smart Business Communications System is a complete portfolio of Cisco Unified Communications products that interoperate seamlessly to provide secure voice, video, wireless and wired data networking.

Wireless Options in SBCS

There are three different options that can be deployed in an SBCS:

  • UC520 Integrated AP—UC520 models which support up to eight or sixteen users can be deployed with an embedded Autonomous Access Point. This option may be suitable for businesses that require a smaller Wi-Fi coverage area. Only one integrated AP is supported in this configuration.

    The integrated AP does not have the capability to perform any “quality of service” guarantee for voice traffic over the data traffic. Due to the QoS limitation and the fact that the coverage area of the integrated AP is restricted to the physical position of the UC520, it is recommended that the integrated AP not be used to deploy Voice over WLAN.

  • Cisco AP521G Autonomous Access Point—These are stand-alone APs that can be deployed anywhere Wi-Fi coverage is needed. A maximum of three autonomous APs, which includes the UC500 integrated AP, can be configured with Cisco Configuration Assistant. AP521G autonomous APs can be used for both data and voice WLANs.

  • Cisco AP521G Access Points with the WLC526 Mobility Controller—This is a combination of controller mode AP521G APs which are configured and managed with the WLC526 wireless LAN controller. This option provides a Wi-Fi client with the ability to seamlessly roam between the access points. A maximum of two WLAN controllers can be deployed in this mode and a maximum of six AP521G lightweight access points can be controlled by one WLC526.

    AP521 controller mode APs in conjunction with the WLC526 are recommended for both data and voice WLANs. The WLC526 controller also provides other advanced mobility services such as secure guest access, radio resource management, and automated configuration and updating of 521 APs.

    Note that the UC500 internal AP can not work with the WLC526 and can not be upgraded to do so.

Design Guidelines for Wi-Fi Deployments in SBCS

It is strongly recommended that a site survey be performed in order to design an optimal radio network, prior to installation. Refer to Voice over WLAN Design Guide for detailed VoWLAN design.

Data Rates, Range and Receiver Sensitivity

Use this table in order to determine the data rate, range and receiver sensitivity for the Cisco 7921G phone depending upon the standard used.

sbcs_7921_wp-1.gif

Call Capacity

About fourteen 7921G phones per AP521G are supported to work properly while still having additional bandwidth available for data traffic.

Cell Overlap

The optimal VoWLAN network requires AP cell overlaps of 20 percent (2.4 GHz), and approximately 15 to 20 percent (5 GHz), where a WLAN Data design may use an AP cell overlap of five to ten percent.

Cell Boundary

The optimal VoWLAN cell boundary recommendation is -67 dBm with a Signal to Noise ratio of 25dBm. The Packet Error Rate (PER) must be no more than one percent.

Wireless Security

The Cisco 7921 G IP phone supports these wireless security features:

Authentication

  • Cisco Centralized Key Management

  • 802.1x authentication

  • Preshared Key

  • Extensible Authentication Protocol-Flexible Authentication via Secure Tunneling (EAP-FAST)

  • Lightweight Extensible Authentication Protocol (LEAP)

Encryption

  • Advanced Encryption Scheme (AES)

  • Temporal Key Integrity Protocol (TKIP) / Message Integrity Check (MIC)

  • 40-bit and 128-bit Wired Equivalent Protocol (WEP)

Single Access Point Mode

  • When you use only one access point, select Single Access Point Mode on the phone in order to reduce scanning and optimize battery life for phones that do not roam.

  • When you use multiple access points with roaming phones, disable the Single Access Point Mode. This prevents voice quality issues for the roaming phones.

Access Point Positioning

  • When you design the placement of the access points, be sure that all key areas have sufficient coverage (signal).

  • Typical WLAN deployments for data only applications do not provide coverage for some areas where VoWLAN coverage is necessary, such as elevators, stairways and outside corridors.

  • Also be mindful of the interference in the 2.4GHz band by common devices, such as cordless phones, Bluetooth devices and microwave ovens.

Site Survey Tool in 7921G

  • There is a site survey tool available in 7921. Press Settings > Status > Site Survey in order to access it.

  • The Cisco 7921G only scans other non-associated channels when the current signal lowers to a certain threshold, so you may only see one access point in the list of the site survey tool.

  • In order to see all neighboring access points, place a call from the 7921G phone to a wired IP phone, where scanning occurs constantly while the phone call is active.

UC520 Integrated AP

A UC520 with an integrated AP can be used in order to provide Wi-Fi coverage if the desired service area is within close vicinity of the physical UC520 unit. This option is optimal for a small office environment that installs the UC520 as a desktop unit.

Even in small offices, it is recommended that an AP521 be installed on the ceiling or wall, to offer better coverage and voice quality.

Since there is only one access point in this setup, there is no roaming support for such deployments.

sbcs_7921_wp-2.gif

Cisco AP521G Autonomous AP

A Cisco AP521G autonomous access point is more suitable for an environment where the desired Wi-Fi coverage area is away from the UC520 unit, or the UC520 unit does not have a built in Access Point or the UC520 integrated AP coverage area must be extended. An example of such deployment can be a UC520 that is mounted in a wiring closet in the back of an office or in a remote part of the office and the desire Wi-Fi coverage area is in the front office away from the wiring closet. The Cisco AP521 can also be added to provide WiFi service to an already deployed UC520 which does not have an integrated AP.

Another case where an AP521G can be added is that of a UC520 with integrated AP which does not cover the entire desired area for Wi-Fi coverage. Multiple AP521G access points can be added to the UC520 in order to provide extra Wi-Fi coverage. A maximum of three autonomous access points are supported by Cisco Configuration Assistant, which includes the integrated AP.

There is no roaming support between the AP521G access points or between the AP521G and the UC520-integrated access point. A client has to re-negotiate with the new AP if it needs to be serviced by that AP.

sbcs_7921_wp-3.gif

Cisco AP521G Controller Mode APs with WLC526

The ultimate wireless and mobility solution for the SBCS environment is the Cisco AP521G controller mode access points deployed in conjunction with WLC526 wireless LAN controller. In this deployment a client can seamlessly roam between the controller mode access points. A maximum of six controller mode access points per WLC526 controller are supported by CCA. A maximum of two WLC526 controllers are supported by CCA. There is no roaming support between the Autonomous access points and the controller mode access points for data or voice clients.

Fast roaming is possible between the controller based APs because the WLC526 controls the association and authentication. When a client moves from one radio to another, it does not need to re-associate itself because the WLC526 maintains the association.

sbcs_7921_wp-4.gif

Configuration Example for UC520 Integrated AP

The UC520 router ships with a factory default configuration that has the configuration for the integrated AP already set to use uc520-voice as the SSID with open authentication and no encryption.

CCA Configuration Example

In these steps, you delete the factory configured Wi-Fi settings and re-configure the router to use WPA security. Use the security option that best meets your needs.

Complete these steps:

  1. Launch the Cisco Configuration Assistant (CCA) application.

  2. Navigate to Configure > Wireless > WLANs (SSIDs).

    This window launches:

    sbcs_7921_wp-5.gif

  3. Highlight the entry with the SSID of uc520-voice, and delete it.

  4. Enable the local RADIUS server or provide the IP address and secret key of the external RADIUS server. If local RADIUS server is used, be sure to add users to it.

  5. Click on Create button in order to create a new SSID.

    This window launches:

    sbcs_7921_wp-6.gif

  6. Enter a suitable name for the SSID.

    The example shown here does not have the SSID broadcasted. You can choose to have the SSID broadcast based upon your network deployment preferences.

  7. Select the Security to be WPA.

Cisco IOS Configuration Example

This is a snippet of the running configuration from the UC500 router:

!
aaa new-model
!
!
aaa group server radius radius_local
 server 192.168.10.1 auth-port 1812 acct-port 1813
!
aaa authentication login auth_method_radius_local group radius_local
aaa accounting update periodic 10
aaa accounting network acct_method_radius_local start-stop group radius_local
!
!
aaa session-id common
clock timezone GMT -8
clock summer-time GMT recurring
!
crypto pki trustpoint TP-self-signed-2778654887
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2778654887
 revocation-check none
 rsakeypair TP-self-signed-2778654887
!
!
crypto pki certificate chain TP-self-signed-2778654887
 certificate self-signed 01…….
.
.
dot11 ssid SBCSD
   vlan 1
   authentication open eap auth_method_radius_local
   authentication network-eap auth_method_radius_local
   authentication key-management wpa
   accounting acct_method_radius_local
   guest-mode
!
dot11 ssid vowlsbcs
   vlan 100
   authentication open eap auth_method_radius_local
   authentication network-eap auth_method_radius_local
   authentication key-management wpa
   accounting acct_method_radius_local
!
 
ip dhcp pool phone
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   option 150 ip 10.1.1.1
!
ip dhcp pool data
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 63.203.35.55
!
.
.
.
!
interface Dot11Radio0/5/0
 no ip address
 !
 encryption vlan 1 mode ciphers tkip
 !
 encryption vlan 100 mode ciphers tkip
 !
 ssid SBCSD
 !
 ssid vowlsbcs
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio0/5/0.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0/5/0.100
 encapsulation dot1Q 100
 bridge-group 100
 bridge-group 100 subscriber-loop-control
 bridge-group 100 spanning-disabled
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
!
interface Vlan1
 no ip address
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Vlan100
 no ip address
 bridge-group 100
 bridge-group 100 spanning-disabled
!
interface BVI1
 ip address 192.168.10.1 255.255.255.0
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly
!
interface BVI100
 ip address 10.1.1.1 255.255.255.0
 ip access-group 103 in
 ip nat inside
 ip virtual-reassembly
!

Configuration of the Cisco 7921 Phone

On the Cisco 7921 phone, navigate to these menus and configure as recommended:

  • Settings > Network profiles > profile1 > network configuration > DHCP enabled: Yes

  • Settings > Network profiles > profile1 > WLAN configuration > SSID: vowlsbcs

  • Settings > Network profiles > profile1 > WLAN configuration > 802.11 Mode: Auto-RSSI

  • Settings > Network profiles > profile1 > WLAN configuration > Security Mode: LEAP

  • Settings> Network profiles> profile1> WLAN configuration>User Name:<username>

  • Settings> Network profiles>profile1> WLAN configuration>Password:< password>

Configuration Example for Cisco AP521G Autonomous Access Point

In these steps, you configure the Cisco AP521G access point to use WPA encryption and open authentication. Use the security option that best meets your needs.

CCA Configuration Example

Complete these steps:

  1. Launch the Cisco Configuration Assistant (CCA) application.

  2. Navigate to Configure > Wireless > WLANs (SSIDs).

    This window launches:

    sbcs_7921_wp-7.gif

  3. From the pull down menu on top of the window make sure that you are working on the desired AP.

  4. Click the Create button.

    This window launches:

    sbcs_7921_wp-8.gif

  5. Enter a suitable name for the SSID.

    The example shown here does not have the SSID broadcasted. You can choose to broadcast the SSID based upon your network deployment preferences.

  6. Select the Security to be WPA and enter the RADIUS server information. Then, click OK to apply.

Cisco IOS Configuration Example

This is a snippet of the running configuration from the AP521G access point:

!
dot11 vlan-name VLAN100 vlan 100
!
dot11 ssid vowlsbcs
   vlan 100
   authentication open eap eap_methods_vowlsbcs
   authentication network-eap eap_methods_vowlsbcs
   authentication key-management wpa version 1
!
power inline negotiation prestandard source
!
!
username Cisco password 7 072C285F4D06
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 100 mode ciphers tkip
 !
 ssid vowlsbcs
 !
 channel least-congested 2412 2417 2422 2427 2432 2437 2442 2447 2452 2457 2462 2467 2472
 station-role root
 bridge-group 1
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 no snmp trap link-status
 bridge-group 100
 bridge-group 100 subscriber-loop-control
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
 bridge-group 100 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 no snmp trap link-status
 bridge-group 100
 no bridge-group 100 source-learning
 bridge-group 100 spanning-disabled
!
interface BVI1
 ip address dhcp client-id FastEthernet0
 no ip route-cache
!

Configuration of the Cisco 7921 Phone

On the Cisco 7921 phone, navigate to these menus and configure as recommended:

  • Settings > Network profiles > profile1 > network configuration > DHCP enabled: Yes

  • Settings > Network profiles > profile1 > WLAN configuration > SSID: vowlsbcs

  • Settings > Network profiles > profile1 > WLAN configuration > 802.11 Mode: Auto-RSSI

  • Settings > Network profiles > profile1 > WLAN configuration > Security Mode: LEAP

  • Settings >Network profiles > profile1 > WLAN configuration > User Name:<username>

  • Settings > Network profiles > profile1 > WLAN configuration > Password:< password>

Configuration Example for Cisco AP521G Controller Mode Access Points with WLC526 Wireless LAN Controller

In these steps, you configure the Cisco WLC526 wireless LAN controller to use WPA encryption and open authentication. Use the security option that best meets your needs. The WLC526 works with Cisco AP521G controller mode access points.

CCA Configuration Example

Complete these steps:

  1. Launch the Cisco Configuration Assistant (CCA) application.

  2. Navigate to Configure > Wireless > WLANs (SSIDs).

    This window launches:

    sbcs_7921_wp-9.gif

  3. From the pull down menu on top of the window, choose the desired wireless device.

  4. Click on the RADIUS server Configure button in order to supply the IP address and credentials.

  5. Click Create.

    This window launches:

    sbcs_7921_wp-10.gif

  6. Click the Voice radio button in the WLAN Type area.

  7. Enter a suitable name for the SSID.

    The example shown here has its SSID broadcasted.

  8. Select the Security to be WPA.

  9. In the Voice CAC area, click the 7920 CAC radio button.

    Note: For Authentication, it is recommend to use 802.1x with the fast roaming (CCKM) option. For Voice deployments you absolutely need this feature enabled on the WLAN to have fast and secure roaming.

WLC526 WEB-UI Configuration Example

These are a few screen captures of the WLC526 controller. They depict the configuration performed with the CCA in the previous steps.

Each page can be located with the “orange” highlighted top bar and the menu on the left hand side.

This screen shot shows the interfaces that are configured on the WLC526 controller:

sbcs_7921_wp-11.gif

This screen shows the SSID configured for the WLAN:

sbcs_7921_wp-12.gif

These four screen shots show the details of the configured WLAN, which can be edited with this web-based user interface:

sbcs_7921_wp-13.gif

sbcs_7921_wp-14.gif

sbcs_7921_wp-15.gif

sbcs_7921_wp-16.gif

sbcs_7921_wp-17.gif

This screen-shot shows the list of clients that connect or already connected:

This screen-shot shows the details of a connected client:

Configuration of the Cisco 7921 Phone

On the Cisco 7921 phone, navigate to these menus and configure as recommended:

  • Settings > Network profiles > profile1 > network configuration > DHCP enabled: Yes

  • Settings > Network profiles > profile1 > WLAN configuration > SSID: sbcsv1

  • Settings > Network profiles > profile1 > WLAN configuration > 802.11 Mode: Auto-RSSI

  • Settings > Network profiles > profile1 > WLAN configuration > Security Mode: LEAP

  • Settings > Network profiles > profile1 > WLAN configuration > User Name:<username>

  • Settings > Network profiles > profile1 > WLAN configuration > Password:< password>

Troubleshooting Tips

The information in this section can be used to troubleshoot your configuration.

  • Before you configure AP521G or WLC526, make sure that these devices have VLAN 100 configured.

  • UC520 does not support CAC in the Cisco IOS code. However, the WLC526 supports CAC on the radio interface for the 7921 telephone.

  • It is recommended that for the 7921 you use unicast MoH (Music on Hold) and not multicast. However, the UC520 does not support the unicast MOH. In most situations there would be heavy packet loss in case of multicast MOH, which results in choppy music.

  • CCA allows only one SSID per VLAN per device.

  • Power levels are set to the default values for all of the three Wi-Fi options. CCA does not provide a way to change power on any radios. This can be done through the CLI or the web-UI of the desired component

  • Data rates are set to the default values. CCA does not provide a way to change the data rates on the individual components. Data rates can be changed through the CLI of the web-UI of the desired component. As with any Wi-Fi deployment, a site survey is recommended. Based on the site survey results, if the boundaries of the proposed “voice over WLAN” cell cannot sustain the data rates to support the number of desired 7921 phones, it is recommended to disable lower data rate settings on the AP. This reduces the size of the Wi-Fi cell, but guarantees minimum data rate for the cell.

    On the WLC526 web-UI, the data rates can be changed on the Wireless/802.11bg/Network screen. On the UC520, the no speed command can be used under the interface dot11 prompt in order to take out the un-desired data rate.

  • The dot11 phone command is not enabled by default nor is it supported by the CCA. However, it is supported by the UC500 router and can be entered with the CLI interface.

  • The dot11 priority-map avvid command is not enabled by default nor is it supported by the CCA. However, it is supported by the UC500 router and can be entered with the CLI interface.

  • The dot11 arp-cache command is not enabled by default nor is it supported by the CCA. However, it is supported by the UC500 router and can be entered with the CLI interface.

  • QoS, CAC and WMM are only supported on the WLC526 controller. QoS is enabled and WMM is disabled by CCA for the voice network.

Related Information

Updated: Apr 08, 2008
Document ID: 100757