Guest

Wireless, LAN (WLAN)

1800 ISR Wireless Router with Internal DHCP and Open Authentication Configuration Example

Document ID: 68099

Updated: Jul 17, 2008

   Print

Introduction

This document provides a sample configuration of a wireless LAN (WLAN) on a Cisco 1800 Integrated Services Router (ISR).

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • 1800 ISR on Cisco IOS® Software Release 12.3 or later with the Advanced IP Services feature set

    Note: You can apply the same configuration to any of the ISRs. The configuration is not specific to the 1800 series.

  • PC with these wireless network cards:

    • 802.11a

    • 802.11b

    • 802.11b/g a/b/g

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

Wireless Connection to the Router

1800_isr_wireless1.gif

Configuration

Step-by-Step Instructions

Complete these steps:

  1. Set up the DHCP scope and excluded addresses.

    Note: Excluded addresses are optional.

    Refer to Cisco IOS DHCP Server for a more detailed explanation of the DHCP server in Cisco IOS Software.

  2. Turn on integrated routing and bridging, and set up the bridge group.

  3. Assign an IP address to interface Bridge-Group Virtual Interface 1 (BVI1).

  4. Set up wireless.

    1. Assign interface Dot11Radio0 or Dot11Radio1 to bridge group 1.

    2. Assign a service set identifier (SSID) to the radio interface, and then define open authentication.

Configuration

This document uses this configuration:

1800 Series ISR Wireless and DHCP Configuration
1800-ISR#show running-config 
 Building configuration...
 .
 .
!
hostname 1800-ISR
!

!--- Output suppressed.

!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.100

!--- This sets up DHCP and excluded addresses. Excluded addresses are optional.

!
ip dhcp pool 1800-ISR
   network 192.168.2.0 255.255.255.0
!
!
bridge irb

!--- Turn on integrated routing and bridging.

!
!
interface Dot11Radio0

!--- This is the wireless radio interface configuration.

 no ip address
 !
 ssid Cisco

!--- Here, the SSID is given as "Cisco".
  
    authentication open 

!--- This defines the authentication as open.

 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
!
interface BVI1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
!

!--- Note: Configure the bridge 1 protocol IEEE and the bridge 1 route IP 
!--- before you create interface BVI1 or add the radio interface to bridge group 1.

!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Use these commands in order to verify proper DHCP and wireless operation:

  • show dot11 associations

  • show ip dhcp binding

The MAC and IP addresses must match in the output of the show dot11 associations command and the output of the show ip dhcp binding command. Here is an example:

1800-ISR#show dot11 associations

802.11 Client Stations on Dot11Radio0: 

SSID [Cisco] : 

MAC Address��� �IP address����� Device������� ���Name����������Parent�������� State��� �
0040.96ac.345c  192.168.2.101�� CB21AG/PI21AG��� WLCLIENT� ��� self���������� Associated
!

!--- Output suppressed.

!
1800-ISR#show ip dhcp binding 
Bindings from all pools not associated with VRF:
IP address��������� Client-ID/������������� Lease expiration������ Type
���������������������Hardware address/
���������������������User name
192.168.2.101��     0100.4096.ac34.5c������ Dec 18 2005 05:07 PM�� Automatic
1800-ISR#

Troubleshoot

Use this section to troubleshoot your configuration.

Troubleshooting Command

Note: Refer to Important Information on Debug Commands before you use debug commands.

Issue the debug ip dhcp server packet command in order to debug the IP DHCP server. With an unencrypted open-authentication WLAN, this command provides the quickest and most effective method to troubleshoot.

The debug ip dhcp server packet command shows these data transactions:

1800_isr_wireless2.gif

This output of the debug ip dhcp server packet command is an example of a successful DHCP request:

1800-ISR#debug ip dhcp server packet

*Dec 17 15:40:50.379: DHCPD: DHCPREQUEST received from client 0100.4096.ac34.5c.
!

!--- This shows the client DHCP discover packet that is sent to the router.

!
*Dec 17 15:40:50.379: DHCPD: No default domain to append - abort update
*Dec 17 15:40:50.379: DHCPD: Sending DHCPACK to client 0100.4096.ac34.5c (192.168.2.101)
!

!--- This shows the router DHCP acknowledgment (ACK) that is sent back to the client.

!
*Dec 17 15:40:50.379: DHCPD: creating ARP entry (192.168.2.101, 0040.96ac.345c).
*Dec 17 15:40:50.379: DHCPD: unicasting BOOTREPLY to client 0040.96ac.345c (192.168.2.101)

Troubleshooting Procedure

If you do not see the DHCP offer in the output of the debug ip dhcp server packet command, begin to troubleshoot the 802.11 protocol. Complete these steps:

  1. Verify the wireless client settings, the SSID, and the no security/encryption setting.

    Note: The SSID must be the same in the ISR and the clients. In this case, the SSID is "Cisco". Figure 1 and Figure 2 show the SSID settings in both Cisco Aironet Desktop Utility (ADU) and Aironet Client Utility (ACU). The window that you see depends on the wireless client card and the firmware versions that you use.

    Figure 1 – Cisco ADU SSID Settings

    1800_isr_wireless3.gif

    Figure 2 – Cisco ACU SSID Settings

    1800_isr_wireless4.gif

    Figure 3 – Windows Wireless Zero Settings

    1800_isr_wireless5.gif

  2. Verify Wi-Fi compatibility.

    Refer to the Wi-Fi Alliance leavingcisco.com page in order to verify the Wi-Fi compatibility of the wireless network interface card (NIC) that is used.

  3. Contact Cisco Technical Support for further technical assistance.

Related Information

Updated: Jul 17, 2008
Document ID: 68099