Guest

X.25 Protocols

Configuring a Router as a PAD for XOT to an Asynchronous Host

Document ID: 14188

Updated: Dec 12, 2007

   Print

Introduction

This document presents a sample configuration in which a remote host connects to X.25 over a Transmission Control Protocol (TCP) network on a Public Switched Telephone Network (PSTN) dial-up line. The host does not send or receive any X.25 packets. However, the remote router it connects to acts as an X.25 packet assembler/disassembler (PAD) and encapsulates and decapsulates X.25 packets for the host.

Note: This is referred to as "reverse pad", as the X25 call can only be established from the X25 device (server) to the asynchronous host, not vice versa. Forward pad requires a different configuration.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The enhancements to PAD-related functionality we can use in protocol translation services was introduced in Cisco IOS® Software Release 11.2.

The following platforms support the PAD enhancements:

  • Cisco 2500 series routers

  • Cisco 26xx series routers

  • Cisco 36xx series routers

  • Cisco 4000 routers

  • Cisco 4500 routers

  • Cisco 4700 routers

  • Cisco AS5200 series routers

  • Cisco 7000 series routers

  • Cisco 7200 series routers

  • Cisco 7500 series routers

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Background Information

PAD over X.25 over TCP (XOT) enables PAD calls to destinations that are not reachable over physical X.25 interfaces, but over TCP tunnels. This function enables PAD calls originating from a router on an IP link to reach an X.25 device. PAD over XOT also enables incoming XOT connections from an IP link to be accepted as PAD or protocol translation connections on the local router.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

netdiag1.jpg

Configurations

This document uses these configurations:

Remote Router
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

Main Router
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

  • debug x25 events—Displays information about all X.25 traffic or a specific X.25 service class.

  • debug pad—Displays debug messages for all PAD connections.

The following debug output is displayed for a successful X.25 call from the server to the host. We executed these debug commands on on the Remote router.

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,

Related Information

Updated: Dec 12, 2007
Document ID: 14188