Guest

T1/E1 & T3/E3

Bundling NxE1 Links With a Multilink Interface

Cisco - Bundling NxE1 Links With a Multilink Interface

Document ID: 11044

Updated: Jan 29, 2008

   Print

Introduction

The sample configurations in this document show how you can bundle NxE1 links (with or without G.704 framing) by means of a Multilink interface. The Multilink interface is introduced in Cisco IOS® Software Release 12.0(3)T for distributed Multilink Point to Point Protocol (PPP) on Cisco 7500 router Versatile Interface Processor (VIP)-based T1 or E1 interfaces (see the Related Information

Related Cisco Support Community Discussions section of this document). The Multilink interface is supported for non-VIP based T1/E1 (and other WAN) interfaces since Cisco IOS Software Release 12.0(4)T.

Prerequisites

Requirements

Since Multilink PPP increases the CPU load, you are advised to:

  1. Verify the current average CPU load before you add Multilink interfaces or add E1 links to a Multilink interface.

  2. Use distributed Multilink PPP on Cisco 7500 VIP-based platforms whenever possible. Refer to the Cisco IOS Software Release 12.0(3)T New Feature Documentation for more details on the restrictions and prerequisites of distributed Multilink PPP (see the Related Information section of this document).

  3. Disable Multilink PPP fragmentation whenever possible.

Note: This increases latency over the Multilink bundle.

Components Used

The information in this document is based on these software and hardware versions:

  • A Cisco 7505 router equipped with VIP2-50 and PA-MC-8E1 that runs Cisco IOS Software Release 12.1(11a).

  • A Cisco 7206 router equipped with PA-MC-8E1 that runs Cisco IOS Software Release 12.1(11).

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Background Theory

Multilink PPP, standardized in RFC 1990, is similar to load balancing techniques in that it sends packets across the individual links in a round robin fashion. However, Multilink PPP adds three significant capabilities.

  • Since Multilink PPP works at the link layer, it makes an NxT1/E1 bundle appear as one logical link to the upper layer protocols in the router. Therefore, only one network address needs to be configured for the entire NxT1/E1 bundle.

  • Multilink PPP keeps track of packet sequencing and buffers packets that arrive early. Multilink PPP preserves packet order across the entire NxT1/E1 bundle with this ability.

  • You can enable packet fragmentation to split large data packets into smaller packet fragments that are individually transmitted across the links. In many circumstances, fragmentation can increase the efficiency of the NxT1/E1 link.

Multilink PPP also offers significant link manageability. If an individual link fails, Multilink PPP can automatically detect the failure and remove that link from the bundle. As long as one link of the bundle works, the logical interface that represents the bundle is up. With the use of keep alive signals, Multilink PPP can detect when a previously failed link comes back up and then reinsert that link into the bundle. Additionally, you can add more links to the bundle when you configure them as a member of the bundle when more bandwidth is needed. No reconfiguration at the network layer, such as new addressing, is needed. This is also a significant factor when you consider the use of advanced router services. For example, you can configure a specific Quality of Service once for the bundle as a whole rather than on each link in the bundle.

The trade-off for the increased functionality is that Multilink PPP requires greater CPU processing than load balancing solutions. Packet reordering, fragment reassembly, and the Multilink PPP protocol itself increases the CPU load.

Configure

This section presents you with the information to configure the features this document describes.

Note: Use the Command Lookup Tool (registered customers only) to find additional information on the commands this document uses.

Network Diagram

This document uses this network setup.

ppp_11044.gif

Configurations

This document uses these configurations.

E1 Links with G.704 Framing

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
username bob password 0 mlppp 

!--- This is an optional Challenge Handshake Authentication Protocol 
!--- (CHAP) secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

! 
no ip domain-lookup 
! 
! 
controller E1 1/0/0 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.
 
! 
controller E1 1/0/1 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/2 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/3 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/4 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/5 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/6 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/7 
 channel-group 0 timeslots 1-31 


!--- You must assign all timeslots to one channel-group.

! 
interface Multilink1 
 ip address 10.10.10.1 255.255.255.0 
 no cdp enable 
 ppp multilink 
 no ppp multilink fragmentation 
 
!--- This command is optional to reduce CPU load. 

 multilink-group 1 
! 
interface Serial1/0/0:0 
 no ip address 
 ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable first-in, first-out (FIFO)  
!--- queueing on the Serial interface.  

ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/1:0 
 no ip address 
 ip route-cache distributed 
 
!--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/2:0 
 no ip address 
 ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 
 
encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/3:0 
 no ip address 
 ip route-cache distributed 
 
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/4:0 
 no ip address 
 ip route-cache distributed 
 
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/5:0 
 no ip address 
 ip route-cache distributed 
 
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/6:0 
 no ip address 
 ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial1/0/7:0 
 no ip address 
 ip route-cache distributed 
 
!--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
no fair-queue 
 
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Ethernet1/1/0 
 ip address 10.10.20.1 255.255.255.0 
 no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 password <password> 
 login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
username diana password 0 mlppp 

!--- An optional CHAP secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
! 
! 
controller E1 3/0 
 clock source internal 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/1 
 clock source internal 

 !--- This command is only required when you provide master clock 
!--- to the remote router.
 
 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/2 
 clock source internal 

 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/3 
 clock source internal 

 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/4 
 clock source internal 

 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/5 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/6 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/7 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
! 
! 
! 
! 
interface Multilink1 
 ip address 10.10.10.2 255.255.255.0 
 ppp multilink 
 no ppp multilink fragmentation 
 
!--- This command is optional to reduce CPU load.
 
 multilink-group 1 
! 
interface FastEthernet0/0 
 ip address 10.10.30.1 255.255.255.0 
 no ip route-cache 
 no ip mroute-cache 
 half-duplex 
 no cdp enable 
! 
interface Serial3/0:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/1:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/2:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/3:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/4:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/5:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/6:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/7:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp authentication chap 
 
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

 ppp multilink 
 multilink-group 1 
! 
ip classless 
ip route 10.10.20.0. 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 password <password> 
 login 
! 
end 

E1 Links with No G.704 Framing

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

no ip domain-lookup 
! 
! 
controller E1 0/1/0 
 channel-group 0 unframed 
! 
controller E1 0/1/1 
 channel-group 0 unframed 
! 
controller E1 0/1/2 
 channel-group 0 unframed 
! 
controller E1 0/1/3 
 channel-group 0 unframed 
! 
controller E1 0/1/4 
 channel-group 0 unframed 
! 
controller E1 0/1/5 
 channel-group 0 unframed 
! 
controller E1 0/1/6 
 channel-group 0 unframed 
! 
controller E1 0/1/7 
 channel-group 0 unframed 
! 
! 
! 
interface Multilink1 
 ip address 10.10.10.1 255.255.255.0 
 no cdp enable 
 ppp multilink 
 no ppp multilink fragmentation 
 
!--- This is an optional command to reduce CPU load. 

 multilink-group 1 
! 
interface Serial0/1/0:0 
 no ip address 
 ip route-cache distributed 

 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/1:0 
 no ip address 
 ip route-cache distributed 

 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/2:0 
 no ip address 
 ip route-cache distributed 
 
 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/3:0 
 no ip address 
 ip route-cache distributed 
 
 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/4:0 
 no ip address 
 ip route-cache distributed 
 
 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/5:0 
 no ip address 
 ip route-cache distributed 

 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/6:0 
 no ip address 
 ip route-cache distributed 

 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial0/1/7:0 
 no ip address 
 ip route-cache distributed 

 !--- This command is default and mandatory for distributed Multilink PPP. 

 encapsulation ppp 
 tx-queue-limit 26 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Ethernet1/1/0 
 ip address 10.10.20.1 255.255.255.0 
 no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 password <password> 
 login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 

! 
controller E1 3/0 
 clock source internal 

 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/1 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/2 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/3 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/4 
 clock source internal 

 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/5 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/6 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
controller E1 3/7 
 clock source internal 
 
 !--- This command is only required when you provide master clock 
!--- to the remote router.

 channel-group 0 unframed 
! 
! 
! 
! 
! 
interface Multilink1 
 ip address 10.10.10.2 255.255.255.0 
 ppp multilink 
 no ppp multilink fragmentation 

 !--- This is an optional command to reduce CPU load. 

 multilink-group 1 
! 
interface FastEthernet0/0 
 ip address 10.10.30.1 255.255.255.0 
 no ip route-cache 
 no ip mroute-cache 
 half-duplex 
 no cdp enable 
! 
interface Serial3/0:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/1:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/2:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/3:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/4:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/5:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/6:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
interface Serial3/7:0 
 no ip address 
 encapsulation ppp 
 no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

 ppp multilink 
 multilink-group 1 
! 
ip classless 
ip route 10.10.20.0 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 exec-timeout 0 0 
 password <password> 
 login 
! 
end 

Verify

This section provides information you can use to confirm your configuration worke properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show ppp multilink—Shows all Multilink bundles together with all Multilink bundle members.

  • show interfaces multilink—Shows the status of the Multilink bundle.

  • show interfaces serial—Shows the status of each Multilink bundle member.

  • show controllers e1—Shows the status of each E1 link.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Procedure

This procedure is relevant to both configurations.

  1. Verify the status of the Multilink interface with the show interface multilink command:

    • If the Multilink interface is down, then verify the status of all Multilink bundle members with the show ppp multilink command.

    • If the Multilink line protocol is down, then verify the Network Control Protocol (NCP) and Multilink PPP (MLP) messages with the debug ppp negotiation and debug ppp multilink events commands.

  2. If a Multilink member is inactive, verify the status of the Serial interface with the show interface serial command:

    • If the Serial interface is down, verify the status of the corresponding E1 link with the show controller e1 command.

    • If the Serial line protocol is down, verify the Link Control Protocol (LCP) and CHAP messages with the debug ppp negotiation and debug ppp authentication commands.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Refer to Important Information on Debug Commands before you issue debug commands.

  • show ppp multilink—Shows all Multilink bundles together with all Multilink bundle members.

  • show interfaces multilink—Shows the status of the Multilink bundle.

  • show interfaces serial—Shows the status of each Multilink bundle member.

  • show controllers e1—Shows the status of each E1 link.

  • debug ppp negotiation—Shows all LCP and NCP negotiation messages.

  • debug ppp authentication—(Optional) Shows all CHAP authentication messages.

  • debug ppp multilink events—Shows all MLP bundle events.

This output shows the troubleshooting commands on the Cisco 7505 for the first configuration example.

All eight E1 links are active:

diana#show ppp multilink 

Multilink1, bundle name is bob 
  Bundle up for 00:05:35 
  Bundle is Distributed 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 3/255 load 
  0x1226 received sequence, 0x1226 sent sequence 
  Member links: 8 active, 0 inactive (max not set, min not set) 
    Serial1/0/0:0, since 00:05:35, no frags rcvd 
    Serial1/0/1:0, since 00:05:35, no frags rcvd 
    Serial1/0/2:0, since 00:05:35, no frags rcvd 
    Serial1/0/3:0, since 00:05:35, no frags rcvd 
    Serial1/0/4:0, since 00:05:35, no frags rcvd 
    Serial1/0/5:0, since 00:05:35, no frags rcvd 
    Serial1/0/6:0, since 00:05:35, no frags rcvd 
    Serial1/0/7:0, since 00:05:35, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
  Hardware is multilink group interface 
  Internet address is 10.10.10.1/24 
  MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 3/255, rxload 3/255 
  Encapsulation PPP, loopback not set 
  Keepalive set (10 sec) 
  DTR is pulsed for 2 seconds on reset 
  LCP Open, multilink Open 
  Open: IPCP 
  Last input 00:00:00, output never, output hang never 
  Last clearing of "show interface" counters 00:06:39 
  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/40 (size/max) 
  5 minute input rate 241000 bits/sec, 28 packets/sec 
  5 minute output rate 241000 bits/sec, 28 packets/sec 
     6525 packets input, 9810620 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     6526 packets output, 9796112 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     0 carrier transitions   

In this output, the E1 controller 3/0 on the Cisco 7206 is disabled, which causes the E1 controller 1/0/0 and Serial 1/0/0:0 on the Cisco 7505 to go down:

diana# 
*Nov 23 12:52:54.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to down 
*Nov 23 12:52:56.171: %LINK-3-UPDOWN: 
Interface Serial1/0/0:0, changed state to down 
*Nov 23 12:52:57.171: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to down 

diana#show ppp multilink
Multilink1, bundle name is bob 
  Bundle up for 00:06:52 
  Bundle is Distributed 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x269C received sequence, 0x269B sent sequence 
  Member links: 7 active, 1 inactive (max not set, min not set) 
    Serial1/0/1:0, since 00:06:52, no frags rcvd 
    Serial1/0/2:0, since 00:06:52, no frags rcvd 
    Serial1/0/3:0, since 00:06:52, no frags rcvd 
    Serial1/0/4:0, since 00:06:52, no frags rcvd 
    Serial1/0/5:0, since 00:06:52, no frags rcvd 
    Serial1/0/6:0, since 00:06:52, no frags rcvd 
    Serial1/0/7:0, since 00:06:52, no frags rcvd 
    Serial1/0/0:0 (inactive) 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
  Hardware is multilink group interface 
  Internet address is 10.10.10.1/24 
  MTU 1500 bytes, BW 13888 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 6/255, rxload 6/255 
  Encapsulation PPP, loopback not set 
  Keepalive set (10 sec) 
  DTR is pulsed for 2 seconds on reset 
  LCP Open, multilink Open 
  Open: IPCP 
  Last input 00:00:00, output never, output hang never 
  Last clearing of "show interface" counters 00:07:47 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/40 (size/max) 
  5 minute input rate 367000 bits/sec, 40 packets/sec 
  5 minute output rate 367000 bits/sec, 40 packets/sec 
     10899 packets input, 16389116 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     10901 packets output, 16367362 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is down, line protocol is down 
  Hardware is Multichannel E1 
  MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 41/255, rxload 41/255 
  Encapsulation PPP, crc 16, Data non-inverted 
  Keepalive set (10 sec) 
  LCP Closed, multilink Closed 
  Closed: CDPCP 
  Last input 00:00:15, output 00:00:17, output hang never 
  Last clearing of "show interface" counters 00:07:42 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/40 (size/max) 
  5 minute input rate 323000 bits/sec, 35 packets/sec 
  5 minute output rate 324000 bits/sec, 35 packets/sec 
     9811 packets input, 14623345 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     9809 packets output, 14680161 bytes, 0 underruns 
     0 output errors, 0 collisions, 1 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     2 carrier transitions alarm present 
  Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
  Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is down. 
  Applique type is Channelized E1 - balanced 
  Transmitter is sending remote alarm. 
  Receiver is getting AIS. 
  Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
  International Bit: 1, National Bits: 11111 
  Data in current interval (465 seconds elapsed): 
     1 Line Code Violations, 1 Path Code Violations 
     0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 19 Unavail Secs 
... 

diana#debug ppp negotiation 
 PPP protocol negotiation debugging is on 

diana#debug ppp authentication 
PPP authentication debugging is on 

diana#debug ppp multilink events 
Multilink events debugging is on 

In this output, the E1 controller 3/0 on the Cisco 7206 is enabled again.

diana# 
*Nov 23 12:53:40.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to up 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: I CONFREQ [Closed] id 34 len 26 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: Lower layer not up, Fast Starting 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Treating connection as a dedicated line 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Phase is ESTABLISHING, Active Open 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFREQ [Closed] id 2 len 27 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:    EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFACK [REQsent] id 34 len 26 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 2 len 27 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:    EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: State is Open 
*Nov 23 12:53:42.079: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by both 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O CHALLENGE id 2 len 26 from "diana" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: I CHALLENGE id 4 len 25 from "bob" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O RESPONSE id 4 len 26 from "diana" 
*Nov 23 12:53:42.079: %LINK-3-UPDOWN: Interface Serial1/0/0:0, changed state to up 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I RESPONSE id 2 len 25 from "bob" 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I SUCCESS id 4 len 4 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: O SUCCESS id 2 len 4 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Request add link to bundle 
*Nov 23 12:53:42.087: Se1/0/0:0 PPP: Phase is VIRTUALIZED 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Adding link to bundle 
*Nov 23 12:53:42.087: Mu1 MLP: Added link Se1/0/0:0 to bundle bob 
*Nov 23 12:53:43.087: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to up 

diana#show ppp multilink
Multilink1, bundle name is bob 
  Bundle up for 00:07:46 
  Bundle is Distributed 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 7/255 load 
  0x35BF received sequence, 0x35BE sent sequence 
  Member links: 8 active, 0 inactive (max not set, min not set) 
    Serial1/0/1:0, since 00:07:46, no frags rcvd 
    Serial1/0/2:0, since 00:07:46, no frags rcvd 
    Serial1/0/3:0, since 00:07:46, no frags rcvd 
    Serial1/0/4:0, since 00:07:46, no frags rcvd 
    Serial1/0/5:0, since 00:07:46, no frags rcvd 
    Serial1/0/6:0, since 00:07:46, no frags rcvd 
    Serial1/0/7:0, since 00:07:46, no frags rcvd 
    Serial1/0/0:0, since 00:00:13, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
  Hardware is multilink group interface 
  Internet address is 10.10.10.1/24 
  MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 7/255, rxload 7/255 
  Encapsulation PPP, loopback not set 
  Keepalive set (10 sec) 
  DTR is pulsed for 2 seconds on reset 
  LCP Open, multilink Open 
  Open: IPCP 
  Last input 00:00:00, output never, output hang never 
  Last clearing of "show interface" counters 00:08:32 
  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/40 (size/max) 
  5 minute input rate 443000 bits/sec, 49 packets/sec 
  5 minute output rate 443000 bits/sec, 49 packets/sec 
     14098 packets input, 21200412 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     14099 packets output, 21170758 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is up, line protocol is up 
  Hardware is Multichannel E1 
  MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 32/255, rxload 32/255 
  Encapsulation PPP, crc 16, Data non-inverted 
  Keepalive set (10 sec) 
  LCP Open, multilink Open 
  Last input 00:00:02, output 00:00:02, output hang never 
  Last clearing of "show interface" counters 00:08:39 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/40 (size/max) 
  5 minute input rate 253000 bits/sec, 24 packets/sec 
  5 minute output rate 254000 bits/sec, 24 packets/sec 
     9821 packets input, 14623552 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     9819 packets output, 14680370 bytes, 0 underruns 
     0 output errors, 0 collisions, 1 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
     3 carrier transitions no alarm present 
  Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
  Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is up. 
  Applique type is Channelized E1 - balanced 
  No alarms detected. 
  Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
  International Bit: 1, National Bits: 11111 
  Data in current interval (519 seconds elapsed): 
     1 Line Code Violations, 1 Path Code Violations 
     0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 37 Unavail Secs 
... 

Related Information

Updated: Jan 29, 2008
Document ID: 11044