Guest

Point-to-Point Protocol (PPP)

Multiple Multilink Bundles Between Routers

Document ID: 9500

Updated: Feb 04, 2010

   Print

Introduction

This document provides a sample configuration for creating multilink bundles between routers. In order to have multiple multilinks beween two routers, you need to configure different authenticated usernames for each bundle.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco IOS® Software Release 12.0(7)T.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Background Information

The sample configuration we have created here has these features:

  • It uses a multilink interface with one physical member interface under it.

  • It uses a BRI interface as the backup for the multilink interface. This BRI interface has multilink capability, and all the other characteristics of the main multilink interface.

  • While switching from the backup interface to the main interface, we use two multilink bundles that are independent from each other. One of these is from the multilink interface, and one is from the BRI. By default, the multilink bundle was identified by the authenticated username. However, this creates issues while switching from the backup (BRI) to the main (multilink) interface. This sample configuration shows you how to work around this issue.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

multilink_bundles.gif

Configurations

This document uses these configurations:

  • Router3

  • Router2

Router3
Router3#show running-config 
!
version 12.0 
!
hostname Router3
!
!
username MultilinkRouter2 password 0 cisco
username Router2BRI password 0 cisco

!--- The username must match the one in the ppp chap hostname command on the remote router

! 
!
isdn switch-type basic-net3 
! 
multilink bundle-name authenticated 

!--- to differentiate bundles based on authenticated usernames

!
interface Multilink1
ip address 192.168.19.6 255.255.255.0 
no cdp enable
ppp authentication chap
ppp chap hostname MultilinkRouter3 

!--- alternate CHAP hostname

ppp chap password 7 121A0C041104
ppp multilink
multilink-group 1
! 
interface Serial1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer rotary-group 1
isdn switch-type basic-net3
ppp authentication chap
ppp multilink
!
interface Dialer1
ip address 192.168.20.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 30
dialer map ip 10.0.0.0 name Router2 broadcast 6084
dialer map ip 192.168.20.2 name Router2 broadcast 6084
dialer load-threshold 1 either
dialer watch-group 1
dialer-group 1
ppp authentication chap
ppp chap hostname Router3BRI 

!--- alternate CHAP hostname

ppp chap password 7 094F471A1A0A
ppp multilink
!
router eigrp 1
network 10.0.0.0
network 192.168.19.0
network 192.168.20.0
no auto-summary
eigrp log-neighbor-changes
!
ip classless
no ip http server
! 
access-list 150 deny eigrp any any
access-list 150 deny udp any any
access-list 150 permit ip any any
dialer watch-list 1 ip 10.0.0.0 255.0.0.0
dialer-list 1 protocol ip list 150

!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end

Router2
Router2#show running-config 
!
version 12.0 
!
hostname Router2
!
!
username MultilinkRouter3 password 0 cisco
username Router3BRI password 0 cisco

!--- The username must match the one in the ppp chap hostname command on the remote router

!
isdn switch-type basic-net3 
!

multilink bundle-name authenticated
!
interface Multilink1
ip address 192.168.19.5 255.255.255.0 
no cdp enable
ppp authentication chap
ppp chap hostname MultilinkRouter2
ppp chap password 7 104D000A0618 

!--- alternate CHAP hostname

ppp multilink
multilink-group 1
! 
interface Serial1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 2000000
ppp multilink
multilink-group 1
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool-member 1
isdn switch-type basic-net3
ppp authentication chap
ppp multilink
!
interface Dialer1
ip address 192.168.20.2 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer remote-name Router3
dialer pool 1
dialer string 6082
dialer-group 1
ppp authentication chap
ppp chap hostname Router2BRI 

!--- alternate CHAP hostname

ppp chap password 7 00071A150754
ppp multilink
!
router eigrp 1
network 10.0.0.0
network 192.168.19.0
network 192.168.20.0
no auto-summary
eigrp log-neighbor-changes
! 
access-list 150 deny eigrp any any
access-list 150 deny udp any any
access-list 150 permit ip any any
dialer-list 1 protocol ip list 150
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show ppp multilink—tests whether your network is operating properly.

The output shown below is a result of entering this command on the devices shown in the network diagram above.

Router3#show ppp multilink
Multilink1, bundle name is MultilinkRouter2
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 1 active, 0 inactive (max not set, min not set)
Serial1
Virtual-Access1, bundle name is Router2BRI
Dialer interface is Dialer1
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x18/0x3F rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 2 (max not set, min not set)
BRI0:1
BRI0:2

Router2#show ppp multilink
Multilink1, bundle name is MultilinkRouter3
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 1 active, 0 inactive (max not set, min not set)
Serial1
Virtual-Access1, bundle name is Router3BRI
Dialer interface is Dialer1
0 lost fragments, 0 reordered, 0 unassigned, sequence 0x18/0x3F rcvd/sent
0 discarded, 0 lost received, 1/255 load
Member links: 2 (max not set, min not set)
BRI0:1
BRI0:2

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 04, 2010
Document ID: 9500