Guest

Cisco Unified Communications Manager Express

Cisco Unified Communications Manager Express: SIP Implementation Guide

Document ID: 99946

Updated: Nov 09, 2007

   Print

Introduction

This document provides step-by-step instructions for setting up a standalone Cisco Unified Communications Manager Express (CME) that uses SIP phones. The document outlines a Cisco Unified Communications Manager Express system with four SIP phones, with configurations for setting up the Cisco Unified Communications Manager Express system and SIP phones.

Note: Though the document covers configuration steps to allow Cisco Unified Communications Manager Express to interoperate with Cisco Unity Express, the Cisco Unity Express configuration is outside of the scope of this paper. Refer to Cisco CallManager Express/Cisco Unity Express Configuration Example for more information on Cisco Unified Communications Manager Express and Cisco Unity Express configurations.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these hardware versions:

  • Cisco 2801 that runs Cisco Unified Communications Manager Express 4.2 with Cisco IOS® Software Release 12.4(11)XW2

  • 9-port double-wide 10/100BASE-T Ethernet switch HWIC

  • Cisco 7970 SIP Phones

  • Cisco 3911 SIP Phone

The information in this document is based on these firmware versions:

  • 7970 IP Phone (SIP)—SIP70.8-2-1S

  • 3911 IP Phone (SIP)—SIP3951.8-0-2-9

Refer to Cisco Unified CME and Cisco IOS Software Version Compatibility Matrix in order to determine the appropriate SIP firmware to use for each Cisco Unified Communications Manager Express version. Since Cisco Unified Communications Manager Express 4.2 is used, refer to the Cisco Unified Communications Manager Express 4.2 Specifications link.

The SIP phoneloads can be downloaded from these locations:

After you have unzipped both the ZIP files in your TFTP folder, copy all the firmware files onto the Cisco Unified Communications Manager Express flash with your TFTP server. Make sure you copy all these files onto flash.

SIP3951.8-0-2-9.loads
SIP3951.8-0-2-9.zz
DSP3951.0-0-0-1.zz
BOOT3951.0-0-0-9.zz
SIP70.8-2-1S.loads
term70.default.loads
term71.default.loads
apps70.8-0-2-55.sbn
cnu70.8-2-0-55.sbn 
cvm70.sip.8-2-0-55.sbn
dsp70.8-2-0-55.sbn
jar70.sip.8-0-2-25.sbn

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

These tables outline the addressing schemes that are used in this setup.

Purpose VLAN Network Interface Interface Address
Voice 192 192.168.10.0/24 VLAN 192 192.168.10.1/24
Data 100 10.10.10.0/24 VLAN 100 10.10.10.1/24

Protocol Phone Type Extension Number Phone Number External Mask
SIP 7970 101 4085251001
SIP 7970 102 4085251002
SIP 3911 103 4085251003
SIP 3911 104 4085251004

Voicemail Pilot Number 100 AA Pilot 110
MWI On 800 MWI Off 801

Note: Use the in order to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

cme-sip-guide01.gif

System Configurations

This document uses these configurations:

Configure DHCP

It is necessary to configure two separate DHCP pools; IP Phones use the Voice DHCP pool and PCs use the Data DHCP pool. IP Phones need to use DHCP option 150 in order to provide the IP address of the TFTP Server.

If there are any devices in either pool with static IP addresses, make sure these addresses are excluded from the DHCP pool in order to avoid addressing conflicts. You can use the show ip dhcp binding command in order to verify which addresses the IP Phones and PCs receive from the router.

DHCP Configuration
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1
   default-router 192.168.10.1

Configure FastEthernet Interface and Switchports

In this section, you configure the VLAN interfaces for both the Data and Voice VLAN and assign switchports into their respective VLANs.

Note: Prior to the configuration of VLANs, be sure to add the previous VLANs to the VLAN database with these commands:

FastEthernet Interface and Switchport Configuration
CME-SIP#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

CME-SIP(vlan)#vlan 100
VLAN 100 modified:
CME-SIP(vlan)#vlan 192
VLAN 192 modified:
CME-SIP(vlan)#exit
APPLY completed.
Exiting....
CME-SIP#

Configure the switchports to be connected to both the Voice and Data VLANs. IP Phones are automatically assigned into the Voice VLAN and PCs connected to either the switchport directly or connected to the switchport on the IP Phone that is assigned to the Data VLAN.

DHCP Configuration
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! 
 interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! !
interface Vlan100
description Data VLAN
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
description Voice VLAN
 ip address 192.168.10.1 255.255.255.0

Configure TFTP

This configuration allows Cisco Unified Communications Manager Express to serve the IP Phones their firmware.

Note: This configuration is mandatory.

TFTP Configuration
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn

Configure Basic Telephony Features

Configure Voice Service parameters

Configure system to allow calls from SIP to SIP endpoints and enable SIP registrar.

Note: This configuration is mandatory.

Voice Service Parameters Configuration
voice service voip
allow-connections sip to sip 

!--- Enable SIP to SIP calls.

sip
registrar server expires max 1200 min 300 

!--- Enable Cisco IOS SIP registrar.

Configure Voice Register Global Parameters

In this section, you configure voice register global parameters.

Note: Voice Register global configurations for SIP are similar to telephony-service configuration parameters for SCCP phones.

Note: This configuration is mandatory.

Voice Register Global Parameters Configuration
voice register global                     
 mode cme  

!--- Set Cisco IOS SIP registrar to CME mode.

 source-address 192.168.10.1 port 5060 

!--- Set the source address for phone registration.

 max-dn 20 

!--- Set max extensions.

 max-pool 10 

!--- Set max phones.

 load 7970 SIP7 SIP70.8-2-1S 

!--- Specify phone loads for each phone type.

 load 3911 SIP3951.8-0-2-9 

!--- Specify phone loads for each phone type.

 authenticate register 

!--- Set authentication for phone registration.

 authenticate realm cisco.com 
 tftp-path flash:  

!--- Specify path for tftp files.

 create profile 

!--- Create configuration files for all phones.

 dialplan-pattern 1 4085251... extension-length 3  

!--- Configure dial-plan pattern for the system.

Here is a link to a video on the Cisco Support Community leavingcisco.comwhich explains the procedure to register an IP Phone with Cisco Unified Communications Manager Express (CME) using SIP Protocol:

Registering a 79xx Series IP Phone using SIP Protocol on CUCME leavingcisco.com

cme-sip-guide02.gif

Configure connection to Cisco Unity Express

Configure necessary dial-peers and MWI ephone-dns to interoperate with Cisco Unity Express. In order for Cisco Unified Communications Manager Express to interoperate with Cisco Unity Express, it is necessary to configure SIP Cisco Unified Communications Manager Express as a back to back user agent (B2BUA), which means that all the signaling and RTP stream goes through the Cisco Unified Communications Manager Express. This configuration is required in order to enable connectivity to Cisco Unity Express.

Cisco Unity Express Connection Configuration
dial-peer voice 2 voip
    destination-pattern 1.0  

!--- Specify destination-pattern to reach CUE VM and AA.

    session target ipv4:10.1.10.1  

!--- Configure IP address to reach Cisco Unity Express.

    session protocol sipv2
    dtmf-relay sip-notify  

!--- Configure DTMF method to communicate with Cisco Unity Express.

    b2bua  

!--- Enable B2BUA for Cisco Unified Communications Manager Express
!--- for calls to Cisco Unity Express.

    codec g711ulaw 
    no vad

Configure Cisco Unity Express MWI support for outcall in order to enable MWI for SIP phones.

Cisco Unity Express MWI Configuration
ephone-dn 11
number 800
mwi on
!
ephone-dn 12
number 801
mwi off

Configure Extension and Parameters

Configure voice register dn in order to create extension numbers for ephones. In the previous network topology, there are four extensions, which need to be created as given here.

Note: This configuration is mandatory.

Extension Configuration
voice register dn 1 
name Phone1 

!--- Set display name.

label 4085251001  

!--- Set display label.

number 101 

!--- Set extension number.

call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch  

!--- Allow this number to be watched (presence).

! 
voice register dn 2 
name Phone2
label 4085251002
number 102 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch
!
voice register dn 3 
name Phone3
label 4085251003
number 103 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch 
! 
voice register dn 4 
name Phone4
label 4085251004
number 104 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch

Configure SIP Phone

Configure voice register pool parameters for each SIP phone.

Note: Voice register pool for SIP phones is identical to ephones for SCCP phones.

Note: This configuration is mandatory.

Voice Register Pool Parameters Configuration
voice register pool  3
 id mac 001A.A11B.500E  

!--- Specify phone mac-address.

 type 3911  

!--- Specify phone type.

 number 1 dn 3  

!--- Assign button 1 dn tag 3.

 dtmf-relay sip-notify  

!--- Configure dtmf-relay sip-notify to work 
!--- with Cisco Unity Express.

 codec g711ulaw  

!--- Specify codec.

 username user1 password cisco  

!--- Configure username and password for SIP registrar.

Note: Multiple methods for DTMF can be configured under voice register pool, but for each SIP phone that has a voicemail box on Cisco Unity Express, configure dtmf-relay sip-notify.

Configure advanced parameters

In this section, you configure advanced parameters for SIP phones such as presence with Busy Lamp Field (BLF) status. Presence with BLF allows either a SCCP phone or SIP phone to monitor the status of another SIP extensions, which enables presence information between phones.

Note: This is an optional configuration.

These phones support SIP presence service on Cisco Unified Communications Manager Express.

Restrictions

BLF Call-List
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.
BLF Speed-Dial
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.

Enable Presence for internal lines

Complete these steps in order to enable the router to accept incoming presence requests from internal watchers and SIP trunks.

1.  enable 
2.  configure terminal 
3.  sip-ua 
4.  presence enable 
5.  exit 
6.  presence 
7.  max-subscription number 
8.  presence call-list 
9.  end
Enable Presence for Internal Lines
Presence  

!--- Enable presence service.

 presence call-list  

!--- Enable BLF monitoring of directory numbers.

 max-subscription 120  

!--- Configure max number watched sessions.

!
sip-ua
 presence enable  

!--- Enable router to accept incoming presence request.

Enable a Directory Number to be watched

Complete these steps in order to enable a line associated with a directory number to be monitored by a phone registered to a Cisco Unified Communications Express router. The line is enabled as a presentity and phones can subscribe to its line status through BLF call-list and BLG speed-dial features. There is no restriction on the type of phone that can have its lines monitored; any line on any IP phone or on an analog phone on supported voice gateways can be a presentity.

1.  enable 
2.  configure terminal 
3.  voice register dn dn-tag 
4.  number number 
5.  allow watch 
6.  end
Enable a Directory Number to be Watched
voice register dn  1
 number 101
 allow watch  

!--- Allow this number to be watched.

 name Phone1
 label 4085251001

Note: Repeat this configuration for each extension number that needs to be watched. This step was already done when you first configured voice register dns.

Enable the SIP Phone to Monitor BLF Status for Speed-Dials and Call Lists

A watcher can monitor the status of lines associated with internal and external directory numbers (presentities) through the BLF speed-dial and BLF call-list presence features. Complete these steps in order to enable the BLF notification features on a SIP phone:

1.  enable 
2.  configure terminal 
3.  voice register pool pool-tag 
4.  number tag dn dn-tag 
5.  blf-speed-dial tag number label string 
6.  presence call-list 
7.  exit 
8.  voice register global 
9.  mode cme 
10.  create profile 
11.  restart 
12.  end
Enable the SIP Phone to Monitor BLF Status for Speed-Dials and Call Lists
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list  

!--- Enable this phone to have presence call list.

 dtmf-relay sip-notify  
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"  

!--- Enable this line to monitor extension 1002.

 blf-speed-dial 3 103 label "3911-1"  

!--- Enable this line to monitor extension 1003.

 blf-speed-dial 4 104 label "3911-2"  

!--- Enable this line to monitor extension 1004.

Note:  Be sure to perform restart every time you change a SIP phone configuration.

Note: Refer to How to Configure Presence Service for more information on the configurations of the SIP Presence Service.

Configure Parallel Hunt Group

In this section, extensions 102, 103, and 104 are assigned into a parallel hunt group. A parallel hunt group is a hunt group that rings all members in the group simultaneously.

Parallel Hunt Group Configuration
voice hunt-group 1
pilot 180  

!--- Configure Hunt group pilot number.

list 102, 103, 104  

!--- Specify members in hunt-group.

final 100  

!--- Specify final number as Voicemail Pilot.

CME- SIP Implementation: Sample Configuration

This section provides the complete sample configuration for setting up a standalone Cisco Unified Communications Manager Express that uses SIP phones.

CME- SIP Implementation: Sample Configuration
CME-SIP#show version
Cisco IOS Software, 2801 Software (C2801-IPVOICE-M), Version 12.4(11)XW2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 02-Jul-07 19:10 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T6, RELEASE SOFTWARE (fc1)

CME-SIP uptime is 18 hours, 55 minutes
System returned to ROM by reload at 17:01:34 UTC Wed Oct 3 2007
System image file is "flash:c2801-ipvoice-mz.124-11.XW2.bin"

Cisco 2801 (revision 4.1) with 235520K/26624K bytes of memory.
Processor board ID FHK084510HS
11 FastEthernet interfaces
1 terminal line
2 Voice FXO interfaces
3 DSPs, 48 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

CME-SIP#show running-config
Building configuration...

Current configuration : 6227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-SIP
!
boot-start-marker
boot-end-marker
!
logging buffered 999999
no logging console
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1 
   default-router 192.168.10.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
voice service voip 
 allow-connections sip to sip
 sip
  registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
 mode cme
 source-address 192.168.10.1 port 5060
 max-dn 20
 max-pool 10
 load 7970 SIP70.8-2-1S
 load 3911 SIP3951.8-0-2-9
 authenticate register
 authenticate realm cisco.com
 voicemail 100
 tftp-path flash:
 create profile sync 0000589556325309
!
voice register dn  1
 number 101
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone1
 label 4085251001
!
voice register dn  2
 number 102
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone2
 label 4085251002
!
voice register dn  3
 number 103
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone3
 label 4085251003
!
voice register dn  4
 number 104
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone4
 label 4085251004
!
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"
 blf-speed-dial 3 103 label "3911-1"
 blf-speed-dial 4 104 label "3911-2"
!
voice register pool  2
 id mac 0014.6948.1D52
 type 7970
 number 1 dn 2
 dtmf-relay sip-notify
 username user2 password cisco
 codec g711ulaw
!
voice register pool  3
 id mac 001A.A11B.4FCE
 type 3911
 number 1 dn 3
 dtmf-relay sip-notify
 username user3 password cisco
 codec g711ulaw
!
voice register pool  4
 id mac 001A.A11B.500E
 type 3911
 number 1 dn 4
 dtmf-relay sip-notify
 username user4 password cisco
 codec g711ulaw
!
voice hunt-group 1 parallel
 final 100
 list 102,103,104
 pilot 180 
!
!
!
!
voice-card 0
!
!
!
archive
 log config
 hidekeys
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 10.1.10.1 255.255.255.0
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/4
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/5
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/6
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/7
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/8
 switchport access vlan 192
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
 ip address 192.168.10.1 255.255.255.0
!
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
ip http server
!
!
!
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 2 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description ** cue auto attendant number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 110
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
presence
 presence call-list
 max-subscription 120
!
sip-ua 
 presence enable
!
!
telephony-service
 max-ephones 24
 max-dn 72
 ip source-address 10.100.100.10 port 2000
 system message CME1
 time-zone 5
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 web admin system name cisco secret 5 $1$4FC/$CMer08o/KELFlVrhL5QRO0
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern 9.T
!
!
ephone-dn  11
 number 800
 mwi on
!
!
ephone-dn  12
 number 801
 mwi off
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

CME-SIP#

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

SIP IP Phone does not get dial tone

A common cause for SIP IP Phones that are not able to get a dial tone is that there is another phone with the same extension. As of Cisco Unified Communications Manager Express 4.2, shared line is not supported on SIP Phones. Thus, SIP phones can not share the same extension among multiple phones. Additionally, make sure that the SIP phone is provisioned with a proper extension.

In order to resolve this issue, make sure that these occur:

  • The SIP phone has the extension configured and extension shows on SIP phone.

  • There is not another SIP or SCCP phone configured with the same extension.

IP Phone Cannot Upgrade to the Latest Firmware

The most likely causes for failure to be able to upgrade a phone is missing firmware files placed on the Cisco Unified Communications Manager Express flash or missing tftp-server commands.

Try these steps in order to resolve this issue:

  • Check that the necessary firmware files are stored on the flash. Perform the dir flash: command in order to check flash for files.

  • Check to see if you have updated the OS79XX.TXT file to reflect the correct firmware. The 79XX phones check this file in order to load the appropriate firmware and change from SCCP to SIP.

  • Check to make sure that the correct tftp-server statements are added for each firmware file. See the Configure TFTP section.

  • Make sure the load command under voice register global is added for each type of SIP phone. See the Configure Voice Register Global Parameters section.

In order to troubleshoot further, collect these debugs in order to see if the phone is able to get the appropriate phone loads from the Cisco Unified Communications Manager Express flash.

Debug tftp events

Unable to Provision Phone

The most likely causes for not being able to provision is phone is that the phone does not have the proper IP address with TFTP server option.

  • Check to see that the phone receives an IP address and the proper TFTP server IP address.

  • Make sure that all proper voice register global commands are added. See the Configure Voice Register Global Parameters section.

  • Check that you use the correct MAC address underneath each voice register pool configuration.

Related Information

Updated: Nov 09, 2007
Document ID: 99946