Guest

Cisco AS5400 Series Universal Gateways

Configuring a Cisco AS5350 or AS5400 for Outgoing Modem and ISDN Calls

Document ID: 24141

Updated: Feb 04, 2010

   Print

Introduction

This configuration has a Cisco AS5400 with one Primary Rate Interface (PRI) and support for 23 modem calls or ISDN calls, depending on the host dialing out or in. It is configured with four PRIs to allow Async and ISDN outbound connections. We have configured static dialer maps on the dialing side for each ISDN or Async connection. We are using static IP routes at both ends of the connection to avoid the unnecessary overhead of a dynamic routing protocol. Adding a remote location would require the addition of a dialer map, user name, and a static route for the new destination on the dialing side. All remote nodes have fixed IP addresses.

Note: This document does not cover incoming Modem and ISDN calls on AS5350 or AS5400 series routers. For more information on this, refer to Configuring an AS5350/AS5400 for Incoming Async and ISDN Calls.

Prerequisites

Requirements

Before attempting this configuration, ensure that you meet these requirements:

  • Please ensure that the ISDN PRI circuits are provisioned by the Telco for dialout-sync and async.

Components Used

The information in this document is based on these software and hardware versions:

  • AS5400 running Cisco IOS® Software Release 12.2(6)

  • One active T1 PRI

  • Nextport modems running portware 0.6.108.0

Since this configuration is only for basic Analog and ISDN dialin, any Cisco IOS software version supported on the AS5350 and AS5400 is sufficient. To run additional features, refer to the Software Advisor tool to select the IOS version and feature set appropriate for your needs.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Related Products

This configuration can also be applied to the AS5350 or AS5400 access server.

This configuration can be modified for use with E1 PRI Ports. Configure the E1 controller with the linecoding, framing and other physical characteristics supplied by the Telco. The D-channel configuration (interface Serial x:15 for E1s) is similar to the one shown here.

This configuration is very similar to an AS5200 or AS5300 configuration for dialout access. Refer to the document AS5300 Dialing out with ISDN/Async (Outbound DDR). The only major change between the two is the command dial-tdm-clock priority number t1_slot/port used to assign the T1 clock priority in the AS5350 or AS5400.

This configuration can also be modified to support both incoming and outgoing calls. Refer to the document Configuring Dialin and Dialout on the Same T1/E1 PRI Circuits for more information

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

5400out.gif

Configurations

This document uses these configurations:

5400
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400
!
no boot startup-test
!
username remoteISDN01 password open4u
username remoteAsync01 password open4u 

!--- Usernames for remote routers and shared secret 
!--- (used for CHAP authentication).
!--- These usernames are for local authentication of the call.
!--- The client presents the username/password and the NAS 
!--- authenticates the peer.
   
!
!
resource-pool disable
!
ip subnet-zero
ip cef
no ip domain-lookup
!
isdn switch-type primary-5ess
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 7/0

!--- T1 Physical interface controller configuration. 
!--- Interfaces are addressed as controller slot/port.

framing esf

!--- Framing for this T1 is Extended Super Frame (ESF). 
!--- Obtain this information from the Telco.

linecode b8zs

!--- Linecoding for this T1. Obtain this information from the Telco.

pri-group timeslots 1-24

!--- PRI T1 with 24 DSOs provided by the Telco.
!--- The PRI signaling is configured in global configuration or the 
!--- the serial 7/X:23 interface (d-channel). The signaling defined 
!--- under the d-channel takes precedence over the PRI signaling 
!--- defined in global configuration.

!

!--- Unsed T1 configuration omitted!

interface FastEthernet0/0
  ip address 172.68.186.54 255.255.255.240
  duplex auto
  speed auto
!
interface FastEthernet0/1
  no ip address
  shutdown
  duplex auto
  speed auto
!
interface Serial0/0
  no ip address
  shutdown
  clockrate 2000000
!
interface Serial0/1
  no ip address
  shutdown
  clockrate 2000000
!
interface Serial7/0:23
  no ip address
  encapsulation ppp
  dialer rotary-group 2

!--- The D-channel is added to rotary-group 2. Interface Dialer 2 
!--- provides the logical configuration for this interface.

  dialer-group 1
  isdn switch-type primary-5ess
  isdn incoming-voice modem

!--- This allows the PRI circuits to accept and place async modem calls.

!
interface Group-Async1

!--- This group-async interface is the configuration template for all modems.
!--- Individual async interface do not have to be configured since they 
!--- can be cloned from one managed copy.

  no ip address
  dialer in-band
  dialer rotary-group 1

!--- This command links this interface to logical interface Dialer interface 1.
!--- The Dialer 1 interface serves as template for this interface.

  group-range 1/00 6/107

!--- Modems 1/00 through 6/107 belong to this group-async interface.
!--- Make sure you configure line 1/00 through 6/107 as well.
!--- This command links all the modem ranges listed to this interface.

!
interface Dialer1

!--- This interface is used for the modem DDR dialout.
!--- This dialer controls rotary-group 1 (configured under Group-Async 1).
! -- Remember that this is a rotary and not a Dialer Profile

  ip address 10.1.1.1 255.255.255.192
  encapsulation ppp
  dialer in-band

!--- Makes this interface DDR capable.
!--- If you do not configure a dialer idle-timeout, the default will be 120
!--- seconds.

  dialer idle-timeout 600

!--- Sets Idle timer to 600 seconds (10 minutes).

  dialer map ip 10.1.1.2 name remoteAsync01 broadcast 4724125

!--- Dialer map for the peer. 
!--- Note the ip address matches the one configure on the peer. 
!--- The name must also exactly match the one used to authenticate the peer.

  dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
!--- Note: The specified dialer-group number must be the same as 
!--- the dialer-list number; in this example, defined as "1".
!--- Interesting traffic specifies the packets that should reset the idle timer.
  
  ppp authentication chap
!
interface Dialer2

!--- This interface will be used for the ISDN DDR outbound calls.
!--- This dialer controls rotary-group 2 (configured under Serial 7/0:23).
! -- Remember that this is a rotary and not a Dialer Profile

  ip address 10.1.1.65 255.255.255.192
  encapsulation ppp
  dialer in-band

!--- If you do not configure a dialer idle-timeout, the default will be 120
!--- seconds.

  dialer idle-timeout 600

!--- Sets Idle timer to 600 seconds (10 minutes).

  dialer map ip 10.1.1.66 name remoteISDN01 broadcast 6665800
  dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
!--- Note: The specified dialer-group number must be the same as 
!--- the dialer-list number; in this example, defined to be "1".
!--- Interesting traffic specifies the packets that should reset the idle timer.

  ppp authentication chap
!
ip classless
ip route 10.1.200.0 255.255.255.0 10.1.1.2

!--- Static route for the 10.1.200.0/24 network.
!--- Note the next hop IP address is the peer router. 
!--- This also matches the ip address in the dialer map
!--- statement under int Dialer 1.

  ip route 10.1.201.0 255.255.255.0 10.1.1.66

!--- Static route for the 10.1.201.0/24 network.
!--- Note the next hop IP address is the peer router. 
!--- This also matches the ip address in the dialer map
!--- statement under interface Dialer 2 no ip http server.

!
dialer-list 1 protocol ip permit

!--- Specifies all IP traffic as interesting. Interesting traffic 
!--- specifies the packets that should reset the idle timer. 
!--- This is applied to interface Group-Async 1 using dialer-group 1.
!--- Note: The specified dialer-list number must be the same as the 
!--- dialer-group number; in this example, defined to be "1".

!
!
call rsvp-sync
!
voice-port 7/0:D
!
voice-port 7/1:D
!
voice-port 7/2:D
!
voice-port 7/3:D
!
!
mgcp profile default
!
!
line con 0
line aux 0
line vty 0 4
login
line 1/00 1/107

!--- These lines are linked to the modems. Note that this range includes 
!--- the group-range configured under group-async 1.

modem InOut
!--- Permit incoming and outgoing calls on the modem.
transport input all
line 6/00 6/107

!--- These lines are linked to the modems. Note that this line range is
!--- included in the group-range configured under group-async 1.

  modem InOut
  transport input all
!
scheduler allocate 10000 400
end

remoteAsync01
remoteAsync01
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteAsync01
!
enable password <deleted>
!
username 5400 password open4u

!--- Username and password for the 5400.
!--- The shared secret password must be identical on both sides.

ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
  no ip address
  no ip directed-broadcast
  shutdown
!
interface Serial1
  no ip address
  no ip directed-broadcast
  shutdown
!
interface Async1

!--- Async interface for the incoming modem call.

  ip address 10.1.1.2 255.255.255.192

!--- IP address for this interface. 
!--- Note: this ip address is the same as the one configured in the 
!--- dialer map on the 5400 Dialer 1.

  no ip directed-broadcast
  encapsulation ppp
  ppp authentication chap
 !
 no ip http server
  ip classless
  ip route 0.0.0.0 0.0.0.0 10.1.1.1

!--- Default router with next hop being the 5400's dialer 1 ip address.

!
 line con 0
  transport input none
 line 1 8

!--- Line number range includes line 1(corresponding to interface async1).

   modem InOut
   transport input all
   speed 38400
   flowcontrol hardware
 line aux 0
 line vty 0 4
!
end

remoteISDN01
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteISDN01
!
enable secret <deleted>
!
username 5400 password open4u

!--- Username and password for the 5400 router.
!--- The shared secret password must be identical on both sides.

ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.1.201.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0

!--- BRI interface for incoming call.

 ip address 10.1.1.66 255.255.255.192

!--- IP address is the same as that configured on the 5400 Dialer 2 
!--- dialer map statement.
!--- A dialer map is not needed on this router. A dynamic map will be created
!--- for incoming calls. If this router is to be used for outgoing calls
!--- then a dialer map is needed.

 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1

!--- Interesting traffic definition from dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
!
no ip http server
 ip classless
 ip route 0.0.0.0 0.0.0.0 10.1.1.65

!--- Default route points to ip address of 5400 dialer 2 interface.

!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show isdn status—The status should be:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED
    

    If Layer 1 is not active, the wiring adapter or port may be bad or not plugged in. If Layer 2 is in a state of "TEI_ASSIGNED", the router is not talking to the switch. Refer to the T1 PRI Troubleshooting document for more information.

  • show isdn service —To check the status of the B channels. There should be a busy channel for each call.

  • show caller—Shows parameters for the particular user such as the IP address assigned, Point to Point Protocol (PPP) and PPP bundle parameters, and so on. If your version of Cisco IOS software does not support this command, use the show user command.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

Configure timestamps in the global configuration as follows:

service timestamps debug datetime msec 
service timestamps log datetime msec 

Use the following commands for troubleshooting:

  • debug dialer—When Dial-on-Demand Routing (DDR) is enabled on the interface, this command displays information concerning the cause of any call (called the dialing cause).

  • debug isdn q931—To check ISDN connections as outbound calls are initiated.

  • debug ppp negotiation—To see if a client is passing PPP negotiation. A high number of concurrent PPP negotiations can overwhelm the router CPU.

  • debug ppp authentication—To see if a client is passing authentication.

  • debug ppp error—To display protocol errors and error statistics associated with PPP connection negotiation and operation.

For modem troubleshooting, use the following commands:

  • debug modem—To see if the router is receiving the right signals from the modem.

  • debug modem csm—To enable the modem management Call Switching Module (CSM) debug mode.

For more information on Nextport commands please refer to Managing Port Services on the Cisco AS5400 Universal Gateway.

Sample Debug Output

Below are some debug outputs for successful calls. Pay attention to the bolded sections and the comments provided in the outputs. Compare the output that you obtain with the result shown below.

Outbound Modem Call

Router#show debug 
General OS: 
 Modem control/process activation debugging is on 
Dial on demand: 
  Dial on demand events debugging is on 
 CSM Modem: 
  Modem Management Call Switching Module debugging is on 
PPP: 
  PPP authentication debugging is on 
  PPP protocol errors debugging is on 
  PPP protocol negotiation debugging is on 
 ISDN: 
 ISDN events debugging is on 
 ISDN Q931 packets debugging is on 
ISDN events debug DSLs. (On/Off/No DSL:1/0/-) 
DSL  0 --> 31 
1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 
ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-) 
DSL  0 --> 31 
1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 
  
Router#ping 10.1.1.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds: 
*Jan  2 01:07:19.085: As1/107 DDR: rotor dialout [priority] 
*Jan  2 01:07:19.085: As1/107 DDR: Dialing cause ip (s=10.1.1.1, d=10.1.1.2) 
*Jan  2 01:07:19.085: As1/107 DDR: Attempting to dial 4724125 

!--- The DDR process has detected interesting traffic destined for a device off 
!--- dialer 1's interface and is inticating a call.

*Jan  2 01:07:19.085: CHAT1/107: Attempting async line dialer script 
*Jan  2 01:07:19.085: CHAT1/107: no matching chat script found for 4724125 
*Jan  2 01:07:19.085: CHAT1/107: Dialing using Modem script: d0efault-d0ials0cript 
& System script: none 
*Jan  2 01:07:19.085: CHAT1/107: process started 
*Jan . 2 01:07:19.085: CHAT1/107: Asserting DTR 
*Jan  2 01:07:19.085: CHAT1/107: Chat script d0efault-d0ials0cript started 
*Jan  2 01:07:20.533: CSM DSPLIB(1/107): Rcvd Dial String (4724125) 
*Jan  2 01:07:20.533: CSM_PROC_IDLE: CSM_EVENT_MODEM_OFFHOOK at slot 1, port 107 
*Jan  2 01:07:20.537: csm_get_signaling_channel csm_call_info->bchan_num 0xFFFFFFFF 
*Jan  2 01:07:20.537: csm_get_signaling_channel dchan_index=16504,next_index=0,
dchan_info=0x628C2BF0 
*Jan  2 01:07:20.537: CSM_PROC_OC3_COLLECT_ALL_DIGIT: CSM_EVENT_GET_ALL_DIGITS 
at slot 1, port 107 
*Jan  2 01:07:20.537: CSM_PROC_OC3_COLLECT_ALL_DIGIT: called party num: (4724125) 
at slot 1, port 107

!--- The Call Switch Module (CSM) is informed of the call. 
!--- The CSM allocates modem 1/107 for the outbound call.

*Jan  2 01:07:20.537: csm_get_signaling_channel csm_call_info->bchan_num 0xFFFFFFFF 
*Jan  2 01:07:20.537: csm_get_signaling_channel dchan_index=24935,next_index=0,
dchan_info=0x628C2BF0 
*Jan  2 01:07:20.537: ISDN Se7/0:23: Outgoing call id = 0x800F, dsl 0 
*Jan  2 01:07:20.537: CSM_PROC_OC3_COLLECT_ALL_DIGIT:  csm_call_info->bchan_num 
0xFFFFFFFF 
*Jan  2 01:07:20.537: ISDN Se7/0:23: VOICE_I.SDNCALL Event: call id 0x800F, 
bchan 65535, ces 0 
*Jan  2 01:07:20.537: ISDN Se7/0:23: process_pri_call(): call id 0x800F, 
number 4724125, speed 64, call type VOICE, redialed? f, csm call? t, pdata? f 
*Jan  2 01:07:20.537: trying to get callinf from isdn_info 
*Jan  2 01:07:20.537: Don't know what calling number for later redial. 
*Jan  2 01:07:20.537: ISDN: Created entry call_id 0x800F, speed 64, remote 4724125, 
calling 
*Jan  2 01:07:20.537: callED type/plan overridden by call_decode 
*Jan  2 01:07:20.537: did't copy oct3a reason: not CALLER_NUMBER_IE 
*Jan  2 01:07:20.537:  building outgoing channel id for call nfas_int is 0 len is 0 
*Jan  2 01:07:20.537: ISDN Se7/0:23: TX -> SETUP pd = 8  callref = 0x000C 
*Jan  2 01:07:20.537:         Bearer Capability i = 0x8090A2 
*Jan  2 01:07:20.537:         Channel ID i = 0xA98397 
*Jan  2 01:07:20.537:         Called Party Number i = 0xA1, '4724125', Plan:ISDN, 
Type:National

!--- Outgoing Q.931 SETUP message. Indicates an outgoing call. 
!--- For more information on Q.931 refer to the document: 
!--- Troubleshooting ISDN Layer 3 using the debug isdn q931 Command.

*Jan  2 01:07:20.617: ISDN Se7/0:23: RX <- CALL_PROC pd = 8  callref = 0x800C 
*Jan  2 01:07:20.617:         Channel. ID i = 0xA98397

!--- The Call Proceeding Message is sent through the D-channel.

*Jan  2 01:07:20.617: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_PROCEEDING 
*Jan  2 01:07:20.617: ISDN Se7/0:23: CALL_PROCEEDING id 0x800F 
*Jan  2 01:07:20.617: ISDN Se7/0:23: PRI Event: 6, bchan = 22, call type = VOICE 
*Jan  2 01:07:20.617: EVENT_FROM_ISDN: dchan_idb=0x62C31CC0, call_id=0x800F, ces=0x1 
   bchan=0x16, event=0x3, cause=0x0 
*Jan  2 01:07:20.617: EVENT_FROM_ISDN:(800F): DEV_CALL_PROC at slot 1 and port 107, 
bchan 22 on Serial7/0:23 
*Jan  2 01:07:20.617: CSM_PROC_OC4_DIALING: CSM_EVENT_ISDN_BCHAN_ASSIGNED at slot 1, 
port 107 
*Jan  2 01:07:20.617: csm_connect_pri_vdev: TS allocated at bp_stream 0, bp_Ch 9, 
vdev_common 0x624BAD88 1/107 
*Jan  2 01:07:20.617: CSM DSPLIB(1/107): np_dsplib_prepare_modem 
*Jan  2 01:07:20.625: CSM DSPLIB(1/107):DSPLIB_MODEM_INIT: 
Modem session transition to IDLE 
*Jan  2 01:07:20.717: ISDN Se7/0:23: RX <- ALERTING pd = 8  callref = 0x800C 
*Jan  2 01:07:20.717: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_PROGRESS 
*Jan  2 01:07:20.717: ISDN Se7/0:23: event CA.LL_PROGRESS dsl 0 
*Jan  2 01:07:20.797: ISDN Se7/0:23: RX <- CONNECT pd = 8  callref = 0x800C

!--- Received the Q.931 CONNECT.

*Jan  2 01:07:20.797: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_CONNECT 
*Jan  2 01:07:20.797: ISDN Se7/0:23: Event CALL_CONNECT dsl 0 
*Jan  2 01:07:20.797: EVENT_FROM_ISDN: dchan_idb=0x62C31CC0, call_id=0x800F, 
ces=0x1 bchan=0x16, event=0x4, cause=0x0 
*Jan  2 01:07:20.797: EVENT_FROM_ISDN:(800F): DEV_CONNECTED at slot 1 and port 107 
*Jan  2 01:07:20.797: CSM_PROC_OC5_WAIT_FOR_CARRIER: CSM_EVENT_ISDN_CONNECTED 
at slot 1, port 107 
*Jan  2 01:07:20.797: CSM DSPLIB(1/107): np_dsplib_call_accept 
*Jan  2 01:07:20.797: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_PROGRESS 
*Jan  2 01:07:20.797: ISDN Se7/0:23: event CALL_PROGRESS dsl 0 
*Jan  2 01:07:20.797: ISDN Se7/0:23: TX -> CONNECT_ACK pd = 8  callref = 0x000C

!--- D-channel transmits a CONNECT_ACK.

*Jan  2 01:07:20.801: CSM DSPLIB(1/107):DSPLIB_MODEM_WAIT_ACTIVE: 
Modem session transition to ACTIVE 
*Jan  2 01:07:20.801: CSM DSPLIB(1/107): Modem state changed to (CONNECT_STATE) 
*Jan  2 01:07:26.797: %ISDN-6-CONNECT: 
Interface Serial7/0:22 is now connected to 4724125 
*Jan  2 01:07:26.893: CSM DSPLIB(1/107): Modem state changed to (LINK_STATE) 
*Jan  2 01:07:29.837: CSM DSPLIB(1/107): Modem state changed to (TRAINUP_STATE) 
*Jan  2 01:07:37.997: CSM DSPLIB(1/107): Modem state changed to (EC_NEGOTIATING_STATE) 
*Jan  2 01:07:38.333: CSM DSPLIB(1/107): Modem state changed to (STEADY_STATE)

!--- Modems have trained up and are in a steady state.

*Jan  2 01:07:38.333: CHAT1/107: Chat script d0efault-d0ials0cript finished, 
status = Success 
*Jan  2 01:07:38.333: TTY1/107: no timer type 1 to destroy 
*Jan  2 01:07:38.333: TTY1/107: no timer type 0 to destroy 
*Jan  2 01:07:38.333: Di1 IPCP: Install route to 10.1.1.2 
*Jan  2 01:07:40.333: %LINK-3-UPDOWN: Interface Async1/107, changed state to up 
*Jan  2 01:07:40.333: As1/107 DDR: Dialer statechange to up 
*Jan  2 01:07:40.333: As1/107 DDR: Dialer call has been placed 
*Jan  2 01:07:40.333: As1/107 PPP: Treating connection as a callout 
*Jan  2 01:07:40.333: As1/107 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 1 load]

!--- LCP negotiation begins.

*Jan  2 01:07:42.469: As1/107 LCP: I CONFREQ [REQsent] id 1 len 25 
*Jan  2 01:07:42.469: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:42.469: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:42.469: As1/107 LCP:    MagicNumber 0x2862C096 (0x05062862C096) 
*Jan  2 01:07:42.469: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:42.469: As1/107 LCP:    ACFC (0x0802)

!--- Incoming LCP CONFREQ. 
!--- For more information on interpreting PPP debugs refer to the document: 
!--- Dialup Technology: Troubleshooting Techniques

*Jan  2 01:07:42.469: As1/107 LCP: O CONFACK [REQsent] id 1 len 25 
*Jan  2 01:07:42.469: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:42.469: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:42.469: As1/107 LCP:    MagicNumber 0x2862C096 (0x05062862C096) 
*Jan  2 01:07:42.469: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:42.469: As1/107 LCP:    ACFC (0x0802) 
*Jan  2 01:07:44.333: As1/107 LCP: O CONFREQ [ACKsent] id 29 len 25 
*Jan  2 01:07:44.333: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:44.333: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:44.333: As1/107 LCP:    MagicNumber 0x081D8CEC (0x0506081D8CEC) 
*Jan  2 01:07:44.333: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:44.333: As1/107 LCP:    ACFC (0x0802) 
*Jan  2 01:07:44.461: As1/107 LCP: I CONFACK [ACKsent] id 29 len 25 
*Jan  2 01:07:44.461: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:44.461: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:44.461: As1/107 LCP:    MagicNumber 0x081D8CEC (0x0506081D8CEC) 
*Jan  2 01:07:44.461: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:44.461: As1/107 LCP:    ACFC (0x0802) 
*Jan  2 01:07:44.461: As1/107 LCP: State is Open

! --- LCP negotiation is complete.

*Jan  2 01:07:44.461: As1/107 PPP: Phase is AUTHENTICATING, by both 
[0 sess, 1 load] 
*Jan  2 01:07:44.461: As1/107 CHAP: O CHALLENGE id 16 len 27 from "Router" 
*Jan  2 01:07:44.477: As1/107 CHAP: I CHALLENGE id 1 len 34 from "remoteAsync01" 
*Jan  2 01:07:44.477: As1/107 CHAP: O RESPONSE id 1 len 27 from "Router" 
*Jan  2 01:07:44.581: As1/107 CHAP: I RESPONSE id 16 len 34 from "remoteAsync01" 
*Jan  2 01:07:44.581: As1/107 CHAP: O SUCCESS id 16 len 4 
*Jan  2 01:07:44.601: As1/107 CHAP: I SUCCESS id 1 len 4

!--- CHAP authentication is successful. 
!--- If this fails, verify that the username and password are correct. 
!--- Refer to Dialup Technology: Troubleshooting Techniques.


*Jan  2 01:07:44.601: As1/107 PPP: Phase is UP [0 sess, 1 load] 
*Jan  2 01:07:44.601: As1/107 IPCP: O CONFREQ [Closed] id 6 len 10 
*Jan  2 01:07:44.601: As1/107 IPCP:    Address 10.1.1.1 (0x03060A010101) 
*Jan  2 01:07:44.601: As1/107 CDPCP: O CONFREQ [Closed] id 5 len 4 
*Jan  2 01:07:44.701: As1/107 IPCP: I CONFREQ [REQsent] id 1 len 10 
*Jan  2 01:07:44.701: As1/107 IPCP:    Address 10.1.1.2 (0x03060A010102) 
*Jan  2 01:07:44.701: As1/107 IPCP: O CONFACK [REQsent] id 1 len 10 
*Jan  2 01:07:44.701: As1/107 IPCP:    Address 10.1.1.2 (0x03060A010102) 
*Jan  2 01:07:44.705: As1/107 CDPCP: I CONFREQ [REQsent] id 1 len 4 
*Jan  2 01:07:44.705: As1/107 CDPCP: O CONFACK [REQsent] id 1 len 4 
*Jan  2 01:07:44.733: As1/107 IPCP: I CONFACK [ACKsent] id 6 len 10 
*Jan  2 01:07:44.733: As1/107 IPCP:    Address 10.1.1.1 (0x03060A010101) 
*Jan  2 01:07:44.733: As1/107 IPCP: State is Open 
*Jan  2 01:07:44.733: As1/107 DDR: dialer protocol up

!--- The route has been successfully negotiated and installed in the routing table.

*Jan  2 01:07:44.737: As1/107 CDPCP: I CONFACK [ACKsent] id 5 len 4 
*Jan  2 01:07:44.737: As1/107 CDPCP: State is Open 
*Jan  2 01:07:45.601: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1/107, 
changed state to up 
*Jan  2 01:07:48.321: TTY0: timer type 1 expired 
*Jan  2 01:07:48.321: TTY0:  Exec timer (continued)

Outbound ISDN Call

Below are some debug outputs for successful ISDN outbound call. Pay attention to the bolded sections and the comments provided in the outputs. Compare the output that you obtain with the result shown below.

Router#show debug 
Dial on demand: 
  Dial on demand events debugging is on 
PPP: 
  PPP authentication debugging is on 
  PPP protocol errors debugging is on 
  PPP protocol negotiation debugging is on 
ISDN: 
  ISDN events debugging is on 
  ISDN Q931 packets debugging is on 
  ISDN events debug DSLs. (On/Off/No DSL:1/0/-) 
  DSL  0 --> 31 
  1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 
  ISDN Q931 packets de  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-) 
  DSL  0 --> 31 
  1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 

Router#ping 10.1.1.66 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.1.1.66, timeout is 2 seconds: 
*Jan  2 02:00:59.937: Se7/0:23 DDR: rotor dialout [priority] 
*Jan  2 02:00:59.937: Se7/0:23 DDR: Dialing cause ip (s=10.1.1.65, d=10.1.1.66) 
*Jan  2 02:00:59.937: Se7/0:23 DDR: Attempting to dial 6665800

!--- The DDR process has detected interesting traffic destined for a device off 
!--- dialer 1's interface and is inticating a call.

*Jan  2 02:00:59.937: ISDN Se7/0:23: Outgoing call id = 0x8016, dsl 0 
*Jan  2 02:00:59.937: ISDN Se7/0:23: Event: Call to 4724125 at 64 Kb/s 
*Jan  2 02:00:59.937: ISDN Se7/0:23: process_pri_call(): call id 0x8016, 
number 6665800, speed 64, call type DATA, redialed? f, csm call? f, pdata? f 
*Jan  2 02:00:59.937: callED type/plan overridden by call_decode 
*Jan  2 02:00:59.937: did't copy oct3a reason: not CALLER_NUMBER_IE 
*Jan  2 02:00:59.941:  building outgoing channel id for call nfas_int is 0 len is 0 
*Jan  2 02:00:59.941: ISDN Se7/0:23: TX -> SETUP pd = 8  callref = 0x0013 
*Jan  2 02:00:59.941:         Bearer Capability i = 0x8890 
*Jan  2 02:00:59.941:         Channel ID i = 0xA98397 
*Jan  2 02:00:59.941:         Called Pa.rty Number i = 0xA1, '6665800', 
Plan:ISDN, Type:National

!--- Outgoing Q.931 SETUP message. Indicates an outgoing call. 
!--- For more information on Q.931 refer to the document. 
!--- Troubleshooting ISDN Layer 3 using the debug isdn q931 Command.

*Jan  2 02:01:00.017: ISDN Se7/0:23: RX <- CALL_PROC pd = 8  callref = 0x8013 
*Jan  2 02:01:00.017:         Channel ID i = 0xA98397

!--- The Call Proceeding Message is sent through the D-channel.

*Jan  2 02:01:00.017: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x8016 CALL_PROCEEDING 
*Jan  2 02:01:00.017: ISDN Se7/0:23: CALL_PROCEEDING id 0x8016 
*Jan  2 02:01:00.021: ISDN Se7/0:23: PRI Event: 6, bchan = 22, call type = DATA 
*Jan  2 02:01:00.093: ISDN Se7/0:23: RX <- CONNECT pd = 8  callref = 0x8013

!--- Received the Q.931 CONNECT.

*Jan  2 02:01:00.097: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x8016 CALL_CONNECT 
*Jan  2 02:01:00.097: ISDN Se7/0:23: Event CALL_CONNECT dsl 0 
*Jan  2 02:01:00.097: %LINK-3-UPDOWN: Interface Serial7/0:22, changed state to up 
*Jan  2 02:01:00.097: Se7/0:22 PPP: Treating connection as a callout 
*Jan  2 02:01:00.097: Se7/0:22 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

!--- LCP negotiation begins.

*Jan  2 02:01:00.097: Se7/0:22 LCP: O CONFREQ [Closed] id 7 len 15 
*Jan  2 02:01:00.097: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.097: Se7/0:22 LCP:    MagicNumber 0x084E600A (0x0506084E600A) 

!--- Outgoing LCP CONFREQ. 
!--- For more information on interpreting PPP debugs refer to the document 
!--- Dialup Technology: Troubleshooting Techniques.

*Jan  2 02:01:00.097: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x8016 CALL_PROGRESS 
*Jan  2 02:01:00.097: ISDN Se7/0:23: event CALL_PROGRESS dsl 0 
*Jan  2 02:01:00.097: ISDN Se7/0:23: TX -> CONNECT_ACK pd = 8  callref = 0x0013

!--- D-channel transmits a CONNECT_ACK.

*Jan  2 02:01:00.105: Se7/0:22 LCP: I CONFREQ [REQsent] id 30 len 15 
*Jan  2 02:01:00.105: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.105: Se7/0:22 LCP:    MagicNumber 0x28938B8C (0x050628938B8C) 
*Jan  2 02:01:00.105: Se7/0:22 LCP: O CONFACK [REQsent] id 30 len 15 
*Jan  2 02:01:00.105: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.109: Se7/0:22 LCP:    MagicNumber 0x28938B8C (0x050628938B8C) 
*Jan  2 02:01:00.109: Se7/0:22 LCP: I CONFACK [ACKsent] id 7 len 15 
*Jan  2 02:01:00.109: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.109: Se7/0:22 LCP:    MagicNumber 0x084E600A (0x0506084E600A) 
*Jan  2 02:01:00.109: Se7/0:22 LCP: State is Open

! --- LCP negotiation is complete.

*Jan  2 02:01:00.109: Se7/0:22 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load] 
*Jan  2 02:01:00.109: Se7/0:22 CHAP: O CHALLENGE id 7 len 27 from "Router" 
*Jan  2 02:01:00.121: Se7/0:22 CHAP: I CHALLENGE id 25 len 33 from "remoteISDN01" 
*Jan  2 02:01:00.121: Se7/0:22 CHAP: O RESPONSE id 25 len 27 from "Router" 
*Jan  2 02:01:00.129: Se7/0:22 CHAP: I SUCCESS id 25 len 4 
*Jan  2 02:01:00.137: Se7/0:22 CHAP: I RESPONSE id 7 len 33 from "remoteISDN01" 
*Jan  2 02:01:00.137: Se7/0:22 CHAP: O SUCCESS id 7 len 4

!--- CHAP authentication is successful. 
!--- If this fails verify that the username and password are correct. 
!--- Refer to Dialup Technology: Troubleshooting Techniques.

*Jan  2 02:01:00.137: Se7/0:22 PPP: Phase is UP [0 sess, 1 load] 
*Jan  2 02:01:00.137: Se7/0:22 IPCP: O CONFREQ [Closed] id 2 len 10 
*Jan  2 02:01:00.137: Se7/0:22 IPCP:    Address 10.1.1.65 (0x03060A010141) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: I CONFREQ [REQsent] id 3 len 10 
*Jan  2 02:01:00.145: Se7/0:22 IPCP:    Address 10.1.1.66 (0x03060A010142) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: O CONFACK [REQsent] id 3 len 10 
*Jan  2 02:01:00.145: Se7/0:22 IPCP:    Address 10.1.1.66 (0x03060A010142) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: I CONFACK [ACKsent] id 2 len 10 
*Jan  2 02:01:00.145: Se7/0:22 IPCP:    Address 10.1.1.65 (0x03060A010141) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: State is Open 
*Jan  2 02:01:00.145: Se7/0:22 DDR: dialer protocol up 
*Jan  2 02:01:00.145: Di2 IPCP: Install route to 10.1.1.66

!--- The Route has been successfully negotiated and installed in the routing table.

*Jan  2 02:01:01.137: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial7/0:22,
changed state to up 
*Jan  2 02:01:06.097: %ISDN-6-CONNECT: Interface Serial7/0:22 
is now connected to 6665800 remoteISDN01

Related Information

Updated: Feb 04, 2010
Document ID: 24141