Guest

Cisco Catalyst G-L3 Series Switches

Configuring EtherChannel and 802.1Q Trunking with Catalyst 2948G-L3s and CatOS Based Switches

Document ID: 24045

Updated: Aug 30, 2005

   Print

Introduction

This document discusses and provides a sample configuration of Fast EtherChannel (FEC) and 802.1Q trunking, between a Catalyst 2948G-L3 switch that runs Cisco IOS® software and switches that run CatalystOS (all models, including Catalyst 4000, 5000, and 6000 series switches).

Prerequisites

Requirements

For a list of Catalyst switches that support 802.1Q and ISL trunking encapsulations, refer to System Requirements to Implement Trunking.

There are certain guidelines for the configuration of EtherChannel and trunking. Refer to the documentation for your switch software. For example, if you are running CatalystOS (CatOS) software release 8.2.x on a Catalyst 6500/6000, refer to the Catalyst 6500 Series Software Configuration Guide, 8.2 and carefully examine any configuration guidelines and restrictions in the Configuring Ethernet VLAN Trunks and Configuring EtherChannel sections.

Components Used

The information in this document is based on these software and hardware versions:

  • Catalyst 2948G with CatOS 7.1.2 installed (802.1Q only)

  • Catalyst 2948G-L3 with Cisco IOS Software Release 12.0(14)W5(20) installed

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Background Theory

The use of EtherChannel can provide increased bandwidth and redundancy. EtherChannel is convenient because it scales the bandwidth without any increase in the complexity of the design. Spanning-tree treats the EtherChannel bundle as a single link, so no loops are introduced. Routing protocols also treat the EtherChannel as a single routed interface with a common IP address. EtherChannel bundling provides up to 1600 Mbps FEC (Fast EtherChannel), full duplex, or 16 Gbps Gigabit EtherChannel (GEC). Trunking carries traffic from several VLANs over a point-to-point link between the two devices. Two methods of trunking are Inter-Switch Link Protocol (ISL, a Cisco-proprietary protocol) or 802.1Q (an IEEE standard). This document specifically deals with 802.1Q trunking.

Configure

In this section, the configurations presented will include a four-port FEC and 802.1Q trunk between the 2948G-L3 and a CatOS switch.

Note: To find additional information about the commands in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

169.gif

Configurations

This document uses these configurations:

Catalyst 2948G
CatOS (enable) show config

This command shows non-default configurations only.
Use 'show config all' to show both default and non-default
configurations.
............

.......................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu Nov 21 2002, 15:24:27
!
#version 7.1(2)
!
!
#system web interface version(s)
set prompt CatOS
!
#test
!
#frame distribution method
set port channel all distribution mac both
!
#ip
set interface sc0 1 10.10.10.1/255.255.255.0 10.10.10.255
set interface sl0 down
set interface me1 down
set ip alias default         0.0.0.0
set ip alias cat             10.10.10.2
!
#spantree
#vlan                         <VlanID>
!
#set boot command
set boot config-register 0x2102
clear boot system all
!

!--- Ports 2/1 to 2/4 are assigned to a port channel.

#port channel
set port channel 2/1-4 29
!
#multicast filter
set igmp filter disable
!
#module 1 : 0-port Switching Supervisor
!

!--- The trunking mode is specified as 802.1Q, because it
!--- is the only encapsulation that is supported on the
!--- 2948G. The mode is set to nonegotiate, because the
!--- 2948G-L3 does not support Dynamic Trunking Protocol (DTP).

#module 2 : 50-port 10/100/1000 Ethernet
set trunk 2/1  nonegotiate 802.1Q 1-1005
set trunk 2/2  nonegotiate 802.1Q 1-1005
set trunk 2/3  nonegotiate 802.1Q 1-1005
set trunk 2/4  nonegotiate 802.1Q 1-1005

!--- The channel mode is set to on, because 2948G-L3
!--- does not support Port Aggregation Protocol (PAgP).

set port channel 2/1-4 mode on
end

Catalyst 2948G-L3
2948G-L3# show run

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2948G-L3
!
enable secret 5 $1$bNvR$33puy1WCyrdKMvlnj61Js.
!
ip subnet-zero
!
!

!--- The logical port-channel interface must be created
!--- before you put the physical interfaces into the
!--- channel group.interface port-channel1.

 no ip address
 no ip directed-broadcast
 hold-queue 300 in
!

!--- Specify the native VLAN: VLAN 1 in this example,
!--- which is the default. For performance and security
!--- reasons, it is recommended that you keep the user
!--- traffic off of the native or management VLAN.

interface Port-channel1.1
 encapsulation 802.1Q 1 native
 ip address 10.10.10.2 255.255.255.0
 no ip redirects
 no ip directed-broadcast
!
interface Port-channel1.2
 encapsulation 802.1Q 2
 ip address 10.10.11.2 255.255.255.0
 no ip directed-broadcast
!

!--- Specify all of the physical ports that are part
!--- of the logical port channel interface.

interface FastEthernet1
 no ip address
 no ip directed-broadcast
 channel-group 1
!
interface FastEthernet2
 no ip address
 no ip directed-broadcast
 channel-group 1
!
interface FastEthernet3
 no ip address
 no ip directed-broadcast
 channel-group 1
!
interface FastEthernet4
 no ip address
 no ip directed-broadcast
 channel-group 1
!

!--- Output suppressed.

!
ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Verify

This section provides information to confirm that your configuration is working properly.

Catalyst 2948G show Commands

  • show port channel—Displays EtherChannel information. It also displays the load-balance or frame-distribution scheme, port, and port-channel information.

    
    
    !--- Verify that the port channel is UP (connected, on) and that
    !--- all the physical ports are members (channel ID).
    
    
    
    CatOS (enable) show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     2/1  connected  on                      29   801
     2/2  connected  on                      29   801
     2/3  connected  on                      29   801
     2/4  connected  on                      29   801
    Port  Device-ID                       Port-ID                Platform
    ----- ------------------------------- ---------------------- --------------
     2/1  2948G-L3                        FastEthernet1          cisco Cat2948G
     2/2   Not directly connected to switch
     2/3  2948G-L3                        FastEthernet3          cisco Cat2948G
     2/4  2948G-L3                        FastEthernet4          cisco Cat2948G

    Note: It is quite normal for port 2/2 not to be directly connected to the switch. Output of the show port channel command on the switch that is connected to a router normally looks like this example. Because the router does not participate in PAgP (used to negotiate channels) and the channeling is on, the ports show the FEC neighbor information using Cisco Discovery Protocol (CDP) data. Cisco IOS software sends out CDP packets on both the channel interface and the physical interfaces. One of the Catalyst ports sees multiple CDP neighbors and reports not directly connected to switch. This is a cosmetic issue, and more information is available in Cisco Bug ID CSCdp04017 (registered customers only) .

  • show port channel statistics—Displays the Admin Group of the port channel and displays whether PAgP is in use on the port channel.

    Verify that PAgP is not in use on the links.

    CatOS (enable) show port channel status
    
    Port  Admin   PAgP Pkts   PAgP Pkts PAgP Pkts PAgP Pkts PAgP Pkts PAgP Pkts
          Group   Transmitted Received  InFlush   RetnFlush OutFlush  InError
    ----- ------- ----------- --------- --------- --------- --------- ---------
     2/1       29           0         0         0         0         0         0
     2/2       29           0         0         0         0         0         0
     2/3       29           0         0         0         0         0         0
     2/4       29           0         0         0         0         0         0
  • show trunk—Displays the the trunking mode, encapsulation, and native VLAN.

    Verify that trunking is enabled on the physical interfaces and on the port channel interface. Also, verify that the trunking mode is correctly set to nonegotiate.

    Note: On a 802.1Q trunk, the native VLAN must match on both sides.

    CatOS (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/1      nonegotiate  802.1Q          trunking      1
     2/2      nonegotiate  802.1Q          trunking      1
     2/3      nonegotiate  802.1Q          trunking      1
     2/4      nonegotiate  802.1Q          trunking      1
    Port      Vlans allowed on trunk
    --------  -----------------------------------------------------------------
     2/1      1-1005
     2/2      1-1005
     2/3      1-1005
     2/4      1-1005
    Port      Vlans allowed and active in management domain
    --------  -----------------------------------------------------------------
     2/1      1
     2/2      1
     2/3      1
     2/4      1
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  -----------------------------------------------------------------
     2/1      1
     2/2      1
     2/3      1
     2/4      1

Catalyst 2948G-L3 show Commands

  • show interfaces port-channel 1—Provides the status of the port channel and the ports that are a member of the port channel group.

    Verify that all of the physical interfaces that are a part of the EtherChannel can be seen as members.

    2948G-L3# show interfaces port-channel 1
    
    Port-channel1 is up, line protocol is up
      Hardware is FEChannel, address is 0008.a308.1c07 (bia 0000.0000.0000)
      MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Half-duplex, Unknown Speed, Media type unknown
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 4
            Member 0 : FastEthernet2
            Member 1 : FastEthernet1
            Member 2 : FastEthernet4
            Member 3 : FastEthernet3
      Last input 00:00:00, output 00:00:55, output hang never
      Last clearing of "show interface" counters never
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/300, 0 drops
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         596128 packets input, 50714549 bytes, 0 no buffer
         Received 7 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         44294 packets output, 17498215 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
  • show cdp neighbor—Lists all of the directly connected Cisco devices that are discovered through CDP.

    Verify that the switch on the other end is visible through all physical ports.

    2948G-L3# show cdp neighbor
    
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    JAB032400H2      Port-channel1.1    126         T S       WS-C2948  2/3
    JAB032400H2      Port-channel1.1    124         T S       WS-C2948  2/4
    JAB032400H2      Port-channel1.1    123         T S       WS-C2948  2/1
    JAB032400H2      Port-channel1.1    123         T S       WS-C2948  2/2

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 30, 2005
Document ID: 24045