Guest

Cisco Catalyst 8500 Series Multiservice Switch Routers

Configuring IP Multicast Routing over ATM Route Module (ARM) on Cisco Catalyst 8540 MSR

Cisco - Configuring IP Multicast Routing over ATM Route Module (ARM) on Cisco Catalyst 8540 MSR

Document ID: 19244

Updated: Dec 18, 2007

   Print

Introduction

As networks increase in size, IP multicast routing becomes critically important as a means to determine which segments require multicast traffic and which do not. IP multicast is a routing technique that allows IP traffic to be propagated from one source to a number of destinations, or from many sources to many destinations. Rather than sending one packet to each destination, one packet is sent to the multicast group identified by a single IP destination group address.

This document shows how to configure IP multicast routing over an ATM Router Module (ARM) on a Catalyst 8540 MSR. This configuration is supported on both ARM and enhanced ARM (known as ARM I and ARM II, respectively).

Prerequisites

Requirements

Readers of this document should be knowledgeable about basic IP multicasting configurations on Cisco routers. For background information, refer to these documents:

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 3600, 7200, and 7500 series routers running Cisco IOS® Software Release 12.1.(7)

  • Catalyst 8540 MSR and Catalyst 8510 MSR running Cisco IOS Software Release 12.1(7)EY

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram:

arm-mul.gif

The Cisco 3640 router, known as C3640, is connected to the Cisco Catalyst 8540 MSR (known as 8540MSR) through the Fast Ethernet port 3/0/1. The 8540MSR has an ARM on slot 11. The C8540MSR is physically connected to the 8510MSR using interface atm 9/1/0. The 8510MSR ATM switch connects to the 8540MSR on ATM interface 1/0/2.

There are two permanent virtual circuits (PVCs) built through the 8510MSR. One is from the 8540MSR ARM multipoint subinterface to the C7513 router and the other is from the same 8540MSR ARM multipoint subinterface to the C7204 router. The routing protocol used is Open Shortest Path First (OSPF). IP Protocol Independent Multicast (PIM) dense-mode is configured on the routers. This includes the ARM module on 8540MSR. C3640, C7513, and C7204 have one interface configured to join the multicast-group 239.0.10.1. A ping from C3640 to the multicast address 239.0.10.1 gets responses from C3640, C7513, and C7204.

Configurations

This section contains the portions of the configuration on the routers and switches described in the network diagram. This is some specific information about the configuration:

  • The configuration that appears in this document uses encapsulation aal5mux.

  • A multipoint subinterface is created on ARM, while ATM PVCs are configured to the remote sites.

  • PIM is used in dense-mode. As far as PIM is concerned, ARM does not differentiate between individual VCs on the multipoint interface.

  • Multicast traffic is forwarded out to all VCs that have "broadcast" configured.

  • The show ip mroute output illustrates that PIM only identifies the outgoing interface and not individual VCs.

The configuration for IP multicast routing with the help of PIM is shown here. All the relevant commands for IP multicast routing are shown in bold.

C3640
ip multicast-routing
!
interface Ethernet1/0
 ip address 10.10.200.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
!

C8540MSR
ip multicast-routing
!
interface FastEthernet3/0/1
 ip address 10.10.200.2 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 no ip mroute-cache
!
!
interface ATM11/0/0.1 multipoint
 ip address 75.75.75.2 255.255.255.0
 ip pim dense-mode
 ip ospf network point-to-multipoint
 map-group multicast
 atm pvc 2 1000 pd on  encap aal5mux ip interface  ATM9/1/0 0 1000 
 atm pvc 2 1001 pd on  encap aal5mux ip interface  ATM9/1/0 0 1001 
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.1 atm-vc 1000 aal5mux broadcast
 ip 75.75.75.3 atm-vc 1001 aal5mux broadcast

8510MSR
interface ATM1/0/2
 no ip address
 atm pvc 0 1000  interface  ATM1/0/1 0 1000 
!         
interface ATM1/0/3
 no ip address
 atm pvc 0 1001  interface  ATM1/0/2 0 1001 
! 

C7513
ip multicast-routing
!
!         
interface Ethernet9/0/2
 ip address 30.30.30.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
!
interface ATM1/0/0.1 multipoint
 ip address 75.75.75.1 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1000 0 1000 aal5mux ip
!
!
router ospf 1
 log-adjacency-changes
 network 30.30.30.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1000 broadcast
!

C7204
ip multicast-routing
!
interface Loopback0
 ip address 40.40.40.1 255.255.255.0
 ip igmp join-group 239.0.10.1
!
!
interface ATM4/0.5 multipoint
 ip address 75.75.75.3 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1 0 1001 aal5mux ip
!
router ospf 1
 log-adjacency-changes
 network 40.40.40.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1 broadcast

Verify

Use these commands to test that your network operates properly:

Certain show commands are supported by the Output Interpreter Tool (registered customers only) . This allows you to view an analysis of show command output.

  • show ip route —Displays IP routing table entries.

  • show ip pim neighbor —Lists the PIM neighbors discovered by the Cisco IOS® software.

  • show ip mroute—Displays the contents of the IP multicast routing table.

  • show ip igmp groups —Displays the multicast groups that are directly connected to the router and that are learned through IGMP.

This output is a result of entering these show commands on the devices shown in the network diagram. This output shows that the network operates properly.

C3640

The show ip route command is used on the C3640 to verify that this router reaches all network IP addresses. It has a route to 75.75.75.1, 75.75.75.2, 75.75.75.3. The loopback interfaces are defined. All the routes are found through OSPF.

C3640#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/12] via 10.10.200.2, 00:01:48, Ethernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.200.0 is directly connected, Ethernet1/0
     75.0.0.0/32 is subnetted, 3 subnets
O       75.75.75.3 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.2 [110/10] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.1 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/21] via 10.10.200.2, 00:01:49, Ethernet1/0

This command is used to identify the IP PIM neighbors. The neighbor in this case is the C8540MSR .

C3640#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface          Uptime/Expires    Ver   DR
Address                                                      Priority/Mode
10.10.200.2       Ethernet1/0        3d03h/00:01:16    v2    N / DR

If the multicast group is pinged from the C3640, it is successful. This indicates that the C3640 communicates to the multicast group defined by IP address 239.0.10.1.

C3640#ping 239.0.10.1  

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.10.1, timeout is 2 seconds:
Reply to request 0 from 10.10.200.1, 4 ms
Reply to request 0 from 75.75.75.3, 4 ms
Reply to request 0 from 75.75.75.1, 4 ms

The show ip mroute command displays the information about the multicast routing table. In this example there is a null route for 239.0.10.1 and 224.0.1.40. The last multicast address is the one designated by Internet Assigned Numbers Authority (IANA) for cisco-rp-discovery.

C3640#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Advertised via MSDP, U - URD,
       I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 2d23h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00

(*, 239.0.10.1), 1w1d/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00
(10.10.200.1, 239.0.10.1), 00:02:37/00:00:22, flags: PCLTA
  Incoming interface: Ethernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

Check the IP IGMP groups with the help of the show ip igmp groups command. Both the cisco-rp-discovery multicast ip address and the igmp multicast group that the C3640 joins are discovered.

C3640#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface            Uptime    Expires   Last Reporter
224.0.1.40       Ethernet1/0          3d00h     00:02:38  10.10.200.2
239.0.10.1       Ethernet1/0          1w1d      00:02:44  10.10.200.1

C8540MSR

The same show commands are used in the C8540MSR Catalyst Switch as those in the C3460. The show ip route command shows that the C8540MSR reaches all the subnets of the network.

C8540MSR#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/2] via 75.75.75.3, 01:25:34, ATM11/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet0
C       10.10.200.0 is directly connected, FastEthernet3/0/1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/1] via 75.75.75.3, 01:25:34, ATM11/0/0.1
O       75.75.75.1/32 [110/1] via 75.75.75.1, 01:25:34, ATM11/0/0.1
C       75.75.75.0/24 is directly connected, ATM11/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/11] via 75.75.75.1, 01:25:35, ATM11/0/0.1
S*   0.0.0.0/0 [1/0] via 10.118.1.21

The show ip pim neighbor command displays the multicast neighbors. In the case of the C8540MSR, the IP PIM neighbors are C3640 (10.10.200.1), C7513 (75.75.75.1), and C7204 (75.75.75.3).

C8540MSR#show ip pim neighbor 
PIM Neighbor Table
Neighbor Address  Interface                Uptime    Expires   Ver  Mode
10.10.200.1       FastEthernet3/0/1        3d02h     00:01:25  v2   
75.75.75.3        ATM11/0/0.1              00:12:11  00:01:33  v2    (DR)
75.75.75.1        ATM11/0/0.1              00:18:43  00:01:32  v2

The show ip mroute command provides information about the multicast routing table. This example shows that there is a null route for 239.0.10.1 and 224.0.1.40. The last multicast address is the one designated by the IANA for cisco-rp-discovery.

C8540MSR#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Group, C - Connected, L - Local,
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP, U - URD, I - Received Source Specific Host
           Report 
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 3d03h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(*, 239.0.10.1), 3d03h/00:02:59, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:17/00:02:49, flags: CT
  Incoming interface: FastEthernet3/0/1, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 00:00:19/00:00:00

C7513

The description and explanations for the commands shown here are the same as the ones provided for C3640 and C8540MSR.

C7513#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/3] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet9/0/1
O       10.10.200.0 [110/2] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     11.0.0.0/24 is subnetted, 2 subnets
C       11.12.12.0 is directly connected, Serial0/0/0/2:2
C       11.11.11.0 is directly connected, Serial0/0/0/1:1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/2] via 75.75.75.2, 02:05:05, ATM1/0/0.1
O       75.75.75.2/32 [110/1] via 75.75.75.2, 02:05:05, ATM1/0/0.1
C       75.75.75.0/24 is directly connected, ATM1/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Ethernet9/0/2
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7513#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM1/0/0.1               04:28:34/00:01:18 v2    N / DR
C7513#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(*, 239.0.10.1), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:51/00:02:08, flags: CLT
  Incoming interface: ATM1/0/0.1, RPF nbr 75.75.75.2
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 00:00:52/00:00:00
C7513#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       Ethernet9/0/2        22:04:09  00:02:50  30.30.30.1
239.0.10.1       Ethernet9/0/2        22:04:15  00:02:50  30.30.30.1

C7204

The description and explanations for the commands shown here are the same as the ones provided for C3640 and C8540MSR .

C7204#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.40.40.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, FastEthernet0/0
O       10.10.200.0 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.2/32 [110/1] via 75.75.75.2, 03:31:48, ATM4/0.5
O       75.75.75.1/32 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
C       75.75.75.0/24 is directly connected, ATM4/0.5
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/12] via 75.75.75.2, 03:31:49, ATM4/0.5
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7204#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM4/0.5                 03:32:29/00:01:23 v2    N /
C7204#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 05:20:47/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:57:26/00:00:00

(*, 239.0.10.1), 03:31:41/00:00:00, RP 0.0.0.0, flags: DL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:31:41/00:00:00
7204#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       ATM4/0.5               05:20:53  00:02:24  75.75.75.3
239.0.10.1       Loopback0              23:33:52  stopped   40.40.40.1

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Dec 18, 2007
Document ID: 19244