Guest

Cisco Catalyst 6000 Series Switches

Comparing Layer 2 Operations in CatOS and Cisco IOS System Software on the Catalyst 6500/6000

Document ID: 12155

Updated: Jan 10, 2006

   Print

Introduction

This document familiarizes users of Catalyst OS (CatOS) with the Layer 2 (L2) configurations that Cisco IOS® System Software uses. This document covers the similarities and differences between CatOS and Cisco IOS Software for commands and concepts such as ports/interfaces, trunks, channels, VLANs, and Virtual Trunk Protocol (VTP). The document provides a CatOS/Cisco IOS Software Command Matrix for quick reference with regard to the most popular commands.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Difference Between CatOS and Cisco IOS System Software

CatOS on the Supervisor Engine and Cisco IOS Software on the MSFC (Hybrid): A CatOS image can be used as the system software to run the Supervisor Engine on Catalyst 6500/6000 switches. If the optional MSFC is installed, a separate Cisco IOS Software image is used to run the MSFC.

Cisco IOS Software on both the Supervisor Engine and MSFC (Native): A single Cisco IOS Software image can be used as the system software to run both the Supervisor Engine and MSFC on Catalyst 6500/6000 switches.

Note: For more information, refer to the document Comparison of the Cisco Catalyst and Cisco IOS Operating Systems for the Cisco Catalyst 6500 Series Switch.

Catalyst 6500/6000 CatOS and Cisco IOS Software Images

Catalyst 6500/6000 switches have the option to run one of two types of software.

CatOS: This implementation is logically equivalent to a Catalyst 5500/5000 series switch with a Route Switch Module (RSM). When you run in CatOS mode, there are two separate software images. The MSFC runs a traditional Cisco IOS Software image, and the Supervisor Engine runs the traditional CatOS. Each device has its own configuration file.

Cisco IOS Software: This implementation provides a single, "router-like" interface. The division between the router (which has the name Route Processor [RP]) and switch Supervisor Engine (which has the name Switch Processor [SP]) is transparent to the user. There is a single console connection, configuration file, and software image.

Note: You always need an MSFC1 boot image to allow the MSFC1 to load properly. The boot image is necessary for hardware support, and the boot image provides a backup for emergency recovery situations. The software image actually loads the necessary software for full functionality of the router.

A Policy Feature Card (PFC) is necessary in addition to an MSFC.

Understand Software Image Name Conventions for CatOS and Cisco IOS Software

In CatOS, the switch Supervisor Engine and the MSFC run separate software images.

With reference to the Supervisor Engine, there are two different image types: one for Supervisor Engine Is and the other one for Supervisor Engine IIs. The numeral that follows the cat6000-sup prefix denotes the difference in the images.

If a 2 follows the cat6000-sup prefix, the image is for the Catalyst Supervisor Engine II. If a 720 follows the cat6000-sup prefix, the image is for the Catalyst Supervisor Engine 720. If neither a 2 nor 720 follows the cat6000-sup prefix, the image is for the Catalyst Supervisor Engine I. So, for example, a file with the name "cat6000-sup.6-2-3.bin" is for the Supervisor Engine I. A file with the name "cat6000-sup2.6-2-3.bin" is for the Supervisor Engine II. To download these images, refer to Software Download - Catalyst 6500/6000 CatOS System Software (registered customers only) .

When you run CatOS with Cisco IOS Software on the MSFC1, MSFC2, or MSFC3, each MSFC type runs its own separate image. The Download Software Area (registered customers only) now incorporates these images. To download the image for the MSFC1, MSFC2, or MSFC3, go to the Cisco Software Download page.

Cisco IOS System Software runs a combined software image for both the Supervisor Engine and MSFC daughter card. For the user, there is only one image to load into Flash. The type of Supervisor Engine and MSFC installation categorizes each image. The image categories in the Download Software Area (registered customers only) are:

  • Supervisor Engine 720/MSFC3 (CAT6000-SUP720/MSFC3)

  • Supervisor Engine 2/MSFC2 (CAT6000-SUP2/MSFC2)

  • Supervisor Engine 1/MSFC2 (CAT6000-SUP1/MSFC2)

  • Supervisor Engine 1/MSFC1 (CAT6000-SUP1/MSFC1)

To download Cisco IOS System Software images, refer to Software Download - Catalyst 6500/6000 Cisco IOS System Software (registered customers only) .

Note: A Supervisor Engine II must use an MSFC2 daughter card; a Supervisor Engine II cannot use the original MSFC daughter card.

To determine which image currently runs, issue the show version command.

Note: In Hybrid mode, issue the show version command on the respective modules to determine the current image they are running.

For example, here, the show version command indicates a Catalyst 6500 with MSFC2 that runs CatOS on the Supervisor Engine and Cisco IOS Software on the MSFC.

Hybrid_Cat6500>(enable) show version
WS-C6509 Software, Version NmpSW: 7.6(4)
Copyright (c) 1995-2003 by Cisco Systems
NMP S/W compiled on Nov  4 2003, 19:22:09

System Bootstrap Version: 5.3(1)
System Boot Image File is 'bootflash:cat6000-supk8.7-6-4.bin'
System Configuration register is 0x2102

Hardware Version: 2.0  Model: WS-C6509  Serial #: SCA043500S2
PS1  Module: WS-CAC-1300W    Serial #: SON04340836
PS2  Module: WS-CAC-1300W    Serial #: SNI05470791

Mod Port Model               Serial #    Versions
--- ---- ------------------- ----------- --------------------------------------
1   2    WS-X6K-SUP1A-2GE    SAD04500AFW Hw : 7.4
                                         Fw : 5.3(2)
                                         Fw1: 5.4(2)
                                         Sw : 7.6(4)
                                         Sw1: 7.6(4)
         WS-X6K-SUP1A-2GE    SAD04500AFW Hw : 7.4   
                                         Sw : 
2   2    WS-X6K-SUP1A-2GE    SAL0549F477 Hw : 7.1
                                         Fw : 5.3(1)
                                         Fw1: 5.4(2)
                                         Sw : 7.6(4)
                                         Sw1: 7.6(4)
         WS-X6K-SUP1A-2GE    SAL0549F477 Hw : 7.1   
                                         Sw : 
3   48   WS-X6148-GE-TX      SAD0746052K Hw : 4.0
                                         Fw : 7.2(1)
                                         Sw : 7.6(4)
4   48   WS-X6248-RJ-45      SAD04281CZY Hw : 1.2
                                         Fw : 5.1(1)CSX
                                         Sw : 7.6(4)
5   48   WS-X6248-RJ-45      SAD042608NZ Hw : 1.2
                                         Fw : 5.1(1)CSX
                                         Sw : 7.6(4)
6   48   WS-X6248-RJ-45      SAD04170CG9 Hw : 1.2
                                         Fw : 5.1(1)CSX
                                         Sw : 7.6(4)
7   48   WS-X6248-RJ-45      SAD04270N9U Hw : 1.2
                                         Fw : 5.1(1)CSX
                                         Sw : 7.6(4)
15  1    WS-F6K-MSFC2        SAD04520C65 Hw : 1.7
                                         Fw : 12.1(19)E1
                                         Sw : 12.1(19)E1
16  1    WS-F6K-MSFC2        SAL0548F2TE Hw : 2.0
                                         Fw : 12.1(19)E1
                                         Sw : 12.1(19)E1

       DRAM                    FLASH                   NVRAM
Module Total   Used    Free    Total   Used    Free    Total Used  Free
------ ------- ------- ------- ------- ------- ------- ----- ----- -----
2      130944K  50017K  80927K  16384K  10857K   5527K  512K  389K  123K
        
Uptime is 142 days, 4 hours, 27 minutes

Default System Differences Between the CatOS and Cisco IOS Software

Features CatOS Cisco IOS Software
Configuration file Two configuration files: one for the Supervisor Engine (NMP1) and one for the MSFC One configuration file
Software image Two images: one for the Supervisor Engine and one for the MSFC One software image; an MSFC boot image is also required to allow the MSFC to load properly
Default port mode Every port is an L2 switched port Every port is an L32 routed port (interface)
Default port status Every port is enabled Every port (interface) is in the shutdown state
Configuration commands format The command keyword set precedes each configuration command Cisco IOS command structure with global- and interface-level commands
Configuration mode No configuration mode (set, clear, and show commands) The commands configure terminal and VLAN database activate configuration modes
Remove/change the configuration Via use of the clear, set, and/or enable/disable commands Same as Cisco IOS command structure; keyword no negates a command

1 NMP = Network Management Processor

2 L3 = Layer 3

Understand Interfaces in Cisco IOS System Software

Interface (Port) Modes in Cisco IOS Software

You refer to ports in Cisco IOS Software as interfaces. There are two types of interface modes in Cisco IOS Software:

  • L3 routed interface

  • L2 switch interface

Note: The default is an L3 routed interface.

Configure L2 Ethernet Interfaces

To make a port/interface an L2 switch interface, add the switchport command under the interface, as this example shows:

Cat6500# show running-config interface fastethernet 5/10 
Building configuration... 
Current configuration: 
! 
interface FastEthernet5/10 
no ip address 
switchport
end 

The default interface configuration for an L2 switch port is different than in CatOS. For example, when a port has an L2 port configuration, the trunk mode is desirable instead of auto. The show interface interface switchport command provides details on the current configuration of an L2 switch port. Here is an example:

Cat6500# show interfaces fastethernet 5/10 switchport 
Name: Fa5/10 
Switchport: Enabled 
Administrative Mode: dynamic desirable 
Operational Mode: down 
Administrative Trunking Encapsulation: negotiate 
Negotiation of Trunking: On 
Access Mode VLAN: 1 ( default) 
Trunking Native Mode VLAN: 1 (default) 
Trunking VLANs Enabled: ALL 
Pruning VLANs Enabled: 2-1001 

There are three main L2 switch port modes in Cisco IOS Software:

  • Access: Sets the interface to nontrunking mode.

  • Dynamic: Sets the interface to dynamically negotiate for access or trunk mode. Two options for this setting are:

    • Desirable: This configuration allows the port to become trunk if the neighbor device has a trunk configuration in the desirable or auto mode. Desirable mode is the default mode when a port has a switch port configuration.

    • Auto: This configuration allows the port to become trunk if the other neighbor has a trunk configuration in the desirable mode.

  • Trunk: Sets the interface to permanent trunk mode.

Port Configuration and Status CatOS/Cisco IOS Command Matrix

Function CatOS
To enable PortFast
CatOS (enable) set spantree portfast 4/1 enable

Warning: Spantree port fast start should only
be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,
bridges, etc. to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port 4/1 fast start enabled.
To configure port for host access. This command enables PortFast and disables trunking and channeling in CatOS.
CatOS (enable) set port host 4/2
Port(s) 4/2 channel mode set to off.

Warning: Spantree port fast start should only be
enabled on ports connected to a single host.
Connecting hubs, concentrators, switches,
bridges, etc. to a fast start port can cause
temporary spanning tree loops. Use with caution.
Spantree port 4/2 fast start enabled.        
Port(s) 4/2 trunk mode set to off.        
CatOS (enable)
To display the port status
show port
show port mod

show port mod/port

show port counters 
show port counters mod/port

Function Cisco IOS Software
To enable PortFast
CiscoIOS(config)# interface fastethernet 4/2
CiscoIOS(config-if)# spanning-tree portfast

Warning: portfast should only be enabled on
ports connected to a single host.

Connecting hubs, concentrators, switches,
bridges, etc. to this interface when
portfast is enabled can cause temporary
spanning tree loops.

Use with CAUTION

Portfast has been configured on
FastEthernet4/2 but will only have effect
when the interface is in a non-trunking mode.

CiscoIOS(config-if)# ^Z
CiscoIOS#
To configure port for host access. This command enables PortFast and disables trunking and channeling in CatOS.
CiscoIOS(config)# interface fastethernet 4/2
CiscoIOS(config-if)# switchport
CiscoIOS(config-if)# switchport mode access
CiscoIOS(config-if)# spanning-tree portfast

%Warning: portfast should only be enabled
on ports connected to a single host.
Connecting hubs, concentrators, switches,
bridges, etc. to this interface when
portfast is enabled, can cause temporary
spanning tree loops. 

Use with CAUTION        

%Portfast has been configured on
FastEthernet4/2 but will only have effect
when the interface is in a non-trunking mode.

CiscoIOS(config-if)# ^Z
CiscoIOS#
To display the port status
show interface status 
show interface status module mod

show interface status errordisabled
show interface counters error module mod

Understand the Use of the range Command in Cisco IOS Software

Even when a switch runs Cisco IOS Software, there is still the potential to have a large number of interfaces. Therefore, to aid in the quick configuration of multiple ports, Cisco IOS Software allows you to configure a range of interfaces simultaneously as in CatOS. If you issue the range command, you can configure many interfaces with the same configuration quickly.

CiscoIOS(config)# interface range gigabitethernet 1/1 -2, fastethernet 4/1 -24

Note: In the syntax of this command, there is a space between the first interface range and the hyphen. Syntax is important and must be absolutely accurate. If a space is not in place, the command-line interface (CLI) returns a syntax error.

These are examples of incorrect usage of the range command:

CiscoIOS(config)# interface range gigabitethernet 1/1-2,fastethernet 4/1-24 
   ^ 
% Invalid input detected at '^' marker.

CiscoIOS(config)# interface range gigabitethernet 1/1 -2,fastethernet 4/1-24 
   ^ 
% Invalid input detected at '^' marker.

CiscoIOS(config)# interface range gigabitethernet 1/1 -2,fastethernet 4/1 -24

This example sets the port from 4/2-8 in VLAN 2:

NativeIOS(config)# interface range fastethernet 4/2 -8
CiscoIOS(config-if)# switchport
CiscoIOS(config-if)# switchport access vlan 2
CiscoIOS(config-if)# no shut
CiscoIOS(config-if)# ^Z
CiscoIOS# show interface 

After this use of the range command, the configuration appears as this:

interface FastEthernet4/4
no ip address
switchport
switchport access vlan 2
!
interface FastEthernet4/5
no ip address
switchport
switchport access vlan 2
!
interface FastEthernet4/6
no ip address
switchport
switchport access vlan 2
!
interface FastEthernet4/7
no ip address
switchport
switchport access vlan 2
!
interface FastEthernet4/8
no ip address
switchport
switchport access vlan 2
!
interface FastEthernet4/9
no ip address
shutdown

Cisco IOS Software Configurations

Configure Trunks in Cisco IOS Software

Cisco IOS Software supports both Inter-Switch Link Protocol (ISL) and IEEE 802.1Q (dot1q) trunking modes. Different options for interface configurations are available, as the section Understand Interfaces in Cisco IOS System Software discusses. Trunking works in exactly the same way as in CatOS, except for the default setting in Cisco IOS Software, which is desirable rather than auto.

Function CatOS
To enable ISL trunk
CatOS (enable) set trunk 4/1 on isl
Port(s) 4/1 trunk mode set to on.
Port(s) 4/1 trunk type set to isl.
To enable dot1q trunk
CatOS (enable) set trunk 4/1 on dot1q
Port(s) 4/1 trunk mode set to on.
Port(s) 4/1 trunk type set to dot1q
CatOS (enable) set vlan 2 4/1
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2    1/1
     4/1 

Note: In the case of dot1q, it is very important that the native VLAN matches across the trunk link. Use the set vlan vlan-id mod/port command in CatOS to set the native VLAN for the trunk.

To change trunk mode
CatOS (enable) set trunk mod/port {on
| off | desirable | auto | nonegotiate}
[vlans] [isl | dot1q | negotiate]
To display trunking status
show trunk
show trunk mod

show port mod/port

Function Cisco IOS Software
To enable ISL trunk
CiscoIOS# configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
CiscoIOS(config)# interface fastethernet 4/1
CiscoIOS(config-if)# switchport
CiscoIOS(config-if)# switchport trunk encapsulation isl
CiscoIOS(config-if)# switchport mode trunk
3d22h: %DTP-SP-5-TRUNKPORTON:
Port Fa4/1 has become isl
CiscoIOS(config-if)# ^Z
CiscoIOS#
To enable dot1q trunk
CiscoIOS# configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
CiscoIOS(config)# interface fastethernet 4/1
CiscoIOS(config-if)# switchport
CiscoIOS(config-if)# switchport trunk encapsulation dot1q
CiscoIOS(config-if)# switchport mode trunk
3d22h: %DTP-SP-5-TRUNKPORTON:
Port Fa4/1 has become dot1q
CiscoIOS(config-if)# switchport trunk native vlan 2
CiscoIOS(config-if)# ^Z
CiscoIOS#
To change trunk mode
CiscoIOS(config-if)# switchport mode {access |
 trunk | multi | dynamic {auto | desirable}}
To display trunking status
show interfaces trunk
show interfaces trunk module number

show interfaces interface-type mod/port

show interfaces status

There are several ways to verify trunk information in Cisco IOS Software.

Note: A routed port is not an L2 trunked port.

The show interfaces trunk command displays all the interfaces that currently trunk. This command does not display ports that have a configuration to trunk but do not actively trunk:

Switch# show interfaces trunk 
Port Mode      Encapsulation Status   Native vlan 
Po41 desirable n-isl         trunking 1    
Port Vlans allowed on trunk 
Po41 1-1005 
Port Vlans allowed and active in management domain 
Po41 1-6,1002-1005 
Port Vlans in spanning tree forwarding state and not pruned 
Po41 1-6,1002-1005

The show interfaces trunk module number command shows all the interfaces on the specified module, regardless of trunk status.

Switch# show interfaces trunk module 4 
Port   Mode      Encapsulation Status       Native vlan 
Fa4/1  desirable n-isl         trunk-inbndl 1 (Po41) 
Fa4/2  desirable n-isl         trunk-inbndl 1 (Po41) 
Fa4/3  desirable n-isl         trunk-inbndl 1 (Po41) 
Fa4/4  desirable n-isl         trunk-inbndl 1 (Po41) 
Fa4/5  desirable negotiate     not-trunking 1 
Fa4/6  desirable negotiate     not-trunking 1 
Fa4/7  desirable negotiate     not-trunking 1 
Fa4/8  desirable negotiate     not-trunking 1 
Fa4/9  desirable negotiate     not-trunking 1 
Fa4/10 routed    negotiate     routed       1 
Fa4/11 desirable negotiate     not-trunking 1 
Fa4/12 desirable negotiate     not-trunking 1 
Fa4/13 desirable negotiate     not-trunking 1 
Fa4/14 desirable negotiate     not-trunking 1 
Fa4/15 desirable negotiate     not-trunking 1 
Fa4/16 desirable negotiate     not-trunking 1 
Fa4/17 desirable negotiate     not-trunking 1

You can use the show interfaces interface-type mod/port trunk command to check the trunking status of a specific interface without the need to scroll through multiple screens.

Switch# show interfaces fastethernet 4/1 trunk 
Port  Mode      Encapsulation Status       Native vlan 
Fa4/1 desirable n-isl         trunk-inbndl 1 (Po41)    
Port Vlans allowed on trunk 
Fa4/1 1-1005 
Port Vlans allowed and active in management domain 
Fa4/1 1-6,1002-1005 
Port Vlans in spanning tree forwarding state and not pruned 
Fa4/1 1-6,1002-1005

The show interfaces status command provides a one-line display for each interface with the status and trunking state.

Switch# show interfaces status

Port Name Status     Vlan   Duplex Speed Type 
Gi1/1	  connected  routed full    1000 1000BaseSX 
Gi1/2	  connected  1      full    1000 1000BaseSX 
Gi3/1	  notconnect routed full    1000 missing 
Gi3/2	  notconnect routed full    1000 missing 
Gi3/3	  notconnect routed full    1000 1000BaseSX 
Gi3/4	  notconnect routed full    1000 1000BaseSX 
Gi3/5	  notconnect routed full    1000 1000BaseSX 
Gi3/6	  notconnect routed full    1000 1000BaseSX 
Gi3/7	  notconnect routed full    1000 1000BaseSX 
Gi3/8	  notconnect routed full    1000 1000BaseSX 
Fa4/1	  connected  trunk  full     100 100BaseFX MM 
Fa4/2	  connected  trunk  full     100 100BaseFX MM 
Fa4/3	  connected  trunk  full     100 100BaseFX MM 
Fa4/4	  connected  trunk  full     100 100BaseFX MM 
Fa4/5	  notconnect 1	    full     100 100BaseFX MM 
Fa4/6	  notconnect 1	    full     100 100BaseFX MM 
Fa4/7	  notconnect 2	    full     100 100BaseFX MM 
Fa4/8	  notconnect 2	    full     100 100BaseFX MM 
Fa4/9	  notconnect 1	    full     100 100BaseFX MM 
Fa4/10	  notconnect routed full     100 100BaseFX MM 
Fa4/11	  notconnect 1	    full     100 100BaseFX MM

Configure EtherChannels in Cisco IOS Software

You configure EtherChannels in Cisco IOS Software much differently than in CatOS. To enable EtherChannel on a group of ports in Cisco IOS Software requires the use of a port channel interface. If all conditions are valid for the group of ports, they form a port channel. By default, all interfaces have port channeling disabled, even when an interface has a switch port configuration.

To configure a group of interfaces to be part of an EtherChannel, you must issue the command channel-group group-number mode channel-mode under each interface individually. If you remove the switchport command from the configuration, all the commands that relate to that switch port no longer show in the configuration. However, the reconfiguration of the port as a switch port returns all the previous commands. As a result, the configuration and the unconfiguration of a port as a switch port does not clear the port channel group information.

Once you have created a channel group, you must issue all of the configuration on the port channel interface and not on the individual physical ports. Any commands that you issue on the port channel propagate to all the physical ports transparently. Commands that you issue on the physical interface of a channel member can remove the interface from the channel group.

Function CatOS
To create the channel
CatOS (enable) set port channel 4/3-4 on
Port(s) 4/3-4 are assigned to admin group 613.
Port(s) 4/3-4 channel mode set to on.
CatOS (enable)
To set the channel mode
CatOS (enable) set port channel
mod/port mode {on | off | desirable |
auto} [silent | non-silent]
To show the port channel status
show port channel        
show port channel mod/port

show port channel channel-group

Function Cisco IOS Software
To create the channel
CiscoIOS# configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
CiscoIOS(config)# interface port-channel 1
CiscoIOS(config-if)# exit
CiscoIOS(config)# interface fastethernet 4/3
CiscoIOS(config-if)# channel-group 1 mode on
CiscoIOS(config-if)# interface fastethernet 4/4
CiscoIOS(config-if)# channel-group 1 mode on
CiscoIOS(config-if)#
To set the channel mode
CiscoIOS(config-if)# channel-group
channel-group_number mode {on | auto
[non-silent] | desirable [non-silent]}
To show the port channel status
show etherchannel 
show etherchannel channel-group

show interfaces etherchannel
show interfaces interface-type mod/port etherchannel

The show etherchannel command has various subcommands to display information about the configuration of the port channels.

The show etherchannel channel-group summary command gives the status of all the interfaces within the channel group configuration. This command is very useful to quickly find the interfaces that are supposed to belong to a channel group.

CiscoIOS# show etherchannel 256 summary 
Flags: U - in use I - in port-channel S - suspended 
D - down I - stand-alone d - default setting 
Group Port-channel Ports 
-----+------------+-----------------------------------------------------------    
256   Po256(U)	   Fa5/5(I) Fa5/6(I) Fa5/7(I) Fa5/8(I) 

The show interfaces etherchannel command displays every interface that associates with a channel group, regardless of the channel status.

CiscoIOS# show interfaces etherchannel 
---- 
GigabitEthernet1/1: 
Port state = EC-Enbld Up In-Bndl Usr-Config 
Channel group = 254 Mode = Automatic Gcchange = 0 
Port-channel = Po254 GC = 0x00FE0001 
Port indx = 0 Load = 0x55 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.    
A - Device is in Auto mode. P - Device learns on physical port. 
Timers: H - Hello timer is running. Q - Quit timer is running. 
S - Switching timer is running. I - Interface timer is running. 
Local information: 
Hello Partner PAgP    Learning Group 
Port  Flags   State   Timers   Interval Count Priority Method Ifindex 
Gi1/1 SAC     U6/S7   Q 	   30s	    1	  128      Any    56 
Partner's information:

Partner Partner Partner  Partner        Group 
Port	Name    Device   ID		        Port Age Flags Cap. 
Gi1/1   69055180(STELLA) 0010.7bbe.50bb 3/4  12s SC    2

You can use the show interfaces interface-type mod/port etherchannel command to check the channel status of a specific interface without the need to scroll through multiple screens.

CiscoIOS# show interfaces fastethernet 5/5 etherchannel 
Port state = EC-Enbld Up Cnt-bndl Sngl-port-Bndl Cnt-Bndl Not-in-Bndl Usr-Config    
Channel group = 256 Mode = Automatic Gcchange = 1 
Port-channel = null GC = 0x11000002 
Port indx = 0 Load = 0x00 

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.    
A - Device is in Auto mode. P - Device learns on physical port. 
Timers: H - Hello timer is running. Q - Quit timer is running. 
S - Switching timer is running. I - Interface timer is running. 

Local information: 
Hello Partner PAgP  Learning Group 
Port  Flags   State Timers   Interval Count Priority Method Ifindex 
Fa5/5 SAC     U6/S7 Q		 30s	  1     128      Any	0 

Partner's information:

Partner Partner	  Partner Partner        Group 
Port	Name	  Device  ID		     Port Age Flags Cap. 
Fa5/5   066549452(SINGHA) 00d0.bb3a.c0d9 4/17 29s SC	2 

Age of the port in the current state: 00h:30m:31s 
Probable reason: pm - different in oper mode (1) with Fa5/8(2)

The show interfaces port-channel channel-group etherchannel command displays the ports that are currently active members of the port channel.

CiscoIOS# show interfaces port-channel 256 etherchannel 
Age of the Port-channel = 05h:52m:49s 
Logical slot/port = 13/64 Number of ports = 2 
GC = 0x01000001 HotStandBy port = null 
Port state = Port-channel Ag-Inuse 
Ports in the Port-channel:

Index  Load   Port   EC state	 Configuration 
------+------+------+-----------+-------------- 
1	   55     Fa5/7  auto	     user 
0	   AA     Fa5/8  auto	     user 
Time since last port bundled: 00h:46m:51s Fa5/7 
Time since last port Un-bundled: 00h:46m:54s Fa5/8

Configure VLANs in Cisco IOS Software

The concept and functionality of VLANs are identical between Cisco IOS Software and CatOS. However, the configuration methods between the two implementations differ significantly. While set commands create VLANs in CatOS, the VLAN creation occurs via the VLAN database configuration mode in Cisco IOS Software.

Function CatOS
To create a VLAN
CatOS (enable) set vlan 2

Vlan 2 configuration successful
To delete a VLAN
CatOS (enable) clear vlan 2 
This command will deactivate all
ports on vlan 2
Do you want to continue(y/n) [n]?y
Vlan 2 deleted
To assign a port to the VLAN
CatOS (enable) set vlan 2 1/1
VLAN 2 modified.
VLAN 10 modified.
VLAN Mod/Ports
---- -----------------------
2    1/1
To see the VLAN status
show vlan

Function Cisco IOS Software
To create a VLAN
CiscoIOS# vlan database
CiscoIOS(vlan)# vlan 2 

VLAN 2 added:
Name: VLAN0002 

CiscoIOS(vlan)# exit 

APPLY completed.
Exiting....
To delete a VLAN
NativeIOS# vlan database
CiscoIOS(vlan)# no vlan 2

Deleting VLAN 2...

CiscoIOS(vlan)# exit

APPLY completed.
Exiting....
To assign a port to the VLAN
CiscoIOS# configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
CiscoIOS(config)# interface gigabitethernet2/2
CiscoIOS(config-if)# switchport
CiscoIOS(config-if)# switchport access vlan 2
CiscoIOS(config-if)# ^Z
CiscoIOS#
To see the VLAN status
show vlan

To check the status of the VLAN, use the show vlan command.

Router# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    VLAN0002                         active
10   VLAN0010                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Configure VTP in Cisco IOS Software

VTP is an L2 protocol that synchronizes VLAN databases in a VTP domain. At the addition, deletion, or modification of a VLAN within the same VTP domain, VTP synchronizes the VLAN database on all of the members within the same VTP domain. VTP pruning minimizes traffic on trunks through the reduction of unnecessary broadcast and multicast traffic for VLANs that do not need propagation.

In Cisco IOS Software, the VLAN database mode defines the VTP configuration. Changes to the VLAN database and VTP occur at the application of the VLAN data. This occurs when the user exits from the VLAN database configuration mode. The default Cisco IOS Software VTP configuration appears here:

Note: The default VTP mode is Server.

CiscoIOS# show vtp status    

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 6
VTP Operating Mode : Server
VTP Domain Name : null
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xE2 0x4F 0xC0 0xD6 0x94 0xBB 0x31 0x9A
Configuration last modified by 0.0.0.0 at 6-27-01 02:04:20
Local updater ID is 0.0.0.0 (no valid interface found)
Function CatOS
To configure VTP
CatOS (enable) set vtp domain cisco

VTP domain cisco modified
To change VTP mode
CatOS (enable) set vtp mode client

VTP domain cisco modified        

CatOS (enable) set vtp mode server  

VTP domain cisco modified        

CatOS (enable) set vtp mode transparent

VTP domain cisco modified
To enable VTP pruning
CatOS (enable) set vtp pruning enable

This command will enable the pruning
function in the entire management domain.

All devices in the management domain
should be pruning-capable before enabling.

Do you want to continue (y/n) [n]? y  

VTP domain cisco modified
To display the VTP configuration
CatOS (enable) show vtp domain

Function Cisco IOS Software
To configure VTP
CiscoIOS# vlan database
CiscoIOS(vlan)# vtp domain cisco

Changing VTP domain name from null to cisco

CiscoIOS(vlan)# exit        

APPLY completed.
Exiting....
To change VTP mode
CiscoIOS# vlan database
CiscoIOS(vlan)# vtp client        

Setting device to VTP CLIENT mode.        

CiscoIOS(vlan)# vtp server        

Setting device to VTP SERVER mode.        

CiscoIOS(vlan)# vtp transparent        

Setting device to VTP TRANSPARENT mode.

CiscoIOS(vlan)# exit        

APPLY completed.    
Exiting....
To enable VTP pruning
CiscoIOS# vlan database  
CiscoIOS(vlan)# vtp pruning

Pruning switched ON      

CiscoIOS(vlan)# exit    

APPLY completed.
To display the VTP configuration
CiscoIOS# show vtp status

CatOS/Cisco IOS Software Command Matrix

This table is a brief list of CatOS commands and the Cisco IOS Software equivalent of the commands. This table is useful for quick reference for migration to Cisco IOS Software from CatOS. The table is an abbreviated list of commands that have frequent use. The table does not list all the parameters for each command. Refer to the Catalyst 6500 Series Cisco IOS Command Reference, 12.2SX for complete command syntax and parameters.

Comments in this section provide assistance with specific commands. The comments appear in italics.

CatOS Command Cisco IOS Software Command
clear vlan vlan no vlan This command is a VLAN database command.
set cam agingtime mac-address-table aging-time This command sets MAC address aging time per VLAN.
set cam set cam {static | permanent} mac-address-table static All static entries are also permanent.
set errdisable-timeout interval errdisable recovery interval 30-86400 This command sets errdisable recovery time.
set mls mls Multilayer Switching (MLS) occurs transparently in Cisco IOS Software.
set option errport errdisable recovery cause This command configures errdisable options.
set port channel The default mode is auto. channel-group group mode The default mode is off.
set port duplex duplex The default behavior varies, which depends on the line card.
set port flowcontrol send [desired | off |on ] flowcontrol send [desired | off | on ]
set port flowcontrol receive [desired | off |on ] flowcontrol receive [desired | off | on ]
set port host switchport switchport mode access spanning-tree portfast The access ports automatically have channeling/trunking turned off.
set port negotiation mod/port disable speed nonegotiate Use this command on gigabit ports only. Use speed and duplex commands for 10/100 Mbps ports.
set port negotiation mod/port enable no speed nonegotiate Use this command on gigabit ports only. Use speed and duplex commands for 10/100 Mbps ports.
set port speed speed The default behavior varies, which depends on the line card.
set qos mls qos
set span monitor session
set spantree spanning-tree
set system crossbar-fallback service internal [no] fabric switching-mode allow [bus-only | truncated]
set test diaglevel diagnostic level This is the bootup diagnostic level.
set trace debug Use this command with caution. Some debugs are intrusive.
set trunk The default mode is auto. switchport mode trunk The default mode is desirable.
set udld udld You configure this command globally and per interface.
set vlan vlan switchport access vlan This command is a VLAN database command. The command is an interface command and does not create the VLAN.
set vtp vtp This command is a VLAN database command.
show boot show bootvar This command shows boot parameters.
show cam dynamic show mac-address-table dynamic
show channel info show port channel show etherchannel summary
show errordetection show errdisable detect
show errdisable-timeout show errdisable recovery
show port show mac show interface
show port status show interface status
show span show monitor
show sprom show idprom This command is useful to determine the chassis serial numbers.
show system crossbar-fallback show fabric switching-mode
show test [diaglevel | mod] show diagnostic [level | mod module]
show qos show mls qos
show traffic show catalyst6000 traffic-meter This command displays backplane utilization.
show trunk show port trunk show interfaces trunk
show udld show udld
show vlan show vlan
show vtp domain show vtp status
switch console remote login Use this command only with Cisco Technical Support for a specific troubleshoot.

Related Information

Updated: Jan 10, 2006
Document ID: 12155