Guest

Cisco Catalyst 2900 XL Series Switches

EtherChannel and 802.1Q Trunks Between Catalyst XL Switches and Catalyst Layer 2 Fixed Configuration Switches Configuration Example

Cisco - EtherChannel and 802.1Q Trunks Between Catalyst XL Switches and Catalyst Layer 2 Fixed Configuration Switches Configuration Example

Document ID: 21041

Updated: Nov 03, 2006

   Print

Introduction

This document provides sample configurations on IEEE 802.1Q trunking and EtherChannel between a Catalyst 3524XL and Catalyst 2950 switch. The results of each command are displayed as they are executed. Any of the Catalyst Layer 2 fixed configuration switches, which include the 2900XL/3500XL, 2940, 2950/2955 and 2970, can be used in the scenarios presented in this document to obtain the same results.

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

In this document, four Fast Ethernet ports from each of the switches have been set up as an 802.1Q trunk and bundled into a Fast EtherChannel (FEC).

Components Used

To create the examples in this document, we used the following switches in a lab environment with cleared configurations:

  • Catalyst 3524XL switch running Cisco IOS® Software Release 12.0(5.2)XU

  • Catalyst 2950 switch running Cisco IOS Software Release 12.1(6)EA2a

Background Theory

There are no requirements to use contiguous ports to form a FEC on these switches.

With a Catalyst 2900XL running Cisco IOS Software Releases 11.2(8)SA1 or 11.2(8)SA2, you are allowed four FECs (port groups) per switch with an unlimited number of ports per group. Load balancing across the links in the channel is always based on the destination MAC address. All ports that are members of the same portchannel must be configured identically. They need to carry the same set of VLANs, and all must have trunk or non-trunk as the operational trunk status. Switched Port Analyzer (SPAN) and port security features are not supported.

On a Catalyst 2900XL running Cisco IOS Software Release 11.2(8)SA3 or later, a Catalyst 3500XL running Cisco IOS Software Release 11.2(8)SA6 or later, and a Catalyst 2950/2955, load balancing across the links in the channel is configurable to be based on source or destination MAC address, with source being the default. Source-based forwarding allows up to eight ports in a FEC (port group). Destination-based forwarding allows unlimited ports per port group. You can configure up to 12 FEC port groups per switch, and can have a mix of source/destination-based groups. All ports that are members of the same portchannel must be configured identically. They need to carry the same set of VLANs, and all must have trunk or non-trunk as the operational trunk status. SPAN and port security are not supported.

Catalyst 2940 and 2950/2955 switches only support 802.1Q trunking and do not support Inter-Switch Link Protocol (ISL) trunking. Catalyst 2970 supports both 802.1Q and ISL trunking protocols.

Configure

Dynamic Trunk Protocol

There are methods for creating trunks. If a port can become a trunk, it may also have the ability to trunk automatically, and in some cases even negotiate what type of trunking to use on the port. This ability to negotiate the trunking method with the other device is called Dynamic Trunk Protocol (DTP).

Note: Catalyst 2900XL/3500XL switches do not support DTP. Catalyst 2950/2955 switches support DTP for dynamic trunking with Cisco IOS Software Release 12.1(6)EA2 or later. Catalyst 2940 and 2970 support DTP in all Cisco IOS Software releases.

Port Aggregation Protocol

Port Aggregation Protocol (PAgP) aids in the automatic creation of FECl links. PAgP packets are sent between FECl-capable ports in order to negotiate the forming of a channel. Some restrictions have been deliberately introduced into PAgP. The restrictions are as follows:

  • PAgP will not form a bundle on ports that are configured for dynamic VLANs. PAgP requires that all ports in the channel belong to the same VLAN or are configured as trunk ports. When a bundle already exists and a VLAN of a port is modified, all ports in the bundle are modified to match that VLAN.

  • PAgP does not group ports that operate at different speeds or port duplex. If speed and duplex are changed when a bundle exists, PAgP changes the port speed and duplex for all ports in the bundle.

  • PAgP modes are off, auto, desirable, and on. Only the combinations auto-desirable, desirable-desirable, and on-on will allow a channel to be formed.

    The PAgP modes are explained below.

    1. on: PAgP will not run. The channel is forced to come up.

    2. off: PAgP will not run. The channel is forced to remain down.

    3. auto: PAgP is running passively. The formation of a channel is desired; however, it is not initiated.

    4. desirable: PAgP is running actively. The formation of a channel is desired and initiated.

    Only the combinations of auto-desirable, desirable-desirable, and on-on will allow a channel to be formed. If a device on one side of the channel does not support PAgP, such as a router, the device on the other side must have PAgP set to on.

Note: Catalyst 2900XL/3500XL switches do not support PAgP. Catalyst 2950/2955 switches support PagP for channel negotiation with Cisco IOS Software Release 12.1(6)EA2 or later; Cisco IOS Software Release 12.0 supports only static configuration. Catalyst 2940 and 2970 support PAgP in all Cisco IOS Software releases.

Link Aggregate Control Protocol (LACP)

Link Aggregate Control Protocol (LACP) trunking supports four modes of operation:

  • On: The link aggregation is forced to be formed without any LACP negotiation .In other words, the switch neither sends the LACP packet nor processes any inbound LACP packet. This is similar to the on state for PAgP.

  • Off: The link aggregation is not formed. We do not send or understand the LACP packet. This is similar to the off state for PAgP.

  • Passive: The switch does not initiate the channel but does understand inbound LACP packets. The peer (in active state) initiates negotiation (when it sends out an LACP packet) which we receive and answer, eventually to form the aggregation channel with the peer. This is similar to the auto mode in PAgP.

  • Active: We can form an aggregate link and initiate the negotiation. The link aggregate is formed if the other end runs in LACP active or passive mode. This is similar to the desirable mode of PAgP.

Note: By default, when an LACP channel is configured, the LACP channel mode is passive.

Note: Catalyst 2900XL/3500XL switches do not support LACP. Catalyst 2950/2955 switches support LACP for channel negotiation with Cisco IOS Software Release 12.1(6)EA2 or later. Cisco IOS Software Release 12.0 supports only static configuration. Catalyst 2940 and 2970 support LACP in all Cisco IOS Software releases.

Network Diagram

This document uses the network setup shown in the diagram below.

131-a.gif

Configurations

This document uses the configurations shown below.

Catalyst 3524 XL
Comments between the outputs are added in 
blue
 italics for explanation.

Flush#show run
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Flush
!
!
ip subnet-zero
!


!--- Since the 2900XL/3500XL switches do not support 
!--- dynamic channel negotiation, verify the 
!--- configuration before enabling secondary links.
!--- You may see a loop before the configuration is finished if 
!--- both ports are connected while doing changes.
!--- Shut down the ports involved in the channel first. When the 
!--- configuration is complete, enable them back.

!--- An example of a brief loop is shown below.
!--- flush#
!--- 6d12h: %LINK-4-ERROR: FastEthernet0/1 is experiencing errors.
!--- 6d12h: %RTD-1-ADDR_FLAP: FastEthernet0/3 relearning five addresses per minute.
!--- 6d12h: %LINK-4-ERROR: FastEthernet0/1 is experiencing errors.
!--- 6d12h: %RTD-1-ADDR_FLAP: FastEthernet0/24 relearning eight addresses per minute.
!--- 6d12h: %LINK-4-ERROR: FastEthernet0/1 is experiencing errors.

!
!
interface FastEthernet0/1
port group 1

!--- Assigned port to port channel 1.

switchport trunk encapsulation dot1q

!--- Configured the port to use the trunking encapsulation dot1Q.

switchport mode trunk

!--- Configured port to be in trunking mode.

!
interface FastEthernet0/2
port group 1

!--- Assigned port to port channel 1.

switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
port group 1

!--- Assigned port to port channel 1.

switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
port group 1

!--- Assigned port to port channel 1.

switchport trunk encapsulation dot1q
switchport mode trunk
......(output Suppressed)
!
interface VLAN1
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login

Catalyst 2950
Comments between the outputs are added in 
blue
 italics for explanation.

Hanka>en
Hanka#show run
Building configuration...
Current configuration : 1298 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Hanka
!
!
ip subnet-zero
!
interface Port-channel1
flowcontrol send off
switchport mode trunk


!--- Since the 2900XL/3500XL series switches do not 
!--- support dynamic channel negotiation,
!--- verify the configuration before 
!--- enabling secondary links.
!--- You may see a loop before the configuration is 
!--- finished if both ports are connected while doing changes.
!--- We suggest shutting down the ports involved in the channel 
!--- first, and when the configuration is complete, 
!--- enabling them back.

!--- An example of a brief loop is shown below.
!--- flush#
!--- 6d12h: %LINK-4-ERROR: FastEthernet0/1 is experiencing errors.
!--- 6d12h: %RTD-1-ADDR_FLAP: FastEthernet0/3 relearning five addresses per minute.
!--- 6d12h: %LINK-4-ERROR: FastEthernet0/1 is experiencing errors.
!--- 6d12h: %RTD-1-ADDR_FLAP: FastEthernet0/24 relearning eight addresses per minute.
!--- 6d12h: %LINK-4-ERROR: FastEthernet0/1 is experiencing errors.


!
interface FastEthernet0/1
 switchport mode trunk  

!--- Configured port to be in trunking mode.

 channel-group 1 mode on    

!--- Assigned port to port channel 1.
!--- Catalyst 2950/2955 switches only support 802.1Q encapsulation, 
!--- which is configured automatically
!--- when trunking is enabled on the interface by 
!--- issuing the switchport mode trunk command.
!--- Note: The channel-group command is introduced in 
!--- Cisco IOS Software Release 12.1. Cisco IOS Software Release 12.0 has
!--- the port group command to configure channeling.



!
interface FastEthernet0/2
 switchport mode trunk
 channel-group 1 mode on   

!--- Assigned port to port channel 1.

!
interface FastEthernet0/3
 switchport mode trunk
 channel-group 1 mode on    

!--- Assigned port to port channel 1.

!
interface FastEthernet0/4
 switchport mode trunk 
 channel-group 1 mode on  

!--- Assigned port to port channel 1.
 
......(output Suppressed)
interface Vlan1
 ip address 1.1.1.1 255.255.255.0
 no ip route-cache
!
ip http server
!
line con 0
 transport input none
line vty 0 4
 login
line vty 5 15
 login    
!
end 

Verify

This section provides information you can use to confirm your configuration is working properly.

Catalyst 2900XL/3500XL

 show CDP neighbor 

Flush#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Hanka            Fas 0/4            173         S I       WS-C2950T-Fas 0/4
Hanka            Fas 0/3            173         S I       WS-C2950T-Fas 0/3
Hanka            Fas 0/2            173         S I       WS-C2950T-Fas 0/2
Hanka            Fas 0/1            173         S I       WS-C2950T-Fas 0/1
Flush#

 show port group

Flush>en
Flush#show port group
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
    1  FastEthernet0/1        source address
    1  FastEthernet0/2        source address
    1  FastEthernet0/3        source address
    1  FastEthernet0/4        source address

show spanning-tree 

Flush#show spanning-tree
Spanning tree 1 is executing the IEEE compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0001.4264.82c0
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set, changes 2
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15 
  Timers: hello 0, topology change 0, notification 0


Interface Fa0/1 (port 1) in Spanning tree 1 is FORWARDING
   Port path cost 8, Port priority 128
   Designated root has priority 32768, address 0001.4264.82c0
   Designated bridge has priority 32768, address 0001.4264.82c0
   Designated port is 1, path cost 0
   Timers: message age 0, forward delay 0, hold 0
   BPDU: sent 41527, received 231

Interface Fa0/5 (port 17) in Spanning tree 1 is down
   Port path cost 100, Port priority 128

Note: Interface Fa0/2 - Interface Fa0/4 are not displayed in the output as they are bundled with Fa0/1 in the port channel.

show interface x/x switchport 

Flush#show interface fast 0/1 switchport 
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Flush#show interface fast 0/2 switchport 
Name: Fa0/2
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Flush#

Catalyst 2950/2955

show CDP neighbor 

Hanka#show cdp neighbor
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Flush            Fas 0/4            127         T S       WS-C3524-XFas 0/4
Flush            Fas 0/3            127         T S       WS-C3524-XFas 0/3
Flush            Fas 0/2            127         T S       WS-C3524-XFas 0/2
Flush            Fas 0/1            127         T S       WS-C3524-XFas 0/1
Hanka#

show etherchannel 

Note: This command was first introduced in Cisco IOS Software Release 12.1(6)EA2. It replaced the show port group command.

Hanka#show etherchannel port-channel
                Channel-group listing: 
                -----------------------
Group: 1 
----------
                Port-channels in the group: 
                ----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 00d:23h:06m:07s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 


Ports in the Port-channel: 
Index   Load   Port    EC state
------+------+------+------------
  0     00     Fa0/1    on         
  0     00     Fa0/2    on         
  0     00     Fa0/3    on         
  0     00     Fa0/4    on         

Time since last port bundled:    00d:23h:05m:46s    Fa0/4

show spanning-tree 

Hanka#show spanning-tree
 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 8, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0001.4264.82c0
   Designated bridge has priority 32768, address 0001.4264.82c0
   Designated port id is 128.1, designated path cost 0
   Timers: message age 2, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 5, received 41627

show interfaces trunk

Note: This command was first introduced in Cisco IOS Software Release 12.1(6)EA2.

Hanka#show interfaces trunk

Port      Mode         Encapsulation  Status        Native vlan
Po1       on             802.1Q          trunking      1

Port      Vlans allowed on trunk
Po1       1-1005

Port      Vlans allowed and active in management domain
Po1       1-2,999

Port      Vlans in spanning tree forwarding state and not pruned
Po1       1-2,999
Hanka#

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 03, 2006
Document ID: 21041