Guest

Cisco 6400 Series Broadband Aggregators

Configure a Cisco 6400 ATM Interface With RBE and DHCP

Document ID: 7208

Updated: Feb 26, 2008

   Print

Introduction

This document provides a sample configuration for a Cisco 827 Digital Subscriber Line (DSL) Router connected to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM), that terminates on a Cisco 6400 Universal Access Concentrator (UAC).

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 827-4V customer premises equipment (CPE) with IOS® Software Release 12.1(1)XB.

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(1)DC1 (external DHCP server) or 12.2(2)B (IOS DHCP server).

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB.

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Background Information

The Cisco 827 is configured with RFC1483 Bridging and integrated routing and bridging (IRB). The Cisco 827 allows PCs on the Ethernet segment to obtain addresses from a DHCP server behind the 6400, or from the 6400 IOS DHCP server. In addition, the BVI address has also been configured to obtain an address and default route from the DHCP server. The Cisco 6400 asynchronous transfer mode (ATM) interface is configured with routed bridge encapsulation (RBE), and is configured to operate with either an external DHCP server or IOS DHCP server on the NRP.

For the Cisco 6400, the ATM RBE feature on the Cisco 6400 node route processor (NRP) routes IP over bridged RFC1483 Ethernet traffic from a stub-bridged LAN. Bridged IP packets received on an ATM interface configured in route-bridged mode are routed through the IP header. The interfaces take advantage of the characteristics of a stub LAN topology commonly used for DSL access, and offer increased performance and flexibility over IRB.

Also, host routes for DHCP clients are automatically added to the 6400 routing table as IP addresses are handed out. The host routes are removed from the routing table when the DHCP address is released.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in figures 1 and 2:

Figure 1 – Scenario 1

fig1_7208.gif

Figure 2 – Scenario 2

fig2_7208.gif

Configurations

This document uses these configurations:

  • Cisco 827

  • Cisco 6400 NRP

  • 6400 Debug (Using RBE with External DHCP Server)

  • 6400 Debug (Using RBE with IOS DHCP Server)

Cisco 827
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface Ethernet0 
 no ip address
 bridge-group 1

!--- Because the Ethernet0 is bridged to the WAN interface,
!--- PCs behind the ethernet0 can be setup as DHCP clients.
!--- They get their addresses from the DHCP server behind the 6400,
!--- or from the IOS DHCP server on the 6400.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address dhcp client-id Ethernet0

!--- This command tells the BVI interface to get the address
!--- from DHCP, and also to get the default route from DHCP.

! 
ip classless 

!--- Note: The default route will be inserted into
!--- the routing table automatically from the DHCP server, and
!--- no static routing statement is required.                         

no ip http server 
! 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end 

Cisco 6400 NRP
Current configuration: 
! 
version 12.1
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 198.1.1.1 255.255.255.0 
 no ip directed-broadcast

!--- This address and mask must match the intended
!--- scope and network configured on the external DHCP server.

! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--- The interface ATM0/0/0.4 point-to-point uses IP
!--- unnumbered Loopback1 for its IP address requirements.

 ip unnumbered Loopback1 
 ip helper-address <dhcp server ip address>
 atm route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 

!--- Note: For every DHCP client that is relayed an address,
!--- a host route will be automatically inserted in the routing 
!--- table, and no host route statement for a DHCP client is required.

end 

6400 Debug (Using RBE with External DHCP Server)
debug ip dhcp server events 

Looks for existing binding. . .

00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1
00:10:56:  find_or_create(): Creating new binding with data
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards DHCP DISCOVER packet from the client to the
!--- external DHCP server.

00:10:56: DHCPD: Received DHCPDISCOVER on UNNUM-IF
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP OFFER packet from the external DHCP server 
!--- to the client.

00:10:56: DHCPD: Unnum: Received DHCPOFFER
00:10:56:  DHCPD: Server Address = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1
00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards the DHCP REQUEST packet from the client to the external
!--- DHCP server.

00:10:56: DHCPD: Received DHCPREQUEST on UNNUM-IF
00:10:56:  DHCPD: request_on_unnumif ():Real Server = 200.200.200.2   
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP ACK packet from the DHCP server to the client.

00:10:56: DHCPD: Unnum: Received DHCPACK
00:10:56:  DHCPD: lease time = 86400

!--- Adds a dynamic host route to the client into the routing table.

00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56:  DHCPD: Adding new route to host 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_create_and_hash_route index = 126
00:10:56: DHCPD: dhcpd_add_route: lease = 86400 
00:10:56:  DHCPD: Server ID saved in Binding = 200.200.200.2
00:10:56:  DHCPD: Server ID saved in Route block = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1

6400 Debug (Using RBE with IOS DHCP Server)
debug ip dhcp server events 

Assigns an address to the client from the IOS DHCP server.

23:19:09: DHCPD: assigned IP address 124.124.124.3 to 
client 0063.6973.636f.2d30.3030.302e.3063.3036.2e32.3339.342d.4256.31.
23:19:10:  DHCPD: lease time = 86400

Adds a dynamic host route to the client into the routing table.

23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10:  DHCPD: Adding new route to host 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_create_and_hash_route index = 127
23:19:10: DHCPD: dhcpd_add_route: lease = 86400

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 7208