Guest

Cisco 1000 Series Routers

Configuring the Cisco 753 and Cisco 1004 to Dial in to a Cisco AS5200 Access Server

Document ID: 10348

Updated: Jan 29, 2008

   Print

Introduction

This document shows you how to configure the Cisco 753 and Cisco 1004 to dial in to the Cisco AS5200 access server in these sections:

A comprehensive configuration example is available at the end of each section.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

How to Configure the Cisco 753 to Dial in to the Cisco AS5200

The Cisco 753 configuration combined with the Cisco 753 default settings provides the system configuration for ISDN and analog connections from a remote client to the Cisco AS5200.

Enter this sample configuration on each router in the Cisco 753 network (enter your own addresses, host names, and passwords where appropriate).

This documents presents these IP and IPX configurations as separate network strategies in order to speed your system set up time and provide a clearer explanation of each protocol's inherent configuration differences. This section includes these network scenarios:

  • How to enable remote IP users to dial in to the Cisco AS5200 from the Cisco 753.

  • How to enable remote Internetwork Packet Exchange (IPX) users to dial in to the Cisco AS5200 from the Cisco 753.

This configuration assumes that you run PPP. If at any point, you need to re-enter or restart the system configuration, enter set defaults command at the prompt, plus this configuration, and remember to substitute your router name and correct IP addresses.

caution Caution: In order to avoid routing loops, do not perform any configuration in the internal profile unless you are bridging.

Enable Remote IP Users to Dial in to the Cisco AS5200 from the Cisco 753

For the simplest and most effective remote IP dialin scenario, configure each Cisco 753 router to be on the same network (or subnet) and network mask, but with different host addresses (see Figure 1).

Figure 1 references the IP addresses throughout the Cisco 753 configuration to help describe the relationships between the devices.

Figure 1 – Address Scheme for Routers Dialing in to the Cisco AS5200

54img_01.gif

On the Cisco AS5200 side of the ISDN network cloud, there is one dialer map created for each dialin routing device. This example network topology requires four dialer maps configured on the Cisco AS5200. The first dialer map entry on the Cisco AS5200 reads dialer map ip 172.16.254.49 name 753-A. The second dialer map entry reads dialer map ip 172.16.254.51 name 753-B, and so on. Each Cisco 753 shares the same profile name, which is AS5200, but different IP addresses exist for each profile. The Cisco 1004 does not support the profile system structure.

Configure the Cisco 753 router in an IP network. Complete the steps outlined in these sections:

System Level

Complete these steps in order to configure the Cisco 753 at the system level:

  1. Enter the host name for the router. Challenge Authentication Protocol (CHAP) also uses this host name for authentication between the router and the Cisco AS5200.

    >
    > set system 753-A
    753-A>

    Note: On the Cisco AS52001 side of the configuration, the dialer map ip and username password commands use this Cisco 7531 host name, which is 753-A.

  2. Set PPP and CHAP on the router for incoming and outgoing authentication.

    753-A> set encapsulation ppp
    753-A> set ppp authentication incoming chap
    753-A> set ppp authentication outgoing chap
  3. Specify the ISDN switch type that your phone company uses. Your options in the United States are NI1, 5ESS, and DMS 100. Other countries use more varied options.

    753-A> set switch 5ess
  4. Specify the transmit and receive password for the client, which is the Cisco 753-A in these examples. You must enter the password (for example, letmein) twice.

    753-A> set ppp secret client 
    753-A> Enter new Password: letmein
    753-A> Re-Type new Password: letmein

    Note: Enter the same password letmein in these three places for successful authentication:

    1. At the set ppp secret client command on the Cisco 753-A

    2. At the set ppp secret host command on the Cisco 753-A

    3. At the username password global configuration command on the Cisco AS5200 access server

    Note: This password is case sensitive on each device.

    Note: Proceed to the User Profile section.

User Profile

Complete these steps in order to configure the user profile:

  1. Enter the profile username of the device that authenticates with the Cisco 753-A router, for example the Cisco AS5200. This entry must match the host name of Cisco AS5200.

    753-A>
    753-A> set user AS5200
    753-A> New user AS5200 being created
  2. In the Cisco AS5200 profile, specify the transmit and receive password for the host, which is the Cisco AS5200. You must enter the password (for example, letmein) twice for verification.

    753-A:AS5200> set ppp secret host
    753-A:AS5200> Enter new Password: letmein
    753-A:AS5200> Re-Type new Password: letmein
  3. Turn off the bridging because you do not want to route packets to different kinds of networks.

    753-A:AS5200> set bridging off
  4. Turn on IP routing.

    753-A:AS5200> set ip routing on
  5. Set the IP address for the Cisco 753-A router, which is one address higher than the pool of addresses reserved for Cisco AS5200 modem connections.

    753-A:AS5200> set ip address 172.16.254.49

    The ip local pool default command configured on the Cisco AS5200 uses the range of IP addresses 172.16.254.1 to 172.16.254.48.

  6. Set the IP netmask address for the Cisco 753-A, which must match the netmask address set on the Cisco AS5200 access server.

    753-A:AS5200> set ip netmask 255.255.255.0
  7. Because you do not run a routing protocol to avoid up-time costs on the ISDN line, configure the IP traffic to route from the Cisco 753-A router to the Cisco AS5200 access server, which is the gateway.

    753-A:AS5200> set ip route destination 0.0.0.0/0 gateway 
    172.16.254.254

    Note: On the Cisco AS5200 side of the configuration, the ip route command configures this traffic route.

  8. Set IP framing for PPP encapsulation.

    753-A:AS5200> set ip framing none
  9. Configure the Cisco 753 to dial the same number twice to bring up two B channels.

    753-A:AS5200> set 1 number 2968388
    753-A:AS5200> set 2 number 2968388

    Proceed to the LAN Profile section.

LAN Profile

Complete these steps in order to configure the LAN profile. This procedure is similar to the configuration of an Ethernet interface:

  1. Assign its own subnet IP address to the extended Ethernet segment, which is connected to the Cisco 753-A.

    753-A:AS5200> cd lan
    753-A:LAN> set ip address 172.16.253.1
  2. Assign an IP netmask for the Ethernet segment.

    753-A:LAN> set ip netmask 255.255.255.0
  3. Turn off bridging.

    753-A:LAN> set bridging off
  4. Turn on IP routing.

    753-A:LAN> set ip routing on

    The Cisco 753 IP configuration is complete.

A Complete Cisco 753-A Startup Configuration

Addition of this configuration to the existing set of Cisco 753-A system defaults creates a complete startup configuration so that the Cisco 753-A can dial a Cisco AS5200.

set system name 753-A
set switch 5ess 
set encapsulation ppp 
set ppp authentication incoming chap 
set ppp authentication outgoing chap 
set ppp secret client 
set user AS5200
set ppp secret host 
set ip routing on
set ip framing none
set ip address 172.16.254.49
set ip netmask 255.255.255.0
set ip route destination 0.0.0.0/0 gateway 172.16.254.254 propagate off cost 1
set 1 number 2968388
set 2 number 2968388
cd lan
set bridging off
set ip routing on
set ip address 172.16.253.1
set ip netmask 255.255.255.0

Enable Remote IPX Users to Dial in to the Cisco AS5200 from the Cisco 753

For the simplest and most effective remote IPX dialin scenario, configure each Cisco 753 router to be on the same network, and each remote IPX client to be on a different network (see Figure 2). This example shows how to configure the Cisco 753-A router. Enter this configuration on each router in the Cisco 753 network (enter your own addresses, host names, and passwords where appropriate).

Figure 2 references the IPX numbers throughout the Cisco 753 configuration to help describe the relationships between devices.

Figure 2 - Address Scheme for an IPX Network

54img_02.gif

Complete the steps listed here in order to configure the Cisco 753-A router in an IPX network:

System Level

Enter these system commands:

Note: The previous System Level section in the Cisco 753 IP configuration example describes this process.

> set system 753-A
753-A> 
753-A> set switch 5ess
753-A> set encapsulation ppp
753-A> set ppp authentication incoming chap
753-A> set ppp authentication outgoing chap
753-A> set ppp secret client 
753-A> Enter new Password: letmein
753-A> Re-Type new Password: letmein

Proceed to the User Profile section.

User Profile

Complete these steps in order to configure the user profile:

  1. Enter these commands, a process that the previous User Profile section in the Cisco 753 IP configuration example describes.

    753-A> set user AS5200
    753-A> New user AS5200 being created
    753-A:AS5200> set ppp secret host
    753-A:AS5200> Enter new Password: letmein
    753-A:AS5200> Re-Type new Password: letmein
    753-A:AS5200> set ipx routing on
    753-A:AS5200> set bridging off
  2. Enter the IPX network number.

    753-A:AS5200> set ipx network 100A
  3. Set IPX framing to none in order to perform PPP encapsulation over the ISDN link on the Cisco 753-A.

    753-A:AS5200> set ipx framing none
  4. Turn off the IPX spoofing.

    753-A:AS5200> set ipx spoofing off
  5. Turn on periodic Routing Information Protocol (RIP) updates.

    753-A:AS5200> set ipx rip update off

    Proceed to the Enable Static IPX Mapping section.

Enable Static IPX Mapping

You can avoid periodic RIP updates that cause your ISDN line to hang up. Configure static mapping with an internal and external IPX file server address. Each device on your IPX network uses these file server numbers.

The external file server address is equivalent to IPX network 100A in the example in Figure 2.

The Novel IPX file server uses the internal address for internal processing. You can retrieve the internal and external passwords with the config command on the console of Novell file server1. An example of an internal network address is 111abc.0000.0000.0001. The first set of numbers, 111abc, change from server to server. Each server has a different internal address. The last three sets of numbers, 0000.0000.0001, never change, and are abbreviated as 01 by the Cisco 753-A system. Enter only the first set of numbers plus the 01 in the IPX internal file server command configured on the Cisco 753-A.

Complete these steps in order to configure your IPX file server address for connection services:

Note: Enter these commands in the Cisco AS5200 user profile on the Cisco 753-A router.

  1. Configure the internal file server1 IPX number:

    753-A:AS5200> set ipx service name SERVERA type 4 address 
    111abc:01:0451 hops 3
  2. Specify the path that a remote PC must transmit across to reach the internal IPX file server.

    753-A:AS5200> set ipx route destination 
    111abc gateway 100A:603ef16f74 hops 3

    This table describes the devices and connections that the set ipx route command establishes:

    Variable Description
    111abc Internal file server address.
    100A Network that the PC must pass through to reach the file server.
    603ef16f74 Cisco AS5200 access server1s Mac address.
    3 Number of devices the remote PC must travel or hop across to reach the internal file server.
    • The first hop is from the PC to the 753-A router.
    • The second hop is from the 753-A router to the Cisco AS5200.
    • The third hop is from the Cisco AS5200 to the internal IPX server.

  3. Specify the path that each remote PC must transmit across to reach the external file server address 101A network.

    753-A:AS5200> set ipx route destination 101A gateway 
    100A:603ef16f74 hops 2

    Proceed to the LAN Profile section.

LAN Profile

Complete these steps in order to configure the LAN profile for an IPX network:

  1. Enter these commands, a process described in the previous LAN Profile section in the Cisco 753 IP configuration example.

    753-A:AS5200> set user lan
    753-A:LAN> set bridging off
    753-A:LAN> set ipx routing on
  2. Send RIP updates periodically to the IPX LAN.

    753-A:LAN> set ipx rip update periodic
  3. Turn on the Ethernet interface IPX network 200A.

    753-A:LAN> set ipx network 200A
  4. Turn off the IPX spoofing.

    753-A:AS5200> set ipx spoofing off

    The Cisco 753 IPX configuration is complete.

IPX Comprehensive Configuration for the Cisco 753-A

Addition of this configuration to the existing set of Cisco 753-A system defaults creates a complete startup configuration for router:

set system 753-A
set switch 5ess
set encapsulation ppp
set ppp authentication incoming chap
set ppp authentication outgoing chap
set ppp secret client 
set user AS5200
set ppp secret host
set ipx routing on
set bridging off
set ipx network 100A
set ipx framing none
set ipx spoofing off
set ipx rip update periodic
set ipx service name SERVERA type 4 address 111abc:01:0451 hops 3
set ipx route destination 111abc gateway 100A:603ef16f74 hops 3
set ipx route destination 101A gateway 100A:603ef16f74 hops 2
cd lan
set bridging off
set ipx routing on
set ipx rip update periodic
set ipx network 200A
set ipx spoofing off

How to Configure the Cisco 1004 to Dial in to the Cisco AS5200

This section describes how to enable remote IP users to dial out from the Cisco 1004 router to the Cisco AS5200. Complete these steps:

Refer to the IP addresses in Figure 1 to gain a conceptual insight into the Cisco 1004 and Cisco AS5200 logical positions while you enter this configuration.

Set Global Configurations

Complete these steps in order to configure the basic global configurations required on the Cisco 1004, for example, a host name, username, password, and ISDN switch type:

  1. Assign a host name, password, and username to the Cisco 1004.

    1004# configure terminal
    1004(config)# hostname 1004
    1004(config)# enable password test
    1004(config)# username 1004 password cisco

    The username 1004 is the hostname of the remote router, and the dialer map command configured on the Cisco AS5200 uses this username. The username is case sensitive, and must match the remote router1 host name.

    The password, which the CHAP authentication process uses, is also case sensitive and must match the password of remote router1.

    Note: In order to avoid confusion, this sample configuration displays the unencrypted form of the password, cisco. In the actual configuration, the password appears in its encrypted form, 7 13061E010803, where 7 denotes the encryption type and 13061E010803 is the encrypted form of cisco. When you enter or make changes to the username command, always enter the password in the unencrypted form and do not enter the encryption type (7). The encryption type is set automatically.

  2. Configure the ISDN switch type, which must match the equipment of your carrier. If you change the switch type, you must reload the router before the new switch can take effect.

    1004(config)# isdn switch-type basic-dms100

    Proceed to the Configure the BRI and Ethernet Interfaces section.

Configure the BRI and Ethernet Interfaces

Complete these steps in order to configure the BRI interface and Ethernet interface to transmit and receive traffic with the Cisco AS5200:

  1. Bring up the BRI interface and assign an IP address.

    1004(config)# interface BRI 0
    1004(config-if)# ip address 172.16.254.50 255.255.255.0
  2. Enable PPP encapsulation over High-level Data Link Control (HDLC) for CHAP authentication.

    1004(config-if)# encapsulation ppp 
  3. Set a bandwidth of 56 kbps.

    1004(config-if)# bandwidth 56

    The default bandwidth setting for a BRI interface is 64 kbps. If you configured your dialer map statements with the speed of 56 kbps, you must include the bandwidth statement.

    This command does not control the speed of your ISDN line, but sets the correct reference point for:

    • The show interface statistics of the BRI port

    • The dialer load-threshold command

    • Routing metrics

  4. Specify the number of seconds the ISDN connection remains up while no traffic is sent from the BRI interface to the remote router.

    1004(config-if)# dialer idle-timeout 300
  5. Set up a dialer map statement for each ISDN phone number to be called. These statements are used with CHAP authentication to place the initial call to the remote router when traffic is forwarded to the BRI interface.

    1004(config-if)# dialer map ip 172.16.254.254 
    name AS5200 speed 56 broadcast 14155551234

    This table describes the dialer map statement options that this command sets:

    Variable Description
    172.16.254.254 IP address for the remote AS52001 PRI interface. In order to determine this address, enter show interface bri 0 command at the access server1s console prompt.
    name AS5200 Host name for the Cisco AS5200. The name is case sensitive and must match the name configured with the username command.
    speed 56 Sets the dialer speed to 56 kbps for ISDN circuits that are not 64 kbps end-to-end links. Include this setting in both the Cisco AS52001 and Cisco 10041 dialer map statements. Most installations in North America are configured for 56 kbps.
    broadcast Enables the forwarding of broadcast packets. Unless the dialer-list command specifies broadcast packets as interesting packets, these packets are only forwarded when the ISDN link is active.
    14155551234 Remote AS52001 ISDN telephone number.

  6. Queue the interesting packets until the ISDN connection is established. In this example, five interesting packets are in queue.

    1004(config-if)# dialer hold-queue 5
  7. Configure bandwidth on demand. Set the maximum load before the dialer places an additional call through the second B channel.

    1004(config-if)# dialer load-threshold 100

    The load is the calculated weighted average load value for the interface, where 1 is unloaded and 255 is fully loaded. The actual load value you configure depends on the characteristics of your particular network. In this example, the second B channel becomes active when the load reaches 39 percent of maximum utilization, which is 100 divided by 255.

  8. Enable the dialer-list 1 on the BRI interface, which determines which packets activate the ISDN connection.

    1004(config-if)# dialer-group 1
  9. If your carrier assigns spids to your ISDN lines, configure the isdn spid command.

    1004(config-if)# isdn spid1 408555432101 5554321
    1004(config-if)# isdn spid2 408555987601 5559876
  10. Enable CHAP authentication.

    1004(config-if)# ppp authentication chap
    1004(config-if)# exit
  11. Bring up the Ethernet interface and assign an IP address.

    1004(config)# interface Ethernet 0
    1004(config-if)# ip address 172.16.252.1 255.255.255.0

    Continue on to the Configure a Routing Protocol, Static Route, Dialer List, Various Lines, and Access Lists section.

Configure a Routing Protocol, Static Route, Dialer List, Various Lines, and Access Lists

Complete these steps in order to configure a Routing Protocol, Static Route, Dialer List, Various Lines, and Access Lists:

  1. Assign a routing protocol and appoint an IP address.

    1004(config)# router igrp 1
    1004(config-if)# network 172.16.0.0 
    1004(config-if)# exit
  2. Create a static route to the Cisco AS52001 network through the Cisco AS52001 BRI interface. A static route is necessary because dynamic routes get lost when the ISDN link goes down.

    1004(config)# ip route 172.16.255.0 255.255.255.0 
    172.16.254.254

    The Cisco AS52001 target IP Ethernet address is 172.16.255.0. The target network mask is 255.255.255.0. The address of the next hop that can be used to reach the target network is 172.16.254.254.

  3. Determine which IP packets are interesting. Create a dialer list that points to access list 100.

    1004(config)# dialer-list 1 list 100
  4. Identify which IP packets activate the ISDN link. The access-list you create depends on your particular network design.

    1004(config)# access-list 100 deny ip 0.0.0.0 
    255.255.255.255 255.255.255.255 0.0.0.0
    
    1004(config)# access-list 100 permit ip 0.0.0.0 
    255.255.255.255 0.0.0.0 255.255.255.255

    The first access-list command defines all broadcast packets as uninteresting.

    The second access-list command defines all other IP packets as interesting.

  5. Enter these line configuration commands in order to complete the Cisco 1004 configuration:

    1004(config)# line con 0
    1004(config-line)# line aux 0
    1004(config-line)# line vty 0 4
    1004(config-line)# password test
    1004(config-line)# login
  6. Write the new configuration to NVRAM.

    1004# copy running-config startup-config
    #########[OK]
    1004#

    The Cisco 1004 IP configuration is complete.

Comprehensive Configuration for the Cisco 1004

This section includes a complete startup configuration for the Cisco 1004.

version 10.2
!
hostname 1004
!
enable password test
!
username C4000 password cisco 
isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

Related Information

Updated: Jan 29, 2008
Document ID: 10348