Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 1700/2600/3600 ADSL WIC (Unnumbered Interface) With RFC1483 Routing Using AAL5SNAP Protocol IP

Cisco - Configuring a Cisco 1700/2600/3600 ADSL WIC (Unnumbered Interface) With RFC1483 Routing Using AAL5SNAP Protocol IP

Document ID: 12966

Updated: Feb 26, 2008

   Print

Introduction

The Cisco 1700, 2600, and 3600 Series Routers support the Asymmetric Digital Subscriber Line (ADSL) WAN Interface Card (WIC). All three platforms are configured the same, but there are differences in hardware and in the Cisco IOS® Software release required for each one. Throughout this document the Cisco 1700/2600/3600 are called the "Cisco ADSL WIC."

This sample configuration shows a Cisco ADSL WIC configured with AAL5SNAP routing and terminating on a Cisco 6400 Universal Access Concentrator (UAC). Both the Cisco ADSL WIC and the Cisco 6400 use an ip unnumbered interface. This type of interface is well-suited for situations in which the number of available IP subnets is restricted.

The asynchronous transfer mode (ATM) main interface does not support the ip unnumbered command; use ATM point-to-point subinterfaces.

The RFC1483 routing service connects subscribers to a Cisco 6400 using AAL5SNAP encapsulation to carry IP traffic over ATM. The Node Route Processor (NRP) routes the IP traffic as required.

Prerequisites

Requirements

There are no specific prerequisites for this document.

Components Used

The information in this document is based on these software and hardware versions.

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS Software Release 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(5)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Hardware Requirements

To support the ADSL WIC on the Cisco 2600/3600, this hardware is required:

Cisco 2600 series router:

  • Chassis WIC slots

  • NM-2W

Cisco 3600 series router:

  • NM-1FE1R2W

  • NM-1FE2W

  • NM-2FE2W

  • NM-2W

Note: For the Cisco 3600, these do not support the ADSL WIC:

  • NM-1E1R2W

  • NM-1E2W

  • NM-2E2W

Software Requirements

To support the ADSL WIC, these minimum Cisco IOS Software releases are required:

  • Cisco IOS Software Release 12.1(5)YB (Plus versions only) on the Cisco 2600/3600.

  • Cisco IOS Software Release IOS 12.1(3)XJ or later (Plus versions or ADSL feature set only) on the Cisco 1700. The ADSL feature set is identified by "y7" in the image name. For example, c1700-sy7-mz.121-3.XJ.bin.

    Note: When you download the image for the Cisco 1700, make sure you select the image name of 1700. Do not download a 1720 or a 1750 image. The features do not support the ADSL WIC.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram.

wicadsl_rfc_1.gif

Configurations

This document uses the configurations shown here.

Cisco ADSL WIC
Current configuration:
!
version 12.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1  
ip subnet-zero
! 
interface FastEthernet0
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
hold-queue 224 in
!
interface ATM0.1 point-to-point
ip unnumbered FastEthernet0
no ip directed-broadcast
pvc 3/100 
protocol ip 172.16.0.2
encapsulation aal5snap
! 
ip classless
ip route 172.16.0.2 255.255.255.255 ATM0.1
no ip http server
!
dialer-list 1 protocol ip permit
!

line con 0 
end

Cisco 6400-NRP
Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NRP
! 
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
! 
interface Loopback1
ip address 172.16.0.2 255.255.0.0
no ip directed-broadcast
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0/0.3 point-to-point
ip unnumbered Loopback1
no ip directed-broadcast
no ip mroute-cache
pvc 3/100 
protocol ip 10.0.0.1
encapsulation aal5snap
! 
interface Ethernet0/0/1
no ip address
no ip directed-broadcast
!
interface Ethernet0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0/0
no ip address
no ip directed-broadcast
half-duplex
!
ip classless 
ip route 10.0.0.1 255.255.255.255 ATM0/0/0.3
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12966