Guest

Asymmetric Digital Subscriber Line (ADSL)

Configuring a Cisco 1700/2600/3600 ADSL WIC to Support PPPoE Clients, Terminating on a Cisco 6400 UAC

Cisco - Configuring a Cisco 1700/2600/3600 ADSL WIC to Support PPPoE Clients, Terminating on a Cisco 6400 UAC

Introduction

The Cisco 1700, 2600, and 3600 series routers support the Asymmetric Digital Subscriber Line (ADSL) WAN Interface Card (WIC). All three platforms are configured essentially the same, but there are differences in hardware and in the Cisco IOS® Software release required for each one. Throughout this document, the Cisco 1700/2600/3600 is referred to as the Cisco ADSL WIC.

This sample configuration shows you how to support a Point-to-Point Protocol over Ethernet (PPPoE) client when it is connected to the Ethernet interface of a Cisco ADSL WIC.

The Cisco ADSL WIC is configured with RFC 1483 leavingcisco.com bridging and terminates on a Cisco 6400 Universal Access Concentrator (UAC) that has been configured to support PPPoE using a multipoint ATM subinterface.

The PPPoE feature allows you to initiate a PPP session on a simple bridging Ethernet connected client. The session is transported over the ATM link via encapsulated Ethernet-bridged frames. The session can be terminated at either a local exchange carrier central office or an Internet service provider (ISP) point of presence.

PPPoE is a client-initiated connection. On the Customer Premises Equipment (CPE) side, a PC with an Ethernet Network Interface Card (NIC) and the PPPoE client code are established. This PC and other PCs are connected to the ADSL WIC Ethernet segment.

The ADSL WIC ATM interface is connected to a Cisco 6130 DSL Access Multiplexer (DSLAM) and terminates on a Cisco 6400 UAC.

Prerequisits

Requirements

Before you attempt this configuration, please ensure that you use one of these prerequisite software releases:

  • Cisco 6400 UAC-NRP IOS Software Release 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS Software Release 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(5)DA

Components Used

The information in this document is based on these software and hardware versions.

To support the ADSL WIC on the Cisco 2600 or 3600, these hardware components are required:

  • 2600: Chassis WIC slots, NM-2W

  • 3600: NM-1FE1R2W, NM-1FE2W, NM-2FE2W, NM-2W

Note: For the Cisco 3600, ADSL is not supported on WIC NM-1E1R2W, NM-1E2W, or NM-2E2W.

These are the minimum Cisco IOS Software Releases required to support the ADSL WIC:

  • Cisco IOS Software Release 12.1(5)YB (Plus versions only) on the Cisco 2600 or 3600

  • Cisco IOS Software Release IOS 12.1(3)XJ or later (Plus versions or ADSL feature set only) on the Cisco 1700. The ADSL feature set is identified by "y7" in the image name; for example, c1700-sy7-mz.121-3.XJ.bin.

Note: When you download the image for the Cisco 1700, make sure you select the image name of 1700. Do not download a 1720 or a 1750 image; the features do not support the ADSL WIC.

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are in a live network, ensure that you understand the potential impact of any command before you use use it.

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

wicadsl_pppoe_1_12963a.gif

Configurations

This document uses the configurations shown below.

Note: In the Cisco 6400 NRP configuration, you set the Maximum Transmission Unit (MTU). For more information about changing the MTU size, refer to Troubleshooting MTU Size in PPPoE Dialin Connectivity.

Cisco ADSL WIC
Current configuration:
!
version 12.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
! 
ip subnet-zero
no ip routing
! 
interface FastEthernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 3/100 
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
! 
bridge 1 protocol ieee
!

line con 0
end

Cisco 6400 NRP
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname NRP1
! 
username username password password


!--- The username and password must match client username and password.

! 
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
ip cef
! 
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 101
pppoe limit per-vc 102
! 
interface ATM0/0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0/0.1 multipoint
 no ip directed-broadcast
pvc 3/100
encapsulation aal5snap
protocol pppoe
! 
interface Ethernet0/0/1
ip address 10.0.0.1  255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet0/0/0
no ip address
no ip directed-broadcast
half-duplex
!
interface Virtual-Template1

!--- Do not use a static IP assignment within


!--- a virtual template; routing problems can occur.

ip mtu 1492
ip unnumbered Ethernet0/0/1

!--- Always use the ip unnumbered command


!--- when configuring a virtual template.

no ip directed-broadcast
ip mroute-cache
peer default ip address pool pool name

ppp authentication chap
!
ip local pool pool name 10.0.0.2 10.0.0.12  
ip classless
no ip http server
! 
line con 0 
!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Feb 26, 2008
Document ID: 12963