Guest

EtherChannel

Configuring FEC and ISL/802.1q Trunking Between a CatOS Switch and External Router

Cisco - Configuring FEC and ISL/802.1q Trunking Between a CatOS Switch and External Router

Document ID: 23307

Updated: Sep 01, 2005

   Print

Introduction

This document provides sample configurations for Fast EtherChannel (FEC), Inter-Switch Link (ISL), and 802.1Q trunking between a Catalyst 6500 switch that runs CatalystOS (CatOS) and a Cisco 7500 router. The results of each command are displayed as they are executed. Although a Catalyst 6000 switch is used in this configuration, you could substitute a Catalyst 4000 or Catalyst 5000 family switch that runs CatOS.

Prerequisites

Requirements

Ensure that you meet these requirements before you attempt this configuration:

  • Catalyst 6000 Series Switches

    • CatOS Release 5.1(1) CSX or later is required to support EtherChannel

  • Cisco 7000 or 7500 Series Routers

    • Cisco 7000 series routers with 7000 series Route Switch Processor (RSP7000) or Chassis Interface (RSP7000CI), or Cisco 7500 series routers with Fast Ethernet Interface Processors (FEIP) or Versatile Interface Processor (VIP2) port adapters

    • If you are using the PA-2FEISL port adapter, you must have hardware revision 1.2 or later.

      Refer to Field Notice: *Expired* FN - 8791_11301999 - PA-2FEISL 2-Port Fast Ethernet ISL Replacement Recommendation for more information.

    • The encapsulation dot1Q native command was introduced in Cisco IOS® Software Release 12.1(3) T. This command changes the configuration.

      See the Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T section of this document for more information.

    • Cisco Express Forwarding is enabled by default on Cisco 7500 series routers. However, Cisco Express Forwarding support for IP routing between IEEE 802.1Q VLANs was not available until Cisco IOS Software Release 12.2 and 12.2T. It is still possible to configure 802.1Q encapsulation in previous releases, but you must first issue the global no ip cef command to disable Cisco Express Forwarding.

    • When a 7500 series router is configured for Multiprotocol Label Switching (MPLS) and FEC, support is currently unavailable for routing (MPLS IP) packets that flow from the MPLS interface to the FEC interface. Therefore, it is not recommended that an MPLS and an FEC configuration coexist on a single router.

    • Cisco IOS Software Release 11.1(14)CA or later is required to support EtherChannel.

      Cisco IOS Software Release 11.3(1)T (any plus feature set) or later is required to support ISL trunking.

      Cisco IOS Software Release 12.0(1)T (any plus feature set) or later is required to support IEEE 802.1Q trunking.

Components Used

The information in this document is based on these software and hardware versions:

  • Catalyst 6500 running CatOS version 5.5.14

  • Cisco 7500 running Cisco IOS Software Release 12.2.7b

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Important Notes

  • Keep in mind that Catalyst 4000 series switches do not support ISL trunking. In addition, some switching modules on Catalyst 5000 series switches are not EtherChannel capable. Issue the show port capabilities module command to determine whether a particular module is EtherChannel capable and what trunking encapsulation it supports.

  • There are certain guidelines for the configuration of EtherChannel and trunking. Always refer to the software documentation of your switch.

    For example, if you were running software release 5.5.x on a Catalyst 5000, you would refer to the Software Configuration Guide (5.5) and carefully examine any configuration guidelines and restrictions in the Configuring Fast EtherChannel and Gigabit EtherChannel section.

EtherChannel

The FEC or Gigabit EtherChannel (GEC) feature allows multiple point-to-point links to be bundled into one logical link. The Catalyst 6000 supports a maximum of eight ports in full-duplex mode, which offers 1600 Mbps or 1.6 Gbps throughput for FEC and 16 Gbps for GEC. The Cisco 7500 series supports a maximum of four ports per FEC, for 800 Mbps. EtherChannel capability and performance is different, depending on the switch or router. Refer to System Requirements to Implement EtherChannel on Catalyst Switches for more information.

EtherChannel distributes traffic across all of the links and provides redundancy if one or more links fail. Refer to Understanding EtherChannel Load Balancing and Redundancy on Catalyst Switches for more information and sample configurations related to EtherChannel.

Refer to the EtherChannel page of Cisco Technical Support & Documentation for more information.

Trunking

Trunking is a way to carry traffic from multiple VLANs over a point-to-point link or an EtherChannel bundle between two devices. These are two ways in which Ethernet trunking can be implemented:

  • ISL (Cisco proprietary trunk encapsulation)

  • 802.1Q (IEEE standard trunk encapsulation)

Refer to the VLAN Trunking Protocols page of Cisco Technical Support & Documentation for more information.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

These sample configurations show you how to do these things:

  • Configure two access ports for Workstation 1 in VLAN 1 and for Workstation 2 in VLAN 2 on the Catalyst 6500.

  • Configure the default gateway for Workstation 1 to be 10.10.10.1 /24 and for Workstation 2 to be 10.10.11.1/24 on the Cisco 7500.

  • Configure ISL and 802.1Q trunks over a two-port FEC between a Catalyst 6500 switch and the Cisco 7500 router.

  • Configure two port-channel subinterfaces with IP addresses for InterVLAN routing.

Network Diagram

This document uses this network setup:

Trunking VLAN 1 and VLAN 2 Over 2-Port FEC

141.gif

Configurations

This document uses these configurations:

Catalyst 6500 Switch

!--- Set the IP address and default gateway for VLAN 1 for management purposes.

Catalyst6500> (enable) set interface sc0 10.10.10.2 255.255.255.0

Interface sc0 IP address and netmask set.

Catalyst6500> (enable) set ip route default 10.10.10.1

Route added.

!--- Set the VTP mode. In this example, the mode is set to be transparent. Depending on your
!--- network, set the VTP mode accordingly.
!--- For details on VTP, refer to Understanding and Configuring VLAN Trunk Protocol (VTP).

Catalyst6500> (enable) set vtp mode transparent

VTP domain modified

!--- Add VLAN 2. VLAN 1 already exists by default.

Catalyst6500> (enable) set vlan 2

VLAN 2 configuration successful

!--- Add port 3/4 to VLAN 2. Port 3/3 is already in VLAN 1 by default.

Catalyst6500> (enable) set vlan 2 3/4

VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     3/4

!--- Set the port speed to 100 and duplex to full. One of the requirements for EtherChannel
!--- to work is for speed and duplex to be the same on both sides. To guarantee this, hard
!--- code both speed and duplex on ports 3/1 and 3/2.

Catalyst6500> (enable) set port speed 3/1-2 100

Ports 3/1-2 transmission speed set to 100Mbps.

Catalyst6500> (enable) set port duplex 3/1-2 full

Ports 3/1-2 set to full-duplex.

!--- Enable FEC on ports 3/1 and 3/2. Because routers do not understand Port Aggregation
!--- Protocol (PAgP), set the channel mode to one which causes ports to channel but which
!--- does not generate PAgP frames.

Catalyst6500> (enable) set port channel 3/1-2 on

Port(s) 3/1-2 are assigned to admin group 105.
Port(s) 3/1-2 channel mode set to on.

!--- Enable trunking on ports 3/1 and 3/2. Because routers do not understand Dynamic
!--- Trunking Protocol (DTP), set the trunking mode to nonegotiate, which causes ports to
!--- trunk but which does not generate DTP frames.
!--- Note: Because EtherChannel is configured first, any trunk settings that are applied
!--- now to one port automatically apply to all other ports in the channel.
!--- Enter the trunking encapsulation as either ISL…

Catalyst6500> (enable) set trunk 3/1 nonegotiate isl

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to isl.

!--- …or as dot1q.
!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

Catalyst6500> (enable) set trunk 3/1 nonegotiate dot1q

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to dot1q.

Catalyst6500> (enable) show config

This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
.........
..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu May 2 2002, 01:26:26
!
#version 5.5(14)
!
!
#system
set system name  Catalyst6500
!
#!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active
mode srb aremaxhop 7 stemaxhop 7
backupcrf off
!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

set ip route 0.0.0.0/0.0.0.0 10.10.10.1
!
#set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat6000-sup.5-5-14.bin
!
#port channel
set port channel 3/1-2 105
!
# default port status is enable
!
!
#module 1 empty
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 2    3/4
set port disable    3/5

set port speed      3/1-2  100
set port duplex     3/1-2  full
set trunk 3/1  nonegotiate isl 1-1005
set trunk 3/2  nonegotiate isl 1-1005

!--- If IEEE 802.1Q is configured, you will see this output instead:
set trunk 3/1  nonegotiate dot1q 1-1005
set trunk 3/2  nonegotiate dot1q 1-1005


set port channel 3/1-2 mode on
!
#module 4 : 24-port 100BaseFX MM Ethernet
!
#module 5 empty
!
#module 6 empty
!
#module 15 empty
!
#module 16 empty
end

Cisco 7500 Router

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- If you are using ISL trunking, configure two port-channel sub-interfaces and issue the
!--- encapsulation isl <VLAN> command to enable ISL trunking.
!--- Configure IP addresses for InterVLAN routing.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation isl 1

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation isl 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- If you are using 802.1Q trunking, issue the encapsulation dot1Q <vlan> native
!--- command to configure two port-channel sub-interfaces and enable 802.1Q trunking.
!--- Configure the IP addresses for InterVLAN routing.

!--- Note: The encapsulation dot1Q 1 native command was added in Cisco IOS Software
!--- Release 12.1(3)T. If you are using an earlier version of Cisco IOS, see the
!--- Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T
!--- section of this document, to configure 802.1Q trunking on the router.




!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation dot1Q 1 native

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command, to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: To make this setup work and to successfully ping between Workstation 1 and
!--- Workstation 2, you must ensure that the default gateways on the workstations are setup
!--- properly. For Workstation 1, the default gateway should be 10.10.10.1; and for 
!--- Workstation 2, the default gateway should be 10.10.11.1.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname 7500
!
boot system disk1:rsp-jsv-mz.122-7b.bin
!
ip subnet-zero
!
ip cef
call rsvp-sync
!
!
!
interface Port-channel1
 no ip address
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0

!--- If 802.1Q trunking is configured, you will see this output instead:
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0


!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T
In Cisco IOS versions earlier than 12.1(3)T, the encapsulation dot1Q 1 native command under the subinterface was not available. However, it is still necessary to match the native VLAN across the link as described previously. To configure 802.1Q trunking in software versions earlier than 12.1(3)T, configure the IP address for VLAN 1 on the main port-channel 1 interface, not a port-channel subinterface.

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- Do not configure an interface port-channel 1.1
!--- Instead, create a port-channel 1 main interface and configure the IP address
!--- for VLAN 1 here.

7500(config)# interface port-channel 1

7500(config-if)# full-duplex

7500(config-if)# ip address 10.10.10.1 255.255.255.0

7500(config-if)# exit

7500(config)#

!--- It is still necessary to create a subinterface for VLAN 2.

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: Remember also that—in any version of software previous to 12.2 or 12.2T for the
!--- 7000/7500 series—you will have to issue the no ip cef command globally before you
!--- configure 802.1Q trunking on a subinterface. Otherwise, you will see this error
!--- message: 802.1q encapsulation not supported with CEF configured on the interface.
!--- See the Components Used section of this document for more information.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7500
!
!
ip subnet-zero
!
no ip cef
!
!
!
interface Port-channel1
ip address 10.10.10.1 255.255.255.0
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

7500#

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

Catalyst 6500 show Commands

  • show interface—Shows the sc0 management interface IP address and VLAN. In this example, the default VLAN is used (VLAN 1).

    Catalyst6500> (enable) show interface
    
    sl0: flags=51<UP,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            VLAN 1 inet 10.10.10.2 netmask 255.255.255.0 broadcast 10.10.10.255
    Catalyst6500> (enable)
  • show ip route—Shows the default gateway. In this example, 10.10.10.1 is the IP address of port-channel 1 (for 802.1Q trunking) or of port-channel 1.1 (for ISL trunking).

    Catalyst6500> (enable) show ip route
    
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled
    
    The primary gateway: 10.10.10.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.10.10.1       0x0          UG      0           sc0
    10.10.10.0       10.10.10.2       0xffffff00   U       8           sc0
    default          default          0xff000000   UH      0           sl0
    Catalyst6500> (enable)
  • show port capabilities mod/port —Gives a quick look at the hardware capabilities of switching modules. In this example, you can see that port 3/1 (and 3/2) is EtherChannel capable, which trunking encapsulations it supports, and other information.

    Catalyst6500> (enable) show port capabilities 3/1
    
    Model                    WS-X6248-RJ-45
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  yes
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(1q4t),tx-(2q2t)
    CoS rewrite              yes
    ToS rewrite              DSCP
    UDLD                     yes
    Inline power             no
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
    COPS port group          not supported
    Catalyst6500> (enable)
  • show port counters mod/port —Gives a quick look at possible port errors. In this example, this port is free of any errors. If you do experience errors on the port, refer to Troubleshooting Switch Port and Interface Problems for more information.

    Catalyst6500> (enable) show port counters 3/1
    
    Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
    ----- ---------- ---------- ---------- ---------- ---------
     3/1           0          0          0          0         0
    
    Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
    ----- ---------- ---------- ---------- ---------- --------- --------- ---------
     3/1           0          0          0          0         0         0         -
    
    Last-Time-Cleared
    --------------------------
    Thu May 2 2002, 02:11:55
    Catalyst6500> (enable)
  • show port mod —Shows port status, VLAN, trunk, and speed and duplex information. In this example, the access port for Workstation 1 is 3/3, which is in VLAN 1. The access port for for Workstation 2 is 3/4, which is VLAN 2. Ports 3/1 and 3/2 are the trunking and FEC ports.

    Catalyst6500> (enable) show port 3
    
    Port  Name                 Status     VLAN       Duplex Speed Type
    ----- -------------------- ---------- ---------- ------ ----- ------------
     3/1                       connected  trunk        full   100 10/100BaseTX
     3/2                       connected  trunk        full   100 10/100BaseTX
     3/3                       connected  1          a-half  a-10 10/100BaseTX
     3/4                       connected  2          a-full a-100 10/100BaseTX
    
    !--- Output suppressed.
    
    
  • show vlan—Shows which ports are assigned to specific VLANs. Notice that trunk ports in this example (3/1 and 3/2) do not show up in this output, which is normal.

    Catalyst6500> (enable) show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    119     2/1-2
                                                            3/3,3/5-48
                                                            4/1-24
    2    VLAN0002                         active    124     3/4
    
    !--- Output suppressed.
    
    
  • show trunk—Shows the trunking mode, encapsulation type, allowed VLANs, and active VLANs. In this example, VLAN 1 (always allowed and active by default) and VLAN 2 are the currently active VLANs for the trunk. Notice that both trunk ports are in VLAN 1.

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
     3/2      nonegotiate  isl            trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2

    For 802.1Q trunking, the output of the previous command changes to this:

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native VLAN
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
     3/2      nonegotiate  dot1q          trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    Catalyst6500> (enable)
  • show port channel—Shows the EtherChannel status. In this example, there is a 2-port FEC (ports 3/1 and 3/2) which is on, to prevent PAgP frames from being transmitted. You can also see the remote port-channel interface of the 7500 router.

    Catalyst6500> (enable)  show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1  connected  on                     105   833
     3/2  connected  on                     105   833
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
    3/1  7500                            Port-channel1.1           cisco RSP4
    3/2  
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

    For a FEC with 802.1Q trunking, the output of the previous command changes to this:

    Catalyst6500> (enable) show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1   connected  on                    257   769
     3/2   connected  on                    257   769
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
     3/1       7500                            FastEthernet5/1/0         cisco RSP4
     3/2       7500                            FastEthernet5/1/1         cisco RSP4
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

If you have the output of a show-tech support command from your Cisco device, you can use Output Interpreter Tool (registered customers only) to display potential issues and fixes.

Cisco 7500 Router show Commands

  • show interface port-channel channel number —Gives the member status for physical interfaces. In this example, a 2-port FEC is configured between ports 3/1 and 3/2 on the Catalyst 6000 and between interface FastEthernet 5/1/0 and 5/1/1 on the 7500. Port-channel 1 shows as up/up.

    It has an IP address configured, which in this case means that it is the native VLAN IP address for 802.1Q trunking. See the Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T section of this document for more information. Output is also shown for the VLAN 2 802.1Q subinterface, from the show interface port channel 1.2 command.

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:14, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         6720 packets input, 923310 bytes, 0 no buffer
         Received 5010 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         1902 packets output, 573088 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1q Virtual LAN, Vlan ID  2.
      ARP type: ARPA, ARP Timeout 04:00:00

    This is the output for ISL trunking and FEC:

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2 
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:01, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         113 packets input, 7278 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
      13 packets output, 2264 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    
    7500# show interface port-channel 1.1
    
    Port-channel1.1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
  • show interfaces fastethernet slot/port-adapter/port —Shows the status of the physical interfaces of the router and whether any errors exist on the interfaces. In this example, it is error free.

    7500# show interface fastethernet 5/1/0
    
    FastEthernet5/1/0 is up, line protocol is up
      Hardware is cyBus FastEthernet Interface, address is 0001.6490.f8a8
      (bia 0001.6490.f8a8)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 1d00h, output 00:00:07, output hang never
      Last clearing of "show interface" counters 1d00h
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         2929 packets input, 425318 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         12006 packets output, 1539768 bytes, 0 underruns
         0 output errors, 0 collisions, 6 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Sep 01, 2005
Document ID: 23307