Guest

EtherChannel

Configuring EtherChannel Between Catalyst Switches Running Cisco IOS System Software and a Cisco Router

Cisco - Configuring EtherChannel Between Catalyst Switches Running Cisco IOS System Software and a Cisco Router

Document ID: 21066

Updated: Dec 15, 2005

   Print

Introduction

This sample configuration demonstrates how to set up a Layer 3 (L3) EtherChannel, without VLAN trunking, between a Cisco router and a Cisco Catalyst 6500 switch running Cisco IOS® System Software. EtherChannel can be called Fast EtherChannel (FEC) or Gigabit EtherChannel (GEC); the term depends on the speed of the interfaces or ports you use to form the EtherChannel. In this example, two Fast Ethernet ports from a Cisco router and a Catalyst 6500 switch have been bundled into a FEC. Throughout this document, the terms FEC, GEC, port channel, channel, and port group all refer to EtherChannel.

This document includes only the configuration files from the switch and router, and the output from the related sample show commands.

Prerequisites

Requirements

Before you attempt this configuration, ensure that you meet these requirements:

  • Catalyst 6500/6000 and 4500/4000 series switches running Cisco IOS Software:

    • Catalyst 6500/6000 and 4500/4000 series switches running Cisco IOS Software support both Layer 2 (L2) and L3 EtherChannel, with up to eight compatibly configured Ethernet interfaces on any module. All interfaces in each EtherChannel must be the same speed. All must be configured as either L2 or L3 interfaces.

    • EtherChannel load balancing can use either MAC addresses, IP addresses, or the TCP port numbers.

      Note: The selected mode applies to all EtherChannels configured on the switch.

    • Catalyst 6500/6000 Cisco IOS Software Release 12.1E or later and Catalyst 4500/4000 Cisco IOS Software Release 12.1(8a)EW or later.

  • Cisco routers:

    • IP traffic distributes over the port channel interface while traffic from other routing protocols sends over a single link. Bridged traffic distributes on the basis of the L3 information in the packet. If the L3 information does not exist in the packet, the traffic sends over the first link.

  • A wide variety of Cisco routers support EtherChannel. To find a platform or version of code that supports EtherChannel on a Cisco router, use the Cisco Feature Navigator II (registered customers only) . A list of routers and Cisco IOS Software releases that support EtherChannel is found under the FEC feature.

For hardware and software requirements for EtherChannel on other Cisco products, refer to System Requirements to Implement EtherChannel on Catalyst Switches.

Components Used

The information in this document is based on these software and hardware versions:

  • Catalyst 6500 switch running Cisco IOS Software Release 12.1(8b)E10

  • Cisco 7500 router running Cisco IOS Software Release 12.1(21)

The switch configuration in this document applies to any Catalyst 6500/6000 and any Catalyst 4500/4000 series switch running Cisco IOS Software.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Note: Use of the write erase command cleared the configurations on all devices to ensure that they had a default configuration. Make sure to reload the devices after you issue the write erase command to flush all the nondefault configurations.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Important Notes

If you initially issue the channel-group command under the physical interface, it automatically creates the port-channel interface. If you configured the port-channel interface before you channeled physical interfaces, remove the port-channel interface first. This is only relevant on Catalyst switches. The order of configuration changes on the 7500 router. You must configure the port-channel interface before you configure the channel group under the physical interface.

The order of configuration of a port channel in Catalyst 6500/6000 and 4500/4000 Cisco IOS Software is important. It is best to issue any switchport command before you issue the channel-group command in a physical interface.

When you issue the channel-group command prior to the switchport command on a physical interface (interface Gigabit Ethernet 1/1), the port-channel interface is created automatically and becomes a L3 interface. If you then issue the switchport command under the physical interface, the physical interface becomes a L2 interface. Also, the port-channel interface that you created earlier has no physical interface associated with it. Notice that the channel-group command is absent from under the physical interface. In this case, you must first issue the switchport command under the newly configured port-channel interface. Then, the physical port accepts the channel-group command again. In this case, the port channel has changed from a L3 interface to a L2 interface.

Consider, in contrast, if you issue the switchport command first on a physical interface and then add the channel-group command. In this case, the port-channel interface is automatically created and inherits all the configured switchport commands.

On a Catalyst 6500/6000 switch running Cisco IOS Software, all ports are L3 ports by default. On a Catalyst 4500/4000 switch running Cisco IOS Software, all ports are L2 ports by default.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

135-a.gif

Configurations

This document uses these configurations:

Note: Comments and explanations appear in blue italics.

Catalyst 6500 Switch (Without VLAN Trunking)
Building configuration...
 
Current configuration : 5869 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
enable password ww
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!

!--- In this example, you configure L3 EtherChannel.
!--- For more details, refer to this document:
!--- Configuring EtherChannels.
!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.


interface Port-channel 1
 ip address 11.1.1.2 255.255.255.0
 duplex full
 speed 100

!--- If you specify the speed and duplex setting at the port channel 
!--- level, these settings pass down to the physical ports.
!--- In other words, the physical ports inherit the same speed 
!--- and duplex settings as the port-channel interface.

 hold-queue 300 in
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!
interface FastEthernet3/1
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (Port Aggregation Protocol [PAgP]), so PAgP
!--- needs to be disabled. On a Catalyst 4500/4000 switch, all ports are
!--- L2 ports by default. Convert this port from a physical L2 port to
!--- a physical L3 port with the no switchport command.

channel-group 1 mode on

interface FastEthernet3/2
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (PAgP), so PAgP needs to be disabled.
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default. 
!--- Convert this port from a physical L2 port to a physical L3 port 
!--- with the no switchport command.


channel-group 1 mode on


interface FastEthernet3/3
 no ip address
 switchport
 switchport mode access
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line vty 0 4
!
end

Cisco 7500 Router (Without VLAN Trunking)

!--- Output suppressed.

!
interface Port-channel1
 ip address 11.1.1.1 255.255.255.0
 full-duplex
 hold-queue 300 in
!
interface FastEthernet0/0
 no ip address
 full-duplex
 speed 100
 channel-group 1
!
interface FastEthernet0/1
 no ip address   
 full-duplex
 speed 100                              
 channel-group 1

!--- Output suppressed.

Verify

This section provides information you can use to confirm your configuration is working properly.

show Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show etherchannel channel-id port-channel —To check port channel in a Cisco IOS switch.

  • show interfaces port-channel channel-id —To check port channel in a Cisco IOS router.

Sample show Command Output

Catalyst 6500/6000 Switch

  • show etherchannel channel-id port-channel

Router#show etherchannel 1 port-channel
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 01h:56m:20s

Logical slot/port = 10/1 Number of ports in agport = 2
GC = 0x00010001 HotStandBy port = null
Passive port list = Fa3/1 Fa3/2
Port state = Port-channel L3-Ag Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
0 55 Fa3/1
1 AA Fa3/2
Time since last port bundled: 01h:55m:44s Fa3/2
Router#

Cisco 7500 Router

  • show interfaces port-channel channel-id

Router#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
Internet address is 11.1.1.1/24
MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
ARP type: ARPA, ARP Timeout 04:00:00
No. of members in this fechannel: 2
Member 0 : FastEthernet0/0
Member 1 : FastEthernet0/1
Last input never, output never, output hang never
Last clearing of "show interface" counters 10:51:55
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/300, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 98281000 bits/sec, 8762 packets/sec
4545 packets input, 539950 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast
0 input packets with dribble condition detected
342251216 packets output, 3093422680 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Dec 15, 2005
Document ID: 21066