Guest

IP Tunneling

Configuring BSTUN Point-to-Point with Local Acknowledgement over Frame Relay

Cisco - Configuring BSTUN Point-to-Point with Local Acknowledgement over Frame Relay

Document ID: 12347

Updated: Nov 01, 2005

   Print

Introduction

The Bisync Serial Tunnel (BSTUN) feature enables support for devices that use the Bisync datalink protocol. This protocol enables enterprises to transport Bisync traffic over the same network that supports their Systems Network Architecture (SNA) and multiprotocol traffic, which eliminates the need for separate Bisync facilities. With Frame Relay, you can use the local acknowledgment feature to provide local termination of the session on the BSTUN peer.

In this example, BSTUN Point-to-Point is configured with Local Ackowledgement over Frame Relay. The relevant states in the show bstun command output are highlighted in the this document.

Note: Although the debug bstun packet/event and debug bsc packet/event commands should not cause excessive CPU utilisation, the logging buffered command is used to copy the output to the log file.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco IOS® Software Release 12.1(5).

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

bstun_p2p_localack_over_fr-01.gif

Configurations

This document uses these configurations:

Kilcot
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname kilcot
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Party
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname party
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Verify

This section provides information you can use to confirm your configuration works properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show bstun

  • show bsc

kilcot#show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

kilcot#show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

party#show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
party#show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

The debug bstun packet/event and debug bsc packet/event output has been copied to the log file. When you interpret this debug output:

  • Serial Data Incoming (SDI)—Packets received from the Synchronous Data Link Control (SDLC) interface.

  • Network Data Incoming (NDI)—Packets de-encapsulated from the WAN.

Note: Before you issue debug commands, refer to Important Information on Debug Commands.

kilcot#show log
Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 5088 messages logged
    Trap logging: level informational, 70 message lines logged
          
Log Buffer (100000 bytes):

Dec 28 09:43:21.748: BSC: Serial1/0: POLLEE-FSM event:  E_LineUp old_state: CU_Down.  new_state: CU_Idle.
Dec 28 09:43:21.756: BSC: Serial1/0: SDI-rx: Data (5 bytes):   40407F7F2D
Dec 28 09:43:36.756: BSTUN bsc-local-ack: Serial1/0 SDI:   Data:   401100
Dec 28 09:43:36.756: BSTUN: Change state for peer  (all[72])200.2.2.2/1976 (closed->opening)
Dec 28 09:43:36.756: BSC: Serial1/0: POLLEE-FSM  event: E_RxEnq 
Dec 28 09:43:36.760: BSTUN: Change state for peer   (all[72])200.2.2.2/1976 (opening->open wait)
Dec 28 09:43:36.764: %BSTUN-6-OPENING: CONN:  opening peer (all[72])200.2.2.2/1976, 3
Dec 28 09:43:36.792: bsttcpd_connect:  Refreshing tcp_encaps for group 72
Dec 28 09:43:36.792: %BSTUN-6-OPENED: CONN:  peer (all[72])200.2.2.2/1976 opened, [previous state open wait]
Dec 28 09:43:36.792: BSTUN: Change state for  peer (all[72])200.2.2.2/1976 (open wait->open)
Dec 28 09:43:36.844: BSTUN bsc-local-ack:  Serial1/0 NDI: Data:   401400
Dec 28 09:43:36.848: BSC: Serial1/0: NDI-rx:  Data (3 bytes):  401400
Dec 28 09:43:37.640: %SYS-5-CONFIG_I:  Configured from console by vty0

party#show log
Syslog logging: enabled (0 messages 
   dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 114 messages logged
        Logging to: vty2(114)
    Buffer logging: level debugging, 5199 messages logged
    Trap logging: level informational, 79 message lines logged
          
Log Buffer (100000 bytes):

ec 28 09:48:09.816: %BSTUN-6-PASSIVEOPEN:   passive open 100.1.1.1(11017) -> 1976
Dec 28 09:48:09.836: %BSTUN-6-OPENED: PHDR:  peer (all[72])100.1.1.1/1976 opened, [previous state closed]
Dec 28 09:48:09.836: BSTUN: Change state for  peer (all[72])100.1.1.1/1976 (closed->open)
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 NDI: Data:   401100
Dec 28 09:48:09.836: BSC: Serial0: NDI-rx:  Data (3 bytes):  401100
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 SDI: Data:   401400
Dec 28 09:48:09.836: BSC: Serial0: SDI-tx:  Data (10 bytes):  37FF32323240407F7F2D

Related Information

Updated: Nov 01, 2005
Document ID: 12347