Guest

IP Tunneling

Configuring BSTUN Point-to-Point

Document ID: 12346

Updated: Oct 08, 2006

   Print

Introduction

The Bisync Serial Tunnel (BSTUN) feature enables support for devices that use the Bisync datalink protocol. This protocol enables enterprises to transport Bisync traffic over the same network that supports their Systems Network Architecture (SNA) and multiprotocol traffic, which eliminates the need for separate Bisync facilities. With Frame Relay, you can use the local acknowledgment feature to provide local termination of the session on the BSTUN peer.

In this example, a BSTUN Point-to-Point is configured with Local Acknowledgement over Frame Relay. The relevant states in the show bstun command output have been highlighted in this document.

Note: Although the debug bstun packet/event and debug bsc packet/event commands should not cause excessive CPU utilization, the logging buffered command is used to copy the output to the log file.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco IOS® Software Release 12.1(5).

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

bstun_p2p.gif

Configurations

This document uses these configurations:

Blutch
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname Blutch 
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Newbury
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname Newbury 
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

  • show bstun

  • show bsc

Blutch #show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

Blutch #show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

Newbury #show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Newbury #show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Note: Refer to Important Information on Debug Commands before you use debug commands.

  • debug bstun packet/event

  • debug bsc packet/event

Note: When you interpret this debug command output:

  • SDI (Serial Data Incoming)—Packets received from the Synchronous Data Link Control (SDLC) interface/

  • NDI: (Network Data Incoming)—Packets de-encapsulated from the WAN.

blutch#debug bstun event
BSTUN event debugging is on

blutch#debug bstun packet
BSTUN packet debugging is on

blutch#
Aug 26 11:29:04.534: BSTUN bsc: Serial0 SDI: Data: 40520040407F7F2D
Aug 26 11:29:04.570: BSTUN bsc: Serial0 NDI: Data: 40D20037
Aug 26 11:29:04.734: BSTUN bsc: Serial0 SDI: Data: 40530040407F7F2D
Aug 26 11:29:04.770: BSTUN bsc: Serial0 NDI: Data: 40D30037
Aug 26 11:29:04.934: BSTUN bsc: Serial0 SDI: Data: 40540040407F7F2D
Aug 26 11:29:04.970: BSTUN bsc: Serial0 NDI: Data: 40D40037
Aug 26 11:29:05.134: BSTUN bsc: Serial0 SDI: Data: 40550040407F7F2D
Aug 26 11:29:05.170: BSTUN bsc: Serial0 NDI: Data: 40D50037
Aug 26 11:29:05.334: BSTUN bsc: Serial0 SDI: Data: 40560040407F7F2D
Aug 26 11:29:05.370: BSTUN bsc: Serial0 NDI: Data: 40D60037
Aug 26 11:29:05.534: BSTUN bsc: Serial0 SDI: Data: 40570040407F7F2D
Aug 26 11:29:05.570: BSTUN bsc: Serial0 NDI: Data: 40D70037
Aug 26 11:29:05.734: BSTUN bsc: Serial0 SDI: Data: 40580040407F7F2D
Aug 26 11:29:05.770: BSTUN bsc: Serial0 NDI: Data: 40D80037
Aug 26 11:29:05.934: BSTUN bsc: Serial0 SDI: Data: 40590040407F7F2D
Aug 26 11:29:05.970: BSTUN bsc: Serial0 NDI: Data: 40D90037
Aug 26 11:29:06.134: BSTUN bsc: Serial0 SDI: Data: 405A0040407F7F2D
Aug 26 11:29:06.170: BSTUN bsc: Serial0 NDI: Data: 40DA0037
Aug 26 11:29:06.334: BSTUN bsc: Serial0 SDI: Data: 405B0040407F7F2D
Aug 26 11:29:06.370: BSTUN bsc: Serial0 NDI: Data: 40DB0037


newbury#debug bstun event
BSTUN event debugging is on

newbury#debug bstun packet
BSTUN packet debugging is on

newbury#
Aug 26 11:26:24.968: BSTUN bsc: Serial0 NDI: Data: 40780040407F7F2D
Aug 26 11:26:24.992: BSTUN bsc: Serial0 SDI: Data: 40F80037
Aug 26 11:26:25.148: BSTUN bsc: Serial0 NDI: Data: 40790040407F7F2D
Aug 26 11:26:25.172: BSTUN bsc: Serial0 SDI: Data: 40F90037
Aug 26 11:26:25.348: BSTUN bsc: Serial0 NDI: Data: 407A0040407F7F2D
Aug 26 11:26:25.372: BSTUN bsc: Serial0 SDI: Data: 40FA0037
Aug 26 11:26:25.548: BSTUN bsc: Serial0 NDI: Data: 407B0040407F7F2D
Aug 26 11:26:25.572: BSTUN bsc: Serial0 SDI: Data: 40FB0037
Aug 26 11:26:25.748: BSTUN bsc: Serial0 NDI: Data: 407C0040407F7F2D
Aug 26 11:26:25.772: BSTUN bsc: Serial0 SDI: Data: 40FC0037
Aug 26 11:26:25.948: BSTUN bsc: Serial0 NDI: Data: 407D0040407F7F2D
Aug 26 11:26:25.972: BSTUN bsc: Serial0 SDI: Data: 40FD0037
Aug 26 11:26:26.148: BSTUN bsc: Serial0 NDI: Data: 407E0040407F7F2D
Aug 26 11:26:26.172: BSTUN bsc: Serial0 SDI: Data: 40FE0037
Aug 26 11:26:26.348: BSTUN bsc: Serial0 NDI: Data: 407F0040407F7F2D
Aug 26 11:26:26.372: BSTUN bsc: Serial0 SDI: Data: 40FF0037
Aug 26 11:26:26.548: BSTUN bsc: Serial0 NDI: Data: 40400040407F7F2D
Aug 26 11:26:26.572: BSTUN bsc: Serial0 SDI: Data: 40C00037
Aug 26 11:26:26.748: BSTUN bsc: Serial0 NDI: Data: 40410040407F7F2D
Aug 26 11:26:26.772: BSTUN bsc: Serial0 SDI: Data: 40C10037

Related Information

Updated: Oct 08, 2006
Document ID: 12346