Guest

IP Tunneling

STUN Direct Encapsulation Configuration Example

Document ID: 12277

Updated: Sep 09, 2005

   Print

Introduction

This document provides a sample configuration for serial tunnel (STUN) direct encapsulation. The relevant states in the show stun command output and state changes in debug command output are shown in the Verify and Troubleshoot sections of this document.

Although the debug stun packet and debug stun event commands should not cause excessive CPU utilization, the logging buffered command is used to copy the output to the log file.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on Cisco IOS® Software Release 12.0(8) with IBM Features for STUN configuration.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

19_a.gif

Configurations

This document uses these configurations:

Cloclo
cloclo# show run

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cloclo
!
boot system flash rsp-jsv-mz.120-8
logging buffered 64000 debugging
no logging console
enable password cisco
!
microcode CIP flash slot0:cip27-3
microcode reload
ip subnet-zero
no ip domain-lookup
ip cef
!
!
stun peer-name 10.10.10.10
stun protocol-group 2 sdlc
!
!
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation stun
 no ip mroute-cache
 clockrate 9600
 stun group 2
 stun route address 1 interface Serial0/1
!
interface Serial0/1
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!

!--- Output suppressed.

!
interface Ethernet1/0
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!

!--- Output suppressed.

!
router eigrp 100
 network 10.0.0.0
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end
cloclo#

Fairbanks
fairbanks# show run

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname fairbanks
!
boot system flash
 logging buffered 64000 debugging
no logging console
enable password cisco
!
ip subnet-zero
!
!
stun peer-name 10.20.20.20
stun protocol-group 2 sdlc
!
!
!
!
interface Loopback0
 ip address 10.20.20.20 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Ethernet1
 ip address 172.17.240.12 255.255.255.0
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation stun
 no ip mroute-cache
 clockrate 9600
 stun group 2
 stun route address 1 interface Serial2
!

!--- Output suppressed.

!
interface Serial2
 ip address 10.2.1.2 255.255.255.0
 no ip directed-broadcast
 clockrate 19200
!

!--- Output suppressed.

!
router eigrp 100
 network 10.0.0.0
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end
fairbanks#

Verify

This section provides information that you can use to confirm that your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

The show stun command output for both routers is shown in this section. It shows that the STUN state of each router is open. Also, the counters for received packets (rx_pkts) and for transmitted packets (tx_pkts) increment each time that you issue the show stun command.

cloclo# show stun

This peer: 10.10.10.10
  *Serial0/0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial0/1        open             4510      4513         0
fairbanks# show stun

This peer: 10.20.20.20
  *Serial0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial2          open             2260      2257         0

fairbanks# show stun

This peer: 10.20.20.20
  *Serial0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial2          open             2270      2267         0

Troubleshoot

This section provides information that you can use to troubleshoot your configuration.

Troubleshooting Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before issuing debug commands, refer to Important Information on Debug Commands.

  • debug stun packet —Displays information about packets traveling through the STUN links.

  • debug stun event—Displays STUN connections and activity.

Debug Captures During STUN Activation

cloclo# show log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 232 messages logged
    Trap logging: level informational, 43 message lines logged

Log Buffer (64000 bytes):

!--- These timestamped lines each appear on one line in normal output:

*Nov  3 11:35:06.191: %LINK-3-UPDOWN:
  Interface Serial0/1, changed state to up
*Nov  3 11:35:07.191: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial0/1, changed state to up
*Nov  3 11:35:31.819: %LINK-3-UPDOWN:
  Interface Serial0/0, changed state to up
*Nov  3 11:35:32.819: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial0/0, changed state to up
*Nov  3 11:35:36.631: STUN sdlc:
  00:04:12 Serial0/0       SDI: (001/008) U: SNRM    PF:1  
*Nov  3 11:35:37.831: STUN sdlc:
  00:00:01 Serial0/0       SDI: (001/008) U: SNRM    PF:1  
*Nov  3 11:35:37.859: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) U: UA      PF:1  
*Nov  3 11:35:37.879: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:37.907: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.031: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.059: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.091: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) I:         PF:0  NR:000  NS:000
*Nov  3 11:35:38.231: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.295: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) I:         PF:1  NR:001  NS:000
*Nov  3 11:35:38.431: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.459: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.555: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) I:         PF:0  NR:001  NS:001
*Nov  3 11:35:38.631: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.691: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) I:         PF:1  NR:002  NS:001
*Nov  3 11:35:38.831: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:38.859: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.031: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.059: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.231: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.259: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.431: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.563: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  

cloclo#
fairbanks# show log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 203 messages logged
    Trap logging: level informational, 40 message lines logged

Log Buffer (64000 bytes):

!--- These timestamped lines each appear on one line in normal output:

*Nov  3 09:38:12.759: %SYS-5-CONFIG_I:
  Configured from console by console
*Nov  3 09:38:14.231: %LINK-3-UPDOWN:
  Interface Serial2, changed state to up
*Nov  3 09:38:15.231: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial2, changed state to up
*Nov  3 09:38:44.687: STUN sdlc:
  00:04:41 Serial0         NDI: (001/008) U: SNRM    PF:1  
*Nov  3 09:38:45.887: STUN sdlc:
  00:00:01 Serial0         NDI: (001/008) U: SNRM    PF:1  @
*Nov  3 09:38:45.899: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) U: UA      PF:1  
*Nov  3 09:38:45.935: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:45.947: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.087: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.099: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.155: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) I:         PF:0  NR:000  NS:000
*Nov  3 09:38:46.287: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.323: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) I:         PF:1  NR:001  NS:000
*Nov  3 09:38:46.487: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.499: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.615: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) I:         PF:0  NR:001  NS:001
*Nov  3 09:38:46.687: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.719: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) I:         PF:1  NR:002  NS:001
*Nov  3 09:38:46.887: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:46.899: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.087: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.099: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.287: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.299: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
 
fairbanks#

Related Information

Updated: Sep 09, 2005
Document ID: 12277