Guest

IP Routing

OSPF Not So Stubby Area Type 7 to Type 5 Link-State Advertisement Conversion

Cisco - OSPF Not So Stubby Area Type 7 to Type 5 Link-State Advertisement Conversion

Document ID: 47867

Updated: Aug 10, 2005

   Print

Introduction

This document shows how Open Shortest Path First (OSPF) converts a Not So Stubby Area (NSSA) type 7 link-state advertisement (LSA) to a type 5 LSA.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in this diagram.

ospfdb8a.gif

Configurations

This document uses the configurations shown here.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
  
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1
 area 1 nssa
 
ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa

end

Router 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show ip ospf database —Displays a list of the LSAs and types them into a link state database. This list shows only the information in the LSA header.

  • show ip ospf database nssa-external—Displays information only about the NSSA external LSAs.

  • show ip ospf database external—Displays information only about the external LSAs.

  • show ip ospf database [router] [link-state-id]—Displays a list of all of a router's LSAs in the database. LSAs are produced by every router, and these fundamental LSAs list all of the routers' links, or interfaces, along with the states and outgoing costs of the links. They are flooded only within the area in which they originate.

  • show ip ospf database summary <link-state id> —Displays the area border router (ABR) summary links.

  • show ip route —Displays the current status of the routing table.

Examine the OSPF Database

To see how the OSPF database looks given this network environment, use the show ip ospf database command.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router    Age    Seq#           Checksum     Link count 
2.2.2.2    2.2.2.2      1235   0x8000001D     0xD9FF           2 
3.3.3.3    3.3.3.3      1100   0x8000000B     0x9455           2 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum 
4.0.0.0    2.2.2.2     1979   0x80000002    0xFDE7 
5.0.0.0    2.2.2.2     1483   0x80000004    0x8864 

                Router Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Link count 
1.1.1.1    1.1.1.1     319    0x8000000C    0xAFA8           3 
2.2.2.2    2.2.2.2     220    0x8000002F    0xD478           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age    Seq#           Checksum 
6.0.0.0    2.2.2.2     1483   0x8000001C     0x7894 

                Type-7 AS External Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    1.1.1.1     334    0x80000005    0xD738        0 

                Type-5 AS External Link States 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    2.2.2.2     1725   0x80000004    0x50C6        0 

To advertise external routes into an NSSA, the autonomous system boundary router (ASBR) creates nssa-external LSAs (type 7).

r2.2.2.2#show ip ospf database nssa-external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 381 
  Options: (No TOS-capability, Type 7/5 translation, DC)

!--- This can be translated into a type 5 LSA by 
!--- an ABR. 

  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number ) 

!--- The ASBR (Router 1.1.1.1) advertises 
!--- 9.0.0.0/8. 

  Advertising Router: 1.1.1.1

!--- Router ID of the ASBR.
 
  LS Seq Number: 80000005 
  Checksum: 0xD738 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1

!--- Forwarding address is incorrectly specified
!--- as an interface on the ASBR.
 

The ABR converts type 7 LSAs into type 5 LSAs, and propagates the type 5 LSAs into normal areas.

r2.2.2.2#show ip ospf database external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States 

  LS age: 1782 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number )

!--- Router 2.2.2.2 advertises 9.0.0.0/8.
 
  Advertising Router: 2.2.2.2 

!--- When the conversion is complete, the advertising 
!--- router ID becomes the ABR router ID 
!--- because the ABR originates this type 5 LSA. 

  LS Seq Number: 80000004 
  Checksum: 0x50C6 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1 
        External Route Tag: 0 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 426 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same 
!--- as the advertising router (next line). 

  Advertising Router: 1.1.1.1
  LS Seq Number: 8000000C 
  Checksum: 0xAFA8 
  Length: 60 
  AS Boundary Router

!--- Bit E in the router LSA indicates that this router
!--- originates from external LSAs.
 
   Number of Links: 3

!--- There are three links in area 1. 


    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

!--- The OSPF cost of the Ethernet segment.
 

    Link connected to: another Router (point-to-point) 

!--- Shows that Router 1.1.1.1 is a neighbor with 
	!--- Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1

!--- The interface address that connects to Router
!--- 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the link that connects 
!--- the two routers.

    Link connected to: a Stub Network 

!--- This represents the serial link 5.0.0.0/8.
 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the serial link.

You can see from the bold output here that although Router 2.2.2.2 does not have any redistribute statements in its configuration, it is still an ASBR because it converts type 7 LSAs into type 5 LSAs.

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1361 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001D 
  Checksum: 0xD9FF 
  Length: 48 
  Area Border Router 
  
!--- Bit B is set in the router LSA to indicate
!--- that this router is an ABR.
 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this router 
!--- originates from external LSAs.

   Number of Links: 2 
  
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1

                Router Link States (Area 1) 

  LS age: 346 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000002F 
  Checksum: 0xD478 
  Length: 48 
  Area Border Router 
  AS Boundary Router 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1245 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000B 
  Checksum: 0x9455 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

To advertise routes from one area into another, the ABR creates summary LSAs (type 3).

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 172 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 4.0.0.0/8 into area 0.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0xFBE8 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 5.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 1687 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 5.0.0.0/8 into area 0. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000004 
  Checksum: 0x8864 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 1697 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 6.0.0.0/8 into area 1.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001C 
  Checksum: 0x7894 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

The ASBR summary LSAs are not needed in this case because the ABR originates the external LSA, and the ABR is reachable within area 0. Compare this example with a scenario where the NSSA was a normal area by looking at the database example How OSPF Propagates External Routes into Multiple Areas.

This routing table output shows the different types of OSPF routes that 9.0.0.0 is known as by each router.

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 01:10:13, Serial0/1/0 
O N1 9.0.0.0/8 [110/79] via 5.0.0.1, 01:07:20, Serial0/1/0 

R3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 02:11:14, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 03:10:41, ATM2/0.20 
O E1 9.0.0.0/8 [110/80] via 6.0.0.2, 02:08:11, ATM2/0.20 

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 10, 2005
Document ID: 47867