Guest

IP Routing

OSPF Routers Connected by a Point-to-Multipoint Link

Cisco - OSPF Routers Connected by a Point-to-Multipoint Link

Document ID: 47862

Updated: Aug 10, 2005

   Print

Introduction

This document shows two Open Shortest Path First (OSPF) routers connected by a point-to-multipoint link.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

ospfdb3a.gif

Configurations

This document uses these configurations:

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 ip ospf network point-to-multipoint
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Verify

This section provides information you can use to confirm your configuration is working properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

  • show ip ospf database—Displays a list of the Link State Advertisements (LSAs) and types them into a link state database. This list shows only the information in the LSA header.

  • show ip ospf database [router] [link-state-id]—Displays a list of all of a router's LSAs in the database. LSAs are produced by every router. These fundamental LSAs list all of the routers' links or interfaces, along with the states and outgoing costs of the links. They are flooded only within the area in which they originate.

Examine the OSPF Database

In order to see how the OSPF database looks given this network environment, look at the output of the show ip ospf database command.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
1.1.1.1  1.1.1.1       206    0x8000000A     0x158C       3 
2.2.2.2  2.2.2.2       206    0x8000000B     0x791        3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 224 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same 
  !--- as the Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.

  LS Seq Number: 8000000A 
  Checksum: 0x158C 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
   
 !--- This line shows that this router(1.1.1.1) is a 
	   !--- neighbor with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1 
     
!--- This line shows the interface on this router 
	    !--- (1.1.1.1) that connects the neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64  
       
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network 
    
!--- This router's (1.1.1.1) interface on the 
    !--- point-to-multipoint network. 

     (Link ID) Network/subnet number: 5.0.0.1 
     (Link Data) Network Mask: 255.255.255.255
     
!--- Notice the mask. Only the interface is advertised,
     !--- not the whole subnet. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 0
      
 !--- The OSPF cost for this router to reach its 
       !--- own interface is zero. 


    Link connected to: a Stub Network
	
!--- Represents the subnet of the Ethernet segment 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
	   
!--- The cost of the link is 10.


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 253 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0x791 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.2 
     (Link Data) Network Mask: 255.255.255.255 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 0 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

Calculate the Shortest Path

This section calculates the shortest path tree from the perspective of Router 2.2.2.2.

Router 2.2.2.2 looks in its own LSA and sees that Router 1.1.1.1 is a neighbor. Router 2.2.2.2 looks at 1.1.1.1's router LSA to verify that 1.1.1.1 sees 2.2.2.2 as a neighbor. If both routers see each other as neighbors, then they are considered reachable.

Each router also checks its local neighbor table (you can check it using the show ip ospf neighbor command) to verify that its interface and the neighbor's interface are on a common IP subnet. If they are, the routers install routes for any stub networks listed in their neighbor's router LSA.

In this example, Router 2.2.2.2 installs a route for 4.0.0.0/8 in its routing table because Router 1.1.1.1 listed 4.0.0.0/8 as a stub network in its own router LSA. Router 1.1.1.1 also listed 5.0.0.1/32 as a stub, which is its interface on the point-to-multipoint network. Therefore, Router 2.2.2.2 installs an OSPF route for 5.0.0.1/32 in its routing table.

Router 2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 
O    5.0.0.1/32 [110/64] via 5.0.0.1, 00:09:26, Serial0/1/0
  
Router 1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 
O    5.0.0.2/32 [110/64] via 5.0.0.2, 00:00:49, Serial2/1/0

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 10, 2005
Document ID: 47862